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In SketchUp, you can
•

Create 3D models of buildings, furniture, interiors, landscapes, and more.

•

Customize the SketchUp interface to reflect the way you work.

•

Share 3D models as walkthrough animations, scenes, or printouts, with realistic light
and shadows. You can even print a model on a 3D printer.

•

Import files from other 3D modeling programs or tools, or export your SketchUp file for
use with other popular modeling and image-editing software.
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Getting Started in SketchUp
The first time you use SketchUp, you need to sign in to activate your trial or subscription. After
you're signed in, the Welcome to SketchUp dialog box appears, as shown here. This dialog box
is your starting point for creating a model and appears every time you start SketchUp (unless
you choose to turn it off in the SketchUp Preferences dialog box).

Welcome to SketchUp dialog box

In the Welcome to SketchUp dialog box, you can choose a template for your model, set the
default template, open recent files, browse for an existing file, or license a copy of SketchUp
Pro (see Understanding Your License for details), and learn more about SketchUp.
Tip: If you’re new to SketchUp, this article is a great place to warm up your 3D modeling skills.
You find an overview of how to select a template, move around the SketchUp interface, create
a basic model, and save your model.

Selecting a template
Every model in SketchUp is based on a template, which has predefined settings for your model’s
background and units of measurement. When you begin a new model, selecting a template
with the correct unit of measurement makes modeling easier.
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Here’s how to select a template in the Welcome to SketchUp dialog box:
1. On the Files panel, which is selected by default in the left-hand sidebar, select one of
the templates shown (such as Architectural Inches or Woodworking Inches).
2. (Optional) If you don’t see the template you want, select More Templates in the upper
right. You see additional options, as shown in the following figure. The bold text
describes the type of work for which the preset was created. The units appear below
the style name. After you select a template, the modeling window appears with your
selected template applied.

Tip: While you’re working in SketchUp, you can access the Welcome to SketchUp window
anytime. On the menu bar, simply select Help > Welcome to SketchUp. After you become
comfortable creating 3D models in SketchUp, you can create a custom template that reflects
your preferences.

Exploring the SketchUp interface
When SketchUp opens, ready for you to start creating a 3D model, you see a screen that
includes the following:
•
•
•
•
•
•
•

Title bar
Menu bar
Getting Started toolbar
Drawing area
Status bar
Measurements box
Default panels

SketchUp Help Pages – version 19.

Page 20/567

SketchUp interface in Windows

Title bar
The title bar contains the standard window controls (close, minimize, and maximize) and the
name of the currently open file. When you start SketchUp, the name of the currently open file
is Untitled, indicating that you have not yet saved your work.

Menu bar
The majority of SketchUp tools, commands, and settings are available within the menus on the
menu bar. The menus are: SketchUp (Mac only), File, Edit, View, Camera, Draw, Tools,
Window, and Help.

Getting Started toolbar
When you begin using SketchUp, the Getting Started toolbar is the one you see by default. It
contains the basic tools you need to begin creating 3D models.
To display additional toolbars, select View > Toolbars. In the Toolbars dialog box that opens,
select the toolbars you want to see and click Close. In macOS, you can display tool palettes by
selecting View > Tool Palettes. (Learn more about the toolbars and how to customize them in
the Customizing SketchUp section of the Help Center.)
Tip: This article introduces you to a few basic tools. As you continue learning how to create 3D
models in SketchUp, the Instructor can teach you (or remind you) how to use each tool. See
Learning how to use SketchUp tools for details.
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Drawing area
The drawing area is where you create your model. The 3D space of the drawing area is identified
visually by the drawing axes, which provide a sense of direction in 3D space while you work.
The drawing area might also contain a simple model of a person to give you a sense of 3D
space.

Status bar
When you’re getting started with SketchUp, the two important elements on the status bar are
the tips in the middle and the Measurements box on the right:
•

Tips for using the tools: In the middle area of the status bar, click the question mark
icon to display the Instructor window, which offers basic information about using
whatever tool you select in the toolbar. The middle area also displays a brief sentence
about using the selected tool. This area is helpful when you’re not sure how a tool works.

•

Measurements box: This box is a critical tool for creating accurate models. The box
displays dimensions as you draw. You can also use this box to manipulate currently
selected entities (such as creating a line that’s a specific length) or to create evenly
spaced copies of entities (such as columns, fencing, or housing blocks in a postindustrial dystopia).

Status bar

Tip: Did the Measurements box disappear? The most likely reason is that your SketchUp window
size is larger than your available screen viewing area. To recover your view of the
Measurements box, click the Maximize button in the title bar.
If you’re a Windows user and enable the Auto-Hide the taskbar option, the Measurements box
can slip behind the taskbar when you have the taskbar displayed. In this case, the
Measurements box reappears when you’re done using the taskbar.
Note: On the left side of the status bar, you find buttons to geolocate and claim credit. These
options help you work with advanced SketchUp features that are beyond the scope of this
article.

Default panels
On the right side of the screen, you see a tray of panels, including the Instructor, Materials,
Styles, and so on. The Default Tray appears when you open SketchUp, but you can close the
Default Tray of panels by click the Close button in the upper right. Toggle the tray so it's visible
or hidden via the Window > Default Tray submenu.

Learning how to use SketchUp tools
As you use SketchUp, the Instructor and the status bar give you pointers on using each tool.
The Instructor teaches you how to use the currently selected tool. To turn on the Instructor,
shown here, select Window > Instructor, which you find in the Default Tray. Here’s what the
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Instructor has to offer:
•
•
•
•
•

An animation that shows basic use of the selected tool
A description of what the tool does
Steps for using the tool, which correspond to the animation
Modifier keys that enable the tool perform additional functions
A link to Help Center articles about advanced functions of the tool

Instructor window

If the Instructor offers more detail that you need, remember that the status bar also offers tips
on using the selected tool. See the Status bar section earlier in this article for details.

Viewing the SketchUp Quick Reference Card
The Quick Reference Card is an easy-to-print guide to all the SketchUp tools and their modifier
keys.
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Keep it handy as you start using SketchUp and you’ll learn to model quickly and efficiently.
Here's what the Quick Reference card looks like:

To download a PDF of the Quick Reference card, click the link that corresponds to your operating
system:
•
•

Apple macOS
Microsoft Windows

Note: Looking for the LayOut quick reference cards? Click here1.

Creating your first 3D model in SketchUp
If you’ve never created a 3D model in SketchUp (or any other modeling program), the following
steps offer a quick overview the basics:
1. Select the person, context-click2 the selection, and select Erase in the context menu
1
2

https://help.sketchup.com/en/layout/introducing-layout-interface#qrc
aka right click (Windows).
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that appears.
2. In the Getting Started toolbar, select the Rectangle tool (

).

3. On the ground plane, in the space between the red and green axis, click the Rectangle
tool cursor (
). Then move your cursor to the right and click again. A rectangle
appears on the ground, as shown here.

A rectangle drawn on the groundplane

4. On the Getting Started toolbar, select the Push/Pull tool (
), and place the
Push/Pull cursor over the rectangle you just created, as shown in the following figure.
5. Click and drag your rectangle up into a 3D shape. Keep an eye on the Measurements
box and release the cursor when your shape is about 5 feet tall.
(cont’d next page)
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Place the Push/Pull cursor over the rectangle.

6. Without clicking or selecting anything, simply type 6’ and press Enter. Notice how the
height of your shape changed to exactly 6 feet tall, and the value you entered appears
in the Measurements box.
7. In the Getting Started toolbar, select the Orbit tool (
). Place the Orbit cursor above
your shape. Then click and hold while you move the mouse down. Notice how the view
of your shape changes, as shown in the following figure. Practice clicking and dragging
with the Orbit tool as much as you like. It’s a pretty fun tool!
(cont’d next page)
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The Orbit tool changes the view of your 3D model.

8. In the Getting Started toolbar, click the Zoom Extents button (
). If you orbit
around until you lose track of where you are in your model, the Zoom Extents button is
a handy way to reorient yourself.
9. If you have a scroll-wheel mouse, scroll down to zoom out a bit. Working in SketchUp
is much easier with a scroll-wheel mouse. However, if your mouse lacks a scroll wheel,
click the Zoom tool (

) and you can zoom in and out that way, too.

Tip: No matter what tool is selected, holding down the scroll wheel activates the Orbit tool until
you release the scroll wheel.
10.

In the Getting Started toolbar, click the Paint Bucket tool (

).

11.

In the Materials panel that appears, select Colors from the drop-down menu, as
shown here. Then select a color from the options that appear on the Select tab.
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Select Colors in the Materials panel.

12.

Click one side of your model with the Paint Bucket cursor to apply your selected color.
Experiment a bit with the different options in the drop-down menu if you like. For example,
select Landscaping, Fencing, and Vegetation from the drop-down menu and apply pebbles
to your model. Select Tile from the drop-down menu and apply a tile pattern that you like.
Orbit around and apply different materials to each side, as shown here.

Apply materials to a 3D model.

13.

Close the Materials panel and select Window > Styles, which appear in the Default
Tray.

SketchUp Help Pages – version 19.

14.

Page 28/567

From the drop-down menu, select Sketchy Edges and then select a style option. In
the following figure, Marker Wide is selected. Notice that the style completely
overrides all the materials and colors applied. To see them again, select In Model
from the drop-down menu and then select the Simple Style option.

The Marker Wide style is selected.

Saving and reopening a model
To save your model, follow these steps:
1.

On the menu bar, select File > Save. If this is the first time you’re saving a model,
the Save As dialog box appears, as shown here. To save an already saved model with
a new name, select File > Save As.

(cont’d next page)
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Save As dialog box

2.

Choose where you’d like to save your model.

3.

In the File Name box, type a name for your model. SketchUp model files end with the
.skp file extension.

4.

(Optional) If you’d like your model to be compatible with earlier versions of SketchUp,
select a version from the Save As Type drop-down list.

5.

Click the Save button.

Tip: After you save a model, you can reopen it later and continue working on it. (Simply doubleclick the file wherever you’ve saved it, or in SketchUp, select File > Open.) If you’re not sure
where a file is saved, hover over the file in the Welcome to SketchUp window, and you can see
the path to the file, as shown in the following figure. Or if your model is complete, you can
show it off by exporting it as a graphic or creating a virtual walk-through.
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Filepath that appears over a recent model in Welcome to SketchUp window

Backing up a SketchUp file or restoring an Auto-save file
SketchUp creates a backup file the second time you successfully save your SketchUp file and
any subsequent saves. This file is an exact copy of the previously saved version of the file. The
backup file uses the naming convention FILENAME.skb on Windows and FILENAME~.skp on
macOS, and it's located in the same folder as the original file.
If SketchUp crashes while you're working on a model, the recovered file is not
deleted.
By default, SketchUp automatically saves your files every five minutes while you're actively
working. You can recover your work from the point the last automatic save was performed by
opening the recovered file. To find and open a recovered file, open the Welcome to SketchUp
window, select the Files tab, and select the file you want to recover from the Recent list.
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Getting Started Self-Paced Tutorials
Self-paced tutorials are SketchUp files that are designed to offer a hands-on, interactive
experience to further develop your SketchUp skills. These tutorials are all stored in the 3D
Warehouse and are free to download at any time.
Getting Started
These tutorials are designed to teach basic navigation and drawing techniques with SketchUp.
Click on the image below to get started with an example tutorial:

You can also view our tutorial videos on the SketchUp YouTube Channel for more visual-based
learning.
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Managing Units of Measurement
For most SketchUp 3D models, the unit of measurement is critical to the success of your final
project. For example, buildings are typically modeled in feet or meters; woodworking projects
in inches or centimeters.
This article introduces the ways you can control units of measurement in your sketchUp model
and points you to other relevant articles for more detailed information.
Table of Contents
1. Understand templates
2. Set units and precision in the Model Info window
3. Discover other measurement tools

Understand SketchUp templates
When you start a new 3D modeling project in SketchUp, you select a template. The template
determines the unit of measurement for your model as a whole. You can see and change the
unit of measurement for your template in the Model Info window.
In Getting Started in SketchUp, you learn the basics of selecting a template. If you’re interested
in creating a custom template with your preferred unit settings, see Setting Up Templates.

Set units and precision in the Model Info window
After you start creating a 3D model in SketchUp, you can view and change the units of
measurement for the model as a whole via the Model Info window. Follow these steps:
1. With your model open in SketchUp, select Window > Model Info.
2. In the sidebar on the left, select Units. The Units panel appears.
3. From the Format drop-down list, select your desired unit format: Architectural, Decimal,
Engineering, or Fractional. Depending on the format you select, different options on the
Units panel are available, as explained in the following list.
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Here’s what the Units options in the Model Info window do:
•
•

•

•
•
•
•
•

Format: Choose your desired format. The options are Architectural, Decimal,
Engineering, or Fractional.
Length, Area, and Volume: Select your preferred unit for each type of measurement
from the drop-down lists. When you select the Decimal format, you’re able to set
different decimal units of measurement for length, area, and volume. For example, you
might want length measured in centimeters but area and volume measured in meters.
In this example, you could draw and measure line lengths in centimeters by default, but
an entity’s area or volume would appear in meters.
Display precision: For each format, you can select how precise you want
measurements to be. For example, the Architectural option lets you fine-tune
measurements up to 1/64 of an inch, and the Engineering option lets you choose up to
six decimal places.
Enable Length Snapping: When this checkbox is selected, your drawing tool will snap
to the closest unit at the level of precision indicated in the text box.
Display Units Format: This option is available when you select the Decimal or
Fractional option. When the checkbox is selected, the unit appears in ToolTips. When
the check box is cleared, only the number appears.
Force Display of 0": This option is available when you select the Architectural format.
When the checkbox is selected, trailing zeros appear in unit measurements (such as 3'
0" instead of 3').
Angle Degrees: Use the drop-down list to select how precise your angles need to be,
up to three decimal places.
Enable Angle Snapping: When this checkbox is selected, angles you draw or measure
will snap to the closest unit based on the level of precision indicated in the text box.

For details about other options in the Model Info window, see Exploring the Model Info dialog
box, which is a section in Setting Up Templates.
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Discover other measurement tools
As you draw with the SketchUp 3D modeling tools, you’ll find lots of ways to model precisely,
check measurements, and label dimensions. The following tools and features are especially
useful:
•

Specify a unit in the Measurements box: The box works differently depending on
which tool you’re using. When you draw an entity, like a line or circle, the Measurements
box lets you specify the precise dimensions and unit. To use a unit other than the default
unit (specified on the Units panel in the Model Info dialog box), you can type a unit
along with the measurement. The Measurements box also helps you position entities
precisely, with the Move tool for example. This introduction to the SketchUp interface is
helpful for beginners.
See the articles about accomplishing specific tasks in Drawing Lines, Shapes, and 3D
Objects for details about how the Measurement box works with a specific tool or check
out this Measurements box quick reference.

•

See an entity’s measurement in the Entity Info panel: Want to know how long a
line is? Need the area of a face or the volume of a solid? Simply select the entity and
open the Entity Info panel, which displays a relevant measurement for the selected
entity.

•

Mark measurements with dimensions: Dimensions are dynamic measurement
labels that update automatically as you create a model. These details about marking
dimensions dynamically explain how SketchUp dimensions work.

•

Understand the Tape Measure and Protractor tools: These tools can help
you model precisely. The Tape Measure can also scale your model.
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Creating a 3D Model
Before you can model your great idea, you need to know the basics of 3D modeling. From
there, you can add modeling techniques to your skillset.
Are you new to creating 3D models? The following Help Center articles help you warm up
your modeling muscles:
•
•

The Getting Started article explains how to select a template, navigate the SketchUp
interface, create your very first 3D model, and save your work.
The articles about drawing and viewing models explain concepts essential to modeling
successfully in the third dimension.

Tip: Drawing in 3D is different from drawing in 2D. If you’re a beginner, the articles about
getting started, drawing, and viewing a 3D model help you transition into a 3D mindset.
Is your model naked? No, this isn’t a figure-drawing art class with human models. SketchUp
nevertheless supports visual creativity. Make your 3D model look realistic (or extraordinary!)
by adding color, materials (such as brick or tile), textures, photos, and more.
Would you like a few details done for you? We all need a helping hand — especially if your
hand is cramped after drawing a detailed 3D model. With SketchUp, you don’t have to reinvent
the wheel — or the IKEA furniture, windows, doors, kitchen cabinets, or myriad other items
that are already available as components or dynamic components. (You can also develop your
own components.) Similarly, SketchUp’s style presets enable you to apply attractive color
schemes and line styles with one click.
Have you created a monster? Organize complex geometry with groups or layers. Keep track
of what appears where by using the Outliner.
Is your model lost in space? SketchUp’s geolocation feature enables you to place your
model anywhere on Earth. If your model needs to reflect specific terrain, you can add terrain
to your model, too.
Or is your model destined for the big screen? Test out your ideas for a production set
by placing movie cameras in models of production sets.
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Drawing Lines, Shapes, and 3D Objects
No matter how simple or complex your model, every model in SketchUp is really just edges
and faces. The drawing tools enable you to create those edges and faces.
If you’re a beginner to drawing in SketchUp, start simple:
•
•
•
•

Learn how drawing lines and shapes in 3D is different from drawing in 2D. Make sure
you understand a few drawing basics and concepts, like how to align lines and shapes
to the correct drawing axis. (Hint: The SketchUp inference engine can help.)
Explore the shape tools and handy selection techniques.
Discover all the ways you can push/pull your geometry into 3D.
Draw outside the box with arcs.

If you’re eager to draw detail and complex 3D models, these Help Center articles can
help you expand your drawing skills:
•
•
•
•

To make curved faces look more polished, check out how to soften round edges so they
look smooth.
To move beyond basic shapes, you need to know how to divide and split faces, move
entities, copy entities, erase lines and faces, flip and rotate entities, scale entities,
and extrude shapes along a path with the Follow Me tool.
You can also model complex shapes with the Solid Tools, which enable you to modify
3D shapes by choosing how one shape adds to or subtracts from a second shape.
Give your model a polished look with text, a custom background, or fog.

If you need to draw precisely, discover how to offset a line and measure angles and
distances.
If examples help you understand how to apply and combine drawing
techniques, check out the articles on creating specific shapes, such as a cone or sphere, and
objects, such as a chair or building footprint.
Before you know it, you’ll be modeling your house, that custom dining room table you’ve been
wanting to make, or the modern storefront that you envision (where others see only a
dilapidated parking lot).
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Introducing Drawing Basics and Concepts
Drawing a model in 3D is different from drawing an image in 2D. This introduction to drawing
basics and concepts explains a few ways you can create edges and faces (the basic entities of
any SketchUp model). You also discover how the SketchUp inference engine helps you place
those lines and faces on your desired axis.
Tip: The basic shape tools use a thin solid line. To create dashed lines, see Applying Dashed
Lines to Layers.
Table of Contents
1.
2.
3.
4.
5.
6.
7.
8.
9.

Drawing a line
Creating a face
Dividing faces
Opening 3D shapes by erasing edges
Healing deleted faces
Finding and locking an inference
Knowing your inference types
Locking inferences with the keyboard
Ensuring edges are aligned to axes

Drawing a line
Use the Line tool to draw edges (also called line entities). Edges form the structural foundation
of all models. Here’s how to draw a line:
1. Select the Line tool (
) on the toolbar (or press the L key). The cursor changes to
a pencil.
2. Click to set the starting point of your line. If you click the wrong place, press the Esc key
to start over. As you move your cursor around the drawing area, notice the following:
o A line follows your cursor.
o The line length is displayed dynamically in the Measurements box. (The
Measurements box uses the units specified in your template.)
o The line that’s following your cursor turns red, green, or blue whenever the line
is parallel with the red, green, or blue axis, respectively. If you hover for a
moment, a ScreenTip appears, like the On Blue Axis tip shown in the figure.
There is no ghost in your machine; that’s the SketchUp inference engine, which
you learn more about later in this article.
3. Click to set the line’s end point. This end point can also be the starting point of another line.
Press Esc or select a different tool when you’re done drawing lines. After you set the end
point, you can press Ctrl+Z (Microsoft Windows) or Command+Z (Apple macOS) to undo
your line and start over.
(cont’d next page)
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4. (Optional) To make your line a precise length, type a value and press Enter (Microsoft
Windows) or Return (Apple macOS). You can repeat this process as many times as you
like until you draw a new line or select another tool. If you don’t specify a unit, SketchUp
uses the unit specified in your template. However, you can type any imperial or metric
unit for your line. So you can type 3mm or 5’2” for example. Your value appears in the
Measurements box as you type.
Note: The Measurements box also accepts 3D coordinates for lines:
•
An absolute coordinate, such as [3’, 5’, 7’], places the end of the line relative to the
current axes. Square brackets indicate an absolute coordinate.
•
A relative coordinate, such as <1.5m, 4m, 2.75m>, places the end of the line
relative to the starting point of your line. Angle brackets indicate a relative coordinate.
You can edit the length of a line as long as it doesn’t bound a face. Here’s how to edit a line:
1. Select the Move tool (
).
2. Hover the Move tool cursor over one of the line’s end points.
3. Click and drag the end point to change the line’s length.
Tip: You can also adjust the length in the Entity Info dialog box. Context-click the line, and
choose Entity Info from the menu that appears. In the Length box, type a new line length.

Creating a face
When you join several lines into a shape, they form a face.
Not a funny face, or a scary clown face, or even a cute puppy face. By default, faces are plain,
but super important: They’re the other half of the duo, edges and faces, which enable every
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SketchUp model ever made to exist.
Tip: By default, SketchUp adds shading to some faces, as shown here, and the faces are
opaque, so you know your model has an actual wall, floor, or whatever your face is supposed
to represent in your 3D model. (However, SketchUp does include a view that enables you to
see through walls, just like Superman. See Viewing a Model for details.)

The shape tools — Rectangle, Circle, and Polygon — also create faces. (See Drawing Basic
Shapes for more about those tools.)

Dividing faces
When you draw a line (or a curve) on an existing face, you split the face.
Tip: This concept is important because, after you split a face, you can use the Push/Pull tool
to push or pull one part of the face while the other part stays put, as shown here. See Pushing
and Pulling Shapes into 3D for details about the Push/Pull tool.

Opening 3D shapes by erasing edges and faces
You can erase an edge or face to create an opening in a shape. To see how erasing an edge
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) in the toolbar or press the E key, and

Clicking an edge erases the edge and any face that touched that edge. As Billy
Idol almost sang, you can have lines without a face. However, a face must be completely
bound by edges.
Context-clicking a face and choosing Erase deletes only the face.

In the figure, you see the original cube and how erasing an edge or face changes the cube.

Tip: If you want to hide a line instead of erasing it, hold down the Shift key as you click the
line with the Eraser. Or context-click the line and select Hide.

Healing deleted faces
If you accidentally delete a face, here’s how to bring it back:
•
•

If you haven’t made any other changes that you’d like to keep, simply select Edit >
Undo from the menu bar. Or press the keyboard shortcut for Undo, Ctrl+Z (Microsoft
Windows) or Command+Z (Apple macOS).
Redraw the line that caused the faces to disappear, and SketchUp will re-create the
faces.

Finding and locking an inference
SketchUp has an inference engine that helps you work in 3D space. For example, when the
Line tool cursor is hovering over the midpoint of another line, the inference engine tells you by
displaying a light blue dot and ScreenTip that says, “Midpoint,” as shown here. Every inference
has its own color and ScreenTip. (See Knowing your inference types for a full list.)
(cont’d next page)
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The inference engine can also help you find geometric relationships between lines. For example,
it tells you when a line you’re drawing is perpendicular to another line. In the following figure,
notice that a colored dot also appears at the start point of the line, giving you a few bits of
information all at once.
Warning: Pay close attention to the inference engine and orbit occasionally to check your
drawing from different viewpoints. In the following figure, the lines might appear to be on the
red and green plane until you orbit to a different view. To avoid this common pitfall, SketchUp
helps by turning your drawing direction or drawing plane red, green, or blue when you're
creating edges or planes parallel to those axes (or magenta if you're parallel/perpendicular to
an edge or face in your model).
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Tip: At times, the inference you need may not come up immediately or SketchUp might choose
alignments with the wrong geometry. In these cases, you can encourage an inference, or
increase the chances of a particular alignment by pausing your mouse cursor over the location
that you want SketchUp to infer from. When the visual cue appears, SketchUp will briefly
prioritize that alignment as you continue drawing.

Knowing your inference types
SketchUp displays several types of inferences: point, linear, and shape. SketchUp often
combines inferences together to form a complex inference. Also, components and dynamic
components have their own inference types.
A point inference is based on the exact point of your cursor in your model. The following table
lists the point inference types.
Point Inference
Type

What It Means

The point at the intersection of the
three drawing axes

Origin point

Component
Point

What It Looks Like

Origin

The axis origin point within a group or
component
and
the
group
or
component's default insertion point

Endpoint

Midpoint

Intersection

Point where a line intersects another
line or face

On Face

A point that lies on a face
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A point that lies on an edge

Center

Guide Point

A guide point

On Line

A point along a guide line

On Section

Point where a drawing tool creates an
edge on a section plane

Note: All these point inference types are magenta in color when the geometry is inside a group
or component.
A linear inference snaps along a line or direction in space. In addition to a ScreenTip, a linear
inference sometimes displays a temporary dotted line while you draw.
Linear Inference
Type

What It Looks Like

What It Means

On Red Axis

Linear alignment to the red drawing
axis (Click and drag as you draw to
see the inference.)

On Green Axis

Linear alignment to green drawing
axis (Click and drag as you draw.)

On Blue Axis

Linear alignment to the blue drawing
axis (Click and drag as you draw.)

From Point

Linear alignment from a point; the
dotted line’s color corresponds to
the axis direction
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Parallel

Parallel alignment to an edge

Perpendicular

Perpendicular alignment to an edge

Tangent at Vertex

Arc whose vertex is tangent to a
previously drawn arc's vertex

Shape inferences help you pinpoint the moment when a rectangle becomes a square, for
example. The following table lists all the shape inferences.
Tip: If your drawing needs to follow specific proportions, shape inferences are a huge help,
because shapes in 3D perspective don’t look the same as they do in 2D.
Shape Inference Type

What It Looks Like

What It Means

Square

A rectangle whose sides are all
the same size

Golden Section

A rectangle whose properties
match the Golden Ratio as found
in mathematics and the arts

Half Circle, Quarter
Three-Quarter Circle

Circle,

or

An arc that is exactly one half of
a circle, one quarter circle, or
three-quarters
of
a
circle,
respectively.

Note: All inferences apply to geometry inside component entities or group entities. Group
and component inference indicators are the same shape, but are magenta color. Group and
component ScreenTips also indicate that the inference is in a group or component entity by
appending the phrase “in group” or “in component” to the end of an inference ScreenTip.
See Adding Premade Components and Dynamic Components for information about
components.

Locking inferences with a keyboard
By locking inferences, you can confidently draw along the direction you intend to draw. Another
reason to lock an inference is to maintain one drawing direction while you reference geometry
from another part of the model. That’s a more advanced move, but very helpful. The easiest
way to lock an inference to the default axes directions is to use the arrow keys:
Key
↑
←
→

What it looks like
Locks the drawing direction to the Blue axis
Locks the drawing direction to the Green axis
Locks the drawing direction to the Red axis. A good way to remember left from right is
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to say “Right locks Red.”
↓
Shift

Locks the drawing direction or drawing plane to the active drawing direction/plane. So
if you’re drawing along the Blue axes and hold down Shift, the Blue inference will lock.

Ensuring edges are aligned to axes
To ensure your edges align to axes, you may find it helpful to change the cursor to the axes
colors. Or if you need to check the alignment of existing geometry, change your edges to the
axes colors.
To change your cursor to axes colors, follow these steps:
•
•

Select the Drawing item on the left.
In the Miscellaneous area of the
hairs checkbox.

Drawing

panel,

select

the Display

cross

To make the edges in your model reflect the axis color to which it is aligned, follow these steps:
1.
2.
3.
4.
5.

Select Window > Styles.
In the Styles dialog box, select In Model from the drop-down list of styles libraries.
Click the Edit tab.
Click the Edge Settings icon, shown in the figure.
From the Color drop-down list, select By axis. The colors of the edges in your model
change to reflect their alignment to the axes (unless an edge isn’t aligned to an axis,
and then the edge color does not change). The following figure shows which edges are
(and are not) aligned to the three axes.

(cont’d next page)
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Drawing Basic Shapes
Many models start with basic shapes. In SketchUp, the shape tools help you draw rectangles,
circles, and polygons. You find these tools on the Getting Started toolbar, the Drawing toolbar,
and the Large Tool Set toolbar.
Table of Contents
1.
2.
3.
4.
5.

Drawing a rectangle or square
Drawing a rotated rectangle
Drawing a circle or ellipse
Drawing a polygon
Editing shapes

Drawing a rectangle or square
In SketchUp, you can draw rectangles pretty much anywhere:
•
•
•
•
•

On the ground plane
On a vertical plane
On existing faces
Separate from existing geometry (aligned to an axes plane)
Inferenced from existing geometry
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To draw a rectangle with the Rectangle tool, follow these steps:
1. Select the Rectangle tool (
to a pencil with a rectangle.

) from the toolbar or press the R key. The cursor changes

Tip: To start over at any point during these steps, press Esc.
2. Move the cursor diagonally to find the desired size and shape for your rectangle. To
draw the rectangle with precise dimensions, use the Measurements box, which at this
point displays your rectangle’s dimensions as you move the cursor. To help you place
the rectangle in relation to the drawing axes or other geometry, SketchUp’s inference
engine displays on-screen cues. When the inference you need appears, move to Step
4. Both the Measurements box and the Rectangle tool inferences are explained a little
later in this section.

As you draw a rectangle, the Measurements box helps you model precisely as follows:
•

•

•

Set the length and width. Type a length value, a comma, a width value, and then
press Enter. For example, type 8‘,20’ and press Enter. If you type only a number or
numbers, SketchUp uses the current document units setting. You can also override the
document units setting by specifying imperial (such as 1’6") or metric (such
as 3.652m) units.
Specify only a length or width. If you enter a value and a comma (3‘,), the new
value is applied to the first dimension, and the second dimension doesn’t change.
Similarly, if you type a comma and then a value (,3’), only the second dimension
changes.
Change the rectangle’s position with negative numbers. If you enter a negative
value (–24, –24), SketchUp applies that value in a direction opposite to the one that
you indicated while drawing.

Tip: You don’t need to click in the Measurements box before you type a value. As you draw,
the Measurements box is waiting for you to type precise measurements if you choose to do so.
Also, until you select another tool or draw another rectangle, you can use the Measurements
box to change a rectangle’s dimensions as many times as you like.
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Note: If you're using a non-English keyboard, use a comma to indicate the decimal place and
a semi-colon to separate the dimensions. For example, you might enter two sides of a rectangle
as: 7,6m;4,3m
As you move your cursor with the Rectangle tool selected, the SketchUp inference
engine displays the following cues:
•
•

Square: When the rectangle’s proportions are a perfect square, you see blue dots and
the Square ScreenTip appear. See Callout 1.
Golden section: A golden section is a rectangle in which the ratio of the longer side to
the shorter side is a golden ratio. When a rectangle is a golden section, blue dots and
the Golden Section Screen tip appear. See Callout 2.

In this video3, you can see these features of the Rectangle tool in action.

Drawing a rotated rectangle
The Rotated Rectangle Tool can come in handy when you need to draw a rectangle whose face
is at an angle to SketchUp's default red, green, or blue axes or to other geometry.
Like the Rectangle tool, the Rotated Rectangle tool enables you to create precise rectangles
and squares and displays inferences to help you as you draw. However, when you create a
rectangle with the Rotated Rectangle tool, you position the rectangle at an angle as well. The
following figure is an example of a rectangle created with the Rotated Rectangle tool.

3

https://youtu.be/WtF8YtX-Tf8
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To create a rotated rectangle, follow these steps:
1. On the toolbar, from the Shape Tools menu, select the Rotated Rectangle tool
(
). Or select Draw > Shapes > Rotated Rectangle from the menu bar.
2. (Optional) Press an arrow key to set the plane for your rotated rectangle, per the table
that appears earlier in this article. For example, press the left arrow key to constrain
the plane of your rotated rectangle to the green plane.
3. Click once to set the first corner of your rectangle.
4. Create the first edge of your rotated rectangle. You can do this in two ways:
o Type a precise measurement and press Enter.
o Or move the cursor where you want to place the second endpoint of this edge,
using the SketchUp inference engine to position the endpoint in relation to the
axes or other geometry, as shown in the following figure, and then click.
Tip: You can use a few modifier keys as you complete this step. Hold down the Shift key to
constrain the first edge to its current direction. The Alt (Windows) or Command (Apple
macOS) key locks the protractor plane. Or the arrow keys can again help you align the first
edge to an axis. Simply press the arrow key that corresponds your desired alignment, as
explained earlier in this section. For example, press the right arrow key to constrain the first
edge so it's aligned with the red axis.
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5. At this point, you set the width and angle of your rectangle. You can set these values in
a few different ways:
o Move around the protractor to set the angle, and move your cursor away from
the center of the protractor to set the width, as shown in the following figure. To
constrain the angle, hold down the Shift key. Click to finish creating the rotated
rectangle.
Tip: Press the Alt (Windows) or Command (Apple macOS) key to set the protractor baseline
at the cursor's current position and then move the cursor to measure the angle from the
baseline you set. This method is helpful if you want to measure the angle from a point other
than the baseline set in Step 3. A dashed line appears so you can see the new baseline.

Drawing a circle or ellipse
Before you draw a circle, it’s helpful to understand how SketchUp creates circle entities:
•
•
•

Circle entities have a radius and connect multiple line segments.
These segments act as a single line in that they can define the edge of a face and divide
a face. Additionally, selecting one segment selects the entire circle entity.
SketchUp’s inference engine still sees the segments in the circle. So, if you hover your
mouse around the circumference of the circle entity, you’ll see endpoint and midpoint
inferences.

To draw a circle, follow these steps:
1. On the toolbar, select the Circle tool (
) from the drop-down menu next to the
Rectangle tool. Or press the C key. The cursor changes to a pencil with a circle, and the
Measurements box indicates the default number of sides: 24, as shown in the figure. To
change the number of sides, you can type a value now or wait until after you’re done
drawing the circle.

SketchUp Help Pages – version 19.

Page 51/567

2. Move the cursor out from the center point to define the circle’s radius. As you move the
cursor, the radius value is displayed dynamically in the Measurements box. Press Esc at
any point to start over.
3. Click to finish the circle. SketchUp creates a circle-shaped face, as shown in the figure.

4. (Optional) Until you select a new tool or draw a new circle, you can use the
Measurements box to change the circle’s radius or the number of sides as follows:
o

To change the radius: Type a number and a unit (if desired), such
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as 6”, 8’, 34cm, or 7m. Then press Enter or Return.
Tip: The Entity Info dialog box offers a handy way to edit the sides and radius values anytime.
See Editing shapes later in this article for details.
To draw an ellipse or oval, follow these steps:
1. Draw a circle with the Circle tool.
2. Select the Scale tool (
).
3. Click the circle. A bounding box with eight green grips is displayed around the circle.
4. Click one of the middle grips (not one of the corner grips) and move the mouse to pull
the circle into an ellipse, as shown here.
5. Click again when you’re done scaling the circle.

Drawing a polygon
You can create polygon entities with the Polygon tool. (No surprise there.) However, here are
a few facts that you may not know about polygons, but that are handy to know as you draw
them:
•
•
•
•

In SketchUp, a polygon has a radius and 3 or more sides. So the size of your polygon
is measured from a center point, and the number of sides determines the type of
polygon you draw. A pentagon as 5 sides; an octagon has 8 sides.
Polygon entities act as a single line in that they can define the edge of a face and also
divide a face. Selecting one side of the polygon selects the entire polygon.
The SketchUp inference engine interprets each side of a polygon as a segment. As you
hover your cursor over a polygon, you see endpoint, midpoint, and from point
inferences.
You can draw polygons on faces or separate from existing geometry.
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Follow these steps to draw a polygon:
1. Select the Polygon tool (
) on the toolbar. The cursor changes to a pencil with a
polygon. The Measurements box indicates the current number of sides. To change the
number of sides in your polygon, you can type a number value now or wait until after
you’re done drawing.
2. Move the cursor out from the center point to define the radius of your polygon. As you
move the cursor, the radius value is displayed dynamically in the Measurements box.
To specify the radius, type a value and press Enter. You can also press Esc to start
over.
3. Click a second time to finish the polygon. Here, you see a 5-sided polygon.

4. (Optional) Until you select a new tool or draw a new polygon, you can use the
Measurements box to change the radius or the number of sides as follows:
o

To change the radius: Type a number and a unit (if desired), such
as 6”, 8’, 34cm, or 7m. Then press Enter or Return.

Tip: Although the Polygon tool works similarly to the Circle tool, the difference between the
tools becomes apparent when you push/pull a circle or polygon into a 3D shape. The circle’s
edges look smooth, but a polygon’s edges show distinct sides, as shown here.
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In this live-action video4, you can see the Circle and Polygon tools demonstrate all their stunts.

Editing shapes
The Entity Info dialog box enables you to change a circle or polygon’s radius or sides anytime
after you create the shape. Here’s how:
1. Context-click an edge (not the face) of a circle or polygon that you want to edit.
2. Select Entity Info from the context menu that appears, as shown here.

3. In the Entity Info panel, click in the Radius or Segments box, change the value, and
4

https://youtu.be/RHnid50KLIA
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press Enter (Microsoft Windows) or Return (Mac). After you press Enter or Return,
your shape immediately reflects your changes.
SketchUp doesn’t enable you to modify the width or length of a rectangle at anytime. If you’ve
already selected another tool or drawn additional rectangles, you need to erase the rectangle
you want to change and redraw it. See Drawing a rectangle for details. Or resize the rectangle
with the Scale tool if you don't need to enter precise dimensions.
Of course, you can do much more than simply change a shape’s size. You can turn a 2D shape
into a 3D shape with the Push/Pull tool. You can distort shapes with the Move tool or scale all
or part of your model.
Tip: The basic shape tools use a thin solid line. To create dashed lines, see Applying Dashed
Lines to Layers.
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Selecting Geometry
The Select tool (
) specifies what entities you want to modify with SketchUp’s other tools or
commands. If you want to change the length of a line, first select the line. If you want to scale
a box, first select that box. If you want to move a line and a box, you start by selecting both,
creating what’s called a selection set.
Here’s where you find the Select tool in SketchUp:
•
•
•

The Getting Started toolbar (shown here), the Large Tool Set toolbar, and the Principal
toolbar (Microsoft Windows)
The Tool Palette (Apple macOS)
The Tools menu

Tip: The Select tool is so important to 3D modeling in SketchUp that the Select tool also has
an easy keyboard shortcut: Just the press the Spacebar, and the Select tool is activated.
Table of Contents
1.
2.
3.
4.

Selecting a single entity
Selecting multiple entities
Adding and subtracting from a selection
Inverting a selection

Selecting a single entity
To select a single entity:
1. Activate the Select tool (
). The cursor changes to an arrow.
2. Click an entity. Whatever you select (edge, face, or component for example) is
highlighted, like the sofa cushion shown here.
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If you don’t select the right thing the first time, just try again. If you don’t want anything to be
selected, click any empty space in the drawing window.

Selecting multiple entities
When you need to select more than one thing, SketchUp offers a few different selection options.
Watch the video to see how these options work and learn tricks for making complicated
selections quickly and easily. Or keep reading about ways to select multiple entities.
Tip: No matter what tool is active, you can select Edit > Select All from the menu bar, or
press Ctrl+A (Microsoft Windows) or Command+A (Apple macOS) to select everything in
your
model.
To make sure nothing is selected, select Edit > Deselect All, press Ctrl+T (Microsoft
Windows) or Shift+Command+A (Apple macOS), or click any empty space in the drawing
area.
When the Select tool is active, you can select multiple entities in any of the following ways:
•

Click and drag to make a selection box. With the Select tool active, click and drag
to create a temporary box around the items you want to select. When you release the
mouse button, your items become selected. If you click and drag to the left (a crossing
selection), anything completely or partially inside the box becomes selected. If you click
and drag to the right (a window selection, shown the figure), you select only what’s
completely inside the box. For example, notice how only one red cushion is selected,
even though the second one is partially inside the window selection box.
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Double- or triple-click. Depending on what you click, you can select combinations of
edges and faces. The following table outlines your options.
Do This. . .

. . .To Select This

Double-click a face

The face and all its bounding edges (1)

Double-click an edge

The edge and its connected face (2)

Triple-click an entity

All the connected entities. For example, if you triple-click a
face in a cube, the entire cube is selected. (3)

•

•

Context-click an edge. When you context-click an edge, a context menu appears with
the following options:
Select > Connected Faces selects all the faces connected to the selected
entity.
o Select > All Connected selects all entities connected to the selected entity.
(The result is the same as triple-clicking the entity.)
o Select > All on same Layer selects all the entities on the same layer as the
selected entity. If you your model doesn’t contain any layers, the result is also
the same as triple-clicking.
Context-click a face. When you context-click a face, the context menu has all the
options you see when you context-click an edge, as well as two other options:
o

•

o
o

Select > Bounding Edges selects all the bounding edges of the selected face.
Select > All with same Material selects any entity with the same material as
the selected face. If you want to select all the faces with a brick material or red
paint, for example, and change that material to something else, this method
makes doing so quick and easy.
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Adding and subtracting from a selection set
When you’re selecting multiple entities, it’s easy to grab an entity you didn’t want or to miss
an entity that you need. To add or remove entities from a selection set, make sure the Select
tool is activated; then adjust your selection by using the keyboard modifiers in the following
table. For example, to select both red cushions as shown here, select one and then hold down
the Ctrl key while selecting the other cushion.

Tip: When you activate a modifier key, the Select tool’s cursor displays a plus or minus sign (
) next to the arrow.
To Do This . . .

Press and Hold This Key(s)

While Also . . .

Add to the selection set, one entity at
a time

Ctrl (Microsoft Windows)
Option (Apple macOS)

Clicking
unselected entities

Change an entity’s selection status.
(Select an unselected entity or clear a
selected entity)

Shift

Clicking an entity

Subtract from the selection set

Shift+Ctrl (Microsoft Windows)
or Shift+Option (Apple macOS)

Clicking
entities

or

selected

Tip: If you need a temporary way of quickly reselecting the same group of items, turn your
selection into a group. See Organizing a Model for details about creating a group.

Inverting a selection
Inverting a selection can simplify complicated edits, like removing leaves from a tree. In this
example, you'd select the trunk and branches and then invert the selection to select all the
leaves.
To invert a selection, make the initial selection and then press Ctrl+Shift+I.
Alternately, you can choose Edit > Invert Selection from the menu bar.
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Pushing and Pulling Shapes into 3D
With the Push/Pull tool (
), you can create a 3D shape from a face or cut a 3D shape out of
your model. You can push/pull any type of face, including circular, rectangular, and abstract
faces.
Table of Contents
1. Pulling a 3D shape from face
2. Cutting a 3D shape out of your model
The video shows you all the tricks you can do with the Push/Pull tool. Or read on for detailed
steps that walk you through push/pulling on your models.

Pulling a 3D shape from a face
To pull out a face and thus add volume to your model, follow these steps:
1. Select the Push/Pull tool (
) or press the P key.
2. With the Push/Pull cursor, click the face that you want to expand. The selected face
becomes shaded, as shown in the following figure.
Tip: If you need to push/pull a face that’s difficult to select, try preselecting the face with the
Select tool and then push/pulling the face. If you need to start over, press Esc.

3. Move the cursor so that the selection expands. The Measurements box displays the
depth of the expanded face (also called an extrusion).
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Tip: If you need to pull a face so that it’s parallel with another face, let the SketchUp inference
engine help. Before you pull the face, hover the Push/Pull cursor over the other face, and the
inference engine tells you when the two faces are parallel, as shown in the following figure.

4. Click again to set the size of your extrusion. Until you select something else, you can
enter a precise distance, which appears in the Measurements box as you type. Type a
number and a value, and then press Enter.
Tip: Immediately after you push/pull to add volume to your model, you can double the size of
the extrusion or create a separate but identical extrusion:
• To duplicate the extrusion on a different face, double-click another face.
• To stack an identical extrusion on top of the existing one, Ctrl+double-click (Microsoft
Windows) or Option+double-click (Apple macOS)
Note: When your push/pull creates a curved face, you create a surface entity, or a surface that
looks smooth but is actually made of many smaller faces. See Softening, Smoothing, and Hiding
Geometry for details about surface entities.
Note: If you pull up an entity a small amount (less than an inch (2.54 cm), edges are visible
through the entity. This is a rendering limitation that affects all 3D programs. Your entity must
be an inch or more thick before this effect goes away. If the edges showing through are an
issue, select the edge, context-click it, and choose Hide.

Cutting a 3D shape out of your model
You can also use the Push/Pull tool to cut pieces out of your model. This action is handy in all
sorts of instances, such as making a doorway, creating an angled roof, or cutting out a notch
for a fastener, as shown in the figure.
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Follow these steps to subtract volume with the Push/Pull tool:
1. Select the Push/Pull tool (
) or press the P key.
2. Click the face you want to push, as shown on the left in the following figure.
3. Move the cursor in the direction you want to push. You can push partway into your
model to remove only some of it, as shown on the right in the following figure. If you
want to completely the remove the content, drag until you see a message that says the
offset is limited.
Tip: To completely remove the content, the face that you push must be parallel with
the face on the opposite side of your model. If any lines divide the opposite face, you
need to erase those lines before you can cut a hole through your model. To see
examples, watch the video at the beginning of this article.
4. Click again to finishing pushing away the content in your model. To set a precise
distance, type a number and value and then press Enter.
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Drawing Arcs
To draw an arc in SketchUp, you can choose from a few different arc tools:
•
•
•
•

2 Point Arc tool: With this tool, click to set two points and then drag out a bulge to
create the arc.
Arc tool: With this tool, you set a center point. A protractor appears to help you set the
beginning and ending of the arc based on your desired angle. This tool creates an open
arc.
Pie tool: This tool works just like the Arc tool, but creates a closed shape that becomes
a face.
3 Point Arc tool: This tool enables you to draw an open arc based on a pivot point.

In SketchUp, here’s where you find the arc tools:
•
•
•
•
•

Getting Started toolbar, shown in the figure.
Drawing toolbar
Large Tool Set toolbar
Tool palette (Apple macOS only)
Draw > Arcs submenu

Before you begin drawing arcs, here are a few handy details about the way arc entities work:
•
•
•
•

An arc contains multiple connected line segments, but you select and edit an arc as a
single entity.
An arc can define the edge of a face and divide a face.
Although an arc is one entity, the SketchUp inference engine sees all the segments that
make up the arc and highlights any geometric point if you hover your cursor over one.
You can tell SketchUp how many segments to use in an arc entity. The default is 12
segments. The more segments you use, the more complex your arc becomes and the
harder SketchUp has to work to display your model. Fewer than 12 segments keep your
model simple, but the arc may look blocky.

The following video introduces how you draw with the rainbow of arc tools and each tool’s
golden secrets. Or read on for details about drawing with each arc tool.
Table of Contents
1.
2.
3.
4.

Drawing with the 2 Point Arc tool
Drawing with the Arc and Pie tools
Drawing with the 3 Point Arc tool
Editing an arc entity
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Drawing with the 2 Point Arc tool
When you draw an arc with the 2 Point Arc tool, you set the starting point, the ending point,
and the bulge distance. The distance between the starting point and the ending point is also
known as the chord length.
To draw a 2-point arc, follow these steps:
1. Select the 2 Point Arc tool (
). The cursor changes to a pencil with an arc.
2. Click to place the starting point of your arc. The Measurements box is ready to accept
a Length value.
3. Move the cursor to the ending point of your chord. (Press the Esc key at any point
during the operation to start over.)
4. Click to place the ending point. Or type a length value and press Enter. A straight line
is created. The Measurements box changes to accept a Bulge value.
5. Move your cursor perpendicular to the straight line to adjust the bulge distance. If you
want to draw a half circle, watch for the half-circle inference, as shown in the figure.
The inference tells you when the arc is a half-circle.

6. Click to set the bulge distance. You can also type a value, such as 5’ or 7mm, and
press Enter or Return.
Note: If you wish to repeat this operation precisely, for example if you're rounding all 4 corners
on a rectangle, you can simply move your cursor to each corner and then double-click it'll
repeat the previous arc parameters and even clean our the excess waste.
Tip: Immediately after you draw a 2-point arc, you can change the bulge, radius, or number
of segments with the Measurements box. Remember that you don’t need to click in the
Measurements box first; simply type a value and press Enter or Return. Here’s how to change
each value:
•
Bulge distance: After you finish creating a 2-point arc, the Measurements box is ready
to accept a Bulge value by default. Simply type the value and units (if different from the default
units in your template).
•
Radius: You can specify an arc radius instead of a bulge distance. Type the desired
radius
in
the
Measurements
box
and
add
the
letter
R
for radius. For
example: 24r or 3'6"r or 5mr
•
Number of segments: Type a number and followed by the letter S for segments. For
example: 20s

Drawing with the Arc and Pie tools
The Arc tool and the Pie tool are handy when you need to know your arc’s angle, rather than a
bulge or radius. The Arc tool draws an open arc, and the Pie tool draws a closed, pie-shaped
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arc.
To create an arc with the Arc or Pie tool, follow these steps:
1. Select the Arc tool (
) or the Pie tool (
). The cursor changes to a pencil with an
open arc or a closed arc, respectively, and a half-circle protractor indicates the
orientation of a drawing plane.
2. Click to place the center of your arc. You have locked the orientation of the drawing
plane and a full-circle protractor appears, as shown in the figure.

3. Move the cursor to the starting point of your arc. Notice that the Radius value in the
Measurements box changes dynamically as you move the cursor. If you like, you can
type a number and unit and the press Enter to set a precise radius value.
4. Click to place the starting point of your arc. A straight dotted line that represents the
radius of your arc appears, as shown in the figure. Notice that the Measurements box
changes to accept an Angle value.
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5. Move the cursor to the ending point of your arc.
6. Click to place the ending point of your arc or type an angle value and
press Enter or Return. SketchUp creates an open arc if you used the Arc tool, or a pieshaped face if you use the Pie tool. The following figure shows an open arc on the left
and a pie shape on the right.

When you draw an arc with the Arc or Pie tool, by default, the arc is drawn with a fixed number
of line segments that grow or shrink in length, depending on the completeness of the arc. You
can change the number of line segments or base the arc on circle segments instead (that is,
the number of segments it would take for the arc to form a complete circle).
•

•

To change the number of line segments: Immediately after drawing the arc, type
the number of sides you want and the letter S for sides. Then press Enter or Return.
For example, typing 10s creates an arc with 10 line segments. Another method is to
press the Ctrl + (Microsoft Windows) or Option + (Apple macOS) to increase the
number of segments. Going the other direction, Ctrl - (Microsoft Windows) or Option (Apple macOS) will decrease the number of lines. If you're using a French Canadian
keyboard, hold down the Ctrl key (Microsoft Windows) and the +/= key to increase the
segments. For macOS, press Command and = to increase segments or - to decrease
segments.
To base your arc on circle segments: Immediately after drawing the arc, type the
number of circle sides and the letter C for circle. Then press Enter or Return. For
example, typing 20c tells SketchUp to base your arc on a 20-sided circle.

Drawing with the 3 Point Arc tool
When you use the 3 Point Arc tool, you draw the arc based on a pivot point. Follow these steps
to use the 3 Point Arc tool:
1. Select the 3 Point Arc tool. The cursor changes to a pencil with an arc.
2. Click to establish a starting point of the arc.
3. Move the cursor away from the starting point.
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4. Click again to establish the second point. A small dot appears, which is a pivot point for
the arc.
5. Move the cursor away from the dot. An arc appears as your move the cursor.
6. When you like the shape of your arc, click to finish creating the arc.
Note: Press the ESC key at any point during the operation to start over.

Editing an arc entity
You can edit the radius of an arc entity by using the Move tool or the Entity Info dialog box.
With the Move tool (
•
•

) selected, you can edit an arc entity as follows:

Adjust the midpoint: Hover the Move tool’s cursor to locate the midpoint of the arc.
Then click and drag to adjust the arc, as shown in the figure.
Move an end point: Click and drag an arc’s end point to adjust the arc’s length and
radius.

You can also adjust the radius and number of segments using the Arc entity's Entity Info panel.
Context-click the arc you want to edit. From the menu that appears, choose Entity Info. In
the Entity Info panel shown here, simply type a new value for the radius or number of
segments.
Tip: The basic shape tools use a thin solid line. To create dashed lines, see Applying Dashed
Lines to Layers.
Warning: If an Arc is transformed in a way that destroys its radial definition, such as with a
non-uniform scale operation, you can no longer edit the entity as an arc. At that point, the arc
behaves like a freehand shape.
When you use the Push/Pull tool to extrude a 2D face that includes an arc, SketchUp extrudes
a special surface entity whose radius can also be edited. Use the Move tool to reposition the
midpoint edge, and the all the geometry that makes up the extruded arc will move accordingly,

SketchUp Help Pages – version 19.

Page 68/567

as shown in the figure.

Tip: The basic shape tools use a thin solid line. To create dashed lines, see Applying Dashed
Lines to Layers.
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Drawing Freehand Shapes
With SketchUp’s Freehand tool (
), you can create hand-drawn lines, such as the planter
decorations shown in the figure. The Freehand tool is handy when you need to trace imported
drawings, create a 2D sketch, or decorate your model.

You find the Freehand tool in the following places:
•
•
•
•

Getting Started toolbar (Click the drop-down arrow next to the Line tool.)
Drawing toolbar
Large Tool Set toolbar
Draw > Lines submenu

Under the hood, the lines that you draw with the Freehand tool become curve entities or
polyline entities. Here’s what you need to know about each of these entity types:
•
•

A curve entity contains multiple line segments but can define and divide a face like a
single line. Although you select all the segments in a curve entity at once, the SketchUp
inference engine displays point and edge inferences for each segment in the entity.
A polyline entity doesn’t generate inference snaps, create faces, or affect geometry in
any way. You create a polyline entity only if you hold down the Shift key as you draw
with the Freehand tool. Polyline entities are thinner than curve entities.

Drawing freehand curves or polylines
You can draw freehand curves on existing faces or separate from existing geometry (but aligned
to an axes plane). To draw a curve, follow these steps:
1. Select the Freehand tool (

). The cursor changes to a pencil with a curve.
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2. Click and hold to place the starting point of your curve.
3. Release the mouse button to stop drawing. The line turns black.
4. (Optional) End your curve at the point where you started drawing to create a closed
shape. The figure shows an open curve (left) and a closed curve (right).

Note: If you push/pull a curve into a 3D shape, you create a polyface surface. See Softening,
Smoothing, and Hiding Geometry for details about this type of surface.

Editing a freehand curve
You can change the length of a curve entity as long as it doesn’t bound a face. To edit a curve,
follow these steps:
1. Select the Move tool (
). The cursor changes to a four-way arrow.
2. Hover the cursor over the curve to locate an end point.
3. Click and drag the end point to adjust the curve, as shown in the figure, and release the
mouse when you’re done.
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Dividing, Splitting, and Exploding Lines and Faces
As you draw 3D models in SketchUp, the ability to divide edges and faces enables you to create
and manipulate your geometry in complex ways. You can also explode entities, such as circles
and polygons, into the individual segments.
Table of Contents
1.
2.
3.
4.

Dividing a line
Splitting a face
Healing a face
Exploding an entity

Dividing a line or arc
SketchUp automatically splits a line segment when a new line is drawn perpendicular to that
line. For example, two lines are drawn perpendicular to each other on the face of the cube. In
the figure, notice the following:
•
•

These lines divide the edges that form the cube as well as the lines on the cube’s face.
Sections of what appear to be whole lines are selected, because the lines are split by
other lines.

The lines don’t have to be perpendicular. You also split a line or arc when a line crosses another
line or arc on a face, as shown in the next figure.
(cont’d next page)
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When you want to divide a line or arc into equal segments, SketchUp helps you out. Simply
follow these steps:
1. Context-click a line or arc.
2. Select Divide from the context menu. SketchUp place points on the line or arc to show
where it will be divided.
3. Move the cursor toward the center of the line or arc to reduce the number of segments.
Move cursor toward either end of the line or arc to increase the number of segments,
as shown in the figure.

Tip: Notice that the Measurements box dynamically changes to Segments. If you prefer, you
can type a number and press Enter and thus skip Step 4.
4. Click the line when the number of segments you would like is shown. The line is divided
into an equal number of joined line segments.

Splitting a face
To split a face, draw a line with starting and ending points on the face's edges. Here, notice
how the lines drawn across on the cube create smaller faces within the larger ones.
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Healing a face
If you remove the line or arc that divides a face, the two faces are healed back into one face.
To remove a line or arc, select it, context-click, and choose Erase from the menu that appears.
Or click the line or arc with the Eraser (
the right-hand face on the cube.

) tool. The figure shows how erasing the arc heals

Tip: As you draw 3D models, these dividing and healing operations are common ways to
manipulate edges and faces into your desired shape.

Exploding an entity
SketchUp is about making models, not destroying them. So why does it have an Explode
feature?
When you draw a circle, arc, polygon, or curve entity, several segments make up the entity,
but selecting any segment selects the whole entity. The explode feature breaks an entity into
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its segments, so that you can select one segment separately from the others.
To explode an entity, select it, context-click the selection, and choose Explode Curve from
the menu that appears. In the figure, you see a polygon that’s about to explode into its
individual segments.
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Moving Entities Around
When you’re drawing a model in SketchUp, moving your model (or parts of it) takes on a third
dimension. Literally.
This article is your guide to moving things around in your 3D model, from a simple click-andmove operation to moving precisely with 3D coordinates.
Note: The Move tool is humble tool whose name doesn’t show off all it can do. See Stretching
Geometry, Copying What You’ve Already Drawn, and Flipping and Rotating for details about
the Move tool’s other tricks.
Ready to move? Follow these steps:
1. With the Select (

) tool, select the item (or items) you want to move.

2. Select the Move tool (
) or press the M key.
3. Click the item you want to move. Wherever you click becomes your move point.
Tip: Moving is easier if select a corner as your move point. If you’re moving an item because
you want to align it with something else in your model, make your move point the corner by
which you want to align your item. For example, if you’re aligning the upper-right corner of a
cabinet with another cabinet, click the upper-right corner, as shown in the figure.

4. Move your mouse to move your selection. As you move your item, notice how the
inferences and Measurements box change:
o
o
o

An inference line appears between the start and ending points of the move. (See
callout 1 in the figure.)
The distance of the move is displayed dynamically in the Measurements box (2).
As you move your item close to other items in your model, you see inferences
to nearby geometry. (3)
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Tip: To lock an inference to an axis as you move, hold down the Shift key when the move
line turns the color of your desired axis. Or hold down the up arrow key to lock your move to
the blue axis, the left arrow to lock your move to the green axis, or right arrow to lock the
move to the red axis.
5. Click the destination point to finish the move.
6. (Optional) To move your item a precise distance, you can type either of the following
during or immediately after the move:
o

Coordinates: The Measurements box accepts global or relative coordinates. To
enter global coordinates, use square brackets, such as [3’, 4’, 5’]. To set
relative coordinates, use angle brackets, such as <3’, 4’, 5’>.

o
To see these steps in action, along with a few extra tips for moving, watch this video5.

5

https://youtu.be/zyjlag15PLE
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Stretching Geometry
When you move geometry that's connected to other geometry, SketchUp stretches your model.
To stretch your geometry, select the Move tool (
•
•
•

) and click and drag any of the following:

An edge
A face
A point

In the figure, you see a basic box (1) and copies of that box that were stretched by an edge
(2), a face (3), and a point (4), respectively. If you want to stretch a surface entity (basically,
any form with a curved edge) or bend a face (like Box 4 in the figure), special rules apply,
which are covered in the following sections.

Tip: If you want to stretch part of your model to a specific scale (for example, make a box
twice as wide), see Scaling Your Model or Parts of Your Model.
Table of Contents
1. Resizing surface entities
2. Bending faces with Autofold

Resizing surface entities
In a surface entity, if you click and drag a control edge, you resize the surface entity without
distorting the geometry. You create a surface entity by extruding an arc, circle, or polygon;
see Softening, Smoothing, and Hiding Geometry as well as articles about arcs, circles, and
polygons for details.
When you position the Move tool over a surface entity's control edge, the edge lights up in a
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way that nearby edges do not. In the following figure, the Move tool has selected a control
edge in the cylinder's surface entity, and you see how dragging that edge enlarges the cylinder.

Tip: To make a surface entity look smooth, SketchUp by default hides surface entity edges.
Viewing hidden edges can help you find the control edge easily. To see hidden geometry,
select View > Hidden Geometry.
Note: A surface entity extruded from a curve entity does not have a control edge. Similarly,
if you stretch a circular cylinder into an ellipse, the surface entity also lacks a control edge.

Bending faces with Autofold
In SketchUp, faces must remain planar. If you stretch geometry in a way that bends a face,
Autofold makes a crease so that all the faces in your geometry remain flat. The following figure
shows before-and-after examples of Autofold's handiwork.
(cont’d next page)
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Tip: Sometimes, SketchUp constrains an operation to keep all faces planar instead of creating
additional fold lines. If SketchUp isn't Autofolding when you want it to, hold down the Alt key
(Microsoft Windows) or Command key (Apple macOS) key as you drag the geometry. The
modifier key enables Autofold so that geometry can move freely in any direction.
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Copying What You’ve Already Drawn
In SketchUp, you can copy geometry by using
•

The Copy and Paste commands

•

The Move tool (

•

The Rotate tool (

)
)

When you copy and paste with the Move tool, you can make a single copy or create multiple
copies and tell SketchUp how to space them — if you know the secret keystrokes.
Use the Rotate tool when you want one or more copies to circle around a center point, sort of
like engineers around a DIY quadcopter kit.
Note that any geometry you copy and paste within a SketchUp model could also be copied and
pasted into a new SketchUp document as well, you aren't required to perform this operation in
only one document.
Table of Contents
1. Copying and pasting geometry
2. Copying and multiplying geometry with the Move tool
3. Rotating copies around an axis

Copying and pasting geometry
SketchUp's Copy and Paste commands work much like they do in many other programs. Here's
how to copy and paste in SketchUp:
1. With the Select tool (
), select the geometry you want to copy. See Selecting
Geometry for tips on making selections.
2. Select Edit
>
Copy from
the
menu
bar.
Or
press
the
keyboard
shortcut Ctrl+C (Microsoft Windows) or Command+C (Apple macOS).
3. Select Edit > Paste from the menu bar. Or press Ctrl+V (Microsoft Windows)
or Command+V (Apple macOS). Your cursor changes to a Move tool cursor, and your
copied geometry floats around as you move the mouse. In the figure, you see a copy
of the copied trapezoid-shaped face about to be placed on the red-green plane.
4. Click where you want to place the copied geometry.
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Copying and multiplying geometry with the Move tool
The Move tool can copy geometry, too — or make numerous copies — with only a few clicks
and keystrokes.
Tip: When you copy with the Move tool, you can specify an interval for the copies. This feature
is particularly useful for creating 3D models of fences, bridges, and decks, where several posts
or beams are equally spaced.
To make copies with the Move tool, follow these steps:
1. With the Select tool (

), select the geometry you want to copy.

2. Select the Move tool (
) from the toolbar or press M. The cursor changes to a fourway arrow.
3. To tell SketchUp that you want to duplicate the selected entities, press and release
the Ctrl (Microsoft Windows) or Option (Apple macOS) key. Next to the four-way arrow
cursor, a plus sign appears.
4. Click the selected entities.
5. Move the cursor to copy your selection. A copy of your selection follows the Move cursor
as you move it onscreen. In the figure, the fence panel has been copied.

6. Click where you want to place your copy. The copied entities are now selected and the
original entities are not selected. Alternately, to move your selection a precise distance,
you can type a length value, such as 21' or 30m, and then press Enter.
7. (Optional) Immediately after placing your copy, create multiple copies or equally spaced
copies by typing a value and a multiplier, which appear the Measurements box. The
following table outlines your options.
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To Do This

Type This
Example
A number and X, or * and
Create multiple copies.
Type 7x (or *7) to make 7 copies.
a number
Type 5/ (or /5) to create five copies
Divide the distance between the
A divisor value
evenly spaced between the original
copy and the original.
and the first copy.
Tip: You can keep typing distances and multipliers until you perform another operation. In
the figure, typing 3/ created enough fence panels to complete one section of the privacy
fence. In this way, you can add a fence or other repetitive element to your model in minutes.

Note: Technically, when you create multiple copies, you're creating a linear array.

Rotating copies around an axis
Whether you want to model Stonehenge or a backyard fire pit, the Rotate tool simplifies the
work of placing copies around a center point.
Tip: If you're not familiar with the Rotate tool, review the basics of rotating geometry in
SketchUp.
To rotate copies around a center point, follow these steps:
1. With the Select tool (

), select the geometry you want to copy and rotate.

2. Select the Rotate tool (
) on the toolbar or press Q.
3. Click where you want the rotation's center point to be, as shown where the Rotate cursor
appears in the figure.
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4. Click the selection you want to copy and rotate. The following figure shows the inference
lines that appear after clicking the rock.

5. Tell SketchUp to make copies by pressing and releasing the Ctrl key (Microsoft
Windows) or the Option key (Apple macOS). A plus sign appears next to the Rotate
cursor. (You can actually tell SketchUp to make copies anytime between Steps 3 and
5.)
6. Move the cursor to wherever you want to place your rotated copy. As you move the
cursor, an inference line shows the angle between your original geometry and the
rotated copy, as shown in the figure.

7. Click to place your copied geometry.
8. (Optional) Type a number and the x, *, or / modifier to create multiple copies around
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the center point. (See the earlier table for details about what each modifier does.) In
the figure, typing 7/ created 7 copies of the rock.

Note: Under the hood, when you follow the preceding steps, SketchUp is creating a circular
array of objects.

SketchUp Help Pages – version 19.

Page 85/567

Erasing and Undoing
In SketchUp, you can correct mistakes with the Undo command or the Eraser.
The Undo command reverses your most recent action. For example:
•
•

If you draw a line and then Undo it, the line will disappear.
If you select a detailed facade to copy it with the Move tool but accidentally stretch it
instead, you haven't lost your detailed selection because Undo can rectify the problem
instantly.

To Undo, select Edit > Undo Whatever You Just Did from the menu bar, as shown in the
figure. The official keyboard shortcut for Undo is Alt+Backspace. However, Ctrl+Z (Microsoft
Windows) or Command+Z (Apple macOS), which is the Undo keyboard shortcut in many
programs, also works.

After you undo an action, you can redo it by selecting Edit > Redo from the menu bar.
The Eraser deletes selected geometry. With the Eraser, you can remove geometry no
matter when you created it. The Eraser also enables you to manipulate your geometry by
strategically removing lines or faces.
You find the Eraser (
•
•
•
•
•
•

) tucked into a few different areas of the SketchUp interface:

Getting Started toolbar
Drawing toolbar
Large Tool Set toolbar
Principal toolbar
Tool Palette (Apple macOS only)
Erase command on a context menu

Here are the ways you can use the Eraser:
•

Click an edge with the Eraser tool cursor. If you select the Eraser tool from any of
the toolbars, you can click an edge to erase it and any faces it bounds.
Tip: The Eraser tool doesn't allow you to erase faces. Technically, faces are erased after
their bounding edges are erased, which enables you to open and otherwise reshape
your geometry, as explained in this introduction to drawing basics. However, SketchUp
does have a workaround — the context menu's Erase command.) see the upcoming
bullet for details

•

Click and drag over multiple lines with the Eraser tool. The lines that you will
erase when you release the mouse button are highlighted in blue.
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Tip: If you accidentally include one or more lines you don’t want to erase in this action, hold
down the Alt key (Windows) or Command key (Apple macOS) and drag over the lines you
want to unselect for erasure.
•
•

Delete a face with the context menu. To remove a single face, context-click the face
and select Erase from the menu that appears.
Delete selected geometry. To delete several edges and faces at once, use the Select
tool to select all the geometry you want to erase, as shown in the following figure. Then
context-click your selection and choose Erase. As you can see in the right-hand image,
the selected lines and faces have been deleted.
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Flipping, Mirroring, Rotating and Arrays
With SketchUp's flipping and rotating tools, your geometry becomes as nimble as an acrobatic
troupe. The Flip Along command enables geometry to backflip 180 degrees along any axis.
With the Rotate tool, your geometry can spin and fold like a professional gymnast.
Table of Contents
1. Flipping geometry along an axis
2. Rotating geometry at an angle
3. Folding geometry along an axis

Flipping geometry along an axis
To flip your geometry, follow these steps:
1. With the Select tool (
), select the geometry you want to flip.
2. Context-click your selection and select Flip Along.
3. In the submenu, select an axis.
In the figure, Sophie demonstrates the results of flipping along the blue axis (1) or the red axis
(2).

Tip: By combining the Copy and Flip Along commands, you can mirror geometry. When
you're modeling objects like cars (or anything that's the same on both sides), mirroring
enables you to create one half of a model (1), copy it (2), and then flip the copy (3) to create
a mirror that completes the model, as shown in the following figure. See Selecting
Geometry for tips on making complex selections.
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Rotating geometry at an angle
With the Rotate tool, you can rotate geometry at any angle. For example, say you want to
rotate this telescope so that it points at a different angle or a different part of the sky.

Here's how to use the Rotate tool to spin geometry around:
1. With the Select tool (
), select the geometry you want to rotate. Here, the geometry
that points the telescope into the sky is selected, but not the base, which needs to stay
on the ground.
2. Select the Rotate tool (
). The Rotate tool's protractor-shaped cursor appears.
3. Move the cursor around until it's on the plane you want to use for your rotation. To lock
the plane, press the Shift key until you click to set the angle's vertex. When your plane
is perpendicular to an axis, the cursor turns red, green, or blue, respectively, as shown
in the figure.

SketchUp Help Pages – version 19.

Page 89/567

Tip: In this example, inferring from a face that's on the same plane as the desired rotation is
the easiest way to find the right plane. Hold down the scroll wheel of your three-button mouse
to temporarily switch to the Orbit tool (
) and find a good view of your desired plane.
See Viewing a Model for details about viewing options.
4. Click to set your angle's vertex (Callout 1 in the following figure).
5. With the circular arrow cursor, click to set first point of your rotation angle. In this
example, the starting point (Callout 2 in the following figure) is parallel to the current
angle of the telescope.

6. Move the cursor in the direction of your rotation and click to complete the rotation angle.
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In the figure, the circular arrow cursor is positioned where you might click to complete
the rotation (Callout 3). Notice that the Measurements box indicates the angle.

7. (Optional) Type a precise angular rotation or slope value and then press Enter. The
following table outlines how to specify each value. Negative values move the angle
rotation in a counter-clockwise direction.
To Specify This . . .

Type This

Example
Type 34.1 to rotate by an
An exact angle in degrees A decimal value
exact 34.1 degree angle.
Type 8:12 for a slope of 8 over
A new angle as a slope
The two values separated by a colon
12.
Here's another example to help you understand how to achieve your desired rotation angle.
Imagine you need to rotate the whole telescope to a different part of the sky (northwest, say,
instead of due north). Start by selecting the whole telescope and then select Camera >
Standard Views > Top to see the telescope from above. (Viewing a Model explains
SketchUp's viewing options.) With the Rotate tool selected, you then lock the protractor cursor
in the blue direction and click the top to set the angle's vertex (Callout 1). Click to start your
angle at due North (2) and then click again to complete the angle at your desired Northwest
direction (3).
(cont’d next page)

SketchUp Help Pages – version 19.

Page 91/567

In this video6, watch the Rotate tool in action, where you see how to rotate clock hands and
open a vault door, fold a SketchUp face into a paper airplane, and more.

Folding geometry along an axis
SketchUp geometry is so flexible, you can fold it like paper. Follow these steps:
1. With the Select tool (

), select the geometry you want to fold.

2. Select the Rotate tool (
).
3. With the Rotate tool's protractor-shaped cursor, click and drag from one endpoint on
the fold line to the other endpoint. Release the mouse button when you're done. In this
example, the line that bisects the polygon is the fold line.
4. Click at the starting point of the rotation. In the figure, the circular arrows cursor is
where the rotation begins.
(cont’d next page)

6

https://youtu.be/EdsFkiPw4nA
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5. Move the mouse to rotate. If angle snaps are active under preferences, movements
close to the protractor result in angle snaps, whereas those farther away allow free
rotation. Also, as you move the cursor, notice that the angle degrees of rotation appear
in the Measurements box.
6. Click at the ending point to complete the rotation. The following figure shows the
rotation's ending point and the dynamic preview of the folded polygon.

7. (Optional) Type a precise angular rotation or slope value and then press Enter. See the
earlier table for details about how to specify each value. Negative values fold the
geometry in a counter-clockwise direction.
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Scaling Your Model or Parts of Your Model
In SketchUp, you can resize and reshape your model based on the relative sizes of your edges
and faces. Here's a quick overview of the available options:
•
•
•
•

Scale your entire model with the Tape Measure tool.
Resize entities while maintaining their proportions with either the Tape Measure
tool or the Scale tool.
Stretch or squish an entity to scale with the Scale tool. For example, stretch a
cabinet so it's twice its current width or narrow a car by 5 percent.
Scale a single component or every component in your model.

This video7 shows how the Scale tool can scale geometry proportionally or stretch its
dimensions.
If you're looking for details about scaling your entire model or detailed steps that walk you
through SketchUp's scaling features, check out the sections later in this article.
Table of Contents
1.
2.
3.
4.

Scaling your entire model
Scaling a selection proportionally
Stretching or squishing geometry to scale
Scaling components

Scaling your entire model
When you want to scale your entire model, use the Tape Measure tool.
Tip: The Tape Measure tool enables you to scale precisely by specifying the desired dimension
between two points. This line is referred to as the reference line.
To scale an entire model, such as the floor plan in this example, follow these steps:
1. Select the Tape Measure tool (
) or press the T key. The cursor changes to a tape
measure.
2. Measure the distance between two points on your model. In this example, say you know
the width of the stairs needs to be 48 inches. Here's how to measure that distance:
a. Click one end of a line segment to set the starting point of a measurement. Use
the SketchUp inference engine to make sure you click the exact point.
b. Move the mouse to the end point of the same line segment. As you move the
mouse, a temporary measuring tape line, with arrows at each end, stretches out
from your starting point.
c. Click at the other end of the line segment, as shown in the figure. The final
distance appears in the Measurements box.

7

https://youtu.be/PLhRTRUPvPE
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3. Type a new size for the line, which appears in the Measurements box, and press Enter.
This size is the basis for a proportional rescale of your model. In this example, the
reference line is scaled to 48”.
Tip: You can use imperial or metric units. SketchUp understands both. Just be sure to specify
your desired unit if it's not your template's default unit of measurement.
4. When the following dialog box asks whether you want to resize your model, click
the Yes button, and the model is rescaled proportionally.
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Scaling a selection proportionally
When you want to resize geometry within your model and maintain its proportions, you can
use either the Tape Measure tool or the Scale tool. Your choice depends on how you want to
set the scale:
•
•

To base the scale on the size of a specific line, use the Tape Measure. For example,
you find out one room in your floor plan can only be 10 feet wide, but the rest of the
floor plan can stay the same. Or you know a statue must be 3 meters tall.
To resize your selection based on a percentage of your original size, use the
Scale tool. For example, choose this method if you want to increase your selection's size
by 200% or decrease it to 50%.

To scale part of your model with the Tape Measure, follow these steps:
1. With the Select tool (
), select the entities you want to scale.
2. Context-click your selection and, from the context menu that appears, select Make
Group.
3. Double-click the group. A box of dashed lines appears around the group, indicating that
you've opened the group, as shown in the figure.

4. Select the Tape Measure tool (
) or press the T key.
5. Click one end point of your reference line. Use the SketchUp inference engine to make
sure you click the exact end point.
6. Click the other end point of your reference line. The current distance appears in the
Measurements box, as shown in the figure. In the example, say you need to decrease
this width to 10 feet, due to issues on the site where the floor plan will be built.
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7. Type a new size for the line (in this example, you type 10') and press the Enter key.
This size will be used as the basis for a proportional rescale of your model. SketchUp
asks whether you want to resize your group or component.
8. Click the Yes button, and your selection rescaled proportionally. Check out the result in
the following figure. That's a much smaller room.

Note: This process also works with components. See Adding Premade Components and
Dynamic Components for an introduction to components. The Scaling components section
later in this article explains how scaling only affects a single component or all component
instances in a model.
When you want to scale your model proportionally by a percentage, the Scale tool can
do the job easily. Imagine you're not sure how to talk to your client about decreasing a room
in their floor plan to 10 feet wide, so you model an elephant in the room while you think it

SketchUp Help Pages – version 19.

Page 97/567

over. Here's how to scale that elephant, or any other selection in your model, by a percentage:
1. With the Select tool (
), select the geometry you want to scale. This step is important
if you want to scale a complex 3D selection. If you have an easy selection, like a 2D
shape or a surface entity, you can skip this step.
2. Select the Scale tool (
) or press the S key. A yellow box with green grips appears
around your selection, as shown in the figure. If you skipped Step 1, click the geometry
with the Scale tool cursor.

3. For a uniform scaling, or one that keeps your selection proportional, click a corner
scaling grip. The selected grip and the opposite scaling grip turn red, as shown in the
following figure, and in the Measurements box, you see a scale of 1.00, which means
your geometry is at its original size, or scaled to 100%.
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4. Move the cursor to scale the entity. The Measurements box displays the scale
dynamically. Press the Esc key at any point to start over. To set the scale from the
center instead of the opposite corner, hold down the Ctrl key (Windows) or
the Option key (Apple macOS) while you move the red corner grip.
5. Click to set your selection's new scale. Or type the desired scale dimensions and press
Enter.
Note: Technically, in Step 5, you can type a dimension, such as 2m or 3", instead of a scale
dimension. However, scaling based on a dimension with the Tape Measure is generally more
intuitive.

Stretching or squishing geometry to scale
Sometimes, you need to scale only one dimension of a model (or maybe two). To do so, use
the Scale tool's edge or face grips. Here's how the process works, using a cabinet as an
example:
1. With the Select tool (
), select the geometry you want to scale. This step is important
for a complex a 3D selection. Skip this step for an easy selection, like a 2D shape or a
surface entity.
2. Select the Scale tool (
) or press the S key. A yellow box with green grips appears
around your selection. If you skipped Step 1, click the geometry with the Scale tool
cursor.
3. Click an edge or face grip (not a corner grip). The selected grip and the opposite scaling
grip turn red, as shown in the figure, and in the Measurements box, you see a scale of
1.00, which means your geometry is at its original size, or scaled to 100%. The
Measurements box also displays the axis direction for your scale, such as Blue Scale or
Red Scale. If you select an edge grip, you see two axes, such as Red, Green Scale.
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4. Move the cursor to scale the entity. The Measurements box displays the scale
dynamically. Press the Esc key at any point to start over. To set the scale from the
center instead of the opposite edge or face, hold down the Ctrl key (Windows) or
the Option key (Apple macOS) while you move the red corner grip.
5. Click to set your selection's new scale. Or type the desired scale dimensions, and
press Enter. To set the scale on two or even three axes, type two or three numbers,
each separated by a comma, such as 3,2. In this example, you see the original cabinet
was scaled to be twice as wide but half the height.

Tip: If you have trouble controlling the scale direction, try repositioning the drawing axes to
your selection. To do so, select Tools > Axes from the menu bar. With the Axes tool cursor,
click corner you want to use to align the drawing axes. Then move the cursor so that it snaps
the edge to which you want to align your inferred axis and click to confirm the change. (The
inference is red, green, or blue depending on the direction you move your cursor.)
See Adjusting the Drawing Axes for details about working with the drawing axes.

Scaling components
You can use these scale techniques on components as well as everyday geometry. (See Adding
Premade Components and Dynamic Components for an introduction to components.) When
you scale a component, however, you can resize a single instance of the component or all
component instances in your model:
•

Scaling a component changes only the individual instance. This feature allows
you to have differently scaled versions of the same component in your model. To scale
a single instance, click the component instance with the Scale tool and use the grips to
set the new scale, using any Scale tool technique explained earlier in this article. The
following figure shows scaling a door component downloaded from the 3D Warehouse.
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Scaling an entity within a component scales every component instance. To scale
an entity in a component, you need to open the component by double-clicking it. Dashed
lines appear around the component, and the lines and faces within the component
become editable, as shown in the following figure. With the component open, you can,
for example, scale a line entity. This action affects the component definition and,
therefore, all instances of the component are scaled to match. With the component
open, you can select a line, and therefore can scale with either the Scale tool or the
Tape Measure tool, as explained earlier in this article. Note, however, that a uniform
scale using the Tape Measure tool is often the easiest way to scale all components in a
model.
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Extruding with Follow Me
The SketchUp Follow Me tool (
) is the Pied Piper of 3D geometry: Follow Me leads a face
along a path to create a 3D shape. The Follow Me tool does only one thing. However, it has a
multitude of applications and enables you to draw complex 3D models with only a few clicks.
Tip: Follow Me is especially handy for modeling finishing details that follow a perimeter or edge,
such as crown molding or gutters. It also makes easy work of modeling lathed objects, like a
spindle, and curved vessels, such as a bowl or a vase.
Here's where you find the Follow Me tool in SketchUp:
•
•
•
•

Tools menu
Edit toolbar
Large Tool Set toolbar
Tool palette (Apple macOS)

In the following video, you see a quick demonstration of the Follow Me tool's many applications.
Read the following sections for steps that walk you through modeling with Follow Me.
Table of Contents
1. Automatically extruding a face with Follow Me
2. Manually extruding a face with Follow Me
3. Modeling a lathed shape with Follow Me

Automatically extruding a profile with Follow Me
This method is the easiest and usually the preferred way to use the Follow Me tool. To extrude
your face automatically, preselect the path using the Select tool. The Follow Me tool then follows
the path along your selection. The following steps explain how the process works:
1. Draw a profile of the face that you want to follow the path, like the yellow face shown
in the figure. Make sure that this profile is approximately perpendicular to the path.
Note that the profile doesn't need to be connected to the path. It just needs to be
perpendicular.
Tip: To keep your profile drawing perpendicular to your path, draw your profile on a
face and then erase any edges you don't need.
2. With the Select tool (
), select the continuous set of edges that represent the path,
also shown in the following figure.
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3. Select the Follow Me tool (
). The edges remain selected.
4. Click the profile that you created, and the surface is extruded automatically along your
preselected path, as shown in the following figure.
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Note: If you've organized your model into groups, your selection and profile must be in the
same group for the preceding steps to work. See Organizing a Model for details about groups.

Manually extruding a profile with Follow Me
When you extrude a profile along a path manually, you do a bit more work but can control the
direction the extrusion travels. Here's how the manual method works:
1. Identify the path for your extrusion.
2. Draw a face or profile that you want to follow the path. Make sure that this profile is
perpendicular to the path. In the following figure, the profile is the half-moon shape and
the path is around the blue shape.

3. Select the Follow Me tool (
).
4. Click and drag the face that you created along the path. As you drag, touch the mouse
pointer to the path you're following. SketchUp highlights the path in red, as shown in
the figure. If your starting edge is not touching the profile, Follow Me starts extruding
at that edge, not from the profile to that edge. If you need to start over, press Esc.
(cont’d next page)
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5. Click to complete the Follow Me operation when you reach the end of the path.
Note: If you've organized your model into groups, your selection and profile must be in the
same group for the preceding steps to work. See Organizing a Model for details about groups.

Modeling a lathed shape with Follow Me
You can use the Follow Me tool to mimic a lathe. Follow these steps:
1. With the Circle tool (
), draw a circle.
2. With the Line, Arc, and Freehand tools, draw a cutaway of half of the final shape. You
need to make sure the cutaway meets the following criteria, as shown in the figure:
3. The cutaway forms a face. (Make sure all your arcs and lines connect.)
4. The cutaway's face is perpendicular to the circle.
5. The bottom of the cutaway (which will be the center of your final lathed shape) aligns
with the center point of the circle.
(cont’d next page)
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), select the circle.

7. Select the Follow Me tool (
) and click the face of the cutaway. Be patient. If your
geometry is complex, this step can take a while to complete. After the processing is
complete, the shaped object is displayed, as shown in the following figure.

Tip: If you have trouble with your extrusion, zoom in close and check for gaps between the
lines. Use the Line tool (
) to connect any gaps and try your extrusion again. Also orbit
around to make sure your cutaway is perpendicular to the circle.

Softening, Smoothing, and Hiding Geometry
The Soften Edges feature may remind you of a stick of butter or a chocolate bar that got too
warm in the sun. In SketchUp, however, the Soften Edges feature does nothing to compromise
your model’s structural integrity.
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Tip: You can use the Soften Edges feature, along with the Smooth edge property, to change
the visibility of your edges and make your model look more realistic with less geometry, which
improves your computer’s performance.
Here, you find an introduction to soft, smooth, and hidden geometry and the types of entities
they create. After you understand the basics, check out a few tips for improving your model’s
appearance and modeling efficiently.
Table of Contents
1.
2.
3.
4.

Understanding the edge properties
Softening and smoothing edges at once
Hiding geometry
Viewing hidden edges

Understanding the edge properties
In SketchUp, the following properties, in various combinations, enable you to control edges’
appearance:
•

•

Soft: When you soften an edge, the edge is hidden, and the faces that the edge bounds
become a surface entity.
Note: A surface entity joins two or more faces so that they look round. Although you
still see inferences for all the geometry that a surface entity contains, the surface entity
acts like a single entity when you select or paint it. In the figure, you see that clicking
the face on either side of the soft edge (1) selects both faces.
Smooth: Smoothing an edge adds shading that makes the faces look smooth. However,
when you apply the Smooth property alone, the edge remains visible. (See Edge 2 in
the figure.)

You can also hide an edge (or any geometry, the hidden property isn’t exclusive to edges).
When you hide an edge, the edge is not visible, but any faces adjoining the edge are not
transformed into a surface entity. (Edge 3 in the figure is a hidden edge.)
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Softening and smoothing edges at once
In SketchUp, softening and smoothing edges typically go hand-in-hand. That’s why both the
Eraser tool and the Soften Edges dialog box apply these properties together.
Tip: Use the Eraser tool to quickly smooth and soften your edges. Open the Soften Edges dialog
box when you need more fine-tuned control.
To soften and smooth edges with the Eraser, follow these steps:
1. Select the Eraser tool (
) or press the E key.
2. Hold down the Ctrl key (Microsoft Windows) or the Option key (Apple macOS) as you
click the edges you want to hide.
If you make a mistake or change your mind, hold down Ctrl+Shift (Microsoft Windows)
or Option+Shift (Apple macOS) and click the edges to undo the softening and smoothing.
To soften and smooth with the Soften Edges dialog box, follow these steps:
1. Select the edges you want to soften and smooth. (See Selecting geometry for tips and
selection techniques.)
2. Or context-click your selection and choose Soften/Smooth Edges. Either way, the
Soften Edges dialog box appears, as shown in the figure.

3. Click and drag the Angle between normals slider to set the maximum size of all
angles that will be smoothed or softened. The higher the setting, the more angles you
are likely to smooth or soften. In the example, the slider is set to 20 degrees, which
smooths and softens most of the rock’s surface.
(cont’d next page)
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4. (Optional) The Smooth normals check box is selected by default. If you don’t want the
shading effect that makes your edges look smooth, clear this check box.
5. (Optional) Select the Soften coplanar check box to soften edges between coplanar
surfaces, essentially deleting those edges. In the example of the rock, selecting the
check box doesn’t impact the rock much, because few (if any) of its faces are on the
same plane.
To check or change the properties applied to an edge, context-click it and choose Entity Info.
In the Entity Info box, shown here, the type of entity appears in the upper left, and you can
select or clear the Soft and Smooth check boxes. Select a face, and you can see whether it’s
a surface entity or another type of geometry.
Tip: Softened and smoothed edges make basic geometry look polished. In a complex model,
relying on soft and smooth edges can noticeably lighten the load on your computer’s memory.
For example, you can create the corbel shown in the figure by creating a 2D drawing in the
shape of the selected edges. Then extrude the face into the 3D shape shown here. The shape
is quite basic, but the softened and smoothed edges enhance the model’s dimensions and
shape. Also, if you draw and extrude arcs, circles, or curves, these entities apply soft and
smooth edges by default.
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Hiding geometry
As you draw a model, you don’t necessarily want a line marking every edge in your model. The
Soften Edges feature hides the line, but also creates a surface entity, which means you can
apply only one material to any face in the surface entity. If you want to hide an unsightly line
without creating a surface entity, seek out the Hide feature. You can hide lines, faces, and any
SketchUp entity.
Follow these steps to hide a line or any geometry:
1. Select the geometry you want to hide.
2. Context-click the selection and choose Hide from the context menu that appears, as
shown in the figure. Or choose Edit > Hide. The selected geometry disappears from
view, although it is still there, like a ghost in the machine.

After you hide geometry, by default, you can’t select it. To make hidden geometry selectable,
you must display hidden geometry or unhide the geometry. (There is a difference.) See Viewing
hidden edges for details.
Tip: In SketchUp, styles change the look of your whole model. All you have to do is click a
style preset. If you’re hiding edges or geometry to see through your model or change the
appearance of your model as a whole, consider whether styles offer an easier way to get the
job done.

Viewing hidden geometry
In SketchUp, any geometry that’s hidden is still there. You just can’t see or select it.
To see the hidden geometry but keep it hidden, choose View > Hidden Geometry. All
hidden entities appear in a ghosted pattern (as shown in the figure), allowing you to select
them. Choose View > Hidden Geometry again to clear the option and make the ghost pattern
disappear.
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To change geometry from hidden to visible, you need to unhide it. Select the hidden
geometry, context-click the selection, and choose Unhide. (The Hide menu item changes to
Unhide when selected geometry is hidden.)
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Offsetting a Line from Existing Geometry
When you create a 3D model, you often need to draw a slightly bigger or smaller version of a
shape and keep the two shapes equidistant from each other. This is called offsetting a line. An
offset is handy when
•
•

•

Drawing a floor plan: A floor plan typically shows both interior and exterior walls.
Draw one set of walls and then use the Offset tool to draw the second set.
Drawing a profile: To create a 3D model of a bowl or vase, for example, you can draw
the lines and curves to create the basic shape and then offset that shape so your profile
has a uniform depth. From there, extruding the profile with Follow Me completes your
3D model.
Drawing an overhang: A house’s eaves are typically equidistant from the exterior
walls. With those walls in place, you can easily draw the outline for the eaves with the
Offset tool.

In the SketchUp interface, you find the Offset tool (
•
•
•
•
•

) in the following places:

Edit toolbar
Getting Started toolbar
Large Tool Set toolbar
Tools menu
Tool palette (Apple macOS only)

In this video8, you see the Offset tool in action and learn tips for using it. Read on for steps
that walk you through using the Offset tool
You can offset lines or faces. If you offset lines, you need to first select the lines you want to
offset. Make sure you select two or more lines that are connected and in the same plane. Then,
follow these steps:
1.
2.
3.
4.

Select the Offset tool (
) or press the F key.
Click one of your selected line segments or the face you want to offset.
Click to finish the offset.
(Optional) To set a precise offset distance, type a number and the Imperial or metric
units you want to use. Then press Enter (Microsoft Windows) or Return (Apple
macOS). You can reset the distance in this way as many times as you like until you
make another change to your drawing or select a different tool.

Tip: Double-clicking another face immediately after you create an offset automatically applies
another offset, of the same amount, to the face.

Measuring Angles and Distances to Model Precisely
What distinguishes solid construction and design from an M.C. Escher optical illusion? Accurate
measurements.

8

https://youtu.be/fmhwjKMJDL0
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In SketchUp, the Tape Measure tool, the Protractor tool, and the Measurements box enable
you to model precisely:
•

With the Tape Measure tool (
), you can measure a distance and set precise guide
lines or guide points.
Note: Guide lines and guide points are temporary dashed lines used as guides to draw
precisely. They do not interfere with regular geometry.

•

The Protractor tool (
) enables you to measure angles and set a precise angled guide
line.
As you use almost any tool in SketchUp, the Measurements box is waiting to accept a
precise value.

•

Beyond these tools, you can also combine the tips in this article with a little math to estimate
building height accurately.
Table of Contents
1.
2.
3.
4.
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Measuring a distance
Measuring an angle
Editing guide lines
Hiding and erasing guide lines
Estimating building height accurately
Measurements box quick reference

Measuring a distance
The Tape Measure tool can measure a distance and create a guide. Here’s where you find the
Tape Measure
•
•
•
•
•

in the SketchUp interface:

Getting Started toolbar
Construction toolbar
Large Tool Set toolbar
Tools menu on the menu bar
Tools palette (Apple macOS)

To measure geometry or set a guide line, follow these steps:
Note: A good rule to remember; You'll use endpoints to create Guide Points, you can create
Guide Lines using midpoints, lines or faces.
1. Select the Tape Measure tool (
) or press the T key.
2. Click the starting point of your measurement. If you need to select an end point or
midpoint, the SketchUp inference engine helps you find it. To create a guide line, click
a line that needs to be parallel to your guide line.
3. Move the cursor in the direction you want to measure. As you move the mouse, a
temporary measuring tape line, with arrows at each end, stretches from your starting
point, as shown in the figure.
Tip: Here are a few tips to help you move the Tape Measure cursor through 3D space:
o The measuring tape line changes color to match an axis colors when it is parallel
to any axis. In the figure, you see measuring tape aligned to the red axis.

SketchUp Help Pages – version 19.

Page 113/567

Press and hold a directional button while measuring to lock an axis. The up
arrow locks the blue axis, the left arrow locks the green axis, and the right
arrow locks the red axis.
o The Measurements box dynamically displays the length of your measuring tape.
4. Press Esc if you need to start over.
o

5. (Optional) To create a guide line, press Ctrl (Microsoft Windows) or Option (Apple
macOS). A plus sign appears next to your Tape Measure cursor (
).
6. Click at the ending point of your measurement. The distance from the start point
appears in the Measurements box. If you pressed Ctrl in the preceding step, a guide
line appears as a dashed line that reaches into infinite 3D space (at least within your
model). In the following figure, the guidelines mark the distance 3 feet from the interior
walls. (See Adding Text to a Model for information about labeling distances in your
model.)
7. (Optional) To move your guide line a precise distance from the starting point, type a
number and unit and then press Enter.
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Note: If you measure a distance without creating a guide and then enter a value, SketchUp
asks whether you want to resize your model. See Scaling Your Model or Parts of Your Model for
details.
Tip: When you measure from an end point inference and create a guide, SketchUp creates a
guide point, as shown in the figure. A guide point is a finite dashed line, whereas a guide line
is infinite.

Measuring an angle
Measure an angle when you want to duplicate that angle elsewhere in your model or create
plans, such as for a woodworking project. To measure an angle or create angled guide lines,
use the Protractor tool.
You find the Protractor tool (
•
•
•
•

) in a few different parts of SketchUp’s interface:

Construction toolbar
Large Tool Set toolbar
Tools menu
Tool palette (Apple macOS)

In this video9, you see how to measure angles and set guides with the Protractor tool. For steps
that walk you through the process, read the rest of this section.
To measure an angle and create an angled guide line, follow these steps:
1. Select the Protractor tool (
). The cursor changes to a protractor. The center point
is fixed to the cursor.
2. Click where the angle that you want to measure begins. (See Callout 2 in in the figure.)

9

https://youtu.be/EMkRPKnAKrM
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Tip: You can click and drag from the vertex to the first point to define the axis of rotation.
This is especially helpful if you need to rotate on an axis that isn’t on the red, green, or blue
planes. Press Esc at any point to start over.
3. Move the cursor to measure the angle. (See Callout 3 in the figure.)
Tip: Here are a few tips to help you find the right angle measurement:
• As you move the cursor, the angle appears dynamically in the Measurements box.
• When the cursor is close to the protractor, the angle snaps to the protractor’s tick marks,
which indicate 15 degree increments. When your cursor is farther from the protractor’s
center, you can measure the angle in more precise measurements.

4. Click to set an angled guide line.
5. (Optional) Type a value and press Enter to change the angle of your guide line (relative
to the start line). You can type a decimal value, such as 34.1, or a slope, such a 1:6.
Change this value as many times as you like until you make another selection or choose
another command.
Note: SketchUp can handle up to 0.1 of a degree of angular precision.

Editing guide lines
To reorient a guide line or guide point, you can move or rotate it. See Moving Entities
Around and Flipping and Rotating for details.
Note: You cannot resize a guide line because guide lines are infinite in length.
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Hiding and erasing guide lines
Guide lines are usually created as a temporary aid for building a portion of your model. Keeping
too many guide lines in your model can decrease SketchUp’s inference accuracy and display
performance, so you might want to hide guide lines as you work or delete all guide lines after
you finish your 3D model.
To hide guide lines, you can use either of the following methods:
•
•

With the Select tool (
), select one or more guides and then select Edit > Hide.
Context-click a selected guide or guides and select Hide from the menu that appears,
as shown in the figure. [figure fg021_5 missing in the original page]

To make hidden guides visible again, select Edit > Unhide and choose an option from the
Unhide submenu.
Deleting guide lines removes them altogether, never to return. Here are some ways to delete
your guide lines:
•
•

With the Select tool (
), select one or more guides and then select Edit > Delete.
Context-click a guide and choose Erase from the menu that appears.

•
•

Click a guide line with the Eraser tool (
).
Select Edit > Delete Guides to erase all guides in the current context.

Estimating building height accurately
If you don’t know the height of an existing building that you’re trying to model, here are some
techniques you can use to make an educated guess:
•
•
•

Count repeated units.
Take a picture with an object of known height
Use trigonometry.

When you’re ready to extrude a building’s footprint to the correct height, make sure you’re in
ISO view by choosing Camera > Standard Views > Iso. Then use the Push/Pull tool (
) to extrude your building into 3D and enter your building's exact height.
Method 1: Count repeated units
Often, buildings are constructed with bricks, blocks or other modular construction materials.
Measure the height of a single unit, count the total number of units on the facade, and multiply
to get an approximate overall height.
This method also works for entire building levels. If you can measure a single level on the
façade of your building, you can multiply by the total number of levels to arrive at an
approximate overall measurement.
Method 2: Take a picture with an object of known height
When you’re taking a picture of the building you plan to model, include something (or someone)
in the photo whose height you know.

SketchUp Help Pages – version 19.

Page 117/567

Tip: Here are a few tips for estimating building height with this method:
•
•
•

A meter stick or a person works well.
Position your “known quantity” as close to the building as possible for accuracy.
Take the photo from as far away as possible to minimize vertical distortion.

You can use a photo-editing program to estimate the height of your building based on the
object (or person) you included in the photograph.
Method 3: Use some simple trigonometry
With a few simple measurements, it’s possible to estimate heights with some accuracy. Take a
look at the figure below. All you need to know is:
1. Your distance from the building
2. Your eye height
3. The angle between the ground and the top of the building

Use this formula to calculate the height of the building:
Height = ( tan(angle) x distance ) + eye height
For example, given a building distance of 25 meters, an angle of 37 degrees, and an eye height
of 1.75 meters, the formula would be:
Height = tan(37) x 25m + 1.75m
= 0.75355 x 25m + 1.75m
= 20.6m
Note: On your calculator, the tan button calculates the tangent of an angle.

Measurements box quick reference
In this section, you find tables that outline all the values the Measurements box accepts,
depending on what tool you’re using. Remember that, after you use a tool, you can simply type
the value and press Enter. You don’t need to click in the Measurements box. Also, until you
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make another change to your model or select a different tool, you can continue to enter values
that modify your action.

Specifying Units of Measurement
The following table outlines how to specify units of measurement. If you don’t indicate a unit,
SketchUp uses the units in your template. To see or change your default units, select Window
> Model Info and select Units in the sidebar on the left.
Unit
Inches
Feet
Millimeters
Centimeters
Meters

How to Specify It
number + “
number + ’
number + mm
number + cm
number + m

Example
10”
10’
10mm
10cm
10m

Creating Arrays
An array arranges geometry in a line (linear array) or around a point (radial array). You create
an array when you copy geometry with the Move tool or the Rotate tool. The following table
outlines all the modifiers you can use when creating arrays.
Array Type
External
External
Internal

How to Specify It Example
number + x
3x
number + *
3*
number + /
3/

Spacing
Equal distance as original and initial copy
Equal distance as original and initial copy
Equal distance between original and initial copy

Entering tool-specific measurement values
Immediately after you use a tool, you can enter precise values, which appear in the
Measurements box. The values you can enter depend on the tool.
Note: The exact format for a list separator may vary, depending on your computer’s Regional
Settings. For European users, the list separator symbol may be a semicolon instead of a
comma.
The following links point you to the article that outlines the accepted values and modifiers for
each tool:
•
•
•
•
•
•
•
•
•
•
•

2 Point Arc, Arc, Pie, and 3 Point Arc tools
Arc tool
Circle tool
Field of View tool
Line tool
Look Around tool
Move tool
Offset tool
Pie tool
Polygon tool
Protractor tool
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Push/Pull tool
Rectangle tool
Rotate tool
Scale tool
Tape Measure tool
Zoom tool
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Modeling Complex 3D Shapes with the Solid Tools
With SketchUp’s Solid tools, you can create new shapes by combining or cutting one shape
with another, making it easy to model an outer shell or joinery.
Note: The Solid Tools are also included with a Shop subscription in SketchUp for Web. To learn
more about the features in the Shop subscription, see SketchUp for Web: Free vs. Shop.
In SketchUp, a solid is any 3D model (component or group) that has a finite closed volume. A
SketchUp solid cannot have any leaks (missing faces or faces that do not meet at an edge).
The following image contains several solids.

Tip: To check whether your group or component is a solid entity, context-click it and
choose Entity Info. In the Entity Info dialog box that appears, the upper-left corner indicates
if the selection is a solid, as shown in the figure. If you’re having trouble identifying leaks that
prevent your model from working as a solid entity, try searching the Extensions Warehouse for
a third-party plugin designed to help with this problem.
Check out the following table for a quick introduction to the Solid Tools, including what the tool
does and whether it’s available in SketchUp Free.
Tool Name
Outer
Shell
Union
Subtract
Trim

What It Does
Included in SketchUp Free?
Leaves only the outer faces of overlapping
Yes
solids.
Combines two or more solids into a single
Paid subscriptions only
form.
Paid subscriptions only. In
One solid removes part of another and is
SketchUp Free, use Intersect
deleted.
with Model.
One solid trims another but remains in the
Paid subscriptions only
model.
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Intersect

Leaves only the intersecting geometry.

Paid subscriptions only

Split

Splits solids along intersecting geometry.

Paid subscriptions only

To find the Solid Tools, look in the following parts of the SketchUp interface:
•
•
•

Solids toolbar
Tools menu (Select Tools > Outer Shell or Select Tools > Solid Tools and select the
other tools from a submenu)
Tool palette (Apple macOS)

In the following video, you see examples of the Solid tools in action. In the following sections
of this article, you will find steps and details about using each tool. (Note, however, that you
can't place SketchUp models in Google Earth anymore.)
Table of Contents
1.
2.
3.
4.
5.
6.

Creating an outer shell
Uniting solids into a single form
Subtracting one solid from another (or use Intersect Faces with Model)
Trimming one solid with another
Leaving only the intersecting geometry
Splitting solids

Creating an outer shell
The Outer Shell tool (
) removes geometry inside overlapping groups or components,
leaving only the outer faces.
Tip: Because an outer shell reduces a model’s geometry, creating an outer shell is helpful when
you need to boost SketchUp’s performance.
For example, say you have two models: One is a detailed interior and exterior building model.
The other model illustrates the building in a street view that shows surrounding buildings,
streets, and landscaping. You can import the detailed building model into your street view.
However, all that geometry might slow down your street view model and isn’t necessary. In
your street view, creating an outer shell of the building eliminates the interior geometry you
don’t need so that your street view model is lighter and renders faster as you work on it.
To create an outer shell from overlapping groups or components, follow these steps:
1. With the Select tool (
), select all the intersecting groups or components you want
to include in your outer shell.
2. Context-click your selection and choose Outer Shell from the menu that appears, as
shown in the figure. The outer faces remain.
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Or, you can create an outer shell as follows:
1. Select the Outer Shell tool (

).

Tip: Until you hover over a solid group or component, you see an arrow cursor with a
circle and a slash. When your cursor hovers over a solid group or component, the red
circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid
Component ScreenTip.
2. Click to select the first group or component in your outer shell.
3. Click the second group or component. SketchUp combines your selections into an outer
shell so that only the outer faces remain.
4. (Optional) Continue clicking additional groups or components to add them to your outer
shell, as shown in the figure.
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Note: The result of an outer shell is similar to the result of a union. However, the result of an
outer shell contains only external faces, whereas a union can also contain internal geometry.
The following figure shows two square tubes on the left, a union of the tubes in the center, and
an outer shell of the tubes on the right.

Uniting solids into a single form
A union merges two or more solid entities into a single solid.
The result of a union is similar to the result of an outer shell. However, the result of a union
can contain internal geometry whereas an outer shell contains only external faces. (See the
preceding figure for an example.)
Here’s how to use the Union tool to combine solid entities:
1. Select the Union tool (

).

Tip: Until you hover over a solid group or component, you see an arrow cursor with a
circle and a slash. When your cursor hovers over a solid group or component, the red
circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid
Component ScreenTip.
2. Click to select the first group or component for the union.
3. Click the second group or component. The resulting union of the geometry remains.
4. (Optional) Continue clicking additional groups or components to add them to the union,
as shown in the figure, which uses X-Ray view so that you can see the geometry within
each solid.
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Tip: Instead of following the preceding steps, you can preselect the groups or components with
the Select tool, context-click your selection, and choose Solid Tools > Union from the menu
that appears.

Subtracting one solid from another (or use Intersect Faces with
Model)
With the Subtract tool, you can use one solid entity to cut another solid entity. Your original
solid entity is then subtracted from the model. For the subtraction to work, the two solids need
to overlap.
Tip: When you use the Subtract tool, the order in which you select each solid entity matters.
To remember which solid to select first, just think, “Use this to cut that.” In other words, the
first solid you select is your cutting tool. The second solid you select is the thing that is cut.
To perform a subtraction, follow these steps:
1. Select the Subtract tool (

).

Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle
and a slash. When your cursor hovers over a solid group or component, the red circle and slash
change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
2. Click to select the cutting group or component. In the example shown here, select the
peg first to make a hole in the board. After you make a selection, the 1 next to the
cursor becomes a 2.

3. Click the group or component that you want to cut. The cutting group disappears, but
makes a hole in the second selection. In this example, you see a peg-sized hole in the
board.

SketchUp Help Pages – version 19.

Page 125/567

Tip: Instead of following the preceding steps, you can preselect your solid entities, contextclick the selection, and choose Solid Tools > Subtract from the menu. SketchUp uses the
order in which you select each solid entity to determine which is the cutting entity and which
entity is cut.
If you’re using SketchUp Free, you can create the effect of a subtraction by using the Intersect
with Model command. When you use Intersect with Model, the two shapes don’t need to be
solid entities. (If fact, Intersect with Model applies a different effect if your shapes are solids,
as explained a little later in this section.) However, when you create a subtraction with the
Intersect with Model command, the process requires a few more steps than the process with
SketchUp Pro’s Subtract tool.
Here’s how to create a subtraction with the Intersect with Model command:
1. Create two distinct volumes, such as a box and a cylinder. (See Drawing Basic
Shapes and Pushing and Pulling Shapes into 3D for help.)
2. With the Select tool (
), triple-click the first volume, which will be your cutting
object. In this example, the cutting object is the cylinder, as shown in the figure.
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3. Move and rotate your cutting shape so that it intersects with the shape you’d like to cut.
(See Moving Entities Around and Flipping and Rotating for help.) Leave your cutting
shape selected, as shown in the figure.

4. Context-click the cutting shape, and choose Intersect Faces > With Model from the
menu that appears. The command tells SketchUp to create edges where the two shapes
intersect.
5. With the Eraser tool (
), erase or move the geometry that you don’t want to keep.
In the following figure, you see how the box shape is changed after the cylinder is
erased.
Tip: Remember you can hold down the scroll wheel on your mouse to temporarily switch
to the Orbit tool, so you can orbit around and find all the geometry you want do delete.
(See Erasing and Undoing for details about the Eraser tool.)

Intersect with Model creates edges in the current context. If your shapes are groups or
components, you can create the intersecting lines either within the group or outside it. When
you create the intersecting lines outside a group’s context, you can easily separate your original
shapes from the edges that SketchUp creates, as shown in the following figure. See Organizing
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a Model for details about groups and Adding Premade Components
Components for an introduction to groups and components, respectively.

and

Dynamic

Trimming one solid with another
With the Trim tool, you cut one solid entity with another, just like a subtraction. However, when
you use the Trim tool, the cutting solid remains in the model. So, if you use a peg to trim a
board, the peg remains after it cuts the board. Like all the Solid tools, the Trim tool works only
if two solid entities overlap.
Tip: When you use the Trim tool, the order in which you select each solid entity matters. To
remember which solid to select first, just think, “Use this to cut that.” In other words, the first
solid you select is your cutting tool. The second solid you select is the thing that is cut.
To perform a trim, follow these steps:
1. Select the Trim tool (

).

Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle
and a slash. When your cursor hovers over a solid group or component, the red circle and slash
change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
2. Click to select the cutting group or component. In the example shown here, select the
peg first to make a hole in the board. After you make a selection, the 1 next to the
cursor becomes a 2.
3. Click the group or component that you want to cut. The cutting group remains, but
makes a hole in the second selection. The result is hard to see at first (refer to Callout
1). However, move the peg out of the hole, as shown in Callout 2, and you see the hole
in the board.
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Leaving only the intersecting geometry
With SketchUp Pro’s Intersect tool (
), you select two or more overlapping solid entities,
and only the intersecting geometry is left behind.
To perform an intersection, follow these steps:
1. Select the Intersect tool (

).

Tip: Until you hover over a solid group or component, you see an arrow cursor with a
circle and a slash. When your cursor hovers over a solid group or component, the red
circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid
Component ScreenTip.
2. Select a solid entity that you want to use in the intersection.
3. Select one or more additional solids that overlap your initial selection. The resulting
intersecting geometry remains. In this example, the intersection of the box and the
sphere (Callout 1) creates a point with a rounded base (Callout 2).

Tip: Alternatively, you can preselect the solids you want to intersect. The context-click your
selection and choose Solid Tools > Intersect from the menu that appears.

Splitting solids
With the Split tool (

), you can divide overlapping solid entities along their intersecting
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edges. To perform a split, follow these steps:
1. Select the Split tool (

).

Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle
and a slash. When your cursor hovers over a solid group or component, the red circle and
slash change to a black 1 inside a circle, and you see a Solid Group or Solid Component
ScreenTip.
2. Click a solid entity.
3. Click another solid entity that intersects your first selection. SketchUp splits all the
geometry along the edges where the selected solids intersect. For example, in the
figure, the two groups shown on the left split into 3 groups, as shown on the right.

SketchUp Help Pages – version 19.

Page 130/567

Adding Text, Labels, and Dimensions to a Model
Can you imagine Johannes Gutenberg, inventor of the printing press, learning how to create
3D models in SketchUp? Hopefully, he’d like the way SketchUp advances his groundbreaking
invention — especially the text that moves and (in some cases) updates as you work on your
model.
In SketchUp, you can add four types of text, each depicted in the following figure:
•

•
•
•

Screen text: The most basic text in SketchUp, screen text (Callout 1) is fixed to the
screen regardless of how you manipulate or orbit a model. Screen text is not attached
to any entity. You might use it to label a model as a whole, such as “Bodega model,
front exterior view.”
Leader text: A leader is the line or arrow pointing to a model entity. Predictably, leader
text (Callout 2) has a leader line that points to a specific entity in your model. Use leader
text for descriptive text, such as, “Metal roof.”
3D text: 3D text (Callout 3) is made of actual edges and faces that become part of your
model. You might use 3D text to show numbers on the front of a house or door.
Dimensions: When you want to indicate a length, radius, or diameter, use the
Dimension tool to create a dimension entity (Callout 4). A dimension entity, which is
linked to the line, circle, or arc entity you choose, displays a measurement automatically
and updates that measurement dynamically as you work on your model.

You create different types of text with different tools:
•

Create screen text and leader text with the Text tool (

•

Add 3D text with the 3D Text tool (

•

Mark dimensions with the Dimension tool (

).
).

).
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For details about creating each type of text, check out the videos and read the sections that
walk you through the steps. The following video introduces how you create screen text, leader
text, and 3D text.
Because dimensions are dynamic, they have special properties and work a bit differently from
the other types of text. Watch the following video to see dimensions in action.
Table of Contents
1.
2.
3.
4.

Typing screen text
Pointing to an entity with leader text
Placing 3D text in your model
Marking dimensions dynamically

Typing screen text
Screen text is so-named because it remains fixed to a point on your screen as you draw and
orbit your model. You create screen text with the Text tool (
following parts of the SketchUp interface:
•
•
•
•
•

), which you find in the

Getting Started toolbar
Construction toolbar
Large Tool Set toolbar
Tools > Text on the menu bar
Tool palette (Apple macOS)

To create and place screen text, follow these steps:
1. Select the Text tool (
). The cursor changes to an arrow with a text prompt.
2. Click a blank area where you want the screen text to appear. In the example, that’s the
upper-left corner of the drawing area.
3. Type your text in the text entry box that appears, as shown in the figure.
4. To complete the text entry, click outside the text box, or press Enter twice.
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To edit screen text, select the Text tool or Select tool and double-click the text. Or contextclick a text entity and select Edit Text from the menu that appears.
You can change the text properties, such as font, size, and so on, for individual screen text
entities or all the screen text in your model:
•

•

To change a single entity’s text properties: Context-click the text entity and
choose Entity Info. Change the text color using the swatch on the left. Click
the Change Font button to choose a different font, style, or point size. You see the
Entity Info panel in the following figure.
To change the properties of all the screen text in your model at once: From the
menu bar, select Window > Model Info. Select Text in the sidebar on the left. In the
Screen Text area on the right, click the Fonts button to adjust the font, style, or point
size. Click the Select All Screen Text button and then click the Update Selected
Text button. Use the color swatch to set the default text color. You see the Model Info
dialog box in the following figure.

Pointing to an entity with leader text
Leader text contains characters and a leader line that points to an entity. Text leaders are tied
to the model, and by default, as you rotate the model, you can still see the text as long as the
arrow is visible. As you move and adjust surfaces, the notes attached to those surfaces adjust
with them.
You create leader text with the Text tool (
SketchUp interface:
•
•
•
•
•

Getting Started toolbar
Construction toolbar
Large Tool Set toolbar
Tools > Text on the menu bar
Tool palette (Apple macOS)

), which you find in the following parts of the
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To create and place leader text, follow these steps:
1. Select the Text tool (
).
2. Click the entity to which you want the leader to point, as shown in the following figure.

3. Move the cursor to position the text. The leader line grows and shrinks as you move the
cursor around the screen. To start over, press Esc at any time.
4. Click to place the text. A text entry box appears with default text, such as the name of
a component (if the ending point of the leader line is attached to a component), or the
square footage of a square (if the ending point of the leader line is attached to the face
of a square).
5. (Optional) To change the default text, click in the text box and type new text.

6. To complete the leader text entry, click outside the text box, or press Enter twice.
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Tip: Double-click on any face, while in the Text tool, to display the area of the face as a Text
entity.
You can edit the following aspects of a leader text entity:
•

•

•

Text properties: Editing text properties (font, size, and so on) for leader text works
almost the same as for screen text; see the screen text section earlier in this article for
details. To change the default leader text properties in the Model Info dialog box, simply
use the Leader Text section instead of the Screen Text section.
Leader style: The default leader style is Pushpin. A Pushpin leader is aligned in 3D
space, and rotates with your model as you change your view. You can change the leader
style to View Based or Hidden. A View Based leader retains its 2D screen orientation,
so it doesn’t rotate as you orbit your model, as shown in the following figure.
See Softening, Smoothing, and Hiding Geometry for details about hidden geometry.
Arrow style: The default arrow style is a closed arrow. For the arrow style, you can
choose None, Dot, Closed, or Open.

To edit the leader line and arrow style for a single leader text entity, context-click the entity
and choose an option from the Leader or Arrow submenu. Or context-click and select Entity
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Info to open the Entity Info dialog box, where you can edit each option.
To change edit the leader line and arrow style for all leader text entities, select Window >
Model Info. In the Model Info dialog box, select Text in the sidebar on the left and use the
Leader Lines area to select your options. Remember to click the Update Selected Text button
at the bottom to apply your changes. (Although the button refers only to text, you need to click
the button to update the leader, also.)

Placing 3D text in your model
The 3D Text tool generates geometry from text that you type. Create 3D text when the text
isn’t a label but part of your actual model — such as house numbers, an engraving, or
meaningful initials that decorate a room.
Here’s where you find the 3D Text tool (
•
•
•
•

) in the SketchUp interface:

Construction toolbar
Large Tool Set toolbar
Tools > 3D Text on the menu bar
Tool palette (Apple macOS only)

To create 3D text, follow these steps:
1. Select the 3D Text tool (
the following figure.

). The Place 3D Text dialog box appears, as shown on in

2. Type text in the large text field at the top. If you need to cancel and start over at any
time, press Esc.
3. (Optional) Modify settings in the Place 3D Text dialog box. You can choose a font, regular
or bold text, and an alignment. To change the height, type a value and unit or use the
default units. Leave the Filled checkbox selected to create faces for 3D text. Uncheck
the Filled checkbox to create 2D text outlines (just edges). Leave the Extruded checkbox
to create extruded (push/pull) 3D text and enter a value in the Extruded box to size the
extrusion precisely. Uncheck the Extruded checkbox to create 2D text.
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4. Click the Place button. SketchUp switches to a move operation with the 3D text and
the move tool.
5. In the model drawing area, click to place the 3D text. (See Moving Entities Around for
details about placing geometry with the Move tool.) Zoom in close, and you can see that
the house numbers are made of 3D geometry, as shown in the following figure.

Tip: To create engraved text, enter a negative value in the Extruded box in Step 3. After you
place your text, explode the group. (Context-click it and select Explode.) Then select each line
and press Delete.

Marking dimensions dynamically
With the Dimension tool, you create dimension entities: finite lines with length information that
enables you to quickly and effectively communicate key model dimensions. Dimension entities
move and update automatically as you create your model.
The Dimension tool (
•
•
•
•

) hangs out in the following areas of the SketchUp interface:

Construction toolbar
Large Tool Set toolbar
Tools > Dimensions on the menu bar
Tool palette (Apple macOS)

Before you create a dimension entity, it’s helpful to know a few basics about how the Dimension
tool works:
•
•

You can start and end a dimension at any of the following points: end points, midpoints,
on-edge points, intersections, and arc and circle centers. As you hover your mouse,
the SketchUp inference engine helps you identify these points.
You can take dimensions in one of several planes. You can pull a dimension string into
the red-green, red-blue, or blue-green plane. You can also align a dimension to the
plane of the edge that you’re measuring. Radius and diameter dimensions are limited
to the plane defined by the arc or circle. After you place a dimension in a plane, you can
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move the dimension only within that plane.
You can create a dimension entity for the length of a line, the diameter of a circle entity,
or the radius of an arc.

To create dimensions, follow these steps:
1. Select the Dimension tool (
). The cursor changes to an arrow.
2. Click the starting point of your dimension.
3. Move the cursor along the entity you want to dimension until the inference engine
highlights your desired ending point.
4. Click the ending point of your dimension.
5. Move the cursor perpendicular to your selected entity to pull out a dimension entity, as
shown in the figure. You may need to orbit in order to place the dimension entity in your
desired plane. Remember that you can hold down the mouse scroll wheel to switch
temporarily to the Orbit tool.
6. Click to place the dimension entity.

Tip: To take a dimension of a single line, simply click the line and move the cursor.
After you create a dimension, you can edit its placement, the text appearance, and a few other
properties. Here’s a quick look at your options:
•
•
•
•
•
•

Toggle a radius or a diameter. Context-click a radius or diameter dimension and
select Type > Radius or Type >Diameter from the menu that appears.
Reposition text in a linear dimension. You can align text centered in, outside the
start of, or outside the end of the dimension. The red dimension in the figure is centered.
Change the dimension entity’s color. Click the color swatch in either the Entity Info
or Model Info dialog box to select a new color.
Change the font properties. You can change the font and choose regular or bold text.
Select a font size in points or use a height measurement instead. All the dimensions in
the following figure have different colors and fonts.
Align the text to the dimension or the screen. By default, the dimension text is
aligned to the dimension. The radius dimension on the pie shape shows the screen
alignment.
Choose an endpoint style. By default, the dimension end point is a slash. You can
change it to a dot, closed arrow, open arrow, or none. The radius dimension shows a
dot. The diameter shows open arrows. The cube shows the default slash style.
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To change these attributes for a single dimension entity, select the dimension with
the Select tool, context-click your selection, and choose Entity Info. You find all the preceding
options in the Entity Info dialog box that appears.
To change these attributes for all you dimensions, or to set new default options,
choose Window > Model Info. In the Model Info dialog box, select Dimensions in the
sidebar on the left. After selecting the properties you want, click the Select All
Dimensions button to do just what the button says. Click the Update Selected
Dimensions button to apply your changes.
Warning: You have the option of changing the text and entering a dimension manually. If you
do so, the dimension no longer updates dynamically. To identify broken dimension associations,
open the Model Info dialog box and click the Expert Dimension Settings button. In the dialog
box that appears, select the Highlight Non-Associated Dimensions checkbox. Any broken
dimensions associations are highlighted in red.
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Adjusting the Drawing Axes
Adjusting the SketchUp drawing axes makes drawing a 3D model easier in several scenarios:
•
•

•

•

Using tools, such as the Scale tool, that modify geometry based on the drawing
axes: When you align the edges that you want to modify with the axes, you can modify
your geometry a little more easily.
Tracing a floor plan to create a 3D model of it: When the edges of a rectangular
floor plan align with the red and green axes, you can trace your floor plan more easily.
That’s because the SketchUp inference engine highlights edges that are parallel to an
axis as you draw them with the Line tool, as shown in the figure.
Geolocating a model on terrain (most often done on a TIN, or triangulated
irregular network): If you’re drawing a geolocated model, you probably want to align
the drawing axes to the cardinal directions that those axes represent. Doing so helps
you situate your model on the terrain correctly. (If you’re not familiar with these
modeling techniques, learn more about modeling terrain and working with TINs.)
Casting realistic shadows: If you geolocate your model, you can also see how your
model looks at different times of day. This is another situation when aligning the axes
to the cardinal directions is helpful.

SketchUp enables you to reposition the drawing axes in a few different ways:
•
•
•

Click with the mouse.
Align the axes to a face.
Move and rotate the axes relative to their current position.

Other times, you may want to hide the drawing axes. For example, in a finished model of a
chair or even a house or street scene, the drawing axes may distract from your final model,
rather than help you draw it.
For specifics about adjusting or hiding the drawing axes, see the relevant sections in this article.
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Aligning the drawing axes with the cardinal directions

Moving and rotating the drawing axes
Here, you find detailed steps for adjusting the drawing axes with the mouse or via the options
on drawing axes context menu.
Tip: Before you adjust the drawing axes, find the best view of your model. Often, that’s a
corner to which you want to align the axes, either from the top or the side. You can orbit around
or select an option from the Camera > Standard views submenu. (See Viewing a Model for a
more in-depth look at your viewing options.)
To adjust the axes with your mouse, follow these steps:
1. Select the Axes tool (
). You find the Axes tool on the Construction toolbar, the
Large Tool Set toolbar, or the Tool palette (Apple macOS only). Alternatively, you can
activate the Axes tool by choosing Tools >Axes, or context-clicking an empty space on
an axis and choosing Place from the menu that appears.
2. Click to place the axes origin point. Typically, you want to set the origin point at the
bottom corner of an object in your model, as shown in the following figure. After you
click, a dotted red axis extends from your mouse cursor.
3. Click to place the green axis. If you adjusted your view to see the edge you want to
align to the red axis, then the dotted green axis might be hard to see. However, the
SketchUp inference engine displays Parallel to Edge inference when you hover over an
edge, even if that edge is hidden in your current view.
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Tip: As you reorient the drawing axes, keep an eye on the blue axis. Unless you want to flip
your model (and the flip and rotate features offer better ways to do that), make sure the blue
axis points up. It is possible for it to point down or to the side as you hover the mouse cursor
around looking for new axis points.
To align the axes to a face, context-click the face and choose Align Axes from the menu that
appears.
The following figure illustrates how the face you context-click reorients the axes:
•
•

If you select a face in the blue-red or blue-green plane (Callout 1), you rotate the
axes 90 degrees. Notice how the green axis points up (Callout 2) and the blue axis turns
on its side, relative to the box.
If you select a face in the red-green plane (Callout 3), the axes don’t rotate, but
the ground plane becomes aligned to the selected plane (Callout 4).

Because of this behavior, the Align Axes command is often useful when you’re drawing a 3D
model from a 2D shape that’s currently on the ground plane. Select the 2D face on the ground
plane, and the drawing axes become aligned to the lower-left corner before you start drawing
in 3D, as shown in the following figure.
(cont’d next page)
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To move and rotate the axes relative to their current position, follow these steps:
1. Context-click an empty area on an axis and choose Move from the menu that appears.
2. In the Move Sketching Context dialog box that appears (shown in the following figure),
enter how far you want to move and rotate each axis. SketchUp uses the units specified
in your template. (To see or change the units, select Window > Model Info and
select Units in the sidebar on the left. Then choose a new measurement unit.)
3. Click the OK button.

In this video10, see how repositioning the drawing axes works and learn a few tips to help you
use the different methods.

Resetting the drawing axes
If you’ve been moving the drawing axes hither and yon, you can move the axes back to their
10

https://youtu.be/43sK5hk3aAY
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default position pretty easily. Simply context-click an axis and choose Reset from the menu
that appears, as shown in the figure.

Hiding the drawing axes
SketchUp enables you to hide the drawing axes in two ways:
•
•

Context-click an open area on an axis and select Hide from the menu that appears.
Select View > Axes from the menu bar. When a check mark appears next to the Axes
menu item, selecting this option clears the Axes menu item and the axes are hidden
from view.

To see the hidden drawing axes again, select View > Axes, which selects the Axes option.

Aligning the drawing axes with the cardinal directions
Each axis has a solid line on one side of the origin and a dotted line on the other side of the
origin. The solid blue line leads up from the origin and the dotted blue line leads down. The
remaining lines correspond to one of the cardinal directions (north, south, east, west). The
following table outlines how each line corresponds to a cardinal direction, leading from the axes
origin point.
Line
Solid green line
Dotted green line
Solid red line
Dotted red line

Direction
North
South
East
West
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Customizing Your Model’s Background
In SketchUp, you see a tan and blue background that suggests the earth and sky. The default
background might be great for buildings, but looks a little strange for a model of a rocking
chair, as shown in the upper-left corner of the figure. No matter what you’re modeling, you
may just want a plain background with sketchy edges to communicate that your model is a
blueprint or prototype. Or you may want a polished and detailed background that simulates an
interior or a street scene.
Notice how the different backgrounds change the look of the model in the figure.

So how do you customize the background of your 3D model? As with most things in SketchUp,
you have a couple of options:
•
•

Styles: Choose from preset styles or mix your own style in the Styles panel.
See Choosing a Style for details.
Images: SketchUp enables you add image files to your model and position those
images so that they act as a background. For example, you can have a single image
placed vertically behind a house so that you can study what will be seen from certain
angles within the house. A more advanced technique is applying an image as a projected
texture to a curved face that you place behind a model, so you can see through more
windows of an interior model. The articles you find in Applying Colors, Photos, Materials,
and Textures explain the concepts and techniques you need to know in order create
these image effects.

•

Letting the Fog Roll into Your Model
Fog is primarily used as a special effect during presentations. The fog effect mimics real fog,
as shown in the figure, so your 3D model becomes clearer as you zoom closer to it, and less
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clear as you move away.

To add fog-like effects to your model, follow these steps:
1. The Fog dialog box appears, as shown in the following figure.
2. Select the Enable Fog checkbox.
3. (Optional) Click and drag the Distance sliders to adjust the fog relative to the camera
(your current view). Here’s how the sliders work:
4. The left-most fog slider determines where the fog starts. At zero, fog begins right in
front of the camera. Moving this slider to the right starts fog somewhere beyond the
camera.
5. The right-most slider determines where the fog is at 100% strength (known as zero
visibility). Move the right-most slider to the left to establish 100 percent strength closer
to the camera. If you move this slider all the way to the left, zero visibility extends info
infinity, and you can’t see your model at all and at any distance.
6. (Optional) Clear the Use Background Color checkbox and click the color swatch to
select a fog color.

Tip: Because fog appearance is based on your current view relative to the camera, the fog
sliders move as you orbit and zoom.

SketchUp Help Pages – version 19.

Page 146/567

Modeling Shapes, Objects, and Building Features in
3D
To create a 3D model in SketchUp, you’re constantly switching among the drawing tools, views,
components, and organizational tools. In this article, you find several examples that illustrate
ways you can use these tools together to model a specific shape or object.
The examples illustrate a few of the different applications for creating 3D models in SketchUp:
woodworking, modeling parts or abstract objects, and creating buildings. The examples are
loosely ordered from the simple to the complex.
Table of Contents
1.
2.
3.
4.
5.
6.

Drawing a chair
Drawing a bowl, dome, or sphere
Creating a cone
Creating a pyramidal hipped roof
Modeling a building from a footprint
Creating a polyhedron

Drawing a chair
In the following video, you see three ways to draw a 3D model of a chair. In the first two
examples, you see two methods for creating the same chair:
•

Subtractive: Extrude a rectangle to the height of the chair. Then use the Push/Pull tool

•

(
) to cut away the chair shape.
Additive: Start by modeling the chair seat. Then extrude the back and the legs with
the Push/Pull tool.

In the third example, you see how to create a more detailed and complex model, using
components to simplify modeling the chair legs and rungs on the back of the chair.
Tip: You can use the tips and techniques demonstrated in these chair examples to create all
sorts of other complex 3D models.

Drawing a bowl, dome, or sphere
In this example, you look at one way to draw a bowl and how to apply the technique for creating
a bowl to a dome or sphere.
In a nutshell, to create bowl, you draw a circle on the ground plane and a profile of the bowl’s
shape directly above the circle. Then you use the Follow Me tool to turn the outline into a bowl
by having it follow the original circle on the ground plane.
Here’s how the process works, step-by-step:
1. With the Circle tool (
), draw a circle on the ground plane. These steps are easier if
you start from the drawing axes origin point. The size of this circle doesn’t matter.
2. Hover the mouse cursor over the origin so that the cursor snaps to the origin and then

SketchUp Help Pages – version 19.

Page 147/567

move the cursor up the blue axis.
3. Starting from the blue axis, draw a circle perpendicular to the circle on the ground plane
(that is, locked to the red or green axis). To encourage the inference, orbit so that the
green or red axis runs approximately left to right along the screen. If the Circle tool
doesn’t stay in the green or red inference direction, press and hold the Shift key to lock
the inference. The radius of this second circle represents the outside radius of your bowl.
4. With the Offset tool (
), create an offset of this second circle. The offset distance
represents the bowl thickness. Check out the following figure to see how your model
looks at this point.

5. With the Line tool (
), draw two lines: one that divides the outer circle in half and
one that divides the inner circle that you created with the Offset tool.
6. With the Eraser tool (
), erase the top half of the second circle and the face that
represents the inside of the bowl. When you’re done, you have a profile of the bowl.
7. With the Select tool (
), select the edge of the circle on the ground plane. This is the
path the Follow Me tool will use to complete the bowl.
8. With the Follow Me tool (
), click the profile of the bowl. Your bowl is complete and
you can delete the circle on the ground plane. The following figure shows the bowl profile
on the left and the bowl on the right.
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Note: Why do you have to draw two lines to divide the offset circles? When you draw a circle
using the Circle tool (or a curve using the Arc tool, or a curved line using the Freehand tool),
you are actually drawing a circle (or arc or curve) entity, which is made of multiple-segments
that act like a single whole. To delete a portion of a circle, arc, or curve entity segment, you
need to break the continuity. The first line you draw creates endpoints that break the
segments in the outer circle, but not the inner circle. Drawing the second line across the inner
circle breaks the inner circle into two continuous lines.
You can use these same steps to create a dome by simply drawing your profile upside down.
To create a sphere, you don’t need to modify the second circle to create a profile at all. Check
out the following video see how to create a sphere.

Creating a cone
In SketchUp, you can create a cone by resizing a cylinder face or by extruding a triangle along
a circular path with the Follow Me tool.
To create a cone from a cylinder, follow these steps:
1. With the Circle tool, draw a circle.
2. Use the Push/Pull tool to extrude the circle into a cylinder.
3. Select the Move tool (
).
4. Click a cardinal point on the top edge of the cylinder, as shown on the left in the figure.
A cardinal point is aligned with the red or green axis and acts as a resize handle. To find
a cardinal point, hover the Move tool cursor around the edge of the top cylinder; when
the circle edge highlighting disappears, this indicates a cardinal point.
5. Move the edge to its center until it shrinks into the point of a cone.
6. Click at the center to complete the cone, as shown on the left in the figure.
(cont’d next page)
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Here are the steps to model a cone by extruding a triangle along a circular path:
1. Draw a circle on the ground plane. You’ll find it’s easier to align your triangle with the
circle’s center if you start drawing the circle from the axes origin.
2. With the Line tool (
), draw a triangle that’s perpendicular to the circle. (See the
left image in the following figure.
3. With the Select tool (

), select the face of the circle.

4. Select the Follow Me tool (
) and click the triangle face, which creates a cone
almost instantaneously (as long as your computer has the sufficient memory). You can
see the cone on the right in the following figure.

Creating a pyramidal hipped roof
In SketchUp, you can easily draw a hipped roof, which is just a simple pyramid. For this
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example, you see how to add the roof to a simple one-room house, too.
To draw a pyramid (pull up a pyramidal hipped roof):
1. With the Rectangle tool (
), draw a rectangle large enough to cover your building.
To create a true pyramid, create a square instead of a rectangle. The SketchUp inference
engine tells you when you’re rectangle is a square or a golden section.
2. With the Line tool (
), draw a diagonal line from one corner to its opposite corner.
3. Draw another diagonal line from one corner to another. In the figure, you see how the
lines create an X. The example shows the faces in X-Ray view so you can see how the
rectangle covers the floor plan.

4. Select the Move tool (
) and hover over the center point until a green inference point
is displayed.
5. Click the center point.
6. Move the cursor in the blue direction (up) to pull up the roof or pyramid, as shown in
the figure. If you need to lock the move in the blue direction, press the Up Arrow key
as you move the cursor.
7. When your roof or pyramid is at the desired height, click to finish the move.
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Tip: When you’re creating a model of house or multistory building, organize the walls and roof
or each floor of your building into separate groups. That way, you can edit them separately, or
hide your roof in order to peer into the interior floor plan. See Organizing a Model for details
about groups.

Modeling a building from a footprint
In SketchUp, the easiest way to start a 3D building model is with its footprint. After you have
a footprint, you can subdivide the footprint and extrude each section to the correct height.
Here are a few tips for finding a building’s footprint:
•

•

If you’re modeling an existing building, trace the outline of the building with the drawing
tools. Unless the building is obscured by trees, you can find an aerial photo on Google
Maps and trace a snapshot. From within SketchUp, you can capture images from Google
and load them directly into a model, as shown in the following figure.
If you don’t have an aerial photo of the existing building you want to model, you may
need to try the old fashioned route: measuring the exterior to create the footprint and
drawing the footprint from scratch. If literally taking measurements of an entire building
is impractical, you can employ tricks such as using the measurement of a single brick
to estimate overall dimensions or taking a photo with an object or person whose length
you do know. See Measuring Angles and Distances to Model Precisely for more details.
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If you’re able to start with a snapshot of your footprint, the following steps guide you through
the process of tracing that footprint. First, set up your view of the snapshot:
1. Select Camera > Standard Views > Top from the menu bar.
2. Select Camera > Zoom Extents to make sure you can see everything in your file.
3. Use the Pan and Zoom tools to frame a good view of top of the building that you want
to model. You need to be able to see the building clearly in order to trace its footprint.
See Viewing a Model for details about using these tools.
4. Choose View > Face Style > X-Ray from the menu bar. In X-Ray view, you can see
the top view of the building through the faces that you draw to create the footprint.
After you set up your snapshot, try the techniques in the following steps to trace the building
footprint:
1. Set the drawing axes to a corner of your building. See Adjusting the Drawing Axes for
details.
2. With the Rectangle tool (
), draw a rectangle that defines part of your building. Click
a corner and then click an opposite corner to draw the rectangle. If your building outline
includes non–90-degree corners, curves or other shapes that you can’t trace with the
Rectangle tool, use whichever other drawing tools you need to trace your building’s
footprint.
3. Continue drawing rectangles (or lines and arcs) until the entire building footprint is
defined by overlapping or adjacent rectangles, as shown on the left in the following
figure. Make sure there aren’t any gaps or holes; if there are, fill them in with more
rectangles.
4. With the Eraser tool (

), delete all the edges in the interior of the building footprint.
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When you’re done, you should have a single face defined by a perimeter of straight
edges. You may want to turn off X-Ray view, as shown on the right in the following
figure, in order to see your faces and final footprint clearly.

5. Some simple buildings have a single exterior wall height, but most have more than one.
After you complete the footprint, use the Line tool to subdivide your building footprint
into multiple faces, each corresponding to a different exterior wall height, as shown in
the following figure. Then, you can use the Push/Pull tool (
to the correct building height.

) to extrude each area

Creating a polyhedron
In this example, you see how to create a polyhedron, which repeats faces aligned around an
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axis.
To illustrate how you can create a complex shape with basic repeating elements, this example
shows you how to create a polyhedron called a rhombicosidodecahedron, which is made from
pentagons, squares, and triangles, as shown in the figure.

The following steps explain how to create this shape by repeating faces around an axis:
1. Establish the correct angle between the first square and the pentagon, and between the
first triangle and the square. See Measuring Angles and Distances to Model Precisely for
details about measuring angles with the Protractor tool.
2. Mark the exact center point of the pentagon, which is shown here on a green surface
that has been temporarily added to the pentagon component. This is the axis around
which the copies will be aligned.

3. Make the square and triangle components, and then group the two components. For
details about components, see Developing Components and Dynamic Components. To
learn about groups, see Organizing a Model.
4. Preselect the objects that you want to copy and rotate (in this case, the group you just
created).
5. Select the Rotate tool (
).
6. Align the Rotate cursor with the pentagon face and click the center point of the
pentagon, as shown in the following figure.
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7. Click the Rotate cursor at the point where the tips of the square, triangle, and pentagon
come together.
8. Press the Ctrl key to toggle on the Rotate tool’s copy function. The Rotate cursor
changes to include a plus sign (+).
9. Move the cursor to rotate the selection around the axis. If you originally clicked the
point where the tips of the square, triangle, and pentagon came together, the new group
snaps into its new position, as shown in the following figure.

10. Click to finish the rotate operation.
11. Continue rotating copies around the axis until the shape is complete. As you build the
rhombicosidodecahedron, you need to group different components together, and rotate
copies of those groups around various component faces.
Tip: If the component you are rotating around is not on the red, green, or blue plane, make
sure the Rotate tool’s cursor is aligned with the face of the component before you click the
center point. When the cursor is aligned, press and hold the Shift key to lock that alignment
as you move the cursor to the center point.
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Viewing a Model
As you create a model in 3D, you need to view it from all sides. In SketchUp, you orbit, zoom,
and pan all the time as you draw:
•
•
•

Orbit: When you orbit, you move around, above, or below your model. Orbiting is like
flying around your model Peter Pan–style.
Zoom: Zoom in to focus on a specific area as you draw, and zoom out to see more of
your model.
Pan: When you pan, you move left, right, up, or down.

Tip: Because you use these tools frequently, SketchUp enables you to switch to each one
temporarily, using a three-button scroll wheel mouse. (You learn the mouse shortcuts later in
this article.) If you do much drawing in SketchUp, a three-button scroll wheel mouse makes
modeling easier than modeling without a scroll wheel or with a one-button mouse.
To see how these tools work, check out the overview in the following video, or read the
upcoming sections for steps that guide you in using these tools. In addition to the navigation
tools, SketchUp includes several standard views, which you find on the Camera menu. In the
following figure, you see how a model looks in each of the standard views: Top (Callout 1),
Bottom (2), Front (3), Back (4), Left (5), Right (6), and Iso (7).
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Tip: When you use the standard views or the more advanced features of the navigation tools,
remember that SketchUp uses the concept of a camera to represent your view. As you switch
and modify your view, it’s as though you’re looking through a camera.
SketchUp’s Camera menu also has three perspective options, shown in the following figure,
that change how you view your model:
•
•
•

Parallel Projection: In this view, lines appear parallel in both 3D and 2D space. This
view is also known as an orthographic view. When you print in this view, line length has
a scale (for example 4’ in SketchUp = 1" on paper). (Callout 1)
Perspective: In this view, lines vanish to a horizon, so certain items appear closer
while other items appear to be far away. Entities are not to scale. This is SketchUp’s
default view. (Callout 2)
Two-Point Perspective: Illustrators often use two-point perspective to draw 3D
buildings and concept art. In SketchUp, choosing this view aligns your perspective so
that the view has two vanishing points. (Callout 3)

Tip: SketchUp can simulate what it’s like to walk through a model and look around. This
technique is often used to present a completed model. You can also save specific views as
scenes, which you can then animate. See Communicating Your Designs for details. If you’re
looking for ways to hide geometry or view hidden geometry, see Softening, Smoothing, and
Hiding Geometry.
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Orbiting around a 3D model
Orbiting enables you to view geometry from the outside. To rotate the camera about a model,
activate the Orbit tool (
•
•
•
•
•

), which you find in the following areas of the SketchUp interface:

Camera > Orbit on the menu bar
Camera toolbar (Microsoft Windows)
Getting Started toolbar
Large Tool Set toolbar
Tool palette (Apple macOS)

Tip: You can temporarily activate the Orbit tool while in any other tool (except the Walk tool):
•
•

On a three-button mouse: Click and hold the scroll wheel.
On a one-button mouse: If you use macOS, press and hold the Control and Command
keys while clicking and holding the left mouse button.

To orbit using the Orbit tool, follow these steps:
1. Select the Orbit tool (
) or press the O key.
2. Click anywhere in the drawing area.
3. Move your cursor in any direction to rotate around the center of the drawing area.
Beyond basic orbiting, the Orbit tool can do a few other tricks:
•
•

To center a model in the drawing area, double-click in the drawing area.
To roll the camera on its side as you orbit, press and hold the Ctrl key (Microsoft
Windows) or Option key (Apple macOS). This suspends the Orbit tool’s built-in sense
of gravity, which keeps vertical edges pointed up and down.

Panning side to side and up and down
When you pan, SketchUp’s camera (your view) moves vertically or horizontally. Here’s where
you find the Pan tool (
):
• Camera > Pan on the menu bar
• Camera toolbar (Microsoft Windows)
• Getting Started toolbar
• Large Tool Set toolbar
• Tool palette (Apple macOS)
Tip: You switch to the Pan tool temporarily while you’re in another tool:
•
On a three-button scroll wheel mouse, hold down the scroll wheel and the left mouse
button.
•
On a one-button mouse or trackpad, press and hold the Control, Command, and Shift
keys simultaneously while holding down the mouse button.
•
On any mouse, if the Orbit tool is selected, press and hold the Shift key.
To pan using the Pan tool, follow these steps:
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1. Select the Pan tool (
) or press the H key.
2. In the drawing area, click and drag the cursor in any direction.

Zooming in and out
In SketchUp, as in many other programs, you can zoom in for an extreme close up, or zoom
out to see the bigger picture. As you draw a 3D model, zooming in can help you align edges
and faces more precisely, whereas zooming out enables you to see your overall model or reorient yourself so you can find a different part of your model to work on.
SketchUp also has two specialized zoom tools, Zoom Extents (
which you learn about later in this section.
In the SketchUp interface, here’s where you find the Zoom tool (

) and Zoom Window (

),

):

• Camera > Zoom on the menu bar
• Camera toolbar (Microsoft Windows)
• Getting Started toolbar
• Tool palette (Apple macOS)
•
Tip: To zoom while using another tool, such as the Line or Move tool, you need a scroll wheel
mouse. Scroll up to zoom in or down to zoom out. When you zoom by scrolling, SketchUp uses
your cursor as the zoom’s center point.
To zoom in and out, follow these steps:
1. Select the Zoom tool (
) or press the Z key.
2. Click and drag up to zoom in; click and drag down to zoom out. When you zoom by
dragging the Zoom tool cursor, SketchUp zooms in or out from the center of the screen.
Note: The zoom speed depends how far your geometry is from the Zoom cursor. When
geometry is farther away, SketchUp zooms quickly. The zoom speed feels slower when your
geometry is relatively close to the Zoom cursor.
To instantly make your whole model visible and centered in the drawing area, click the Zoom
Extents tool (
) or press Shift+Z. You find Zoom Extents in the following corners of the
SketchUp interface:
•
•
•
•
•

Camera > Zoom Extents on the menu bar
Camera toolbar (Microsoft Windows)
Getting Started toolbar
Large Tool Set toolbar
Tool palette (Apple macOS)

To zoom in on a specific rectangular portion of your model, use the Zoom Window tool. (You
find Zoom Window in the same places where you find the Zoom and Zoom Extents tools, with
the exception of the Getting Started toolbar.) To zoom in on a portion of your model:
1. Select the Zoom Window tool (
).
2. Click and drag to make a box appear around the area that you want to zoom in on.
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When you release the mouse button, everything in the box you drew fills the drawing
area.

Changing the field of view or focal length
A lesser-known Zoom tool feature is changing the field of view, or how much of your model
you can see. Because your view in SketchUp is like looking through a camera, you can adjust
the field of view in degrees. Alternatively, change the focal length using millimeters, as you do
in a camera.
Tip: If you’re unfamiliar with the field-of-view concept, think of it this way: Humans have a
field of view that’s about 180 degrees in front of them. If you narrowed that field to 90 degrees,
you’d lose your peripheral vision.
To adjust the field of view or focal length, follow these steps:
1. Select the Zoom tool or press the Z key. You can also select Camera >
View from the menu bar.
2. Type a value in degrees or millimeters, respectively. For example, typing 45
a 45 degree field of view; typing 35 mm sets a focal length equivalent to
camera. Or, to visually adjust the field of view, hold down the Shift key while
the Zoom tool.

Field of
deg sets
a 35mm
dragging

Tip: Wider fields of view are useful when working inside a room, where you might want to
see more of the room as you draw. The following figure shows the same room at two different
fields of view. In the top figure, the field of view is 35 degrees. In the bottom figure, the field
of view is 75 degrees.
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Setting a standard view
You can immediately change the drawing window to any of the standard views by
selecting Camera > Standard Views and selecting your desired view from the submenu. Your
options are as follows: Top (Callout 1), Bottom (Callout 2), Front (Callout 3), Back (Callout 4),
Left (Callout 5), Right (Callout 6), and Iso (Callout 7). See an example of each one in the
following figure.
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Tip: To keep the standard views only a click away, display the Views toolbar. See Customizing
Your Workspace for details.
Note: Iso stands for isometric. In a true isometric view, which is common in technical or
mechanical drawings, a 3D object is drawn in 2D space from a specific angle, so that the angle
between each drawing axis is 120 degrees. However, in SketchUp, the Iso camera view is not
the same as an isometric projection, in which objects along the x, y or z axis are in proportion.
SketchUp’s Iso view simply shows your whole model from a standard angle.
Tip: To quickly align SketchUp’s point of view it's top-down with the axis centered, contextclick a drawing axis and select Align View from the menu that appears.

Returning to a previous view
SketchUp remembers your views as you move from one to the next. To return to the preceding
view, select Camera > Previous. After you return to a view, you can move to a later view by
selecting Camera > Next.
Tip: To keep the Previous command handy, display the Large Tool Set toolbar or the Camera
toolbar. (See Customizing Your Workspace for details.) You can click the Previous tool to move
backward one view at a time.
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Choosing a Style
In the way clothes say something about the people wearing them, SketchUp styles convey
information about your model. The sketchy edges style suggests that your model is still a workin-progress whereas a finished concept might show a full-color mockup of a modern building
with transparent window glass and limestone brick, custom paint colors, and a slanted metal
roof.
Note: Styles are also included with SketchUp for Web, Shop edition. To learn more about the
features in SketchUp Shop, see SketchUp for Web: Free vs Shop.
To add a style to your model the easy way, apply one of many predefined styles to your model.
Each predefined style represents a collection of specific settings for the edges, faces, and
background. To select and apply a predefined style, follow these steps:
1. At the top of the panel that appears, you see the thumbnail, name, and description for
the currently selected style.
2. Click the Select tab (if it’s not already selected).
3. From the Styles Collections drop-down list, select a collection, such as Default Styles,
Color Sets, or Sketchy Edges. In the figure, the Color Sets collection is selected.

4. Click a style thumbnail. The style is applied to your model and the drawing area, as
shown in the following figure.
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If the predefined styles and collections aren’t quite what you need, the Styles panel also
includes powerful tools for customizing styles, managing your own collections, and sharing
styles:
•
•
•

•

See Customizing a Model’s Background with Styles for details about customizing the
background colors or using a foreground or background photo.
Jump to Creating and Editing a Style to learn about all of SketchUp’s edge and face
options and how to combine them into a style.
You can save multiple styles with your model so that you can switch among them quickly
and easily. These are the In Model styles. You can also organize predefined and custom
styles into collections, so the style you use most often or for certain projects are in one
handy place. See Managing In Model Styles and Collections.
When you’re collaborating on a project or with a team, you can make sure everyone
has access to the same styles. See Sharing Styles for details.
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Customizing a Model’s Background with Styles
Your model’s style contains background settings. To customize a model’s background, you can
choose the background, sky, and ground colors or use a photo background.
In the figure, the background colors make the space rover model appear to be somewhere
Mars-like.

You could also create a plain white background, if that’s what your model needs.
To customize the background colors in your own model, follow these steps:
1. Select the Edit tab.
2. Select the Background Settings icon (
) just below the tab name.
3. Choose your desired background, sky, and ground options. Here’s a quick look at each
one:
o Background color swatch: Click this color swatch to select a new background
color.
o Sky checkbox: Select the Sky checkbox to have a sky color that is different
from the background color. Click the color swatch to select a sky color.
o Ground checkbox: Select the Ground checkbox to choose a ground color that
is different from the background color. Click the color swatch to select a ground
color.
o Transparency slider: Slide the Transparency slider to adjust the level of
transparency for the ground plane. Drag the slider toward the left-most position
to minimize below-ground visibility. Drag the slider toward the right-most
position to maximize below-ground visibility.
o Show ground from below checkbox: Select or clear this checkbox to toggle
the display of the ground plane from viewpoints below the horizon.
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4. (Optional) Click the Update Style button (
) in the top-right of the Styles panel.
Clicking this button updates the copy of the currently active style in the In Model styles.
See Managing In Model Styles and Collections for details about In Model styles.
Tip: With a background photo, your model can display a detailed and realistic background
without excess geometry that might slow SketchUp’s performance. You can insert the
background photo as a watermark, as explained in the following steps, or project an image
texture onto a face, as explained in Applying Colors, Photos, Materials, and Textures.
To insert a static background photo, place the image as a watermark. Here’s how it works:
1. In the Styles panel, select the Edit tab and then click the Watermark Settings icon
(

).

2. Click the Add Watermark icon (
).
3. In the Choose Watermark dialog box that appears, navigate to the image you want to
use as a background. After you select an image, the Create Watermark dialog box
appears.
4. Give your watermark a name and select the Background radio button. Then
click Next.
5. Leave the Create Mask checkbox cleared, unless you’re familiar with creating photo
masks. Use the Blend slider to make your background image watermark more or less
transparent. Click Next.
6. Choose how you’d like your background image watermark to appear. Here’s a look at
your options:
o Stretched to fit the screen: You image fills the background. Clear the Lock
Aspect Ratio checkbox if it’s okay to distort your image to fill the entire
background.
o Tiled across the screen: Use the Scale slider to set the tile size.
o Positioned in the screen: Click a radio button to select the positioning. Use
the Scale slider to set the image size.
7. Click Finish to apply your options.
In the following figure, a photo of woodland scene is placed as a background image watermark.
For details about using watermarks for branding and editing watermarks, see Watermarking a
Model.
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Creating and Editing a Style
In SketchUp, you can create and edit styles so that you can apply your preferred style settings
with a single click.
Tip: If you want to develop a sketchy edges style, check out Style Builder.
To create a new style, follow these steps:
1. Open the Styles panel by toggling it open in the Default Tray. Or select Window >
Default Tray > Styles so that the Styles option is selected.
2. In the upper right, click the Create New Style button (
of the currently active style in the In Model styles.

). SketchUp creates a copy

3. Click the Select tab, click the In Model icon (
), and in the list of styles that appears,
select your new style so that it’s the active style.
4. Click the Edit tab, click the Edge Settings icon (
options.

), and select your desired edge

5. Click the Face Settings icon (
) and select your desired face options. The following
figure shows the Edge Settings (Callout 1) and the Face Settings (Callout 2). In the
following tables, you find a basic illustration and explanation of each setting.

6. Select the Background Settings icon (
), and choose how you’d like the background
to appear. See Customizing a Model’s Background with Styles for details about these
settings.
7. (Optional) If you’d like to include a watermark in your style, click the Watermark
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Settings icon (
) and select your options. Your options are explained
in Watermarking a Model.
8. (Optional) Check that visual cues such as selection colors work well with your new style.
If needed, you can use the Edit tab's Modeling Settings pane to change the colors for
selections and other modeling color cues.
9. Click the Update Style with Changes button (
) in the upper right of the Styles
panel. If the Update Style with Changes button is grayed out, your style is up-to-date.
Tip: To edit a style (including any predefined style that comes with SketchUp), simply follow
Steps 3–8 in the preceding steps.
Note: All the In Model styles are saved with your model; see Managing In Model Styles and
Collections for details.
Option

Example

Good to Know

Edges

Toggles the display of edges in your model. The
example shows edges toggled on (selected).

Back Edges

Displays edges obscured by other edges in your
model. Obscured edges appear as dashed lines.
When selected, this setting disables the X-Ray
face style.

Profiles

Emphasizes the outlines of major shapes in your
model. This style borrows from a drawing
technique that emphasizes the 3D nature of
geometry. Enter a thickness, in pixels, for the
profile lines.
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Depth Cue

Emphasizes foreground lines over background
lines. Enter a foreground line thickness in pixels.

Extension

Extends each line slightly past its endpoint for a
hand-drawn appearance. This style does not
affect inference behavior. Enter a length, in
pixels, for the extension lines.

Endpoints

Places additional line thickness at the endpoints
of lines. Enter a length, in pixels, for the length
of the emphasized endpoints.

Jitter

Renders each line multiple times at a slight
offset, giving your model hand-drawn sketched
appearance. This edge rendering style does not
affect inference behavior.

Color:
Same

Displays all edges in the color defined in color
swatch. This option does not actually change any
edge color assignments you may have made, but
preserves them if you choose to view them
again.

All
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Color:
By
Material

Displays edges with an assigned material color,
such as those painted with a color.

Color:
Axis

Edges that aren't aligned with an axis are colored
with the All Same color swatch. Also, an axis
color doesn’t appear on hidden edges.

By

In the next table, you see all the ways you customize faces’ appearance.
Option

Example

Good to Know

Front
Color,
Back Color

Sets the default color for all front and back sides
of faces. Materials assigned to faces override this
setting. Here a face was removed from the cube
so that you can see the front color is yellow and
the back color is blue.

Style:
Wireframe

Displays only the model’s lines. Because faces are
not displayed, you can’t use face modification
tools, such as the Push/Pull tool.

Style: Hidden
Line

Display
faces
without
any
shading
or
textures. Tip: This option is handy for printing
only in black and white.

SketchUp Help Pages – version 19.

Page 171/567

Style: Shaded

Shades faces to simulate a light source.

Style: Shaded
Using
Textures

Displays shading to simulate a light source and
any textures applied to a face. Tip: Textures
require more memory to render your model. If
you experience performance problems, switch to
a style without textures.

Style: Shaded
Using
All
Same

Displays faces with the default front and back face
color.

X-Ray

Makes all faces transparent so you can see
through your model. Tip: In this mode, you can
easily visualize, select, and snap to points and
edges that would otherwise be hidden behind
faces. However, you can’t select and infer faces
that would otherwise be hidden. Faces cannot cast
shadows in X-Ray mode, which is different from
material transparency.

Enable
Transparency

Toggles global material transparency on or off.

Transparency
Quality

Choose between the Faster and Nicer option.Each
differs in its speed and quality of transparency
sorting. Faster sacrifices accuracy to provide
faster rendering, whereas Nicer performs
additional calculations to correctly display
transparent
surfaces.

Tip: With Nicer selected, you can adjust the X-Ray opacity to create compelling presentation
images, such as the one shown in the following figure.
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Note: X-Ray mode can be very sensitive to z-fighting, which makes overlapping faces flash or
appear striped as you orbit. With opaque models, z-fighting only occurs on surfaces you can
see. In X-Ray mode, you may see z-fighting on several surfaces. However, static images look
quite nice.
Tip: The basic shape tools use a thin solid line. To create dashed lines, see Applying Dashed
Lines to Layers.
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Managing In Model Styles and Collections
In SketchUp, collections help you organize styles and easily access the ones you use most
often. SketchUp includes several default collections, but you can create your own and save
collections to a favorites list.
The In Model styles collection is particularly helpful, because it contains all the styles currently
included with your model file. To see your In Model styles, follow these steps:
1. On the Select tab, click the In Model icon (
) or select In Model from the Styles
Collections drop-down list, as shown in the figure.

Tip: Your In Model style collection can contain styles that are not currently applied your model.
If you’ve saved several styles with your model that you no longer need, click the Details
arrow (
) next to the Styles Collections drop-down list and select Purge Unused from the
menu that appears, as shown in the figure. SketchUp removes all styles in the In Model styles
that are not actually used in your model.
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With a custom collection, you can bundle predefined styles that you often use in SketchUp or
styles that you created or customized for a specific project. (See Creating and Editing a
Style for details.) To create your own collection, follow these steps:

1. In the Styles panel, click the Details arrow (
) and select Open or Create a
Collection from the menu that appears.
2. Click New Folder to create a subfolder in your selected folder and give your folder a
name.
3. Click the Display Secondary Selection Pane icon (
) to open a pane below your
new collection, which is currently empty.
4. In the secondary selection pane, navigate to a style you want to add to your collection.
5. Drag the style from the secondary selection pane into your new collection. Continue
navigating to and dragging styles to your collection until it contains all the styles you
want.
Tip: If all the styles you’d like to use in your collection are already in the In Model collection,
click the Details arrow (
) and select Save Collection As. SketchUp prompts you to save
the collection under a new name so that you can easily open the collection in another model.
After you create a custom collection, accessing it in another model is easy. You simply open it
— and if you use the collection frequently, add it to your favorites.
Note: If you need to clean up your favorites list, click the Details arrow, select Remove
Collection from Favorites, select a collection to remove, and click Remove. Repeat the
process for any collections you don’t use very often.
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Sharing Styles
Styles are shared in .style files that can be opened by any copy of SketchUp 6 or later. You
must create a .style file to share a style with others. To share a style:
1. Create a new folder/directory on your computer to contain your shared styles.
2. On the Select tab, choose In Model from the Styles Collections drop-down list.
3. Context-click the style name you would like to share, and select Save As from the menu
that appears.
4. In the Save As dialog box, navigate to the folder/directory you created in Step 1.
5. Type a name for the style in the File name field.
6. Click the Save button. The style file is saved to your newly created folder/directory. You
can now share this style file with others.
To open a .style file that a friend has shared with you, follow these steps:
1. Create a new folder on your computer. Name the folder something simple, for example
Shared Styles.
2. Copy and paste the .style file in the folder that you created in Step 1.
3. Click the Details arrow (
) on the Select tab and choose Open or Create a
Collection.
4. Browse to and select the folder created in Step 1.
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Speeding Up Rendering with Fast Styles
SketchUp Styles can add complexity to a model that slow down SketchUp as you work on your
3D model. To apply the styles you need while optimizing performance, use Fast Style. When a
style qualifies as a Fast Style, SketchUp displays a badge like this:
If you apply a style created in SketchUp 2014 or earlier, the Fast Style doesn't display the
badge until you force the style to update once in SketchUp.
A Fast Style disables a style's more taxing effects — that is, settings that require additional
processing and slow down SketchUp as your model becomes more complex. If any of the
following settings are enabled, then the style will lose its classification as a Fast Style and the
badge will no longer appear.
Edge
•
•
•
•
•
•

Styles
Profiles
Depth Cue
Extension
Endpoints
Jitter
Sketchy Edges

Face Styles
• X-Ray with Transparency: Medium
• X-Ray with Transparency: Nicer
• Transparency: Medium
• Transparency: Nicer
Every face style, including X-Ray, with Transparency set to Medium or Nicer will lose the Fast
Style classification. The one exception is the Wireframe face style, which remains a Fast Style
with any Transparency setting.
Tip: Additional settings, such as the Fog and Shadow settings, may affect a model's
performance. If you're still seeing slower performance in SketchUp, see Improving Performance
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Customizing Modeling Settings to Complement a
Style
Not all styles work well with SketchUp's default settings for selection colors or the display of
hidden geometry, section planes and cuts, guides, and more. If you are color blind, changing
these settings can also help you see SketchUp's modeling cues more clearly than you can with
the default settings.
In the Styles panel, the Edit tab has a Modeling Settings pane, shown in the following figure.
Here you can customize colored visual cues and choose what cues, such as section planes, do
or don't appear. You can save these selections with the active style.
Here's a quick overview of what the settings do:
•

•
•

Color swatches: Click a item's corresponding color swatch to choose that item's color.
For example, if you'd like locked geometry to appear yellow instead of red, click the
color swatch and use the color picker that appears to select your desired color.
See Mixing Colors in the Color Picker for details about selecting colors.
Section cut width: Enter a number to define the thickness (in pixels) of all cut lines in
the active section plane.
Check boxes: For any item you'd like to appear in your style, select its checkbox. For
example, if you'd like section planes to be visible, select the Section Planes checkbox.
If you want to keep the axes hidden, clear the Model Axes check box.

The Match Photo settings enable you to control how photos appear when creating a 3D model
with the Match Photo feature.
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Applying Colors, Photos, Materials, and Textures
With colors, textures, and photos, you can add details that make a 3D model look realistic and
complete:
•
•
•

Colors are like paint.
Textures add realistic materials, such as carpet, tile, grass, wood, glass, and anything
else you can capture as a digital image.
Photos can be pinned to your model (or just a face within it).

In SketchUp’s Materials panel (Microsoft Windows) or Colors panel (Apple macOS), you find
predefined colors and textures, which you can edit. Or try mixing your own colors or creating
a texture from a photo.
Tip: The color and texture materials not only add detail to model, but also enable you to swap
one material for another with a click and to calculate what materials you need. For example, if
you’re creating a precise model of something that you plan to build in real life, you can use the
color and texture materials to determine details such as how much surface area you need to
paint or how many square feet of tile you need. Adding Colors and Textures with
Materials explains how to work with materials.
In SketchUp, texture materials are typically photos that are tiled on a face. However, you may
want a single photo to cover a face instead. SketchUp gives you several options for doing so,
all of which are explained in Sticking a Photo or Texture to a Face. Among those options is a
pretty neat feature that enables you to snip an building image from Google Street View and
import that image directly into your model — all without leaving SketchUp!
With the Match Photo feature, you can apply one or more photos to a 3D model’s faces or draw
a model based on a photo. Match Photo is especially helpful if you’re modeling an existing
structure that you can photograph. By matching photos to your model, you can show quite a
bit of detail without having to create that yourself, and SketchUp can render a model with
photos faster than one with lots of detailed geometry. Check out Matching a Photo to a Model
(or a Model to a Photo) for detailed steps that explain how to use Match Photo.
To mix your own colors to simulate paint or to colorize a texture, you need to understand a bit
about how SketchUp’s color pickers reflect the underlying technologies for digital colors. Mixing
Colors in the Color Picker walks you through the basics.

Adding Colors and Textures with Materials
To add detail and realism to your models, SketchUp enables you to paint materials on
faces. Materials are essentially paints that have a color and optional texture (defined within an
image file). For example, in the following figure, the roofing material has a blue color and a
texture that simulates metal roofing. The siding and grass are also materials that have a color
and texture.
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After you apply materials like these to your model, the special capabilities of SketchUp’s
materials can help you do any of the following:
•
•

•

Replace one material with another: Say you want to show a metal roof instead of
shingles. You can swap the roofing material for shingles quickly and easily.
Edit the material: Because the color and texture are separate, you can change them
independently of each other. For example, you can change the siding color (how does
yellow look?) but keep the same texture. You can also edit a material’s opacity, which
controls how opaque or transparent the material is.
Calculate how much material you need: SketchUp can tell you the area of all the
shingles or the siding. Of course, for this calculation to mean anything, you need
to create a precise model so that the numbers reflect your model’s actual size.

Tip: SketchUp includes several collections of materials: carpet, tile, groundcover, glass, wood,
and more. However, if the specific material you need isn’t available, you can create your own
material. This feature is especially handy if you’re a decorator or builder who needs to show
your clients precise finishes.
In the SketchUp interface, you model materials with the Paint Bucket tool (
) and the
Materials panel (Microsoft Windows) or the Colors panel (Apple macOS). The Materials or Colors
panel also enables you to view, manage, and organize the materials. The Materials or Colors
panel keeps track of the materials in your model, and it's where you can create custom
materials collections specific to your projects or workflows.
Note: If you switch between computers running Microsoft Windows and macOS, note that the
Materials panel interface and Colors panel interface are unique to their respective operating
systems. In the following sections, you see instructions for Microsoft Windows or macOS,
depending on which operating system you've selected from the drop-down list on any page in
the Help Center.
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In this video11, you see how to apply materials and make a few common changes, such as
replacing one material for another. For steps that walk you through how to use materials in
detail, check out the following sections.
Table of Contents
1.
2.
3.
4.
5.
6.
7.

Applying materials
Replacing one material with another
Editing materials
Repositioning textures
Calculating material area automatically
Managing and organizing materials
Creating your own materials

Applying materials
Applying materials to your model is pretty simple: Select a face or faces and then select your
desired material. If you’re painting groups or components, check out the tips at the end of this
section, which can make applying materials even easier.
You apply materials to your model with the Paint Bucket tool (
the following parts of SketchUp’s interface:
•
•
•
•

), which you find in

Getting Started toolbar
Large Tool Set toolbar
Principal toolbar
Tools > Paint Bucket on the menu bar

To start applying materials to your model, follow these steps:
1. Select the Paint Bucket tool (
).
2. From the drop-down list, select a materials collection.
3. Click the material you want to use.
Tip: To sample a material that’s already in your model, hold down the Alt key to switch
temporarily to a Sample tool. With the Sample tool’s eyedropper cursor, click the face
whose material you want to sample. Release the Alt key to return to the Paint Bucket
tool.
4. Back in the drawing area, click a face or faces to apply the material.

11

https://youtu.be/CL3_L8i2bnc
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Tip: To restore the default colors, follow the preceding steps, but instead of clicking a material,
click Set Material to Paint with Default (
) in the upper right and click a face in your
model to apply the default colors.
Tip: If the selected material doesn’t appear after you click a face, your model is likely using a
style that doesn’t display textures. To check, open the Styles panel, select the Edit tab, and
click the Face Settings icon. In the Style area, make sure that the Display Shaded Using
Textures option is selected.
If your styles are showing textures, your computer may have insufficient memory to display
materials in your model. See Fixing an Issue in SketchUp for help.
You can paint multiple faces and edges at once. To do so, use the Select tool (
) to
select the edges and faces that you want to paint . Then switch to the Paint Bucket tool and
apply a material. (Selecting Geometry offers tips for making selections.)
When you apply materials to several faces at once, remember the following:
•

•

Faces have two sides: a front and a back. You can paint the front or the back of all
the selected faces, but not a combination. The side you paint is determined by the side
you click with the Paint Bucket cursor. In the following figure, clicking the front of a face
paints all the front faces in the selection, even though you see two front faces and two
back faces.
Control how the back edges look with a style. When you select a face and all edges
and paint the front of the face, all the selected edges are painted. Paint the back faces,
however, and none of the edges are painted. To blend back edges with materials, open
the Styles panel, click the Edit tab, click the Edge Settings icon, and select By
Material from the Color drop-down list.
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You can apply materials to a group or component as whole or to specific geometry
within the group or component:
•
•

To paint a whole group or component, select it and apply a material. When you
select a group or component and apply a material, only faces in the default material are
painted.
To paint geometry within the group or component, double-click it to open its
context. Then select the faces you want to paint with a material.

The following video demonstrates several tips and tricks for applying materials to components.
Or read on for steps that walk you through how to paint all or part of your components.
Tip: To model variations in materials quickly and easily, combine the techniques for painting
all and part of your components.
To see how this tip works, say you’re modeling a chair with a wood frame and two cushions,
and you want to show four cushion colors. The Outliner, shown here, shows that each chair
element (the frame and two cushions) is a group, all of which are nested within a group, which
is then nested in a component. (See Organizing a Model for more about the Outliner.)
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The following steps explain the easiest way to apply materials and show the four color options:
1. Because the frame is the same on every chair, select the frame’s group and apply the
wood material, as shown here.

2. Create a copy for each cushion color. (Copying What You’ve Already Drawn explains
how.)
3. Select a component and apply a cushion color material. Because the frame is already
painted but the cushions are still the default color, only the cushions are painted with
the color material. The frame keeps the wood material.
4. Repeat the preceding step for each color option. You see the result in the following
figure.

Tip: When several groups or components are nested within other groups and components,
SketchUp may not let you paint by clicking the top-most group or component. If you run into
this problem, try applying materials to a group or component nested lower in the hierarchy.
The Outliner can help you see where your selection is in the hierarchy.
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Replacing one material with another
Because SketchUp enables you to replace one material with another, you can experiment with
materials quickly and easily. In a kitchen, preview different countertop materials, such as black
granite, blue tile, and white composite. If you’re picking out house paint colors, compare yellow
siding and dark green trim with navy siding and cream trim. When you know the keyboard
modifiers, the process is a cinch. Check them out in the following table.

To Replace One Material with Another …

Modifier Key
(Microsoft
Windows)
Ctrl

On adjacent faces
On all faces in the current context (for example,
Shift
the same group or component)
On all connected faces
Ctrl+Shift

Modifier Key
(Apple macOS)
Option
Shift
Option+Shift

Here’s an example help you visualize how each shortcut works. Say you’re trying to figure out
the colors for an abstract mural on two separate walls. The following figure shows the mural
mocked up with materials from the Colors-Named collection.

To see how replacing the red with green might look, select the Paint Bucket tool and then select
a green from the Materials panel (Microsoft Windows) or Colors panel (Apple macOS). If you
Ctrl- or Option-click the red triangle in the upper left, only the adjacent faces with the red
material are replaced with green, as shown in the following figure.

If you Shift-click instead, all the red faces become green:
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But if you Ctrl+Shift-click or Option+Shift-click, the red faces turn green only on the left wall:

Editing materials
SketchUp enables you to edit materials. As you make changes, any faces painted with the
material that you’re editing are updated automatically. Because each material has a color and
an optional texture, you can edit the color and texture independently of each other.
A material needs to be saved with your model before you can edit it. To see the materials saved
with your model, open the Materials panel, and click the In Model icon (
In Model collection, as shown in the following figure.

) to display your
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If the material you want to edit doesn’t appear in your In Model collection, you can save a
material with your In Model collection whether or not the material is currently applied to faces
in your model. To add a material to your In Model collection, follow these steps:
1. Click the Display Secondary Selection Pane icon (
) in the upper right of the
Materials panel.
2. In the secondary pane at the bottom, browse the collections for the material you want
to edit.
3. Drag the material swatch into your In Model collection.
To edit the material, select it in the In Model collection and click the Edit tab, shown in the
following figure.

Here’s a brief introduction to all the tools for editing a material’s color:
•

•
•

Picker drop-down list: Use the Picker drop-down list to select between the HLS, (Hue,
Light, Saturation), HSB (Hue, Saturation, and Brightness), RGB, (Red, Green, Blue),
and Color Wheel color pickers. See Mixing Colors in the Color Picker for details about
the color picker.
Undo Color Changes swatch: Click this swatch to undo all the color changes you
make during an edit session.
Match Color of Object In Model button: Click this button to turn the cursor into an
eyedropper. With the eyedropper cursor, click an entity to sample its color and apply
that color to the material that you’re editing.
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Tip: If you sample a textured material, the texture variations can disguise the material’s
color a bit. To sample a specific color from a texture, use the Match Color on Screen
button for better results.
•

Match Color on Screen button: Click this button and then click anywhere on the
screen with the eyedropper cursor to sample a pixel color. SketchUp then applies that
color to the currently selected material.

The following tools enable you to tinker with a material’s texture:
•

•

•

Use Texture Image checkbox: When this checkbox is selected, you can include an
image file that represents a texture. Clearing the checkbox removes the texture image
file. (Note that selecting the checkbox again doesn’t restore the image file. Instead,
you’re prompted to select a new image file.)
Texture image file and Browse button: The texture file field contains the name of
an image file (representing a texture), if any, associated with the current material. To
change the texture, drag an image file to this field or click the Browse button to display
the Choose Image dialog box, where you can browse for an image file on your hard
drive. After you apply a texture, you can also adjust how the texture tiles on your model.
See the upcoming section, Repositioning textures for details.
Edit Texture Image in External Editor button: When you click this button, SketchUp
opens the texture image file in your default image editor.
Note: Your image editor is defined in the SketchUp Preferences dialog box, on the
Applications panel. See Customizing Your Workspace for details about setting this
preference. If you haven’t specified an image editor, SketchUp launches your operating
system’s default editor or image display application.

•
•
•

•

Colorize checkbox: Select this checkbox to apply the same hue to the whole texture.
The color is defined in the Edit tab’s Color area. This option is useful for files that are
not displaying proper colors.
Reset Color swatch: Click this color swatch to reset the material to the color in the
texture image file.
Dimension fields: When you paint a texture on a face, the texture image is tiled to fill
the face. Type a value in the width or height box to change the size of the texture tile.
By default, the image’s aspect ratio is maintained. So, if you type 2 in the width
dimension box, the height box automatically updates to maintain the aspect ratio. Click
the chain icon to break the chain (sorry, Fleetwood Mac), and you can distort the aspect
ratio. If you don’t love the results (and will never love them again), click the horizontal
and vertical arrow buttons to revert to the previous width and height settings.
Opacity slider: Opacity refers to how transparent or opaque your image is. Sliding the
opacity slider to the right increases the opacity of the texture, where 100 is totally
opaque. Move the slider left to increase the transparency of the texture, where 0 is fully
transparent. Alternatively, type a number from 0 to 100 in the Opacity field.

Repositioning textures
After you apply a texture to one or more faces in a 3D model, you can adjust how the texture
tiles across a face. To do so, you use the Position Texture tool, which has two modes:
•

Fixed Pin mode: In this mode, you can move, rotate, scale, or distort a texture. For
example, in this mode, you can adjust a texture on one face so that it lines up with the
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same texture on another face, such as siding on two faces of a building.
Free Pin mode: If you need to stretch or shrink a texture, use Free Pin mode.

Here’s how to adjust a texture in Fixed Pin mode:
1. Context-click the material and select Texture > Position from the menu that appears.
You see a matrix of dotted lines that represents the texture’s individual tiles. The cursor
also changes to a hand and four pins are displayed.
2. Use the hand cursor and/or the pins to adjust your texture. In this example, the goal is
to move the green pin so that the direction of the wood on the top of the cabinet matches
the side. Here’s a quick rundown of all your options:
o
o
o

Click and drag the material with the hand cursor to reposition the texture as a
whole.
Click a pin to pick it up and click again to drop the pin elsewhere on the texture.
Drag a pin to alter the texture. Dragging the blue pin scales or shears the
texture. Dragging the yellow pin distorts the texture. Dragging the green
pin scales the texture or rotates it around the Move pin’s axis. Dragging the red
pin, which is the move pin, moves the texture.

3.
Tip: In Fixed Pin mode, you can also context-click the texture to see additional options:
flip the texture to the left or right or up or down, rotate the texture in increments of 90
degrees. The reset option reverts the texture to its original state, whereas the Undo
option simply undoes the last command. If you undo an action, Redo also becomes an
option.
4. When you’re finished changing the texture, context-click the texture and select Done.
Or just click outside the texture to exit Fixed Pin mode.
In Free Pin mode, you can set the size of your texture tile relative to your model. Here’s how
the process works:
1. Context-click the material and select Texture > Position from the menu that appears.
By default, you’re in Fixed Pin mode.
2. Click a pin to pick it up and click again to place the pin in its new location. Do this for
all four pins to set where the corners of the texture tile appear. If you place the pins in
a configuration that isn’t rectangular, you distort the texture.
3. When you’re finished, context-click the texture and select Done. Or simply click outside
the texture to exit Free Pin mode.
Tip: In Free Pin mode, you see the size of the texture tile only on the selected face. To change
the size of your texture tile throughout your model, use the Materials panel (Microsoft Windows)
or the Colors panel (Apple macOS). See the earlier section, Editing materials, for details.

Calculating material area automatically
If you want SketchUp to calculate the surface area painted with a material, you can contextclick the material and select Area > Material. In Windows, you can also context-click the
material in the Materials panel, and select Area from the menu. (If the Area menu item is grey,
the material isn’t applied to any faces.)
Either way, an Area dialog box shows the total area of faces to which the selected material is
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applied. The units (such as square feet or square meters) depends on the units specified in
your template. See Setting Up Templates for details about changing your default units.
If you use IFC classifications, you can generate a report on materials in your whole model. See
Classifiying Objects (and specifically the section on generating a report) for details.

Managing and organizing materials
The Materials panel (Microsoft Windows) or Colors panel (Apple macOS) helps you find and
organize materials. The following list explains how you can manage materials with the operating
system you've selected in the Help Center.
•

Browse the included collections: On the Select tab, choose a collection from the
drop-down list to see the materials.

•

Keep track of the materials in your model: Click the In Model icon (
) to see all
the materials you’ve applied to your model.
Clear out unneeded materials: Even if you replace a material with another, so that
the original material no longer appears in your model, the original material still remains
in your In Model collection until you delete it by context-clicking and selecting Delete.
To remove all the unused materials in a model, make sure your In Model collection is

•

•

selected. Then click the Details arrow (
) and select Purge Unused. Alternately,
you can select Delete All to remove all the materials from your model and In Model
collection.
Add frequently used collections to your favorites: On the Select tab, click the
Details arrow and choose Add Collection to Favorites. The currently selected
collection then appears in a favorites list at the bottom of the drop-down list. You can
select the collection, click the Details arrow, and choose Remove Collection from
Favorites if you no longer need the collection on your favorites list.
Note: Click the Details arrow, and you can choose to view materials as small, medium,
large, or extra-large tiles. Choose the List option to see the materials names instead of
the preview swatches.

Creating your own materials
The materials included in SketchUp help you start using materials and explore how they work.
To apply materials specific to your own design or building, you probably need to create your
own materials. The process is pretty easy: Start with an image to create a texture tile and then
specify a color if needed.
To create a new material from your own files or color codes, follow these steps:
1. In the Materials panel, click the Create Material icon (
) in the upper right.
2. In the Create Material dialog box that opens, type a name for the new material in the
text field at the top.
3. Choose the color, texture, and opacity options for your new material. The options work
just like those in the Edit panel. Refer to the earlier section, Editing materials, for details.
Or, for help understanding the color options, see Mixing Colors in the Color Picker.
4. Click OK. Your new material appears selected in the In Model collection.
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Tip: You can also expand your materials collections by downloading materials. Check out this
post from the SketchUpdate blog for details.
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Tracing an Image
Tracing an image is an easy (and thus common) way to create a floorplan in SketchUp and
then turn that plan into a 3D model. You can also trace an image to model a 2D design that
you want to place somewhere in a 3D model. Whatever you’re trying to model, here’s how to
start tracing an image:
1. Import your image into SketchUp by selecting File > Import. Then navigate to and
select the image you want to import. If you don't see the image you're looking for, make
sure the correct file type is selected (such as JPG or PNG).
Tip: Alternately, you can also drag and drop importable files into the drawing area. After
you drop the file, click and drag the scaling handles to size the image on the ground
plane.
2. In the Use Image As area, make sure the Image radio button is selected and
click Import.
3. Click where you want to place the top-left corner of the image, and click again to place
the lower-right corner, which scales the image.
4. (Optional) Select Camera > Standard Views > Top to get a top view of your image.
If you choose this step, also be sure to switch to Parallel Projection as well.
5. Select a drawing tool to start tracing the image. The Line tool is a popular choice.
If precision is important to you, use a line in your model to scale the drawing.
In this video12, you see two examples of tracking an image to create a floorplan. The first
example is a napkin sketch; the second is a drawing plan with precise measurements.

12

https://youtu.be/cfoQf_8YYxg
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Sticking a Photo or Texture to a Face
Have you ever stuck a decal on a window or a wall? In SketchUp, sticking an image on a face
is even easier than those decals, because digital images don’t wrinkle or trap air bubbles.
Technically speaking, SketchUp enables you to import images that are already on your hard
drive. When you import images from your hard drive (select File > Import to see the Open
dialog box, shown in the figure), you can import the image as an image, a texture, or a matched
photo.

Here’s how those options help you do different things with the image in your model:
•
•

Import the image as a basic image, and SketchUp enables you to place the image
anywhere in your model. You can then move, rotate, scale, or stretch the image.
Import the image as a texture, and you can apply the image to an existing face.
However, you also gain access to all the materials and Position Texture tools. These
tools are introduced in Adding Colors and Textures with Materials, but that article
focuses on tiled images. In this article, find out how to do special techniques with a
single image, such as wrapping an image around corners, wrapping an image around a
hidden face on a cylinder, or projecting an image onto a face. When you project
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textures, you can apply them to curved surfaces.
Import the image as a matched photo, and you activate SketchUp’s Match Photo
tool, which enables you to match a photo of an existing building to a model of that
building or draw a building based on a photo. Match Photo enables you to apply images
to buildings two faces at time, using the corner of a building or room to apply a 2D
image onto a 3D model. Unlike images or textures, which work best with rectangular
images and faces, Match Photo works well with non-rectangular building shapes, such
as angled roof lines. Learn all about Match Photo in Matching a Photo to a Model (or a
Model to a Photo).

Tip: If your model is spherical, these tools likely won’t work well for you. The one exception is
projected textures, which you can apply to curved (or seemingly curved) surfaces. (For details
about how SketchUp makes flat faces look smooth, see Softening, Smoothing, and Hiding
Geometry.
Table of Contents
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Understanding image basics
Digital images come in myriad file types and sizes. SketchUp supports the image file formats
outlined in the following table. Some formats may be more appropriate than others for certain
types of images and applications.
Windows and macOS
JPEG, PNG, EPS, TIFF

Microsoft Windows
TGA, BMP

Apple macOS
PDF, PICT, PSD, SGI

An image’s size is referred to as its resolution. An image’s resolution reflects how many pixels
the image contains. The resolution of an image depends on the image source. Typically, images
captured with a digital camera, especially a dSLR camera, have very high resolutions, and
images downloaded from the web have low resolutions. You can check an image’s resolution
in an image editing program, such as Photoshop.
Tip: The higher an image’s resolution, the more detail you see in the image. However, a high
resolution also makes the image file bigger, which in turn makes your SketchUp model file
bigger. Aim for the lowest image resolution that still shows the image’s detail clearly in your
model. Also, JPEG and PNG file types use compression algorithms that also help lower an
image’s file size.
Digital images and SketchUp models are so diverse, it’s difficult to give specific
recommendations here. However, here’s an example to illustrate how you might find the right
resolution and file type for an image. Say your image was captured with a digital camera in a
JPEG or JPEG+RAW format. Try saving a copy of your digital image at a resolution of 72 ppi
(pixels per inch) and in the JPEG format. If you model dimensions aren’t very large, you may
want to reduce the image dimensions as well (the width and height in pixels). Then, import the
image into your SketchUp model and see how the image looks. If you save a copy of the original
image, you can always go back and try different settings in your image editor until you find the
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resolution and dimensions that work well with your SketchUp model.

Importing a 2D image
To import an image from your hard drive into a SketchUp model, follow these steps:
1. With your model open, select File > Import.
2. In the Import dialog box that appears, navigate to the image file on your hard drive and
select it. If you don’t see the image you’re looking for, make sure All Supported Image
Types is selected from the Files of Type drop-down list.
3. Select an option for importing your image: Use As Image, Use As Texture, or Use As
New Matched Photo.
4. Click the Import button and your image appears in your model.
Tip: Instead of importing your image, you can drag and drop supported files into the drawing
area. After you drop the file, the image is imported as though you selected Use As Image in
the preceding steps. If you want to import an image as a texture or matched photo, use the
Import dialog box instead of drag and drop.
If you selected the Use As Image option, your image appears in your model as an image entity
with a bitmap image applied to a face. Here are the basics of working with image entities in
your model:
•

•
•

To place the image entity, click anywhere in your model to place one corner. As you
move the cursor, the image entity grows or shrinks in size. Click again to place the
opposite corner. SketchUp maintains the image proportions by default; to deconstrain
the proportions as you place the file, hold down the Shift key.
To move or rotate the image, use the Move or Rotate tool.
To resize the image after you’ve placed it, use the Scale tool.

The following figure shows an image placed on a model’s ground plane.
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Applying a texture to the side of a building
When you apply a photo as a texture instead of an image, you can’t place the image anywhere
in your model. You need to have a face already drawn to which you can apply the image.
However, you do have a little more control over the texture’s positioning on the face.
Tip: Sometimes it’s useful to subdivide a face on the side of your building into smaller faces
before you apply a photo texture. This is especially true for very long street-facing walls that
are difficult to see in a single photograph. Use the Line tool to draw edges that subdivide a
face.
The following steps walk you through the process of applying a photo texture to flat face and
offer a few tips along the way:
1.
2.
3.
4.

Select File > Import and select the Use As Texture option.
Click in the lower-left corner of the face that you want to photo-texture.
Click in the upper-right corner of the face to finish applying the image.
(Optional) If you need to stretch the image or adjust its position, context-click the
texture and select Texture > Position from the menu that appears. Then context-click
the texture again and clear Fixed Pins, so that the Position Texture tool is in Free Pin
mode. You can then drag the white pins to each corner of the face to stretch the image
or otherwise apply it to the face more precisely. Click outside the texture when you’re
done.

Note: For details about the Position Texture tools and Fixed Pins versus Free Pin mode, see
the section on repositioning textures in Adding Colors and Textures with Materials.

Wrapping textures around boxes and cylinders
After you import an image as a texture, you can wrap it around an existing box or cylinder,
sort of like wrapping paper.
Follow these steps to import an image and wrap it around a box:
1. Select File > Import.
2. In the Import dialog box, navigate to your image, select it, select Use As Texture, and
click Import.
3. Click on the lower-left corner of the face on which you want to start wrapping your
image.
4. Then click the upper-right portion of the face. This places your image, as shown in the
following figure.
(cont’d next page)
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Tip: If you need to stretch or reposition your image after you place it, see the section on
repositioning textures in the article Adding Colors and Textures with Materials.
5. Select the Paint Bucket tool (
).
6. Hold down the Alt key (Microsoft Windows) or the Command key (Apple macOS) to
switch to the Eyedropper cursor.
7. Click the texture that you applied to the face. The Eyedropper samples your photo.
8. Release the modifier key to return to the Paint Bucket tool, and click an adjacent face
or faces in your model to wrap the image around it, as shown in the following figure.

When you wrap a material around a cylinder, the steps are the same. However, because a
cylinder is made of several faces that are hidden and smoothed, your image may look clipped
at first.
The following figure shows how the image looks after placing the texture by clicking the bottom
edge of the cylinder and then the top edge.
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However, after you sample the texture with the Eyedropper cursor and click the cylinder with
the Paint Bucket cursor, the whole image wraps around the cylinder, as shown in the next
figure.
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Projecting textures onto a curved surface
In SketchUp, projected textures are images applied to faces as though a slide projector is
projecting the image onto your model. Projected textures enable you to apply a texture over a
curved surface. This feature is particularly useful for applying a topographic image over a site
model, because topography is rarely flat like the side of a building.
Tip: If your curved surface is a group, open the group’s context before you follow these steps.
Alternately, you can explode the group and then turn your curved surface back into a group
after you complete the steps. For details about organizing geometry into groups,
see Organizing Your Model.
To project a texture over a curved surface, follow these steps:
1. Draw a single, flat face that matches the dimensions of your curved surface. The
following figure shows a top view of a flat surface over a blank terrain.
Tip: Select the flat face and turn on X-Ray mode (select View > Style > X-Ray) so you can
see the curved surface under the flat surface.

2. Import a photo as a texture, as explained in the earlier section Applying a texture to
the side of a building. Remember that to see this texture, the Face settings in the Styles
panel must be set to Display Shaded Using Textures. (See Creating and Editing a
Style for details about face styles.)
3. (Optional) If needed, adjust the position of the texture so it matches your flat face. For
example, in the following figure, you see the texture in Free Pin mode after each pin
was dragged to a corner of the flat face. See the section on repositioning textures
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in Adding Colors and Textures with Materials for details.

4. Context-click the texture that you applied to the flat face, and from the menu that
appears, select Texture > Projected. This step transforms the texture into a projected
texture, so that the remaining steps work.
5. With the Select tool (

), select all the faces in your curved surface.

6. Select the Paint Bucket tool (
).
7. Hold down the Alt key (Microsoft Windows) or the Command key (Apple macOS), and
with the Eyedropper cursor that appears, click the projected texture to sample it.
Release the modifier key so the cursor turns back into the Paint Bucket.
8. With the Paint Bucket cursor, click the curved surface selection to apply the projected
texture to all the faces.
9. Delete the flat surface, because you no longer need it. The following figure shows the
projected texture after it’s applied the curved surface and the flat surface is deleted.
(cont’d next page)
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Matching a Photo to a Model (or a Model to a Photo)
SketchUp’s Match Photo feature has inspired many happy dances, because it enables you to
•
•

Apply a photo to an existing model: Say you have a model of an existing structure
and you want the model to look realistic. Applying a photo with Match Photo is much
easier than drawing that detail and applying materials to individual elements.
Create a model from a photo: When you want to model an existing structure, Match
Photo enables you to use a photo as a starting point. You can essentially trace the photo
to draw the model.

•
Until you get the hang of Match Photo, you may suspect that SketchUp dumped a box of
rainbow spaghetti on your model like a toddler bored with pasta crafts. Match Photo is a bit
confusing at first, but this article gives you the tips and steps that you need to use Match Photo
in the magical way its developers intended. When you’re first learning how to use Match Photo,
orient yourself to the color-coded tools that Match Photo spills onto your screen and check out
what photos work well with the Match Photo feature. Then try your hand at matching a photo,
following the detailed steps in the following sections.
Tip: In this YouTube video13, you see Match Photo in action. Although the demo uses an older
version of SketchUp, the process in current versions of SketchUp is similar.
Table of Contents
1.
2.
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Introducing Match Photo’s color-coded tools
Choosing photos that work with Match Photo
Matching a photo with an existing model
Creating a 3D model from a photo
Deleting a matched photo

Introducing Match Photo’s color-coded tools
To start using Match Photo, select Camera > Match New Photo. Select the photo you want
to use, and your screen looks something like the following figure, which shows an image
captured from Google Street View. The following list identifies all the tools that appear onscreen:
(cont’d next page)

13

https://www.youtube.com/watch?v=BRM7WXU5GrY
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1. Scene tab: A scene is a saved camera view of your model that’s associated with a tab.
If you orbit away from this particular view, the matched photo disappears. But you can
click the Match Photo scene tab to return to the view with the photo.
2. Match Photo view: When the camera is in Match Photo view, you see Match Photo in
the upper left of the drawing window.
3. Vanishing point bar: You see two green bars and two red bars with dashed lines and
a square grip on each end. You click and drag the grips to align these bars with elements
in your photo.
4. Horizon line: This yellow line aligns with the horizon in your model. Typically, if you
set the vanishing point bars, the horizon line takes care of itself.
5. Axis bars: The solid green, red, and blue lines represent each axis. As you adjust the
vanishing point bars, the axis bars move, too, so you usually don’t need to adjust these
manually. You can click and drag up and down the blue axis bar to roughly scale your
photo.
6. Axis origin: The origin is where the three axes meet. If you start with a Match Photocompatible image, Match Photo does a pretty good job of locating the origin for you,
but you might need to adjust it a bit. In the example, the origin needs to move down a
bit so the axis origin is at the corner where the walls and ground meet. (If the photo
looks down on a building, try a corner where the roof and walls instead.) For a photo
taken indoors, place the origin where the walls and ceiling or the walls and floor meet
in a corner.
Tip: The Match Photo dialog box is another important tool that appears when you enter Match
Photo view. Find out how and when to choose features in the dialog box as you walk through
the steps for matching a photo with an existing model or creating a 3D model from a photo.

Choosing photos that work with Match Photo
Match Photo works best when your photo meets certain criteria. When you’re taking or choosing
photos to use with SketchUp’s Match Photo feature, keep the following tips in mind:
•

Match Photo works best with structures made mostly of right angles. You
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definitely need at least one right angle for Match Photo to work.
Use photos taken at a roughly a 45-degree angle from a corner. The preceding
figure from Google Street View is an example of an image taken at a 45-degree angle.
If you’re taking photos, you can use Match Photo on several parts of your model if you
take photos of each corner.
Do not crop photos. Although it may seem possible to use a cropped image, typically
vertical lines don’t align well across a cropped image, and you won’t like the result.
Avoid warped or distorted photos if you can. Match Photo doesn’t work best with
images that an image editor or specialized camera has warped. For example, because
the Google Street View camera warped the image of the preceding building a bit as the
camera went around the corner, the vanishing point bars, axes, and horizon may not
line up precisely. However, the school house photos used later in this article match up
exactly with the model, because the photos had no distortion at all.
Tip: Sometimes an image editor can remove barrel distortion or issues where straight
lines are bent away from the center of the image. Barrel distortion typically occurs on
wide angle lens cameras.

•
•
•

Avoid stitched images (panoramas). Stitched images are typically excessively
warped and have multiple vanishing points for each axis.
Choose photos without foreground features. When trees and other foreground
objects block the view of a building, those foreground elements get in the way of
drawing a model based on your photo.
Make sure your image has two vanishing points. You’ll have a hard time adjusting
the vanishing point bars if your image has only one, infinite vanishing point, such as a
hallway or a long train track. Similarly, images taken with a very long telephoto lens (or
a satellite or aerial image) also make adjusting the vanishing point bars difficult.

Matching a photo with an existing model
To apply a photo to an existing model with SketchUp’s Match Photo feature, have your model
and your photo on your hard drive. When you’re ready, follow these steps:
1. Select File > Open and select the model you want to open in the drawing area. This
example uses the following model of a schoolhouse.
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2. Select Camera > Match New Photo.
3. In the Select Background Image File dialog box that appears, navigate to your image
file and click Open. The camera switches to Match Photo view, so your photo appears
in the drawing area, as shown in the following figure, and your camera angle is
automatically saved to a scene tab, which appears in the upper left.

Tip: When a Match Photo is active, you can context-click any Match Photo tool to open
a context menu. Select Start Over or Cancel Match if your photo matching goes awry.
Select Zoom Matched Photo to fit your photo in the drawing area. Zoom Vanishing
Points zooms so that all the vanishing points fit in the drawing area.
4. In the Match Photo dialog box, shown in the following figure, select the style that reflects
the type of photo you have. Click Inside for an interior image, click Above for an
exterior photo of a building taken from the top, or click Outside an exterior photo taken
from the ground.
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Tip: You can adjust the grid to suit your preferences and help you align and scale your
photo. Select the Auto radio button to make the grid appear only when you’re adjusting
one of the matching tools. (The vanishing point bars, horizon bar, and axes are always
visible in Match Photo view.) Use the Planes options to select whether you want the grid to
show the red/green, red/blue, or green/blue planes. Type a value in the Spacing text box
to set the size of the grid spacing, which can help you scale your model to a multiple of the
actual structure’s size.
5. Click and drag the axis origin to a distinct origin point on your photo. In this example,
that’s the corner where the building meets the ground, as shown in the following figure.
See Introducing Match Photo’s color-coded tools for tips on setting the axis origin.

6. (Optional) Clear the Model checkbox to hide your model from view. You don’t have to
hide your model, but it’s often a little easier to line up the vanishing point bars with the
photo if the lines in your model aren’t competing with your photo.
7. Click and drag the grips on each of the four vanishing point bars. Align the green
vanishing point bars with photo elements that need to be parallel the green axis bar.
Make the red vanishing bars align with photo elements that are parallel with the red
axis bar. The example in the following figure illustrates how the vanishing point bars
align with their respective axis bar.
Tip: Window frames, door frames, and roof lines are handy reference points for aligning
the vanishing point bars. Also, the longer the vanishing point bar extends, the better
your results.
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8. Select the Model checkbox in the Match Photo dialog box so that your model reappears.
9. Hover the cursor over the blue axis bar. When a two-headed arrow cursor appears, click
and drag the cursor up or down the blue axis bar to scale your model. You want the
model outline to line up with your photo, as shown in the following figure.

10. (Optional) In the Match Photo dialog box, click the Project Textures from
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Photo button to project the photo on the model. If you project textures, you can see
the photo applied to your model’s faces as you orbit around you model. The following
figure shows textures projected on the schoolhouse example.
Note: If your model already contains materials, SketchUp asks whether you want to
replace the existing materials. You may also see the Trim partially visible
faces? message. If so, click Yes to apply photo textures only to the visible portion of
faces in your model. Click No to apply textures to an entire face, even only a part of
the face is visible.

11. Click the Done button to exit the Match Photo toolset.
Tip: In the Match Photo dialog box, you can click Edit Matched Photo (the gear icon at the
top) to adjust the Match Photo tools.
Note: If you’ve taken several photos that you’re matching to each corner of a building, contextclick a Match Photo tool and choose Rotate 90 Right or Rotate 90 Left. These commands move
the red and green axes 90 degrees. If the commands don’t work well with your model and
photo, simply move the axes in the opposite direction, and click New Matched Photo button
(the plus sign icon in the upper left of the Match Photo dialog box). A new Match Photo scene
appears, and you can then place a new photo and set the origin point manually.
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Creating a 3D model from a photo
If you have a photo of something you want to model, Match Photo can help you draw the 3D
model.
Tip: This process works best for objects with parallel lines, such as the top and bottom of a
rectangular window.
To draw a model with the help of a photo and SketchUp’s Match Photo feature, follow these
steps:
1. Follow the steps in the preceding section, “Matching a photo with an existing model,” to
set up your axis origin, vanishing point bars, and scale. The only difference is that you
don’t need to worry about opening the model that goes with your photo or projecting
textures onto a not-yet-existing model. These steps explain how to draw the model
based on your photo.
Tip: To help you set the scale of your photo, insert one of SketchUp’s 2D people, as
shown in the figure. If you don’t already see one of these folks in your model already,
find them in the Components panel.

2. Select the Line tool
.
3. Starting at the axis origin, trace one of the edges in your photo. Continue tracing edges
until you create a face.
4. Use SketchUp’s tools to continue creating your 3D model based on the photo. For
example, after tracing the side of the barn shown in the following figure, you might use
the Push/Pull tool
to extrude the face, as shown in the following figure. When you
use the drawing tools, you’ll likely leave the Match Photo view. Click the Match Photo
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tab see your photo again and check the length of your extrusion against the length of
the barn in your photo.

Tip: The process of modeling from a photo is iterative. You’ll likely do a little drawing,
check your model against the photo, do a little more drawing, and so on.
5. (Optional) Click the scene tab to see your photo and project the photo textures onto
your model. To do so, click Project Textures from Photo in the Match Photo dialog
box or context-click the photo and choose Project Photo from the menu that appears.
In the figure, you see the barn textures projected onto the model.
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Deleting a matched photo
If your matched photo didn’t work out or you don’t need it any more, you simply delete the
Match Photo scene. Here are two ways to do so:
•
•

Context-click the scene tab and select Delete from the menu that appears.
In the Scenes dialog that appears, select the scene with your matched photo and then
click Remove Scene (the minus sign icon).
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Mixing Colors in the Color Picker
You're most likely to encounter SketchUp's color picker when you apply materials to a model.
(However, you do find the color picker elsewhere, such as when selecting a color for text.) This
article explains how to use the color picker for your current operating system.
To select a color, you can choose from the following different methods:
•
•
•
•
•

The color wheel
The HSB or HSL color model
The RGB color model
The CMYK color model (Apple macOS only)
Grayscale slider (Apple macOS only)

RGB or HSB color pickers work best for most SketchUp models and applications.
Tip: If you know the HSB, RGB, HEX or CMYK numerical code for the color you want, simply
type the color values in their respective boxes. Or, if you find a color you want to use elsewhere,
within or outside SketchUp, take note of its numerical code. Then you can simply retype the
code for an exact color match.
The color wheel arranges color hue radially around the wheel, with the highest saturation at
the outer edge of the wheel. If you're not familiar with the different color models or just want
to pick a color by sight, rather than enter a numerical color code, the color wheel is an easy
choice. Simply click a color on the wheel to select it. Click and drag the slider next to the wheel
to make the selected color brighter or darker.
On Microsoft Windows, the color wheel appears on the Materials browser's edit tab, as shown
in the figure.

HSB stands for hue, saturation, and brightness. This color model helps you easily select
desaturated colors. For example, if you know you want a deep gray color that has red
undertones, first select a red in the Hue spectrum. Then use the Saturation slider to desaturate
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the red, so there's just a little bit left. Use the Brightness slider to adjust the brightness or
darkness of your color.
In the following figure, you see the HSB color picker in Microsoft Windows. If you're a Windows
user, you also see an HLS color picker. The HLS color model, which stands for hue, lightness,
and saturation, is very similar to HSB.

RGB stands for red, green, and blue. This color model is traditionally used when modeling color
on a computer screen. RGB offers a wide range of colors (also called a wide color gamut) and
is the most effective color space in SketchUp. Use the sliders or type a value to select a color
in the RGB color space.
The following figure shows SketchUp's RGB color picker in Microsoft Windows.
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Getting Started with Modeling from Trimble Vision
Imagery
By using Trimble Vision Imagery to collect precisely located imagery, you can now use Trimble
Business Center (TBC) to generate key points from the collected data that will aid the modeling
process within SketchUp.
Note: This article assumes that you have a good understanding of drawing geometry and
making components. For more information about the process performed in Trimble Business
Center (TBC), please consult the TBC Help system. This article only addresses the process of
importing the .skp file generated from TBC onward.
1. Open the .skp file that was exported from Trimble Business Center (TBC) via File >
Open.
2. Once imported, you will see the guide points generated from TBC as seen below:

3. Each panoramic image is imported as its own Match Photo Scene which are located
across the top of the modeling window. Scenes can be modified by using the Window
> Scenes window or by right-clicking an individual scene tab at the top of the modeling
window.
Note: When importing V10 data, the imagery captured from the downward facing cameras
could be included. To delete unwanted images, simply delete them by using the described
methods above.
4. The blue axis will be oriented in its native vertical direction. However, the red and green
axes will need to be aligned with the orientation of the building.
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5. To do this, use the Axes tool (
) to set the model axes so successive geometry is
properly aligned with the building orientation.
6. To start modeling, use the Image Igloo View (Camera > Image Igloo) to navigate to
a Matched Photo Scene with a guide point present and press Enter or double-click the
scene to activate the highlighted scene.
7. In this example, we will be modeling this building starting with the guide point shown
below:

8. Use the Line tool (
) to draw a line from the guide point to the corner inferencing
the blue axis as shown here in yellow:
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9. Now use the Line tool ( ) to draw the face of the building inferencing the axes. It is
helpful to use the zoom feature as you draw:

10. Once one face of the building is modeled, use the Push/pull tool (
) to create the
basic 3D structure of the building:
11. Continue modeling by using the Image Igloo View to navigate between scenes and use
the guide points generated in TBC. If needed, use the Photo Point tool (
) to
manually create camera guidelines that can be used for geometry when guide points
are not available.
12. Once finished, textures can be applied to your model by using the Position Texture
tool or by using the "Project textures from photo" function within the Match Photo
window.
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Components

and

Dynamic

SketchUp components enable you to reuse objects. For example, pretty much every building
has at least one door and window. Instead of modeling these common objects, you can insert
a component that someone else has already made.
Like all geometry in SketchUp, a component is still made of edges and faces. The edges and
faces are simply part of a special component group. (You can also create components to reuse
your own geometry, but that’s covered in Developing Components and Dynamic Components.)
Table of Contents
1.
2.
3.
4.
5.
6.
7.
8.
9.

Getting started with components
Inserting components
Replacing components
Interacting with dynamic components
Searching for components
Adjusting a component’s insertion point
Editing components
Organizing component collections
Gathering intelligence about components

Getting started with components
Before you start inserting components, you need to know that every component has a definition
and an instance:
•
•

A component definition provides a blueprint for how all components of a specific type
appear and behave in the drawing area.
When you insert a component into a model, you create a component instance, which
is based on its definition.

So, say you want to use a premade component called Framed Half Door with Double Panel. The
component definition outlines what that door looks like, and you can insert as many instances
of that component into your model as you like. In the following model, you see two instances
of Framed Half Door with Double Panel. Inserting components, later in this article, explains
how insert one or more component instances.
(cont’d next page)
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Tip: All this business about the definition and instances is important, because when you edit
entities within a component instance, you edit the definition, too. Change the door’s glass,
and the glass in all component instances changes. Change the double panel into a single
panel, and all the doors in your model have a single panel, too. However, you can scale,
rotate, and flip a whole component without changing the other instances. Editing components
explains how to edit component entities or the component as a whole.
You can also replace all component instances with another component. If you (or a client)
decide you don’t like the Framed Half Door with Double Panel, you can easily swap that
component with a different one. See Replacing components, later in this article, for details.
Dynamic components have even more capabilities than regular components. If a component is
dynamic, it has at least one of the following elements:
•

•

•
•

Constrained values: For example, a dynamic cabinet door component might have a
frame that’s constrained to 3 inches. Whether the panel inside the frame is 12 x 24
inches or 24 x 48 inches or some other dimension, the frame remains 3 inches wide all
the way around the door, as shown in the following figure.
Repetitive elements: A dynamic component can have subcomponents that repeat as
you scale the component. For example, a repetitive dynamic component might add steps
to a staircase, cushions to couch, pickets to a fence, studs to construction framing, and
so on.
Configurable values: A dynamic component can have a predefined set of values that
you can configure, such as a couch’s length or the picket spacing in a fence component.
Animated features: An animated dynamic component moves when you click it with
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the Interact tool (
). With animated dynamic components, your model can have
doors and windows that open. Interacting with components, later in this article, explains
how to open and close animated components.

You can find a few sample components in SketchUp’s Components panel, but components’ true
home is the 3D Warehouse, an online tool for searching and downloading 3D models created
in SketchUp. This article helps you navigate the Components panel and start searching for
components in the 3D Warehouse via tools available in SketchUp.
After you become comfortable inserting and editing components, you might develop a special
fondness for components that you find in the 3D Warehouse or create yourself. To keep your
favorite components handy and organized, you can create collections in the Components panel.
In the following video, you see a brief introduction to components, how components are
different from groups, and ways you can edit components. Although this video was created on
an older version of SketchUp, the basic component behavior and features are the same in
current SketchUp versions. In the sections that follow, you find detailed steps that walk you
through the basics of inserting and working with components and dynamic components.

Inserting components
You can insert a component instance into your model in three ways:
•
•
•

Select or download a component via the Components panel.
Import a SketchUp file (with the .skp file extension).
Drag a SketchUp file from File Explorer (Microsoft Windows) or the Finder (Apple
macOS) into your model.

Premade components are most often inserted from the Components panel into a model. Follow
these steps:
1. By default, the Components panel opens to the Components Sampler collection, as
shown in the figure.
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2. You can select one of the sample components and proceed to the next step. However,
the sampler’s selection is limited compared to the vast selection in the 3D Warehouse.
To try the 3D Warehouse, type a search term in the 3D Warehouse search box.
(Searching for components, later in this article, explains other ways to search the 3D
Warehouse.) To browse collections, click the down arrow next to the In Model icon (
) and select a collection. (See Organizing component collections for details about the
existing collections and how to create your own.) After you select or download a
component, SketchUp loads the component onto the Move cursor.
3. Click in the drawing area to place the component in your model.
Tip: If you have trouble seeing the components in the Components panel, try changing your
view options. Click the View Options button (
Thumbnails, Details, or List.

) and choose from Small Thumbnails, Large

If you have a SketchUp model saved to your hard drive, you can import that model as a
component in another model. Follow these steps:
1. Open the model into which you want to import a SketchUp file.
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2. Select File > Import.
3. In the Open dialog box that appears, navigate to the SketchUp file. If you don’t see
your file, in the Files of Type drop-down list, select SketchUp Files (.skp).
4. Select the SketchUp file, and click Open. SketchUp loads the component onto the Move
cursor.
5. Click in the drawing area to place the component in your model.
Dragging a SketchUp file from the File Explorer (Microsoft Windows) or the Finder (Apple
macOS) into an open model also loads the SketchUp file onto the Move cursor. Simply click to
place the component in your model.
Tip: When your component is loaded onto the Move tool cursor, the Move tool is anchored to
the component’s axis origin point. If that doesn’t work for you, change the location of the
component’s axis origin before you insert the component. Doing so will change the default
insertion point. See Adjusting a component’s insertion point for details.

Replacing components
People like to see different options, and they change their minds all the time. When indecision
strikes or your design just hasn’t become clear to you yet, know that you can easily replace
one component with another component. Here’s how the process works:
1. Add the new component to your model. If you don’t have anywhere to put it, just place
it in an empty area in your model by following the steps in the preceding section. Placing
the component somewhere in your model ensures that the component appears in your
In Model collection. (Even if you then delete the component for now, the component
remains in your In Model collection until you purge unused components.)
2. In the Components panel, click the In Model icon (
) to see your In Model collection.
3. Select the component or components that you want to replace.
Tip: To select all instances of a component, context-click the component in the Components
panel and choose Select Instances, as shown in the figure.

SketchUp Help Pages – version 19.

Page 221/567

4. In the Components panel, context-click the component you want to use instead of the
existing one and choose Replace Selected from the context menu. In this example,
that’s the Large Panel Door component. The old door is now replaced with the new door,
as shown in the following figure.

Tip: SketchUp Pro users have an additional tool: the Swap Component command, which works
with dynamic components.
To swap out a series of dynamic components in SketchUp Pro, follow these steps:
1. Select the dynamic components you want to replace. The components are highlighted
in the drawing window.
2. Context-click one component, and select Dynamic Components > Swap
Component. The Select a SKP dialog box is displayed.
3. Select the SketchUp file containing the dynamic component that will replace the
currently selected components.
4. Click the Open button. The new dynamic component replaces the previously selected
dynamic components.

Interacting with dynamic components
Your ability to interact with a dynamic component depends on its variables. In the following
figure, you see a basic building with two instances of a dynamic door component.
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To activate the component’s animation, select the Interact tool (
) on the Dynamic
Components toolbar or select Tools > Interact. When you click the door with the Interact tool
cursor, the door opens, as shown in the following figure.
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This dynamic component also has configurable values. To see these values, click
the Component Options tool (
) on the Dynamic Components toolbar or select Window
> Component Options. In the Component Options window, shown in the following figure, you
can choose from preset options for the frame width, frame height, door type, and more.

Searching for components
You can search for components in the Components panel or the 3D Warehouse.
In the Components panel, on the Select tab, you can use the following features to browse or
search for components:
•
•

In Model icon: Click the In Model icon (
), and you see the In Model collection, which
shows all the components currently saved with your model. Note that a component
doesn’t have to actually appear in your model to be saved with it.
In Model drown-down menu: Click the down arrow next to the In Model icon, and
from the list that appears, you can select premade collections such as Architecture,
Landscape, People, and Transportation. This menu may also show collections you’ve
created, collections you’ve designated as a favorite, or collections you’ve visited
recently. (Organizing component collections, later in this article, explains how to create
and manage collections.)
Tip: If your model is geolocated, the Components panel enables you to search for
nearby models. Search for components in the search box. Then, from the In Model dropdown menu, select Nearby Models, which filters your search results to nearby models.

•

3D Warehouse search box: Type a search term in the box and press Enter (Microsoft
Windows) or Return (Apple macOS), and you see a list of components from the 3D
Warehouse. To connect to the 3D Warehouse, your computer needs to an Internet
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connection. If your search brings up multiple results, you can click the arrows at the
bottom of the Components panel to see more results. You may find it easier to search
the 3D Warehouse in a full browser window than the Components panel, which is too
small to show much detail in the component thumbnails.
To access the 3D Warehouse directly from SketchUp, click the Get Models tool (
you find in the following parts of SketchUp’s interface:
•
•

), which

Getting Started toolbar
Warehouse toolbar

You can also select File > 3D Warehouse > Get Models.
Whichever method you use, the 3D Warehouse opens, as shown in the following figure. From
the opening screen, you can browse the featured models, featured manufacturer catalogs,
featured collections, and recent models. However, you most likely want to use the Search box
at the top. Type a search term and click the Search button.
Tip: Start with the most specific search term. For example, if you’re looking for a window
that’s a dynamic component with a cut plane that makes a hole in your model, type a search
term like, dynamic component window cuts face. If you don’t find a component you like, make
your search term less specific from there.

When you find a result that interests you, click it to open its details page. Click
the Download button in the upper right to download the component into your model. You then
return to SketchUp, where the Move cursor is loaded with the component. Click in the drawing
area to place the component in your model.

Adjusting a component’s insertion point
A component has its own axis origin point, which determines the component’s insertion point,
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or the point that’s loaded onto the Move cursor when you place a component in your model.
If the component is box-shaped (such as a dresser, cabinet, or the Mesopotamian Tablet of
Destinies), the insertion point is typically the front, lower-left corner, as shown in the figure.
That placement works great — unless you need to place the component against other
components or otherwise work around existing geometry.

Whatever your reasons for moving the insertion point, here’s how to reset a component’s axis
origin:
1. Select the component in your model.
2. Context-click the component and select Change Axes.
3. With the Axes tool cursor that appears, reset the axis origin. See Adjusting the Drawing
Axes for details about working with the Axes tool. The only difference is that you’re
setting the axis origin for a component, not the whole model.
Tip: After you place a component in your model, you can move the component by any point
you like. Simply select the Move tool (
), click the point you want to use for moving the
component, and click again to place the component. For example, after placing a cabinet
component in your model, you might need to move the cabinet by its midpoint so you can slide
the cabinet next to existing cabinets. See Moving Entities Around for more about moving
entities with the Move tool.

Editing components
You can edit a component as a whole or edit individual entities within a component.
Note: Editing or modifying a component instance as a whole affects only the component
instance, not the component definition or other instances.
Here are some of the edits you can make to a component as a whole:
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Scale: Scaling a component as a whole scales the individual component instance, not
the component definition, allowing you to have differently scaled instances of the same
component in your model. A component can become skewed when you scale the
component in multiple directions. You can reset a component’s scale and skew by
context-clicking the component and selecting Reset Scale or Reset Skew. To scale a
component, use the Scale tool(
), as explained in the article, Scaling Your Model or
Parts of Your Model.
Flip: You can flip (or mirror) a component along an axis. Context-click the component,
select Flip Along, and select an axis (Component’s Red, Component’s Green, or
Component’s Blue).
Rotate: You can rotate a component with the Rotate tool (
) or the Move tool (
). When you use the Rotate tool, you have more control over the rotate plane and center
of rotation.

Flipping and Rotating explains how to flip and rotate geometry. To rotate a component with the
Move tool, hover the Move tool over a face that’s perpendicular to the desired axis of rotation
until four rotation handles and a protractor appear on the face, as shown in the following figure.
Then click a rotation handle and rotate the component.

Editing entities within a component changes the component definition, and thus
changes all other component instances in your model. To learn about the more advanced
techniques involved in editing a component definition, see Editing a Component in
the Developing Components and Dynamic Components section.
You can also save edits to your component, revert an edited component to the original file, or
explode the component:
•

To save an edited component as a separate file with a new name, select the
component, context-click it, and select Save As from the menu that appears. Navigate
to where you want to save the .skp file, type a new name, and click Save.
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To reload a component from its original file, which overrides any edits, contextclick the component and select Reload.
To break a component back into its entities, select your component and then
select Edit > Component Instance > Explode from the menu bar. Or context-click
the component and select Explode from the menu that appears. Your component is no
longer a component with a special force field. It returns to plain old geometry, kind of
like a captain returning to civilian life.

Note: You can edit properties of a component, such as whether it cuts a hole in a face, or set
variables for a dynamic component. Because these advanced tasks are closely related to
creating components, you find out how to work with these properties in Developing Your Own
Components or Dynamic Components.

Organizing component collections
In SketchUp’s Components panel, collections help you organize components.
The In Model collection is a special collection that’s an important part of the Components panel.
It holds all the components saved with your model, whether or not those components currently
appear in your model. When you context-click a component in this collection, you see
commands not available in other collections, such as Select Instances, Reload, and more.
To see your In Model collection, click the In Model icon (

). If you’ve inserted several

components that you no longer need to save with your model, click the Details arrow (
and select Purge Unused.

)

SketchUp includes a few prebuilt collections, such as Architecture, Landscape, Construction,
and so on. You find these collections by clicking the down arrow next to the In Model icon, as
shown in the following figure.
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Tip: By creating your own collections, you can organize components in whatever way makes
sense to you. If you use certain components all the time, create a My Favorite Components
collection. If you use specific components for a certain client or project, organize them into a
collection so they’re accessible from a single collection.
The following steps explain how to create a component collection for your selected operating
system (Microsoft Windows or Apple macOS):
1. Click the Details arrow (
) and select Open or Create a Local Collection.
2. In the dialog box that appears, navigate to the folder where you want to save your
collection. To create a subfolder for the collection, click the New Folder button and
create the folder.
3. Select the folder where you want to save the components collection and click . You see
a blank collection on the Components panel’s Select tab. If the blank folder doesn't
appear, click the In Model drop-down arrow and select the collection that matches your
folder from the menu.
4. Click the Display Secondary Selection Pane icon (
).
5. In the secondary selection pane, navigate to a component that you want to add to your
collection and drag it into the blank collection. In the following figure, the Galaxy Class
Starship component in the In Model collection (bottom) was added to the newly created
Components collection (top).
6. Continue navigating to components in the secondary selection pane and adding them
to your new collection until your collection is complete.
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Tip: After you have a few collections, you can add them to a list of favorite collections that
always appears on the In Model drop-down menu. First, display the collection the Components
panel: If you used the collection recently, you can select the collection by name from the In
Model drop-down menu. If the collection doesn’t appear there, click the Details arrow and
select the Open or Create Local Collection (Microsoft Windows) or Open a Local
Collection (Apple macOS). After your collection appears in the Components panel, click
the Details arrow and select Add to Favorites or Remove from Favorites.

Gathering intelligence about components
SketchUp provides a few tools that enable you to find important details about components:
•

•

The Entity Info window is the most basic. To open it, context-click a component and
select Entity Info. Or select a component and then. If your entity is indeed a
component, you see Component in the upper left and how many of instances of the
selected component appear in your model.
In the Components panel, you see the component’s name, thumbnail, and description
at the top. Click the Statistics tab, and you see a report of how many elements, such
as faces, edges, construction lines, appear within the component. Select All
Geometry from the drop-down list to see statistics for all geometry in the component
or group. Alternatively, select Components from the drop-down list to see statistics for
all components in the component. Finally, click Expand to see components and groups
nested within the currently selected component or group.
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Inspecting an Entity
As you create 3D models in SketchUp, you create an entity whenever you draw a line or face.
Combining lines and faces into a group or component creates a special group or component
entity.
Each entity in a model has attributes, such as its measurement, the layer it’s on, and more. If
an entity is a component, then it has an instance and might be a solid (or not) or have other
attributes, such as an IFC type.
Depending on what you’re doing in SketchUp, you might need to know or change an entity’s
attributes. To do so, look in the Entity Info panel:
1. Select one or more entities.
2. Open the Entity Info panel byThe entity’s details appear before you. If you select
multiple entities, you see the number of selected entities.
The following figure shows an Entity Info panel for an edge, a face, a group, and a component.

Tip: The Entity Info panel also enables you to toggle visibility, locked status, and an entity’s
ability to cast and receive shadows. To toggle any of these items, click the [original text in Web
site missing. Reported.]
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Organizing a Model
To appreciate SketchUp’s organization tools, you don’t need to be the type who has a separate
compartment for every spoon, bottle stopper, and spatula in your kitchen drawers. If you spend
a little time learning how SketchUp’s organization tools work, you can organize geometry as
you go with little effort.
Here’s a quick overview of the techniques for organizing your model:
•

•
•

Organize related geometry into groups or components, which enable you to
isolate geometry into smaller chunks within your model. Grouping
Geometry explains how to create groups. For an introduction to components,
see Adding Premade Components and Dynamic Components. To create your own
components, see Developing Components and Dynamic Components.
Nest groups and components within other groups and components to create a
hierarchy. You can give your groups and components meaningful names and find them
easily using the Outliner. Check out Working with Hierarchies in the Outliner for details.
Toggle the visibility of groups and components on or off. In SketchUp, to control
what’s visible in your model, you use groups and components in combination with
layers. If you use other image-editing or CAD modeling programs, the behavior of
SketchUp layers is completely different from those programs. Controlling Visibility with
Layers offers tips and tricks to help you manage SketchUp layers successfully.

Grouping Geometry
In SketchUp, groups help you organize your model because
•
•
•

•

Groups hold other entities. In a 3D model of a house, for example, you can put all
the house geometry into a group.
You can nest groups within groups. For your house model, this means that the first
floor, second floor, and roof can each be a group within the house group. In each of
your floor groups, you can nest furniture, which may be groups or components.
Grouped entities don’t stick to entities outside their own group. This means you
can edit each group independently of other groups, even if the groups are stacked on
top of each other. For example, if you need to change footprint of a house, you can
change the floor first and then edit the roof to match. Without these groups, the walls
in the house would stick to the roof, and all the geometry can quickly become distorted.
You can lock groups to prevent editing. A locked group can't be moved or edited
and is a great way to have boundaries for convenient snapping without accidentally
modifying your geometry.

Tip: When you need to see how groups or components are nested, look no further than the
Outliner. Working with Hierarchies in the Outliner explains everything you can do with this
handy feature.
To create and work with groups in a 3D model, here’s what you need to know:
•
•

To select a group, click it with the Select tool. The group's bounding box becomes
highlighted, as shown in Callout 1.
To open a group’s context so that you can edit the entities within the
group, double-click the group with the Select tool. The dotted box indicates the group’s
context is open and you can edit the entities. (See Callout 2.) To leave the group’s
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context, click an empty part of the drawing area, or choose Edit > Close
Group/Component.
To create a group, select all the geometry you want to include in the group. (Selecting
Geometry offers lots of tips for making selections.) Then, from the menu bar,
choose Edit > Make Group. Alternatively, context-click the selection and choose Make
Group.
To break up the group, click to select it and choose Edit > Group > Explode.
To lock a group so it can’t be edited, context-click it and select Lock. After you lock
a group, the menu item changes to Unlock, so you can reverse the change. Lock a group
to prevent it from being edited accidentally as you work on nearby parts of a model.
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Working with Hierarchies in the Outliner
In SketchUp, the Outliner enables you to view a model's groups, components, and section
planes as a hierarchical tree. With the Outliner, you can
•
•
•
•

Navigate large models.
Name groups, components, and section planes
Find a component instance or section plane.
Restructure the model hierarchy.

Note: The Outliner is also included with SketchUp for Web, Shop edition. To learn more about
the features in SketchUp Shop, see SketchUp for Web: Free vs Shop.
To open the Outliner, as shown in the following figure, select Window > Outliner from the
menu bar. Your model's name appears at the top of the hierarchy. In this example, the model
is named Two story house and within the House group, it contains three groups named First
floor, Second floor, and Roof. (The Roof group is hidden.) You also see a section plane
called Plan view, although the section plane isn't visible and the section cut isn't active.

When a group or component contains nested elements, the Outliner's navigation tree displays
a plus sign (Microsoft Windows) or triangle arrow (Apple macOS) next to the group or
component's name.
You can explore the hierarchy of your model in the following ways:
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•

To see what's nested in a group or component, click the plus sign or triangle next
to its name. The plus sign changes to a minus sign or the right-pointing triangle turns
downward. After you display nested elements, you can then click the minus sign or
downward triangle to close that branch of the hierarchy.
To see all the groups, components, and section planes in a model's

•

hierarchy, click the Details arrow (
) and select Expand All from the menu.
To close the hierarchy, click the Details arrow and select Collapse All.

In the sections that follow, you find details about naming and finding groups, components, and
section planes and changing the structure of your model's hierarchy.
Table of Contents
1.
2.
3.
4.
5.

Renaming a group, component, or section plane
Finding a group, component, or section plane
Identifying the status of a group, component, or section plane
Restructuring a model's hierarchy
Controlling visibility with the Outliner

Renaming a group, component, or section plane
While this article mentions the ability to name and identify Section Planes, this feature is only
available in SketchUp 2018 and newer versions.
After you create group, component, or section plane, the Outliner enables you to give that
entity a meaningful name.
Tip: Giving these entities meaningful names enables you and others to find, select, and edit
the entities quickly and easily. For example, a meaningful name might describe a group or
component's location. In a model of a housing development, you might create a group for each
plot of land and name it after the plot numbers. As you continue to build the model, you might
import SketchUp models of standard house designs, and each component's name would reflect
the design name. In the preceding figure, each group was given a more descriptive name than
the default name, Group. With the descriptive names, you can easily see which group is the
roof, first floor, or second floor.
Rename a group
To name (or rename) a group in the Outliner, follow these steps:
1. Context-click the group name in the Outliner and select Rename from the menu that
appears.
2. Type a name.
3. Press Enter (Microsoft Windows ) or Return (Apple macOS) to save the name.
Rename a component
Compared to renaming groups, renaming components is a bit more complicated. You can
rename the component definition or an instance of that component's definition. ( Adding
Premade Components and Dynamic Components explains the difference between a component
definition and a component instance.)
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By default, every component instance has the same name as its definition, and in the Outliner,
all components are enclosed in angle brackets. If you have several component instances with
the same name, you may have a hard time finding the instance you need. Say you have four
instances of the same chair component, and each instance illustrates a different color option.
To locate each color option quickly and easily in the Outliner, you might add the color name to
each component instance. To rename a component instance, follow the same steps you use to
rename a group.
When you rename the component definition, you change the name of every component
instance in your model. To rename a component definition, follow these steps:
1. In the Outliner, context-click the component name and select Entity Info from the
menu that appears.
2. In the Definition text box, select the component definition name and type a new one,
as shown in the following figure. When you're done, you can close the Entity Info box.
Back in the Outliner, your component instances all show the new definition name.

Rename a section plane
The Outliner enables you rename both the section plane and its symbol. To rename a section
plane via the Outliner, context-click the section plane and select Rename Section
Plane or Rename Symbol. Then type your desired name for the plane or symbol and
press Enter.
For details about section planes, see Slicing a Model to Peer Inside.
Finding a group, component, or section plane
When you need to find a specific group, component, or section plane in your model, here's how
the Outliner can help:
•

•

Select: When you select a group, component, or section plane in your model, it
becomes highlighted in the Outliner, too. Conversely, select a group, component, or
section plane in the Outliner, and you select that a group, component, or section plane
in your model.
Sort: To sort all the model entities in the Outliner by name, click the Outliner's Details
arrow (
) and select Sort By Name. If this menu item is selected, choosing it
deselects the Sort By Name option. When Sort By Name is deselected, components are
sorted by creation or insertion.
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Filter: At the top of the Outliner, type a term to filter what entities appear in the
Outliner. In the following figure, you see the Outliner is filtered to show only entities
that contain the word Floor.

Identifying the status of a group, component, or section plane
The Outliner uses icons and text to identify a group, component, or section plane, as well as
its status (open, locked, or hidden). The following table shows how the icon and text change
as the group or component's status changes.
Tip: Open means a group, component, or section plane it can be edited. Locked means the
group, component, or section plane can't be edited, as explained in Grouping Geometry. Hidden
means the group, component, or section plane isn'''t visible, as explained in Softening,
Smoothing, and Hiding Geometry.
Status

Group

Component

Open
Inactive n/a

Section Plane
*

n/a

Locked
Hidden

* Section plane cuts are also active or inactive. This image displays a section plane that is
unlocked and an active cut.
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Restructuring a model's hierarchy
If a model's group and component hierarchy needs to be adjusted, you can click and drag an
item to a new position in the Outliner.
For example, say you want the sofa to be tucked inside the First floor group, so that the
hierarchy reflects where the sofa is located. Simply drag the sofa component to the desired
position, as shown in the figure.

Controlling visibility with the Outliner
As mentioned in the table earlier in this article, any item that's grayed out in the Outliner is
hidden. Indeed, the Outliner can be a helpful way to hide or show elements in your model as
you work on it.
To hide an element in the Outliner, context-click it and select Hide from the menu that appears.
Everything your element contains becomes hidden. For example, to hide everything in the
second floor and see only the first floor, all you have to do is hide the Second floor group and
Roof group, as shown in the figure.
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To see the hidden group, component, or section plane again, simply context-click it in the
Outliner and select Unhide.

Controlling Visibility with Layers
In SketchUp, layers control your geometry's visibility.
Warning: If you have image-editing experience or work in CAD, you probably expect
SketchUp's layers to keep elements separate from each other. In SketchUp, layers do not
isolate geometry from other geometry, but if you use SketchUp layers expecting them to do
so, creating 3D models becomes a difficult and frustrating experience. Geometry on each layer
sticks to the other layers, and you'll be selecting, moving, stretching, and otherwise changing
geometry in ways you don't expect. The video at the end of this article illustrates some of the
frustrations new SketchUp users have with layers and the techniques in this article that help
you avoid those frustrations.
Tip: Protect your happiness. Set your expectations accordingly. Use layers to control only
visibility, following the recommendations in this article.
To work with SketchUp layers successfully, you need to understand the following concepts:
•

Every model has Layer0. Layer0 is the default layer, and you cannot delete it. Layer0
is like a base layer on which you draw everything in your model. You add new layers
only to control visibility.
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A group or component controls the layer visibility of the entities that the group
or component contains. So, to control visibility, associate only a group or component
with a layer (not entities within that group or component). Always draw individual
entities on Layer0 and leave them there. When you associate the group or component
with a layer, the entities within the group or component remain on Layer0, where they
belong.
Geometry is connected. Remember that, in SketchUp, layers don't isolate geometry.
Groups and components do. Without groups and components, geometry on one layer is
connected to geometry on every other layer.

When you apply these concepts to creating a 3D model that has layers to control visibility, the
process looks like this:
1. Draw everything on Layer0. If you're new to drawing in SketchUp, start with the
article, Drawing Lines, Shapes, and 3D Objects.
2. Organize sections of your model into groups or components. Grouping
Geometry explains what groups are and how to create them. For an introduction to
components, see Adding Premade Components and Dynamic Components; find out how
to create your own components in Developing Components and Dynamic Components
3. Create a new layer.
4. Associate only that group or component with that layer. Repeat Steps 3 and 4 until you
have a layer for each group or component whose visibility you want to toggle on or off.
5. Use the Layers panel to control the group or component's visibility.
To find out how to do Steps 3–5, keep reading this article.
Now that you understand the basic concepts, here's an example, that shows how layers control
visibility. In the following figure, each group has been assigned to its own layer, and each layer
appears in the Layers panel.

After the Visible checkbox for the Roof layer is deselected, the roof becomes hidden, and you
can peer inside the second floor.
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Almost everything you can do with layers happens in the Layers panel, which you open by
selectingHere's a quick rundown of what you can do in the Layers panel:
•
•

•
•
•
•

•

Add layers. Click the plus sign icon in the upper left, and a new layer appears in the
list. Type a name for the layer and press Enter (Microsoft Windows) or Return (Apple
macOS).
Delete layers. Select a layer by clicking its name so it becomes highlighted. (The radio
button to the left indicates the active layer, which is different from selecting a layer.)
Then click the minus sign icon in the upper left. If you've assigned anything to the layer,
SketchUp asks what you'd like to do with the layer's contents: Move to Current Layer,
Move to Default Layer, or Delete Contents. Select an option and click OK (Microsoft
Windows) or Delete (Apple macOS). To delete all unused layers, click the Details arrow
(
) and select Purge.
Name layers. When you create a layer, the default name is selected and ready for you
to replace with a meaningful name. If you decide to rename a layer, simply double-click
its name in the Layers panel and enter a new name.
Select the active layer. To the left of each layer's name is a radio button, and the
selected radio button indicates the active layer.
Tip: Make sure that Layer0 is selected before you draw or edit any geometry.
Change a layer's visibility. Every layer as a checkbox in the Visibility column.
Deselect this checkbox to hide the layer. To display the layer again, select the checkbox.
Sort layers. When you click the Name or Visible column header, you sort the list of
layers. Clicking the Name column sorts the list in ascending or descending order.
Clicking the Visible column orders the list so that visible layers are sorted from the
invisible ones.
Color geometry by layer color. Have you noticed the color squares next to each
layer? When you click the Layers panel Details arrow (
) and select Color By Layer,
SketchUp applies a color material to your model based on the layer color. In the
following figure, you can see how the groups match their corresponding color swatch in
the Layers panel. If you want to revert to your original materials, simply deselect Color
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By Layer. SketchUp selects a color when you create a layer, but you can change a layer's
color by clicking the color swatch in the Layers panel and using the color picker that
appears to select a new color. (For help with the color picker, see Mixing Colors in the
Color Picker.)

One thing the Layers panel can't do is move a group or component to a new layer. After you
create a group or component and set up your layers, you move a group or component to a
layer as follows:
1. Select the group or component in the drawing area.
2. Context-click your selection and choose Entity Info.
3. In the Entity Info panel that appears, select a layer from the Layer drop-down list.
Remember that you need to set up your layers before you can choose one from this list.
Watch this video14 to see SketchUp's layers feature in action. You also discover tips for
cleaning up layers from imported CAD files and for using layers to improve SketchUp's
performance when you're working on a large model. The video introduces SketchUp's
Layers toolbar and why you need to be careful about the active layer if you use the toolbar.

14

https://youtu.be/oCz1aC99txo
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Applying Dashed Lines to Layers
In SketchUp, the Layers panel has dash patterns so you can change entity lines on a layer from
solid to dashed. Any geometry on the layer inherits the layer’s dash pattern. Dashed lines
appear in the model view at any screen scale.
With these dash patterns, you can define property boundaries, identify elements to be
demolished in a model of an existing structure, or create a grid or reference lines (for elements
like topology or hidden pipes or services).
Dashes also help you follow simple and efficient workflows when you use SketchUp with
LayOut and/or a CAD program.
For details about how SketchUp layers work, see Controlling Visibility with Layers.
Table of Contents
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Follow the dashes workflow
Choose a dash pattern in the Layers panel
Control dashes of components and groups
Toggle dash pattern visibility
Work with dashes imported from a CAD file
Print a model with dashes
Export an image or model with dashes

Follow the Dashes
Because you select dash patterns in the Layers panel, it’s helpful to think about how to apply
dashes in the overall context of working with layers:
1. When you draw your model, draw on Layer 0 and create groups or components as you
normally would.
2. Use layers to organize entities by type, such as a layer for trees and a layer for buildings
or a separate layer for each floor of a building. (See Controlling Visibility with Layers for
more information.)
3. When you want to assign a dash pattern to a layer, give the layer a name that clarifies
what the dash pattern communicates. For example, you might name the layer Property
Boundary, Demolition Lines, or Underfloor Heating.
4. In the Dashes column of the Layers panel, select the dash pattern you’d like to apply to
the layer. Choose from several styles with dashes, dots, or some combination.
5. Move the geometry that will have dashed lines to the layer you created. To move
geometry to a layer, select the geometry you want to move and use the Layer dropdown menu in the Entity Info panel to move the selected geometry to the desired layer.
6. (Optional) Toggle the visibility by layer to hide geometry or adjust whether all lines are
solid or dashed globally for the model in the Styles panel.
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Choose a dash pattern in the Layers panel
To choose a dash pattern for a layer, follow these steps:
1. In the Layers panel, click Default in the Dashes column for the layer to which you want
to add dashed lines.
2. Select the dashed line style from the menu that appears. Any geometry on the layer
now has dashed lines.

Tip: If you don’t see dashed lines, select the geometry that should be dashed and use the
Entity Info panel to check that the geometry is on the correct layer. If that doesn’t work, open
the Edit tab of the Styles panel, select the Edge Settings icon, and make sure the Dashes
checkbox is selected.
With the Profiles and Depth Cue edge style options, edges appear thicker or thinner to create
certain effects. These varied thicknesses apply to dashed lines in the same way they apply to
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solid lines.
Control dashes of components and groups
Note that components and groups inherit the dash style of their layer with one exception: edges
assigned to a layer with a dashed line style within the component do not inherit the
component’s line style.
Tip: You might be familiar with the way components inherit dashed lines if you’re familiar with
the way components inherit materials. You can apply a material to an entity within a component
and then apply a different material to component.
With this behavior, a component can contain 3D geometry and a patterned 2D representation
on different layers. The following figure of a door is an example. The dash pattern that
illustrates how the door swings is within the door component, and the lines of the 3D door and
2D swing pattern are different.

Toggle dash pattern visibility
Layers were designed to control the visibility of the geometry on a layer. When you toggle a
layer’s visibility, you toggle the visibility of the edges and their dashes on that layer. To toggle
a layer’s visibility, clear the Visible checkbox for the layer in the Layers panel.
Globally, you can control the visibility of only the dashes via the Styles panel. To show dashes,
display the Edge Settings on the Edit tab and select the Dashes checkbox. When you clear the
Dashes checkbox, the lines are visible but the dashes are not.
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Work with dashes imported from a CAD file
All CAD line styles (imperial and metric equivalents) can be imported. When you import a CAD
file (.dwg or .dxf) into SketchUp, the layers from the CAD file appear in SketchUp and retain a
close approximation to the original dashed lines.
Note: When SketchUp doesn’t offer a dash pattern that’s an exact match for a CAD line style,
SketchUp uses the closest match. If SketchUp doesn’t offer a close match for a CAD line style,
the line appears with a solid dash pattern.
You can change the dashes in SketchUp on the Layers panel by selecting a different dash
pattern for the layer.
(cont’d next page)

SketchUp Help Pages – version 19.

Page 246/567

SketchUp Help Pages – version 19.

Page 247/567

SketchUp Help Pages – version 19.

Page 248/567

Print a model with dashes
Although you can print a model with dashes directly from SketchUp, using LayOut to print is
recommended. For a professional SketchUp user, LayOut enables you to print more accurately
and offers more control over size, page setup, and line thickness and quality.
To print a model with dashes from SketchUp, here’s the recommended workflow:
1. Export the model as a PDF, which is a 2D vector graphic file.
2. Print the PDF using a third-party application for printing PDFs.
On macOS, you can also print the model to a PDF via the print dialog box with good results.
If you choose to print a model via LayOut, here are a few tips for working with dashed lines in
LayOut:
•
•
•

You can add your SketchUp model to a LayOut document.
Control the line thickness using the SketchUp Model panel. By default, the dashed lines
appear at a 0.5pt scale.
To adjust the stipple length, you can adjust the scale factor separately from the line
weight, which will stretch or contract the repeating pattern

Export an image or model with dashes
When your SketchUp model contains dashed lines, you can preserve the dashes when you
export to the following formats:
•
•
•

Vector image formats: PDF and EPS
Raster image formats: PNG, JPEG, TIF, BMP
CAD format: DWG and DXF

If the SketchUp model was originally imported from a CAD file and you didn’t edit the dashes,
the dashes should remap back to the original CAD line styles. Otherwise, the SketchUp dash
pattern is remapped to the equivalent CAD line style.
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Developing Components and Dynamic Components
When you create a component, you turn SketchUp geometry into something special.
A basic component becomes reusable and separate from other geometry.
If you’re a SketchUp Pro user, you can add attributes to create dynamic components. Users
can then configure certain aspects of the component, or the component can add steps to
staircases or pickets to fences as you scale the dynamic component.
After you try a few basic dynamic components to get a feel for how they work, you find specific
examples that walk through the steps to building complex dynamic components and references
and examples for the building blocks of dynamic components: attributes, functions, and
operators.
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Creating a Basic Component
When you transform geometry into a component, your 3D model has all the behaviors and
capabilities of a component:
•
•
•
•
•

Your component is reusable.
The component geometry becomes separate from any geometry to which it’s currently
connected. (This is similar to groups.)
Anytime you edit your component, you can edit the component instance or the
definition.
If you like, you can make your component stick to a specific plane (by setting its gluing
plane) or cut a hole in a face (by setting its cutting plane).
You can associate metadata, such asadvanced attributes andIFC classification types,
with the component. Classifying Objects introduces classification systems and how you
can use them with SketchUp components.

Tip: Before you create your component, make sure it’s aligned to the drawing axes and
connected to other geometry in the way you intend to use the component. This tip is especially
important if you want the component to have a gluing plane or a cutting plane, because this
context ensures that the component sticks to the plane or cuts a face in the way you expect.
For example, make sure a couch’s legs are on the horizontal plane. Unless you need a window
or a door in the floor, create a window or door component on a wall that’s vertically aligned to
the blue axis.
Table of Contents
1. Create a component
2. Choose alignment options
3. Set advanced attributes
Create a component
When you create a component, you can create it right in your model or in a separate SketchUp
file. Either way, you use the Create Component dialog box, as shown in the following figure.
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Follow these steps to create a component:
1. Select the geometry you want to include in your component. For tips on making
selections, see Selecting geometry.
2. Choose Edit > Make Component from the menu bar, or context-click the selection
and choose Make Component. The Create Component dialog box appears.
3. In theDefinitionbox, type a meaningful name for your component. You want the name
to be specific enough that you can easily locate the component in the Outliner among
your other geometry. See Working with Hierarchies in the Outliner for tips on naming
groups or components.
4. In
the Description box,
add
a
short
description
of
your
component.
Tip: The description is a great place to include details that will be meaningful to you or
others over time. For example, whereas your component name might be “St. Patrick
Window,” the description can include more detail, such as, “A Gothic-style Harry Clark
stained-glass window that depicts St. Patrick and has a cutting plane.”
5. (Optional) Set your alignment options.
6. (Optional)Add advanced attributes and select an option from the Type drop-down list if
you’re using classification data. With this metadata, the component works with BIM
workflows and the Generate Report feature. See Classifying Objects for more details.
7. Leave the Replace Selection with Component checkbox selected if you want to
transform the geometry you selected in Step 1 into a component. Deselect this box to
leave the geometry as-is but create a component definition based on it. The component
definition becomes available in your In Model collection.
8. Click the Create button to complete your component.

Choose alignment options
You have alignment options for gluing a component to a plane or aligning a component or its
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shadows. Here's how those options work:
•

•

To set a gluing plane: Select one of the following options from the Glue To dropdown list: Any, Horizontal, Vertical, Sloped. When you select a gluing plane, the Cut
Opening checkbox becomes active, and the Always Face Camera and Shadows Face Sun
options become inactive. If you set a gluing plane, you can enable your component to
cut an opening in a face by selecting the Cut Opening checkbox.
To make your component a 2D form: Select the Always Face Camera option,
which increases performance by eliminating the need to render the component as a 3D
model. SketchUp comes with several 2D people components that are examples of 2D
forms that always face the camera. If you select this option, the Shadows Face Sun
option becomes active.
Select the Shadows Face Sun checkbox to cast shadows from the component’s current
position as though the component were facing the sun. The shadow shape does not
change as the component rotates to face the camera.
Tip: The Shadows Face Sun option works best with components that have short bases
(such as trees). This option does not work well with components that have wide bases
(such as people in midstride).

•

To move the component’s axis origin or the cutting plane: Click the Set
Component Axes button After you click the button, the cursor enables you to set a
new axis origin in the same way you use the Axes tool. After you set a new component
axis origin, the Create Component dialog box becomes active again.
Tip: You might change the component’s axis origin for the following reasons:
•
The component’s axis origin determines what corner of the component is loaded
onto the Move tool cursor when you insert a component instance in a model.
•
The red/green plane’s orientation also defines the cutting plane. If you want a
vertical cutting plane, like the back of a window, to cut a face, then you need to move
the red/green plane to the back of the window.
•
The following figure shows a window component in the making, after the
component axis origin was reset to place the cutting plane on the back of the window.
If you’re using the Shadows Face Sun option, position the component’s axis origin at
the bottom center of the component for best results.

Set advanced attributes
Design is so much more that defining what something looks like. With the Advanced Attributes
section in the Create Component dialog box, you can attach information to components. This
information helps teams make design decisions and supports the eventual construction
process.
For example, if your component is a door and you add a price, size, and type to your
component, you can then generate a report that can help you estimate how much using that
door in your project would cost. To see how using a different type of door might impact the
cost, you can swap one door component for another using SketchUp's Replace
Selected component feature and see an updated report with new cost estimates.
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You can set the following attributes in the Create Component dialog box:
•
•
•
•

Price: To do simple price calculations based on content you create, enter the cost of
your component in the text box. Note that the Price attribute does not support different
currencies that this time. Simply enter a numerical value.
Size: Enter a simple indication of size. For example, you might enter 30x80 to indicate
the size of a door. Note that scaling does not update the string-based attributes. To add
that kind of logic, you need to create a dynamic component.
URL: Enter a web page address that is relevant to the component, such as the page
where you can purchase a door or window and find other technical specifications from
the manufacturer.
Type: Select an option from the Type drop-down list if you’re using IFC classification
data. See Classifying Objects for details.

Tip: After you create a component, you can also add attributes for the status and owner on
the Entity Info panel. With the component selected and the Entity Info panel open, click
the Show Advanced Attributes icon. You see a list of advanced attributes you added in the
Create Component dialog box as well as options to enter details about the component status
or owner. Simply type your desired information in the appropriate text box. Keep in mind that
the instance values apply only to an instance of the component. If you change an instance
value (status or owner), the change applies only to that specific component instance, not all
components with that definition.
In the Entity Info panel, you can also edit values for the Price, Size, URL, and Type attributes,
which are part of the component definition. Changing a definition value changes all instances
of the component.

Note: When you use LayOut to create construction documents, any component attributes that
you specify in SketchUp flow into LayOut. First, in SketchUp, generate a report as a .csv file.
Then, in LayOut, you can import the .csv file data into a table. This compatibility is useful not
only for creating tables, but also labeling items automatically.
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Editing a Component
When you edit a SketchUp component, you can edit the component definition or the instance.
When you edit the definition, you change every component instance. When you edit the
instance, the component becomes an unique component and no longer reflects changes to its
fellow components.
For example, say you’re modeling a picket fence. In your fence model, shown in the following
figure, the Fence Panel component contains subcomponents: Post, Rail, and Picket.

The following sections explain a few different ways you can edit components, using the Fence
Panel component as an example.
Table of Contents
1.
2.
3.
4.

Editing all instances of a component
Changing a single component instance
Replacing all component instances with another component
Editing a component with the Solid tools

Editing all instances of a component
To edit all instances of a component, follow these steps:
1. Open the context for the component you want to edit. In this example, that’s the Picket
component. To open the context, you can double-click the component. Or select it,
context-click the selection, and choose Edit Component.
2. Use the SketchUp drawing tools to edit your component. In this example, we used the
Line, Tape Measure, 2 Point Arc, and Push/Pull tool to change the top of the Picket
component. All component instances change as you draw.
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3. Click outside the component’s context and save your work. SketchUp automatically
updates the component definition to reflect your edits.

Changing a single component instance
Say you want to edit only one instance of a component. For example, perhaps you want to
model two or more picket styles so that you can experiment with the options. Follow these
steps to edit one instance but leave the other component instances as they are:
1. Select the component instance that you want to edit.
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2. Context-click the selected instance and choose Make Unique, as shown in the figure.
If you have the Entity Info panel open, you see that SketchUp changes the Definition
by adding #1, or something similar. By making the instance unique, you’re basically
creating a new component based on your original.

3. Open the context for the unique component. To open the context, you can double-click
the component. Or select it, context-click the selection, and choose Edit Component.
4. Use the SketchUp drawing tools to make changes to the component. In this case, we
made a slight change by selecting the edges on each side of the picket and moving them
inward 5/16 inch. This made the picket width slightly narrower.
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5. Click outside the component context when you’re done editing. In the figure, you can
see that one picket is slightly narrower than the others.

Replacing all component instances with another component
When you use instances of the same component throughout a model, you can easily replace
all instances of a component with a completely different component. To replace one component
with another, follow these steps:
1. In the Components panel, click the In Model icon.
2. In the area that lists all the components in your model, context-click the component
you want to replace and choose Select Instances.
3. Still in the Components panel, navigate to the component you want to use instead.
4. Context-click the new component and select Replace Selected from the menu that
appears.
Editing a component with the Solid tools
When you edit a component with the Solid tools, the steps are little different than the steps for
editing components with the other drawing tools.
Tip: To start, if you want to use the Solid tools to edit a subcomponent within a component,
you need to explode the main component. For example, to edit the Picket component with the
Subtract tool, which is one of the Solid tools, you need to explode the Fence Panel component
so that you can click the Picket component immediately after selecting the cutting object. After
you’re done editing the Picket component, you can re-create the Fence Panel component.
The following steps explain how to edit a component with the Solid tools, using the fence model
as an example:
1. Edit the component with a Solid tool In this example, the Subtract tool cuts a hole in
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the Picket component. In the Entity Info panel, notice that the name of the component
instance changes from Picket to Difference.

2. To update the component definition so that all pickets reflect your changes, contextclick the modified picket and select Make Component.
3. In the Create Component dialog box, make sure the component matches the original
component name. In this example, that name is Picket.
4. Click the Create button. A dialog box asks whether you want to replace the component
definition.
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5. Click Yes. All instances of your component reflect the change you made with the Solid
tool or tools.
6. (Optional) If you exploded a component to access subcomponents, you can re-create
the component. For example, select all the entities in the updated fence and re-create
the Fence Panel component.
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Making a Dynamic Component
To create a dynamic component, you add attributes to a basic component and then create
values for those attributes. For simple dynamic components, the process is easier than you
might think, especially if you start with SketchUp’s predefined attributes and are familiar with
SketchUp’s basic drawing tools and spreadsheet programs’ common functions. You don’t need
to be a computer programmer, a math genius, or a benevolent wizard.
You do need a SketchUp Pro license. You can insert dynamic components into SketchUp Make
or SketchUp Pro, but developing dynamic components is available only to SketchUp Pro users.
Tip: As you add attributes and subcomponents to a dynamic component, the setup becomes
more complex. It’s normal to have bugs that you need to find and fix before the dynamic
component works the way that you envision. Hang in there, and you’ll get the hang of dynamic
component development. Although it isn’t nearly as difficult as cloning a sheep or reverseengineering an evil hex on your home’s sewer pipes, developing your own dynamic component
is among the most difficult tasks in SketchUp.
So what does that process look like? Here’s an overview of the steps:
1. Create a new component that’s made entirely of groups or subcomponents. Creating a
Basic Component explains how to turn selected geometry into a component. Organizing
a Model gives you the lowdown on groups and nesting groups and components in
hierarchies.
2. Add attributes that make your component dynamic (that is, tell the component to do
something). You can choose from predefined attributes or create custom attributes.
3. For each attribute you add, define a value that tells the attribute how to take action.
These values can be a simple number that constrains a component’s size, a formula that
uses mathematical operators, or a function that iterates through several options that
you define in the formula’s parameters.
4. Test your dynamic component to make sure it works correctly. As mentioned earlier,
you’ll probably go back to Step 1 or 2 a few times before the dynamic component works
the way you hope.
5. Save the component in a separate file that you can import into other models via the
Components browser or share with others via the 3D Warehouse. For the component to
work, make sure you context-click the highest level of the component and select Save
As from the menu that appears. Then save the resulting .skp file in a component
collection.
In this video15, you can see these steps in action. In the sections that follow, you find details
and tips for working through the preceding steps.
Tip: After you cover the basics in this article, check out a few examples that walk you through
building specific dynamic components. Those examples can help you see how to apply the
abstract concepts explained here to create all sorts of dynamic component interactions. You
find several specific examples in Creating Common Types of Dynamic Components. Also, you
can find the Dynamic Component Training collection in the Components browser and download
the following tutorials from the 3D Warehouse:

15

https://youtu.be/fsBpIPnF31A
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Befriending all the axes
In dynamic component development, component axes are like little elven tricksters, sabotaging
your good intentions &#8212 unless you remain aware of these axes and keep them working
for, rather than against, you. Before you create one attribute, review the following tips for
keeping the axes on your side:
•

•

•

Every component and subcomponent has its own axis origin point. If you use
attributes to set the dimensions of, position, or move a dynamic component, the values
you enter are relative to the component’s axis origin. If you position more than one
subcomponent, each one will have a different axis origin. So know the whereabouts of
each component’s axes origin, and reposition it if needed.
The axes’ colors become letters. Everywhere in SketchUp, you see references to the
red, green, and blue axes — except in the Component Attributes dialog box. Here, the
red axis is X, the green axis is Y, and the blue axis is Z. For example, the LenX attribute
defines the length of the X, or red, axis.
Gluing and cutting planes can turn the axis origin sideways. When you create a
component, you can set both gluing and cutting planes. When a component glues to
only vertical surfaces, the blue (Z) and green (Y) axes are swapped: LenZ has a length
value for the green axis, and LenY’s value is what’s typically the blue axis. For example,
if you want to constrain a gluing component that glues to vertical surfaces, such as
window, to a specific height, your formula needs to constrain LenY, not LenZ. If your
component has a cutting plane, remember that to create that cutting plane on a vertical
face, you had to move the axes, because the red/green plane determines the cutting
plane.

Tip: As you develop a dynamic component, you may need to reset a component’s axis origin
point by relocating the axes. To do so, context-click the component and select Change Axes,
which activates an Axes tool cursor for the component. Adjusting the Drawing Axes explains
how to use this cursor.
Adding attributes
Attributes make components dynamic by telling SketchUp what to do. You can choose from
predefined attributes or create custom attributes:
•

Predefined attributes enable you to quickly and easily set up dynamic behaviors for
common features, such as constraining a dynamic component’s size or applying a
material. You can browse predefined attributes in the Component Attributes dialog box,
or check out the Dynamic Component predefined attributes reference.
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Custom attributes enable you to add your own attributes.

To add attributes, follow these steps:
1. Select the component you want to make dynamic.
2. On the Dynamic Components toolbar, click the Component Attributes tool (
) or
select Window > Component Attributes. Either way, the Component Attributes
dialog box opens, as shown in the following figure. In this example, the Component
Attributes dialog box shows the DynamicCylinder component.

3. Click the Add Attribute plus sign icon to see a list of options.
4. Select a predefined attribute or select the Or Enter a Custom Name option at the
bottom. If you selected a predefined attribute, you’re ready to add values.
5. If you selected to add a custom name, type a name to replace the Enter
Name placeholder text that appears.
Tip: An attribute’s name must start with a letter and cannot contain any spaces. Otherwise,
you can name the attribute anything you want. Choosing a name that reminds you what the
attribute does is helpful.
Note: If you need to rename a custom attribute, double-click its name and type a new one.
(You can change the names of custom attributes only, not a predefined attribute.) If you need
to delete an attribute, just click the Delete Attribute minus sign icon next to the attribute’s
name.
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In this example, you see the Material attribute added to the DynamicCylinder component.

Defining attribute values
After you set up an attribute or three, you’re ready to enter values that tell the attributes what
to do. You can complete this step in a myriad ways, depending on the attributes you choose.
Generally speaking, you can define attribute values in the following ways:
•

Type in the attribute value text box. For example, add a Description attribute and
type a description directly in the value text box. (See Callout 1 in the following figure.)
If you’re defining formulas, type an equal sign (=) and then enter your formula.
Tip: If you want to see the complete formulas in the attribute value box, click
the Toggle Formula View button in the upper right of the Component Attributes dialog
box. If you manipulate a component with a SketchUp tool while the Component
Attributes dialog box is open, click the Refresh button to refresh values in the
Component Attributes dialog box.

•

Insert a function from the drop-down list. To see the drop-down list, click
the Functions tab. Open the drop-down list to select from any of the dynamic
component functions. (See Callout 2.) After you select a function, you see a brief
description (in very tiny text) below the drop-down list. Select the attribute value text
box where you want to insert the function, and click the Insert button to add the
function to the text box. Then you need to customize the value based on the function
you chose.
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Click the Details arrow (
) in the attribute value field. You see a drop-down list
that enables you to set display values for the attribute. Select whether or not users can
see the attribute, and if so, whether the value appears as a text box or a drop-down
list. If you select the Users Can Select from a List option, you can then define what
values users can select. In this example, adding different materials values enables users
to select from a limited range of materials. (See Callout 3.)

When you create formulas, here are the rules you need to follow:
•
•
•
•
•
•

Put text in quotes.
Concatenate a string with the ampersand (&). For example: ="I am a table with the
cost of" & variable name
To display quotes in a text string, use a backslash (\). For example: ="This is the
"\official\" retail price for this item:" & variable name
Formulas that return numbers will return them as floating values, never as integers. So,
the formula if(5=5,1,0) will return 1.0 instead of 1.
All lengths are in inches and angles in degrees.
Use an exclamation point (!) to refer to a value outside of the current subcomponent.
For example, Fence!spacing refers to the value of the spacing variable in
the Fence component.

Tip: This overview of the basic options can help you connect the features in the Component
Attributes dialog box to the attribute, function, and operator references. These references
contain the building blocks for adding dynamic features to components, as you see in
the dynamic component examples.
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Testing a dynamic component
After you define the attributes and values for a dynamic component, test how it works in the
Component Options window, which you can open in any of the following ways:
•
•
•

Click the Component Options tool (
) on the Dynamic Components toolbar.
Select Window > Component Options.
Context-click the component and select Dynamic Components > Component
Options.
In the following figure, you see that each attribute appears in a drop-down list. Select an option
and click Apply to change the component’s color.
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Creating Common Types of Dynamic Components
Ready to dive into serious dynamic component development? Check out the following articles,
which walk you through the steps for developing specific dynamic components:
•
•
•
•
•
•
•
•

Repeating a sub-component within a dynamic component (1 Dimension)
Repeating a sub-component within a dynamic component (2 Dimensions)
Making components that animate
Making components that copy
Constraining attributes of a Dynamic Component
Creating a Dynamic Component that snaps to a specific size
Implement dynamic pricing
Making attribute values end-user configurable

Repeating a sub-component within a dynamic component (1 Dimension)
This is a Pro only feature.
A repetitive dynamic component is a component containing a sub-component that repeat, such
as the pickets of a fence component, or the steps of a stair component.
Following is an image of the fence component. This component contains 4 sub-components: a
top rail, a bottom rail, a picket, and a post. You are going to replicate the picket sub-component
as the component is scaled in the X direction. The main issue when creating a replicating subcomponent is the spacing between each replicated part and how the part is replicated (linearly
for a fence, diagonally for stairs, circular for circular stairs, and so on).

Note: The components in this example must be constrained before you can perform these
steps. Refer to 'Constraining attributes of a dynamic component' for further information.
1. Create the component with one of the replicating subcomponents, such as the fence
with one picket.
2. Context-click on the component. The component's context menu is displayed.
3. Select the Dynamic Components > Component Attributes menu item. The
Component Attributes dialog box is displayed.
4. Click the plus (+) button next to the Fence component. A list of attributes appears for
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the component.
Note: A list of attributes will only appear if you have constrained the component before
trying these steps. Refer to 'Constraining attributes of a dynamic component' for further
information.

5. Click on the Add attribute button in the last row of the Fence component. A list of
predefined attributes is displayed. The field is opened for editing.
6. Type spacing and press the Enter (Microsoft Windows) or Return (Apple macOS) key.
An attribute named 'spacing' is placed in a list of attributes called 'Custom.' The field
next to the spacing attribute is opened for editing.
7. Type 2.
8. Press the Tab key to accept the value. You have established a spacing value of 2"
between pickets. The following image shows the results of steps 5 through 8.
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9. Click the plus (+) button next to the Picket component. A list of attributes appears for
the component.
10. Click on the add attribute button in the last row of the Picket component. A list of
predefined attributes is displayed. The field is opened for editing.
11. Click on the 'Copies' attribute in the list. The field is populated with the word 'Copies'
and the field next to the 'Copies' attribute is opened for editing. You need to create a
formula that will yield a number of copies given the length of TopRail (or
BottomRail) component.
12. Type =(TopRail!LenX)/(Picket!LenX+Fence!spacing)-1.
13. Press the Tab key to accept the value. The first part of this formula, TopRail!LenX is the
length of the TopRail component in the X direction. This number is then divided by the
width of a picket plus the spacing (Picket!LenX+Fence!spacing). A value of 1 is then
subtracted from the total. As mentioned, this formula yields the number of pickets that
are created given the length of TopRail. These copies are placed at the same X, and, Z
coordinate as the original Picket component (so all your pickets are exactly at the same
spot). Next, we will use a formula to position, in the X direction, each copy of Picket.
Note: Open the Outliner to see the copies being made as the component is scaled. The
copies of the original picket will display as Picket copy 1, Picket copy 2, Picket copy 3,
and so on.
14. Double-click on the value in the value field for the 'X' attribute.
15. Press the Backspace (Microsoft Windows) or Delete (Apple macOS) key to delete the
current value for the 'X' attribute.
16. Type =5+COPY*(Fence!spacing+LenX).
17. Press the Tab key to accept the value. This formula uses a predefined attribute called
'Copy' to determine X positioning for each picket. The Copy attribute is simply a counter
that begins at 0 (for the original Picket) and adds one for each additional copy. So, Copy
is equal to 1 for the first copy, equal to 2 for the second copy, equal to 3 for the third
copy, and so on. However, you will only ever see the X value for the original Picket
component in the Component Attributes dialog box. The following image shows the
results of steps 9 through 17.
Note: Multiplication takes place before addition.

_
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18. Click on the close button.
19. Use the Scale tool to scale your component in the X direction. The component should
add pickets as you scale. The following image shows the Fence component after scaling
along the X axis.

You might consider hiding the scale handles so that only the handles in the X direction
are visible when using the Scale tool. Refer to Hiding scale handles for further
information.
Repeating a sub-component within a dynamic component (2 Dimensions)
This is a Pro only feature.
A repetitive dynamic component is a component containing a sub-component that replicate,
such as the tiles within a floor component. In the case of a floor and tiles, the component scales
in 2 dimensions, X, and Y.
Note: You should create a component whose subcomponent replicates in one direction prior to
creating a component whose subcomponent replicates in two directions. This document
assumes you are familiar with 1 dimensional replication. Refer to 'Repeating a sub-component
within a dynamic component (1 Dimension)'.
Following is an image of the Floor component containing 1 Tile sub-component (it simply looks
like one tile). The Tile sub-component replicates as the Floor component is scaled in the X and
Y directions (using the Scale tool).
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Following is an image of the Floor component after it has been scaled. Now the Floor has 8
copies of the replicating Tile subcomponent.

To replicate a subcomponent within a parent component (in two dimensions):
1. Create your component with one subcomponent, such as a floor with one tile.
2. Context-click on the component. The component's context menu is displayed.
3. Select the Dynamic Components > Component Attributes menu item. The
Component Attributes dialog box is displayed.
4. Ensure that the attributes for all components are visible.
5. Create a 'Columns' attribute in the Floor component to hold the number of rows in your
dynamic component.
6. Create a 'Rows' attribute in the Floor component to hold the number of rows in your
dynamic component.
7. Create an attribute, in the Floor component, that represents the size of the replicating
subcomponent. For example, this example contains a 'TileSize' attribute.
8. Set 'TileSize' to some value, such as 12.
9. Set the 'LenX' and 'LenY' of the Tile subcomponent to the size in the parent component.
For example, set 'LenX' to equal Floor!TileSize and 'LenY' to equal Floor!TileSize (for the
Floor Tile subcomponent).
10. Use a formula in the field next to the Floor component's 'Columns' attribute to determine
the number of columns in the parent component. This formula will be based on the size
of the replicating subcomponent (Tile) and overall size of the parent component (Floor).
For example:
=CEILING(LenX/TileSize)
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Note: The ceiling function, with only one argument, rounds the result of LenY/tilesize to
the nearest bigger whole number.
11. Use a formula in the field next to the Floor's 'Rows' attribute to determine the number
of rows in the parent component. This formula will be based on the tile size of the
replicating subcomponent (Tile) and overall size of the parent component (Floor). For
example:
=CEILING(LenY/TileSize)
12. Add the Copies attribute to the Tile subcomponent.
13. Use a formula in the field next to the 'Copies' attribute to calculate the number of copies
of the replicating subcomponent. The copies are calculated by multiplying the rows by
columns and subtracting one (for the original). For example:
=Floor!rows*Floor!columns-1
14. Establish the position of each replicating subcomponent (the exact column and row).
Position is determined by establishing a multiplier that represents the row or column
and then multiplying the multiplier by the size of the subcomponent to establish its X
and Y location.
a. Create an attribute to hold the row multiplier, such as myRow, in the Tile
subcomponent.
b. Use a formula in the field next to the 'myRow' attribute that iterates through
each copy and determines the row where the copy will be placed. For example:
=FLOOR(COPY/Floor!columns)
If Copy equals 7, and there are 3 columns in the object, then myRow will be
equal to 2. Note that rows start at 0, so 2 represents the 3rd row.
Note: The floor function, with one argument, rounds the result down to the
nearest whole number.
c. Create an attribute to hold the column multiplier, such as myColumn, in the Tile
subcomponent.
d. Use a formula in the field next to the 'myColumn' attribute that iterates through
each copy and determines the column where the copy will be placed. For
example:
=COPY-(myRow*Floor!columns)
If copy equals 7, myRow equals 2 (calculated previously) and there are 3
columns in the object, then myColumn will be equal to 1. Note that columns start
at 0, so 1 represents the 2rd row.
Note: The floor function, with one argument, rounds the result down to the
nearest whole number.
e. Use a formula in the field next to the Tile subcomponent's 'X' attribute to
calculate the location of the sub-component. For example:
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X =myColumn*floor!tilesize
f.

Use a formula in the field next to the Tile sub-component's 'Y' attribute to
calculate the location of the sub-component. For example:
Y =myRow*floor!tilesize
The following is an image of the Component Attributes dialog box with all Floor
and Title attributes:

Note: The Tile replicating subcomponent is copy 0 and only the values for copy 0 are displayed
in the Component Attributes dialog box.
Making components that animate
This is part three a three part video series to get you started creating Dynamic components.
Use the links below to navigate to the each video in the series.

SketchUp Help Pages – version 19.

Page 273/567

Making components that copy
This is part two of a three part video series to get you started creating Dynamic components.
Use the links below to navigate to the each video in the series.
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Constraining attributes of a Dynamic Component
This is a Pro only feature.
A constrained dynamic component is a component that has elements (sub-components or subgroups) that, when scaled with the Scale tool, will not change size or orientation to the axes.
To constrain entities of a dynamic component:
1. Create a new component that is comprised entirely from groups or sub-component
instances, each with a unique name. Following is an image of the fence component used
in this example. This component contains 4 sub-components: post,top rail, bottom rail,
and picket sub-components. The parent component and each sub-component have a
unique name. For example, the parent component is called Fence and it contains Post,
TopRail, BottomRail, and Picket sub-components.
2.

Note: Configuring a dynamic component is easier when the component is placed at the
origin of the axes in SketchUp.
3. Context-click on the component. The component's context menu is displayed.
4. Select the Dynamic Components > Component Attributes menu item. The
Component Attributes dialog box is displayed.
5. Click the + button next to the Fence component. An empty list of attributes appears for
the component.
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6. Click on the add attribute button in the last row of the Fence component. A list of
predefined attributes is displayed. The field is opened for editing.
7. Click on Position in the list of predefined attributes. All of the position attributes are
displayed for the component.
8. Click on the add attribute button in the last row of the Fence component. A list of
predefined attributes is displayed. The field is opened for editing.
9. Click on 'Size' in the list of predefined attributes. All of the size attributes are displayed
for the component. The following image shows these attributes within the Fence
component.
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10. All of the attributes are faded gray color to indicate they are not constrained to a specific
value.
11. Double-click in the field next to the LenY attribute in the Fence component. The field is
opened for editing.
12. Erase the current value.
13. Type =4 in the 'LenY' field to constrain the length of the Fence component in the Y
direction (the fence cannot be scaled in the Y direction).
14. Press the Tab key to accept the formula. The value for LenY (4) is displayed in black to
indicate it is constrained (the fence cannot be resized using the Scale tool).
15. Click on the + next to the TopRail sub-component to display its attributes.
16. Click on the add attribute button in the last row of the TopRail component. A list of
predefined attributes is displayed. The field is opened for editing.
17. Click on Position in the list of predefined attributes. All of the position attributes are
displayed for the component.
18. Click on the add attribute button in the last row of the TopRail component. A list of
predefined attributes is displayed. The field is opened for editing.
19. Click on 'Size' in the list of predefined attributes. All of the size attributes are displayed
for the component.
20. Double-click in the field next to the X attribute in the TopRail sub-component. The field
is opened for editing.
21. Erase the current value.
22. Type =4 in the 'X' field of the TopRail to constrain the TopRail to 4" along the X axis
from the Fence's origin (to accommodate the 4" width of the Pole). Generally, you want
all of your sub-component's values constrained. Some of the parent's values might be
constrained depending on the type of component you are creating. For example, the
Fence's thickness (LenY) is constrained to 4". But all other values, including Fence's
location to SketchUp's axes (X,Y, and Z) are unconstrained so it can be moved anywhere
and scaled in the X and Z directions (LenX and LenZ).
Note: Constrained values appear in solid black text. Unconstrained values (values that
could be altered when scaling a component) are in light gray.
23. Press the Tab key to accept the formula.
24. Double-click in the field next to the Y attribute. The field is opened for editing.
25. Erase the current value.
26. Type =1.25 in the 'Y' field of the TopRail to constrain the TopRail to 1.25" along the Y
axis from the Fence's origin (the middle of the Pole).
27. Press the Tab key to accept the formula.
28. Double-click in the field next to the Z attribute. The field is opened for editing.
29. Type =Fence!LenZ-9 in the 'Z' field of the TopRail to constrain the Pole's Z value using
a formula based on the overall height of the Fence (Fence!LenZ).
30. Press the Tab key to accept the formula. The value of TopRail's Z is constrained to 9
inches below the length of Fence (Fence!LenZ). The following image shows the changes
made in steps 9 through 29:
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Tip: Move the cursor over a field and click the mouse button to create a reference to
the content in that field in your formulas. For example, clicking on the LenZ field of
Fence would place 'Fence!LenZ' in the currently edited formula.
31. Double-click in the field next to the LenX attribute. The field is opened for editing.
32. Erase the current value.
33. Type =Fence!LenX-Post!LenX in TopRail's 'LenX' field. The length of the TopRail will be
constrained to the length of Fence minus the length of the post (4").
34. Press the Tab key to accept the formula.
35. Double-click in the field next to the LenY attribute. The field is opened for editing.
36. Erase the current value.
37. Type =1.5 in TopRail's 'LenY' field. The thickness of TopRail is set to 1.5".
38. Press the Tab key to accept the formula.
39. Double-click in the field next to the LenZ attribute. The field is opened for editing.
40. Erase the current value.
41. Type =3.5 in TopRail's 'LenZ' field. The height of TopRail is set to 3.5".
42. Press the Tab key to accept the formula. All of TopRail's default attributes are now
constrained so that the component will not change its position and size when scaled.
The following image shows the changes made in steps 30 through 41:

43. Continue constraining all of the default attributes (X,Y,Z, LenZ, LenY, and LenZ) for
each of Fence's sub-components. Hint: you will want to constrain the LenZ of the picket
to some value that is relative to the Fence's LenZ so the picket resizes proportionally to
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the fence in the Z (blue) direction.
44. Click on the Close button.
45. Use the Scale tool to scale your component. The component should only scale in the
directions that are unconstrained (the X and Z directions). Sub-components should
retain their dimensions (such as post and picket width and depth).
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Creating a Dynamic Component that snaps to a specific size
This is a Pro only feature.
You can constrain a component to a series of predefined sizes by placing specific formulas in
the LenX, LenY, or LenZ fields of the parent component.
Snapping to the nearest rounded value
Place the following formula in the LenX field for a component to snap the component's LenX to
the nearest width within 2 inches after scaling:
LenX =ROUND(CURRENT("LenX")/2)*2
This formula is useful for components that represent items that only come in whole number
sizes.
Snapping to one of a series of specific values
Place the following formula in the LenX field for a component to snap the component's LenX to
the nearest value (24, 36, or 48 inches) in a list after scaling:
LenX =NEAREST(CURRENT("LenX"),24,36,48)
This formula is useful for components that represent items that come in a pre-defined series
of sizes, such as kitchen cabinets.
Snapping to a smallest or largest size
Place the following formula in the LenX field for a component to snap the component's LenX to
20 inches wide when a scale operation scales the component beyond 20 inches:
LenX =SMALLEST(CURRENT("LenX"),20)
Place the following formula in the LenX field for a component to snap the component's LenX to
10 inches wide when a scale operation scales the component below 10 inches:
LenX =LARGEST(CURRENT("LenX"),10)
These formulas are useful for components that represent items that must not be smaller than
or larger than a specific size.

Implement dynamic pricing
This is a Pro only feature.
You can create a component whose pricing changes based on the type of material or size of
component the user chooses. To implement dynamic pricing in your dynamic component:
1. Create a component, such as a cabinet door.
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2. Context-click on the component. The component's context menu is displayed.
3. Select the Dynamic Components > Component Attributes menu item. The
Component Attributes dialog box is displayed. Notice that the top-level component is
listed.
4. Click on the add attribute button in the last row of the component. A drop-down list
of attributes appears.
5. Click on the Material attribute in the list. The field is populated with the word 'Material'
and the field next to the Material attribute is opened for editing.
6. Click on the Details button to the right of the Material value. A drop-down list of display
rules appears.
7. Select Users can select from a list from the 'Display rule' drop-down list. The Display
label and a table appear. The following image shows the Display rule drop-down list,
Display label field, and table.
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8. Replace the word Material with Wood Type in the 'Display label' field.
9. Click the Add option icon in the List Option column of the table. A row is created with
the field in the List Option column open for edit.
10. Type Cherry in the 'List Option' field. This text will appear in a drop-down list in the
Configure Options dialog box.
11. Press the Tab key.
12. Type Wood_Cherry_Original in the 'Value' field. This is the name of a specific material
in the Materials Browser.
13. Press the Tab key to accept the value.
14. Plywood, Wood_Plywood_Knots
The following image shows the attribute details panel with all completed fields:

15. Press the Apply button. The attribute details panel closes.
16. Click on the Add attribute button in the last row of the component. A drop-down list
of attributes appears.
17. Type Cost and press the Tab key. An attribute named 'Cost' is placed in a list of
attributes called 'Custom.' The field next to the Cost attribute is opened for editing.
18. Type
=if(MATERIAL="Wood_Board_Cork", 40.00, if(MATERIAL="Wood_Cherry_Original",60.50,15.25))
19. Press the Tab key to accept the formula. This formula assigns a cost for the door based
on the material (wood) that is selected by the user.
20. Click on the Close button.
21. Context-click on the component. The component's context menu is displayed.
22. Select the Component Options menu item. The Component Options dialog box is
displayed. The following is an image of the Component Options dialog box for the
Television dynamic component:
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Choosing different Wood Types from the drop-down list not only changes the SketchUp
material applied to the component (to reflect the wood type), but changes the MSRP of
the door to reflect the wood type.
You can also use the CHOOSE and OPTIONINDEX functions in place of nested if
statements (as in step 17).
For example:
MSRP =CHOOSE (OPTIONINDEX("MATERIAL"), 40, 60.50, 15.25)
In the previous example, if the first choice in a drop-down list of materials is chosen
(Cork), the price $40. If the second choice in a drop-down list of materials is chosen
(Cherry), the price is $60.50. And, if the third choice in a drop-down list of materials is
chosen (Plywood), the price is $15.25.
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Making attribute values end-user configurable
This is a Pro only feature.
You might want to allow the users of your dynamic component to configure some values of
your dynamic component, such as the spacing between pickets in a fence or the width of your
stairs. Values that are configurable will appear in a Component Options dialog box accessible
from the component's context menu. To make a value configurable:
1. Context-click on the component. The component's context menu is displayed.
2. Select the Dynamic Components > Component Attributes menu item. The
Component Attributes dialog box is displayed. Notice that the top-level component is
listed.
3. Click the + button next to the component's name. A list of attributes appears for the
component.
4. Click on the Details button to the right of the attribute you want to make end-user
configurable. A drop-down list of display rules appears. There are two display rules
allowing users to configure the attribute: 'Users can edit as textbox' and 'Users can
select from a list.' This article explains how to configure the more complex display rule:
'Users can select from a list."
5. Select Users can select from a list. The Display label and a table appear. The following
image shows the Display rule drop-down list, Display label field, and table.

6. Type a label in the in the 'Display label' field. This field contains the user-friendly name
you want to appear in the configuration box for this attribute.
7. Click the add option icon in the List Option column of the table. A row is created with
the field in the List Option column open for edit.
8. Type Small in the 'List Option' field. This text will appear in a drop-down list in the
Configure Options dialog box.
9. Press the Tab key.
10. Type 1 in the 'Value' field.
11. Press the Tab key to accept the value.
12. Repeat steps 7 through 11 using the option and value pairs of:
o Medium , 2"
o Large , 3
o Extra Large , 4
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The following image shows the attribute details panel with all completed fields:

13. Click on the Apply button. The attribute details panel closes.
14. Click on the Close button. The Component Attributes dialog box closes. The user of this
component can now configure the component's Slat Spacing attribute using the
Configure Options dialog box. Refer to Configuring a Dynamic Component for further
information.
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Referencing Dynamic Component Attributes, Functions, HTML Tags,
and Operators
To develop your dynamic component interactions, use the following references to the
predefined attributes, functions, and operators. These are the building blocks for any dynamic
component behavior that you can imagine.
•
•
•
•

Dynamic
Dynamic
Dynamic
Dynamic

Component Predefined Attributes
Component Supported Functions
Component supported operators
Components supported HTML tags

The following tables of examples complement the function reference:
•
•
•
•
•
•

Math Function Examples
SketchUp Function Examples
Text Function Examples
Trig Function Examples
Logical Function Examples
OnClick Function Examples

For a little extra help with materials and textures, check out these articles:
•
•

Preserving textures in a dynamic component
Using unique textures in a dynamic component

And if you want to control the display of scale handles on dynamic components that scale only
in specific directions, find out how to hide the scale handles.
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Dynamic Components Developper's Guide
The Dynamic Components Developer's Guide contains step-by-step instructions on how to
perform specific dynamic component creation tasks. The content in this guide answers the 'How
Do I...' questions of end-users.
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Adding an Attribute
Deleting an Attribute
Renaming an Attribute or Component Name
Constraining Attributes of a Dynamic Component
Creating a Dynamic Component That Snaps to a Specific Size
Repeating a Sub-Component Within a Dynamic Component (1 Dimension)
Repeating a Sub-Component Within a Dynamic Component (2 Dimensions)
Making Attribute Values End-User Configurable
Making a Dynamic Gluing Component
Implementing Dynamic Pricing
Using Unique Textures in Dynamic Components
Hiding Scale Handles
Swapping Multiple Dynamic Components
Configuring a Dynamic Component
Generating an Attribute Report
Identifying Dynamic Components
Interacting with Dynamic Components
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Dynamic Component predefined attributes
This is a Pro only feature.
Following is a list of all predefined attributes for use in creating your dynamic components.
X, Y, Z
The X, Y, and Z attributes contain the value for the component's X (red), Y (green), or Z (blue)
coordinate.
LenX, LenY, LenZ
The LenX, LenY, and LenZ attributes contain the length of the component in the X (red), Y
(green), or Z (blue) direction.
RotX, RotY, RotZ
The RotX, RotY, and RotZ attributes contain the rotation about the X, Y, or Z axis, in degrees.
Hidden
The Hidden attribute contains either a 1 (TRUE) to hide the component or 0 (FALSE) to unhide
the component.
Copies
The Copies attribute contains the number of copies of the component to be created by
SketchUp. Every copy will be created at the exact X, Y, and Z coordinates of the original. The
Copies attribute is usually used in conjunction with the Copy attribute.
Copy
The Copy attribute contains the copy number of a specific copy. So for example, if Copies is
equal to 3, Copy can contain 0 through 3 (0 being the original). Copy is generally used within
formulas (so it's more of a variable than an attribute) to refer to a specific copy (usually to
position that copy to different X, Y, and Z coordinates). For example, you might have a formula
that positions copies of pickets on a fence horizontally along the X axis. The formula for X would
look like=5+Copy*(Fence!spacing+LenX).
If 'Fence!spacing' for the picket is 4" and the width (LenX) of the picket is 2.5", this formula
resolves to 5" for the X value of the original component (5+0*(4+2.5)). The formula resolves
to 11.5 for the first copy (5+1*(4+2.5)), 18 for the second copy (5+2*(4+2.5)), and so on for
each copy of the picket.
You can only see copies of a component in the Outliner (Window > Outliner), not in the
Component Attributes dialog box. Therefore, you can never look at the attribute/value pairs
for a copy.
Name
The Name attribute contains the name of the component as you would like it to appear in the
Component Options dialog box.
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Summary
The Summary attribute contains a brief, one sentence summary of the component for the
Component Options dialog box.
Description
The Description attribute contains a longer description of the component for the Component
Options dialog box.
ItemCode
The ItemCode attribute contains a manufacturer item code for the product represented by the
dynamic component.
ImageURL
The ImageURL attribute contains a URL to a GIF, JPG, or PNG file on the Internet that you want
to appear in the Component Options dialog box. For example, if ImageURL is equal
to http://mysite.com/myimage.gif, then 'myimage.gif' image would appear, instead of the
SketchUp-generated thumbnail, inside the Component Options dialog box.
DialogWidth
The DialogWidth attribute contains the width, in pixels, of the Component Options dialog box.
DialogHeight
The DialogHeight attribute contains the width, in pixels, of the Component Options dialog box.
onClick
The onClick attribute contains a simple script identifying how the component will react to being
clicked (using the Interact tool). For example, if the onClick attribute contained alert("Hello
World");, an alert box would display when a user clicked on the component. Refer to 'onClick
functions' for further information.
Material
The Material attribute contains the material to apply to the component. The material can be in
several formats:
•
•
•
•

A named color, such as 'Blue' (See Ruby API docs for complete list of colors).
A hexadecimal string, such as '#FFFF00' or '3399A0' (the # is optional).
A three number list of RGB values (between 0 and 255). For example, 255, 128, 0.
A material name that exists in the InModel material list. Your dynamic component needs
to have a tiny swatch of the material you want displayed embedded somewhere on the
component. The material also needs to have a custom name. For
example,"0002_HotPink' won't work unless you rename it to be '0002_MyHotPink').
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Dynamic Component supported functions
Following is a list of all functions supported within your dynamic components. Many of these
functions are identical to functions found in spreadsheet applications such as the spreadsheet
application that is a part of Google Docs.

Math functions
The following functions are for math-related use:
ABS(number)
The ABS function returns the absolute value of number.
CEILING(number, significance)
The CEILING function rounds a number to the nearest integer or multiple of significance. The
significance argument is the value whose multiple of ten is the value to be rounded up (.01,
.1, 1, 10, etc.).
DEGREES(number)
The DEGREES function converts the number(in radians) to degrees.
EVEN(number)
The EVEN function rounds the numberup to the nearest even integer.
EXP(number)
The EXP function returns e raised to the power of number.
FLOOR(number, significance)
The FLOOR function rounds the number down to the nearest multiple of significance.
INT(number)
The INT function rounds the number down to the nearest integer.
ISEVEN(number)
The ISEVEN function returns TRUE if the number is an even integer, or FALSE if the number is
odd. If the number is not an integer, the function evaluates only the integer part of the number.
ISODD(number)
The ISODD function returns TRUE if the number is an odd integer, or FALSE if the number is
even. If value is not a number, the function evaluates only the integer part of the number.
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LN(number)
THE LN function returns the natural logarithm based on the constant e of the number.
LOG10(number)
The LOG10 function returns the base-10 logarithm of the number.
ODD(number)
The ODD function rounds the number up to the nearest odd integer.
PI()
The PI function returns the value of PI to fourteen decimal places.
RADIANS(number)
The RADIAN function converts the number (in degrees) to radians.
RAND()
The RAND function returns a random number between 0 and 1.
RANDBETWEEN(bottom, top)
The RANDBETWEEN function returns a whole number between the bottom and top number.
Example:
=RANDBETWEEN(1,3)
The previous example returns a 1, 2, 3.
ROUND(number, count)
The ROUND function rounds the number to a certain number of decimal places according to
valid mathematical criteria. The count argument is optional and represents the number of the
places to round the number. If the count argument is negative, only the whole number portion
is rounded.
Example:
=ROUND(1.12789,2)
The previous example returns 1.13.
SIGN(number)
The SIGN function returns the sign of the number. The function returns the result 1 for a
positive sign, -1 for a negative sign, and 0 for zero.
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SQRT(number)
The SQRT function returns the positive square root of the number. The number must be
positive.

SketchUp functions
The following functions are specific to SketchUp dynamic components:
CHOOSE(index,value1,value2, ...valueN)
The CHOOSE function returns a value from a list of parameters at the location of the index
value. This function allows you to create a single drop-down list that drives multiple attribute
changes at once.
Example:
=CHOOSE(2,"Blue","Red","Green")
The previous example results in "Red."
Use CHOOSE and OPTIONINDEX together as a mechanism to assign different values depending
on a user's choice in the Component Options dialog box. For example, if the Component Options
dialog box allows the user to choose different materials to assign to a component (and the
price changes depending on material chosen), the formula for MSRP might be:
=CHOOSE (OPTIONINDEX("Material"), 100, 150, 200)
The previous example returns 100, 150, or 200 depending on the material chosen in the
Component Options dialog box.
CURRENT("attributeName")
The CURRENT function accepts a string name of an attribute, and returns the size or position
attribute that the SketchUp user just applied. This function allows you to do validation of Scale
tool or Move tool actions.
Example:
=ROUND(CURRENT("LenX")/2)*2
The previous example, when entered into the LenX value field, constrains the component to
the nearest width, within 2 inches, after scaling.
EDGES()
The EDGES function returns the number of 'ungrouped' edges inside the component or group
that this function is called within.
FACEAREA("materialName")
The FACEAREA method returns the area (in square inches) of every 'ungrouped' face that is
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painted with the materialName. The FACEAREA method returns the total area of all ungrouped
faces when the materialName is not provided.
Example:
=FACEAREA("Oak")
The previous example returns the square inches of Oak material inside the component or group.
FACES()
The FACES function returns the number of 'ungrouped' faces inside the component or group
that this function is called within.
LARGEST(value1,value2,...valueN)
The LARGEST function returns the largest of the values in a list.
Example:
=LARGEST(CURRENT("LenX"), 20, 10)
The previous example, when entered into the LenX value field, constrains the component so it
cannot be scaled more than the largest of three numbers (either the value of LenX, 20, or 10).
LAT()
The LAT function returns the latitude of the current SketchUp model.
LNG()
The LNG function returns the longitude of the current SketchUp model.
NEAREST(originalValue, value1, value2, ...valueN)
The NEAREST function compares the originalValue with a list of target values, and returns the
target value that is closest to the originalValue.
Example:
= NEAREST(CURRENT("LenX"),24,36,48)
The previous example, when entered into the LenX value field, will cause the component to
snap to the nearest width of 24,36, or 48 after scaling.
OPTIONINDEX("attributeName")
The OPTIONINDEX function returns the currently selected index from its option list given a
string name of an attribute. For example, if an attribute can be 'red,' 'blue,' or 'green,' and blue
is the current value, this function returns 2. If no match is found, 0 is returned.
OPTIONLABEL ("attributeName")
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The OPTIONLABEL function returns the currently selected label form its option list given a string
name of an attribute. For example, if an attribute can be 'Red=red','Blue=blue', or
'Green=green', and blue is the current value, this function returns 'Blue.' If no match is found,
an error is raised.
SMALLEST(value1,value2,...valueN)
The SMALLEST function returns the smallest of the values in a list.
Example:
=SMALLEST(CURRENT("LenX"),20, 10)
The previous example, when entered into the LenX value field, constrains the component so it
cannot be scaled less than the smallest number (the value of LenX, 20, or 10).
SUNANGLE()
The SUNANGLE function returns the angle (in degrees) between the sun and the current
model's North direction.
SUNELEVATION()
The SUNELEVATION function returns the elevation (in degrees) of the sun from the current
model's shadow settings. The elevation is defined as the angle between a vector pointing at
the sun and the ground plane.

Text functions
CHAR(number)
The CHAR function converts a number into a character according to the current code table. The
number argument can be a two-digit or three-digit integer number between 1 and 255
(representing the code value for the character).
CODE(text)
The CODE function returns a numeric code for the first character in a text string. The text
argument is the text for which the code of the first character is to be found.
CONCATENATE(text1, text2, ...textN)
The CONCATENATE function combines several text strings into one string. The text1, text2,
...textN arguments are text strings that are combined into one string.
DOLLAR(value, decimals)
The DOLLAR function converts a number to an amount in the currency format, rounded to a
specified decimal place. Thevalueargument is the number to be converted to currency. The
value argument can be a number, a reference to a cell containing a number, or a formula which
returns a number. The decimals (optional) argument is the number of decimal places. If no
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decimals value is specified, all numbers in the currency format will be displayed with two
decimal places. The currency format is set in the system settings.
EXACT(text1, text2)
The EXACT function compares two text strings and returns TRUE if they are identical. This
function is case-sensitive. The text 1 and text 2 arguments are the text strings.
FIND(findText, text, position)
The FIND function looks for a string of text within another string. The findText argument is the
text to be found. The text argument is the text string to be searched. The position (optional)
argument is the position in text where the search starts. The findText argument can be a
number or any string of characters. The search is case-sensitive.
LEFT(text, number)
The LEFT function returns the first character (or characters) in a text string. The text argument
is the text string. The number (optional) argument is the number of characters to be returned.
One character is returned if the number is not defined.
LEN(text)
The LEN function returns the length of a text string including spaces. The text argument is the
string whose length is returned.
LOWER(text)
The LOWER function converts all uppercase letters in a text string to lowercase. The text
argument is the string to be converted.
MID(text, start, number)
The MID function returns a text segment of a text string. The text argument is the text string.
The start argument contains the position of the first character in the text to extract. The number
argument is the number of characters to return.
PROPER(text)
The PROPER function capitalizes the first letter in all words of the provided text string.
REPLACE(text, position, length, new)
The REPLACE function replaces part of a text string with a different text string. The text
argument is the text string containing the section to be replaced. The position function is the
position within the text where the replacement will begin. The length argument is the number
of characters in the text to be replaced. The new argument is the replacement text.
This function can be used to replace both characters and numbers (which are automatically
converted to text). The result of the function is always displayed as text. To perform further
calculations with a number which has been replaced by text, convert it back to a number using
the VALUE function. Any text containing numbers must be enclosed in quotation marks so it is
not interpreted as a number and automatically converted to text.
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REPT(text, number)
The REPT function repeats a text string. The text argument is the text to be repeated. The
number argument is the number of repetitions. The result can be a maximum of 255 characters.
RIGHT(text, number)
The RIGHT function returns the last character or characters in a text string. The text argument
is the text string. The number (optional) argument is the number of characters to be returned.
SUBSTITUTE(text, searchText, newText, occurrence)
The SUBSTITUTE function substitutes new text for old text in a string. The text is the old text
string. The searchText argument is the segment intextto be replaced. The newText argument
is the replacement text. The occurrence (optional) argument indicates the number of
occurrences of searchText to be replaced. If the occurrence is missing, the search text is
replaced throughout.
TRIM(text)
The TRIM function removes spaces in front of a text string or aligns cell contents to the left.
The argument contains text string or cell whose contents will be left-aligned.
UPPER(text)
The UPPER function converts a text string to uppercase. The text argument contains the lower
case letters you want to convert to upper case.
VALUE(text)
The VALUE function converts a text string into a number. The text argument is the text to be
converted to a number.

Trig functions
ACOS(number)
The ACOS function returns the inverse cosine of the number in degrees.
ACOSH(number)
The ACOSH function returns the inverse hyperbolic cosine of the number in degrees.
ASIN(number)
The ASIN function returns the inverse sine of the number in degrees.
ASINH(number)
Returns the inverse hyperbolic sine of the number in degrees.
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ATAN(number)
The ATAN function returns the inverse tangent of the number in degrees.
ATANH(number)
The ATANH function returns the inverse hyperbolic tangent of the number in degrees.
COS(number)
The COS function returns the cosine of the number in degrees.
COSH(number)
The COSH function returns the hyperbolic cosine of the number in degrees.
SIN(number)
The SIN function returns the sine of the number in degrees.
SINH(number)
The SINH function returns the hyperbolic sine of the number in degrees.
TAN(number)
The TAN function returns the tangent of the number in degrees.
TANH(number)
The TANH function returns the hyperbolic tangent of the number in degrees.

Logical functions
The following functions are for math-related use:
AND(logicalValue1, logicalValue2, ...logicalValueN)
The AND function returns TRUE if all arguments are TRUE. If any element is FALSE, this function
returns the FALSE value. The logicalValue arguments are conditions to be checked. All
conditions can be either TRUE or FALSE.
FALSE()
The False function sets the logical value to FALSE. The FALSE function does not require any
arguments.
IF(test, thenValue, elseValue)
The IF function identifies a logical test. The test argument is any value or expression that can
be TRUE or FALSE. The thenValue (optional) is the value that is returned if the logical test is
TRUE. The elseValue (optional) is the value that is returned if the logical test is FALSE.
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Example:
=IF (5=5, 1, 0)
The previous example returns a 1 if the test (5=5) is TRUE. Otherwise, the function returns a
0.
NOT(logicalValue)
The NOT function reverses the logicalValue. The logicalValue argument is any value to be
reversed.
OR(logicalValue1, logicalValue2, ...logicalValueN)
The OR function returns TRUE if at least one argument is TRUE. This function returns FALSE if
all the arguments have the logical value FALSE.The logicalValue arguments are conditions to
be checked. All conditions can be either TRUE or FALSE.
TRUE()
The TRUE function turns the logical value to TRUE. The TRUE() function does not require any
arguments.

OnClick functions
ALERT("message")
The ALERT function displays the value of the message in an alert box.
Example:
=ALERT("You Clicked Me!")
The previous example displays an alert box with the phrase 'You Clicked Me!,' when inside the
ONCLICK attribute.
ANIMATE(attribute, state1, state2, ... stateN)
The ANIMATE function starts an animation that will change the value of the attribute to the
next value in a list of parameters every half a second.For example, if the ONCLICK attribute
contains ANIMATE("X",0,100), and the user clicks on the component, the component would
animate the value of the 'X' attribute between 0 and 100. A subsequent click would animate
back to 0 from 100.If more than two animate states are passed, then the value will toggle
between them in order. So, if the ONCLICK attribute equalsANIMATE("ROTZ",0,130,10,100) the animation would go through each of the 4 values with each click.
This function animates with defaulteasing. Easing is the speed of the animation (on a scale of
0 to 100, 0 being fastest). Easing is represented by two numbers. The first number (easein)
identifies the speed at the start of the animation. The second number (easeout) identifies the
speed at the end of the animation. Default easing is 0,100 (animation starts fast but slows
down at the end).
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ANIMATESLOW("attributeName", state1, state2, ... stateN)
The ANIMATESLOW function does the same thing as animate, but slower (one second).
ANIMATEFAST("attributeName", state1, state2, ... stateN)
The ANIMATEFAST function does the same thing as animate, but faster (a quarter of a second).
ANIMATECUSTOM("attributeName", time, easein, easeout, state1, ...stateN)
The ANIMATECUSTOM function does the same thing as animate, but with an arbitrary time with
easing. Refer to the ANIMATE function for information about easing.
GOTOSCENE("sceneName", time, easein, easeout)
The GOTOSCENE function moves to a scene identified by a name or number. Refer to the
ANIMATE function for information about easing.
REDRAW()
The REDRAW function redraws the component that contains this function.
SET("attributeName", state1, state2, ...stateN)
The SET function sets a given attribute to the next state in a list.
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Dynamic Component supported operators
Following is a list of all operators supported in dynamic component formulas.
•
•
•
•
•
•
•
•
•
•
•

+ (add)
- (subtract)
* (multiply)
/ (divide)
< (less than)
> (greater than)
<= (less than or equal to)
>= (greater than or equal to)
= (equal)
() (parentheses)
<> (not equal to)
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Dynamic Components supported HTML tags
This is a Pro only feature.
The following HTML tags are supported within a Dynamic Component's Description and
Summary fields:
•
•
•
•
•
•
•
•
•
•
•
•

<a>
<b>
<i>
<u>
<strong>
<em>
<p>
<br>
<ol>
<ul>
<li>
<font>

Any tag or version of a tag that is not in this list will be ignored. The following additional rules
also apply:
•
•
•

No style attributes are allowed. For example, <bstyle="color: red">Hello</b> will be
ignored. Instead use <b><font color="red">Hello</font></b>
Link tags must be in the strict form of <a href="http://someurl">. Alternatives such as
<a href=http://someurl> or <a href="ftp://someurl"> will be ignored
No attributes are allowed for tags other than for <a> and <font>. For example, the tag
<br> is allowed, but <br clear="all"> is not allowed.
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Dynamic Components Math Function Examples
•
•
•
•
•
•

Math Functions
SketchUp Functions
Text Functions
Trig Functions
Logical Functions
OnClick Functions

Math Functions (Specific to SketchUp Dynamic Components)
Function

Description

Example(s)

ABS(number)

The ABS function returns the
absolute value of number.

Example:
View SketchUp Example

CEILING(number,
significance)

The CEILING function rounds a
Example:
number to the nearest integer or View SketchUp Example
multiple of significance. The
significance argument is the
value whose multiple of ten is
the value to be rounded up (.01,
.1, 1, 10, etc.).

DEGREES(number)

The DEGREES function converts
the number(in radians) to
degrees.

Example:
View SketchUp Example

EVEN(number)

The EVEN function rounds the
numberup to the nearest even
integer.

Example:
View SketchUp Example

EXP(number)

The EXP function returns e raised Example:
to the power of number.
View SketchUp Example

FLOOR(number,
significance)

The FLOOR function rounds the
number down to the nearest
multiple of significance.

Example:
View SketchUp Example

INT(number)

The INT function rounds the
number down to the nearest
integer.

Example:
View SketchUp Example
Example:
View SketchUp Example

ISEVEN(number)

The ISEVEN function returns
TRUE if the number is an even
integer, or FALSE if the number
is odd. If the number is not an
integer, the function evaluates
only the integer part of the
number.

ISODD(number)

The ISODD function returns
Example:
TRUE if the number is an odd
View SketchUp Example
integer, or FALSE if the number
is even. If value is not a number,
the function evaluates only the
integer part of the number.
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LN(number)

THE LN function returns the
natural logarithm based on the
constant e of the number.

Example:
View SketchUp Example

LOG10(number)

The LOG10 function returns the
base-10 logarithm of the
number.

Example:
View SketchUp Example

ODD(number)

The ODD function rounds the
number up to the nearest odd
integer.

Example:
View SketchUp Example

PI()

The PI function returns the value
of PI to fourteen decimal places.

RADIANS(number)

The RADIAN function converts
the number (in degrees) to
radians.

Example:
View SketchUp Example

RAND()

The RAND function returns a
random number between 0 and
1.

Example:
View SketchUp Example
Example:

The RANDBETWEEN function
RANDBETWEEN(bottom,
=RANDBETWEEN(1,3)
returns a whole number between
top)
The previous example returns
the bottom and top number.
a 1, 2, 3.
View SketchUp Example
The ROUND function rounds the
number to a certain number of
decimal places according to valid
mathematical criteria. The count
argument is optional and
ROUND(number, count)
represents the number of the
places to round the number. If
the count argument is negative,
only the whole number portion is
rounded.

Example:
=ROUND(1.12789,2)
The previous example returns
1.13.
View SketchUp Example

SIGN(number)

The SIGN function returns the
Example:
sign of the number. The function View SketchUp Example
returns the result 1 for a positive
sign, -1 for a negative sign, and
0 for zero.

SQRT(number)

The SQRT function returns the
positive square root of the
number. The number must be
positive.
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Dynamic Components SketchUp Function Examples
•
•
•
•
•
•

Math Functions
SketchUp Functions
Text Functions
Trig Functions
Logical Functions
OnClick Functions

SketchUp Functions (Specific to SketchUp Dynamic Components)

Function

Description

Example(s)

The CHOOSE function
returns a value from a list
of parameters, at the
location of the index
value. This function
allows you to create a
single drop-down list that
drives multiple attribute
changes at once.

Example:
=CHOOSE(2,"Blue","Red","Green
")
Results in "Red."

The CURRENT function
accepts a string name of
an attribute, and returns
the size or position
attribute that the
CURRENT("attributeName")
SketchUp user just
applied. This function
allows you to do
validation of Scale Tool or
Move Tool actions.

Example:
=ROUND(CURRENT("LenX")/2)*
2
When entered into the LenX value
field this example constrains the
component to the nearest width,
within 2 inches, after scaling.

Example:
=CHOOSE
(OPTIONINDEX("Material"), 100,
150, 200)
Returns 100, 150, or 200
Use CHOOSE and
depending on the material chosen
OPTIONINDEX together
in the Component Options dialog
as a mechanism to assign box.
CHOOSE(index,value1,value
different values
2, ...valueN)
depending on a user's
View SketchUp Example
choice in the Component
Options dialog box. For
example, if the
Component Options
dialog box allows the user
to choose different
materials to assign to a
component (and the price
changes depending on
material chosen), you can
create a formula for the
MSRP

View SketchUp Example
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The EDGES function
View SketchUp Example
returns the number of
"ungrouped" edges inside
the component or group
that this function is called
within.

The FACEAREA method
returns the area (in
square inches) of every
"ungrouped" face that is
painted with the
FACEAREA("materialName"
materialName. The
)
FACEAREA method
returns the total area of
all ungrouped faces when
the materialName is not
provided.

FACES()

Example:
=FACEAREA("Oak")
Returns the square inches of Oak
material inside the component or
group.
View SketchUp Example

The FACES function
View SketchUp Example
returns the number of
"ungrouped" faces inside
the component or group
that this function is called
within.

Example:
=LARGEST(CURRENT("LenX"),
20, 10)
When entered into the LenX value
The LARGEST function
field this example constrains the
LARGEST(value1,value2,...v
returns the largest of the component so it cannot be scaled
alueN)
values in a list.
more than the largest of three
numbers (either the value of
LenX, 20, or 10):
View SketchUp Example
LAT()

The LAT function returns View SketchUp Example
the latitude of the current
SketchUp model.

LNG()

The LNG function returns
the longitude of the
-current SketchUp model.

NEAREST(originalValue,
value1, value2, ...valueN)

Example:
=
The NEAREST function
NEAREST(CURRENT("LenX"),24,3
compares the
6,48)
originalValue with a list of When entered into the LenX value
target values, and returns field, this example will cause the
the target value that is
component to snap to the nearest
closest to the
width of 24,36, or 48 after
originalValue.
scaling.
View SketchUp Example
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The OPTIONINDEX
View SketchUp Example
function returns the
currently selected index
from its option list given a
string name of an
OPTIONINDEX("attributeNa attribute. For example, if
me")
an attribute can be
"red","blue", or "green",
and blue is the current
value, this function
returns 2. If no match is
found, 0 is returned.
The OPTIONLABEL
View SketchUp Example
function returns the
currently selected label
form its option list given a
string name of an
attribute. For example, if
OPTIONLABEL("attributeNa
an attribute can be
me")
"Red=red","Blue=blue",
or "Green=green", and
blue is the current value,
this function returns
"Blue". If no match is
found, an error is raised.

The SMALLEST function
SMALLEST(value1,value2,...
returns the smallest of
valueN)
the values in a list.

Example:
=SMALLEST(CURRENT("LenX"),2
0, 10)
When entered into the LenX value
field this example constrains the
component so it cannot be scaled
less than the smallest number
(the value of LenX, 20, or 10).
View SketchUp Example

SUNANGLE()

The SUNANGLE function View SketchUp Example
returns the angle (in
degrees) between the sun
and the current model's
North direction.

SUNELEVATION()

The SUNELEVATION
View SketchUp Example
function returns the
elevation (in degrees) of
the sun from the current
model's shadow settings.
The elevation is defined
as the angle between a
vector pointing at the sun
and the ground plane.
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Dynamic Components Text Function Examples
•
•
•
•
•
•

Math Functions
SketchUp Functions
Text Functions
Trig Functions
Logical Functions
OnClick Functions

Text Functions
Function

Description

Example(s)

CHAR(number)

The CHAR function converts a number View SketchUp Example
into a character according to the
current code table. The number
argument can be a two-digit or threedigit integer number between 1 and
255 (representing the code value for
the character).

CODE(text)

The CODE function returns a numeric View SketchUp Example
code for the first character in a text
string. The text argument is the text
for which the code of the first
character is to be found.

CONCATENATE(text1,
text2, ...textN)

The CONCATENATE function combines View SketchUp Example
several text strings into one string.
The text1, text2, ...textN arguments
are text strings that are combined
into one string.

DOLLAR(value,
decimals)

The DOLLAR function converts a
View SketchUp Example
number to an amount in the currency
format, rounded to a specified decimal
place. The value argument is the
number to be converted to currency.
The value argument can be a number,
a reference to a cell containing a
number, or a formula which returns a
number. The decimals (optional)
argument is the number of decimal
places. If no decimals value is
specified, all numbers in currency
format will be displayed with two
decimal places. The currency format is
set in the system settings.

EXACT(text1, text2)

The EXACT function compares two
text strings and returns TRUE if they
are identical. This function is casesensitive. The text 1 and text 2
arguments are the text strings.

FIND(findText, text,

The FIND function looks for a string of View SketchUp Example

View SketchUp Example
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text within another string. The
findText argument is the text to be
found. The text argument is the text
string to be searched. The position
(optional) argument is the position in
text where the search starts. The
findText argument can be a number
or any string of characters. The
search is case-sensitive.

LEFT(text, number)

The LEFT function returns the first
character (or characters) in a text
string. The text argument is the text
string. The number (optional)
-argument is the number of characters
to be returned. One character is
returned if the number is not defined.

LEN(text)

The LEN function returns the length of
a text string including spaces. The
-text argument is the string whose
length is returned.

LOWER(text)

The LOWER function converts all
uppercase letters in a text string to
lowercase. The text argument is the
string to be converted.

MID(text, start,
number)

The MID function returns a text
View SketchUp Example
segment of a text string. The text
argument is the text string. The start
argument contains the position of the
first character in the text to extract.
The number argument is the number
of characters to return.

PROPER(text)

The PROPER function capitalizes the
View SketchUp Example
first letter in all words of the provided
text string.

View SketchUp Example

The REPLACE function replaces part of View SketchUp Example
a text string with a different text
string. The text argument is the text
string of which part will be replaced.
The position function is the position
within the text where the replacement
will begin. The length argument is the
number of characters in the text to be
REPLACE(text, position,
replaced. The new argument is the
length, new)
replacement text.
This function can be used to replace
both characters and numbers (which
are automatically converted to text).
The result of the function is always
displayed as text. To perform further
calculations with a number which has
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been replaced by text, convert it back
to a number using the VALUE
function. Any text containing numbers
must be enclosed in quotation marks
so it is not interpreted as a number
and automatically converted to text.

REPT(text, number)

The REPT function repeats a text
View SketchUp Example
string. The text argument is the text
to be repeated. The number argument
is the number of repetitions. The
result can be a maximum of 255
characters.

RIGHT(text, number)

The RIGHT function returns the last
View SketchUp Example
character or characters in a text
string. The text argument is the text
string. The number (optional)
argument is the number of characters
to be returned.

SUBSTITUTE(text,
searchText, newText,
occurrence)

The SUBSTITUTE function substitutes View SketchUp Example
new text for old text in a string. The
text is the old text string. The
searchText argument is the segment
in text to be replaced. The newText
argument is the replacement text. The
occurrence (optional)argument
indicates the number of occurrences
of searchText to be replaced. If the
occurrence is missing, the search text
is replaced throughout.

TRIM(text)

The TRIM function removes spaces in View SketchUp Example
front of a text string (or aligns cell
contents to the left). The argument
contains text string or cell whose
contents will be left-aligned.
View SketchUp Example

UPPER(text)

The UPPER function converts a text
string to uppercase. The text
argument contains the lower case
letters you want to convert to upper
case.

View SketchUp Example

VALUE(text)

The VALUE function converts a text
string into a number. The text
argument is the text to be converted
to a number.
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Dynamic Components Trig Function Examples
•
•
•
•
•
•

Math Functions
SketchUp Functions
Text Functions
Trig Functions
Logical Functions
OnClick Functions

Trig Functions

Function

Description

ACOS(number)

The ACOS function returns the inverse cosine
of the number in degrees.

ACOSH(number)

The ACOSH function returns the inverse
hyperbolic cosine of the number in degrees.

ASIN(number)

The ASIN function returns the inverse sine of
the number in degrees.

ASINH(number)

The ASINH function returns the inverse
hyperbolic sine of the number in degrees.

ATAN(number)

The ATAN function returns the inverse
tangent of the number in degrees.

ATANH(number)

The ATANH function returns the inverse
hyperbolic tangent of the number in degrees.

COS(number)

The COS function returns the cosine of the
number in degrees.

COSH(number)

The COSH function returns the hyperbolic
cosine of the number in degrees.

SIN(number)

The SIN function returns the sine of the
number in radians.

SINH(number)

The SINH function returns the hyperbolic
sine of the number in radians.

TAN(number)

The TAN function returns the tangent of the
number in radians.

Example(s)
View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

View SketchUp Example

SketchUp Help Pages – version 19.

TANH(number)

The TANH function returns the hyperbolic
tangent of the number in radians.
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View SketchUp Example
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Dynamic Components Logical Function Examples
•
•
•
•
•
•

Math Functions
SketchUp Functions
Text Functions
Trig Functions
Logical Functions
OnClick Functions

Logical Functions (for math-related use)
Function

Description

The AND function returns TRUE if all
arguments are TRUE. If any element is
AND(logicalValue1,
FALSE, this function returns the FALSE
logicalValue2,
value. The logicalValue arguments are
...logicalValueN)
conditions to be checked. All conditions
can be either TRUE or FALSE.
FALSE()

Example(s)
View SketchUp Example

The False function sets the logical value View SketchUp Example
to FALSE. The FALSE function does not
require any arguments.

The IF function identifies a logical test.
The test argument is any value or
expression that can be TRUE or FALSE.
IF(test, thenValue, The thenValue (optional) is the value
elseValue)
that is returned if the logical test is
TRUE. The elseValue (optional) is the
value that is returned if the logical test
is FALSE.

Example:
=IF (5=5, 1, 0)
Returns a 1 if the test (5=5)
is TRUE. Otherwise, the
function returns a 0.

The NOT function reverses the
NOT(logicalValue) logicalValue. The logicalValue argument
is any value to be reversed.

View SketchUp Example

View SketchUp Example

OR(logicalValue1,
logicalValue2,
...logicalValueN)

The OR function returns TRUE if at least
one argument is TRUE. This function
returns FALSE if all the arguments have
the logical value FALSE.The logicalValue -arguments are conditions to be checked.
All conditions can be either TRUE or
FALSE.

TRUE()

The TRUE function turns the logical
View SketchUp Example
value to TRUE. The TRUE() function does
not require any arguments.
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Dynamic Components OnClick Function Examples
•
•
•
•
•
•

Math Functions
SketchUp Functions
Text Functions
Trig Functions
Logical Functions
OnClick Functions

OnClick Functions
Function

ALERT("message")

Description

The ALERT function displays the
value of the message in an alert
box.

Example(s)
Example:
=ALERT("You Clicked
Me!")
Displays an alert box
with the phrase ""You
Clicked Me!," when
inside the ONCLICK
attribute.
View SketchUp Example

ANIMATE(attribute, state1,
state2, ... stateN)

The ANIMATE function starts an
View SketchUp Example
animation that will change the
value of the attribute to the next
value in a list of parameters
every half a second. For
example,if the ONCLICK attribute
contains ANIMATE("X",0,100),
and the user clicks on the
component, the component would
animate the value of the "X"
attribute between 0 and 100. A
subsequent click would animate
back to 0 from 100. If more than
two animate states are passed,
then the value will toggle
between them in order. So, if the
ONCLICK attribute equals
ANIMATE("ROTZ",0,-130,10,100)
the animation would go through
each of the 4 values with each
click.
This function animates with
default easing. Easing is the
speed of the animation (on a
scale of 0 to 100, 0 being
fastest). Easing is represented by
two numbers, the first number
(easein) identifies the speed at
the start of the animation. The
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second number (easeout)
identifies the speed at the end of
the animation. Default easing is
0,100 (animation starts fast but
slows down at the end).
ANIMATESLOW(attribute,
state1, state2, ... stateN)

The ANIMATESLOW function does View SketchUp Example
the same thing as animate, but
slower (one second).

ANIMATEFAST(attribute,
state1, state2, ... stateN)

The ANIMATEFAST function does
the same thing as animate, but
faster (a quarter of a second).

View SketchUp Example

The ANIMATECUSTOM function
View SketchUp Example
does the same thing as animate,
ANIMATECUSTOM("attribute",
but with over an arbitrary time
time, easein, easeout, state1,
with easing. Refer to the
...stateN)
ANIMATE function for information
about easing.
GOTOSCENE("sceneName,"
time, easein, easeout)

The GOTOSCENE function moves View SketchUp Example
to a scene identified by a name or
number. Refer to the ANIMATE
function for information about
easing.

REDRAW()

The REDRAW function redraws
View SketchUp Example
the component that contains this
function.

SET("attribute", state1,
state2, ...stateN)

The SET functoin sets a given
attribute to the next state in a
list.

View SketchUp Example
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Preserving Textures in a Dynamic Component.
When purging a model in SketchUp or uploading it to the 3D Warehouse, unused materials will
be removed. If your model contains a Dynamic Component, though, you may also lose textures
in "Choose Options" or "OnClick" attributes. To avoid losing these textures, you'll need to
embed them into the Dynamic Component:
1. Create your Dynamic Component.
2. Create a small face.
3. Apply the unique texture to the face. The texture is now embedded in the component
and will be available to all users of the component.
4. Select the small face, context-click and select Hide.
5. Repeat for all other textures.
Note: If your Dynamic Component contains custom textures (textures that don't come with
SketchUp), you'll also need to embed them in order for those textures to be accessible on other
computers.
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Using Unique Textures in a Dynamic Component
This is a Pro only feature.
Dynamic Components that use unique textures (textures that do not ship with SketchUp, such
as photographic textures of a specific material), must be embedded in the Dynamic Component
to be accessible when that component is used on different computers. To embed a texture in
a Dynamic Component:
1. Create your Dynamic Component.
2. Create a small face (it can be as small as a few millimeters) on the component that is
not visible to the user. For example, create a face on the bottom of a couch component.
3. Apply the unique texture to the face. The texture is now embedded in the component
and will be available to all users of the component.
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Hiding the Scale Handles in a Dynamic Component
This is a Pro only feature.
Add the Scale tool attribute to your Dynamic Component to toggle display of scale handles on
the component (limiting how users can scale the component). To hide scale handles using the
Scale tool attribute:
1. Context-click on the component. The component's context menu is displayed.
2. Select the Dynamic Components > Component Attributes menu item. The
Component Attributes dialog box is displayed. Notice that the top-level component is
listed.
3. Click the + button next to the component's name. An empty list of attributes appears
for the component.
4. Click on the add attribute button in the last row of the attributes list. A list of
predefined attributes is displayed. The field is opened for editing.
5. Click on the Scale tool attribute in the list. The field is populated with the word 'Scale
tool.'
6. Click on the Details button to the right of the Scale tool attribute. The attribute details
panel is displayed. The following image shows the attribute details panel:

7. Deselect the checkboxes next to the scale handles you want to toggle off. Or,
alternatively, select the checkboxes next to the scale handles you want to toggle on.
8. Click on the Save button. The attribute details panel closes.
9. Click on the Close button. The Component Attributes dialog box closes.
10. Select the Scale tool (
). The cursor will change to a box within another box.
11. Click on the Dynamic Component. The scaling grips that are toggled on will appear
around the Dynamic Component.

Classifying Objects
Some philosophers say that naming something is the first step toward figuring out what makes
that thing different from all the other things in the world.
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In a SketchUp 3D model, this idea isn’t some wishy-washy concept. When you use the Classifier
to embed data into groups or or components, those groups or components become objects.
When objects have names, descriptions, and so on, you can manage the details about all the
classified objects.
The details that you can track and manage can represent so much more than simply what the
modeled object looks like. Consider the following:
•
•
•

•

You can count, measure, dimension, and tag objects.
You can generate reports. When your model contains classified objects, SketchUp’s
Generate Report feature enables you to output that the classification data however you
need to see it.
You can analyze your model. If you want to analyze a model for energy performance,
cost, schedule or even just render a beautiful photorealistic picture from it, you need
more information than exists in SketchUp’s native geometry of lines and faces.
SketchUp objects can carry that information, which means you can do BIM (Building
Information Modeling).
You can export the objects into other formats or programs. When you export
SketchUp objects, they can contain all kinds of higher-order representations of things.
For example, if your project workflows use BIM, you can export objects classified using
the IFC 2x3 schema from SketchUp into the open BIM data exchange standard, IFC.
(IFC stands for Industry Foundation Classes, an open data model standard for building
information.) Rendering applications can use these attributes, such as material type and
light sources, to simulate a scene. SketchUp’s APIs expose all the additional data that
developers need to make rich importers and exporters from just about any information
modeling format.

The upshot is that if you classify your data in SketchUp, you can use BIM to create models that
not only look realistic, but also contain practical data about all the objects that need to be
assembled in order to keep the rain out.
Note: To use SketchUp’s Classifier tool and its related features covered in this article, you need
a SketchUp Pro

license.

Tip: To learn more about BIM and IFC, visit the Building Smart website.
In the sections that follow, you find out how to classify objects in SketchUp and generate a
report based on that data. If you need to use classification data other than the IFC standard
that SketchUp supports, learn how to import and export classifications or create your own
classification data file.
Table of Contents
1.
2.
3.
4.

Classifying objects in the SketchUp interface
Generating an attribute report
Importing, exporting, and deleting classifications
Creating an SKC file

Classifying objects in the SketchUp interface
Before you start classifying objects, make sure your model is ready:
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Your soon-to-be objects must start as components. Developing Components and
Dynamic Components explains how to transform everyday geometry into a component.
Tip: When you create a component, you can assign it a type by selection an option from
the Type drop-down list in the Create Component dialog box.

•
•

The classification system must be loaded into your template. If you create a 3D
using SketchUp’s Architectural Design - Feet and Inches template, the IFC classification
system is ready to go. (Otherwise, you need to import classifications.)
You probably want to display the Classifier toolbar. IF you don’t see it,
select View > Toolbars and select the Classifier checkbox

After you complete the basic housekeeping, you’re ready to start classifying objects. With the
Classifier toolbar, all you have to do is click a couple of things:
1. Select your component.
2. Open the drop-down menu in the Classifier toolbar, click the arrow next to IFC 2x3 (or
whatever your classification system is), and select an object type, as shown in the
following figure.

Tip: If you’re having trouble finding the classification you need, type part of its name in the
Filter text box, which narrows down the options.
The toolbar also has the Classifier tool (
classify objects with the Classifier tool:
•

). Here are a few things to keep in mind as you

If the drop-down menu has a white background and a type, this indicates that the
Classifier tool is active and clicking objects with the Classifier tool will apply the type
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displayed in the toolbar.
If you click a component, the classification type is assigned to all the instances of the
same component unless you hold down the Shift key as you click with the Classifier
tool. Holding down the Shift key makes the component instance you click unique and
applies the type data only to that component instance.
To remove a type from an object, make Type: <undefined> active in the drop-down
menu and then click an object to remove the type data. Alternatively, select the same
type from the list of classification options.

If you prefer, you can select classification data from the Entity Info panel:
1. Context-click your component and select Entity Info from the menu that appears.
2. In the Entity Info panel, shown in the following figure, select a classification from the
Type drop-down menu. This displays the same interface you see when using the
Classifier toolbar.

You can also sample an object’s classification and apply it to another component. First make
sure no geometry is selected. Then, click the Classifier tool (
). Hold down the Alt key
(Microsoft Windows) or Command key (Apple macOS) as you click a classified object. Release
the modifier key and click another component to apply the object’s classification type.
Tip: When you assign an IFC type to a component, know that the type is assigned to the
component definition (not a single component instance). If you copy components in your
model, know that you’re assigning that classification type to all component instances.
If you need to separate a component into two different definitions, you can do that. For
example, say both a floor and a ceiling are the same shape and they both
need IfcSlab classifications. You don’t want to redraw the geometry, but you do want to
distinguish between floors and ceilings in your information modeling. Here’s how to set up that
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information modeling structure with the least amount of work:
1. Copy a classified object and move it into its new position. In the example, you copy the
floor and move the copy to create a ceiling.
2. Context-click the copy and select Make Unique from the menu that appears.
3. Open the Entity Info window for the copy (in this case, the ceiling).
4. Type a new definition in the Definition text box. In the following figure, you can see the
Entity Info panels for the two example components; notice how they both have the
same IFC type but different definitions.

Generating an attribute report
With the Generate Report feature, you can create a report that lists component attributes and
download the report as a CSV file. Generating a report is a quick and easy way to see quantities,
materials, and other data about items in a SketchUp model.
For example, say you have a model that contains several components (doors, columns, and
slabs) and several instances of each component. You can generate a report that shows how
many of each item you needand how much it will cost. The following video walks you through
the process of generating a report.
Note: To use the most current version of the Generate Report feature for your version of
SketchUp, your computer needs to be online. For instructions on using Generate Report without
an internet connection, select SketchUp 2015 from the Help Center version picker.

Set up a template to customize report data
The Generate Report feature uses templates to determine what data appears in your report
and how that data is organized. You can create several templates to reflect the different types
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of reports you need.
To create a template, follow these steps :
1. Select File > Generate Report. You see the templates manger.
2. ClickCreate New Template, and you see options to include in your template.
Alternately, you can duplicate and edit the selected template to create a new template
based on an existing one.
3. Select your desired filters, columns, and units for your template. For details about these
options, see the following list.
4. Click Save Changes to save this template to your model so that you can use the
template again.(If you need to use this template only once, you can instead click Run
Report to generate a report without saving the template.)
5. Enter a title and description and then click Save to Model, as shown in the following
figure. Your template is saved.
Here’s how the template options, shown in the following figure, enable you to customize your
report:
•
•

•

Selection: Select Entire Model, which is the default, to generate a report on your
whole model. Select the Current Selection checkbox to generate a report that includes
only selected entities.
Component Nesting Levels: When the lower check box is selected, you can determine
what components appear in the report based on how they’re nested in your model. The
SketchUp model itself is Level 1, and any Group or Component at the root level is a
Level 2 object. The entities in Level 3 are entirely dependent on how the model was
created. You can see how entities are nested in a specific model by opening the Outliner
panel. When the Component Nesting Levels checkbox is selected, you can enter a level
or range of levels in this text box, and the report will include only entities in those levels.
Format Columns: Use the options in this area determine what data your report
includes and how it’s organized. The left column holds all the attributes you can add to
your report.The icon next to each item indicates a core SketchUp attribute (
Similarly, the IFC icon (

•

).

) indicates an IFC attribute, and the Dynamic Component

icon (
) indicates a dynamic component attribute. Note that the different types of
attributes aren't connected, so you could have an IFC price attribute and a DC price
attribute
that
show
different
prices.
On the right,the Group By box sets how the data types you choose are grouped in a
single row, andthe Report Attributes box lists what attributes will appear in the report
and
the
column
order.
To move an attribute from the left column to the right, select the attribute and click the
right-pointing arrow to move it to the Report Attributes box.You can then drag any item
from the Report Attributes box to the Group By box. Also, click the gear icon next to
any item to select options for how an attribute is aggregated (concatenated strings,
concatenated subtotals, or total sum).To customize the order of the columns in the
report, use the up and down arrows or drag items to your desired location in the list.
Units: Select what type of units your report uses. You can choose from Architectural,
Decimal (in inches, feet, centimeters, meters, and so on), Engineering, or Fractional
Inches. You can also set a level of precision.
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Tip: You can edit a template anytime. On the templates manager screen, select the report
you want to edit and click the Edit button.

Import and export a report template
When you save a report template, it's saved with your model. To share a template across
models, you can export a .grt file to your hard drive by clicking the Export button in the
Generate Report box and saving the file. Then in the model where you want to reuse the
template, click the Import button in the Generate Report box to import that .grt file.
Alternatively, you can save your report template to a SketchUp model template, so that your
report template is always available. Simply save the report template to your model and
then save that model as a SketchUp template that you can use every time you start SketchUp.

Generate a report based on a template
1. Select File > Generate Report and select the template you want to use.
Tip: If your template generates a report based on the current selection, make sure the
components you want to include in your report are selected.
2. Click Run to generate the report, which then appears on-screen, as shown in the
following figure.
3. (Optional) Click Download to open the Save Report dialog box. Name the file, choose
where you want to save it on your hard drive, and click Save. You can then open the
CSV file in a spreadsheet program or insert it as a table in LayOut.
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Importing, exporting, and deleting classifications
As you work with classification files, know that SketchUp uses classification systems that are
in the .skc or .xsd file formats.
To import a classification into a SketchUp model, follow these steps:
1. Select Window > Model Info.
2. In the Model Info window, select Classifications on the left.
3. In the Classifications panel, click Import. By default, a file browser opens to your user
Classifications folder.
4. If you copy your .skc or .xsd file to the Classifications folder, select the file you want
and click Open. Otherwise, click the Browse button to import a file from another
location.
When you import a classification, that data is embedded into the SketchUp file. So if you share
a SketchUp model with someone else and they open the file on their copy of SketchUp, they
can reference and use the same classification.
Tip: You can also create a SketchUp template with your favorite classification so you don’t
have to import the .skc or .xsd file every time you create a new SketchUp file. SketchUp’s
Architectural Design and Construction Documentation templates have the IFC 2x3 classification
in them by default.
If you receive a SketchUp file that has an embedded classification, you can export
that classification to a .skc file on your computer. To do so, open the Classifications panel in
the Model Info window. Select the classification from the list that appears, and click
the Export button. This is helpful if you want to have a local copy of a .skc classification file to
use in other SketchUp models.
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When you remove a classification from your SketchUp model, you remove the type and
attribute data from that SketchUp file, too. However, any classifications that exist locally on
your computer stay where they are. To delete a classification from a SketchUp model, open
the Model Info windows Classifications panel, select the classification, and click Delete.

Creating an SKC file
In SketchUp, the .skc file format stores the classification data that you see in the Classification
tool. Each .skc file contains XML schema definition files and other files that help define
additional schema metadata. All these files are zipped up in one file.
In this section, you learn about the guts of the .skc file and find steps that walk you through
creating one.
For the purposes of this tutorial, you modify a sample ifcXML4.skc file to create a new SKC file
with your schema data. Follow these steps to get started:
1. Click here to download the sample ifcXML4.skc file.
2. Rename the file from ifcXML4.skc to something else, like my_schema.zip.
3. Unzip my_schema.zip.
In the sections that follow, you find a introduction to each of the files in my_schema.zip. You
also find details about what you can change and how to customize your classification data.
After you learn about each file, you find out how to back the .zip file back into an .skc file.
doc_thumbnail.png
This image file visually represents your schema. You can replace this file with your own image
file and name it however you like. (Note that SketchUp 2014 and 2015 don’t currently use this
file but may do so in a future release.)
documentProperties.xml
This file is required, and you cannot change its name. However, you may want to change
several fields in this file. Although SketchUp 2014 and 2015 display only your change to the
title field, future releases of SketchUp may take advantage of the other fields in this file. Here’s
a list of all the fields in the documentProperties.xml file and what you can and can’t change:
•
•
•
•
•

•

The title field contains the name of your schema that appears throughout the
SketchUp UI. Change it to reflect your schema’s name.
The description field contains the schema’s description. Change it to describe your
schema.
The creator field contains the the schema creator’s name. Change it to reflect the
creator of your schema.
The revision field reflects the revision of your schema. Change it if you would like or
leave this field as it is. This field must have a value.
The created and modified fields reflect the created and modified dates of the
schema. You can change these fields or leave them as they are but they can’t be blank.
If you change the dates, the values must follow this format: YYYY-MM-DDThh:mm:ss.
For example, sometime on January 30, 2014 looks like this: 2014-01-30T12:00:00
The thumbnail field points to your schema’s thumbnail. If you are using a schemaspecific thumbnail, change this field to reflect the name of your schema’s thumbnail.
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The
following
figure
shows
the
data
you
might
want
to
change
in
the documentProperties.xml file. Don’t modify any data other than what’s highlighted here.

references.xml
This file is required to properly load the .skc file. You can’t rename it or modify anything within
it.
Schemas folder
This folder holds your schema’s .xsd files. You also have the option of saving filter files in this
folder. Filter files control what type data is displayed, as explained a little later in this section.
Copy your .xsd files to this subfolder and delete the sample ifcXML4.xsd file.
SketchUp
can
process
any
valid .xsd file
or
collection
of
files
that
the http://www.w3.org/2001/XMLSchema namespace, with the following exceptions:
•
•
•

use

The XML Schema format allows for circular importing of .xsd files (i.e. two files
referencing each other with the element). This is only supported in SketchUp 2015 and
later.
The XML Schema format allows for externally referenced .xsd files. This is only
supported in SketchUp 2014 M1 and later.
Any <xsd:list> or <xsd:choice> attributes don’t appear in the Component Options
dialog box where classification attribute data is displayed. These attributes may become
visible in future versions of SketchUp.

Note: If your schema file contains included or imported .xsd files, the XML Schema file
hierarchy must be maintained.
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Filter files
Filter files enable you to restrict what type and attribute data is visible in the SketchUp UI by
default. If an .xsd.filter file exists, a Simplify button appears in the SketchUp UI wherever type
data is displayed. This Simplify button enables users to toggle between the restricted view of
the schema data that you set up and the full set of data. If an .xsd file has no filter file, all
types and attributes are visible.
Filter files can whitelist types and their attributes, and they can blacklist attributes:
•
•

Whitelisting makes the types and attributes visible in the UI. When you whitelist
a type, you can choose what attributes for that type appear in the Component Options
dialog box.
Blacklisted attributes are not displayed. Blacklisting an attribute affects all types
that haven’t whitelisted that attribute.

To create a filter file, follow these steps:
1. Create a file with the same name as the .xsd file that you want to filter and a .filter file
extension.
2. List the type names you want to make visible by default in the UI.
3. (Optional) In curly braces ({}), list any attribute data you want to make visible by
default.
For example, here’s how the my_schema.xsd.filter file shown in the following figure impacts
the SketchUp interface:
•
•
•

A Simplify button appears for the my_schema schema.
By default, only the IfcBeam type as well as its Name, Description, ObjectType, and Tag
attributes are visible. A user can, however, click the Simplify button to toggle the display
all schema data and the simplified version you set up.
The blacklisted instanceAttributes attribute isn’t visible.
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As you create your own filter files, the following tips are also good to know:
•
•
•
•

To add comments to this file, start each line with a double forward slash (//).
To create an attribute blacklist (instead of a whitelist), don’t add a type name to the
line before the open curly brace ({).
Save a .filter file with its .xsd counterpart. For example, if base.xsd is saved in
the Schemas\base folder, you need to save base.xsd.filter in the same folder.
The .filter file format is subject to change in future versions of SketchUp.

document.xml
This file indicates the relative path to the root .xsd file for your schema. This file is required
and
you
can’t
rename
it.
As
shown
in
the
following
figure,
change xsdFile="Schemas/ifcXML4.xsd" to point at your root .xsd file that you copied to the
Schemas folder.

Repackaging your .zip file
After you customize the files, you simply have to zip them back together. Include only the
necessary files — not the folder that contains all your files. If you include that folder, SketchUp
can’t import your schema.
After you create the .zip file, change the extension from .zip to .skc and optionally rename the
file. You are now ready to load your .skc file into SketchUp!
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Placing Movie Cameras in a Model of a Production Set
The Advanced Camera Tools (ACT) are designed for people in the film and television industry
who storyboard, design sets, visualize scenes, and plan locations. Use ACT to place real-world
cameras in your SketchUp models and preview real camera shots.
To place cameras in a model with the ACT tools, you need a SketchUp Pro license.
The following figure shows a scene with four ACT cameras:

You can look through cameras to preview a shot.
The following figure shows the view through Camera 1.
(cont’d next page)
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When you switch your view to Camera 2, you see a different perspective from within the model,
as shown in this next figure.
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In the next figure, you see how Camera 3 enables you to preview a closeup shot.

If you have SketchUp Pro, you can access the Advanced Camera Tools as a toolbar or under
the Tools > Advanced Camera Tools menu.
Note: You may need to install the Advanced Camera Tools extension from the Extension
Warehouse before you use the tool.
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Creating an ACT camera
To create a camera using ACT:
1. Select View > Tool Palettes > Advanced Camera Tools (Apple macOS) or View >
Toolbars > Advanced Camera Tools (Microsoft Windows). The Advanced Camera
Tools toolbar is displayed.
2. Select Tools
>
Advanced
Camera
Tools
>
Select
Camera
Type
> categories > camera. Shaded horizontal letterboxing (1) or vertical pillarboxing (2)
bars appear if your camera has a different aspect ratio than SketchUp's drawing area.
The area within the bars indicates the area viewable through the camera.

3. Click Create Camera (
). The Camera Name dialog box appears.
4. Type a name of the camera in the Name field.
5. Click Done. A physical camera model (group) is created and placed in your model. You
are placed in camera view mode, where you are looking through the camera at your
subject. A crosshair shows the middle of the camera. Camera properties appear in the
lower-left corner of the model. A tab with the camera's name also appears. You can
perform several functions on the camera, such as looking through the camera and
editing camera properties in camera mode.
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6. (Optional) Use SketchUp's Orbit, Pan, and Zoom tools to physically reposition the
camera in your model. Using the Zoom tool physically repositions the camera.
See Repositioning an ACT camera for details.
7. (Optional) Use the arrow keys to pan, tilt, dolly, truck, pedistal, roll, and adjust the focal
length while looking through the ACT camera. Moving and Aiming an ACT
Camera explains how these actions work in detail.
8. After you adjust your camera, click Lock Camera (
). This option ensures that you
don't move or alter the camera position or settings.
9. Context-click and select Done. You are finished creating your camera.
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Deleting an ACT Camera
To permanently remove an ACT camera, follow these steps:
1. Ensure you are not in camera view mode.
2. Zoom out so you can see the camera you want to delete.
3. Delete the camera model. The corresponding scene and scene tab are also removed.
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Editing an ACT Camera's Properties
To edit the properties of an ACT camera while in camera view mode, follow these steps:
1. Context-click and select Edit Camera. The Camera Properties dialog box appears.
2. Modify properties as needed. See the upcoming list for details about your options.
3. Click OK.
You can also edit an ACT camera's properties outside of camera view mode. Here's how it's
done:
1.
2.
3.
4.

Move the cursor over the camera model.
Context-click and select Edit Camera. The Camera Properties dialog box appears.
Modify properties as needed. See the upcoming list for details about your options.
Click OK.

In the Camera Properties dialog box, you can control the following options for your ACT
cameras:
•
•
•
•
•
•
•

Name: Type descriptive name for your camera, which appears within the Advanced
Camera Tools submenus in SketchUp.
Height: Set the camera's height relative to the ground.
Tilt: Control the camera's forward or backward tilt.
Roll: Set the camera's left or right swivel in degrees. The swivel is similar to a person
turning their head.
Focal Length: This setting controls the camera's zoom value.
Aspect Ratio: Set the width and height of the film or sensor as a decimal number. The
numbers 1.33 and 2.4 are common aspect ratios for film.
Image Width: Adjust the physical width of the camera's film or sensor in millimeters.
You can usually find this figure in your camera's user manual.
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Looking through an ACT Camera
In camera view mode, you can look through an ACT camera in a few different ways.
Here's how to peer into your camera with the ACT toolbar:
1. Click Look through a camera (
). The Select Camera dialog box appears.
2. Select a camera from the Camera drop-down menu.
3. Click OK to look through the camera.
Click one of the ACT tabs, and you see through the tab's corresponding camera.
If you're a fan of navigating via context menus, follow these steps:
1. Move the cursor over the camera model.
2. Context-click the camera and select Edit Camera. The Camera Properties dialog box
appears.
3. Modify the camera's properties as needed. Refer to The ACT Camera Properties dialog
box for further information.
4. Click OK.
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Moving and Aiming an ACT Camera
In camera view mode, you can move and aim SketchUp's virtual cameras much like you'd move
an actual movie camera. The following figure shows off all the SketchUp ACT camera moves:
dolly (1), pedistal (2), truck (3), pan (4), tilt (5), roll (6), and changing focal length.

Tip: Before you move or aim a camera, you can increase or decrease the speed of the action.
Press the + key to increase the speed or the - key to slow things down.
Performing a dolly
Hold the Shift key while pressing the up and down arrow keys to move a camera forward or
back. Or, hold the Shift key and the left mouse button while moving the mouse forward or
backward to move a camera forward or back.
Performing a pedistal
Hold the Shift and Ctrl keys (Microsoft Windows) or Shift and Option keys (Apple macOS) while
pressing the up and down arrow keys move a camera up or down. Or, hold the Shift and Ctrl
keys (Microsoft Windows) or Shift and Option keys (Apple macOS) and the left mouse button
while moving the mouse forward or backward to move a camera up or down.
Performing a truck
Hold the Shift key while pressing the left and right arrow keys to move a camera left or right.
Or, hold the Shift key the left mouse button while moving the mouse left or right to move a
camera left or right.
Performing a pan
Press the left or right arrow keys to pan (swivel) a camera left or right. Or, press and hold the
left mouse button while moving the mouse left or right to pan (swivel) a camera left or right.
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Performing a tilt
Press the up or down arrow keys to tilt a camera up or down. Or, press and hold the left mouse
button while moving the mouse forward or backward to tilt a camera up or down.
Performing a roll
Hold the Ctrl key (Microsoft Windows) or Option key (Apple macOS) while pressing the left and
right arrow keys to spin a camera left or right. Or, hold the Ctrl key (Microsoft Windows) or
Option key (Apple macOS) and the left mouse button while moving the mouse left or right to
spin a camera left or right.
Performing a focal length
Hold the Ctrl key (Microsoft Windows) or Option key (Apple macOS) while pressing the up and
down arrow keys to zoom the lens in and out. Or, hold the Ctrl key (Microsoft Windows) or
Option key (Apple macOS) and the left mouse button while moving the mouse forward or
backward to zoom the camera in and out.

Repositioning an ACT Camera
Wherever you create an ACT camera, SketchUp creates a small camera model. To reposition
this physical ACT camera model, use SketchUp's Move and Rotate tools.
Tip: Physically repositioning the camera model is different than aiming the camera (with the
pan, tilt, truck, or dolly movements, for example).
To move an ACT camera model, follow these steps:
1. Select the ACT camera model, as shown in the following figure.
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2. Use the Move and Rotate tools to reposition the camera model. Note that the precise
eye point of any camera is the center of its lens, as shown in the following illustration.

Showing or Hiding ACT Camera Geometry
When you add an ACT camera to your SketchUp model, SketchUp inserts a camera model with
built in frustrums, safe zones, and aspect ratio masking bars. In the following sections, you
find out to show or hide each element of the camera geometry.
Showing or hiding cameras
Every camera you create is added to a layer titled Cameras. If you're familiar with SketchUp's
layers feature, you know the layer enables you to control the cameras' visibility. However,
instead of using the Layers manger, you simply click Show/Hide All Cameras (
handy Advanced Camera Tools toolbar.

) on the

If you're not one for clicking toolbar buttons, you can instead select Tools > Advanced
Camera Tools > Show/Hide All Cameras, and in an instant, the cameras are shown or
hidden.
Showing or hiding frustrum lines
A camera’s frustum is the space that the camera can "see," given its focal length and aspect
ratio. When you create a camera with the Advanced Camera Tools, SketchUp generates not
only a camera model, but also geometry representing the camera's frustrum. This geometry
helps you know whether the camera can see everything you want to include in the shot and
nothing you don't.
In the following figure, you can see how frustrum lines (Callout 1) appear to show the boundary
of each camera's shot (Callout 2).

SketchUp Help Pages – version 19.

Page 339/567

To show or hide all camera frustrum lines, click Show/Hide All Camera Frustrum Lines (
) on the Advanced Camera Tools toolbar. Or select Tools > Advanced Camera Tools >
Show/Hide Camera Frustum Lines .
You can also show or hide all frustrum volumes. In the following figure, you see how frustrum
volumes (Callout 1) show the boundary and the complete volume of the visible area for the
camera ( Callout 2).
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To toggle the display of frustrum volumes, dlick Show/Hide All Camera Frustrum
Volumes (
) on the Advanced Camera Tools toolbar. Or on the menu bar, select Tools >
Advanced Camera Tools > Show/Hide Camera Frustum Volumes.
Note: Frustrum lines exist on a layer called Camera_FOV_Lines. Frustrum volumes exist on a
layer called Camera_FOV_Volume. These operations toggle the visibility of these layers on or
off.
Showing or hiding aspect ratio bars
When you create an ACT camera, aspect ratio bars appear if your camera has a different aspect
ratio than SketchUp's drawing area. To show or hide these bars, follow these steps:
1. Ensure you are not in camera view mode. Clearing the aspect ratio bars while in camera
view mode resets the camera to a default state.
2. Click Clear Aspect Ratio Bars (
) or select Tools > Advanced Camera Tools >
Reset cameras to hide all aspect ratio bars.
3. Click a camera's tab to restore aspect ratio bars.
Showing or hiding safe zones
A camera safe zone represents an area visible through the lens. Safe zones may represent any
of the following:
•
•
•

Different output resolutions
Different aspect ratios
How different viewing devices will crop the frame

Not all ACT cameras have safe zones, but some have several. When a camera has safe zones,
the zones appear as blue rectangles in the drawing area. To display a camera's safe zones,
follow these steps:
1. Make sure you're in camera view mode.
2. Context-click in the model window, and select Safe Zone Visibility > Show All Safe
Zones to show all safe zones for the camera. Or, select an individual safe zone to show
just that safe zone.

Editing the ACT cameras.csv File
Following are the contents required for each camera definition in the cameras.csv file:
Id
A unique numerical identifier for your camera.
Name
A descriptive name for your camera (this will appear within the Advance Camera Tools
submenus in SketchUp).
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Description
An additional description for your camera.
Note: the name and description fields need to have the same value and must be different
from any other line ID.
Category
The category or "type" of your camera. The category appears as a menu item under Tools >
Advanced Camera Tools > Select Camera Type. Existing categories include 16mm, 35mm,
Digital, IMAX, and Photography. You can also create a sub-category menu by placing a forward
slash between category and sub-category. For example, Digital/RED creates a category menu
titled "Digital" and a sub-category menu titled "Red."
image_width
The physical width of the film or sensor for your new camera, in millimeters. Usually you will
need to look this up this figure in your camera's manual.
aspect_ratio
The ratio of the width to the height of the film or sensor as a decimal number. The numbers
1.33 and 2.4 are common aspect ratios for film.
absolute_safe_ids
An absolute safe zone represents an area of the frame that’s limited by a physical reality such
as a film or sensor size, or a maximum resolution for a given frame rate.
Use this field to include other cameras’ image widths and aspect ratios as safe zones for the
camera you’re adding. Enter their IDs separated by vertical bars (|). For example, the RED®
Mysterium® Full CCD Area camera has the following Absolute Safe IDs:
23|24|25|26|27|28|29|30|31|32|33|34
The previous string of IDs means that each of these referenced cameras will appear as safe
zones when you’re looking through a RED® Mysterium Full CCD Area camera in SketchUp.
relative_safe_ids
A Relative Safe Zone represents an area of the frame that will be visible if the image is displayed
in a particular way. Safe zones for SDTV (aspect ratio of 1.33) and HDTV (aspect ratio of 1.78)
are good examples.
Similar to Absolute Safe IDs, Relative Safe IDs are used to reference other cameras (rows) in
the CSV as safe zones for the camera you’re creating. List the IDs for the cameras you want
to reference, separated by vertical bars (|).
camera_model
The ACT plugin checks this field in the CSV to see which SketchUp file (.skp) it should it should
use to represent the camera in the drawing area. Camera SKP files are stored in the same
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cameradata folder as the cameras.csv file.
You can create your own camera models and reference them in cameras.csv as well. Just
ensure you place the .skp file in the same directory as cameras.csv.

Adding an ACT camera to the list of camera types
You can add additional camera types to the list of camera types included with ACT (found in
Tools > Advanced Camera Tools > categories > camera) by editing a CSV file on your
computer. This file is found here on Microsoft Windows:
C:\Program Files\SketchUp\SketchUp 2019\ShippedExtensions\su_advancedcameratools\
cameradata\cameras.csv
This file is found here on Apple macOS:
~/Library/Application Support/SketchUp 2019/SketchUp/Plugins/su_advancedcameratools/
cameradata/cameras.csv
To edit this file:
1. Open cameras.csv in a spreadsheet.
2. Add a row to contain the new camera's information.
ACT cameras.csv file for further information.
3. Save the cameras.csv file in the same location.
4. Reload SketchUp to verify your camera has been added.

Refer

to The

Modeling Terrain and Other Rounded Shapes
Terrain is important to many SketchUp modelers: Your building needs ground to stand on, or
maybe you’re modeling the ground itself to create a landscape.
But wait. SketchUp’s Sandbox tools — the tools you use to model terrain — can also create
forms completely unrelated to terrain. How can terrain include all these other possibilities?
The secret is in the hidden geometry. When you’re modeling terrain (or other shapes) with the
Sandbox tools, you’re technically sculpting a special type of geometry called a TIN,
or triangulated irregular network. That’s a fancy way of saying, “a group comprised of
triangles.” The following figure shows a flat TIN that hasn’t been sculpted into anything yet.
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In the next figure, you see an example of a TIN sculpted into hills and a watery valley. The
Sandbox tools are traditionally used to create this type of terrain.

Reveal the hidden lines in this bust of Beethoven, and you can see it’s also modeled from a
TIN.

In the following sections, you find out how to start modeling TINs, where to find the Sandbox
tools, and what it means to geolocate terrain. After you cover the basics, you also find pointers
to how to start sculpting a TIN.
Table of Contents
1. Getting started with TINs
2. Enabling the Sandbox tools
3. Introducing geolocated terrain
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Getting started with TINs
To create a TIN, you can import contour lines from another program or import terrain from
Google Earth via SketchUp’s built-in tools. You can also transform contour lines that you draw
yourself into a TIN, or draw a plain flat rectangular TIN like the one shown earlier in this article.
To get started, see Importing Preexisting Terrain and Creating Terrain from Scratch.
Note: You can also use the Sandbox tools to sculpt a polygon mesh, but only if you import it
into SketchUp from another program. Importing Preexisting Terrain introduces this topic and
points you to additional help with importing.
After you have a TIN in SketchUp, learn how to toggle the TIN’s visibility, sculpt and fine-tine
its features, and place other items on its surface.

Enabling the Sandbox tools
You find the Sandbox tools on the Sandbox toolbar or by selecting Tools > Sandbox and
selecting your tool of choice from the submenu. As you read through this article’s subarticles,
you find out how to use each tool for its respective task.
Tip: In SketchUp Pro, the Sandbox tools are enabled by default. In SketchUp Make, you also
have access to the Sandbox tools, but you must enable them

Introducing geolocated terrain
If you’re modeling terrain, you can geolocate it, or embed geographical coordinates that place
your terrain at a specific point on Earth. Geolocated models (or geomodels for short) offer a
number of advantages:
•

•

Study the sunlight and shadows at different times of day and on different days
of the year. Shadow studies can tell you things like whether adding a second story to
a house will turn a sunny garden patch into a shady hosta bed. You can also see how
the sunlight shines into an interior space at different times of day.
View your model in Google Earth. Google Earth comes in free and paid versions that
you download to your computer, and it’s full of aerial imagery and models. This means
you can view your model on the site where you plan to build it, surrounded by the
buildings and landscapes that are already there. If you’re modeling something for
clients, seeing a model in Google Earth is sure to impress them.

For details about shadow studies and viewing a model in Google Earth, see Communicating
Your Designs. As you model your terrain, know that you can geolocate it by importing terrain
from Google, as explained in Importing Preexisting Terrain. Also, Modeling Terrain for Google
Earth offers tips and tricks that can improve your model’s appearance in Google Earth.
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Importing Preexisting Terrain into SketchUp (and
Geolocate a Model)
Does the terrain that you want to model exist somewhere outside your imagination and in
digital form? Hurrah! You can just import it!
Well, sort of. Also, after you import terrain, you usually need to edit it. At minimum, you likely
need to clean up the imported data by reducing the number of faces to improve your model’s
performance, tracing contour lines, or a few other tasks covered in Editing and Fine-Tuning
Terrain. But for now, enough of the sour details.
This section focuses on the happy, easy part of importing terrain. In SketchUp, you can bring
terrain into your model in the following ways:
•
•

•

Grab a location from Trimble. In SketchUp Pro, this method is the easiest way to
import terrain, and the steps to do it appear later in this section. Importing terrian is
not available with SketchUp Make or my.SketchUp.
Import contour lines. If your contour lines are a raster image file, you can trace the
contour lines in SketchUp. If you can import actual geometry, you just need to turn the
contour lines into a TIN (triangulated irregular network) using the From Contours tool,
as explained in Creating Terrain from Scratch.
Tip: If your contours are a vector image or a .dwg file (which is a CAD file format that
only SketchUp Pro supports), SketchUp imports your contour lines as geometry, rather
than an image that you need to trace. For performance reasons, simplify your contours
in your image editor or CAD program as much as possible before importing the contour
lines into SketchUp.
Import a polygon mesh. A mesh comes from a CAD program such as AutoCAD. A
polygon mesh is like a TIN but contains faces with more than three vertices. That is, a
mesh can contain polygons, not just triangles like a TIN, and you can use SketchUp’s
Sandbox tools to edit the mesh.

•
For all the details on what types of files you can import into SketchUp (such as image files or
CAD files) and how to import a file with your terrain data, see Using SketchUp Data with Other
Modeling Programs or Tools. Then check out the aforementioned article about editing
terrain.For details about grabbing terrain from Trimble via SketchUp’s built-in tools, keep
reading.
In SketchUp, when you grab terrain from Trimble, you’re technically importing a geolocation
snapshot into your SketchUp file. A geolocation snapshot includes the following elements:
•

•

•

The geographic coordinates of your selected location: These coordinates aren’t
absolutely necessary for modeling terrain, but if you import this data, SketchUp can use
it to create realistic shadow studies or display your model in Google Earth.
See Communicating Your Designs for details.
Color aerial imagery: The imagery is projected as a texture onto your terrain. The
article Sticking a Photo or Texture to a Face explains how projected textures work and
includes an example of projecting a texture onto terrain. Adding Colors and Textures
with Materials explains how to edit this image.
3D terrain: This geometry is a TIN that reflects the terrain data for the area you
specify.

To import terrain from Trimble, follow these steps:
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1. Click the Add Location tool (
) on the Location toolbar or select File >
Geolocation > Add Location.
2. In the Add Location window that appears, type an address or intersection where your
desired terrain is located.
3. Click the Search button, and an aerial view of your location appears in the window. In
the figure, you see the results for the Boulder Public Library, or more specifically, its
address at 1001 Arapahoe Ave., Boulder, CO 80302.

4. (Optional) To see all the terrain that you want to import, use the zoom controls on the
left, or scroll your mouse wheel to zoom in or out.
5. Click Select Region in the upper-right. An selection box becomes highlighted in the
Add Location window. The highlighted area represents the area of terrain that you’ll
import into your model.
6. Click and drag a corner of the selection box so that the selection highlights only the
terrain you need. In the following figure, you see how the aerial view of the library looks
after zooming in and adjusting the selection box to highlight only the library building.
Tip: The edges and faces in a terrain add up pretty quickly. The more edges and faces
your model has, the more processing power SketchUp needs to render your model onscreen. When you select only the terrain you need, you don’t have unnecessary edges
and faces bogging down your model.
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7. Click the Grab button in the upper right. By default, a 2D image of the selected area
appears in your model, as shown in the following figure. However, you can toggle
between 2D and 3D and change the view to show or hide the Snapshot. Toggling Terrain
Visibility explains all your options.
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Note: After you geolocate a model by importing terrain, the north angle changes slightly. When
you export a model to a format such as .kmz, this small rotation improves the accuracy of
tracing the image as the file is converted from Cartesian coordinates to UTM or Mercator.
After you can see your geometry, you can edit it or place your model on it. Modeling Terrain
for Google Earth offers tips specific to geolocated models, if you want to view your model in
Google Earth.
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Creating Terrain from Scratch
In SketchUp, importing preexisting terrain is your easiest route to creating terrain. However,
the tools for creating terrain from scratch are useful in the following scenarios:
•
•

You have contour lines that you either imported or traced and now need to transform
into a TIN (triangulated irregular network).
Reality would only interfere with your creative vision. That is, you want to shape
the terrain yourself, starting from a fairly flat surface or you want to model something
other than terrain. This approach is a great starting point if, for example, you’re creating
a model of a golf course full of ponds, sand traps, and other obstacles or a model sprung
wholly from your imagination.

Tip: If you’re working with imported contour lines, simplify them before you create a TIN.
Table of Contents
1. Simplifying contour lines with a script
2. Creating a TIN from contour lines
3. Creating a flat rectangular TIN

Simplifying contour lines with a script
To optimize SketchUp’s performance, include the minimum number of contour lines needed to
create your TIN. Beyond erasing actual lines, you can simplify the lines themselves by reducing
the number of segments in each line. Of course, do this only if the contours’ complexity isn’t
necessary for your overall model.
Note: For a refresher on how curve and polyline entities are made of segments, see Drawing
Freehand Shapes.
If your hands feel cramped just thinking about all that mousing, you’ll be happy to know that
an extension can simplify contour lines for you. Developers create SketchUp extensions, which
are Ruby scripts designed to do special jobs. The Simplify Contours Tool script is specifically
designed to reduce the number of segments in curves and polylines so that a TIN created from
your contours has the least geometry necessary.
To install the script, follow these steps:
1.
2.
3.
4.

Select Window > Extension Warehouse.
Sign in with your Google account user name and password.
Search for Simplify Contours Tool.
Follow the on-screen instructions to download and install the extension. The Knowledge
Center’s Extension Warehouse section explains all the ins and outs of SketchUp
Extensions.

After you install the script, here’s how to make it evaluate and simplify contour line segments:
1. Select all the contour lines you want to simplify.
2. From the menu bar, select Extensions > Simplify Contours.
3. In the Simplify Angle dialog box that appears, enter the angle at which you want to
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merge two segments into one. For example, say you use the default of 10 degrees. If
any pair of segments forms an angle of less than 10 degrees, the script merges the pair
into one segment.
4. Click OK and the contours are simplified.

Creating a TIN from contour lines
After you import or draw contour lines and then simplify them, follow these steps to transform
contours into a TIN:
1. Place each contour line at the appropriate height relative to the ground plane, as shown
in the following figure. Your first contour might be on the ground plane, the second line
2 feet above the ground plane, the third line 4 feet above the ground plane, and so on.
Use the Move tool (

2. With the Select tool (

) to raise or lower each contour along the blue axis.

), select all the contour lines.

3. Click the Sandbox From Contours tool (
) on the Sandbox toolbar or select Draw
> Sandbox > From Contours on the menu bar. Either way, the contour lines instantly
become a TIN, as shown in the following figure. SketchUp automatically organizes all
the TIN geometry into a group, so you have to open the group context to edit the TIN.

Tip: Sometimes, the Sandbox From Contours tool creates flat spots or plateaus that don’t
belong in your TIN. You can retriangulate the plateaus (to create a slope) using the Flip Edge
tool. Editing and Fine-Tuning Terrain explains how to flip edges and make other common edits.

Creating a flat rectangular TIN
If you prefer to to start modeling terrain from a flat, rectangular TIN, you draw the shape with
the Sandbox From Scratch tool:
1. Select the Sandbox From Scratch tool (
) on the Sandbox toolbar, or select Draw
> Sandbox > From Scratch from the menu bar.
2. Click to set the TIN’s starting point.
3. Set the TIN’s length by moving the mouse cursor in any direction and clicking to set the
desired length. As you move the cursor, you see inferences that help you align the
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length to your desired drawing axis or in relation to existing geometry. Instead of using
the mouse, you can type a value and press Enter (Microsoft Windows)
or Return (Apple macOS) to set a precise distance in the Measurements box. If you
type only a number, SketchUp uses the units that your template specifies. But you can
also use a different unit by typing it after the value. For example, if your template is set
to inches, typing 48 sets a length of 48 inches but typing 104cm or 6’ sets a length of
104 centimeters or 6 feet, respectively.
4. Set the TIN’s width by moving the mouse cursor and clicking or typing a precise value.
In the following figure, the inference engine is indicating that the width is parallel with
the green axis, and the Measurements box, which updates dynamically as you move
the cursor, indicates that clicking at this point would set the width at 51 feet, 8 5/16
inches.

5. (Optional) Type a value in the Measurements box and press Enter (Microsoft Windows)
or Return (Apple macOS) to change the TIN’s default grid spacing from 10 feet to some
other value. In the following figure, you see the newly created TIN and the
Measurements box ready to accept a Grid Spacing value.

Tip: When you create a TIN with the Sandbox From Contours or Sandbox From Scratch tool,
the TIN geometry is contained within a group. This means you need to open the group’s context
in order to sculpt or edit your TIN. Grouping Geometry explains how SketchUp groups work,
and Editing and Fine-Tuning Terrain walks you through common edits to terrain.
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Toggling Terrain Visibility
Hiding terrain can improve SketchUp’s performance. Terrain can gobble up a noticeable chunk
of your computer’s processing power, but SketchUp doesn’t ask your processor to render
hidden geometry.
Having a way to hide the terrain is also handy when terrain obscures the bottom parts of a
model. Hide the terrain, and it’s out of your way.
You can toggle terrain between visible and hidden with SketchUp’s layers feature — after all,
controlling visibility is the whole purpose of layers. After you create or import your terrain,
make sure that all your terrain geometry is organized into a single group. Then assign that
group to a layer to control the terrain’s visibility. To learn details about groups, see Organizing
a Model and its subarticles. To understand the tricks to working with layers, see Controlling
Visibility with Layers.
Warning: SketchUp layers work differently than layers in CAD or image-editing programs. If
you’re new to SketchUp layers, read and follow the steps in Controlling Visibility with
Layers carefully so that your layers work as you expect them to.
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Sculpting and Fine-Tuning Terrain
Whether you import terrain into SketchUp or create your terrain completely from scratch, you
likely need to sculpt your terrain or make minor adjustments.
With specialized Sandbox tools, you can create berms, ponds, terraced landscapes, and so on.
The Smoove tool enables you to model hills and valleys on a TIN (triangulated irregular
network). With the Add Detail tool, you can split a selection within a TIN into smaller triangles
so that you can model detail where its needed.
If you imported contours or terrain from Google Earth, a few edges are likely creating unwanted
flat spots on your terrain. This problem is so common, SketchUp includes a tool dedicated to
fixing it: the Flip Edge tool.
Tip: Remember that terrain imported from Google Earth or created with the Sandbox From
Contours or Sandbox From Scratch tool is automatically organized into a group. If your group
is locked (it’s highlighted red when you click it), context-click the group and select Unlock. To
edit the group, double-click to open the group’s context. Organizing a Model explains the
details of working with groups.
In the following sections, you find steps and examples that walk you through the process of
sculpting or fine-tuning your TIN. When you’re done shaping your TIN, you can set other things,
like buildings or pathways, on top of the terrain, as explained in Placing Objects on Terrain.
Warning: Before you start, remember to model only functional terrain, which is terrain that
doesn’t bend back upon itself creating overhangs, underhangs, or caves. If you draw a vertical
line through your TIN at any point and the line touches the terrain at only one point, your
terrain is functional. This concept is important because you can use a tool such as Smoove to
move TIN geometry horizontally, but the result is nonfunctional terrain, or terrain that can’t be
manipulated in a known way.
Table of Contents
1. Smooving hills and valleys
2. Detailing terrain
3. Flipping edges

Smooving hills and valleys
The Smoove tool’s capabilities are as cool as its name, which is a portmanteau
of smooth and move. To sculpt your terrain with the Smoove tool, follow these steps:
1. (Optional) With the Select tool (
smoove.

), select the area of your TIN that you want to

2. Select the Smoove tool (
) from the Sandbox toolbar or select Tools > Sandbox
> Smoove from the menu bar. You see the Smoove cursor, shown in the following
figure. The red circle represents the circular area that the Smoove tool will bulge or
sink.
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3. (Optional) Type a radius for the Smoove tool operation and press Enter (Microsoft
Windows) or Return (Apple macOS). In the preceding figure, the radius is 45 feet.
4. With the Smoove tool cursor, click to set a center point for smooving. The vertices that
the Smoove tool selects light up in yellow anticipation of their elevation changes, as
shown in the following figure.

5. (Optional) Type a value to specify how far you want to offset the selection. Type a
positive value, like 10‘, to make a hill. Or use a negative value like –10’ to create
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a valley, as shown in the figure.
6.

You can repeat this process as much as you like to sculpt your terrain. For example, the
following terrain has been smooved to resemble a ski slope (or a large nose emerging from the
earth, depending on how you look at it).
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Note: As your model becomes larger and more complex, Smoove tool operations take longer
to complete. Because you don’t see a progress bar while SketchUp processes the edits, your
computer may seem hung while the operation is running. In cases like this, pressing the Esc
key doesn’t cancel the operation. You just need to be patient and allow the operation to run its
course.

Detailing terrain
Ideally, a TIN contains the fewest lines and faces necessary to create the shape of your terrain
(or whatever you decide to model with the TIN). With that in mind, the Add Detail tool splits
existing triangles into smaller ones — but only where you need them.
For example, say you wanted to add moguls to your terrain. Although the Add Detail tool isn’t
so handy at forming powerful movie producers, it’s perfect for creating small bumps on the ski
slope terrain shown in the preceding section. With the Add Detail tool, you can split a face into
several triangles so that the geometry is detailed enough to create the moguls.
Tip: Before you use the Add Detail tool, it’s helpful to see all the lines in your TIN, some of
which may be hidden. If you don’t see the triangles of your TIN, select View > Hidden
Geometry, and the hidden edges appear as dashed lines.
To add detail to your TIN, follow these steps:
1. Select the Add Detail tool (
) on the Sandbox toolbar or select Tools > Sandbox
> Add Detail from the menu bar. You see the Add Detail cursor, and inferences appear
where you can divide an edge or face.
2. Click an edge or face where you want to create a new vertex, as shown in the following
figure.
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3. When the cursor changes to up and down arrows, move the cursor up or down to adjust
the height of the vertex and the surrounding triangles, as shown in the following figure.
Or use the Measurements box to type a precise offset distance.
Note: You can hold down the Shift key to move the geometry horizontally, but the
result is nonfunctional terrain, as explained at the beginning of this article.

4. Click to set the vertex height.
Tip: To add detail to several edges and faces at once, select the edges and faces with
the Select tool (
) and then click the Add Detail tool. All the faces are evenly divided into
smaller triangles, as shown in the following figure. When you use this method, you can’t change
the height of all the vertices.

After you add enough detail, you can create more detailed features with the Smoove tool. In
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the following figure, you see the ski slope after adding the moguls, applying a color material,
smoothing and softening the geometry, and adding a 2D skier component for scale.

Flipping edges
If you see undesirable flat areas after you convert contours to a terrain, the Flip Edge tool helps
you fix the problem.
First, make sure hidden geometry is visible by selecting View > Hidden Geometry. Edges
that need to be flipped look something like the selected edge in the following figure, which is
creating a peak where the surface should be smooth.
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To fix the edge, select the Flip Edge tool (
) and click the edge with its cursor. After doing
so, you can see how the triangles form a more regular pattern in the following figure. In this
example, you may need to flip a few more edges before area is completely smooth.
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Placing Models and Objects on Your Terrain
If you like arranging furniture, blank terrain is as exciting as moving into a new home:
Everything is clean and open and ready for your stuff. Can’t wait to set the house you designed
onto its site, model a winding path through your garden, and fill the landscape with plants and
trees? You’re in the right place.
In SketchUp, two Sandbox tools help you place objects on terrain:
•
•

Stamp tool: This tool stamps a flat surface onto your terrain and creates a transition
from that flat surface to the surrounding terrain.
Drape tool: This tool enables you to transfer edges from a face onto your terrain, so
that the edges follow your terrain’s curves.

In the following sections, find out how to stamp or drape geometry onto your TIN (triangulated
irregular network).
Table of Contents
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2. Draping edges onto a TIN

Stamping a surface onto a TIN
When your 3D object is a group or component, the Stamp tool uses your object’s bottom to
create a flat pad for your 3D object. So, before you begin using the Stamp tool, turn your
object into a group or component.
Tip: For a refresher on groups, see Organizing a Model and Grouping Geometry. For the scoop
on creating components, check out Creating a Basic Component.
When you’re ready to stamp your TIN with a group or component, follow these steps:
1. Move the group or component so that it hovers above your TIN, in the position where
you want to create the stamp.
2. Click the Stamp tool (
) on the Sandbox toolbar or select Tools > Sandbox >
Stamp from the menu bar.
3. Click the group or component that you want to use as a stamp.
4. Type an offset value and press Enter (Microsoft Windows) or Return (Apple macOS).
This sets how much space you have to create a transition between your group or
component and the terrain. The value you choose depends on how you want your object
to blend in (or not) with the surrounding terrain, as well as how flat or sloped your
terrain is.
5. Click your terrain. The pad for your group or component appears, and the cursor
changes into an up and down arrow, as shown in the figure (Callout 1).
6. Move the mouse cursor up or down to set the flat pad’s height.
7. Click to finish the stamp operation. When you’re done, you can use the Move tool to set
your group or component on its flat surface, as shown on the right in the figure (Callout
2).
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Tip: After you create the flat pad but before you set your group or component on top of the
pad, you might need to flip edges, as explained in Sculpting and Fine-Tuning Terrain.
Note: The Stamp doesn’t work on a group or component whose context is open for editing.
If you’re having trouble using the Stamp tool, check whether an open group or component
context is causing the problem. Also, your stamp doesn’t need to be a group or component.
You can use a face, too. However, this section focuses on stamping with a group or component
because a 2D face is rarely used as a stamp. Most often, a 3D model that contains several
edges and faces is the stamp, and you want the flat pad to match the bottom of your 3D
model.

Draping edges onto a TIN
When you use the Drape tool, SketchUp transfers edges from a flat face onto a TIN’s curved
surface.
Tip: To create the edges that you want to transfer onto your TIN, draw a rectangular face
above your TIN. Then, draw the edges on the flat rectangle with the faces in X-Ray mode, so
that you can see the TIN underneath. You can then erase the edges and faces you don’t need,
leaving only the ones that you want to drape onto your TIN, as shown on the left in the figure
(Callout 1).
When you’re ready to drape the edges, follow these steps:
1. Select the edges you want to drape over the TIN.
2. Select the Drape tool (
) from the Sandbox toolbar or select Tools > Sandbox >
Drape.
3. Click the TIN to drape the selected edges onto the TIN, as shown on the right in the
following figure (Callout 2).
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Tip: After you drape edges onto your terrain, you can hide or delete the face that used to
create the edges initially. You can apply a material to the faces within your draped edges,
setting them off from the rest of the terrain. You can also hide the edges. For details about
adding materials, see Applying Colors, Photos, Materials, and Textures. You find steps for
hiding edges in Softening, Smoothing, and Hiding Geometry. In the following figure, you see
the slope with a slightly darker color applied to the path, and the edges around the stamped
area and the draped area are hidden.

SketchUp Help Pages – version 19.

Page 363/567

Modeling Terrain for Google Earth
If your model is geolocated with the Add Location feature and you want to display it in Google
Earth, you may need to take a few extra steps. Here’s a quick overview of the tips and tricks
that help your model looks its best in Google Earth:
•

•

•

Minimize the number of faces in your custom terrain. First and foremost, only
include the terrain that you really need. You find tips for minimizing geometry as you
create and sculpt terrain in several of the Modeling Terrain subarticles. The tips for
minimizing contour lines in Creating Terrain from Scratch are especially helpful. Also,
see Sculpting and Fine-Tuning Terrain for tips on adding detail to your TIN only where
you need it.
Adjust your model’s horizontal or vertical position relative to its terrain. You
want to make sure the roof and base align, and that the model is sitting flat on the 2D
Location Snapshot, rather than hovering in the air or sunk into the ground. For an
introduction to the 2D Location Snapshot, see Toggling Terrain Visibility.
Create custom terrain to fill gaps. If your model is placed on rolling or sloped terrain,
gaps may appear between your part of your model and the 2D Location Snapshot. To
fill these gaps, create a little custom terrain painted to match the ground.

For details about positioning your model and creating custom terrain, read the following
sections.
Table of Contents
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Positioning your model
Check that your model’s roof and base align and that it’s flat on the Location Snapshot layer.
Misalignment happens most often in tall building models. To check the alignment, follow these
steps:
1. Select Camera > Standard Views > Top.
2. Select Camera > Parallel Projection to turn off perspective.
3. See whether your model’s base sticks out unevenly from any side of the roof. In the
following example, everything looks pretty straight.
4. If you notice any issues, use the Move tool (

) to adjust your building’s placement.

Tip: For a refresher on moving geometry, see Moving Entities Around.
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To check that your model isn’t hovering in the air or sunk in the earth, but sitting right on on
the Location Snapshot, follow these steps:
1. If you see the Location Terrain layer instead of Location Snapshot, click the Toggle
Terrain tool (

), which switches back and forth between these two layers.

2. Use the Orbit tool (
) to move to a side view of your model. Or select Camera >
Standard Views and select either Front, Back, Left, or Right from the submenu.
3. Check whether your model rests on the Location Snapshot. In the following figure, the
park shelter is hovering over the Location Snapshot.
4. If you need to adjust your model’s vertical position, use the Move tool to move it up or
down. To lock the move in the blue direction as you move geometry, hold down
the Shift key or press the up arrow key.

Filling gaps with custom terrain
After you check and adjust your model’s vertical alignment, your model still might float or sink
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— or both, as shown in the following figure. That’s because Google Earth’s 3D terrain doesn’t
always match what exists in the physical world.

To hide the gaps, put a skirt on your model. To create this skirt, you don’t need to know a thing
about fashion or sewing. Just follow these steps:
1. Make sure the Location Terrain layer is enabled by clicking the Toggle Terrain tool (
).
2. Make sure your model is a group or component. If not, see Grouping
Geometry or Creating a Basic Component.
3. Sink the part of your model that belongs underground, such as a basement or an
underground garage. Everything that belongs above ground can float for now.
4. With the Line tool (
), click a bottom corner of your model, starting from the
Endpoint in Group inference.
5. Click a point on your terrain to connect your building to the terrain.
Tip: Look for the On Face in Group inference to make sure the line’s endpoint touches
the terrain.
6. On your model, click a lower edge that connects to the endpoint you clicked in Step 3.
7. Click the endpoint that you clicked in Step 3 to create a third edge. A triangular face
appears, as shown in the following figure.
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8. Continue drawing triangles until the skirt is complete, as shown in the following figure.

9. Select the Eraser tool (
).
10. Hold down the Ctrl key (Microsoft Windows) or the Option key (Apple macOS) and click
any edges that you want to soften with the Eraser cursor. (Softening, Smoothing, and
Hiding Geometry explains what softening edges is all about.)
11. Sample the texture on the existing terrain by selecting the Paint Bucket tool (
),
holding down the Alt key (Microsoft Windows) or Command key (Apple macOS), and
clicking the Google snapshot.
12. Click your terrain skirt to paint the photo texture on the new faces, so that they blend
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Customizing SketchUp
You can customize SketchUp so that it fits you like perfectly worn-in blue jeans — the pair you
wear so often you worry how you’ll ever leave the house after the inevitable hole appears in
the seat, because how you could ever leave the house without those jeans?
Or maybe you’re more the button-down-shirt-and-trousers type?
The point is that you can fashion SketchUp to reflect your specific situation:
•
•
•

Create settings that fit your general work patterns. For example, to keep your
most often used commands accessible, you might create keyboard shortcuts or
customize your toolbar display.
Tailor settings for a specific project or workflow. For example, if, every time you
create a new model, you adjust the default template to suit a client or project, you can
save those settings as a custom template.
Adjust settings to patch up computer or performance issues. SketchUp’s defaults
are set to help you recover your work, if needed, and render graphics as seamlessly as
possible. However, your computer may have its quirks, and adjusting a few settings,
like how often SketchUp auto-saves or how it renders graphics, might help SketchUp
better fit your system.

For details about designing settings for the way you or your projects work, check
out Customizing Your Workspace, Customizing Your Keyboard and Mouse, and Setting Up
Templates.
For help ironing out wrinkles in your
Preferences and Improving Performance.

system,

see Setting

Software

and

File
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Setting Software and File Preferences
In SketchUp, you can set a few preferences for how the software works overall and how files
are saved.
To access these preferences, select Window > Preferences (Windows) from the menu bar.
Most of these preferences are on the General pane, which you click in the sidebar on the left.
As shown in the following figure, your options include Saving preferences at the top and
Software Updates preferences at the bottom.
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Setting file recovery preferences
Checking models for problems
Seeing Scenes and Styles warnings
Selecting Software Updates preferences
Choosing default locations for files
Changing SketchUp’s language
Toggle Welcome Window
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Setting file recovery preferences
Here’s a quick look at the Saving options on the General preferences pane:
•

•

Create Backup: By default, this option is selected because it helps you recover your
work if anything happens as you’re creating a 3D model. When Create Backup is
enabled, SketchUp automatically creates a backup file when you save a model. The
backup file is the previously saved version of the file and lives in the same folder as the
model file. For example, if your model file is hotel.skp, on Microsoft Windows, the
backup is hotel.skb, and on Apple macOS, the backup file is hotel~.skp. On either
operating system, you find both files in the same folder.
Auto-save: This option is also enabled by default and helps you recover any changes
you make to a model if you experience computer problems. When enabled, Auto-save
tells SketchUp to automatically save changes to your model into a temporary file at
specific time interval. By default, the interval is 5 minutes, but you can make that
shorter or longer if you like. Just enter a new interval in minutes in the text box. Note
that the auto-save file is preserved only if SketchUp suddenly crashes. If SketchUp
closes successfully, the auto-save file is deleted.

•
Tip: The SketchUp team strongly recommends leaving Auto-save enabled, because it
helps you keep your work. During the auto-save, SketchUp checks your model for
unrecoverable errors so that a good auto-save file isn’t overwritten. In the rare case that
SketchUp finds unrecoverable errors in your model, a dialog box appears with the option to
quit SketchUp and send a report. Click the Quit SketchUp and Send Report button to
terminate SketchUp and preserve your valid auto-saved file. This report contains valuable
information regarding the unrecoverable errors.
Note: Want to find an auto-saved file? Recovered files will always be accessible from the
Welcome Window’s main screen. If you’re seeing a recovered file, you have the ability to open
it and re-save it to a new location. If you’ve disabled the Welcome Window you can always
access it by going to Help > Welcome to SketchUp.

Checking models for problems
The General preferences pane includes a section called Check Model for Problems, where you
find the following two options:
•

•

Automatically Check Models for Problems: This option is selected by default and
enables SketchUp to check your model before it auto-saves, as mentioned in the
preceding section. When this option is selected, SketchUp checks for problems when
your model is loaded or saved. Because SketchUp offers so much flexibility for designing
a 3D model, it’s important to check and fix major or minor issues and thus optimize
your model’s performance. Although deselecting this option isn’t recommended, if you
do so, you can check for problems manually by selecting Window > Model Info,
selecting the Statistics panel, and clicking the Fix Problems button.
Automatically Fix Problems When They Are Found: This option is deselected by
default, so that when SketchUp finds a problem, you see a dialog box that asks whether
and when you’d like to fix the problem. If you select this option, you don’t see the dialog
box, and SketchUp fixes the problem behind the scenes.
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Seeing Scenes and Styles warnings
Scenes enable you to save a view of your model, and styles impact how your model’s edges,
faces, and background look. If you edit a style and then add a new scene, SketchUp can prompt
you to decide whether you want to save your changes as a new style, update the selected
style, or do nothing, as shown in the following figure. This warning can help you manage your
style changes as you work with different scenes.

By default, the Warn of Style Change When Creating Scenes checkbox is enabled. If you
deselect the checkbox, you don’t see the warning dialog box and are not prompted about how
you’d like to manage your scenes and styles.

Selecting Software Updates preferences
On the General preferences pane, the Software Updates section has only one option, Allow
checking for updates, which is enabled by default. When enabled, SketchUp checks for
updates when you’re connected to the Internet.

Choosing default locations for files
In SketchUp, the Preferences dialog box includes a Files option in the sidebar on the left. The
Files pane enables you to set the default save locations for models, components, materials,
styles, and more.
If the folder where you want to save certain files doesn’t yet exist, create the folder using
Windows Explorer or Finder first. After the folder is ready, follow these steps in SketchUp:
1. Select Window > Preferences.
2. Select Files in the sidebar on the left.
3. In the Files pane, click the Change File Location Preference icon (
) and a Select
Folder dialog box appears.
4. Navigate to the folder that you want to designate as the default location for the related
files.
5. Click Select Folder in the Select Folder dialog box and click OK again in the SketchUp
Preferences dialog box. Going forward, the files for that option are saved in the folder
you specify.
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Tip: To quickly navigate to a default folder, click the Open This Folder icon (
location opens in Windows Explorer or Finder.

) and the

The following table outlines how each option changes your default locations.
Option

Changes the Default Location For …

Models

Opening or saving a model

Components

Opening and saving a collection via the Components browser

Materials

Opening or creating a collection via the Materials browser

Styles

Opening or creating a collection via the Styles browser

Texture images

Inserting images with the File > Insert > Image As Texture
command

Watermark
images

Images that you can use as a watermark

Export models

Models that that exported with the File > Export > 3D Model
command

Classifications

Files used to set up classification systems for the Classifier
feature

Templates

SketchUp template files you customized and saved to your hard
drive

Changing SketchUp’s language
SketchUp is currently available in English, French, Italian, German, Spanish, Japanese, Korean,
Brazilian Portuguese, Polish, Russian, Traditional Chinese, and Simplified Chinese.
You can download SketchUp in any of the preceding languages. However, SketchUp reverts to
English if your operating system’s language doesn't match the language version of SketchUp
that you installed. For example, if you’ve downloaded the French version and your operating
system is set to English, you see the English version of SketchUp.

Toggle Welcome Window at Startup
Welcome WIndow: By default, this option is selected because, coupled with the auto-save
setting, it helps you recover your work if anything happens as you're creating a 3D model.
You'll find Recovered Files in the Welcome Window as well as be able to start new files by
choosing your desired template on launch every time you open SketchUp.
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Customizing Your Workspace
You know how you like to work, and SketchUp enables you to customize the overall workspace
to reflect that.
In this article, find out what workspace preference options you have and how those options
work. Also, check out the tips and tricks for customizing your toolbars and tidying up dialog
boxes that you like to keep open. You're almost certain to find a few ways to draw more
efficiently in SketchUp.
Table of Contents
1.
2.
3.
4.
5.
6.
7.

Running SketchUp on multiple displays
Setting preferences to customize your workspace
Exporting and importing SketchUp preferences
Migrating plugins, materials, and components
Viewing and customizing toolbars
Arranging dialog boxes and trays
Changing colors of selected items and other on-screen aids

Running SketchUp on multiple displays
For most people who have a multiple-display system, it's hard to imagine ever working on a
single monitor again. If that describes you, the good news is that you might be able to run
SketchUp on a multiple-display system. The not-so-good news is that SketchUp doesn't
officially support multiple-display systems, so if you encounter issues running SketchUp on
multiple monitors, Trimble doesn't provide support for those issues.

Setting preferences to customize your workspace
In SketchUp, preferences options enable you to customize your workspace.
To access these preferences, select Window > Preferences (Microsoft Windows)
or SketchUp > Preferences (Apple macOS) from the menu bar. In the sidebar on the left,
select the preference panel that you need.
The following table outlines how you can customize the workspace and what preference panel
enables you to make a change.
Tip: SketchUp extensions, also called plug-ins, enable you to add specialized tools and features
to SketchUp. To customize your workspace with extensions or manage you extensions
preferences, log into the Extension Warehouse and use the extensions management features.
See the Extension Warehouse section of the Help Center for details.

To Do This

Open this
Preference
Panel

Good to Know

Set the default image
editor.

Applications

Determines what image editor opens when you
want to edit a texture in an external editor.
Click Choose and select an application on your
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Open this
Preference
Panel

Good to Know

operating system.
Display crosshairs on
your cursor that
correspond to axes
colors.

Drawing

Select the Display Crosshairs checkbox in the
Miscellaneous area.

Activate the Paint Bucket
tool after you click a
material swatch (Apple
macOS only).

Drawing

This checkbox is enabled by default.
Deselect Auto-activate Paint Tool to disable
it.

Drawing

Pre-pick is enabled by default so that you can
select a face, orbit, and push/pull the face even
when the selected face doesn't appear in the
current view. Select Disable Pre-pick on
Push/Pull Tool to disable the feature.

Compatibility

This feature is disabled by default. Select
the Bounding Box Only checkbox, and a
component's edges appear in a different color
from the component box when you select the
component.

Extensions

After you download an extension, select its
check box and click Install Extension. See
the Help Center's Extension Warehouse section
for details about extensions.

Workspace

The large buttons are enabled by default
because they're easier to see and use. For
smaller buttons and a larger drawing area,
deselect the Use Large Tool
Buttons checkbox.

Select whether windows
cascade and the default
window size (Apple
macOS only).

Workspace

On a Mac, windows cascade by default.
Deselect Cascade Main Windows to turn off
cascading. Click the Save Current Window
Size button to make the size of the active
window your default window size in SketchUp.

See the toolbars and
panel trays after closing
them.

Workspace

Click the Reset Workspace button and your
toolbars and panels instantly reappear in the
most recent docked position .

Toggle the Push/Pull
tool's pre-pick feature.

Display a component
bounding box and its
edges in different colors.
Enable SketchUp
extensions that you
download from the
Extension Warehouse.

Change the size of the
toolbar buttons.

Exporting and importing your SketchUp preferences
When you make changes to your preferences, SketchUp saves your preferences automatically.
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If you work on your 3D models on two different computers or are upgrading from one computer
to another, you can export your preferences from one copy of SketchUp and import them into
another. This section explains how to export and import preferences for your current operating
system.
Note: On Windows the only preferences which can be exported are the File Location &
Shortcuts settings, on the Mac the only settings which are backed up are the Shortcuts settings.
To export your preferences in Microsoft Windows, follow these steps:
1.
2.
3.
4.

Select Window > Preferences.
Select Files in the sidebar on the left.
Click the Export button. The Export Preferences dialog box appears.
Navigate to the folder where you want to save the preferences file. The file is
called Preferences.dat by default but you can rename it if you like.
5. (Optional) By default, your keyboard shortcuts and file locations are both exported in
the same file. If you don't want to export either of these, click the Options button to
open the Export Preferences Options dialog box. Deselect the Shortcuts or File
Locations checkboxes and click OK when you're done.
6. In the Export Preferences dialog box, click the Export button, and the preferences file
is saved to the location you specified. You can now save the file to your new or other
computer and import your preferences into another copy of SketchUp.
When you're ready to import your preferences into SketchUp on another computer, follow these
steps:
1.
2.
3.
4.

Select Window > Preferences.
Select Files in the sidebar on the left.
Click the Import button.
Navigate to the location on your computer where you saved the exported preferences
file and select the file.
5. (Optional) Click the Options button and, in the Import Preferences Options dialog box,
deselect the Shortcuts or File Locations checkbox if you don't want to import
keyboard shortcuts or file locations. Click OK when you're done.
6. Click the Import button, and your preferences are imported into SketchUp.

Migrating plugins, materials, and components
SketchUp 2014 introduced options for Ruby scripting which may have affected your favorite
plugin. If you're upgrading to a newer version of SketchUp from SketchUp 2013 or older please
read our article on SketchUp Plugin Compatibility before you start installing or transferring
plugins.
Migrating Materials and Components
1. If you're migrating from SketchUp 8 and older: Navigate to the root folder in SketchUp
8 and older. This is typically,
C:\Program Files\Google\Google SketchUp #\Materials (or Components)
If you're migrating from SketchUp 2013, 2014, 2015, or 2016: Navigate to the root
folder in that version of SketchUp. This is typically,
C:\Program Files\SketchUp\SketchUp 201#\Materials (or Components) where # is the
most recent version of SketchUp installed.
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If you're migrating from SketchUp 2017: Navigate to the roaming folder for that
version of SketchUp. This is,
C:\Users\username\App Data\Roaming\SketchUp\SketchUp #\Materials (or
Components) where # is the most recent version of SketchUp installed.
Select the files in the Materials folder and press Ctrl+C to copy the items.
Navigate to C:\Users\username\App Data\Roaming\SketchUp\SketchUp #\Materials
(or Components).
Press Ctrl+V on your keyboard to paste the files. On Windows 7, you'll be asked if you
want to Merge the folders and "Confirm Folder Replace." Click Yes to the warnings.
You'll then be prompted with each subsequent material file to either Copy and
Replace or Don't Copy. We recommend you select Don't Copy so you can retain the
new content with the same file name. Any new content files that you created, however,
will be copied without any problem. You can also select the "Do this for the next ###
conflicts" so you don't have to approve each file.
Open your most current copy of SketchUp, and your new materials should be in the
Materials dialog box, and/or your new components will be in the Components dialog
box.

Migrating Plugins
We've been investing heavily in extensions because we know that the power of SketchUp shines
when customers install the right extensions to solve their needs. That's why we've built
the Extension Warehouse, worked carefully with developers so they can get their plugin in the
Extension Warehouse, and addressed long standing requests like updating the Ruby
environment to version 2.0 (which is why some plugins may be breaking at the moment - we
made the change that developers have been asking for!). The problem is that the current way
of managing extensions, plus the updated Ruby version, doesn't support the old way of
managing plugins very well. This makes migrating plugins to SketchUp 2014 and newer a bit
tricky. We also don't have all the possible plugins in the Extension Warehouse. We feel that
finding and managing SketchUp Extensions is getting better and brighter all the time, but we're
not at our ideal yet.
For some customers, they will need to go through their old plugin list, plugin by plugin, search
for that plugin in the Extension Warehouse, install the plugin, and move on to the next.
Once your plugins are managed by the Extension Warehouse, it will be significantly easier to
re-install these extensions when newer versions of SketchUp are released in the future, or if
you get a new computer and have to install a fresh copy of SketchUp. If you've installed plugins
from the Extension Warehouse in an older version of SketchUp and you need to install the
same plugin in a newer version of SketchUp, we added an Install All button in the Extension
Warehouse. The Install All feature will install your old plugins into an upgraded copy of
SketchUp in one click, but only if those plugins have been updated to support new versions,
which most of them have. Only after you've tried installing plugins from the Extension
Warehouse, or downloading an updated version of plugins that you've paid for from those
plugin developers, do we suggest attempting to copy and paste plugins between folders:
If you have a plugin that utilized a custom installer (i.e. you double-clicked on a file that
installed the plugin), you need to contact the plugin developer for specific instructions on
updating to support SketchUp 2014 or newer. These instructions are intended for users who
copy and pasted .RB, .RBS, or .RBZ files into the SketchUp plugins folder:
1. Open a new Windows Explorer window.
2. Navigate to the root folder for the older version of SketchUp. See the file locations for
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different versions of SketchUp in the preceding Materials and Components section.
3. Select the files in the Plugins folder and press Ctrl+C to copy the items.
4. Navigate to C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp #\Plugins.
Note: If the "Plugins" folder doesn't exist you'll need to create a New folder and name
it "Plugins" to proceed.
5. Press Ctrl+V on your keyboard to paste the files.
6. Open SketchUp and access the plugins as you have in the past. Note that there may be
some older plugins that are not compatible with your current version of SketchUp. In
this case, please contact the plugin developer for additional assistance.
Note: Not all SketchUp plugins are compatible with the current version of SketchUp. Please
contact the plugin developer if you need additional assistance.

Viewing and customizing toolbars
Depending on what you model in SketchUp or where you are in the 3D modeling process, you're
likely to favor some tools over others. In SketchUp, you can decide which toolbars you want to
see. Toolbars are organized differently on Microsoft Windows and Apple macOS. In this section,
you discover the options for customizing SketchUp toolbars for your current operating system.
On Microsoft Windows, you can change which toolbars appear in your SketchUp workspace by
selecting View > Toolbars. In the Toolbars dialog box that appears, select the checkbox next
to any toolbar you want to see, or deselect the checkbox for any toolbar you don't want to see.
Then click the Close button.
The following table introduces each toolbar and when the toolbar is most useful.
Toolbar Name

Toolbar

This Toolbar Is
Handy When …

Advanced
Camera Tools

Modeling movie sets
with the ACT tools

Camera

Looking at your model
from many different
angles

Classifier

Modeling with BIM
(Building Information
Modeling) and IFC
data.

Construction

Modeling precisely

Drawing

Drawing a 3D model

Dynamic

Developing dynamic
components

Components
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This Toolbar Is
Handy When …

Edit

Editing an existing
model

Getting Started

Learning to draw in
SketchUp

Google

Tools for accessing
images, geolocation
data, or terrain

Large Tool Set

Displays the Principal, Drawing, Edit,
Construction, and Camera toolbars as well as
the Section tool in a long narrow toolbar that
docks to the left side of the drawing area.

You need an allpurpose toolbar.

Layers

Organizing groups or
components into
layers to control
visibility, especially
after you have
experience working
with SketchUp's layers
feature.

Location

Accessing maps for
images, geolocation
data, or terrain

Principal

You need only a basic
tool set and want to
maximize the drawing
area

Sandbox

Modeling TINs to
create terrain or
rounded objects

Section

Adding section planes
that create a view
inside your model
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This Toolbar Is
Handy When …

Shadows

Adjusting shadow
settings or studying
shadows at different
times of day

Solid Tools

Modeling complex
shapes with the Solid
tools

Standard

Accessing basic file
and clipboard
commands from a
toolbar would be
helpful

Styles

Switching among
SketchUp's face styles
frequently, such as
when tracing a floor
plan in X-Ray view and
then checking your
geometry in Shaded
with Textures view

Views

Switching among the
standard views, such
as Top, Front, Iso, and
so on

Warehouse

Sharing models via the
3D Warehouse or
adding extensions via
the Extension
Warehouse

Arranging dialog boxes and trays
In SketchUp, dialog boxes are maintained in a tray. You can customize the tray in terms of
which dialog boxes are expanded or collapsed, as well as which dialog boxes are in a given
tray, and the location of the tray on your screen. The default tray has many of the most
commonly used dialog boxes.
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As you create your 3D models, try the following techniques for arranging dialog boxes in a
tray:
•

•
•

•

Expand or Open them: Click the dialog box’s title bar to expand or open the dialog
box so you can see the contents. If enough dialog boxes are opened so that they go
below the SketchUp window, move your mouse cursor over the tray and scroll your
mouse.
Collapse or Close them: Click a dialog box’s title bar to collapse the dialog box, so
that you see only the title bar. Click a collapsed dialog box to open it again.
Add/Remove them: Select Window > Manage Trays… to open the tray manager.
Select the tray you want to modify in the left pane, then add a checkmark to dialog
boxes you want to see in the tray, and remove the checkmark next to dialog box names
that you want to remove from the tray.
Shuffle or Move them: Drag a dialog box’s title bar up or down through the tray to
change the order of the dialog boxes. You can do this if the dialog box is expanded or
collapsed, though it’s a bit easier to see what you’re doing if you shuffle the dialog boxes
when they’re collapsed. To move a dialog box between trays, drag the dialog box to the
destination tray tab at the bottom of the tray window where you would like to move the
dialog box.
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Tip: You can assign keyboard shortcuts to trays including which dialog boxes to open, toggling
the visibility of a tray, and open Manage Trays... or New Tray... dialogs.
Managing Trays
When you first install SketchUp, a default tray will be created for you and it will contain the
most commonly used dialog boxes. Over time, you may want to create new trays that contain
only the dialog boxes you want. To create a new tray, simply select Window > New
Tray... This will open the New Tray manager. Give a name to the tray – don’t worry, you can
change this name later if you’d like – and select which dialog boxes you want to add to the
tray. To toggle between the trays, click the tray name in the tabs listed at the bottom of the
tray area.
Note: You can hide any tray as well as delete any tray – but note the difference. Hiding a tray
removes the tray from the drawing window. You can do this clicking on the close button in the
top right corner of the tray (the red square with the white X) or by clicking Window > [Tray
Name] > Hide Tray. To show the tray again, select Window > [Tray Name] > Show Tray.
If you want to delete a tray, select Window > [Tray Name] > Delete Tray. You can’t delete
the Default tray, however.
What’s great about the tray system is that if you would like to have a clean drawing space with
no dialog boxes, select the pin icon in the top right corner of the tray. This puts the tray in
Auto Hide mode. Move your mouse to the drawing area and the tray will disappear. To unhide
the tray, move your mouse to the right side of the drawing window and over the tab with the
tray name. If you created additional trays, those trays will also appear as a tab.
Tip: You can move trays, too! Simply select the top bar of the tray – where the tray name is
located – and drag the tray to the top, bottom, left, or right side of the drawing window. You
can even drop the tray anywhere on your screen to make it a “floating” tray. The tray can’t be
moved while in Auto Hide mode, however.
Tip: You can change the tray width by dragging the side edge of the tray left or right. Likewise,
if the tray is floating (i.e. not docked), you can also drag the lower edge up or down – ideal for
smaller trays as it can remove empty white space.
Understanding Tray States
Tray States isn't a nickname for States in the US that resemble a cafeteria tray (sorry
Colorado). "States" in this case refers to the ways that trays can be positioned on your
computer screen when using SketchUp. The three tray states are Pinned, Auto Hide, and
Floating. This section will also cover how to dock, undock, and organize trays.
•

•
•

Pinned: This is the default state when you first create a new tray. Pinned trays are
stuck to the side of the window and always visible – and you can have multiple pinned
trays. If you create a new tray, it will pin itself to the side of your window and you will
have two tabs at the bottom of the window. Click the X on a tray to hide that tray. Click
the thumb tack icon to unpin and re-pin trays.
Auto Hide: Trays will hide and show when you move your cursor over the tray name
on the side of your screen. To auto hide a tray, click the thumb tack icon.
Floating: A floating tray will sit wherever you put it on the screen. If you have multiple
pinned trays (i.e. you see tabs at the bottom), they will all stay in the floating tray.
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Docking, undocking, and organizing trays
To make a tray float, grab the tray header and drag it off the side of the screen. To doc a
floating tray grab the header and place it on one of the tray icons that appear. If you are
docking a floating tray over a pinned tray note that you can doc it to the side or add it as a tab
by dropping it over the center icon showing the tray tabs.

Changing colors of selected items and other on-screen aids
You can customize the colors of selected, locked, and other on-screen aids. Perhaps you have
trouble seeing a particular color, or your model's materials closely match a specific color onscreen.
Here's a quick list of the on-screen aids whose color you can customize:
•
•
•
•
•
•
•

Selected item
Locked geometry
Guides
Inactive section planes
Active section plane
Section cuts
Section fills

To customize the colors of these items, follow these steps:
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1. Open the Styles dialog box in the Default Tray.
2. Click the Edit tab.
3. Click the Modeling Settings icon (
), and you see color swatches for the items you
can customize, as shown in the following figure.
4. Click the color swatch for the item you want to customize.
5. In the Choose Color dialog box, select a new color and click OK. For details about
selecting colors, see Mixing Colors in the Color Picker. Your model reflects the new color
immediately.

Tip: On the Modeling pane, you can toggle the visibility of items by selecting or deselecting the
checkboxes in the middle of the pane. For example, to hide all the guides in your model, you
can deselect the Guides checkbox.
See Matching a Photo to a Model (or a Model to a Photo) for details about the Match Photo
settings.
For people who experience color blindness, SketchUp has the following options:
•

A Color Blind style changes the colors of on-screen elements so that the drawing axes,
inferences, and other color-based visual cues stand out for people who have some
degree of color blindness. You find the Color Blind style in the Color Sets group of
predefined styles. See Choosing a Style for details about applying predefined styles.
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Tip: To improve visibility based on your needs, you can customize the Color Blind style
and save it to your computer. As you customize the style, remember that your goal is
to see when lines change from white to another shade. With this goal in mind, we
recommend you start by adjusting the following settings as needed: edge color, front
and back face colors, background and sky colors, and highlight color. For details about
customizing and saving a style, see Creating and Editing a Style.
•

An Accessibility Preferences pane enables you to change axis and some inference
colors so that these visual cues are even easier to see — especially with the Color Blind
style applied.

For example, in the 3D model of a cube shown in the following figure, the right-hand face and
its edges are selected, and the drawing area has been customized as follows:
•
•
•
•

The
The
The
The

default Color Blind style is applied.
red axis has been changed to yellow.
green axis is a light gray.
blue axis is a lighter shade of blue to help it stand out from the dark background.

Tip: If you set up more than one scene of your 3D model, you can apply different styles in
each scene. With different scenes, you can toggle between two different styles, such as a scene
for working with your preferred color settings and a scene for sharing with other color settings.
For help creating scenes, see Creating Scenes.

To change axis and inference colors, follow these steps:
1. Select Window > Preferences. The SketchUp Preferences dialog box appears.
2. In the sidebar on the left, click Accessibility to see the pane shown in the following
figure.
3. Click a color swatch for any option to open a Choose Color dialog box. You can use the
color picker to choose a color and the slider to adjust the saturation of the color.
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4. When you're done customizing the colors, click OK.

Note: To reset the axis and inference colors to their defaults, click the Reset All button.
Tip: After you customize the Color Blind style and set your desired Accessibility preferences,
you can save your selections as a template and set that template as the default template for
your SketchUp models. See Setting Up Templates for details.
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Customizing Your Keyboard and Mouse
Drawing 3D models in SketchUp requires a lot of back and forth between your keyboard and
mouse. As you become a more experienced SketchUp modeler, you develop a sense of what
commands and tools you use most often and what you do and don’t like about the default
keyboard and mouse settings.
Tip: Keyboard shortcuts are one of the most flexible ways you can tailor SketchUp to your
unique modeling quirks and desires. If you’ve ever wished you could open a specific feature
with a single keystroke, get ready to fall in love with the Shortcuts preferences panel. It’ll be
one of the easiest relationships you’ve ever had.
Because SketchUp relies so heavily on mouse and keystroke combinations already, the mouse
customizations aren’t quite as flexible as the keyboard shortcuts. However, you can change the
scroll wheel zooming and the way the mouse and Line tool interact. The following sections
explain all the details.
Table of Contents
1.
2.
3.
4.
5.

Creating keyboard shortcuts
Inverting the scroll wheel
Remapping mouse buttons
Choosing mouse-clicking preferences for the Line tool

Creating keyboard shortcuts
In SketchUp, you can assign keyboard shortcuts to the commands you use most often, so that
the commands are literally at your fingertips.
For the most part, you can customize the keyboard shortcuts however you like, but here are a
few guidelines to help you understand what you can and can’t do as you assign shortcuts:
•
•
•
•

You can’t start with a number because that would conflict with the functionality of
SketchUp’s Measurements box, and you can’t use a few other reserved commands.
You can add modifier keys, such as the Shift key.
You can’t use shortcuts that your operating system has reserved. If a shortcut
is unavailable, SketchUp lets you know.
You can reassign a keyboard shortcut that already exists in SketchUp. For example,
by default, the O key is the shortcut for the Orbit tool, but you can reassign the O key
to the Open command if you like.

To create your own keyboard shortcuts, follow these steps:
1. Select Window > Preferences.
2. In the Preferences dialog box that appears, select Shortcuts in the sidebar on the left.
3. In the Function list box, select the command to which you want assign a keyboard
shortcut. If your selection already has a keyboard shortcut assigned to it, that shortcut
appears in the Assigned box.
Tip: When you type all or part of a command’s name in the Filter text box, the Function
list box options are filtered to only those options that include the characters you type.
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For example, typing mater filters the list down to three commands related to materials,
as shown in the following figure.
4. In the Add Shortcut text box, type the keyboard shortcut that you want to assign to the
command and click the + button. The shortcut you type moves to the Assigned box. If
the shortcut you chose is already assigned to another command, SketchUp asks whether
you want to reassign the shortcut to the command you selected in Step 3.
5. Repeat Steps 3 and 4 until you’ve created all your desired shortcuts. When you’re done,
click OK.
Tip: If a shortcut is getting in your way, you can remove it. Simply select the command with
the offending shortcut in the Function list box. Then select its shortcut in the Assigned box and
click the minus sign button. The shortcut vanishes from the Assigned box — nay, from your
copy of SketchUp.
If you ever want to reset all your keyboard shortcuts to the defaults, click the Reset All button
on the Shortcuts preference panel. If you want to load your keyboard shortcuts onto another
copy of SketchUp, find out how to export and import preferences in Customizing Your
Workspace

Inverting the scroll wheel
If you use SketchUp with a scroll wheel mouse — which makes drawing in SketchUp much
easier, by the way — by default, you roll the scroll wheel up to zoom in and roll down to zoom
out.
On Microsoft Windows, you can flip this behavior by following these steps:
1.
2.
3.
4.

Select Window > Preferences.
In the sidebar on the left, select Compatibility.
In the Mouse Wheel Style area, select the Invert checkbox.
Click OK and take your inverted scroll wheel for a test drive.

Remapping mouse buttons
Remapping your mouse buttons refers to customizing the way the buttons work. If you’ve used
your operating system preferences to flip the right and left mouse buttons because you’re lefthanded, your remapped mouse should work fine in SketchUp.
However, if you’ve used a special utility to assign commands to your mouse buttons, you may
experience unpredictable behavior or lose functionality in SketchUp.
Warning: Because SketchUp makes extensive use of the mouse buttons in combination with
various modifier keys (Ctrl, Alt, Shift), you can easily lose functionality by remapping the mouse
buttons.

Choosing mouse-clicking preferences for the Line tool
If you want to customize how the Line tool cursor responds to your clicks, you find a few options
on the Drawing preferences panel. Here’s a quick look how you can customize the Line tool’s
behavior:
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Click-Drag-Release radio button: Select this option if you want the Line tool to draw
a line only if you click and hold the mouse button to define the line’s start point, drag
to extend the line, and release the mouse to set the line’s end point.
Auto Detect radio button: When this option is selected (it’s the default), you can
either click-drag-release or click-move-click as necessary.
Click-Move-Click radio button: Force the Line tool to draw by clicking to define the
line’s start point, moving the mouse to extend the line, and clicking again to establish
the line’s end point.
Continue Line Drawing check box: When either Auto Detect or Click-Move-Click is
selected, you can choose whether to select or deselect this checkbox. (It’s selected by
default.) When the checkbox is selected, the Line tool treats an end point as the start
of a new line, saving you the extra click required set a new start point. If that behavior
isn’t your cup of tea, deselect the checkbox. Then go enjoy a cup of tea, knowing that
the Line tool now works the way you always wanted.
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Setting Up Templates
Your model’s template determines your model’s default settings. SketchUp includes several
templates for common applications, like architecture, construction, urban planning, landscape
architecture, woodworking, interior and production design, and 3D printing.
Your template determines a model’s default units of measurement. In each of SketchUp’s
included templates, the default units reflect each template’s application. For example, 3D
printing and woodworking require a high degree of precision, so the 3D printing and
woodworking template units are either millimeters or inches. However, if you’re designing a
building or a landscape, working in millimeters or inches would be annoying and impractical.
That’s why those templates default to feet and inches or meters.
If the default templates aren’t quite to your liking, you can add your own custom touches and
save them as a custom template file. Here’s a quick look at the types of things you can save
to a template:
•
•
•
•

All the settings in the Model Info dialog box: This dialog box sets the defaults for
your model as a whole. You will find a quick introduction to this dialog box at the end
of this section.
Geometry you’ve created in the drawing area: For example, some templates
include a 2D person standing at the axis origin. When you save geometry to a template,
any new model based on the template includes the geometry you saved.
Styles: In the Styles browser, you find bundled sets of styles or you can edit the face,
edge, background, and watermark individually. See Choosing a Style for details.
Shadows: Shadows are often a finishing touch on a model, but you can also use them
to explore shadow behavior or simply enhance the contours of an object.
See Communicating Your Designs for details. Keep in mind, however, that because
shadows require extra memory, so they’re typically not turned on by default. This keeps
your model light, as explained in Improving Performance

Table of Contents
1. Changing your default template
2. Creating a template
3. Exploring the Model Info dialog box

Changing your default template
You selected a default template when you first started SketchUp (as explained in Getting
Started in SketchUp). If you ever want to change the default template, just follow these steps:
1. Select Window
>
Preferences (Microsoft
Windows)
or SketchUp
>
Preferences (Apple macOS).
2. In the sidebar on the left, select the Template option.
3. Select one of the templates in the Drawing Template list box. Or click
the Browse button to navigate to a template that you’ve saved locally, select the
template file, and click Open.
4. Click OK (Microsoft Windows) or simply close the dialog box (Apple macOS). The next
time you create a new model file, SketchUp uses your new default template.
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Note: You can also choose your desired template every time you launch SketchUp using the
Welcome Window. To learn more about this new feature, be sure to check out "Selecting a
template" in our Getting Started article.

Creating a template
If you’re always making the same change or set of changes when you create a new model, you
can save all those changes to a new template so that you can start creating your model right
away.
To create a new template, follow these steps:
1. Create a new SketchUp file with your current default template.
2. Make only the modifications that you want to save with the template. Templates include
all the settings in the Model Info dialog box, Style settings, and Shadow settings. You
can also create any base geometry. For an overview of the Model Info dialog box, see
the next section.
3. Select File > Save As Template.
4. Navigate to the location where you want to save your template.
5. Give the template a name.
6. Click the Save button.
After you save the template, you need to follow the steps in the preceding section to make the
modified template your default template.
Note: Technically, you can overwrite the existing template with your changes by saving the
template under its installed filename in SketchUp’s installed Templates folder. However, you’ll
like need to make changes in your operating system first. On Microsoft Windows, you need
permission to save files to SketchUp’s Template’s folder, which you find at the following
location: . On Apple macOS, you need to make your Library files visible in order to see them,
and your templates are saved in this location: ~/Library/Application Support/SketchUp
201#/SketchUp, where # reflects your SketchUp version number.

Exploring the Model Info dialog box
The Model Info dialog box is where you apply settings for your entire model, so it makes sense
that templates reflect all the settings you make here. To open the Model Info dialog box, shown
in the following figure, select Window > Model Info. To access the different types of settings,
select an option from the sidebar on the left.
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The following list introduces each of the options in the sidebar:
•
•
•

•

•
•
•

•
•
•
•

Animation: If you animate scenes, as explained in Communicating Your Designs, the
settings here set the timing for the transitions and delay between scenes.
Classifications: If you use BIM (building information modeling) and classification data,
as explained in Classifying Objects, you can import classification systems via this panel.
Components: Set preferences for how components and groups appear when you’re
editing inside the component or group context. You can also toggle the visibility of
component axes. See Grouping Geometry and Developing Components and Dynamic
Components for details.
Credits: You can view who created a model or click Claim Credit to add the name of
the SketchUp license owner to the model. If your model contains components, see who
created the components, too. This feature is handy if you’re collaborating with a team
to create a model, or if you upload or download models and components via the 3D
Warehouse.
Dimensions: Set the defaults for dimension text. See Adding Text to a Model.
File: See basic data about the model file.
Geo-location: Check whether your model is geolocated. If not, you can add a location
via Google. SketchUp Pro users can also enter geographic coordinates manually.
See Modeling Terrain and Other Rounded Shapes for an introduction to geolocated
models.
Rendering: You find a setting here for anti-aliased textures, which improves
performance. See Improving Performance for more about customizing SketchUp to
manage performance issues.
Statistics: This pane keeps track of all the entities your model contains. You find tools
for purging unused entities and fixing problems, too.
Text: Set defaults for screen text and leader text, as explained in Adding Text to a
Model.
Units: Choose the default unit of measurement for your model. Start with the options
in the Format drop-down list: Architectural, Decimal, Engineering, or Fractional. If you
choose Decimal, you can also choose whether your model uses inches, feet, millimeters,
centimeters, or meters as the default unit.
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Improving Performance
Like all SketchUp users, you want SketchUp to be fast.
Whatever your experience level or modeling style, the way you model impacts SketchUp’s
performance, and this article explains how to create 3D models in ways that optimize
performance.
Behind the scenes, you can check how your computer stacks up against SketchUp’s
requirements. And tucked into SketchUp’s preferences, you find a few settings that might also
boost performance.
Table of Contents
1. Optimizing your modeling techniques
2. Checking your computer
3. Setting OpenGL and anti-aliasing preferences

Optimizing your modeling techniques
Every time you orbit, pan, zoom, draw, or edit, SketchUp is rendering what you see in the
drawing area. The more edges, faces, styles, materials, and so on, the more stuff SketchUp
has to render as you work on your model. Minimizing the stuff (or keeping your model light)
can be like transforming stone into cloud — metaphorically speaking, of course: What once
took lots of effort to sculpt or move becomes easy to model because it renders quickly. (Stone
materials in your building or landscape won’t evaporate and wander lonely as a cloud that floats
on high o’er vales and hills — unless you follow the last tip and purge unused materials.)
Follow these tips to keep your model light and optimize SketchUp’s performance:
•

Stick to simple styles. Whenever possible, turn off shadows, textures, and special
display effects while modeling.
Tip: Create two separate styles: one for modeling (which is fast) and another for
presentation (which can be slower). SketchUp 2015 includes Fast Styles that are
designed for this purpose.

•

•

•
•

Components are your friends. When you use the same entity multiple times (for
example, a window or a tree), make it a component, and then use copies of the
component. Multiple instances of a component are lighter weight than multiple copies
of an entity or group.
Hide geometry you don’t currently need. The more geometry that is visible in a
model, the more slowly SketchUp runs. To improve performance, the best way to hide
geometry is by controlling its visibility with layers. For example, you could group
images, landscaping items like trees and shrubs, furniture, or cars onto separate layers
and toggle their visibility on and off.
Choose JPEGs over TIFFs. If you import images into your model, use JPEG images
rather than TIFF images. TIFF images tend to have large file sizes and take more
computing resources to display.
Disable fog and shadows. Fog and shadows give SketchUp more work to do, and
typically aren’t necessary if you’re still drawing or editing your model. If your model has
shadows enabled, select View > Shadows to deselect the Shadows menu item. To turn
off fog, select View > Fog to deselect the Fog menu item.
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Purge data that you don’t need anymore. Your model stores components, styles,
and materials that you’ve added to your model even if you’ve since erased or replaced
them. SketchUp squirrels away these elements in case you need them later, but if you
know that you don’t, tell SketchUp to let it all go. For details about purging unused
items from the Styles browser, Materials browser, or Components browser,
see Managing In Model Styles and Collections, Adding Colors and Textures with
Materials, and Adding Premade Components and Dynamic Components. Or, to purge all
your unused items at once, select Window > Model Info, select Statistics in the
sidebar on the left, and click the Purge Unused button.

For a much more in-depth look at techniques that keep your model light, check out this onehour video about modeling smart. The video was created at SketchUp 3D Basecamp in 2008,
but the basic concepts from the presentation still apply.

Checking your computer
Your computer’s RAM, processor speed, and graphics card all affect SketchUp’s performance.
If SketchUp is noticeably sluggish, make sure your computer meets or exceeds the minimum
requirements for your version of SketchUp. For details, see SketchUp Hardware and Software
Requirements.
Also, keep your computer updated with the latest version of SketchUp. When you stay current
with updates, SketchUp has a better chance of running more efficiently. The same is often true
for your operating system and your graphics card driver. To check for SketchUp software
updates, select Help > Check for Update (Microsoft Windows) or SketchUp > Check Web
for Update (Apple macOS). See How can I update my computer's graphics driver? and your
system documentation for details about updating your operating system and graphics card
driver.

Setting OpenGL and anti-aliasing preferences
OpenGL stands for Open Graphics Library, and it’s the API (application programming interface,
which is like an application’s building blocks) used to render SketchUp’s 3D graphics.
Anti-aliasing is a technique for making jagged edges on graphics look smoother.
Now that you know what OpenGL and anti-aliasing are, you have an idea of what the OpenGL
and anti-aliasing preferences do. If SketchUp has performance issues on your computer,
adjusting a few OpenGL settings may help SketchUp render your model faster.
To access the OpenGL preferences, select Window > Preferences (Microsoft Windows)
or SketchUp > Preferences (Apple macOS). Then select the OpenGL option in the sidebar
on the left. The following list outlines the settings you find and what each one does:
•

•

Multisample Anti-Aliasing: Multisample anti-aliasing (MSAA) can produce a highquality image. The higher the setting, the less jagged the lines but the more computer
power required to display the image. If you need a high-quality rendering of your model,
choose a value greater than 0x from this drop-down menu.
Use Maximum Texture Size: By default, this setting is deselected, because using
maximum texture sizes slows down SketchUp. (Textures are images applied to your
model.) Specifically, when this checkbox is deselected, SketchUp won't render graphics
at a resolution higher than 1024 x 1024. You might select this option to see an image
at a resolution higher than 1024 x 1024. However, if you have enabled this option and
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SketchUp seems slow, deselect this checkbox.
Use Fast Feedback: Fast feedback improves SketchUp’s performance, especially if
you’re working on a large model. When you start SketchUp, it checks whether your
graphics card supports fast feedback combined with multi-sample anti-aliasing. If so,
this option is selected by default. If this option is unselected and disabled, you may be
able to enable it by choosing a different multi-sample anti-aliasing setting.

In the Model Info window, you can toggle the anti-aliasing of textures on or off.
(Select Window > Model Info and select the Rendering option in the sidebar on the left.)
By default, the Use Anti-Aliased Textures checkbox is selected, because this feature
improves SketchUp’s performance and textures’ appearance. If you see blurry textures or
unusual display effects, deselecting this checkbox may improve your model’s appearance.
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Developing Tools with the SketchUp Ruby API and
Console
SketchUp contains a Ruby application programming interface (API) for users who are familiar
with (or want to learn) Ruby scripting and want to extend the functionality of SketchUp. With
the API, you can create tools, menu items, and other plugins, such as automated component
generators, to be included in the menus within SketchUp. In addition to the API, SketchUp also
includes a Ruby console, which is an environment where you can experiment with Ruby
commands or methods.
For additional information on the Ruby programming language, visit www.rubycentral.com.
To learn more about the SketchUp Ruby API, visit our Ruby API Code Site. This site contains
an FAQ, tutorials, documentation, and the SketchUp Developers Forum.
Currently, we do not offer technical support for the Ruby Application Programmers Interface
(API) or for any Ruby plugins created by third parties. We encourage posting Ruby API
questions to our SketchUp Developers Forum. General Ruby information may be obtained
at http://www.ruby-lang.org.
We reserve the right to change this policy at any time.
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Communicating Your Designs
After you create a 3D model, you likely need to share your design with others. SketchUp’s tools
for sharing and communicating how your designs look are as versatile as a Ginsu kitchen knife
set.
Just like the Ginsu, SketchUp’s section planes enable you to slice your model quickly and easily,
so you can share a cross-section of your model.
But wait! There’s more!
In SketchUp, you can also
•
•
•
•
•
•
•

Simulate walking through a model with the Walk tool.
Save different views of your model as scenes.
Animate scenes to create a tour of your model’s exterior and interior.
Cast realistic shadows based on your location and different times of day.
View your model in Google Earth, so you can show how your model looks in its intended
surroundings.
Watermark your model with an overlay or background image, such as a company logo.
Print your model, either on paper or with a 3D printer. (The steps for Microsoft
Windows and Apple macOS are different, so see the article that covers your operating
system.)

And that’s not all you can do!
The ways you can share your designs go beyond SketchUp. In the 3D Warehouse, you can
upload your model and share it with the SketchUp Community. If you’re a SketchUp Pro user,
you have LayOut, which enables you to create 2D drawings and documentation of your model,
including plans, sections, elevations, and perspectives.
Tip: For details about exporting a view of your model as an image file, see Using SketchUp
Data with Other Modeling Programs or Tools, which covers how to import or export several
different file types into or out of SketchUp.
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Managing models using Trimble Connect
The Trimble Connect extension for SketchUp provides direct access to projects, models, and
other features of the Trimble Connect platform. Create a model in SketchUp and then Publish
to a Project and share with team members. Import a model into SketchUp to use as a reference
model. Pull in changes from collaborators as needed. Make changes and re-publish your model.
Your use of the Trimble Connect extension for SketchUp is subject to the Trimble Extension
End User License Agreement.
To learn more about using Trimble Connect, visit the Getting Started page.
If you're using using SketchUp for Web you have a Trimble Connect login, the free version of
SketchUp for Web includes the Trimble Connect Personal, if you've subscribed to SketchUp for
Web - Shop then your subscription includes Trimble Connect Business.

Getting Familiar with the Extension
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This Extension comes with SketchUp Pro 2016 by default and offers the following capabilities:
•

•
•
•
•

•
•

Sign In / Sign Out…: Sign in or out of Trimble Connect. At this time, you must to sign
into a Google Account to use the Trimble Connect extension inside SketchUp. Although
you need a Google Account, you don't need to create a new Gmail address. To create a
Google
Account
and
associate
with
any
email
address,
visit http://accounts.google.com/newaccount and then click I prefer to use my
current email address.
Open Model… - Open a Sketchup file hosted on Connect.
Publish Model - Upload a SketchUp model to a Connect Project.
Publish Model As… - Upload a model to a specific folder or upload model with a new
name.
Import a Reference Model… - Imports a model file (skp, ifc, dwg, dxf) to use as a
reference. The geometry in a reference file can be leveraged to coordinate modeling
tasks. A layer will be created for each reference model to help you manage visibility.
Reference Models are positioned based on the origin of the file. They are also locked.
To re-position a reference model, use the “Position Reference Model…” feature on the
context menu.
Update Reference Models - Updates all reference models with the latest versions
available from Connect. To upload a single reference model, use the Update Reference
Model feature on the context menu (right click on any reference model).
Open Trimble Connect... - Opens the full Trimble Connect web app inside SketchUp.
This allows you to manage your projects folders, add todos and configure Trimble
Connect.
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If you run into any issues when using Trimble Connect within SketchUp please contact SketchUp
Support directly through our contact page.
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Sending a SketchUp Model to LayOut
SketchUp and LayOut are designed to work together seamlessly. In SketchUp, the Send to
LayOut button (
toolbars:
•
•

) opens your model directly in LayOut. You find this button on the following

Getting Started
Large Tool Set

To send a model from SketchUp to LayOut, follow these steps:
1. In SketchUp, click the Send to Layout button. The LayOut application opens.
2. Select a LayOut template for your document. Your model opens in LayOut as a Sketchup
viewport.
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Slicing a Model to Peer Inside
In SketchUp, section planes cut a model along a plane so that you can peer inside the model
— without moving or hiding any geometry. In a 3D model, an active section plane hides
everything on one side of the plane, as shown in the following figure.

You can use section planes for all types of applications:
•
•

Cut a building horizontally to see the floor plan. In architectural drawing, this twodimensional top-down cut is called a planimetric view.
Cut a building vertically to see inside the rooms of several floors at once. This
type of cut is called a sectional view (not to be confused with SketchUp’s section
planes).

Tip: To create a planimetric view like an architect, place the section plane 48 inches above the
floor’s surface. This placement usually enables you to see windows and doors in the slice
without cutting through countertops or furniture. To create a sectional view, don’t cut through
columns, because they’ll look like walls instead of objects that people can walk around; do cut
through stairs or elevators, because this shows how people move through the building.
In SketchUp, you can insert multiple section planes, but only one section plane can be the
active cut in each context. You create more than one context in a model by creating groups or
components, each of which has a separate context. For example, the house in the following
figure is a component and has two active section plane cuts: one cut is outside the house
component and the other is within the component's context.
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Tip: Want to show off multiple interior views of a model? SketchUp enables you to show section
cuts in scene animations. To animate scenes that show different section cuts, you need to save
the section settings in a style and then save each view in a scene. Animating Scenes explains
how to create animations of your model.
In the upcoming sections, you find detailed steps that walk you through the many things section
planes can do.
Table of Contents
1.
2.
3.
4.
5.

Adding a section plane
Filling voids in section cuts
Creating new geometry from a section plane
Showing or hiding section planes, cuts, and fills
Exporting section cut effects

Adding a section plane
Inserting a section plane is easy as pie. Make sure nothing in your model is selected, and open
the group or component context where you want to add the section plane. Also, if you want to
place the section plane at a specific height, such as 48 inches above the floor surface, use the
Tape Measure tool to set a guide line that will help you place the section plane precisely where
you want it.
When you’re ready to add a section plane, follow these steps:
1. Select the Section Plane tool (
) or select Tools > Section Plane. Microsoft
Windows users find the Section Plane tool on the Sections toolbar. On both Microsoft
Windows and macOS, the Section Plane tool is on the Large Tool Set palette.
2. With the section plane cursor, shown in the following figure, click a face to place your
section plane.
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Tip: If you have trouble keeping the section plane in your desired orientation, hover
over a face that matches the orientation you want and hold down the Shift key to lock
the section plane cursor’s direction. You can also tap the arrow keys to orient
the normal of the section plane to the default axes directions: Up for Blue axes, Right
for Red axes, Left for Green Axes, and Down for parallel to face.
3. When the Name Section Plane dialog box appears, type a name for your section plane.
You can also select a symbol (the default is a number). If your model has more than
one section plane, adding a different number for each one can help you identify them.
4. Click OK.

After you click a face, your section plane appears, as shown in the following figure.
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After you place a section plane, you can reposition it or adjust it as follows:
•
•
•
•
•

Adjust the placement with the Move tool or the Rotate tool.
Reverse the cutting direction by context-clicking the section plane and
selecting Reverse from the menu that appears. For example, if you make a vertical
cut, you can reverse the cut to display the inside of the other half of your building.
Align SketchUp’s camera with the section plane by context-clicking the section
plane and selecting Align View. In the preceding figure, aligning the view to your
section plane takes you to a top view of the model.
Select which section plane is the active cut, if you have more than one, by contextclicking the section plane you want to make active and selecting Active Cut from the
menu. Or, double-click the section plane you'd like to activate or deactivate.
Control section plane visibility. See details about hiding or showing section
planes later in this article.

Tip: Want a quick way to manage your section planes? Each section plane appears in
the Outliner panel with the name you entered when you created the section plane. You can edit
the section plane's name and symbol in the Outliner or the Entity Info panel.
In the Outliner, you can also context-click a section plane and use the menu that appears to
hide, activate, reverse, and take other actions to manage that section plane. Double-clicking
the name in the Outliner activates or deactivates the section plane.
Note: When you use the Align View command in Parallel Projection perspective, you can
quickly generate sectional elevation or one-point perspective views of your model.

Filling voids in section cuts
When you slice a solid with a section plane, you may not want to see voids where solid material
should be. For example, say a section plane is showing a sliced concrete block. Depending on
your section fill settings, the model might show empty space where the concrete block would
be filled.
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To fill closed loops in the slice, you can simply select the Section Fill check box in the Styles
panel. For example, the following figure shows how the concrete block changes when the
Section Fill check box is selected. Alternately, you can toggle section fill visibility with the View
> Section Fill command or the Display Section Fill button (
) on the toolbar. (Remember
that whether you use the Styles panel, View menu, or toolbar buttons, you modify the style
and need to save the style if you don't want to lose the visibility settings you've applied.)

To control the Section Fill settings in the Styles panel, follow these steps:
1. Open the Styles panel.
2. Click the Edit tab.
3. On the Edit tab, click the Modeling Settings icon (
).
4. To fill areas that are closed loops, select the Section Fill check box. Remember that,
to create a filled section cut, the geometry in the section slice must form a closed loop
within its group or component hierarchy. You can see that hierarchy in the Outliner.
5. (Optional) To adjust the color, click the Section Fill color swatch and use the color
picker to choose your desired color.
Tip: Need some help troubleshooting a fill? Context-click the section plane and choose
Troubleshoot Section Fill. You then see red circles around the vertices that border the opening
in the loop.
See Customizing Modeling Settings to Complement a Style for more details about your
Modeling Settings options.

Creating new geometry from a section plane
Where a section plane intersects with a model, SketchUp enables you to create geometry,
which is automatically organized into a group. You can then move that group to a new location
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in your model, so you have a copy to work with, as shown in the following figure. Or explode
the group so you can use the geometry to divide your model.
To create geometry in this way, context-click a section plane and select Create Group from
Slice from the menu that appears.
Tip: If you have trouble seeing or selecting the group, select the group in the Outliner.

Showing or hiding section planes, cuts, and fills
When a section plane cuts your model, the cut isn’t permanent, and you can control the visibility
of the plane, cut, and fill independently of each other. Hiding the section plane makes the
transparent plane with its color handles disappear. Hiding the section cut makes your model
look whole again. Hiding the section fill can make closed loops look hollow instead of solid.
Tip: The best way to control the visibility of section planes, cuts, and fills is via the Styles
panel. Whether you use the Styles panel, the View menu, or a toolbar button, your change
always modifies the style. When you use the Styles panel, it's easier to remember that you've
changed the style and need to save it in order to preserve your changes. For example, when
you change section plane visibility via the View menu, you change the style. If you want those
visibility settings to apply after you switch between styles or scenes, make sure you save your
changes to the style. If you don't save the changes, you can lose them after you switch between
styles or scenes. To save your changes, click the Update Style with Changes button (
)
in the upper right of the Styles panel. If the Update Style with Changes button is grayed out,
your style is up-to-date.
Here’s how to control the visibility of your section planes and cuts:
•

Toggle the visibility of all section planes: By default, a colorful section plane
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appears every time you create a section plane. To toggle the visibility of all the section
planes in your model in the Style panel, click the Edit tab, select the Modeling
Settings icon, and select or clear the Section Planes check box. The Section
Planes command on the View menu and the Display Section Planes tool (
the same effect.

) have

Tip: Microsoft Windows users can find all the section tools on the Section toolbar.
macOS users can add section tools to the main toolbar. See Customizing Your
Workspace for details.
•

•

•

Toggle visibility of a single section plane: If you have multiple section planes but
want to hide only one, context-click the section plane and select Hide. When you hide
a single selection plane, its visibility no longer toggles on and off as described in the
preceding bullet until you unhide the section plane by displaying hidden geometry and
selecting Unhide from the context menu.Another easy to way to hide or show a single
section plane is via the Outliner.
Toggle visibility of all section cuts: The Styles panel has a Section Cuts checkbox
that toggles the visibility of all cuts. Alternately, click the Display Section Cuts tool (
) or select View > Section Cuts.
Toggle visibility of all section fills: The Styles panel has a Section Fills checkbox that
toggles the visibility of all fills. You can also change the fill color as explained earlier
in Filling voids in section cuts. Alternately, click the Display Section Fills tool (
or select View > Section Fills.

)

Exporting section cut effects
SketchUp can export an image of your model displaying section cut effects. You can use these
images in LayOut, portfolios, presentations, websites, or basically anywhere you might want to
show off an image of your work. Just make sure your model shows the section cut as you want
it to appear in your image. See Using SketchUp Data with Other Modeling Programs or Tools for
details about exporting a model as an image or other file type.
With SketchUp Pro, you can also export a section slice, which is a 2D vector image of geometry
along a section plane. Here are a just a few ways you might use a section slice:
•

•

Create scaled drawings in a CAD program. If you created a 3D model with precise
measurements and angles, the section slice feature enables you to scale the slice.
(Technically, you can scale imprecise models, too; the scale just doesn’t mean
anything.)
Edit the slice as a vector image. Because the 2D slice is exported as a vector graphic,
you may be able to open the exported file in programs like Adobe Illustrator.

Tip: When the scale of your 2D slice is important, pay close attention to your view in SketchUp.
If your view is set to Perspective, you can’t export to scale. If you’re viewing your model in
Parallel Projection view, only faces whose normals are perpendicular to the view angle are
measurable. Viewing a Model explains what the different views show and how to change your
view.
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To export a section slice from SketchUp Pro, follow these steps:
1. If your section plane is within a group or component context, double-click the group or
component to open its context.
2. Select the section plane with the section cut that you want to export.
3. Select File > Export > Section Slice. The Export 2D Section Slice dialog box appears,
as shown in the following figure.
4. Choose where you want to save the file. By default, the file is saved in your Documents
folder.
5. Type a name for the exported file in the File Name box (Microsoft Windows) or Save
As box (Apple macOS).
6. Select what type of file you want to export from the Save As Type box (Microsoft
Windows) or Format box (Apple macOS). The default option is .dwg or you can
select .dxf. Both of these are AutoCAD file types.
7. (Optional) Click the Options button to open a dialog box where you can select your
options. The following list outlines what your options mean. After you’re done selecting
options, click OK to return to the Export 2D Section Slice dialog box.
8. Click the Export button. Your file is saved in the location you selected in Step 4.

When you export a 2D slice, you can choose from the following options:
•
•
•
•

True Section (Orthographic) exports the section slice as a true orthographic drawing.
This is useful for creating templates for CAD drawings or any other time you want to
generate accurate, measurable slices.
Screen Projection projects the section cut as you see it on your SketchUp screen,
including any perspective distortion. This is most useful for diagrams that you don’t
need to measure.
AutoCAD Version enables you to select the version of AutoCAD you plan to use from
the drop-down list.
Drawing Scale and Size options enable you to configure the scale of the exported
section slice. If Full Scale is selected, SketchUp exports the file at a 1:1 scale. The In
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Drawing and In Model options enable you to specify a drawing scale, where In
Drawing is the measurement of the exported geometry and In Model is the object’s
actual measurement. For example, for a scale of 1:4, enter 1" in the In Drawing box
and 4" in the In Model box.
Section Lines options enable you to choose how the section cut lines in your exported
slice appear. None exports the lines at normal width. Polylines with Width turns the
lines into polylines. Wide Line Entities (only available when exporting .dwg files to
AutoCAD 2000 or later) makes the lines in the exported file wider than normal. If you
want to set the line width automatically, leave the Automatic checkbox selected. Or
clear Automatic and enter a value in the Width box to set an exact line width.

On Microsoft Windows, you also see Section Line options for separating profile edges on a layer
and always being prompted for section slice options.
•

Select the Always Prompt for Section Slice Options checkbox, and SketchUp
displays the 2D Section Slice Options dialog box every time you export a section slice.
When this checkbox is cleared, by default, SketchUp uses whatever options were
selected last time.
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Walking through a Model
Imagine shrinking into a tiny person and jumping into your computer to check out (or show
off) your 3D models.
That’s basically what SketchUp’s walkthrough tools enable you to do. But instead of altering
your entire body composition, you just click a few tools — namely the Position Camera, Look
Around, and Walk tools.
Tip: Remember that SketchUp uses the metaphor of a camera to change how you see your
model.
Here’s how each tool enables you to tour your model:
•

The Position Camera tool ( ) enables you to view your model at a specific height
relative to the surface of your model. That height is meant to reflect a person’s eye
height, and you can adjust it to any height you like.

•

The Look Around tool (
of like turning your head.

•

The Walk tool (
) moves SketchUp’s camera forward or turns it in different
directions, which simulates how your model looks from eye height.

) enables you to move the camera from side to side, sort

Because all these tools are related, you find them clustered in the following parts of the
SketchUp interface:
•
•
•

Camera menu
Camera toolbar (Microsoft Windows)
Large Tool Set

Tip: Before you start exploring your model, know that the walkthrough tools work best when
SketchUp’s camera has a wide field of view. For details about changing your field of view,
see Viewing a Model.
In the following sections, you find videos that demonstrate how the walkthrough tools work
and steps with detailed explanations of how to use each tool.
Table of Contents
1. Positioning the camera
2. Looking around your model
3. Walking through a model

Positioning the camera
You can position the camera using one of two methods:
•
•

Place the camera at eye-level above a specific point (5’ 6" above that point by default).
Place the camera at a specific point, facing a specific direction.
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In the following video, you see how to use both methods.
To position the camera a specific point, follow these steps:
1. Select the Position Camera tool ( ).
2. Click a point in your model, and SketchUp places the camera’s point of view at 5’ 6"
directly above the point you click.
3. (Optional) If you want to make the eye height taller or shorter, enter a new value and
press Enter. Remember that Measurements box is ready to accept a value; you don’t
need to click in the box before you type a value.
After you place your camera, SketchUp automatically switches to the Look Around tool (
).
Basically, you just click and drag the cursor in the direction you want to look, but the next
section, Looking around your model explains the details.
If you follow the preceding steps, the camera by default looks due north, which is the top of
the screen in SketchUp-land. If you want the camera to look at a specific object or in a specific
direction within your model, position the camera by following these steps:
1.
2.
3.
4.

Select the Position Camera tool ( ).
Click and hold the mouse where you want to position the camera.
Drag the cursor to the point or object that you want the camera to display.
(Optional) Type a new eye height in the Measurements box and press Enter.

Looking around your model
If you position SketchUp’s camera with the Position Camera tool, then SketchUp automatically
activates the Look Around tool (
the tool itself.

). You can also activate the Look Around tool by selecting

The Look Around tool’s cursor looks like an eye, to emphasize that it’s simulating looking around
a model at eye height. When you’re in the Look Around tool, the Measurements box is ready
to accept an Eye Height value anytime. Just type a value and press Enter. Note that the value
you type is relative to the ground plane, not a surface in your model.
To do some actual looking around, click and drag the Look Around cursor left, right, up, or
down — whichever way you’d like to turn your simulated head.

Walking through a model
The bad news is that walking through your model isn’t actual exercise. But everything else
about the Walk tool is pretty awesome!
In the following video, you see the Walk tool in action, and the video is a nice introduction to
how the tool works.
Here’s the, uh, step-by-step for walking through your model:
1. Select the Walk tool (

). The cursor changes to a pair of shoes.
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2. Click and drag the cursor to start walking. A small crosshair appears where you click,
and the farther you walk from the crosshair, the faster you walk. You can also control
your speed with modifier keys, outlined in the following table.
3. Move the cursor up, down, left, or right to move through your model. You can go up
and down inclines or stairs while maintaining eye height. However, by default, collision
detection is turned on, so you can’t walk through walls; override collision detection with
a modifier key.
Tip: Want to stop and look around during your walk? If you’re using the recommended scrollwheel, two-button mouse, looking around is easy. When you’re using the Walk tool, click and
hold your scroll wheel to temporarily switch to the Look Around tool.

To Do This

Microsoft Windows
Modifier Key

Apple macOS Modifier
Key

Move up or down (instead of
backward and forward)

Shift

Shift

Run instead of walk

Ctrl

Option

Walk through walls (that is, disable
collision detection)

Alt

Alt

Note: When you’re using the Walk tool, the Measurements box indicates the eye height
relative to the ground plane. You can override this height at this time by typing a new value
and pressing Enter. However, because the Walk tool maintains a consistent camera height
as you walk, relative to the model surface, you shouldn’t need to enter a new Eye Height
value as you walk around.

SketchUp Help Pages – version 19.

Page 413/567

Creating Scenes
In SketchUp, making a scene doesn’t disturb anybody. In fact, scenes help you save different
model views and properties and then present those views to other people.
When you create a scene, a tab appears at the top of the drawing area, so you can simply click
the tab to display the saved view. In the following figure, you can see how several views of the
Victorian-style house are saved as scenes, with tabs along the top of the drawing area.

Here are a few ways you might use scenes:
•

•

•
•

As you’re creating a 3D model, create scenes so that you can quickly move among
different views of your model. You might save views from different angles, like the front,
back, and side of your model. Or you might create scenes so you can quickly move
among different rendering styles, such as wireframe, monochrome, or textured.
Save scenes to go along with a presentation of your model. Instead of pausing your
presentation to orbit, pan, and zoom while your audience watches and waits, you can
make all these moves before your presentation by saving a scene of every view that
you want to show. During your presentation, you just need to click the scene tabs.
Save scenes with a model that you share via the 3D Warehouse.
Animate a sequence of scenes to show off a model. Learn how to animate scenes
in Animating Sections and Scenes.

In the sections that follow, you find out how to add a scene and control what properties you
save with that scene. If you want to save changes that you make to a scene, you can do so by
updating the scene. SketchUp also has commands for sequencing scenes and deleting scenes
that you no longer need.
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Adding a scene
Managing properties saved with a scene
Updating a scene
Sequencing scene tabs
Deleting a scene
Customizing thumbnails the Scenes dialog
Viewing scenes in models imported from the 3D Warehouse

Adding a scene
Before you create a scene, set the view and apply any styles, fog, shadows, or section
cuts that you want to the scene to display. Also, hide any geometry or deselect any layers that
you don’t want the view to display. All these properties are saved with your scene, although
you can update or manage these properties later, as explained in the next two sections of this
article.
To add a scene, follow these steps:
1. Click the Add Scene icon (
name of Scene 1.

). The scene appears in the Scenes dialog with the default

2. (Optional) Click the Show Details icon (
) in the upper right of the Scenes dialog.
Use the options provided to rename the scene (as shown in the following figure), add a
description, and select which properties are saved with the scene. The next
section, Managing properties saved with a scene, explains how the properties options
work.
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Tip: If your model already contains one scene, you can context-click the scene tab and
select Add, which also creates a new scene. Alternately, in the Scenes dialog, you can add a
scene by clicking the Scenes dialog’s Details arrow (
menu that appears.

) and selecting Add Scene from the

If you’re creating a new model of a building and you have a photo of that building, you can
create a scene and start a Match Photo operation at the same time. In the Scenes dialog, click
the Details arrow (
) and select Add Scene with Matched Photo. You’re prompted to
select the photo file you want to use, and then SketchUp switches to Match Photo mode.
See Matching a Photo to a Model (or a Model to a Photo) for details about working with the
Match Photo feature.

Managing properties saved with a scene
By default, when you add a scene, SketchUp saves several properties that affect the view of
your model. In the Scenes dialog, the following checkboxes enable you to control which of
these properties are saved. Here’s brief introduction to the checkboxes and the properties they
control:
•
•
•
•

Camera Location: Remember that SketchUp uses a camera as a metaphor for the way
you view your model. The camera properties saved with a scene include the the point
of view, including the zoom distance and field of view.
Hidden Geometry: If your scene has hidden geometry, this geometry remains hidden
every time you load that particular scene.
Visible Layers: This property applies if you use layers to control visibility.
Active Section Planes: Your model can contain several section planes, which slice
your model at a certain point to display a view of the inside, usually from the top or the
side.
Tip: You can use different section cuts in successive scenes to create exciting
animations of your model.

•
•
•

Style and Fog: This checkbox determines whether the scene saves style settings, such
as edge rendering and fog.
Shadows Settings: This checkbox tells SketchUp whether to store all shadow-related
information, including type, time, date, and so on, with the scene.
Axes Location: This setting affects whether the axes display and the axes' position in
the scene.

By default, all these checkboxes are selected, so all the properties are saved with your scene.
If you don’t want to save one of these properties, select the scene in the Scenes dialog, click
the Show Details icon (
) to display the checkboxes, and deselect the checkbox for each
set of properties that you don’t want to save.
Note that you can’t save updates to a property with a scene if that property isn’t saved with
the scene. See the next section for details about making sure you include all the properties you
want to save in an update.
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Updating a scene
Updating a scene saves any changes that you make to a scene after you create it. To update
a scene, follow these steps:
1. In the Scenes dialog, select the scene you want to update.
2. Click the Show Details icon (
with the scene are selected.

) and make sure all the properties you want to save

3. Click the Update Scene icon (
) in the upper left of the Scenes dialog.
4. In the Scene Update dialog box that appears, you can deselect any properties you don’t
want to save with the update. Remember that if an item wasn’t selected in Step 3, that
property doesn’t save, even if you select it in the Scene Update dialog box. After you’re
done selecting or deselecting properties, click Update.
Tip: If you don’t like keeping the Scenes dialog open, you may prefer to update a scene by
context-clicking a scene’s tab and selecting Update. In the Scenes dialog, you can also click
the Details arrow (

) and select Update Scene.

Sequencing scene tabs
SketchUp adds scene tabs and lists of scenes in the Scenes dialog based on the order in which
you create the scenes. However, this order may not be what works best. For example, in the
following figure, say you want to move the interior scene later in the sequence, after all the
exterior scenes.
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To change the sequence of your scenes, you use either the scene tab’s context menu or the
Scenes dialog:
•
•

Scene tab context menu: Context-click the tab you want to move and select Move
Left or Move Right. Repeat the command if you want to move the scene more than
one position in the tab order.
Scenes dialog: Select the scene from the list and click the Move Scene Down icon (
) or the Move Scene Up icon (
) in the upper right. The tab order updates to
reflect the order in the Scenes dialog.

Deleting a scene
If you no longer need a scene, you can delete the scene in the following ways:
•

Select the scene in the Scenes dialog and click the Remove Scene icon (
upper left.

•

Select the scene in the Scenes dialog, click the Details arrow (
), and select Delete
Scene from the menu that appears.
Context-click the scene tab and select Delete from the menu that appears.

•

) in the

Customizing thumbnails in the Scenes dialog
In the Scenes dialog, you can customize how the scene thumbnails and the list of scenes
appear.
The following options enable you to control how the scene thumbnails appear:
•
•

If you don’t want to see the thumbnail images, click the Details arrow(
) and
deselect Use Scene Thumbnails.
If you update a scene and want the thumbnail to reflect the update, click the Details
arrow and select Update Scene Thumbnail.

Click the View Options (
) menu in the upper right of the Scenes dialog, and you can select
from the following options, which control how your lists of scenes appears:
•
•
•
•

Small Thumbnails: You see only thumbnails, not the scene names, and more than ten
thumbnails are visible in the list at once, before you need to scroll in order to see more
scenes. However, as the option name indicates, the thumbnail images are quite small.
Large Thumbnails: See only large thumbnail images of a scene, not the scene name.
With this option selected, you can see about six thumbnail images at a time.
Details: This is the default option, which shows medium-sized thumbnails, the scene
name, the photo if your scene has one, and the scene description. You see more
information but fewer scenes in this view.
List: See only the scene names in a list. The text is a bit larger in this view than in the
Details view.

Viewing scenes in models imported from the 3D Warehouse
If you download a model from the 3D Warehouse into SketchUp, your download is inserted into
your model as a component. However, components don’t have scenes.
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Tip: To see and access the scenes, you must open the model in a new instance of SketchUp,
so it opens as a full model rather than as a component in a model.
To open a 3D Warehouse download as a model, click No when a message asks, “Load this
directly into your SketchUp model?” You then see another message that asks, “Do you want to
open or save this file?” Click Open and you can see and use any scenes saved with the model.
For details about saving, sharing, or downloading models via the 3D Warehouse, see the 3D
Warehouse section of the Help Center.
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Animating Scenes
SketchUp can animate scenes of a 3D model. Animations are a great way to show off your
model from different angles or share shadow studies. For example, say you create a scene with
a morning shadow, another scene with a noon shadow, and a third with an evening shadow.
With SketchUp’s animation feature, you can watch the shadow transition from morning to
evening.
Before you create an animation, create scenes of your model, each with different settings, as
explained in the article, Creating Scenes. When the scenes are ready to be animated, you can
create the animation in one of three ways:
•
•
•

Play an animation of the scenes in SketchUp.
Export the animation to a video file, such as .mp4, which plays on most devices.
Export an image set, which is a collection of image files that you can animate with video
software. (SketchUp Pro only)

Tip: Use SketchUp for simple presentations or when the customer has SketchUp Mobile Viewer.
The animation export features are handy when you can’t use SketchUp to play an animation.
Here are a few examples of when you might need to export your animation:
•
•
•

Presenting your model to a client who doesn’t have SketchUp or SketchUp Mobile
Viewer.
Sharing a video export on your website or via a video sharing service.
Post-processing the animation in another application.

Table of Contents
1. Animating scenes in SketchUp
2. Exporting video animations
3. Exporting image sets

Animating scenes in SketchUp
After you create and sequence your scenes, animating scenes in SketchUp is easy. You can
play the animation in one of two ways:
•
•

Context-click the scene tab that you want to begin the animation and select Play
Animation from the menu that appears.
In the Scenes manager, select the scene that you want to begin the animation, and
select View > Animation > Play from the menu bar.

To customize the animation, select View > Animation > Settings or select Window >
Model Info and select the Animation option in the sidebar. Either way, you see the following
settings in the Model Info window:
•

•

Scene Transitions: The Enable Scene Transitions checkbox is selected by default,
and when selected, SketchUp animates a smooth transition from one scene to the next.
Below the checkbox, enter a number in the Seconds box to set the length of each
transition.
Scene Delay: Type a number in the Seconds box to set how long a scene appears
before SketchUp begins to transition to the next scene.
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Exporting video animations
To export your animation, follow these steps:
1.
2.
3.
4.

Select File > Export > Animation > Video. The Export Animation dialog box appears.
Navigate to the place where you want to save your video file.
Type a name for the file in the File Name text box.
Select a file format from the Save As Type drop-down list. The following table explains
your file format options.
5. Click Options to open the Export Options dialog box, where you can set the resolution,
aspect ratio, frame size, frame rate, and more. See the upcoming list for details about
each option.
6. After you finish setting your options, click OK in the Export Options dialog box to return
to the Export Animation dialog box.
7. Click Export and SketchUp renders your animation as a video file.
The table outlines your codec (which compresses the video) and file format options and what
you need to know about each one.

Option

Where to Play
This File Type

Good to Know

H.264 codec .mp4

In a web browser,
with many video
programs, and on
many hardware
devices

.mp4 is a compressed video format, and one of
the most broadly supported video file types.

Uncompressed .avi

In Windows Media
Player or on a
Mac, in VLC

Uncompressed .avi generates a large video file
and also plays on most computers and devices.
You may want uncompressed video if you plan
to edit the video in video-editing software.

Vp8 codec .webm

In the Chrome,
Firefox, or Opera
web browser, or
with a few media
player
applications, such
as VLC.

.webm is a compressed open media file format
that works with the HTML5 video tag. The
format was designed as an open format for the
web.

Theora codec .ogv

In a web browser
or with a media
player, such as
VLC

An .ogv file is often embedded in a web page via
the HTML5 video tag as an alternate to
the .webm format. This way, website visitors
can use whichever file their preferred browser
supports.

Before you render your video, you can choose from the following options, which can make your
file size larger or smaller and change the physical dimensions of the video. Here’s a quick
overview of the export options:
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Resolution: Choose among three preset resolutions: 1080p Full HD, 720p HD, or 480p
SD. The lower the number, the lower the resolution. The highest resolution looks great
when played full screen on a large monitor. However, it also has the biggest file size,
which may not be great for video played over the web on a mobile device. The lowest
resolution has an aspect ratio for monitors with a standard 4:3 aspect ratio, which is
more square than a widescreen monitor (with a 16:9 aspect ratio). The preset options
cover most video outputs, but if you’re video savvy and have SketchUp Pro, you can
create a custom setup: Select Custom to set the Aspect Ratio and Frame Size on your
own.
Aspect Ratio: This item is locked unless you select a custom resolution. Choose from
16:9 for widescreen monitors, 4:3 for standard monitors, or Custom to modify the
frame’s width and height independently of each other.
Width and Height: These settings are locked by default. By choosing Custom from the
Resolution drop-down list, you can alter the height. By choosing Custom for the Aspect
Ratio drop-down list, you can alter both the Width and Height.
Line Scale Multiplier: This value controls the overall line thicknesses of exported
animations. If the line weights in your animation are too thick or too thin, you can
change the line weights with this value. The larger the number, the thicker the lines in
your animation will appear.
Preview Frame Size: Click this button to check how your video will look in the frame
size that you’ve selected.
Frame Rate: The higher the frame rate, the smoother the video and the larger the file
size will be. The default setting is 24 frames per second, but you can select 15, 25,
29.97, or 30 to lower or raise the frame rate.
Loop to Starting Scene: In SketchUp Pro, this option is enabled by default. When
selected, the animation will loop back to the original scene. Deselect this option if you
wish for the video to end on the final scene.
Anti-alias Rendering: This option is enabled by default and smooths vector lines if
they appear choppy or jagged.
Always Prompt for Animation Options: When selected, you’re prompted to set
animation options before you export the file. By default, this option is deselected.
Restore Defaults: Click this button to reset the export options to SketchUp’s default
options.

Exporting image sets
You can export an animation to series of images called an image set.
To create an image set, follow these steps:
1. Select File > Export > Animation > Image Set.
2. In the Export Animation dialog box, select where you want SketchUp to save your
images. Because the process typically generates a few hundred images, creating a folder
just for these images is a good way to keep them organized.
3. In the File Name box, type the root name for your images. SketchUp appends a
number to each image as it renders the image set, so that the images stay in order for
the animation.
4. In the Save As Type drop-down list, select an image type. The .png file type works for
most applications, but you can also choose from .jpg, .tif, and .bmp. The .tif format
produces large image files that are less compressed and typically less compatible with
other software than .jpg or .png.
5. Click Options to open the Export Options dialog box, where you can set the resolution,
aspect ratio, frame size, frame rate, and more. Refer to the preceding section for details

SketchUp Help Pages – version 19.

Page 422/567

about each option, but note that the Anti-alias Rendering option is not available for
image sets. Click OK when you’re done setting your options to return to the Export
Animation dialog box.
6. Click Export, and SketchUp begins creating your image set. The process can take a few
minutes or longer, depending on the length of your animation.
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Casting Real-World Shadows
With SketchUp’s Shadows feature, you can make your model cast a basic shadow or see how
the sun casts shadows on or around a geolocated model.
When you’re casting real-world shadows, SketchUp’s calculations are based on the following:
•
•
•

The model’s latitude and longitude
The model’s cardinal orientation (north, south, east or west; see Adjusting the Drawing
Axes for details about how the drawing axes are aligned to the cardinal directions)
The selected time zone

Tip: The Shadows feature can give you only a general idea of how the sun and shadows will
look at a specific location. The time is not adjusted for daylight saving time. If the model is
geolocated in an area where time zone lines zigzag rather dramatically, the time zone may be
off by an hour or longer.
Tip: Before you can cast real-world shadows in a model, your model must be geolocated. To
geolocate your model in SketchUp Pro 2017, you can import terrain using the Add Location
tool. Or to add a location manually in any version of SketchUp, select Window > Model Info,
select the Geo-location option in the sidebar on the left, click Set Manual Location, and
enter a latitude and longitude in the dialog box that appears. After you model is geolocated,
SketchUp knows (roughly) how the sun will shine on your model.
By default, shadows are turned off, because they can use a lot of your computer’s processing
ability. To turn on shadows and see shadows at different times of day, follow these steps:
1. Select View > Shadows. This enables the Shadows feature.
2. , where you can control how the shadows appear. (Alternately, you can display the
Shadows toolbar; Customizing Your Workspace explains how to show and hide
toolbars.)
3. To select the time of day, drag the Time slider along the timeline or enter a time in the
Time box.
4. To select a month and day, drag the Date slider or enter a date in the Date box.
In the following figure, you see the how the shadows change from 7:00 a.m. (top) to 3:30 p.m.
(bottom).
(cont’d next page)
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Beyond the basic shadow settings outlined in the preceding steps list, you can customize a few
more shadow attributes in the Shadow Settings dialog box:
•
•
•
•
•
•

The Display Shadows button in the upper left toggles the shadow display on and off.
The Time Zone drop-down list enables you to choose a new time zone. If your model
is geolocated, this time zone should be accurate, but you can check that it’s correct or
change it if you like.
The Light slider controls the light’s intensity. This option effectively lightens and
darkens illuminated surfaces.
The Dark slider controls the shadow’s intensity. With this option, you can lighten or
darken areas under shade or shadows.
When the Use Sun for Shading checkbox is selected, SketchUp’s simulated sun shades
parts of your model even if shadows are toggled off.
The On Faces checkbox enables faces to cast shadows on other faces. This feature
gobbles up your graphics card’s processing power, so you might try deselecting this
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option if you want to display shadows but the feature is causing a performance problem.
When the On Ground checkbox is selected, your geometry can cast shadows on the
ground plane.
The From Edges checkbox controls whether edges that are not associated with a face
cast a shadow. By default, this option is deselected.

Check out this blog post for more information on how to control shading in your SketchUp
models.
Tip: Have a transparent face that isn't casting shadows? When the material applied to a face
has an opacity of less than 70%, the face stops casting shadows. If you want a transparent
face to cast shadows, edit the material's Opacity setting to 70% or higher.
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Viewing Your Model in Google Earth
Previewing a SketchUp model in Google Earth is great way to see how your model looks in the
context of its surroundings.
You start the process in SketchUp, where you optimize the model for viewing in Google Earth.
Because Google Earth and SketchUp models can both use a lot of your graphics card’s
processing power, your model needs to be as light as possible.
Of course, all this assumes you have Google Earth installed on your computer. If not, Google
Earth is free, and you can download the software at www.google.com/earth.
In the sections that follow, you find help with optimizing your model, previewing your geolocated model in Google Earth, and finding additional online learning resources.
Tip: For an in-depth look at site-modeling in SketchUp, check out the following video. The
video walks you through an architectural workflow for creating a site model by combining
SketchUp, Google Earth, and Google Maps.
Table of Contents
1.
2.
3.
4.
5.

Optimizing a model for display in Google Earth
Previewing a model in Google Earth
Placing models in the ocean
Saving a model in Google Earth
Finding help with Google Earth

Optimizing a model for display in Google Earth
When you create a 3D model that you want to display in Google Earth, you can create your
model in SketchUp so that your model looks its best in Google Earth. This section explains the
SketchUp modeling techniques that work best with Google Earth.

Geolocate your model
To geolocate your model in SketchUp Pro 2017, import terrain using the Add Location tool.
When you geolocate your model with the Add Location tool, you can import terrain that enables
you to create your model based on the site where you plan to build it (or just display it in
Google Earth). Wherever you place your model on imported terrain in SketchUp determines
the location of your model when you preview it in Google Earth. See Modeling Terrain and
Other Rounded Shapes for details about importing and sculpting terrain as well as tips for
modeling terrain that you want to display in Google Earth.
You can add a location manually in any version of SketchUp. Select Window > Model Info,
select the Geo-location option in the sidebar on the left, click Set Manual Location, and
enter a latitude and longitude in the dialog box that appears. When you geolocate your model,
you ensure your model appears in the correct location in Google Earth.
If you don’t geolocate your model, your model appears in Google Earth at a default location.
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Note: Your default location depends on the language associated with SketchUp. For example,
if you downloaded the American English version of SketchUp, SketchUp’s default location is
Boulder, Colorado. Other default locations include London, Paris, Berlin, Rome, Tokyo,
Barcelona, Taipei, Brasilia, Seoul, Beijing, Moscow, and Amsterdam.
Create a precise model
When you display your model in Google Earth, your model dimensions need to be accurate so
that your model’s scale is proportional to the surrounding landscape or buildings in Google
Earth.
Measuring Angles and Distances to Model Precisely explains how to create a model with precise
dimensions. If you create a model with the Match Photo feature, you can scale the model after
you’re done creating it.

Minimize the edges and faces
Tip: The key to optimizing a SketchUp model for Google Earth is to keep the model complexity
as light as possible.
For example, the following figure shows a model of the Eiffel tower optimized for display in
Google Earth. Without textures projected onto the model (as explained in a moment), you can
see how minimal the underlying geometry can be, even when you’re modeling a complex
structure.

As you create a model with minimal geometry, remember that you can reduce the number of
sides in a circle or an arc.
Make sure fronts of faces are facing outward
Remember that SketchUp faces have a front and back. If the back side of a face points outward,
the face appears black in Google Earth, no matter what material is applied to the back side of
the face.
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To check that the face fronts point outward in SketchUp, select View > Face Style >
Monochrome to see whether the back sides of a any faces point outward. By default, the face
fronts are white and face backs are dark gray. To reverse a face, context-click it and
select Reverse Faces.
In the following figure, you see a basic model with materials (left) and in monochrome (right);
the left, side face needs to be reversed.

Tip: Sometimes, it’s difficult to determine whether a face is truly facing outward or just shaded
to show perspective. If you’re having trouble, orbit so you have a straight-ahead view of the
face. Or, in the Styles browser, you can use the Face Settings to edit the default back face
color so that the backs of faces stand out more than they do in the default gray.

Convey model details by projecting image textures onto your model
In a model that’s optimized for viewing in Google Earth, the geometry itself conveys little detail
about the building. Instead, you use photos applied to each face to show the detail.
In SketchUp, applying a photo to a face is called projecting a texture. You can project a texture
by importing a photo as a texture or projecting textures after you use the Match Photo feature.
You can use Google imagery, digital photos, or graphics you create as photo textures in
SketchUp. For example:
•
•

If you’re modeling an existing building, you might be able to import images from
Google or take your photos with a digital camera. (The article on using the Match Photo
feature includes tips on taking photos for 3D modeling.)
If you’re modeling a building plan, you can create a building image in a graphics
editor and export it in one of the image formats that SketchUp photo textures support,
such as .png. Or apply custom photo textures to your model as materials, and project
the textures before viewing your model in Google Earth. For details, see Applying Colors,
Photos, Materials, and Textures.

Tip: Because your overall goal in optimizing your model for Google Earth is the smallest file
size, make sure your images are optimized for the Web. Both .png and .jpg files can be
compressed to lower the file size. If you’re using images taken with a digital camera, be sure
to optimize the images for the web in your image editor before importing the images into
SketchUp.
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Texture your model with images that support transparency
If you need to be able to look through part of your building, create transparent areas in the
images that you use to texture your model. You may need to convert your images to a file
format that supports transparency, such as .png, and then create the transparent areas in an
image editor.
In the following figure, you see the Eiffel tower model with photo textures that contain areas
of transparency. On the left, you see the model in Google Earth, and on the right, you see the
same model in SketchUp. Notice that the model looks realistic and that you can look through
the structure, just as you can with the real tower.

Previewing a model in Google Earth
For example, the following figure shows a model of a garden shed placed on imported terrain.
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After you tell SketchUp that you want to preview the model in Google Earth, Google Earth loads
your model and zooms to show in the location you indicated, as shown in the following figure.

Note that sometimes Google Earth imagery is a little older than what’s in Google Maps’ aerial
or Street View photography. Also, in flat areas or areas with mostly rectilinear buildings, you
can see your model in the context of the surrounding area more easily than you can in a
neighborhood with lots of mature trees.
Within Google Earth, you can use Google Earth’s navigation tools to move around the area and
see how your model looks on its intended site.

Placing models in the ocean
Google Earth has an Ocean layer, and you can preview models in the ocean by completing a
few extra steps.
First, in SketchUp, select Window > Extension Warehouse, and in the Extension Warehouse
window that opens, search for the Ocean Modeling extension. After you select the extension to
open its page, you can click an Install button the upper right.
After the Ocean Modeling extension installed, you can locate your model in the ocean and
preview it in Google Earth. The following figure shows the garden shed floating the Pacific
Ocean, off the coast of Los Angeles, California.
(cont’d next page)
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Saving a model in Google Earth
When you preview a model in Google Earth, the model is loaded into Temporary Places. If you
want to save your model in Google Earth, context-click the temporary model name in the
Temporary Places folder and select Save to My Places. The model then moves from the
Temporary Places folder to the My Places folder, as shown in the following figure.

After your model is saved in Google Earth, you can open Google Earth directly, select the
model, and fly to it. You don’t need to use the preview feature in SketchUp.
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Tip: By default, your model is named SUPreview0 in Google Earth. To give your model a more
descriptive name, context-click the model name in Google Earth’s Places pane and
select Rename. If you need to delete a model from Google Earth, context-click its name in the
Places pane and select Delete.

Finding help with Google Earth
Although SketchUp includes tools for previewing your model in Google Earth, Trimble doesn’t
offer full Google Earth support.
You find several Google Earth tutorials for beginning and advanced users on Google Earth’s
Learn page. You can also take a full tour of the Google Earth interface.
On Google Earth’s Connect page, you find links to the Google Earth community, including its
user forum, and newsletter.

SketchUp Help Pages – version 19.

Page 433/567

FAQ for Add Location changes in SketchUp
What’s changed with the Add Location and Photo Textures feature?
The Add Location feature that was powered by free data from Google has changed to another
provider. After Trimble’s acquisition of SketchUp from Google in 2012, Google agreed to provide
this data service for five additional years. This grace period of five years ended this May. Old
features are no longer available as of May 22nd 2017. Trimble and SketchUp have changed
geographic data providers so that it can continue to enable the Add Location feature
in some versions of SketchUp.
We understand that modeling in SketchUp with geographic data has been an important feature
for so many. As a result, we are taking steps to provide access to geographic data in SketchUp
Make 2017 (in the form of Map information) and SketchUp Pro 2017 (in the form of satellite
imagery and terrain data).
In addition, the Photo Textures feature is no longer be accessible in any version of SketchUp
once this transition is complete. There is no similar data service available for SketchUp at this
time.
Location Based
Features
Add Location
Location Terrain
Location Imagery
Photo Textures via
Google Street View

Older Versions my.SketchUp
no
no
no

no
no
no

no

no

SketchUp Make SketchUp Pro
2017
2017
yes
yes
no
yes
no
yes
no

no

How does this affect me?
It depends on which version of SketchUp you’re currently using. Please locate the version below
to learn more:
SketchUp 2017 (Pro or Make)
Because Google was able to provide this data for free, this service was easily available to all
SketchUp users. To continue supporting the Add Location feature, the new data provider comes
with licensing fees. For that reason, Add Location’s satellite imagery and terrain will be
accessible in SketchUp Pro 2017 going forward.
SketchUp Make 2017 will have access to Map information only – no satellite or terrain
information will be available.
my.SketchUp
Because the new geodata service that SketchUp comes with licensing fees, my.SketchUp will
behave just like SketchUp Make and have access to Map information only. Satellite imagery
and terrain data will not be made accessible.
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SketchUp 2016 (Pro or Make) and older versions of SketchUp
At this time, there is no feasible way to update these versions of SketchUp to use the new
geodata service. The Add Location and Photo Textures features will no longer function.

What are my options?
The older Google provided data is no longer available.
•
•
•

If you're using SketchUp Make and you wish to have access to location data for terrain
or imagery you'll need to upgrade to SketchUp Pro 2017.
If you're using an older version of SketchUp Pro and your Maintenance and Support Plan
is current then you can upgrade to SketchUp Pro 2017 at no cost.
If you're using an older version of SketchUp Pro and your Maintenance and Support Plan
is NOT current, you'll need to renew your plan to allow you to upgrade to SketchUp Pro
2017.

How do I access geographic data?
After May 22nd 2017, SketchUp Pro 2017 (or newer version) will be the best version of
SketchUp that matches the behavior for Add Location that’s powered by Google data.
•
•

If you are in SketchUp 2017, use the Layer's selector in the upper right to change
between new and old layer.
The data layer you choose will be imported into SketchUp and will not change if you
toggle terrain off

Note: Terrain will no longer be available in SketchUp Make after May 22nd 2017.

SketchUp Pro 2016 (or older)
If you’re using an older SketchUp Pro license with an expired Maintenance and Support plan,
one option is to renew your plan here, which will generate a license to support the current
version of SketchUp Pro.
SketchUp Make 2017
We chose to enable Map information data from Open Street Map when using Add Location in
SketchUp Make 2017. What’s great about OSM is that anyone can contribute data to ensure
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accuracy. If you are a SketchUp Make user who needs road data in a particular location, check
out how you can contribute to OSM.
SketchUp Make 2016 (or older)
There will be no changes made to SketchUp Make 2016 (and older) to utilize the new geodata
provider. Add Location and Photo Textures will no longer be working features in these versions.
We suggest utilizing SketchUp Make 2017 or my.Sketchup if possible to access the Add
Location feature.
Have another question?
Post your question to the Forum
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Using the Credits feature
Overview
In SketchUp, you can use the Credits feature to associate a model with yourself, and you can
see who else has contributed to a model. Please note that you will need a Google Account to
use the Credits feature. If you claimed the credit for a model and upload the model to the 3D
Warehouse, anyone who downloads the model will see your Google Account Nickname in
SketchUp's Credits feature when viewing the model in SketchUp.
There are times when you may want to claim authorship outside of 3D Warehouse. Or you may
have a component that displays as ‘by Unknown’ in the component browser (for which you
want to claim authorship). In these instances, follow these steps to Claim Credit:
Claiming Credit
1. Open the component model file. If your component is within another model, right click
on the component and select Save As to make a separate SketchUp file of the
component, then Open that separate model SKP file.
2. When you are inside your SketchUp model file, click the Sign In Account button in the
lower left-hand corner, denoted by the human torso figure.
3. If you aren't signed in yet, you'll be prompted to sign in to your Google Account.
4. Once you are signed in, you might see a 'SketchUp is requesting permission' dialog.
Click Allow Access to continue.
5. Click Window > Model info > Credits. This will open the Credits window.
6. Your user name will appear in the 'Model authors' section. Click Claim Credit.
7. If the Claim Credit box is grayed out, draw a single line somewhere in the model, then
erase it. This will activate the Claim Credit button. Click Claim Credit.
8. Your user name will appear in the 'Model authors' section. Click Claim Credit.
9. Save the file, File > Save.
10. Now when you import the component into a new model file you'll see yourself in the
Component Authors list.
Note: This feature is not a Digital Rights Management (DRM)-type feature, just a simple
attribution. We do not enforce any usage restrictions based on credits.
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Watermarking a Model
In SketchUp, the Watermark feature can place a graphic in front of or behind your model.
You can add a watermark for its traditional purpose: inserting a company name and logo into
your model.
However, watermarks have creative applications, too: inserting a background image to create
a unique model setting or overlaying your model with a translucent or cutout image (such as
binoculars).
To add a watermark to your model, follow these steps:
1. Select Window > Styles to open the Styles browser.
2. Select the Edit tab.
3. Select the Watermark Settings icon (
). The Display Watermarks checkbox is
selected by default and needs to be selected so that your watermark appears in your
model.
4. Click the Add Watermark icon (
). The Choose Watermark dialog box appears.
5. Navigate to the image saved on your hard drive that you want to insert as a watermark,
select the file, and click Open. You can import the following image file
types: .jpg, .png, .psd, .tif, .tga, .bmp.
6. In the Create Watermark dialog box that appears, type a descriptive name for your
watermark in the Name box. Select either the Background or Overlay radio button
to indicate whether you want the watermark to appear behind or in front of your model.
When you’re ready, click Next.
7. (Optional) On the next pane of the Create Watermark dialog box, select the Create
Mask checkbox to create a vignette-like mask of your image. When Create Mask is
selected, the white portion of the graphic becomes transparent and black areas use the
background color.
8. (Optional) Click and drag the Blend slider to set how transparent your watermark is.
The closer the slider is to the Background side of the slider, the more transparent the
watermark appears.
9. Click Next.
10. Select a radio button to set your watermark’s position. You can stretch the watermark
across the whole screen; tile several instances of the watermark across the screen; or
position the watermark in a corner, on an edge, or in the center of the screen.
11. (Optional) If you stretch your watermark, you can deselect the Lock Aspect
Ratio checkbox to distort your image’s dimensions so that the image fits the whole
screen. If you tiled or positioned your watermark, you can click and drag
the Scale slider to make your watermark larger or smaller than its current size.
12. Click Finish if you’re done creating your watermark. You can also click Previous to go
back and change a selection; click Cancel if you decide you don’t want the watermark
after all or to start over.
In the following figure, you see a logo watermark inserted as a background, made somewhat
transparent, and positioned in the upper-left corner of the drawing area.
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After you create your watermark, you can edit the watermark by following these steps:
1. Select the watermark in the Styles browser’s list of watermarks.
2. Click the Edit Watermark Settings icon (
).
3. In the Edit Watermark dialog box that appears, change any options you want to modify.
The options you can change include the watermark’s name, masking, blend, positioning,
and scale.
4. Click OK when you’re done editing your watermark.
To delete a watermark, select it in the Styles browser’s list of watermarks and click the Delete
Watermark icon (

)

Tip: If you have more than one watermark, click the Move Watermark Up (
Watermark Down (

) or Move

) icon to set how the watermarks are layered in your model.
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Printing Views of a Model in Microsoft Windows
To print your model in Microsoft Windows, you can select File > Print, click OK, and your
model prints using the existing settings.
If you want to customize the paper size, scale, number of copies printed, print quality, and
more, you need to choose your settings in the Print Setup dialog box and then either the Print
Preview or Print dialog box. The following sections help you wade through the options.
Tip: When you print your model, SketchUp takes your current view into account. When the
camera is set to a Top or Iso view, your print will reflect that Top or Iso view. See Viewing a
Model for details about basic view options. If you want to print specialized views, check out
how to make section cuts, save specific views as scenes, or view a walkthrough of your model.
SketchUp is great at modeling in 3D. If you're a SketchUp Pro user, however, you also have
LayOut, which is great at 2D. When you need to print a SketchUp model, see whether inserting
your model in a LayOut document provides the flexibility and options you need for a top-notch
printout. The LayOut section of the Knowledge Center can help you start using LayOut.
Table of Contents
1. Selecting Page Setup options
2. Selecting Document Setup options
3. Selecting Print options and printing your model

Selecting Print Setup options
In the Print Setup dialog box, you select what printer, paper, and orientation you’d want to use
for your printout.
The following steps walk you through your options:
1. Select File > Print Setup. The Print Setup dialog box appears, as shown in the
following figure.
2. From the Name drop-down list, select the printer you want to use.
3. Click the Properties button to configure your printer options. The properties you can
set depend on your printer, so see your printer’s documentation for details about your
options and how they work.
4. From the Size drop-down menu, select a paper size. Your options reflect the paper sizes
that your printer supports.
5. From the Source drop-down list (sometimes called the Location drop-down list,
depending on your system), select a printer tray, if your printer has more than one. If
you see an option for borderless printing, selecting it tells the printer to print without
margins.
6. In the Orientation area, select the Portrait or Landscape radio button.
7. When you’re done selecting options, click OK.
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Selecting Print Preview or Print options
After you select your Print Setup options, you’re ready to select your printing options in the
Print Preview or Print dialog box.
Tip: The Print Preview and Print dialog boxes contain the same options, and selecting options
in one dialog box sets your options in the other. The only difference is that the Print Preview
dialog box displays a preview of your printout instead of sending your print job directly to a
printer. The following steps focus on the Print Preview dialog box, because checking a preview
of your printout before you print can save you time and ink.
Note: If you want to print your model to a specific scale, you need to select Camera >
Standard Views and select one of the standard views from the submenu that appears. You
also need to switch from Perspective view (SketchUp’s default view) to Parallel Projection
view. Viewing a Model explains how to change your view. You can also watch the video Printing
to Scale with SketchUp
To set your printing options in the Print Preview dialog box, follow these steps:
1. Select File > Print Preview. The Print Preview dialog box appears, as shown in the
following figure. The printer you selected in the Print Setup dialog box appears at the
top. You can change your printer and printer properties again if you like or proceed to
the next step.
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2. To print the current view, leave the Current View radio button selected in the Tabbed
Scene Print Range area. If your model contains scenes, you also have the option of
printing one or more of your scenes. To do so, select the Scenes radio button and
indicate the range of scenes that you’d like to print.
3. (Optional) To print more than one copy of your model, enter a number in the Number
of Copies box.
4. (Optional) By default, when you print the current view, the Fit to Page option, which
tells SketchUp to size your print so that it fits on the selected paper size, is selected. To
change the print size, deselect the Fit to Page checkbox and enter a value in
the Width or Height box. The other value (Width or Height) adjusts automatically to
maintain the model’s proportions.
Tip: You can make the print size larger than the paper size, so that the image of your
model tiles across several pages.
5. (Optional) To ensure that the model fits within the print, select the Use model
extents checkbox. This option only zooms to the model extents if the current view
contains the entire model. If the view is zoomed in too close to the model, this option
won't work.
6. (Optional) To print to scale, first deselect the Fit to Page checkbox. In the Scale area,
you set the scale by typing a value for the printed geometry in the In the Printout box
and a value for the model geometry in the In SketchUp box. For example, to set a 1:4
scale, enter 1 in the In the Printout box and 4 in the In SketchUp box.
7. (Optional) If your print size or scale makes your print larger than the paper size you
selected, leave the All radio button selected to print all the tiled pages. To print only
selected tiles, select the Pages radio button and enter the range of tiles you want to
print.
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8. From the Print Quality drop-down menu, select your desired quality.
o The Draft option, which prints quickly but produces a low-quality image, is great
when you need a rough copy for a meeting or to show a colleague.
o The Standard option balances speed and quality.
o The high-definition options produce high-quality images but take longer to print.
Use the high-quality options when you’re printing a model for an important
presentation or to send to a client.
o The Large Format option optimizes the printout for large-format prints such as
plotters and tiled sheets; this option sets the image resolution and line weights
to make your printout easy to see from far away.
9. (Optional) If your model has a 2D section slice, select the 2D Section Slice
Only checkbox to print the slice.
10. (Optional) Select Use High Accuracy HLR to send the model information to the printer
as vector data.
11. When you’re done selecting all your options, click OK. A preview of your printout
appears on-screen.
12. If you’re happy with the preview, click the Print button to start the printing process. If
you need to make adjustments, click Cancel, reopen the Print Preview dialog box, and
make your changes.
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Printing Views of a Model in Apple macOS
To print your model in Apple macOS, you can select File > Print, click the Print button, and
your model prints using the existing settings.
If you want to customize the paper size, scale, number of copies printed, print quality, and
more, you need to choose your settings in the Page Setup, Document Setup, and Print dialog
boxes first. The following sections help you wade through the options.
Tip: When you print your model, SketchUp takes your current view into account. If your view
in SketchUp is zoomed out, your print will appear zoomed out. When the camera is set to a
Top or Iso view, your print will reflect that Top or Iso view. See Viewing a Model for details
about basic view options. If you want to print specialized views, check out how to make section
cuts, save specific views as scenes, or view a walkthrough of your model.
SketchUp is great at modeling in 3D. If you're a SketchUp Pro user, however, you also have
LayOut, which is great at 2D. When you need to print a SketchUp model, see whether inserting
your model in a LayOut document provides the flexibility and options you need for a top-notch
printout. The LayOut section of the Knowledge Center can help you start using LayOut.
Table of Contents
1. Selecting Page Setup options
2. Selecting Document Setup options
3. Selecting Print options and printing your model

Selecting Page Setup options
The Page Setup dialog box may look familiar: It’s a standard dialog box that appears in all
macOS applications. In this dialog box, you tell your printer what paper size and orientation
you want. To set up your Page Setup options, follow these steps:
1. Select File > Page Setup. The Page Setup dialog box appears, showing the Page
Attributes settings, as shown in the following figure.
2. From the Format For drop-down list, you can leave Any Printer selected if you want
the settings to apply to any printer. If you’re creating settings for a specific printer that’s
already installed on macOS, you can select that printer by name from the drop-down
list. To access your Apple macOS printing preferences, select Printers & Scanners
Preferences.
3. From the Paper Size drop-down list, select your desired paper size.
Tip: If you need to specify a custom size, select Manage Custom Sizes. Click the plus
sign in the lower left to create a new custom size. Then you can enter your desired
paper size and specify custom margins (or Non-Printable Area in the dialog box’s
parlance). When you’re done, click OK to return to the Page Setup dialog box. If you
define a custom paper size, keep in mind that SketchUp doesn’t know whether your
printer is capable of printing on the paper size that you define. Check your printer
documentation to find out what paper sizes your printer can handle.
4. To set the orientation, select the portrait or landscape icon.
5. In the Scale box, type a percentage to reduce or enlarge your model on the printout.
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Tip: If you want to automatically scale your model to fit your selected paper size, leave
this option as is and use the Fit View to Page option in the Document Setup dialog box
or the Scale to Fit Paper Size checkbox in the Print dialog box, both of which are covered
later in this article.
6. If you want the settings you selected to become the defaults, select Save As
Default from the Settings drop-down list at the top.
7. When you’re done, click OK.

Selecting Document Setup options
Whereas the Page Setup dialog box enables you to set up the page for any printout in Apple
macOS, the Document Setup dialog box enables you to configure the print size or scale.
If you want to tile a single printout across several sheets of paper and then tape them together
or if you want to make sure your model prints at a specific scale, the Document Setup dialog
box is the one you need.
Tip: To successfully print a model to scale, select Camera > Standard Views and select one
of the standard views from the submenu that appears. You also need to switch from Perspective
view (SketchUp’s default view) to Parallel Projection view. Viewing a Model explains how the
view options work.
The following steps walk you through your Document Setup options:
1. Select File > Document Setup.
2. If you want to customize the print size (not to be confused with the paper size) or your
model’s print scale, deselect the Fit View to Page checkbox. Otherwise, you probably
want to leave this option selected.
3. (Optional) Set a custom size by entering your desired width or height in
the Width or Height box. You need to enter only one dimension. SketchUp sizes the
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other dimension to preserve the print’s aspect ratio.
Tip: Here’s an example to illustrate how the Print Size option works. Say your paper
size is 8.5 inches wide and 11 inches tall. If you set the print width at 16 inches in the
Document Setup dialog box, your print size will be larger than your selected paper.
When you print your model view, your printout is split among several sheets of paper
to create your desired print size.
4. (Optional) Set a scale for your printout. The In Drawing box is the measurement in
your printout, and the In Model box is the object’s actual measurement. For example,
for a scale of 1:4, enter 1” in the In Drawing box and 4” in the In Model box.
5. Click OK to save your settings.
Tip: If you set a print size or scale that makes your model larger than the selected paper size,
you can see how many pages are needed to print your model in the Pages Required area of the
Document Setup dialog box.

Selecting Print options and printing your model
After you set up your page and document, you’re ready to set options in the Print dialog box.
This is where you choose what printer to use, how many copies you want, and whether you
want to print a draft or high-quality printout. This dialog box is the standard Print dialog box
for all Apple macOS applications.
Follow these steps to set your options in the Print dialog box:
1. Select File > Print. The Print dialog box appears, as shown in the following figure. You
see a preview of your printout on the left.
2. Select which printer you want to use from the Printer drop-down list.
3. (Optional) If you’ve created presets in Apple macOS, you can select them from
the Presets drop-down list. Otherwise, leave the Default Settings option selected.
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4. (Optional) In the Copies box, type the number of copies you want to print. The default
is 1 copy.
5. (Optional) When you’re printing a model view from SketchUp, you likely want to print
all the pages if you setup your print so that it’s larger than a single page. However, you
can select to print a specific page range here.
6. Select a Print Quality that reflects how you intend to use your printout. If you just
need a quick, low-quality copy to show a colleague or take to a status meeting,
select Draft. If you need a high-quality copy that you plan to print on glossy photo
paper and send to a client, select High or Extra High (for measured drawings or ultrafine prints). The default is Standard, which uses more ink than Draft but prints faster
than the higher-quality options.
7. (Optional) To send your model information to the printer as vector data, select
the Vector Printing checkbox.
8. (Optional) To make the lines thinner or thicker than the default of 0.5 points, select a
new line thickness from the Line Weight drop-down list. You can also type a value in
the text box.
9. When you’ve selected all the options you want, click Print to send your printout to the
selected printer.

Note: This section covers the SketchUp print options. To see other options, open the dropdown list in the middle of the Print dialog box, where you can choose to set layout, color, paper
handling, cover page, and other print options, all of which are part of Apple macOS.
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3D Printing a Model
Before you print a model on a 3D printer, you need to make sure your 3D printer can
understand your model data. Here’s a quick overview of how to set up your SketchUp model
for 3D printing:
•

•

•

•

Orient your model so that the 3D printer has a base on which to build your
model. Your 3D printer prints your model one layer at a time. If your model juts out at
the top, the 3D printer has nothing to build upon. For example, if you want to 3D-print
a gear, rather than orient the gear vertically, place the gear on its side, as shown in the
following figure.
Make sure your model is a solid group. With your group or component selected,
choose Window > Entity Info. If your model is a solid group, the Entity Info window
tells you so in the upper left, also shown in the following figure. If your group or
component isn’t solid, download and install the Solid Inspector 2 extension created by
Thomas Thomassen and available via the Extension Warehouse. (In SketchUp,
select Window > Extension Warehouse, search for the extension, and click the
red Install button.) This extension helps you analyze why your model isn’t solid and
repair and holes or issues. For example, if your model contains internal geometry, then
your model is not a solid.
Check that the fronts of faces point outward. (And thus, the backs of faces need
to face inward.) Technically, making sure all your faces are oriented the correct way is
called checking the normals. To check that the face fronts point outward in SketchUp,
select View > Face Style > Monochrome to see whether the back sides of a any faces
point outward. By default, the face fronts are white and face backs are dark gray. To
reverse a face, context-click it and select Reverse Faces. If you use Solid Inspector 2,
the extension can find and fix the reversed faces for you.
Your model needs to have a volume. For example, if you want to print a box that’s
hollow in the middle, the faces along the outside of the box need to have a thickness,
as shown in the following figure.

After you check that your model is ready to be 3D printed, you need to output your model to
a format your 3D printer understands, also known as the STL format. To export your model as
an STL file,see Importing and Exporting STL Files for 3D Printing
Note: As 3D printing technology improves, SketchUp users are sharing new tips and tricks for
great 3D-printed models all the time. To connect with other SketchUp users, check out
the SketchUp User Forum.
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Print to Scale
SUBSCRIPTION
Paid subscribers and SketchUp for Schools users have access to additional functionality
in SketchUp for Web for scaled prints. Switch the Print Mode drop-down to Print to Scale to set
up a one-page scaled-print.

In Print to Scale mode, your print preview is rendered with SketchUp's parallel projection
camera. You can still pan, orbit, and zoom your model: but now, as you zoom, the implied
scale of your drawing will change. Similarly, changing paper size will change the implied
drawing scale.
To choose a specific drawing scale, simply type in the scale you prefer and the print preview
will resize your print. Note: zooming in or out will change this scale once you’ve set it.
Click Print Scale to display the scale of your drawing on your print if you like.
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Tip: If you have documented a scene in your model for printing, you can still choose this scene
in Print Preview, and then switch to Print to Scale mode to create a scaled version of your
scene. This works best for plans and elevations which are already composed with a parallel
projection camera setting.
Note: At this time, SketchUp for Web supports only one-page prints.
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Using SketchUp Data with
Modeling Programs or Tools

Other

When you want to use SketchUp with other modeling programs or tools, that typically means
you need to either
•
•

Import a file from another program into SketchUp.
Export your SketchUp model into a file format that works with another program.

Tip: When this article refers to other modeling programs or tools, that means programs outside
the SketchUp family of software and tools. If you want to open a 3D model as a
document in LayOut, create your own styles in Style Builder, or share models on SketchUp
Mobile Viewer or the 3D Warehouse, these programs and tools are designed to work directly
with SketchUp. Each of the these applications has its own section in the Knowledge Center,
which can help you get up to speed quickly and easily.
Here, you find subarticles about working with CAD files, different types of image files, and other
file formats designed for sharing 3D modeling data between applications. To import or export
some of these files, you need a SketchUp Pro license or active SketchUp for Web, Shop Edition
subscription. The following table has a full list of the different types of files you can import into
and export from SketchUp.
Note: The SketchUp Subscriptions have additional import and export options as well.
File Type
CAD files

File
Extension(s)
.dwg, .dxf

SketchUp Pro
and Shop Only?

Learn More Here

PRO and SHOP only

Importing and Exporting CAD
Files and Starting with a CAD
File in SketchUp

.jpg, .png, .tif, .b Some file types
Importing and Exporting
mp, .psd, .tga, .p are PRO and SHOP onl
Image Files
df, .eps
y
Importing and Exporting
COLLADA files
.dae
COLLADA Files
PRO and SHOP neede Importing and Exporting 3DS
3D Studio (3DS) files .3ds
d for export
Files
Digital elevation
Importing DEM Files for
.dem, .ddf
models (DEM files)
Terrain
FBX files
.fbx
PRO and SHOP only
Exporting FBX Files
Exporting KMZ Files for
Google Earth files
.kmz
Google Earth
OBJ files
.obj
PRO and SHOP only
Exporting OBJ Files
VRML files
.wrl
PRO and SHOP only
Exporting VRML Files
XSI files
.xsi
PRO and SHOP only
Exporting XSI files
IFC files
.ifc
PRO only
Exporting IFC files
Image files

Tip: If you export your SketchUp model to another file type and receive an error, the
article Solving a Blank Dialog or SDK Error When Exporting may help you resolve the problem.
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Note: The Epix (*.epx) image file format was deprecated and removed from SketchUp Pro
2016.
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Importing and Exporting CAD Files
If you're a SketchUp Pro user, you can import or export CAD files, which use
the .dwg or .dxf file formats.
Before you import a file, it's helpful to know what CAD entities SketchUp Pro does and doesn't
support and how to prepare your CAD file for best results. Then, you can walk through the
basic importing steps outlined in this article. After you're done importing, check out Starting
with a CAD File in SketchUp Pro, which offers several tips and tricks for handling imported CAD
geometry.
If you're exporting a SketchUp Pro file to a CAD format, how you import a CAD file depends on
whether it's a 2D file, such as a floor plan, or a 3D model. In this article, you also discover how
SketchUp data is exported into CAD format.
Table of Contents
1.
2.
3.
4.
5.
6.

Understanding what CAD elements SketchUp can import
Preparing a CAD file for import into SketchUp
Importing a CAD file into SketchUp
Understanding how SketchUp data is exported to CAD format
Exporting a SketchUp Model as a 2D CAD file
Exporting a SketchUp Model as a 3D CAD file

Understanding what CAD elements SketchUp can import
The following table outlines what CAD elements SketchUp does and doesn't support. If an
element isn't supported, SketchUp simply ignores it when you import the CAD file.
Supported CAD Entities
Arcs
Circles
Entities with thickness
Faces
3D faces
Layers
Lines and supported Line Styles
Materials
Polyline-based solids
Nested blocks
AutoCAD regions
Point
Ellipse
Spline
RasterImage

Unsupported CAD Entities
Proprietary ADT or ARX objects
Dimensions
Hatching
Text
XREFs

Preparing a CAD file for import into SketchUp
When you take a few steps to check and prepare your CAD file before import, you can make

SketchUp Help Pages – version 19.

Page 453/567

sure all the data you need imports into SketchUp and streamline the import process. The
following sections outline what you need to look for and how to resolve any potential conflicts
between CAD elements and SketchUp.
Tip: You don't want to lose details in your original CAD file. Remember to create a copy of the
CAD file and prepare that copy for importing into SketchUp.
Change unsupported elements
If you need to import unsupported CAD elements into SketchUp, try exploding those elements
in CAD so they become primitive CAD drawing elements that SketchUp does support.
For example, when you explode CAD objects into block entities, they import into SketchUp as
components. If you explode the CAD block entities into polylines, the polylines import into
SketchUp as lines or polylines.
Delete unnecessary layers
In an imported CAD file, SketchUp automatically discards any entities that have no 3D
relevance, such as text, dimensions, hatching, and so on. However, SketchUp won't discard
the layers holding these entities. To avoid a bunch of empty layers in SketchUp, you may want
to purge any unused layers through Statistics on the Model Info dialog.
Move geometry close to the origin
In SketchUp, geometry that's many miles or kilometers away from the origin (0,0) can cause
performance problems. To avoid these problems, check the placement of geometry in your
CAD file before you import the CAD file into SketchUp.
For example, say you're importing Autodesk AutoCAD DWG files, such as civil site plans, in
order to work with the contour lines. If the graphic or geometry is far away from the origin,
move it close to the origin before importing the CAD file into SketchUp.
Alternatively, deselect the Preserve Drawing Origin option in SketchUp's DWG/DXF import
options, as explained in Importing a CAD file into SketchUp, later in this article.
Reduce the file size if needed
Generally, CAD files import into SketchUp successfully when the file size is 15MB or less. When
you import larger CAD files, the import can take a long time or may fail. Conversely, the smaller
your CAD file size, the quicker and easier the import. Also, after a complex CAD file is imported
into SketchUp, you may notice that SketchUp's performance slows down. That's because lines
and faces in SketchUp contain more data than their CAD equivalents.

Tip: For best results with imported CAD files, keep the size of imported files to a minimum.
Here are a few tips for minimizing a CAD file before you import it into SketchUp:
•

Import only the necessary geometry. SketchUp models can be designed to be as
accurate as models in CAD. However, SketchUp is not designed for the same type of
line-intensive drawings done in CAD software. In your CAD file, clean up or remove any
content that you don't need to use after you import the CAD file into SketchUp. You
might simplify the CAD file to just walls — and maybe doors and windows if you want
to model those in your SketchUp file, too.
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Separate levels of detail among different CAD files. If your CAD file holds lots of
necessary geometry, consider whether you break one file into a few smaller files. For
example, one imported CAD file can contain site plan information, another can have a
floor plan, and a final file can have a specific detail.

Check the unit of measure
If possible, find out the unit of measure used to create the CAD file. When you import the CAD
file into SketchUp, you need to know whether your file uses inches, feet, or a metric unit of
measurement. That way, you can match the SketchUp model's units to the CAD file's units and
thus maintain the scale and dimensions of your imported CAD geometry.
In SketchUp 2018 and later, you also have the option to import the model using the units
specified in the CAD file. In the Units dropdown, select Model Units from the list, which tells
SketchUp to attempt to match the units saved in the CAD file. If SketchUp is unable to
determine what unit of measurement was used to create the CAD file, it will default to 1 CAD
unit equals 1 inch in SketchUp.
Save in a SketchUp-compatible CAD file format
When SketchUp imports a CAD file, SketchUp strips the information to its basic geometric
components. So no matter what AutoCAD file format you use (such as 2013 or 2018), the end
result is essentially the same. To maximize compatibility between a CAD file and SketchUp,
however, saving your CAD file in the Release 13 or Release 14 format works best.

Importing a CAD file into SketchUp
After you've checked and prepared your CAD file, you're ready to import it into SketchUp. The
following steps walk you through the import process for your operating system:
1. In SketchUp, open the SketchUp model into which you want to import
your .dwg or .dxf file.
2. Select File > Import. An Import dialog box appears.
3. Navigate the the place your hard drive where your CAD file is saved.
4. From the Files of Type drop-down list, select AutoCAD Files (*.dwg, *.dxf).
5. Select the file you want to import.
6. Click the Options button. The Import AutoCAD DWG/DXF Options dialog box appears,
as shown in the following figure.
7. (Optional) In the Geometry area, select your preferences for the following options:
o select Merge Coplanar Faces to tell SketchUp to automatically remove
triangulated lines from planes.
o Selecting the Orient Faces Consistently box tells SketchUp to analyze the
direction of imported faces and orient the faces so that their direction is uniform.
8. (Optional) Select the Preserve Drawing Origin checkbox to place the imported geometry
at the origin defined in the .dwg or .dxf file. Leave the checkbox deselected if you want
to place the imported geometry near the SketchUp origin.
9. (Optional) To import geometry at the correct scale, select the unit used in your CAD file
from the Units drop-down list. Your options are Model Units, Inches, Feet, Yards, Miles,
Millimeters, Centimeters, Meters and Kilometers.
Tip: If you don't know the units used in the original file, select Model Units so that
SketchUp turns one CAD unit into 1 inch in SketchUp. Or use a large unit type, such as
feet or meters. Then you can resize the model as necessary after it's imported.
Warning: If you select a small unit, such as millimeters, but the model was originally
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intended to display in feet, you can unintentionally create itty-bitty faces that will be
lost on import. For SketchUp to recognize a face, the face must be .001 square inches
or larger.
10. Click OK in the Import AutoCAD DWG/DXF Options dialog box.
11. Back in the Import dialog box, click the Import button, and SketchUp Pro begins
importing your CAD file.
Tip: When importing a LayOut file created using the “Export for SketchUp” feature, use the
Merge Coplanar Faces option for clean imported faces.
Tip: You can also drag and drop importable files into the drawing area. After you drop the file,
any relevant Import dialog box opens so you can select your desired options.

Tip: If you have a floor plan or other vector graphics in an Adobe Illustrator (.eps) file, you
can export the .eps file to .dwg or .dxf format in Illustrator. Then import the vector graphics
following the preceding steps. If, in Adobe Illustrator, you first reduce the number of anchor
points that define curves, you can improve the file's performance in SketchUp. In particular,
when you extrude faces from curves that contain lots of line segments, the SketchUp file size
can increase dramatically.

Understanding how SketchUp data is exported to CAD format
Before you export a SketchUp model to a CAD file format (.dwg or .dxf), you may find it helpful
to understand how SketchUp data is translated into the CAD format that you choose. Here's
what you need to know:
•
•

SketchUp faces are exported as a triangulated polyface mesh with interior splframe
hidden lines (if applicable). This conversion helps to simulate the appearance of your
SketchUp file, even when all exported faces are triangular.
SketchUp uses the current units set in the Units pane of the Model Info dialog box as a
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reference for translation to a .dwg or .dxf file. For example, if the current Model Info
unit setting is Decimal and Meters, then AutoCAD must be set to decimal for the units
to translate correctly as meters when you open the exported file in AutoCAD.
Duplicate line entities aren't created on top of a p-line entity.

Exporting a SketchUp Model as a 2D CAD file
When export your model view as a 2D CAD file, you can choose the scale and a number of line
options. The result is a 2D vector file in .dwg or .dxf format that you can open in your CAD
program.
Follow these steps to export a 2D CAD file:
1. To maintain your model's scale in the exported file, in SketchUp, select Camera >
Parallel Projection. Then set your view to one of SketchUp's standard views by
selecting Camera > Standard Views and selecting an option from the submenu that
appears. (See Viewing a Model for details about the model view options.)
2. Select File > Export > 2D Graphic.
3. Navigate to the place where you want to save your exported file.
4. (Optional) Change the file name if you'd like to name the exported file something other
than the SketchUp file's current name.
5. Select either the .dwg or .dxf file type. In Microsoft Windows, select this option from
the Save As Type drop-down list. On a Mac, use the Format drop-down list.
6. Click the Options button to set the scale and line options, which are explained in detail
in the upcoming list. When you're done, click OK in the DWG/DXF Hidden Line Options
dialog box (Microsoft Windows) or the Export Options dialog box (Apple macOS).
7. Click Export and your CAD file is saved in your selected location.
In the following figure, you see the line options dialog box for your current operating system.
The following list introduces your options so that the lines in your exported file meet your
needs:
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AutoCAD Version: Select what version of AutoCAD you'd like to use to open the
exported file.
Drawing Scale & Size: The Full Scale checkbox is selected by default. However, if
you deselect that checkbox, you can set a custom scale. In the In Drawing box, type
the actual measurement you want to use to set your scale. In the In Model box, type
the value for scaling your exported model. For example, for a scale of 1:4, type 1' in
the In Model box and 4' in the In Drawing box.
Profile Lines: Here, you can customize how profile lines appear in your exported file.
You can set the line width as follows:
o Select None to export profile lines at the standard width.
o Select Polylines with Width to export profile lines as AutoCAD polylines. When
you select this option, you can leave Automatic selected so that the exported
lines match the profile line width. If you deselect Automatic, you can enter a
custom width in the Width box.
o Select Wide Line Entities to export profile lines as AutoCAD wide line entities.

The Separate on a Layer checkbox, which is selected by default, creates a layer for
profile edges. If you've used SketchUp layers to control visibility, note that SketchUp
layer assignments don't translate directly when you export a SketchUp file to a 2D CAD
file.
• Section Lines: If you export section lines or a section slice, these export options
become available. See Slicing a Model to Peer Inside for details about sections and how
to export them.
• Edge Extensions: Some CAD applications might have problems recognizing line
endpoints and intersections when your model uses SketchUp line extensions. Deselect
the Show Extensions checkbox to toggle extensions off in your exported file. If you
leave Show Extensions selected and deselect the Automatic checkbox, you can enter
an exact length for line extensions in the Length box.
In Microsoft Windows, you can select the Always Prompt for Hidden Line Options if you'd
like to set options in this dialog box anytime you export a 2D CAD file. You can also restore the
default settings by clicking the Defaults button.

Exporting a SketchUp Model as a 3D CAD file
When you export a SketchUp model as a 3D CAD file, you can select what entities are exported.
To export your model, follow these steps:
1. In SketchUp, select File > Export > 3D Model. The Export Model dialog box appears.
2. Navigate to the location where you want to save your exported file.
3. (Optional) Change the file name if you like. By default, the exported file uses the same
name as your SketchUp file name.
4. Select either .dwg or .dxf as the file format for your exported file. In Microsoft Windows,
select your file type from the Save As Type drop-down list. In Apple macOS, use
the Format drop-down list.
5. Click the Options button to open the Export Options dialog box, shown in the following
figure. From the AutoCAD Version drop-down list, select the version of AutoCAD you'd
like to use to open the exported file. In the Export area, select the checkbox for each
type of entity that you want to include in the exported file. Click OK when you're done.
6. Back in the Export Model dialog box, click Export, and your file appears in the location
where you chose to save it.
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Tip: Export and Import with materials for better BIM interoperability and workflows using the
.dwg format.
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Starting with a CAD File in SketchUp
Like many SketchUp users, you may want to use your CAD files to create excellent, useful, and
lightweight SketchUp models. Importing and exporting common CAD file formats has always
been part of SketchUp's DNA, but CAD files imported into SketchUp do have a few known quirks
that you can sidestep if you know the tips explained in this article.
Here are the known issues that you may find after you import a CAD file into SketchUp:
•
•

The size or scale may not import correctly. This is especially true if you weren't
sure what unit of measurement was used to create the CAD file. (See Importing and
Exporting CAD Files for details about matching the units.)
The lines in an imported CAD file often don't connect to form SketchUp
faces. Hunting down all these little gaps can be tedious — unless you know a few tricks
explained in this article.

Whether you've never worked with a CAD file imported into SketchUp before or have lots of
experience importing CAD files, the tips and examples in the following sections can help you
quickly start modeling with your file in SketchUp.
Tip: To import CAD files into SketchUp, you need a SketchUp Pro license.
Table of Contents
1. Preparing an imported CAD file for modeling in SketchUp
2. Building a model from a CAD floor plan
3. Adding doors and windows to the model

Preparing an imported CAD file for modeling in SketchUp
After you import a CAD file, following these steps can help you make sure the CAD file is ready
for modeling. These steps assume that you don't create a 3D model directly from the CAD
geometry, but instead, use the CAD geometry as a reference for creating a SketchUp model.
Tip: Why use the CAD file as a reference? The main reason is because CAD geometry is often
way too complicated to create a useful SketchUp model. When in doubt, re-creating the model
with SketchUp's native drawing tools typically produces better and more consistent results than
trying to manipulate the imported CAD geometry. Also, imported CAD geometry is likely full of
gaps that need to be closed to create faces. If you've imported a floor plan, for example,
drawing over a floor plan to create a new model is easier than hunting and pecking to find and
fix all those gaps. If you need to use your CAD geometry, however, check out the Edge Tools
2 extension by user ThomThom. This extension can clean up terrain and CAD files for you by
simplifying curves and closing gaps. For details about installing extensions, see Adding
Extensions to SketchUp
Here's a recommended workflow for getting an imported CAD file ready for modeling in
SketchUp:
1. Check the size of the imported CAD geometry. Choose an entity with a
measurement you know and check its size with the Tape Measure tool (

). If the
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size is incorrect, the Tape Measure tool also enables you to scale the entire model so
that the dimensions are correct.
2. Make sure the CAD geometry is a single group. If your SketchUp model contained
any geometry before the import, the imported CAD geometry is grouped
automatically.If not, beginning with SketchUp 2018, the geometry is imported as a
component. (Earlier versions of SketchUp require you to select the imported geometry
and create a group manually.)
3. Line up the floor plan with SketchUp's drawing axes using the Rotate tool (

4.
5.
6.
7.

) or the Axes tool (
). For example, you want the right angles in a floor plan to
line up with the red and green axes, so that the SketchUp inference engine makes
drawing over your floor plan easy.
Delete extra layers and place the CAD group on a new layer.
Tip: In Controlling Visibility with Layers, you find an introduction to SketchUp's layers
feature and a video with tips for cleaning up layers in imported CAD files.
Lock the group by context-clicking it and selecting Lock. You lock the group
because you don't want to edit it, but use it as a reference for creating a model in
SketchUp.
Adjust the edge styles. This step depends on your preferences, but you might want
to turn off profiles in the Styles browser so that all the lines are same width.
Create scenes to toggle layer visibility. Basically, create two scenes where visibility
is the only attribute saved in each scene. In the first scene, make the CAD group's layer
visible. In the second scene, hide the group's layer. See Creating Scenes for details
about creating and customizing scene tabs.
Tip: Although you can also toggle layer visibility with the Layers manager, creating
scenes enables you to toggle the views with tabs at the top and close the Layers
manager so it's out of the way.

Building a model from a CAD floor plan
In the following video, you see one workflow for creating a floor plan from an imported CAD
drawing. The basic process works as follows:
1. With the Rectangle tool (

), draw rectangles to fill the outline of the building.

2. With the Eraser tool (
), delete any interior rectangle lines, so you have one face in
the shape of the building's outline.
3. To create an exterior only, use the Push/Pull tool (

) to create a volume in the shape

of the building. Or use the Offset tool (
) to create exterior walls, and then trace
inside each room with the Rectangle tool or other shapes tools to model faces for the
interior walls.
The technique shown in the following video illustrates how to use the CAD geometry as a
reference for creating a new 3D model of a building, but the basic process is helpful whether
you're creating a new model or fine-tuning imported CAD geometry of a floor plan.

Adding doors and windows to the model
To add doors to a floor plan, you can create one door at the desired height and copy it wherever
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you need other doors.
For windows, create guides to set the first window at the correct height. After you place one
window, copy it, and let the SketchUp inference engine help you place other windows at the
correct height as well.
In this video16, you see both of these techniques in action.

16

https://youtu.be/bXbyrZnqxOM
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Importing and Exporting Image Files
In SketchUp, images can help your model come to life on-screen. You can import images to
create custom textures that you apply to faces in your 3D model. And you can export images
to share a model with friends, clients, or colleagues or perhaps in an online portfolio of your
work.
Most of the details about importing images is covered in Creating a 3D Model, but this article
outlines all the ways you import and export images and directs you to the pertinent details in
other articles.
You can work with images in an array of file formats. In the following table, you find an overview
of the raster versus vector images that SketchUp supports. Later in this article, you find a more
detailed explanation of the differences between raster and vector files and tips for when to
choose among the possible file types.
Image Format
JPEG
PNG
TIFF
BMP
PSD
TGA
PDF
EPS

Raster or
Can Export
Can Import into SketchUp
Vector?
SketchUp
Raster
Yes
Yes
Raster
Yes
Yes
Raster
Yes
Yes
Raster
Yes
Yes
Raster
Yes
Yes
Raster
Yes
No
Vector
No
PRO only Yes
Vector
Convert to CAD format
PRO only Yes

from

Last but not least, you find detailed steps that walk you through the process and options for
exporting raster and vector images in SketchUp or SketchUp Pro.
Table of Contents
1.
2.
3.
4.

Importing images
Understanding raster and vector images and their file formats
Exporting a raster image
Exporting a PDF or EPS vector image

Importing images
In SketchUp, you can import images in a few different ways, depending on how you want to
use them in your model. Check the following articles for details:
•
•
•
•

To trace an image with the SketchUp drawing tools for a floor plan or other drawing,
see Tracing an Image.
To import an image that you want to use as a custom texture in the Materials browser,
see Adding Colors and Textures with Materials.
To import a photo and apply it over a whole face, check out Sticking a Photo or Texture
to a Face.
To import images via the Match Photo feature, Matching a Photo to a Model (or a Model
to a Photo) explains how in detail.
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To import a vector image as terrain, you need to export the vector image as
a .dwg or .dxf file in your image editor, such as Adobe Illustrator, and then follow the
steps in Importing and Exporting CAD Files to import the vector image as geometry,
rather than a 2D image.

Tip: You can also drag and drop importable files into the drawing area. After you drop the file,
any relevant Import dialog box opens so you can select your desired options.
To manage file sizes and image quality, follow these tips:
•

•
•

Size images no larger than 1024 x 1024 pixels. That’s the maximum size of an image
that can be imported into SketchUp. If you use an image that exceeds the maximum,
SketchUp automatically downsizes the file using a medium-quality sampling
mechanism. However, your image looks better if you size the photo yourself in an
image-editing program like Adobe Photoshop (one that supports bicubic resampling).
Crop your image to include only the portion of the image to be used. Doing so keeps
your SketchUp file size small, especially if you plan to use the image as a custom
texture.
Save the file as a high-quality JPEG file.

Understanding raster and vector images and their file formats
In SketchUp, you can import and export raster image files. In SketchUp Pro, you can also
export vector images. If you’re unfamiliar with the differences among image formats and the
image file formats that SketchUp supports, this section introduces you to the basics.
•

•

Raster images are made up of square, colored pixels that combine to create an image.
Because a raster image has a certain number of pixels, you can usually decrease the
image size and still have a good-looking image. However, the more you increase the
image size, the more blocky a raster image looks. A raster image’s resolution tells you
how many pixels the image has. In SketchUp, you use raster images for textures,
backgrounds, watermarks, and so on. You can export a model view as a raster image
file to share with a client, create a presentation, and much more.
Vector images don’t have a resolution. Instead, mathematical algorithms work behind
the scenes to create a vector image. The advantage is you can make vector images as
big or small as you like, and they still look good. However, vector images work best
with lines, curves, and flat colors. Vector images are useful for creating a set of 2D
construction documents, plotting a perspective in a large format, or importing into
vector illustration software for further editing. (LayOut has vector image-editing
capabilities.)

SketchUp supports several different raster image formats, each of which has its own
advantages. Here’s a quick overview of the raster file formats that work with SketchUp:
•

•

JPEG (Joint Photographic Experts Group): Many applications, computer platforms,
and digital cameras support JPEG files, which have the file extension .jpg. JPEG
compression can reduce file size to a fraction of other formats, which is useful when you
need to email an image or share it on a website. However, compressing a JPEG image
discards information from the image, and you can create a blocky or low-quality image
if you apply too much compression.
PNG (Portable Network Graphics): The PNG format was developed for transferring
images efficiently over the world wide web without data loss. Unlike JPEG, PNG
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compression doesn’t discard data from the image file. When you export PNG files from
SketchUp, the image can maintain the transparency of materials such as glass.
TIFF (Tagged Image File Format): TIFF is primarily used for high-resolution printing,
and thus, images in the TIFF file format hold a lot of image data but also tend to be
large. SketchUp supports as wide a range of TIFF formats as possible, and you should
test compatibility with other applications before exporting to TIFF file. 1-bit raster files,
or TIFF files with GIF encoding, are not compatible with SketchUp. You can also export
TIFF files with transparency.
BMP (Bitmap): The BMP file format was created for Microsoft Windows operating
systems primarily as the format used for the Microsoft Windows clipboard and for
viewing (especially as wallpaper). BMP does not use compression. Therefore, BMP can
be useful for creating temporary files to be further modified in other applications.
However, BMP tends to create very large files that are not suitable for archive, web, and
email use.
PSD: The PSD format is native to Adobe Photoshop. You can only import images in this
format. However, PSD files tend to be large, so consider whether exporting a PSD file
to JPEG or PNG format first would help improve SketchUp’s performance.

Note: SketchUp 2016 and later versions no longer support the EPix file format for export.
Tip: Most of the time, you likely want to import or export a JPEG or PNG image. Both of these
formats keep file sizes small, can be viewed on any system, and can display lots of colors and
details. The JPEG format is slightly better for photos with lots of details and color variations,
whereas the PNG format is excellent for images with a more limited color palette than a photo.
If you’re printing a high-resolution image of your model, check your printer documentation for
the best file format or ask your printing service whether you should use TIFF.
SketchUp Pro enables you to export to two vector formats:
•

•

EPS (Encapsulated PostScript): This format is based on PostScript, a graphics
description language that Adobe developed as a standard way for graphics programs
and print devices to communicate. EPS is widely used in the graphic design and
publishing industries.
PDF (Adobe Portable Document Format): PDF is the open standard for worldwide
electronic document distribution. PDF preserves a source document’s fonts, formatting,
graphics, and color, regardless of the application and operating system used to create
the document. Also, PDF files are compact, and anyone with free Adobe Acrobat Reader
software can view, share, navigate, and print PDFs.

Exporting a raster image
To export the current view of your SketchUp model as a raster image, follow these steps:
1. Select File > Export > 2D Graphic. The Export 2D Graphic dialog box appears.
2. Navigate to the location where you want to save your image.
3. (Optional) In the File Name box, type a name for your image file. By default, the image
file has the same name as your SketchUp model.
4. From the Export Type drop-down list, select a raster file type. The raster options are
JPEG, PNG, TIFF, or BMP.
5. (Optional) Click the Options button to open the options dialog box for your selected file
type. The options for each file type are listed in the following sections. Click OK to save
your options and return to the Export 2D Graphic dialog box.
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Note: There is a size limit when exporting; the maximum for height and width is 9,999
pixels.
6. Click Export and your file saved in the location you selected.

JPEG options
When you export an image in JPEG format, you have the following options, as shown in the
following figure:

•
•

•

•
•

Use View Size checkbox: Keep this selected to output your image at a 1:1 scale.
Width and Height boxes: Clear the Use View Size checkbox, and you can type a
custom width or height in pixels in the Width or Height box. If you type a width, the
height value adjusts to maintain your image proportions. On macOS, you can click the
chain icon to unlock the aspect ratio and type a custom value in both the Width and
Height boxes.
Line Scale Multiplier: Clear the Use View Size checkbox, and you can also scale lines
in an exported image. The default is 1x and the minimum is 0.25x. The higher the value,
the thicker the lines will appear. For larger images, you might want to increase the line
scale to more than 1 so that lines in your exported image look similar to those in the
drawing area.
Anti-alias checkbox: Selected by default, this option tells SketchUp to smooth jagged
lines and pixelated artifacts in the exported image. Clear this box if you don’t want to
use anti-aliasing.
JPEG Compression slider: Drag the slider to indicate how much compression you want
to apply to your image. More compression creates a smaller file size but can degrade
the image quality, and less compression produces a better quality image but a larger
file.
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PNG and TIFF options
When you export an image in PNG or TIFF format, you have these options, as shown in the
following figure:
•
•
•

In the Image Size area, select how you want to size your image. The options are
identical to the Image Size options for JPEG files.
Anti-alias checkbox: When this option is selected, it smooths jagged edges and
artifacts. To turn it off, clear the Anti-alias checkbox.
Transparent Background checkbox: If you want the model’s background to appear
transparent, select the Transparent Background checkbox.

You see the options dialog box for your current operating system in the following figure.

BMP options (Microsoft Windows only)
When you export a file as a BMP, you can adjust the image size, line scale, and turn off antialiasing. The options work just like the Image Size, Line Scale, and Anti-alias options for JPEG
files.

Exporting a PDF or EPS vector image
In SketchUp Pro, you can export your models as 2D vector drawings in either PDF or EPS
format. However, a few model features or details may be lost or change in the export process.
A better option is to send your SketchUp model to LayOut and print from that application
instead.
If you do need to print your PDF or EPS file from SketchUp, you might notice the following
issues:
•

Graphic features that rely on raster images, such as textures, shadows, smooth shading,
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backgrounds, and transparency, can’t be exported to PDF and EPS vector files.
Tip: If you want to create a raster-based PDF that preserves textures, try printing to
PDF from SketchUp instead of exporting a PDF vector file. Or, export a raster image file
instead of a vector image file. For details about printing in SketchUp, see Printing Views
of a Model in Microsoft Windows or Printing Views of a Model in Apple macOS. For details
about exporting raster images, see the earlier section, Exporting a raster image.
•
•

When other geometry hides text and dimensions, the text and dimensions appear on
top of the geometry in the exported file. When edges of the SketchUp drawing area clip
part of a text or dimension entity, it’s not exported at all.
Some text may appear in a slightly different font in the exported file.

To export your current model view to a 2D vector image, follow these steps:
1. Select File > Export > 2D Graphic. The Export 2D Graphic dialog box appears.
2. Navigate to the location where you want to save your image.
3. (Optional) In the File Name box, type a name for your image file. By default, the image
file has the same name as your SketchUp model.
4. From the Export Type drop-down list, select a vector file type. Your options are PDF or
EPS.
5. (Optional) Click the Options button to open the options dialog box for your selected file
type. The options for both PDF and EPS files are the same, although in the following
figure you see the dialog box for EPS files. The following list explains each option.
Click OK to save your options and return to the Export 2D Graphic dialog box.
6. Click Export and your file saved in the location you selected.

When you select PDF or EPS as the format for your exported 2D graphic, you have the following
options in the Hidden Line Options dialog box that appears:
•
•
•

Full Scale checkbox: Select this checkbox for a 1:1 scale.
Width and Height boxes: Enter a value in these boxes and use the drop-down lists to
select your desired unit.
Scale options: To use these options, your model must be in Parallel Projection mode
or a two-point perspective and you need to select a standard view from the Camera >
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Standard Views submenu. The value for In Hidden Line Output indicates how the
exported geometry is sized, and the In SketchUp value is the actual measurement of
the geometry. For example, you might enter 1 inch in In Hidden Line Output and 4 feet
in In SketchUp to create a 1:4 scale.
Show Profiles checkbox: Select this checkbox if you want lines displayed in profile to
appear thicker in the exported vector file. When you clear the Show Profiles checkbox,
all the lines have a consistent width.
Match Screen Display checkbox: When Show Profiles is selected, you can
leave Match Screen Display (Auto Width) selected to let SketchUp determine the
width of profile lines. Clear the Match Screen Display (Auto Width) option, and you can
set a width manually in the box to the right of the checkbox.
Show Section Lines checkbox: This checkbox is available only when you export
section slices, as explained in Slicing a Model to Peer Inside. These options aren’t
available when you export PDF or EPS files.
Extend Edges checkbox: Select this checkbox if your model style uses edge
extensions and you want them to appear in the exported file. If you plan to import your
vector image into a CAD program, you may want to clear the Extend Edges option,
because some CAD applications have problems recognizing endpoints and intersections
when a file uses SketchUp edge extensions. When Extend Edges is selected, the Match
Screen Display (Auto Width) checkbox is also selected by default. When selected,
the extension line width in the exported file matches what appears on-screen in the
SketchUp drawing area. Clear this option to set a custom width in the box to the right.
Always Prompt for Hidden Line Options: Select this option to automatically display
the Hidden Lines Options dialog box whenever you export a PDF or EPS file.
Map Windows Fonts to PDF Base Fonts: When exporting a PDF file, select this
checkbox to tell SketchUp to map any font it can’t find to a PDF base font.
Defaults button: Click this button to restore the options in the dialog box to their
default settings.
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Importing and Exporting STL Files for 3D Printing
In SketchUp, you can import and export STL files, which are used in 3D printing. As explained
in 3D Printing a Model, for a SketchUp model to become a successful 3D printout, the model
needs to meet certain criteria, such as having a base and a volume and being a solid.
Table of Contents
1. Importing an STL file into SketchUp
2. Exporting a SketchUp model as an STL File

Importing an STL file into SketchUp
To import an STL file into SketchUp, follow these steps:
1. Select File > Import.
2. In the Import dialog box that opens, navigate to the STL file that you want to import
and select it.
3. (Optional) Select STereoLithography Files (.stl) from the file type drop-down list and
then click the Options button. The STL Import Options dialog box appears.
4. (Optional) Select your desired options (explained in the following list) and click OK. You
return to the Import dialog box.
5. Click Import, and SketchUp imports the selected STL file.
Tip: You can also drag and drop importable files into the drawing area. After you drop the file,
the relevant Import dialog box opens so you can select your desired options.
The STL Import Options dialog box enables you to make a few selections about how geometry
and scale are handled when SketchUp imports your file:
•
•
•
•

Merge Coplanar Faces: In most cases, you want to select this checkbox, which merges
all faces on the same plane into one face. By default, this checkbox is cleared, which
preserves multiple objects on multiple layers.
Preserve Drawing Origin: You likely want to clear this checkbox and let SketchUp
choose an origin or reset the origin after import.
Swap YZ Coordinates: When you select this checkbox, the Y coordinate becomes the
vertical coordinate. In other words, the Y axis is up instead of the Z axis.
STL Units: The default unit is millimeters. You can change the units to centimeters, feet,
or inches by selecting an option from the drop-down list.

Exporting a SketchUp model as an STL File
To export a SketchUp model to an STL file, first make sure that your model meets the basic
recommendations for 3D printing. Then follow these steps:
1.
2.
3.
4.
5.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to save your exported file.
(Optional) In the appropriate text box, type a name for the exported STL file.
From the Save As Type drop-down list, select STereolithography File (.stl).
(Optional) Click the Options button, and in the STL Export Options dialog box, select
your desired options for the exported STL file. (See the following list for details about
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each option.) Click OK when you’re done.
6. Back in the Export Model dialog box, click Export. SketchUp exports your model to the
STL format and saves the file in the location you specified.
The STL Export Options dialog box enables you to choose a few options for how SketchUp
renders your exported file:
•

•
•
•

Export Only Current Selection: When you select this checkbox, SketchUp exports
only the selected geometry to the STL file. This option is helpful if you want to model
several parts that fit together in one SketchUp model file, but export each part to a
separate 3D-printable STL file.
File Format: By default, Binary is selected from the drop-down list. The other format
option is ASCII. The binary format is generally preferred because this format helps
reduce the size of an STL file.
Swap YZ Coordinates: By default, this checkbox is cleared. If you select it, the Y axis
becomes the vertical axis instead of the Z axis.
STL Units: By default, the STL file is exported using the same units specified in the
model. (To check your model’s default units, select Window > Model Info and, in the
Model Info window, click Units in the sidebar on the left.) You can change the units in
the exported STL file to meters, centimeters, millimeters, feet, or inches.
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Importing and Exporting COLLADA Files
COLLADA is an XML-based schema that enables you to transfer data among 3D digital content
creation tools, such as SketchUp, Maya, 3ds Max, and Rhino. COLLADA files use the .dae file
extension, which stands for digital asset exchange.
In SketchUp, you can import and export COLLADA files pretty easily.
Note: SketchUp supports the COLLADA 1.4 specification and schema. To learn more about
COLLADA, visit Collada.org.
Table of Contents
1. Importing a COLLADA file
2. Exporting a COLLADA file

Importing a COLLADA file
To import a COLLADA file into SketchUp, follow these steps:
1. Select File > Import.
2. In the dialog box that appears, locate and select the .dae file that you want to import.
If you don't see the file you're looking for, make sure the correct file type is selected
from the drop-down list in the lower right.
3. Click the Options button. The DAE Import Options dialog box appears.
4. (Optional) By default, the Validate COLLADA File checkbox is selected, which prompts
SketchUp to check that your file is a valid COLLADA 1.4.1 file. If the file isn’t valid,
SketchUp asks whether you still want to import the file. Note that an invalid COLLADA
file can yield unexpected results. Deselect this option if you don’t want SketchUp to
check the file’s validity.
5. (Optional) By default, the Merge Coplanar Faces checkbox is selected, which tells
SketchUp to automatically remove edges on coplanar faces that share the same
material. This feature is helpful when importing 3D data from programs that use only
triangular faces, which can be tedious to clean up by hand in SketchUp. Deselect this
option to retain the triangular faces.
6. Click OK in the DAE Import Options dialog box.
7. Back in the main dialog box, click Open (Microsoft Windows) or Import (Apple
macOS), and SketchUp begins importing your COLLADA file.

Tip: If you can’t see the imported model, click the Zoom Extents tool (
fills the SketchUp drawing area.

) so that the model

Tip: You can also drag and drop importable files into the drawing area. After you drop the file,
any relevant Import dialog box opens so you can select your desired options.

Exporting a COLLADA file
Before you export a 3D model from SketchUp to a COLLADA file, know that COLLADA doesn’t
support all SketchUp features. If your SketchUp model includes the following elements, don’t
expect to see them in your exported COLLADA file:
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Coordinate lines
Dimensions
Guide lines and guide points
Matched photos
Material pushpin locations
Rendering options
Scenes
Section planes
Section cuts
Shadows
Text

To export your SketchUp model to a COLLADA .dae file, follow these steps:
1.
2.
3.
4.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to export your COLLADA file.
From the Export Type drop-down list, select COLLADA File (*.dae).
(Optional) By default, SketchUp gives your COLLADA file the same name as your
SketchUp model, but you can change the name by typing a new one in the File
Name box.
5. (Optional) Click the Options button to open the DAE Export Options dialog box. Select
your options, which are explained in the following list, and click OK to return to the
Export Model dialog box.
6. Click the Export button, and your exported file is saved in the location you selected.
When you export a COLLADA file, most of your options enable you to determine how geometry
is exported, but you also have options for materials and credits. The following list explains each
checkbox you find in the DAE Export Options dialog box:
•

•
•
•

•
•

Export Two-Sided Faces: When this checkbox is enabled, faces are exported twice:
once for the front and once for the back. SketchUp welds the vertices of the front faces
together and the vertices of the back faces together. This option doubles the number of
polygons in the resulting .dae file and can slow down rendering. However, this option
ensures that, in other COLLADA-compatible programs, your model appears more like it
appears in SketchUp than it would otherwise. Both faces will always render, and
materials applied to front and back faces are preserved.
Export Edges: When this option is selected, the exported file maintains the appearance
of a SketchUp model with visible edges. Note that stand-alone edges are always
exported.
Triangulate All Faces: When selected, this option breaks all surfaces into triangles
instead of multisided faces. Use this option when you plan to use your COLLADA file
with a program that supports only triangular faces.
Export Only Selection Set: If you select geometry before you begin the export
process, you can select this checkbox to export only the geometry that’s currently
selected in SketchUp’s drawing area. If you don’t select anything in your model or leave
this option deselected, the whole SketchUp model is exported to your COLLADA file.
Export Hidden Geometry: If your SketchUp model contains hidden geometry,
selecting this checkbox tells SketchUp to export that geometry.
Preserve Component Hierarchies: As explained in Organizing a Model, you can
create hierarchies of groups and components. When you select this checkbox, the
component hierarchies appear in the exported .dae file, too. When this option is
deselected, the component hierarchy is flattened, and component instances become
unique objects rather than instances of a single component. For details about
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component instances, see Adding Premade Components and Dynamic Components.
Export Texture Maps: When this option is selected, textures applied to your model
are exported with your .dae file.
Preserve Credits: Select this option if you’ve added one or more credits to a model’s
creator in the Model Info dialog box and you want to export those credits. This feature
is especially handy if you want to share your exported file to the 3D Warehouse.
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Importing DEM Files for Terrain
SketchUp can import digital elevation models (DEM), which contain point data relating to terrain
elevations. DEM files don’t come in a standardized format, but SketchUp supports the import
of two file types:
•
•

USGS DEM format uses the .dem file extension. If your DEM file is missing its file
extension, you need to add it before the file will import into SketchUp.
Spatial Data Transfer Standard format (SDTS) uses the .ddf file extension. SDTS
models usually consist of 20 or more files, all with the .ddf extension, stored in a single
directory. You can select any of the .ddf files in a SDTS directory to import the entire
set of files.

To import a DEM file into SketchUp, follow these steps:
1.
2.
3.
4.
5.

6.
7.
8.
9.

Select File > Import. The Import dialog box appears.
From the Files of Type drop-down list, select DEM (*.dem, *.ddf).
Navigate to the location where your DEM file is saved and select it.
Click the Options button. The DEM Import Options dialog box appears.
(Optional) In the Points and Faces boxes, you see how many points (and subsequent
faces) are created when you import the DEM file. If you like, you can adjust the number
of points by entering a new number. When you lower the number of points, you can
improve the terrain’s performance in SketchUp, but the terrain will lose detail.
(Optional) Select the Generate Gradient Texture checkbox if you’d like a gradient
that’s darker in the low areas and lighter in the high areas to appear over your imported
terrain.
Click OK in the DEM Import Options dialog box to return to the Open dialog box.
Click Import, and SketchUp imports your file.
Click Close in the Import Results dialog box, and your terrain appears at the origin
point. If you don’t see the terrain, click the Zoom Extents tool (

).

Tip: You can also drag and drop importable files into the drawing area. After you drop the
file, any relevant import dialog box opens so you can select your desired options.
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Importing and Exporting 3DS Files
The 3DS format is one of those oldies but goodies. The format is native to the original DOSbased 3D Studio modeling and animation application. Although the 3DS format is obsolete in
many ways, it’s still widely used. You can import 3DS models into SketchUp, and if you have
SketchUp Pro, you can export SketchUp models into 3DS format, too.
Tip: 3DS offers a direct way to export simpler SketchUp models into a wide range of 3D
modeling packages. Because 3DS preserves material assignments, texture mapping, and
camera position, 3DS can often transfer ideas that you generate in SketchUp to other programs
with greater fidelity than CAD formats can.
This article walks you through the steps for importing and exporting 3DS files and explains the
options you encounter along the way.
Table of Contents
1. Importing 3DS files
2. Exporting 3DS files

Importing 3DS files
Before you import a 3DS file into SketchUp, check whether the file has textures that you want
to import. If so, make sure the texture files are saved in the same folder as the 3DS file.
When you’re ready, follow these steps to import your 3DS file into SketchUp:
1.
2.
3.
4.
5.

Select File > Import. The Import dialog box appears.
Navigate to your 3DS file and select it.
From the Files of Type drop-down list, make sure 3DS Files (*.3ds) is selected.
Click the Options button. The 3DS Import Options dialog box appears.
(Optional) When selected, the Merge Coplanar Faces option removes triangulated
lines from coplanar faces. If you want to remove these lines, selecting this option tells
SketchUp to remove the lines automatically and saves you the tedious work of removing
these lines by hand. Leave the option deselected to leave triangulated faces as they
are.
6. (Optional) From the Units drop-down list, select the unit of measure that the 3DS file
uses to import your 3DS geometry at a 1:1 scale. Or change the scale by changing the
units. For example, a face that is 1 cm x 1 cm is imported into SketchUp as 1cm x 1cm
if your 3DS file has its units value set to centimeters and you select Model Units in this
drop-down list. A 1cm x 1cm face imports into SketchUp with dimensions of 1 in x 1 in
if you choose Inches in the drop-down list. If SketchUp doesn’t detect a units value in
the 3DS file, SketchUp imports the 3DS file in inches, unless you specify a different
value here.
Tip: SketchUp only recognizes faces of .001 square inches and larger. It is possible to
have very small faces on import if you select millimeters as your SketchUp units but the
model was originally intended to be displayed in feet. Therefore, use a large unit type,
such as feet or meters, if you do not know the units used in the original file. Resize the
model as necessary after it is imported.
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7. Click OK in the 3DS Import Options dialog box.
8. Back in the Open dialog box, click Import to begin importing your file. If your file is
large, the process can take a while.
9. Click OK in the Import Results dialog box. The model appears in the drawing area at
the origin. If you don’t see your model, click the Zoom Extents tool (

).

Tip: You can also drag and drop importable files into the drawing area. After you drop the file,
any relevant Import dialog box opens so you can select your desired options.

Exporting 3DS files
If you’re a SketchUp Pro user, you can export your SketchUp models as 3DS files. The following
sections explain how to prepare your SketchUp model for export, export to a 3DS file, select
export options, and handle known issues with 3DS exports.

Prepare your SketchUp model
Before you export your SketchUp model, you need to do a little preparation:
•

Make sure the front of all your SketchUp faces point outward. (Remember that
every face in SketchUp has a front and back.) To check that the face fronts point
outward in SketchUp, select View > Face Style > Monochrome to see whether the
back sides of a any faces point outward. By default, the face fronts are white and face
backs are dark gray. To reverse a face, context-click it and select Reverse Faces.
In the following figure, you see a basic model with materials (left) and in monochrome
(right). The left, side face needs to be reversed.

•

Tip: Sometimes, it’s difficult to determine whether a face is truly facing outward or just
shaded to show perspective. If you’re having trouble, orbit so you have a straight-ahead
view of the face. Or, in the Styles browser, you can use the Face Settings to edit the
default back face color so that the backs of faces stand out more than they do in the
default gray. Or, instead of checking and reversing faces, you can select the Export
Two-Sided Faces option when you export your 3DS file, as explained later in this section.
Show all the geometry you want to export. Only entities that are currently visible
in SketchUp are output to the 3DS file. Rendering display options are not taken into
account, which means that faces are output even if SketchUp is in wireframe mode.
Faces are not output, however, if they are hidden or reside on a hidden layer.
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Make sure you can live without your layers. The 3DS format does not support
layers. Any layers you assign in SketchUp don’t appear in your exported 3DS file. If you
need to export layers, exporting to the DWG format might be a better solution.

Export a 3DS file
When your SketchUp model is ready to export to 3DS, follow these steps:
1.
2.
3.
4.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to save your file.
From the Export Type drop-down list, select 3DS File (*.3ds).
(Optional) By default, the 3DS file has the same name as your SketchUp model. You
can change the file name if you like in the File Name box.
5. Click the Options button. The 3DS Export Options dialog box appears. Select your
options, which are explained in the following list, and click OK to return to the Export
Model dialog box.
6. Click Export, and your file is saved in the location you selected.

Select 3DS export options
When you open the 3DS Export Options dialog box, you see a long list of options. The rest of
this section helps you decode how each of these options impacts your exported 3DS file.
In the Geometry area, you find options for how SketchUp geometry appears in a 3DS file:
•

Export drop-down list: Choose how you want to organize meshes in the exported 3DS
file.
o Full Hierarchy: This option, selected by default, creates meshes for each toplevel nested component and group and for non-grouped entities based on the
connection of faces. These meshes are organized according to their place in the
component and group hierarchy. This option enables you (using a tree view in
Autodesk 3DS Max, for example) to select individual components and groups
with all their children and each connected face set as separate meshes. This
option preserves the name of the component or group using the following rule
for components: If an instance name exists, that name is used; if an instance
name does not exist, the definition name is used.
o By Layer: This option creates separate meshes based on how faces are
connected and on what layer (from SketchUp) the faces appear. All faces that
are connected and are on the same layer are grouped in separate meshes. These
meshes are then organized based on the layer to which they belong. This option
enables you (using a tree view in Autodesk 3DS Max, for example) to select all
objects on a layer using the organization scheme and then to drill down and
select individual meshes within that layer. No hierarchy is created with this
option. If you used SketchUp layers in the recommended way, however, all your
geometry is on Layer0 and you’ve assigned only groups or components to other
layers in order to control visibility.
o By Material: This option creates separate meshes based on how faces are
connected and their material. All faces that are connected and have the same
material are grouped together in a mesh. These meshes are then organized
based on their materials. In this organization scheme, you can select all objects
with the same material and then drill down to select individual meshes having
that material. No hierarchy is created with this option.
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Single Object: This option exports your SketchUp model as a single 3DS mesh,
which is simple to select and manipulate after you import it into another
application. However, because the 3DS format limits meshes to 65,536 vertices
and faces, you’ll find more than one mesh in your exported file if it exceeds this
limit.
Export Only Current Selection: If you select geometry in your SketchUp file before
you begin the export process, selecting this option tells SketchUp to export only the
selection. If you have no selection or leave this checkbox deselected, your whole model
is exported.
Export Two-Sided Faces: When selected, this option tells SketchUp to export faces
twice: once for the front and once for the back. The vertices of the front and back faces
are welded together, according to the logic for texture mapping and welding explained
in the upcoming Export Texture Maps option. This option doubles the number of
polygons in the resulting 3DS file and can slow down rendering. However, this option
ensures that your model appears more like it appears in SketchUp when you open the
3DS file in another program. Both faces will always render, and materials applied to
front and back faces are preserved.
Export Stand-Alone Edges: SketchUp’s support for stand-alone line entities (that is,
lines not connected to a face) is unique. The 3DS format doesn’t support them, nor do
many other 3D programs. When you select this option, SketchUp transforms standalone edges into thin rectangles that look like stand-alone lines in the 3DS file. Although
this solution seems simple, the reality is that it doesn’t always work: The result may
create invalid texture coordinates or create an altogether invalid 3DS file. If you run
into problems with stand-alone edges, try exporting to the VRML format instead.
o

•

•

•

In the Materials section, the Export Texture Maps option enables you to select how you’d
like to export materials and textures applied to your model. Select Export Texture Maps to
assign texture maps to 3DS materials whenever the corresponding SketchUp material uses a
texture image. The 3DS format allows only one mapping coordinate per vertex, which means
two faces that share the same vertex can’t have two different maps. Given this limitation of
the 3DS format, you need to make a tradeoff between preserving texture coordinates and
welding geometry. You can guide how SketchUp makes this tradeoff by selecting one of the
following Favor radio buttons:
•

•

Preserving Texture Coordinates: When you select this option, the goal is to preserve
textures. Whenever SketchUp finds conflicting texture maps, SketchUp breaks up
geometry so that each coplanar group has its own vertices. In other words, vertices
aren’t welded together, and faces aren’t smoothed. Vertices are welded when welded
faces have identical texture maps.
Welding Vertices: When you select this option, welding and smoothing get top
priority. If two faces share a vertex but have different texture maps, only one texture
map is preserved in the exported file.

In the Cameras area, select the Generate Cameras from Scenes checkbox to create a
camera for the default view as well as any SketchUp scenes that you’ve created. The current
SketchUp view is exported with the name Default Camera, and other scene camera definitions
are labeled with their scene name. See Creating Scenes for details about creating and naming
scenes in your SketchUp model.
In the Scale area, use the Units drop-down list to determine the unit of measurement in the
exported 3DS file.
The Units setting can affect the way geometry is described within the 3DS file. For example, a
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1 meter cube in SketchUp exports to 3DS with sides of length 1 when units are set to meters.
If you change the export units to centimeters, the same cube exports to 3DS with a length of
100.
The 3DS format contains extra information that indicates the original units using a scale factor.
This information allows an application that reads 3DS to automatically adjust a 3DS model to
its original size. Unfortunately, many applications ignore this unit scale information. As a result,
the centimeter cube imports as 100 times larger than the 1 meter cube, instead of at the same
size. Worse, it isn’t always clear in which unit a 3DS file was saved, so you have to discover
the original size through trial and error. In these cases, the best work-around is simply to
export files at the units setting that the 3DS importing application expects.

Understand known issues with files exported to 3DS
Because 3DS is an older format, transitioning to newer software and operating system contexts
isn’t always easy. Here are a few known issues you may encounter after you import your 3DS
file into another program:
•

•

•

Textures and materials exported with the Export Two-Sided Faces checkbox
selected can become flipped in certain applications, such as Maya. A 3DS mesh does
not store any normal data, so the target system must compute the model’s normals.
Some importers might compute the normals incorrectly, resulting in flipped textures.
Truncated texture map file names are also common. Because the 3DS format was
designed in the DOS age, it’s not capable of storing texture file names that exceed the
8.3 DOS character limit. If you’ve used modern OS file names (and you probably have),
SketchUp creates unique names for each texture by adding unique suffixes to file
names. For example, a file named corrugated metal.jpg is described in the 3DS file
as corrugat.jpg. Any other files that use the same first six letters are truncated, and the
suffix 01, 02, and so on, is added.
3DS format can’t store an orthographic camera. This format is simulated through
a perspective camera with a very small field of view or a very large lens length. The eye
point is moved as far away as possible to yield the same width and height of the
projection plane. Certain applications might have problems with a small field of view.
For example, Maya does not read the field of view at all and only lets it become as small
as 2.5.
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Exporting FBX Files
In SketchUp Pro, you can export a SketchUp file to the FBX format, which is a proprietary
Autodesk format.
The idea behind FBX is that, if you’re creating a film, game, or similar 3D content, you (and a
team of other people) likely need to use several applications in your workflows. The FBX format
enables all those applications to share 3D data. Because SketchUp Pro can export an FBX file,
you can create scenes or movie sets in SketchUp and then export that data to FBX for use with
other applications that support FBX.
To export a SketchUp model to an FBX file, follow these steps:
1.
2.
3.
4.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to save your file.
From the drop-down list, select FBX File (*.fbx).
(Optional) By default, your exported file has the same file name as your SketchUp
model. Change the name if you like in the File Name text box.
5. (Optional) Click the Options button to open the FBX Export Options dialog box. Select
your options, which are explained in the following list, and click OK to return to the
Export Model dialog box.
6. Click Export and your file is saved in the location you selected.
When you export an FBX file, you can choose from the following options:
•
•
•

•
•
•

•

Export Only Current Selection: If you make a selection in your model before you
begin the export process, selecting this box exports only the selected geometry. When
this option is deselected, the whole model is exported.
Triangulate All Faces: Select this option to break the output into triangles instead of
multisided faces.
Export Two-Sided Faces: When you select this option, faces are exported twice: once
for the front and once for the back. Although this doubles the number of polygons in
the exported file, the model will look more like it appears in SketchUp. Both faces will
render, and materials applied to the front and back faces are preserved.
Separate Disconnected Faces: If this option is selected, joined faces are exported as
separate meshes. If the option is not selected, faces are exported in the same mesh.
Export Texture Maps: Select this checkbox to export textures applied to faces with
your FBX file.
Swap YZ Coordinates (Y Is Up): This option does just what it says: swaps the Y
(green) axis and the Z (blue) axis so that the Y axis points up. For some applications,
this orientation is the default. To leave the default orientation (Z is up), leave this
checkbox deselected.
Units: Select an option from the drop-down list to set the unit size in the FBX file. If
you want the units to be the same as those in your SketchUp model, leave Model Units
(the default option) selected.
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Exporting KMZ Files for Google Earth
Google Earth is a great tool for viewing a model in the context of its intended surroundings,
such as the buildings on a city block. Although SketchUp has built-in tools for viewing your
model in Google Earth, you might need to export a KMZ file if
•
•

A client wants to see a model in Google Earth but doesn’t have SketchUp.
You want to share your model for viewing in Google Earth in SketchUp’s 3D Warehouse.

The KMZ format is a zipped form of Google Earth’s proprietary Keyhole Markup Language
(KML). A KMZ can contain location data (latitude and longitude) along with other information,
such as SketchUp geometry.
To export a KMZ file, follow these steps:
1.
2.
3.
4.
5.
6.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to save your KMZ file.
From the drop-down list, select Google Earth File (*.kmz).
(Optional) In the File Name box, type a new name for your file.
Click the Options button.
(Optional) Select the Export Hidden Geometry checkbox to export your model’s
hidden geometry.
7. Click OK in the KMZ Export Options dialog box.
8. Back in the Export Model dialog box, click Export and your KMZ file is saved in the
location you selected.
Note: The Credits feature was intended for use with the 3D Warehouse, but the 3D Warehouse
no longer supports the credits feature. When you upload model to the 3D Warehouse, however,
you can include any additional information about the model, including credits, in your model
description. See the <="" a="" style="background-color: transparent; color: rgb(90, 89, 98);
text-decoration: underline; transition: color 400ms ease 0s;">3D Warehouse section of the
Knowledge Center for details about uploading models to the 3D Warehouse.
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Exporting OBJ Files
If you’re a SketchUp Pro user, you can export files in the OBJ format.
Wavefront Technologies developed the OBJ file format for its Advanced Visualizer software, and
over time, other 3D software developers have adopted the open OBJ format. OBJ files are textbased and support free-form and polygonal geometry. When you export an OBJ file from
SketchUp, an additional .mtl file describes materials defined in the .obj file.
In the upcoming sections, you find out what the OBJ format does and doesn’t support and how
to export an OBJ file from SketchUp Pro.
Table of Contents
1. Understanding what OBJ does and doesn’t support
2. Exporting an OBJ file

Understanding what OBJ does and doesn’t support
Before you export a SketchUp model to the OBJ file format, it’s helpful to know what the format
does and doesn’t support. Here’s an overview of what you can expect from your exported OBJ
files:
•
•

•

•

No spaces are allowed in file names. OBJ files don’t support spaces in their file
names. When you export an OBJ file, SketchUp replaces any space with an underscore
(_).
Each SketchUp face exports as one polygon (unless you tell SketchUp
otherwise). If the application in which you want to use the OBJ file expects triangulated
faces, you can select the Triangulate All Faces option when you export the file to avoid
triangulation errors, such as missing or reversed polygons.
OBJ supports a flat set membership hierarchy, not a tree hierarchy. In a flat set
membership hierarchy, the format identifies what objects belong to a set but can’t tell
whether one set belongs to another set. This is different from the tree hierarchy you
see in SketchUp’s Outliner, which indicates, for example, that a cushion is a
subcomponent of a sofa or that a leg component is nested inside a chair component.
SketchUp outputs polygon faces only. SketchUp doesn’t support the output of
NURBS or any advanced OBJ entities.

Note: If PNG and JPG images, which are included in an OBJ export from SketchUp, don’t appear
in Maya, this problem is due to a known bug in Maya for Apple macOS.

Exporting an OBJ file
To export an OBJ file from SketchUp Pro, follow these steps:
1.
2.
3.
4.
5.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to save your OBJ file.
In the drop-down list, select OBJ File (*.obj).
(Optional) Rename your file in the File Name text box.
(Optional) Click the Options button. The OBJ Export Options dialog box appears. Select
your desired options, which are explained in the following list, and click OK to return to
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the Export Model dialog box.
6. Click Export and your OBJ file is saved in the location you selected.
When you export an OBJ file from SketchUp Pro, you can choose from the following options:
•
•
•

•

•
•

•

Export Only Current Selection: If you make a selection in your model before you
begin the export process, selecting this box exports only the selected geometry. When
this option is deselected, the whole model is exported.
Triangulate All Faces: Select this option to break the output into triangles instead of
multisided faces.
Export Two-Sided Faces: When you select this option, faces are exported twice: once
for the front and once for the back. Although this doubles the number of polygons in
the exported file, the model will look more like it appears in SketchUp. Both faces will
render, and materials applied to the front and back faces are preserved.
Export Edges: When you select this checkbox, SketchUp line entities are exported as
OBJ line entities. If you leave this checkbox deselected, edges are ignored. Usually, this
checkbox is deselected because most applications ignore edges when importing OBJ
files.
Export Texture Maps: Select this checkbox to export textures applied to faces with
your OBJ file.
Swap YZ Coordinates (Y Is Up): This option does just what it says: swaps the Y
(green) axis and the Z (blue) axis so that the Y axis points up. For some applications,
this orientation is the default. To leave the default orientation (Z is up), leave this
checkbox deselected.
Units: Select an option from the drop-down list to set the unit size in the OBJ file. If
you want the units to be the same as those in your SketchUp model, you can leave
Model Units (the default option) selected.
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Exporting VRML Files
If you’re a SketchUp Pro user, you can export your SketchUp models to a VRML file, which has
the .wrl file extension.
VRML 2.0 (Virtual Reality Modeling Language) is a 3D scene/object description format often
used to exchange data between 3D applications and to publish 3D information online. VRML
files can store the following SketchUp entities and features:
•
•
•
•
•
•
•

Camera views
Edges
Faces
Groups
Lights
Materials and textures
Transparency

To export a VRML file from SketchUp Pro, follow these steps:
1.
2.
3.
4.
5.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to save your VRML file.
In the Export Type drop-down list, select VRML File (*.wrl).
(Optional) Rename your file in the File Name text box.
(Optional) Click the Options button. The VRML Export Options dialog box appears.
Select your desired options, which are explained in the following list, and click OK to
return to the Export Model dialog box.
6. Click Export and your VRML file is saved in the location you selected.
When you export a VRML file from SketchUp Pro, you have the following options:
•

Output Texture Maps: When you select this checkbox, SketchUp exports textures to
the VRML file. When deselected, only colors are exported.
Tip: If you publish VRML files online, make sure the VRML file references to the textures
from their online location, not your local hard drive. Also, because VRML texture and
materials names can’t contain spaces, SketchUp replaces spaces with an underscore.
Be sure the file names in your VRML file and your texture images are consistent before
you upload a VRML file to the Web.

•
•
•

•

Ignore Back of Face Material: When selected, the front material is applied to both
the front and back of your model’s faces. SketchUp exports VRML files with double faces
so that you can see the file from any viewpoint.
Output Edges: When you select this checkbox, SketchUp Pro exports displayed edges
as VRML edge entities.
Use VRML Standard Orientation: When selected, your exported file conforms to the
VRML standard, which impacts the orientation of your model’s ground plane. Whereas
SketchUp considers the XY plane to be the ground plane, the VRML standard considers
the XZ plane to be the ground plane.
Generate Cameras: Select this option to create a camera for the default view and
any SketchUp scenes defined in your model. The current SketchUp view is exported with
the name Default Camera. The other scenes are given the same scene name that
appears in SketchUp.
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Allow Mirrored Components: If you mirrored a component so it’s the opposite of the
original, select this checkbox so that your mirrored component is exported to the VRML
file.
Check for Material Overrides: Select this checkbox, and SketchUp Pro determines
whether any faces, edges, or components contain references to the default material or
default layer.
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Exporting XSI files
SketchUp Pro enables you to export a model as an XSI file.
XSI files are used with Autodesk Softimage, an application filmmakers, video game designers,
and advertising firms use to create 3D content. Although the use of Softimage has declined
and Autodesk plans to deprecate Softimage in 2016, you may need an XSI file if you still use
Softimage in your workflows.
To export an XSI file from SketchUp Pro, follow these steps for your current operating system:
1.
2.
3.
4.
5.

Select File > Export > 3D Model. The Export Model dialog box appears.
Navigate to the location where you want to save your XSI file.
In the Export Type drop-down list, select XSI File (*.xsi).
(Optional) Rename your file in the File Name text box.
(Optional) Click the Options button. The XSI Export Options dialog box appears. Select
your desired options, which are explained in the following list, and click OK to return to
the Export Model dialog box.
6. Click Export and your XSI file is saved in the location you selected.
When you export an XSI file from SketchUp Pro, you can choose from the following options:
•
•
•

•

•
•

•

Export Only Current Selection: If you make a selection in your model before you
begin the export process, selecting this box exports only the selected geometry. When
this option is deselected, the whole model is exported.
Triangulate All Faces: Select this option to break the output into triangles instead of
multisided faces.
Export Two-Sided Faces: When you select this option, faces are exported twice: once
for the front and once for the back. Although this doubles the number of polygons in
the exported file, the model will look more like it appears in SketchUp. Both faces will
render, and materials applied to the front and back faces are preserved.
Export Edges: When you select this checkbox, SketchUp line entities are exported as
XSI line entities. If you leave this checkbox deselected, edges are ignored. Usually, this
checkbox is deselected because most applications ignore edges when importing XSI
files.
Export Texture Maps: Select this checkbox to export textures applied to faces with
your XSI file.
Swap YZ Coordinates (Y Is Up): This option does just what it says: swaps the Y
(green) axis and the Z (blue) axis so that the Y axis points up. For some applications,
this orientation is the default. To leave the default orientation (Z is up), leave this
checkbox deselected.
Units: Select an option from the drop-down list to set the unit size in the XSI file. If
you want the units to be the same as those in your SketchUp model, you can leave
Model Units (the default option) selected.
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Solving a Blank Dialog or SDK Error When Exporting
Situation
You're exporting a SketchUp file to one of these formats: FBX, OBJ, 3DS, VRM, or XSI. On the
Windows platform your export fails with a blank dialog box. On a Mac you get an error message
like "SketchUp SDK error: An error has occurred resulting in an invalid output file..."
Cause
Most likely this problem is caused by materials based on images that have no extension. For
example, your material may be based on an image named "brick" rather than "brick.jpg" or
"brick.png"
Solution
To resolve this error you'll need to identify which materials in your file are missing extensions
and either remove or fix them. This can be difficult in models with many textures, so you may
want to follow the Ruby steps below to identify the offending materials:
1. Browse to the Window > Ruby Console, which will open the Ruby Console
2. Copy
and
paste
the
following
line
into
the
Ruby
Console:
Sketchup.active_model.materials.each {|m| puts "\n" + m.display_name if (not
m.texture.nil? and not m.texture.filename.include? "." )}
3. Press the Enter key. if you have any materials in your model that are based on textures
that have no file extensions, the names of the materials will be printed in the Ruby
Console and you should do the following with each of them:
1. Go to Window > Materials to open the Materials dialog.
2. Click on the Home button to view your In Model materials.
3. Either delete the materials printed from the Ruby command or fix them to have
valid file extensions
On the PC, click Details button > List view to view your materials by name,
which will make it easier to find them.
If you want to fix your materials to have valid file extensions, here are some suggested steps:
Windows
1. Select the first problematic material in your Materials browser.
2. Right click and choose Export texture image and export the texture to your desktop,
making sure it has a valid file extension like “my_texture.jpg”
3. Click the Edit tab of the Materials browser.
4. Click the Browse button under the “Use texture image” section and browse to the
texture you exported in step two.
5. Click the Open button. Your material should now be based on a texture that has a file
extension.
6. Repeat steps 2-5 with any other materials that are missing file extensions.
7. Try exporting again; the export should be successful.
macOS
1. Select the first problematic material from the Materials browser.
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2. Right-click and click Edit... This will open the texture tweaker on the bottom.
3. Click the Edit texture image with external editor button (i.e. the brown cube with
the orange arrow) and the image will open with your default image editing program,
which will probably be Preview.
4. Assuming that the image was opened in Preview, click File > Save As or File >
Export and save the image to your Desktop, making sure it has a valid file extension
like “my_texture.jpg”
5. Back in SketchUp, double-click on the same material in the Materials browser to expand
the texture tweaker again.
6. Click the Texture drop-down menu and select Load.
7. Browse to your Desktop and select the image you saved in step 4.
Note: in the texture tweaker area, the name will still appear to be missing the file
extension as the Mac does not show file extensions.
8. Repeat steps 2-5 with any other materials that are missing file extensions.
9. Try exporting again; the export should be successful.
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Using the Photo Point Tool
Use the Photo Point tool to create a 3D model by plotting points to create camera guidelines
from Matched Photos. It works by casting a guide from one camera through an image point
that you can see in at least one other photo. You can then snap to that guide in another scene
to locate the point in 3D. Note that it is necessary to set your model axes to model from the
camera guideline.
Tip: If you do not have enough guide points from Trimble Business Center to complete the
model, you can use the Photo Point tool to create additional guide points within SketchUp.
1. Once enabled, a new window will appear:

2. Navigate to a point of interest in your series of photos using the Image Igloo View and
press enter to activate highlighted scene.

SketchUp Help Pages – version 19.

Page 490/567

3. In this example we will be modeling the structure shown below:

4. Click (

) and zoom into the point of interest and click to create a guide. In this
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5. Once the Photo Point is set, navigate to another image in your photo series where your
point of interest is also present by using the arrow keys in Image Igloo View.
6. Once you have another perspective of your point, you will see a projected camera
guideline as seen below in yellow.
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7. Use the Photo Point camera guideline to direct the line tool to the point of interest in
the image (corner of structure). Once found, use the line tool to draw a line from the
camera guideline down to the ground by inferencing the z-axis as shown here:

8. If you navigate back to the original perspective using the Image Igloo View, you will see
that the line is properly placed:
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9. You can now create the front face of the structure by inferencing the axes as shown
here:

10. Change perspectives using the Image Igloo View to model the rest of the structure.
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11. To replicate the structure on the left, simply inference the structure on the right.

12. Finish the structure by connecting each side as shown below:
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Fixing an Issue in SketchUp
Is SketchUp Make or SketchUp Pro displaying an error or not behaving the way the program
normally does? You can find solutions to known issues grouped into the following categories:
•
•
•
•
•
•
•

Handling Error Messages
Fixing Installation Problems
Fixing Startup Problems
Improving Graphics Performance
Connecting to Online Features (3D Warehouse,
Warehouse)
Reporting Errors with BugSplat
Handling Issues with Creating 3D Models

Add

Location,

and

Extension
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Space Bar opens Model Info dialog box
This is a Mac specific issue regarding shortcuts.
To work around this issue, press Ctrl+F7. If you're using a Mac laptop, press Ctrl+Fn+F7.
Pressing Ctrl+F7 will disable Full Keyboard Access". If the shortcut doesn't work, go to System
Preferences > Keyboard > Keyboard Shortcuts' , select 'Text boxes and lists only' under 'Full
Keyboard Access'.
This issue is caused by having "All controls" selected in System Preferences > Keyboard >
Keyboard Shortcuts. When this option is selected, SketchUp will give focus to buttons like the
Geo-location button in the status bar and then the Space bar will select that control. If you
select the "Text boxes and lists only'' option, this issue will no longer occur.
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Troubleshooting ATI/AMD Related Crashes
On some Windows machines with ATI/AMD graphics cards, SketchUp 2017 can crash on launch,
when saving a model or when working in the model.
If you have an ATI/AMD graphics card and are experiencing crashes, install the latest version
of SketchUp 2017 by going to Help > Check for Update. We added a fix to SketchUp 2017
maintenance release 2 that may fix this crash on your configuration.
If, after installing the latest version of SketchUp 2017 you are still crashing, the following steps
may help solve your crash:
1. Close SketchUp
2. Download
the
Registry
script
WorkaroundMaxSolidLineWidth.reg
by
right
clicking here and choosing to "Save Link" to your computer. Make a note of where the
file is saved.
3. Locate and double-click the WorkaroundMaxSolidLineWidth.reg script downloaded in the
previous step. You'll need to click "Yes" in response to the warning prompts you may
see.
The above steps will set a value in the SketchUp section of the Windows registry that will clamp
down the width of profile lines to a value of 2. On some graphics cards, wide profile lines are
causing SketchUp to crash.
If the above steps don’t solve your crash …
1. Download the Registry script UndoWorkaroundMaxSolidLineWidth.reg by rightclicking here and choosing to "Save Link" to your computer. Make a note of where the
file is saved.
2. Locate and double-click the UndoWorkaroundMaxSolidLineWidth.reg downloaded in the
previous step. You'll need to click "Yes" in response to the warning prompts you may
see. This will return your registry to its state prior to running the script.
3. Contact our Support team for further assistance.
We are working on a more comprehensive fix for a SketchUp 2017 maintenance release. We
appreciate your patience!
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Handling Error Messages
When SketchUp displays an error message, check out the subarticles in this section for details
about how to handle the error.
For example, you find out how resolve errors about the following issues:
•
•

File errors, including issues with file formats, filenames, license files, and file
compatibility with other versions of SketchUp
Hardware compatibility problems, including support for Microsoft’s .NET Framework and
meeting the minimum specifications to run SketchUp

Resolving "Authentication Error"
You may see this error when interacting with 3D Warehouse or Extension Warehouse from
inside SketchUp.
To resolve this issue, please follow these steps:
1. Log out of your account out by selecting the icon at the bottom left side of the SketchUp
drawing window.

2. Log back in to your account.
3. Try opening 3D Warehouse or Extension Warehouse again.

SketchUp Help Pages – version 19.

Page 501/567

If that doesn't seem to do the trick, there may be an issue with the Internet browser on your
computer. In this case, delete your browser's history: Internet Explorer for Windows users
and Safari for Mac users.

Resolving "File currently locked by another user" error
This file error is not an issue in SketchUp 2017 and beyond. Select another version of SketchUp
from the drop-down list to see details about resolving this issue in SketchUp 2014, 2015, or
2016.

I'm getting an Unexpected file format or File not found error
In the case of an incomplete download, the problem isn't with the model itself; rather, the
failed download results in an incomplete file that SketchUp can't recognize or open.
Incomplete downloads can be caused by many different things, for example, heavy Internet
traffic, transmission errors, and slow connections (some dial-up services might not be able to
handle large file downloads). You may notice that the download process simply stops before
the entire file has been downloaded, or you may see an "Unexpected File Format" or "File not
found or invalid" error at the end of the download.
In cases like this, you still may be able to successfully download the model; however, before
you try the download again, it's important to clear yo clear your browser's cache.
It may also help if you try the download at a later time when Internet traffic is not so busy,
and to save the model to your hard drive rather than loading it directly into your SketchUp
model.

I'm getting an invalid filename message (PC)
Situation: every few minutes, an "invalid filename" message is displayed.
SketchUp automatically saves your files while you are working on them, by default, every five
minutes. This message is displayed when SketchUp is unable to write the auto-save file to the
default location.
On a PC, the auto-save file is saved in the same folder as the model is saved. If you haven't
yet saved your file, by default, it is saved in your "My Documents" folder; however, it's possible
to change the default location where models are saved by changing a setting in the SketchUp
Preferences. This issue happens if you don't have full write permissions to that location.
To check this:
1.
2.
3.
4.
5.
6.

Open the "Windows" menu.
Click "Preferences."
In the left pane, click "Files."
In the right pane, copy the path for models.
Open Windows Explorer, paste the path into the address bar, and press Enter.
If an error message is displayed, you don't have the necessary write permissions for
the default location where models are saved. You can either change the permissions to
the default location or change that location in the SketchUp Preferences dialog box. To
change the location, just click the folder button next to the path for models, and then
select a different location.
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I'm getting an error saying the .NET Framework is missing
The PC version of SketchUp Pro requires the Microsoft .NET Framework 4.5.2. During install,
SketchUp will detect if the correct version of the .NET Framework is missing and will prompt
you to download and install the package. Click the "Yes" button to install the package. Due to
file size, we suggest downloading the .NET Framework using a broadband connection or faster.
If you're using a dial-up connection, please be aware that downloading will take some time.
At this time, SketchUp Pro requires version 4.5.2 or higher of the .NET Framework. If your
computer has a lower version of the .NET Framework installed, you'll be asked to download
version 4.5.2. Multiple versions of the .NET Framework can co-exist on your computer without
interfering with SketchUp Pro.
You can download the standalone Microsoft .NET Framework 4.5.2 installer from their site
directly here.

Unable to copy the license file (Windows)
This message indicates that SketchUp Pro can't generate a license file in the shared folder that
you created. To troubleshoot this issue, please try the following steps to test the the
permissions of the shared folder:
1. Log in to a computer with the user name and password of someone who will be using
SketchUp Pro.
2. Click "Start" (on Vista click the Windows button) > "All Programs" > "Accessories" >
"Notepad."
3. When Notepad opens, type a few letters, and then click "File" > "Save."
4. When prompted, browse to and select the shared folder you created.
5. Enter a file name, and click "Save."
6. If you can't successfully save the file, folder's permissions aren't correctly set. Please
note that users need full read and write access to the folder. Test again after making
changes to the permissions to verify that you can successfully save and delete the file.
Note: If you continue to see this issue after having the proper sharing settings, ensure that
users also have full access to the main SketchUp folder, which is typically
C:\ProgramData\SketchUp\SketchUp # or C:\Program Files\SketchUp\SketchUp
# for SketchUp Pro 2013 and newer
or C:\ProgramData\Google\Google SketchUp # or C:\Program Files\Google\Google SketchUp
# for SketchUp Pro 8 and older
For more information about sharing folders in Windows, click here to see Microsoft's
documentation on the subject.
For step-by-step instructions on setting up a network license, click here.

Log in errors with SketchUp Tools
SketchUp needs to connect to the internet in order to use a number of tools including: Get
Models, Share Model, Share Component, Add Location, Add Building, and Photo Textures. In
addition, Sharing Models and Components both require a 3D Warehouse account, but this
account is optional if you’re using Add Building. SketchUp uses the operating system’s built-in
web browser to connect.
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Since these tools all share the same web browser, they may periodically encounter problems
related to how they were last accessed. If you’re unable to use any of these tools there are
several steps you can try to resolve the issue.
1. The first thing to test is whether you’re able to access any of the other SketchUp web
services. Regardless of where the error occurred we recommend first clicking “Share
Model” or “Get Model,” allowing the page to load, and then trying the original tool again.
2. If you’re still unable to open the desired tool please click the “G” icon in the bottom
status bar which will provide a login screen for the 3D Warehouse. Log in if possible and
again test to see if the issue continues.
3. If you are logged in and still encountering problems, try logging out using the “G” icon,
and logging in again.
4. If you’re still unable to use the tool you need, exit SketchUp and open the appropriate
system browser - Internet Explorer on a Windows machine and Safari on a Mac. For
either browser you’ll need to clear the recent history, cookies and cache. Those
instructions are below:
Note: All Microsoft Windows computers will use Internet Explorer and should have
version 7 or greater installed; all macOS computers will use Safari and should have
version 4 or greater installed.
Internet Explorer 7
1. From the Tools menu in the upper right, select Internet Options.
2. Under "Browsing history", click Delete...
o To delete your cache, click Delete files...
o To delete your cookies, click Delete cookies...
o To delete your history, click Delete history...
3. Click Close, and then click OK to exit.
Internet Explorer 8
1. From the Safety menu in the upper right, click Delete Browsing History...
2. Deselect “Preserve Favorites” website data, and select:
o Temporary Internet files
o Cookies
o History
3. Click Delete.
Safari
1. From the Safari menu, select Reset Safari...
2. From the menu, select the items you want to reset, and then click Reset.
Note: As of Safari 5.1, Remove all website data covers both cookies and cache.

Incorrect error message when changing an edge style value
Situation
This is only an issue on the Windows operating system. In the Styles browser Edit tab, you
change one of the edge settings (e.g. Profiles, Depth cue, Endpoints, or Jitter) to have a value
between 1 and 99, but you see an error message "Please enter an integer between 1 and 99."
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Cause
This is likely caused by the fact that the Edge Extension value, which is on the “Edge Settings”
tab of the Styles browser, has an incorrect value of 0.
Solution
To resolve this error:
1.
2.
3.
4.
5.
6.

Open the Styles browser.
Click on the Edit tab.
Click on the Edge Settings icon, which is the first one on the left.
Check the Extension check box.
Change the extension value from 0 to something else - e.g., 1.
Uncheck the Extension check box (unless you want to see edge extensions).

You should now be able to change your other edge settings without getting the error message.

Error: "The file was created in a newer version of SketchUp"
You may be seeing this error message if you created a model with SketchUp 2016 and you'd
like to open the model with SketchUp 2015 or older. Note that every major version of SketchUp
(eg, 6, 7, 8, 2013, 2014, 2015) has a unique version of the *.skp file format. As such, the
model needs to be saved in the correct version of SketchUp that will open the file. But don't
worry, you can always "down save" a model so you can open the file in an older version. To do
so, please follow these steps:
1. Open the version of SketchUp that matches the version of the SketchUp file. For
example, SketchUp Pro 2016 or SketchUp Make 2016.
2. Open the SketchUp file by clicking File > Open.
3. Click File > Save As.... This will open the Save dialog box.
4. Click the Save as Type drop-down menu and choose the version of SketchUp you would
like use to open the file. For example, SketchUp version 2015.
5. Modify the file name to make it unique, for example, add "-v2015" to the end of the file
name.
6. Click OK. You can now open the resulting file in SketchUp Pro 2015.

Resolving NVIDIA error message
Error Message: "Your hardware configuration does not meet minimum specifications needed to
run the application. The application must close. Error code: 6" To resolve this issue, please try
the following steps:
1.
2.
3.
4.

Right-click on the Desktop and click Nvidia Control Panel.
Click Manage 3D settings.
Click Program Settings.
Select SketchUp from the drop-down list.

There are five settings that you need to configure:
•
•

Anisotropic Filtering set to Application Controlled.
Antialiasing FxAA set to On.
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•
•

Antialiasing Gamma set to On.
Antialiasing Mode set to Application Controlled.
Open GL set to the name of the video card that you have.
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Fixing Installation Problems
Whether you want to try fixing an issue by uninstalling and reinstalling SketchUp or are
experiencing a more specific installation issue, the subarticles in this section may be able to
help.
Some issues you may not recognize as installation issues include the following:
•
•
•

An expiration message appears.
SketchUp doesn’t run.
A digital signature or custom locations are missing.

Uninstalling or repairing SketchUp
Instructions are for SketchUp and SketchUp Pro
1. Click the Start (Windows logo) menu > Control Panel > Programs > Programs and
Features > SketchUp #.
2. Select Remove (Uninstall on Vista or Windows 7).
3. When asked if you'd like to remove SketchUp, click Yes.
If you are having problems with SketchUp, you can try the Change option, which begins the
process of reinstalling the program features that were installed during the last installation. This
can fix any application files that were corrupted (this doesn't affect or fix your SketchUp
drawing files, the SKP files). If that doesn't work, try uninstalling and reinstalling SketchUp.

The installation won't run
If you can't start the installation, the cause is most likely an incomplete download of the Setup
file. Compare the size of the file to the official download sizes, which you can find here. If there
is a difference, try deleting the first file then downloading again.
For SketchUp 6 and older, if you can start the installation, but it stops abruptly, the cause is
most likely corrupt installation information. The installation process won't overwrite this
information, so you'll need to rename the folders that contain it, which forces the installation
process to create new folders containing fresh install information.
1. Rename this folder, appending a suffix
C:\Program Files\Common Files\InstallShield
2. Restart the computer.
3. Run the installation again.

like

"BAD"

to

the

folder

name:

Digital signature is invalid or missing
SketchUp has a digital signature imprint from Verisign, so if you receive a message that there
is an invalid digital signature or no digital signature, the likely cause is that installation file was
corrupted during download.
In that case, clear your browser's cache, and then try the download again. Note: It can take
up to 30 minutes to clear the cache.
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Custom locations missing after installing SketchUp
Previous versions of SketchUp (6.0.514 and earlier) store custom locations in the "sketchup.tzl"
file, which is located in the path below:
SketchUp 6.0.514 and earlier
"C:\Program Files\Google\Google SketchUp 6\Support\"
SketchUp Pro 5
"C:\Program Files\@Last Software\SketchUp 5\Support\"
Newer versions of SketchUp (6.4.112 and above) store custom locations in the "locations.dat"
file in "C:Program Files\Google\Google Sketchup #\Resources\en-US\"
To transfer your custom locations to a newer version of SketchUp, open the "sketchup.tzl" file
with a text editor, copy the contents, and paste them into the "locations.dat" file.

Accessing SketchUp with multiple partitions (Mac)
Situation: You have multiple partitions or hard drives set up on your Mac. After booting into a
different partition or drive you're missing your extensions and plugins.
When installing SketchUp on a Mac with multiple drives or partitions, we always recommend
installing on your root volume. However this can cause problems when booting into another
partition. To resolve this problem we suggest one of these two options:
Option one (recommended): Create a symbolic link. Creating a symbolic link on your
secondary volume will allow SketchUp to reference the extensions and plugins on your first
volume, and no extra installations are required. Let's say you have HD1 and HD2 and you have
installed SketchUp on HD1. To create a symbolic link, follow these steps:
Note: You'll need administrator privileges to make a symbolic link.
1. Open a Terminal window (in Finder: Applications > Utilities > Terminal).
2. In your Terminal window, change your directory to HD2 the drive that does not have
SketchUp installed. For example, you may need to type cd /HD2.
3. Within HD2 navigate to /Library/Application Support.
Note: This is not ~/Library/Application Support/

4. In
the
Terminal
window,
type: ln
-s
/Volumes/HD1/Library/Application\
Support/Google\ SketchUp\ 8/Google SketchUp 8. This will create the symbolic link.
5. To verify that the symbolic has been created, type: ls -la | more in the Terminal window.
You
should
see
a
line
with
the
following: SketchUp
8
->
/Volumes/HD1/Library/Application Support/Google SketchUp 8/
6. Close Terminal and use SketchUp as usual.
Option two: Install SketchUp directly on your second partition. You will have two
separate SketchUp installations, which may have different properties. For installation
instructions, please visit our installation page.
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Fixing Startup Problems
If SketchUp has trouble getting started, pouring coffee on your computer won't help. Instead,
see whether the sub-articles in this section can help you resolve the problem.
Some known startup issues include the following:
•
•
•

SketchUp simply won't start when you try to launch the application.
SketchUp tells you it can't start because your computer's clock was set back.
SketchUp starts but then quits or freezes.
o For Mac OS.
o For Windows.

SketchUp won't start on my PC
The Quick Answer
•
•
•

Check that your system meets the requirements for SketchUp.
Reboot your system to ensure that SketchUp isn't locked by another process.
Make sure that there aren't any applications running on your system that might conflict
with SketchUp, such as anti-virus, firewall, or internet security software.

There are a few known issues that can cause this:
•
•

•
•

•

Your computer and operating system must meet the minimum requirements. For more
information, click here.
There is a known issue with EarthLink TotalAccess 2005.1 that can cause SketchUp and
other programs to fail to start up. When this happens, you may see a BugSplat dialog
box. To fix this issue, simply upgrade to the current version of EarthLink TotalAccess.
You can download and install it from www.earthlink.net/software/.
The Norton Internet Security 2005 firewall blocks SketchUp (and many other programs
that have a built-in Web update service) from starting. The best way to fix this issue is
to upgrade to Norton Internet Security 2006.
As an alternative, you can temporarily disable the Norton Internet Security 2005
firewall, start SketchUp, and then re-enable the firewall. This is a temporary fix; you'll
need to repeat this process every three weeks or so when the periodic "Check for
Update" runs.
SketchUp requires a graphics card that is OpenGL compliant. If SketchUp won't start on
a computer running Microsoft Windows, you should first verify that the graphics card
supports OpenGL:
1.
2.
3.
4.
5.
6.
7.
8.

Click the "Start" button.
Click "Control Panel."
Click "Appearance and Themes."
Click "Display."
Click the "Settings" tab.
Click the "Advanced" button.
Click the "Troubleshoot" tab.
Make a note of the "Hardware acceleration" slider setting, and then move it to
"None."
9. Click "OK" to close the Advanced and Display Properties dialog boxes.
10. Close the Control Panel.
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11. Start SketchUp. If SketchUp now starts, then the graphics card doesn't support
OpenGL.
12. After you have finished performing this test, reset the "Hardware acceleration"
slider to its previous setting.
If the graphics card doesn't support OpenGL:
o
o

Try installing an updated graphics driver. For more information, click here.
If that doesn't work, to use SketchUp you'll need to replace the graphics card
with one that is OpenGL compliant.

If none of the above solve the issue, then there is an underlying conflict with your computer
system that is preventing SketchUp from starting. Here are a couple more things you can try:
•
•

Download and install any updates that are available for your operating system.
Restart Windows. After restarting:
1. Exit any programs or utilities running in the background (anti-virus software,
printer/plotter managers, pop-up blockers, security/firewall software, remote
desktop connection software, and so on).
2. Try starting SketchUp by double-clicking its desktop icon or by clicking the link
on the "Start" menu (in other words, don't try to open it by double-clicking a
model, in case the model itself is corrupt).

When I launch SketchUp for macOS, SketchUp unexpectedly quits
The Quick Answer
•
•

Check that you have the most current update of macOS and the most current version
of SketchUp for macOS installed.
Delete your SketchUp preferences (plist) file.

Situation: SketchUp unexpectedly quits as soon as you start it on Apple macOS.
The problem is either with a corrupt preference file, a corrupt application file, or a system
conflict. Here are some steps you can take to try to resolve this:
•

Be sure that you've updated to the most current update available for your current
installation of macOS:
1. Click the Apple.
2. On the "Apple" menu, click "Software Update."
3. If there is a Apple macOS update available, install it.

•
•

Whether or not you installed an update, restart your Mac.
If SketchUp still crashes, delete the SketchUp preferences file. (Note: This step resets
all of your preferences, including references to the location of materials and components
you've added.)
1.
2.
3.
4.

Quit SketchUp.
Open a Finder window.
In the left pane, click your user name.
In the right pane, click the "Library" folder.
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5. In the "Library" folder, click the "Preferences" folder.
6. In the "Preferences" folder, find the SketchUp preferences file(s) and drag it to
the Trash. The file can be one or more of the following:
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪

com.sketchup.SketchUp.2013.plist
com.sketchup.LayOut.2013.plist
com.sketchup.StyleBuilder.2013.plist
com.sketchup.SketchUp.2014.plist
com.sketchup.LayOut.2014.plist
com.sketchup.StyleBuilder.2014.plist
com.sketchup.SketchUp.2015.plist
com.sketchup.LayOut.2015.plist
com.sketchup.StyleBuilder.2015.plist
com.sketchup.SketchUp.2016.plist
com.sketchup.LayOut.2016.plist
com.sketchup.StyleBuilder.2016.plist

7. Start SketchUp. A new preferences file is generated.
•

If SketchUp still crashes, it's possible that some of its files have become corrupted, so
you should completely remove SketchUp and its files, and then reinstall it.
1. Quit SketchUp. (If you have more than one instance of SketchUp open, make
sure you quit all instances of SketchUp.)
2. Open a Finder window.
3. Delete the SketchUp folder from the main library:
a. In the left pane, click "Macintosh HD."
b. In the right pane, click "Library," and then "Application Support."
c. In the "Application Support" folder, find the "SketchUp #" folder, and then
drag it to the trash.
4. Delete the SketchUp folder from your user library:
a. In the left pane, click your user name.
b. In the right pane, click "Library," and then "Application Support."
c. In the "Application Support" folder, find the "SketchUp #" folder, and then
drag it to the trash.
5. Delete the SketchUp application:

•

•

a. In the left pane, click "Applications."
b. In the right pane, find the "SketchUp #" folder, and then drag it to the
trash.
6. Reinstall SketchUp. If you need to download the trial version again: click here.
If SketchUp still crashes, the issue could be a conflicting with other software.
1. Exit any other running applications (including any applications running in the
background).
2. Try to start SketchUp. If this works, then there is a conflict with one of the
applications you closed, and you should test against each one to see the one that
is causing the conflict.
If SketchUp still crashes, the issue is likely due to damaged hardware that may need
fixing or replacement. We recommend that you work with a technician experienced with
Apple computers to resolve this.
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"SketchUp can't be started because your system clock has been set
back" error message.
The full error message is "SketchUp can't be started because your system clock has been set
back to before the last time you used SketchUp."
When you encounter this error message, please contact technical support for additional
assistance.

Freezing upon launch
Situation:
When using SketchUp on Windows Vista or Windows 7, you double-click the "SketchUp"
shortcut on the Desktop or from the "Windows" button, and SketchUp freezes or loads a blank
window.
How to fix it:
To resolve this issue we recommend downloading the latest drivers for your video graphics
card.
If you have a nVidia video graphics card, please make sure you follow their eight-step
installation instructions.
If updating the video card driver doesn't resolve the issue, try launching SketchUp by doubleclicking on a SKP file. If you haven't created a new SKP file yet, you can download one from
the 3D Warehouse.
Please note that we suggest continually checking with your graphics card driver provider for
new Vista-compatible drivers.
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Improving Graphics Performance
SketchUp is a graphics-intensive program, so getting your work done can be difficult when
graphics performance is slow or choppy.
The subarticles in this section can help you troubleshoot some known issues, including
problems with a Logitech mouse and performance issues that occur after changing the camera
view.
You also find help diagnosing whether system hardware, such as your graphics card, needs an
upgrade.

SketchUp and OpenGL
3D applications, such as SketchUp, require abundant system resources. Aside from having a
fast CPU and large amounts of RAM, your video card and video card drivers must be 100%
OpenGL compliant.
What is OpenGL?
OpenGL is the industry-standard graphics library used in numerous software applications and
games, to draw 3D geometry. Most Microsoft Windows and Apple macOS operating systems
come with a software-based OpenGL driver. However, these drivers rely heavily on the CPU to
perform the rendering calculations of OpenGL (a task that is not done efficiently by most CPUs).
Many video card manufacturers have also built cards that support the OpenGL standard. These
cards perform the rendering calculations using a specialized chip called the Graphics Processing
Unit or GPU (instead of relying on the CPU). These chips significantly enhance OpenGL
performance upward of 3000 percent. This performance enhancement is known as Hardware
Acceleration.
Hardware Acceleration
SketchUp will take advantage of hardware acceleration if your computer has a 100% OpenGL
compatible video card.
Note: Hardware Acceleration might only be available on your system for certain resolutions and
color depths. Check the system settings for your video card to see if it supports hardware
acceleration (using the Control Panel on Microsoft Windows or System Preferences on
Macintosh macOS).
Note: We strongly recommend that you set your display colors to a 32-bit color depth
(using Control panel > Display Properties) to ensure that your SketchUp model will render
accurately when using hardware acceleration (Microsoft Windows).
We cannot control the quality of the OpenGL driver on your computer system. Video card device
drivers are proprietary and are maintained solely by the manufacturer of the video card in your
system. Therefore, we cannot guarantee that SketchUp will work with hardware acceleration
on your system.
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Compatibility Issues
OpenGL incompatibility is a significant system configuration issue leading to problems with
SketchUp. Difficulties with Sketchup tools, performance, and rendering (such as mysterious
graphics appearing on your screen) are usually the result of a video card not fully supporting
OpenGL (despite claims by the manufacturer), an out-of-date video card driver, or
incompatibility with 32-bit color depth.

My Logitech mouse is running very slowly in SketchUp
If your Logitech mouse is running fine in other programs, but very slowly in SketchUp, there is
a setting you can switch to eliminate this problem.
The newer Logitech mouse drivers have a special setting for use with games that disables
acceleration, but this actually applies to all applications that use OpenGL, which includes
SketchUp. To re-enable acceleration:
1. Open the "Properties" dialog box for your Logitech mouse driver.
2. Click the "Motion" tab.
3. Clear the "Disable acceleration in games" check box.

Unknown graphics card
This message means your computer can't detect an installed graphics card. When that happens,
the computer runs in Software Emulation mode. If you see this message, you should update
your graphics driver. For more information about how to update a graphics driver, click here.

What is a graphics card and a graphics driver?
Graphics card
The graphics components are the part of your computer that control and enhance how graphics
(pictures, videos, programs, animation, 3D) are displayed on your computer screen.
Often, the graphics components are on a separate card that plugs into a slot on the
motherboard, which is the main part of the computer. That's why the graphics components are
commonly called the graphics card. Sometimes the graphics card components are build directly
into the motherboard.
Other common names for graphics components
Other common names for the graphics components are: video card, video adapter, display
adapter, and graphic accelerator.
Graphics driver
The graphics driver is a program that controls how your graphic components work with the rest
of your computer: your software, like SketchUp, your monitor, and so on.
More information
For more information about:

SketchUp Help Pages – version 19.

•
•
•

Page 514/567

The graphics cards that are recommended for SketchUp, click here.
How to find out which graphics card you have in your PC, click here.
How to update a graphics driver, click here.

Which graphics cards are recommended for SketchUp?
We recommend any graphics card that fully supports OpenGL 3.0 or higher and has at least 64
MB of video memory. If you're going to create large models, we recommend a graphics card
with more than 512 MB of video memory.
OpenGL is a set of instructions for how your computer's graphics components work with the
rest of your computer and your software. OpenGL is particularly important for 3D programs
like SketchUp, as well as 2D graphics programs. If the graphics card manufacturer supports
the standard OpenGL instructions well, then your 3D and 2D programs will work well.
We've seen good results when SketchUp is run with most of the graphics cards recently released
by NVIDIA and AMD.
For older graphics cards and cards from other manufacturers, it is important to update to the
latest graphics driver for your graphics card. For more information about how to update a
graphics driver, click here.
Some graphics cards are designed primarily for games and don't fully support the OpenGL
standard. Other graphics cards are designed to support only more simple graphics (this can be
the case with the graphics capabilities in some notebooks and budget computers). Cards like
these may not support 3D programs like SketchUp very well. If you have updated to the latest
graphics driver and you are still having problems using SketchUp, you may need to upgrade
your computer's graphics capabilities.

How can I find out which graphics card I have in my PC?
SketchUp is a graphics-heavy program. Knowing your graphics card can help you troubleshoot
odd visual behaviors or recommend a good-performing card to other users. The easiest way to
find your graphics card is to run the DirectX Diagnostic Tool:
1.
2.
3.
4.
5.

Click Start.
On the Start menu, click Run.
In the Open box, type "dxdiag" (without the quotation marks), and then click OK.
The DirectX Diagnostic Tool opens. Click the Display tab.
On the Display tab, information about your graphics card is shown in
the Device section. You can see the name of your card, as well as how much video
memory it has.

If you're experiencing odd visual behavior in SketchUp, our Blurring/distorted images article
may help you understand and resolve the problem.

How can I update my computer's graphics driver?
SketchUp is a graphics-heavy application. We suggest always keeping your graphics drivers
up-to-date. Updating drivers can often correct odd visual behaviors such as freezing, artifacts,
model slicing, and slow performance.
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Windows
If you have a notebook or laptop computer:
You should visit the website of the notebook manufacturer to download the latest driver.
If you have a desktop or workstation computer:
Before you can update the graphics driver, you need to know what kind of graphics card you
have. For more information about how to find out what graphics card you have in your PC,
click here.
Once you know the kind of graphics card you have, visit the manufacturer's website to
download the latest driver. Here are links for downloading drivers from the most common
graphics card manufacturers:
•
•
•

NVIDIA: http://www.nvidia.com/content/drivers/drivers.asp
AMD: http://support.amd.com/en-us/download
Intel: http://support.intel.com/support/graphics/

If you upgraded your driver to resolve a display issue, and it didn't resolve the issue, you may
consider installing an older driver for your graphics card instead. Older drivers may be available
online or in a resource CD that came with your computer. NVIDIA, for example, offers a driver
archive.
macOS
1. Click the Apple logo.
2. On the "Apple" menu, click "Software Update."
3. If there is a Apple macOS update available, you can install it. If there is a graphics driver
update, it will be included in the Apple macOS update.

Model seems sticky after camera movement
To keep SketchUp interactive and responsive while you're modeling, SketchUp waits to render
the model with full detail until you temporarily stop working on the model. For large models
that are using a complex Style, you may notice a significant pause when you end a modeling
operation before the full-detail rendering completes. This pause allows you to start your next
modeling operation without the renderer interrupting your work.
However, once the full detail rendering has begun, it can't be interrupted until it's complete.
We refer to this pause as "stickiness" in the model. You won't be able to start new tool
operations or orbit the model while SketchUp is rendering. If this stickiness is too intrusive to
your modeling process, you may want to disable some of the more complex rendering styles
to make SketchUp render faster.
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Connecting to Online Features
In SketchUp, you need an Internet connection to access three important features:
•
•
•

Add Location
3D Warehouse
Extension Warehouse

If you’re having trouble connecting to these features or an error message appears, the
subarticles in this section point you to solutions that may fix the problem.

Problems connecting to the Internet
SketchUp requires uninterrupted access to the internet for features such as the 3D Warehouse,
Add Location and Extension Warehouse. To ensure connectivity you may need to adjust settings
in your Firewall, Proxy or Internet Security software for your network or computer.
•
•
•

SketchUp needs access on the following ports:
80, 8888, 8080, and 443
For Network Licenses, SketchUp needs access to the following ports:
5053 and 50530
SketchUp needs permission to visit all of the sub-domains for SketchUp.com, easily
included as:
*.sketchup.com

If you're uncertain if these ports are open on your machine please contact your network
administrator for assistance.

Troubleshooting Connectivity Issues within SketchUp
There are a few techniques that may help resolve this issue.
A. Upgrade your version of Internet Explorer
SketchUp connects to several Google APIs. At this time, Google web APIs support Internet
Explorer 10 or higher. You can download the Internet Explorer 10 install file by visiting this
page.
B. Clear Cache and Cookies in Internet Explorer
To connect to the Internet, SketchUp uses Internet Explorer even if you have a different default
browser. Clearing the cache and cookies can often help resolve many Internet-related
problems. To clear the cache and cookies in Internet Explorer, try the steps on this page.
C. Adjust the Microsoft Internet Explorer security settings
Custom or higher settings in Microsoft Internet Explorer can restrict access to functionality
within SketchUp. As a troubleshooting step, open the Internet Settings dialog within Internet
Explorer, navigate to the Security tab and change the slider to "Medium" to reduce the
restrictions within Internet Explorer. In this same tab be sure to uncheck "Enable Protected
Mode" which will restrict all internet activity.
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D. Check your Internet settings
To check if the computer is connected to the Internet, SketchUp tries to contact a website. If
your network has a Proxy in place that tries to direct the computer to another location,
SketchUp may think that the computer isn't connected to the Internet. Similarly, if there are
any Firewalls in place that are preventing SketchUp from contacting the Internet, that could be
the source of the issue as well. We recommend that you contact your local IT administrator
and share this information with that person. They should be able to investigate further to
identify the source of the problem.
E. Change the URL SketchUp uses to test connectivity
If you would like to change the URL that SketchUp uses to test connectivity, please ask your
IT department to make the following change to your computer:
1. To start, you’ll need to open and edit the PrivatePreferences.json file which can be found
in the following locations:
o On Windows, navigate to:
%localappdata%\SketchUp\SketchUp 2019\SketchUp\PrivatePreferences.json
o On MacOS, select Go > Go to Folder... and enter:
~/Library/Application Support/SketchUp
2019/SketchUp/PrivatePreferences.json
2. Locate the line "OnlineTestURL": "", and insert a desired URL in the blank quotes.
o For example, use https://www.yahoo.com (not just yahoo.com). Save your
changes to the PrivatePreferences.json file (with SketchUp closed) and then start
SketchUp to begin using the new URL.
Note: SketchUp must be closed when this edit is made. If SketchUp is open during the edit
then the file will be overwritten back to the default setting upon SketchUp closing.
F. Clear DNS cache
Sometimes, the Windows operating system stores information about Internet activity. Clearing
the Windows cache, can help resolve this issue:
•
•

Windows 7 & 8 instructions
Windows 10 instructions

G. Ensure the proper ports and domains aren't blocked
SketchUp requires uninterrupted access to the internet for features such as the 3D Warehouse,
Add Location and Extension Warehouse. To ensure connectivity you may need to adjust settings
in your Firewall, Proxy or Internet Security software for your network or computer.
SketchUp needs access on the following ports:
80, 8080, 443.
For network licenses SketchUp also needs ports 5053 and 50530
If you're uncertain if these ports are open on your machine please contact your network
administrator for assistance.
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SketchUp needs permission to visit all of the sub-domains for SketchUp.com, easily included
as:
*.sketchup.com
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Reporting Errors with BugSplat
SketchUp uses BugSplat to discover when the software is having problems and to collect data
that helps our team find a solution.
The subarticles in this section introduce you to the BugSplat reporting system and explain how
to send data about any problems that you encounter.

Bugsplat Crash Message in SketchUp
BugSplat (click www.bugsplatsoftware.com to learn more!) is a 3rd party software application
that is integrated in SketchUp to help improve the quality of the product. BugSplat helps us
troubleshoot SketchUp crashes by allowing crash information to be sent to us.
How Does it Work?
If SketchUp crashes you will see the following dialog indicating that SketchUp has crashed.

This dialog gives you the option to send us information regarding the crash you just
experienced. We encourage everyone to submit this form! Submitting a description of what
you were doing prior to the crash is key to helping us reproduce the crash and fix it. The
following are examples of descriptions that are really helpful (though any kind of description is
useful):
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SketchUp seems to crash consistently when I do the following:
1.
2.
3.
4.
5.

Open SketchUp
Draw a rectangle
Select it
Edit > Copy
Edit > Paste - crash

Or
SketchUp crashed when exporting my model to dwg. Others models seems to export fine.
Providing your email and name is also helpful as it is is possible, if we are stuck, we may contact
you regarding the crash.
How we use the data you submit
The data you submit allows us to gather information on our crashes as a whole and gives us
some details, mostly at the code level, about each crash. We use this data in a few ways:
•
•
•

If you contact Technical Support, we may look up your specific crash to see if we can
give you some information that will help you.
We analyze which crashes are our top crashes and, each release, we try to solve them.
Once we solve a crash or come up with a workaround, we add that information to the
crash so that, if you submit that crash to us, you will get an update from us containing
that information.

We unfortunately cannot monitor every crash that comes in and we usually do not contact the
submitter of the crash. The data you submit though is very crucial as we do analyze it and
often take action on it.
Crash troubleshooting steps
Some steps you can do to try to troubleshoot a crash include:
•

Try updating your graphics card driver via the following steps:
https://help.sketchup.com/en/article/36254
http://forums.sketchup.com/t/updating-intel-graphics-card-drivers/35093
http://www.wikihow.com/Update-Your-Video-Card-Drivers-on-Windows-7
https://support.microsoft.com/en-us/instantanswers/ad5a063e-5f57-c7152566-b983195752c1/update-drivers-in-windows-10
Alternatively, if you just updated your graphics drive and the crash started occurring,
try rolling back your graphics driver.
Try running SketchUp with Ruby plugins disabled to see if a Ruby plugin is the culprit.
See whether the crash is reproducible - i.e., can you repeat it if you do a specific set of
steps?
See whether the crash is reproducible - i.e., can you repeat it if you do a specific set of
steps?
See whether the crash happens with all SketchUp models or just the one you are
working on.
See whether the crash occurs in a previous version of SketchUp if you have multiple
versions of SketchUp installed on your machine.
o
o
o
o

•
•
•
•
•
•
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Try closing other running applications to see if SketchUp is conflicting with another
application you have open.
Try opening the SketchUp file and copying & pasting the geometry into a new SketchUp
file.
Try opening the SketchUp file and clicking "Window" > "Model Info" > "Statistics" >
"Purge unused."
If you have installed SketchUp in a non-default location, try installing it to the default
location.
If you have multiple user accounts on your machine, try logging on as a different user
and see if the crash is still reproducible.
Try closing all of your SketchUp dialogs/trays to see if the crash still occurs.
Submit the crash to us to see if we have any updates on the crash for you.

Getting Help
If you are experiencing a crash and need immediate help, contact technical support or visit
our SketchUp forums.
Please be aware, for our support team to assist you with a reported bug, you must include
your email address when submitting your original Bugsplat.
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BugSplat
Defined:
If you encounter a problem that causes SketchUp to unexpectedly close, the BugSplat dialog
box opens and invites you to send us an error report describing what happened just before
SketchUp had to close. Please do send us the error report, and please include a description of
what happened just before SketchUp had to close. This really helps us to track down and fix
any problems that cause our software to close. Please be aware that you may not receive a
response after submitting a BugSplat.
Troubleshooting:
Check out the following common solutions in response to a BugSplat:
•
•
•
•

Update the driver for your graphics card.
Open the SketchUp file. Then copy and paste the geometry into a new SketchUp file.
Open the SketchUp file and select Window > Model Info > Statistics > Purge
Unused.
Make sure that no unusual characters appear in Scene or Layer names.
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Handling Issues with Creating 3D Models
In Creating a 3D Model, the articles offer lots of tips and tricks to help you avoid common
mistakes. However, some known issues aren’t connected to any tool or technique.
The subarticles in this section explain how to handle known issues that cause problems with
creating 3D models, such as the following:
•
•
•
•

Problems in the interface, such as a box around the cursor or a missing status bar
Trouble with selected, clipped, and missing faces
Images and background colors displaying improperly
SketchUp crashing when you leave the Components browser open

White or black box around cursor
SketchUp supports real-time 3D drawing, you must make sure your display settings are
optimized for 3D. If you see a white or black outline around your cursor in SketchUp, you can
usually fix this by increasing the color quality for your display.
Note: For some older graphics cards, this might not work. In that case, you should try updating
your graphics driver. For more information about how to update a graphics driver, click here.
PC
1.
2.
3.
4.
5.
6.
7.
8.
Mac
1.
2.
3.
4.

Open the Start menu.
Click Control Panel.
Click Appearance and Themes.
Under Pick a task, click Change the screen resolution.
The Display Properties dialog box opens with the Settings tab selected.
In the Color quality box, select Highest (32 bit).
Click OK.
Restart SketchUp.
Open System Preferences.
In the Hardware section, click Displays.
In the Color box, select Millions.
Restart SketchUp.
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I lost my SketchUp status bar (PC)
This can happen when your SketchUp window is larger than your monitor's screen. You can
display the SketchUp status bar by clicking the "Maximize" button to maximize the SketchUp
window (the "Maximize" button has an icon that looks like a computer screen and is just to the
left of the "Close" button, the red button with the white "x").

You can also manually resize the window so that it is smaller by dragging down the top bar,
and then moving the entire window up.

When I select a face, the reverse face is selected (PC)
This is a known issue with some OpenGL graphics drivers. We have built a workaround option
into SketchUp:
1.
2.
3.
4.
5.

In SketchUp, open the "Window" menu.
Click "Preferences."
Click "OpenGL."
In the "Acceleration" section, select the "Correct reversed picking driver bug" option.
Click "OK."

Clipping and missing faces
Clipped or Missing Faces
Situation: you are orbiting around your model and you see an effect that looks like a section
plane attached to your view at a fixed distance. Objects may also disappear or appear to shake
when you try to zoom in.
This is a known issue called Camera Clipping Plane. First, don't worry; although it can be
distracting, this doesn't cause any actual damage to your model.
There are several situations in which you might encounter this:
•

•

One is when the field of view (FOV) is set very wide. You can adjust the FOV between 1
and 120 degrees (the default is 35 degrees in SketchUp and 30 degrees in SketchUp
Pro). It's easy to unintentionally change the FOV by pressing the Shift key while you
are zooming in or out using the Zoom tool. You can change it back, though, by going
to Camera > Field of view and typing your desired field of view in the measurement
toolbar.
Another situation that can cause clipping is when the Perspective camera mode is turned
off. In that case, click the Zoom Extents button (it looks like a magnifying glass with
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four red arrows pointing outward). The camera zooms out to display the entire model,
and the clipping is eliminated.
Another situation is when the scale of your model is very small or very large. In this
case, you can change the scale of your model while you work on it. For more information
about how to control the scale in a model, click here.
This can also happen if your model is very far away from the origin point (the point
where the red, green, and blue axes intersect). In that case, you can move your model
closer to the origin point following these steps:
o Select all of the geometry in your model by typing Control+A or Command+A,
or by clicking and dragging the Select tool across your geometry.
o Change to the Move tool by going to Tools > Move.
o Grab a corner point of the selected geometry that is on the ground plane and
start to move the selected geometry.
o Type [0,0,0] (including the square brackets) in the Measurement toolbar (which
is in the lower-right corner of the SketchUp window). This causes the selected
point to be moved to the origin point.
Most frequently, clipping occurs after a DWG import and is caused by a combination of
the above points. If you're moving your geometry to the origin or checking for scale,
you'll want to ensure that you can see all the geometry in the model. These three steps
will help you do that:
o Turn on all your layers in the Window > Layers menu.
o Unhide geometry using the Edit > Unhide all command.
o View all hidden geometry by clicking on View > Hidden Geometry.
After making all your geometry visible, go to Camera > Zoom extents to see the full
extents of your model. If you find that you have geometry located long distances from
the origin, removing that geometry will help resolve this problem.

Flickering Faces in your model
You may sometimes encounter a flickering behavior on some surfaces, this is typically called
"z-fighting" as two faces are fighting to be seen along the z-axis. This happens when two faces
are either co-planar or nearly co-planar and SketchUp is trying to show both.
If you have overlapping geometry but they're not grouped then it will just "cut" the surface
and no flickering will occur. You'll see this flickering when a face is drawn on grouped geometry,
or when 2 different groups have a face that is on the same plane. The group (or component)
is preventing the 2 faces from merging into one face, so the 2 faces compete. If you would like
to eliminate the z-fighting, here are three approaches:
•
•
•

Change how the geometry is grouped so that the faces merge. eg. Explode your group
or component or re-nest the geometry.
Move the 2 face away from each other to prevent the z-fighting.
Note that moving it so that its still nearly co-planar will still result in some flickering at
different zoom levels.
Give the top face some thickness. eg. Use Push/Pull to pull that 0 thickness face into a
piece of geometry with some thickness to it.

If you need to adjust the nested level of the geometry, rather than just exploding, then you
can use the Outliner to move geometry between levels. To adjust the nest level:
1. Select one set of geometry by double-clicking that group until you're able to select
ungrouped geometry.
2. Go to Edit > Cut.
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3. Change nested levels either by double-clicking until you can select the remaining surface
or use the Outliner to find the desired nest level.
4. Use Edit > Paste In Place to paste the cut geometry into the nested group definition.

Blurred or distorted images
The Quick Answer
•
•
•

Download and install the most current video card drivers from the manufacturer's
website.
Disable 'Fast Feedback' on your system.
Make sure that your video card supports OpenGL 1.5+.

There are two likely causes of display issues like this:
•
•

PC or Mac: On some systems, Fast Feedback can cause blurring and other display issues.
PC only: The anti-aliasing feature of the graphics driver of some graphics cards can
cause blurring.

To check whether Fast Feedback is causing the blurring:
1.
2.
3.
4.
5.
6.

Open the "Window" menu (Mac = "SketchUp" menu).
Click "Preferences. "
In the left pane, click "OpenGL."
Clear the "Fast Feedback" check box.
Restart SketchUp.
Continue working on your model to see if the issue has been resolved.

When Fast Feedback is disabled, you'll notice the SketchUp display speed slow down, especially
as your model gets more complex, so turning Fast Feedback off isn't the ultimate solution. If
turning Fast Feedback off resolves the issue:
•
•
•

Mac and PC: Make sure your system meets the SketchUp Hardware and Software
Requirements (click here).
Mac: Run a software update to make sure you are running the latest version of Max
macOS (click here).
PC: Download the latest graphics driver for your graphics card (click here). If that
doesn't work, you might need to install a different, OpenGL-compliant graphics card.

To check whether anti-aliasing is causing the display issue:
1. Find the performance settings for your graphics card. (Check the documentation for
your graphics card for information about where you can access these settings. Often,
you find them by clicking the "Advanced" button on the "Settings" tab of the Display
Properties dialog box.)
2. Mark sure that anti-aliasing is set to "Application-controlled. "
3. You can then control the level of anti-aliasing from within SketchUp:
1.
2.
3.
4.

Open the "Window" menu.
Click "Preferences."
In the left pane, click "OpenGL."
In the right pane, select a setting in the "Capabilities" section.
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Model's background color shown in Vector mode
If you're using the Vector rendering feature in LayOut, you may see the background color of
your SketchUp model in cases where it shouldn't be visible. This can happen if there's a hole
in your geometry that shows the background color or if the SketchUp window in LayOut clips
any geometry. To resolve this problem, you may consider the following steps:
•
•
•

Try using a Model Style that doesn't include a background color.
If possible, change your viewport size to include all model geometry.
Use Hybrid rendering rather than Vector rendering.

Account has no nickname error message
The Credits feature
in
SketchUp
requires
your
Google
Account
to
have
a Nickname associated with it. To add a Nickname to your Google Account, visit the 3D
Warehouse and click the Sign In link in the upper right-hand corner. You'll automatically be
prompted for a Nickname if you don't have one already.
If you continue to encounter this error message, please follow these steps:
1. Open an Internet browser, and go to www.google.com.
2. If you're signed into your Google Account, click on your email address in the upper right
hand corner. This will open a small window. If you're not signed into your Google
Account, click "Sign in" and enter the required information.
3. Click the "Account" link.
4. In the "Email" section, there is a small link called "Edit." Click on the "Edit" link.
5. In the "Edit personal details" section, there's a box called "Nickname." Please add your
nickname information into that box.
For more information about Nicknames, please visit this Help Center article.

I'm unable to set the north angle for my model
Editing the North angle can only be done with the Pro version of SketchUp 8 or with a previous
version of SketchUp. To enable the North angle, click View > Toolbars > Solar North
Likewise, there can only be one North angle used in a SketchUp file. If you need to display
varying North angles, you can create separate files or use an older version of SketchUp.
Note: This plugin isn't installed by default in SketchUp Pro 2013. You'll need to open the
Extension Warehouse from within SketchUp, locate the "Solar North" plugin and choose
"Install" to add this plugin.

SketchUp crashes on the Mac after prolonged use
This is a known issue that we're currently investigating. For now, we recommend closing
the Components browser and leaving is closed as much as possible.

Restoring thumbnails for SketchUp files on Windows
Summary of issue
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You may not be able to see SketchUp file thumbnails on Windows if SketchUp was previously
uninstalled.
Description
When SketchUp is uninstalled and a new different, default version of SketchUp is set, the
SketchUp file thumbnails may disappear even after reinstalling the latest version of SketchUp.
Workaround
If SketchUp is currently uninstalled on your computer:
1. Install SketchUp by double-clicking on the installer and following the steps to install.
2. If thumbnails are still not visible after installation of SketchUp , click on the Windows
Start button and go to Default Programs.
3. Select Set your default programs.
4. Click on SketchUp in the Programs list.
5. Select Set this program as default.
If SketchUp is currently installed on your computer:
1. Reinstall SketchUp by double-clicking on the installer.
2. Click Repair during
the
install
when
the Change,
repair,
installation dialog appears.
3. Finish the install.
4. Click on the Windows Start button and go to Default Programs.
5. Select Set your default programs.
6. Click on SketchUp in the Programs list.
7. Select Set this program as default.

or

remove

Note: Thumbnails should now show for any newly saved files. If you can't see a thumbnail for
an old file, you can open it and click Save and it should show the thumbnail.
If the above workaround does not work, disable any third party thumbnail software (e.g.,
MysticThumbs) that you may have installed. Third party software can also contribute to
thumbnail issues.
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SketchUp Errors and Warnings
On launch, SketchUp, LayOut, Style Builder and Viewer check that your machine meets the
requirements to run each program and shows you an error dialog if it does not meet those
requirements. In addition, SketchUp will present some warnings for conditions that may result
in SketchUp not running as well as it could.

Launch Errors
If your machine does not meet the minimum requirements for running SketchUp, LayOut, Style
Builder and Viewer, you will see an error dialog like this one:

Here are the specific errors that you may see and the potential actions you can take to fix
them:
1. Hardware acceleration is unsupported or has been disabled on your graphics
card. SketchUp requires that you use a hardware accelerated card.
SketchUp will not run if your graphics card does not support hardware acceleration.
If you see this error, updating your graphics card driver (Windows) / running an
Operating System update (Mac) would be a good first step in troubleshooting why your
card does not support hardware acceleration - often an updated graphics card driver
allows your graphics card to become accelerated.
2. Your <name of video card> graphics card's OpenGL version is <your version>.
SketchUp requires a graphics card that supports OpenGL 3.0 or better.
SketchUp will not run if your graphics card’s OpenGL version is less than version 3.0. If
you see this error, updating your graphics card driver (Windows) / running an Operating
System update (Mac) would be a good first step to troubleshoot this error as updated
drivers may upgrade the version of OpenGL that your card supports. If updating the
drivers does not work, investigate whether your graphics card has the capability of
supporting OpenGL version 3.0 or higher. If it does not, you will need to upgrade your
graphics card.
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3. Tests that exercise your <name of video card> graphics card's capabilities
have failed.
SketchUp will run a series of tests to determine if your graphics card has the capability
of supporting the rendering functions SketchUp needs to display SketchUp models.
These tests include checks like the compilation of SketchUp’s GLSL shaders and support
for OpenGL framebuffer objects. If you see this error, try updating your graphics card
driver (Windows) / running an Operating System update (Mac) to see if that helps solve
this issue.
SketchUp, Style Builder and Viewer will not launch if you see any of the above issues until your
resolve them. LayOut will launch but will not be able to render SketchUp models.

Launch Warnings
On launch, if your system has the capability to use an AMD/NVIDIA graphics card but is instead
using an integrated Intel graphics card, SketchUp will issue the following warning message:
SketchUp has detected your computer system has multiple graphics cards and is defaulting to
an integrated Intel graphics card. SketchUp will perform better if you change your system to
default to the AMD/NVIDIA card.
In a system with multiple GPUs, SketchUp will likely perform better on an AMD or NVIDIA GPU
than on a GPU from another vendor. If you see this warning, you may need to specify in the
NVIDIA or AMD software that SketchUp is a 3D accelerated application and to use that card
when running SketchUp. You may wish to review this article concerning how to set the default
video card on your system.

OpenGL Warnings
After SketchUp launches successfully, SketchUp will also evaluate whether your machine has
conditions that may cause it to not run as well as it could. If it finds those conditions, you will
see a warning icon and some text on the Preferences > OpenGL dialog:

and if click on the Graphics Card Details button, you will see detailed warning information:
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Here are the specific warnings that you may see and the potential actions you can take to fix
them:
1. Your <name of video card> graphics card has a depth buffer that is less than
24 bits. SketchUp recommends a 24 bit or more depth buffer for your graphics
card. You may see display issues with your current configuration.
SketchUp works best with a graphics card that supports a 24 bit or more depth buffer.
If you see display issues, you may want to upgrade your graphics card.
2. Your <name of video card> graphics card has a color buffer other than 24 bits.
SketchUp recommends a 24 bit color buffer for your graphics card. You may
see display issues with your current configuration.
SketchUp works best with a graphics card that supports a 24 bit color buffer. If you see
display issues, you may want to upgrade your graphics card.
3. Your <name of video card> graphics card does not support stencil bits.
Shadows may display incorrectly on your current configuration.
SketchUp works best with a graphics card that supports stencil bits If shadows are not
displaying in your models as expected, you may want to upgrade your graphics card.
4. SketchUp has detected your computer system has multiple graphics cards and
is defaulting to an integrated Intel graphics card. SketchUp will perform better
if you change your system to default to the AMD/NVIDIA card.
In a system with multiple GPUs, SketchUp will likely perform better on an AMD or
NVIDIA GPU than on a GPU from another vendor. If you see this warning, you may need
to specify in the NVIDIA or AMD software that SketchUp is a 3D accelerated application
and to use that card when running SketchUp. You may wish to review this
article concerning how to set the default video card on your system.
5. Depth buffer or Color buffer or Stencil buffer information is missing.
SketchUp will issue the above warning(s) if, after querying your graphics card, it can’t
find the information it was looking for.
If you see this warning, try updating your graphics card driver (Windows) / running an
Operating System update (Mac) to see if that helps solve this issue.
If you see any of the above errors or warnings, try to solve the issue and then re-run
SketchUp to see if your actions were successful.

SketchUp Help Pages – version 19.

SketchUp Hardware
Requirements

Page 532/567

and

Software

Like many computer programs, SketchUp requires certain hardware and software specifications
in order to install and run. These are basic requirements, though, so you may want to use our
recommended suggestions to improve performance.

Windows
Windows 10, Windows 8+ and Windows 7+
•

Software
o An internet connection is required to install and authorize SketchUp and to use
some of the features.
o Microsoft® Internet Explorer 9.0 or higher.
o SketchUp Pro requires .NET Framework version 4.5.2. For more information
about the .NET framework, click here.
SketchUp requires a 64-bit version of Windows. Also, to install SketchUp, Windows 8.1
must be current with Windows Update.
Boot Camp, VMWare, and Parallels are not supported environments.

•

Recommended hardware
o 2+ GHz processor
o 8+ GB RAM
o 700MB of available hard-disk space
o 3D class video card with 1 GB of memory or higher and support for hardware
acceleration. Please ensure that the video card driver supports OpenGL 3.0 or
higher and is up to date.
SketchUp's performance relies heavily on the graphics card driver and its ability
to support OpenGL 3.0 or higher. To test your graphics card's compatibility,
please download and run the SketchUp Checkup application. Historically, people
have seen problems with Intel-based cards with SketchUp. We don't recommend
using these graphics cards with SketchUp at this time.
o 3-button, scroll-wheel mouse.

•

Minimum hardware
o 1 GHz processor
o 4GB RAM
o 500MB of free hard-disk space
o 3D class video card with 512 MB of memory or higher and support for hardware
acceleration. Please ensure that the video card driver supports OpenGL 3.0 or
higher and is up to date.

macOS
Mac OS 10.14+ (Mojave), Mac OS 10.13+ (High Sierra), and 10.12+ (Sierra).
•

Software
o An internet connection is required to authorize SketchUp and to use some of the
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features.
o QuickTime 5.0 and web browser for multimedia tutorials.
o Safari
Boot Camp, VMWare, and Parallels are not supported environments.
•

Recommended hardware
o 2.1+ GHz processor
o 8GB RAM
o 700MB of available hard-disk space
Alert: Please be aware, SketchUp is unable to support case sensitive hard drives
with our installation. If you use a case sensitive hard drive you'll experience
crashes at launch which cannot be resolved.
o 3D class video card with 1 GB of memory or higher and support for hardware
acceleration. Please ensure that the video card driver supports OpenGL version
3.0 or higher and is up to date.
o 3-button, scroll-wheel mouse

•

Minimum hardware
o 2.1+ GHz Intel™ processor
o 4GB RAM
o 500MB of available hard-disk space.
o 3D class video card with 512 MB of memory or higher and support for hardware
acceleration. Please ensure that the video card driver supports OpenGL version
3.0 or higher and up to date.
o 3-button, scroll-wheel mouse.

To use your license with SketchUp Pro you must have internet access. For additional details
concerning these internet requirements, please read Understanding Your License.
Compatibility Changes
SketchUp 2019
With the release of SketchUp 2019 we've removed support for Apple macOS 10.11 (El Capitan).
You need to sign in with a Trimble ID to access the SketchUp Pro 2019 subscription or to
participate in a Free Trial. SketchUp Desktop 2019 Classic licenses do not require a sign-in.
SketchUp 2018
With the release of SketchUp 2018 we've removed support for Apple macOS 10.10 (Yosemite).
There is no longer a SketchUp Make for download, our free version of SketchUp is called
SketchUp Free and available in all modern web browsers.
SketchUp 2017
With the release of SketchUp 2017, we've removed support for 32-bit operating systems,
OpenGL 2.0, and software rendering of models (as opposed to hardware acceleration). We also
removed support for macOS 10.9 (Mavericks.)
SketchUp 2016
With the release of SketchUp 2016 we’ve removed support for macOS 10.8 (Mountain Lion)
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and earlier.
SketchUp 2015
With the release of SketchUp 2015 we’ve removed support for Windows Vista, Windows XP and
macOS 10.7 (Lion) and earlier. SketchUp 2015 and earlier isn't supported on Apple macOS
Sierra, but is supported on Apple macOS Mountain Lion, Mavericks, and Yosemite. Additionally
you must have Microsoft Internet Explorer 9 or greater.
SketchUp 2014
No System requirement changes were made.
SketchUp 2013
With the release of SketchUp 2013 we reduced the level of support we can offer for Windows
XP and removed support for macOS 10.6 (Snow Leopard) and earlier.
SketchUp 8
With the release of SketchUp 8 we removed support for macOS 10.4 (Tiger) and earlier.
SketchUp 7
With the release of SketchUp 7 we removed support for Windows 2000 and earlier.
High DPI Support
SketchUp is DPI aware and can adjust the sizes of Icons and drawing elements so they are
sized correctly for High DPI screens. Icons are sized when SketchUp starts up. If you adjust
your DPI or scaling (Microsoft Windows – but only up to 150%) you will need to restart
SketchUp to see correctly sized Icons and drawing elements.
Unsupported environments
Apple macOS 10.12 (Mojave)
SketchUp 2018 has a known issue that leads to a one-time crash of SketchUp 2018 on MacOS
Mojave in the first 10-15 minutes (or so).
Windows Vista and older
These versions of Windows are no longer supported.
Apple macOS 10.10 (Yosemite) and older
These versions of macOS are no longer supported.
Linux
A Linux version of SketchUp isn't available at this time. However, you may be interested to see
how others have had success running SketchUp on Linux using Wine.
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Virtualized Environments
At this time, SketchUp doesn't support operation in a virtualized environments such as VMWare
or Citrix.
Per the SketchUp Pro License in section 1.1: You may not use or host the Software in a virtual
server environment.
Boot Camp/Parallels/VMWare
Neither Boot Camp, VMWare nor Parallels are supported environments.
Remote Desktop Connections
Due to hardware restrictions in shared environments we can't reliably predict how SketchUp
will perform. At this time SketchUp is not supported via a Remote Desktop Connection (RDC)
on any platform.
Note: SketchUp will run on multiple-processor machines; however, SketchUp will only use one
processor. SketchUp doesn't support hyper-threading or multi-threading at this time.
Note: You can use Logitech 3D Motion Controllers from 3Dconnexion to create models in
SketchUp. The 3Dconnexion website has more information about these controllers.
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Release Notes
SketchUp Desktop 2019.3
Released: October 14th, 2019
Version:
19.3.253 (Win 64-bit)
19.3.252 (Mac 64-bit)
Table of Contents
1. Sign In Workflow Changes
2. SketchUp Release Notes

Sign In Workflow Changes
What has changed?
Users will now sign into our desktop applications via an external web browser, instead of an
embedded web browser. This change impacts both subscription and classic license users.
The change in 2019.3 that will impact classic license users: Users need to be signed in
before accessing the 3D Warehouse, Extension Warehouse and Add Location, which they didn't
need to do in previous builds. Accessing these features will go through the new sign-in
workflow, which means classic license users need Trimble IDs (or Google IDs) to access them.
Why?
This past April, Google announced that it will no longer support Google Sign In through
embedded browser frameworks. In order to continue supporting Google Sign In, we’re following
one of Google’s recommended solutions: to have users sign in through their default web
browsers and capture the sign in information via a web server on their local machine
(127.0.0.1).
What does this mean from a user’s point of view?
•
•

All users need to be signed in to access the 3D Warehouse, Extension Warehouse,
Trimble Connect and Add Location from within the desktop apps.
When a user selects a ‘Sign In’ command from within a desktop app, the user’s default
web browser will open a new tab in order for them to sign in.

SketchUp Release Notes
Fixes
macOS Catalina Support
Added
•
•
•

support for macOS Catalina, which included the following updates:
Implemented the notarization process that will be required for macOS Catalina.
Fixed an issue where the Welcome Window’s templates panel sometimes loaded slowly.
Fixed an issue where text was displayed with a black background on some
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Other
Changed our internet connection tests to work more robustly across the globe.
• (Win) Updated libcrypto and libssl dlls to 1.1.1c.
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SketchUp Desktop 2019.2
Released: July 18th, 2019
Version:
19.2.222 (Win 64-bit)
19.2.221 (Mac 64-bit)
Table of Contents
1.
2.
3.
4.
5.

What’s new in SketchUp 2019.2
What’s new in LayOut 2019.2
SketchUp Release Notes
LayOut Release Notes
SketchUp API Release Notes

Enhancing your professional workflow—it's the small things that count!
We are excited to announce our second desktop product update since releasing SketchUp 2019.
We've been hanging out on the forum and researching at 3D Basecamp to get some insight
into your workflows. With your feedback, we've worked hard to update some top features in
SketchUp Pro 2019 and LayOut. Try out these new updates, and see how they impact your
professional outputs and workflows.

What's new in SketchUp 2019.2
The name of the game (update) is ease of use. This release has made SketchUp more intuitive
— and more fun to use. With more focus on improvements to imagery exports, usability, and
a seamless LayOut connection — your professional workflow will greatly benefit. Check out the
top features below.
Professional output enhancements
Exporting images. Exporting 2D graphics, raster files, and animations just got better. You
can now control the overall line thicknesses of exported images with our new line scale
multiplier, found in the export options dialogs. Before this change, line weights stayed the same
as the viewport which could make the line weight too small or too large. So, if you are
experiencing line weights that are too thick, you can make those line weights thinner. Also,
.png images now export with transparency so you can see what is behind the material while
compositing.
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Customizable unit settings. Have you ever needed to use different unit measurements for a
model? Now your model can be customized to show different unit measurements for area and
volume. For example, in a model of a room, you can use inches for the wall and feet for volume.
Available unit types: inches, feet, millimeters, centimeters, and meters.

Workflow improvements
Invert Selection. Just like the title suggests, it's the small things that help your workflow!
This new feature will allow you to select anything, then invert the selection of objects. This
makes it simple to select items and then perform actions on their inverse. The keyboard
shortcut for this will be: CTRL + SHIFT + I (Windows) or CMD + SHIFT + I (Mac).
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Importing files. The days of picking out your import file format from a long list are over. You
can now drag and drop ALL supported file types directly into your modeling window. By default,
you'll now see all supported file types available for import. Additionally, the DWG and DXF
importers now bring in fewer duplicate and messy edges.
Eraser Tool. Have you ever accidentally erased too much in your model? To make your
detailing workflow a little smoother and seamless, we added alt & cmd as modifier keys to
remove any unnecessarily highlighted lines that you might have accidentally captured during
your modeling efforts.

Section Planes. Cutting a model along a plane so that you can peer inside the model? We just
made this way smoother. Section planes now ask the user to name them after placing them in
the model. Simply place, then name.
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Send to LayOut. Clearly, we want to make LayOut even better to use! You can now send your
models directly to LayOut from the large toolset in the left-hand toolbar. If you haven't used
LayOut before, you should check it out now!
Large Area Imports for Add Location. You can now easily import large sites at full
resolution. How can you take advantage of this new feature? Simply zoom out a bit, then select
the level from which you want to import. Be aware that, importing very large areas with lots
of imagery can adversely affect performance in your SketchUp model. Check out our help center
to be sure you're aware of how to best handle lots of data in your models. Note that this feature
is only available to SketchUp Pro and Studio subscription holders.

What's new in LayOut 2019.2
The overall changes for LayOut can be summed up in a few words: improved overall interaction
for construction documentation. We focused on making the usability of LayOut more natural
and consistent with that of SketchUp. Check out these life-changing updates.
Professional output enhancements
Isometric dimensioning. It is now possible to make linear dimensions align with an isometric
viewpoint. This one is huge! Since an isometric drawing is a primary type of drawing in LayOut,
we wanted to make it smoother and more straightforward. You can now control extension lines,
gap distance, and align dimensions with isometric angles.

Auto-text. Similar to “smart labels”, you can now add text to dimensions without breaking the
automatic measurement. For example, let's say you create a wall dimension. You can
dimension a wall, add the word “height”, and the dimension measurement will still update if
the measurement changes. Pro tip: make sure your string has <> in it. For example, Height
<>' will turn into 'Height 132in'.
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Workflow enhancements
Rotating dimensions. Now, when your dimensions are off-axis, the bounding box will remain
aligned with the object so you can continue to scale it in the right orientation.
Scaling dimensions. All connected dimensions will move and scale with the parent object.
Just select the SketchUp model or Scaled Drawing or anything a dimension is attached to and
connected dimensions will come along for the ride.
Quicker editing. Staying consistent with SketchUp usability, you can now hit the return key
to edit SketchUp model views, groups, dimensions, or labels! Just select, press return, and
start typing!

SketchUp Release Notes
Bug fixes/small features added
We have fixed a good deal of bugs with this release and added some small features, including:
Stability
•
•
•
•
•
•

Fixed a crash that could occur when offsetting a chain of edges that resulted in a smaller
number of edges.
Fixed a crash that could occur when fixing validity errors in a model where the length
in a dynamic component is set to infinity.
Fixed a crash that could occur when copy/pasting certain section planes and saving the
model.
Fixed a crash that could occur when deleting a line with the Dimension, Rotate or
Protractor tools active.
Fixed a crash that could occur when offsetting open arcs so that they almost disappear.
[Win] Fixed a crash that sometimes occurred when changing scenes.
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Model Display
•
•
•
•
•

Fixed an issue where guides that are coincident with a section plane were not drawing.
Fixed an issue where profile lines for softened back edges were displaying as solid vs
with the dashed back edge stipple pattern.
[Win] Fixed an issue where SU could open with a blank workspace when using Intel
graphics cards with certain Intel drivers.
[Mac] Fixed an issue where line weight thickness was sometimes rendered incorrectly
on systems with two monitors.
[Mac] Fixed an issue where arrowheads incorrectly resized when clicking between lowres and Retina displays.

Tools/Inferencing
•
•
•
•
•
•
•
•
•

Fixed an issue where zoom could be too sensitive when zooming into a filled section
plane.
Removed the display of radial lines and centers when offsetting arcs, circles and
polygons to make interactions cleaner.
Fixed an issue where inferencing could not find an endpoint of a recently created edge.
Fixed an issue where, when offsetting a single painted face outward, the newly created
faces did not inherit the material of the original face.
Fixed an issue where the offset could be larger than expected when offsetting a circle
using the “allow overlap” modifier key.
Fixed an issue where, when offsetting a three pointed star, the offset could shift
incorrectly.
Fixed an issue where drawing small rectangles on small faces could cause the loss of
materials and/or faces.
Improved how the offset tool works with certain arcs to ensure arcs are retained in
more situations after an offset operation.
Fixed an issue where the Measure tool still showed the units of a face's area when the
display of units was turned off in Model Info.

Image export
•
•
•
•
•

Fixed an issue where sketchy edges in an image exported using the transparent
background option could display with a white halo.
Fixed an issue where transparent faces in an image exported with the transparent
background option displayed without transparency in other applications.
Fixed an issue where the width and height values in the Options dialog for image export
would not update when edited.
Changed image export to give consistent results for text and dimensions regardless of
the DPI of the display from which the export occurs.
[Mac] Fixed an issue where setting certain format-specific image export options had no
effect.

Miscellaneous
•
•
•

Fixed an issue where extensions licenses could not be obtained for users with a
SketchUp Subscription license. Extension licenses should be correctly obtained during
extension installation in all cases now.
Added a warning message when SU launches and is not using an available AMD or
NVIDIA graphics card.
Fixed an issue where guide points made by typing a length of 0 couldn't be selected.
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Fixed an issue where sampling with the Material Browser's eye dropper picked the
default material vs the sampled material when picking through a section plane.
Fixed an issue where the user could not import the JPEG file format.
Added timestamp and path name tool tip text to the Welcome Window's Recent Files
tab.
Changed the messaging in the "Oops...That didn't look like valid licensing info..." error
message for Classic licensing, to provide more precise instructions for resolution.
Updated the Trimble Connect extension to utilize a newer Connect API version.
Fixed an issue where the Help Center for errors on startup did not go to a language
specific link.
Fixed an issue where the Unit combo boxes were editable in Model Info.
Improved formatting of file location tool tip text in the Welcome Window.
[Win] Fixed an issue where recovered files were sometimes deleted during a revert
operation.
[Win] Fixed an issue where the SketchUp 'Send to LayOut' command did not work if
LayOut was already open with certain configurations.
[Win] SketchUp now displays backup (.skb) files when the user selects File > Open.
[Win] Fixed an issue where the STL Import Option choices for units did not persist when
closing and re-opening the Options dialog.
[Mac] Added the ability to save as older versions for Save A Copy As.
[Mac] Changed the "Length" label in Entity info to be more accurate depending on
which entity type is selected.
[Mac] Fixed an incorrect Japanese translation in the Styles tray.

Known Issues
Certain extensions are not yet compatible with SketchUp 2019.2. We are not able to know
every extension that is affected, but we don’t believe that the number of extensions affected
is large.
We know that Thea is not yet compatible with SketchUp 2019.2. If you require Thea Renderer,
we recommend that you not upgrade at this time, until they are able to release a compatible
version.
Please see this SketchUp Forum post for more information.

LayOut Release Notes
Bug fixes/small features added
We have fixed a good deal of bugs with this release and added some small features, including:
Stability
•

Improved the way we handle selection and multiple select.

SketchUp Model View
•

Render Mode and Scene can no longer be changed when selecting multiple Locked SU
model viewports.
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DWG Export
•

Fixed an issue where a SketchUp model view that was grouped would export at 1:1
PaperSpace scale.

Miscellaneous
•
•
•
•
•
•
•
•
•
•

Addressed a problem where auto-render could cause an infinite loop or latency in the
application when a model failed to render.
Fixed a problem where LayOut and Style Builder did not display offline Action Manager
notifications.
Fixed an issue where the clipping mask would be lost after editing.
Improved Welcome Window load time.
Changed the warning message when a model fails to render to provide instructions on
how to resolve the rendering failure.
[Win] Fixed an issue where the Welcome Window would not scroll.
[Win] Fixed an issue where the LayOut window would lose focus when using the label
tool and multi component component names.
[Win] Corrected an inconsistency where the list of available versions in Save As were
in a different order from the way they were displayed on the Mac or in SketchUp.
[Win] Removed the "All Files(*.*)" entry from the File > Save and File > Save As file
picker dialogs.
[Mac] We have restored the “Space” and “List” functionality for text editing.

SketchUp API Release Notes
What's New?
Ruby Version Upgrade
The SketchUp application and the SDK have been updated to Ruby version 2.5.5. This was
done to address an optimization bug in 'if' and 'jump' and to improve security.
Mouse Wheel in the Ruby API!
In addition to exposing new functionality in SketchUp we exposed the mouse wheel event to
custom Ruby tools. This opens up new possibilities for interacting with the viewport and UI and
could make for some exciting new Ruby extensions.
Textures - Export Performance and other Improvements
Exporting texture data and performance was a theme across both APIs. For anyone exporting
textures, we fixed two specific issues.
1. In the C API, previously we were re-writing all images, even if SketchUp itself was not
altering the image (ie. with a colorization effect). This significantly increased export
times. We've changed it to now just dump the original file.
2. In the Ruby and the C API, we've made a change to how we export colorized png's.
Previously we were using the highest (and slowest) compression setting. We've adjusted
this setting to a more moderate compression. Our 4k x 4k image export test reduced
from ~50 seconds to only ~6 seconds.
A number of missing "Remove" functions were added to the C API, further improving the feature

SketchUp Help Pages – version 19.

Page 546/567

parity with the Ruby API.
Ruby API Additions and Improvements
•
•
•
•

•

Added onMouseWheel event to the Tool interface.
Added Sketchup::Selection#invert
Added :scale_factor to view.write_image to allow the API user to control the scaling
factor of viewport dependent elements such as line weights.
Added the new area and volume unit settings to Sketchup::OptionsProvider.
o Added Sketchup.format_volume.
o Added constants to the Length class for area and volume units to be used with
the OptionsProvider.
Documented :source => :framebuffer option in Sketchup::View#write_image that
dumps the current frame as drawn in viewport. This has existed since SketchUp 7.

Ruby API Bug Fixes
•
•
•
•
•
•

Update Ruby Version to 2.5.5 to fix optimization bug in Ruby 2.5.1.
Fixed possible crash in Sketchup::Entities#clear.
Added checks to prevent Image materials from being assigned to normal drawing
elements. Doing so will now throw an ArgumentError.
It is no longer possible to assign Sketchup::Image materials to entities.
onViewChanged now triggers when the viewport changes size.
Dynamic Component no longer throws an error on deleted entity.

SketchUp C API Additions and Improvements
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Added SUApplicationGetActiveModel
Added SULengthFormatterGetAreaUnits
Added SULengthFormatterSetAreaUnits
Added SULengthFormatterGetVolumeUnits
Added SULengthFormatterSetVolumeUnits
Added SUMaterialGetColorizeDeltas
Added SUMaterialGetColorizeType
Added SUMaterialSetColorizeType
Added SUMaterialGetOwnerType
Added SUModelGetAllMaterials
Added SUModelGetNumAllMaterials
Added SUModelGetGuid
Added SUModelLoadDefinition
Added SUModelRemoveComponentDefinitions
Added SUModelRemoveLayers
Added SUModelRemoveMaterials
Added SUModelRemoveScenes
Added SUStylesRemoveStyle
Added SUStylesSetSelectedStyle
Added SUTextureWriteOriginalToFile
Removed Deprecated C++ Com Interface.
Updated SDK docs on VC++ runtime versions.
It is now possible to use the C API to get the active model using
SUApplicationGetActiveModel. This is for Read Only access to the model. Mac builds
were missing the symbols for Live C API. They are now included in this build.
For more information about the Read Only Live C API, how to link correctly - read this
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forum post.
SketchUp C API Bug Fixes
•
•
•
•
•

Fixed a bug where SUModelSaveToFileWithVersion and SUModelSaveToFile weren't
updating the model's GUID.
Fixed SUStylesAddStyle where it would fail to load some .style files.
SUComponentInstanceFromEntity returns NULL if underlying entity is a Group
Fixed a performance regressions where SUTextureWriteToFile would rasterize noncolorized texture instead of just dumping the original file data.
It is no longer possible to assign Sketchup::Image materials to entities

Ruby API and C API
•

Increased performance of PNG image export for colorized materials. Previously, it used
to use max compression. Now we use a more balanced compression setting. This affects
SUTextureWriteToFile/Sketchup::Texture#write as well as the texture writer. We also
added some general optimizations for SUTextureWriteToFile/Sketchup::Texture#write.
On a 4Kx4K texture we saw the processing time drop from ~50 seconds to ~6 seconds.

C++ API (SkpReader) Removal
We recently announced that we had done the work to remove the C++ API from the SketchUp
SDK. This is our first release that does not support the C++ API. See this forum post for more
information:
https://forums.sketchup.com/t/developer-announcement-c-api-removal/94943
Who does this affect?
This change should not affect most people, as most people are using our C API. However,
anyone that is still using the C++ API which has been included in the “deprecated” folder in
the SDK since SketchUp 2013 will need to migrate their code to the C API. You will still be able
to read and write SketchUp 2019 and earlier .skp files using the C++ API that we released with
previous versions of SketchUp 2019. But you will not be able to add a custom exporter that
uses the C++ API to SketchUp. The bridge that connects the C++ exporters to the SketchUp
exporter interface has been completely removed in this and all future versions of SketchUp.
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SketchUp Desktop 2019.1
Released: April 8th, 2019
Version:
19.1.174 (Win 64-bit)
19.1.173 (Mac 64-bit)
Table of Contents
1. SketchUp Release Notes
2. LayOut Release Notes
3. SketchUp API Release Notes

SketchUp Release Notes
Fixes:
•

•
•
•

•
•

Fixed an issue where the classic and trial licensing information displayed to the user in
the Welcome Window could be confusing. Specifically:
o When a user enters a classic license alongside an active SketchUp trial, they are
still be eligible to try other products in the Studio bundle.
o The licensing panel now defaults to the Classic tab if the user has entered a
Classic license.
o If the user has entered a Classic license, we no longer show trial expiration text
in the upper right corner of the Files panel.
Fixed an issue where exporting using AutoCAD 2018 file format would create a "Student
Version" plot stamp for both SketchUp and LayOut when the file was opened in AutoCAD
2019.
Fixed an issue where text would not export with a 2D DWG/DXF export.
Fixed an issue where auto-save files did not persist on the Mac after a reboot or
shutdown.
o On Windows, recovered files are now saved here:
C:\Users\YourUserName\AppData\Local\SketchUp\SketchUp
2019\SketchUp\working\SKETCHUP\RecoveredFiles
o On the Mac, recovered files are now saved here: ~/Library/Application
Support/SketchUp 2019/working/SKETCHUP/Recovered Files
(Win) Fixed an issue where models would open slowly with the Materials dialog
expanded.
(Win) Fixed an issue where the Add License button was not working for Windows OS
usernames having an apostrophe.

LayOut Release Notes
Fixes:
•

Fixed an issue where LayOut could crash when opening a file. This was caused by corrupt
paths not being removed when they were detected.
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SketchUp API Release Notes
Fixes:
•
•
•

Fixed the accepted types for the "point" in entities.add_text
Fixed Model.save for VERSION_2019
Fixed crash when rendering_options["RenderMode"] = 4
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SketchUp Desktop 2019
Released: February 5th, 2019
Version:
19.0.685 (Win 64-bit)
19.0.684 (Mac 64-bit)
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SketchUp Pro 2019 Release Notes
A New Way to SketchUp
Subscriptions and Classic Licenses
Users now have the choice to buy a SketchUp subscription or a classic license of SketchUp Pro
for desktop. Learn more about our subscription offerings in this Help Center article.
Trimble ID
A Trimble ID (TID) will be the gateway to access any SketchUp products. A TID will allow you
to download a trial, buy a classic license or subscribe. You can sign up using an existing Gmail
account or you can create a TID using a valid email address.
Launch Experience
We’ve refreshed the launch experience on SketchUp’s desktop applications—SketchUp Pro for
Desktop, LayOut, and Style Builder. To access these applications, just sign in with a Trimble
ID or enter an active classic license.
30 day Trials
There are a number of products you can explore during your 30-day trial of SketchUp Studio.
The free trial currently includes:
•
•
•
•
•
•

SketchUp for Web
SketchUp desktop applications: SketchUp Pro for Desktop, LayOut, Style Builder.
Trimble Connect Personal (5 collaborators, 2 projects, and up to 10 GB of cloud storage)
Sefaira (building performance analysis software).
Augmented reality viewing on SketchUp Viewer for iOS and Android
Viewing on XR applications: HTC Vive, Oculus Rift, Hololens, and HP Windows Mixed
Reality
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What’s New in SketchUp Pro for Desktop?
Welcome Panel (SketchUp Pro for Desktop + LayOut)
We’ve made some updates to our Files, Learn, and Licensing tabs to make it easier to manage
projects and licenses. While we were at it, we added links to learning resources directly into
SketchUp and LayOut.
Files tab: When you launch SketchUp or LayOut, you’ll see a Files panel where you can manage
default templates and access new, recent and recovered files. To change to a different template
when opening a new file, select the “New From Template” option in the File pulldown menu.
Learn tab: We are introducing a new portal for training content, appropriately named,
the SketchUp Campus. This is the hub for both beginner and advanced learning through video
courses that will eventually cover the entire SketchUp family and many professional industry
work flows.
Licensing tab: You can still easily access your licensing information from within SketchUp and
LayOut. When you select the licensing tab, you can choose to view either your classic license
or subscription information.
Default Toolbar Changes: We’ve made some new updates to the toolbars in SketchUp Pro
and LayOut. You’ll notice a “My Account” icon in the top upper-right hand side of the screen.
Here, you can access your licensing information, sign in and sign out.
Dashes: Solid lines don’t always tell the full story. Sometimes you need a dash pattern to
convey your design idea. Whether you need to demarcate a property boundary, identify what
is proposed, or identify walls for demolition, adding a stipple might be your best solution.
(see images pp. 246 & 247).

That’s why we’ve incorporated dashed lines into SketchUp Pro 2019. These dashes are
properties of Layers and can be controlled from the Layers panel. Even better, components on
layers will inherit the dash pattern. In LayOut, your dashes will show in the viewport at any
screen scale and in all render modes with the ability to edit the dash width and scale.
When you’re ready to export, SketchUp can convert your dashed pattern into a bunch of file
formats: PDF, EPS (vector), images (raster), and DWG/DXF.
SketchUp Tape Measure Tool
Upgrades to the Tape Measure tool mean less time you’ll spend opening up Entity Info or
looking at the Measurements box. Now, you can get the length of edges, area of faces, and
coordinates of midpoints and intersections straight from an inference tip.
Compatibility Mode for Windows 10
It is no longer necessary to run SketchUp in compatibility mode. Compatibility mode was
employed for several SketchUp releases as a workaround for problems with older Intel HD 2000
and HD 3000 GPUs on Windows 10. These GPUs have been deprecated by Intel on Windows
10 and because this workaround introduced problems of its own, it has been removed. As a
result SketchUp, LayOut, and Style Builder will no longer run with Intel HD 2000 and HD 3000
GPUs on Windows 10.
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Support for macOS Mojave
Our QA team has smashed and banged on Apple’s newest operating system, macOS Mojave,
enough to say that SketchUp 2019 is fully compatible.
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What’s New in LayOut?
LayOut File Locking
We’ve made it harder to overwrite your LayOut files with unintentional edits. If you have
multiple people working in the same file or if you’ve opened a file in two separate LayOut
instances, we’ll temporarily lock your file and let you know it’s “read only.” Simple.
SketchUp Dashes Control
With the introduction of Dashes in SketchUp, LayOut now has the ability to modify how those
lines styles are displayed. With the SketchUp model viewport selected, the SketchUp
Model inspector will allow for modification.

LayOut’s SketchUp Model inspector

Export for SketchUp feature
SketchUp has always played nice with others. We’ve been hard at work making it even easier
for you to move between the software you need. In LayOut we have added a ‘Export for
SketchUp’ feature to the DWG/DXF exporter that places all LayOut entities into the Model
Space so that SketchUp can now ‘play’ with all LayOut data. As part of this feature Groups are
sent over as SketchUp Components, Fills and Patterns are sent over as SketchUp faces for easy
Push/Pull’n.
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LayOut’s DWG/DXF Export Options dialog

Plan and Elevation created in LayOut
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Plan and Elevation imported into SketchUp via the new “Export to SketchUp

With the 2019 release, you can now import and export AutoCAD 2018 DWG files in SketchUp
Pro and LayOut. In LayOut, we’ve made it easier to export to DWG, and added the ability to
adjust the Model Space Units when you import a DWG.

LayOut’s DWG/DXF Import dialog
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Mouse Scroll Speed Controller
We now provide users the ability set their mouse scroll speed within LayOut. With so many
variances in systems, this is a helpful way to improve your LayOut experience.

LayOut’s Mouse Scroll Speed Dialog

Bug Fixes/Small Improvements in SketchUp
In addition to the above, we’ve been heads down fixing bugs and adding some smaller features:
Stability
•
•
•
•
•
•
•
•
•
•
•

Fixed a crash that could occur when exporting models with section planes to PDF.
Fixed an issue where deleting lines could cause invalid text entities that corrupted the
camera view / made the model unusable.
Improved the overall stability of 2D and 3D DWG importing and exporting.
(Win) Fixed a crash that occurred when importing shortcuts with certain key
combinations (including arrow keys, Ctrl -, Ctrl =).
(Mac) Fixed a very frequent crash that could occur when working with multiple
documents, one of which has shadows on.
(Mac) Fixed a frequent crash that could occur when doing certain actions during scene
transitions.
(Mac) Fixed a frequent crash that could occur when cancelling out of certain tools and
switching documents.
(Mac) Fixed a crash that could occur when painting a face after closing a document.
(Mac) Fixed a crash that occurred on exit if a material was added to a material list
created outside of SketchUp.
(Mac) Fixed a crash that occurred when exporting to IFC in JA.
(Mac) Fixed a crash that occurred when adding a new texture to a newly created
materials list in Materials dialog.
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(Mac) Fixed a crash when deleting the values in the Style Browser.

Model Display
•
•
•
•
•
•
•
•

Improved the rendering of stipple patterns when there is rotation so that the stipple
pattern is always perpendicular to the line.
Added anti-aliasing to stipple patterns.
Changed the alpha value for back edges.
Improved filled section cut rendering, allowing a section to be filled when one hidden
face surrounded by two visible faces is cut.
Added the ability to allow soft profiles to be displayed as back edges.
Added a space between a number and metric units when formatting lengths displayed
in SketchUp - e.g. 10 mm.
Fixed an issue where diagonal lines did not display well with faster transparency + 0x
MSAA.
Fixed an issue where lines could be clipped/disappear when zooming in with a section
cut.

Tools/Inferencing
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Enhanced the Measure tool to show the length of an edge and area of a face in the “On
edge” and “On face” tooltips.
Enhanced the Measure tool to show the coordinates of vertices in the Measurements
toolbar (VCB) and a tooltip.
Fixed an issue where Offset could give unexpected results when offsetting shapes with
rounded corners.
Fixed an issue where selection was slow on some Windows 10 machines.
Fixed an issue where you could not enter Imperial inches units into the Measurements
toolbar (VCB) when model units were set to metric.
Fixed an issue where you would sometimes get an unwanted component origin
inference.
Fixed an issue where you could pick up an unexpected "On Section" inference with a
hidden section plane.
Fixed an issue where zooming could lag on some machines with Intel GPUs at higher
MSAA settings.
Fixed an issue where zooming could be very slow when the mouse is not over any
geometry.
Fixed an issue with the Rectangle tool where midpoints could not always be inferred
when using locking.
Fixed an issue with the Rectangle tool where the alignment preview icon was incorrect
when inside a rotated component.
Fixed an issue where the Offset tool sometimes based its offset on vertices and not
edges.
Fixed an issue with the Measure tool where lines did not always turn bold when Shift or
the arrow keys were used to constrain lines.
Fixed an issue with the Move tool where lines did not turn bold when the cursor was
directly in front of the dashed lines when the arrow keys were used to move an object
in one of the x,y,z axis directions.
Fixed an issue where the picking order was incorrect for a rectangle on top of an image,
resulting in unexpected behavior when using the Text tool on the rectangle.
(Win) Fixed an issue where some of our standard shortcuts unexpectedly changed the
drawing mode for the Rectangle tool to “Draw about center”.
(Win) Fixed an issue where 3D Text dialog checkboxes were difficult to use when scaling
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was greater than 100%.
(Mac) Fixed an issue in which the default extrusion value changed each time 3D Text
was placed if not using units of Inches.

DWG Import
In SketchUp you now have the ability
interoperability for CAD and BIM workflows.
•
•
•
•

to Import and Export

Materials improving

Fixed an issue where polylines with arcs would import with extraneous geometry.
We now import entities on frozen layers as non-visible.
We revised the precision of our importer to better allow for import of small entities,
faces and solids.
We revised our importer to adaptively calculate the scale factor on imported geometry.

DWG Export
•
•
•

We fixed an issue where geometry could get lost at a very small scale.
We improved the precision of Arcs and Circles so that they would be more accurate and
created for most conditions.
(Mac) We fixed an issue where wide polylines were not being created when exporting
2D DWG with automatic width checked.

Vector Output (PDF export, Vector printing, Vector and Hybrid rendering modes in
LayOut)
•
•
•
•
•
•
•
•

Fixed an issue where extra lines were seen when a section cut is coincident with a face.
Fixed an issue where extra lines were seen when extruded circles are cut along their
center.
Fixed an issue where hidden divided edges on top of faces drew as if they were visible.
Fixed an issue where images incorrectly showed a border around them.
Fixed an issue where lines were missing with some plan view models.
(Win) Fixed an issue with .PDF Export where the actual line widths were not exporting
correctly.
(Win) Simplified the .PDF and .EPS dialogs and added control over the Line Scale.
(Mac) Wording with Export to .PDF and the Print dialog has changed from ‘Line Weight’
to ‘Line Scale’.

Layers Dialog
•
•
•

Updated the active layer and visible icons in the Layers dialog to align across LayOut &
SketchUp.
Adjusted layer panel column ordering to address issues where the active layer may be
changed unintentionally for new users, and to reduce the prominence of the active layer
controls.
Layer Name sorting logic has changed o For context, this would occur when sorting by name previously:
Layer1
Layer10
Layer11
Layer2
Layer22
Layer3

SketchUp Help Pages – version 19.

Page 559/567

Now this will occur:
Layer1
Layer2
Layer3
Layer10
Layer11
Layer22
Miscellaneous
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Fixed an issue where SketchUp models performed slowly in some models with a section
plane.
Fixed an issue where the Entity Info "Toggles" icons did not update visually when tab
was pressed.
Added the ability to edit a selected component by pressing Enter.
Fixed an issue where text/dimensions set with the “height” property scaled incorrectly
on high DPI machines.
Fixed an issue where models with lots of construction points performed very poorly.
Fixed an issue where exploding a classified component instance produced an extra
hidden classified entity.
Fixed an issue where Entity Info did not report area for surfaces.
Fixed a strange jump that could occur when editing component instances far from the
origin.
Fixed an issue where Component Definitions in Model Info > Statistics were not updating
properly when adding or deleting a component.
Fixed an issue where the shadows date and time controls do not scale properly on high
DPI displays.
Fixed an issue where SketchUp would take focus during start up preventing work in
other apps.
Fixed an issue where Add location terrain failed to import for some locations.
Fixed an issue where a "SketchUp Make" dialog was appearing in SketchUp Pro.
Fixed an Add Location issue where terrain import failed when a location has gaps in
terrain coverage.
Added the ability to see a full shortcut description in the Preferences dialog.
Improved sorting of layers to be more intuitive.
Fixed an issue where Activating Shadows via the View menu would not require that the
model be saved.
Upgraded the version of Chromium that SketchUp uses.
Updated error messages to refer to component definition instead of component name
for consistency with Entity Info terminology.
Updated template names to reduce redundancy with Units specifications.
Fixed an issue where the "Enable length snapping" option could not be disabled when
using the Architectural units format.
Fixed an issue where whole numbers were not displayed consistently when using the
Engineering units format.
Fixed an issue where validity checking did not occur when saving/opening a SU 2015 or
newer model in some cases.
Fixed an issue where you could have unexpected results when changing the number of
segments of a polygon or arc.
Removed the ability to sign out from the 3D Warehouse and Extension Warehouse pages
within SketchUp to avoid signing users out of SketchUp and thus losing access to their
subscription.
Fixed miscellaneous language translation and truncation issues in localized builds.
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Fixed an issue to provide dynamic block support for DWG imports.
Fixed an issue where certain .STL files would fail to load.
(Win) Fixed an issue where the Scene tab’s Rename item context menu was missing.
(Win) Fixed an issue where SketchUp did not display area for curved surfaces.
(Win) Fixed an issue in which a Tray context menu would appear when clicking within a
context menu that was outside of the drawing window.
(Win) Fixed an issue in which tray dialogs would flicker when resized.
(Win) Fixed an issue in which 3D Warehouse and Extension Warehouse dialogs would
flicker when resized.
(Win) Fixed an issue where the user was not alerted that autosave files existed when
opening files via double-clicking.
(Win) Changed the “Length” label in Entity Info when circles, polygons and arcs are
selected.
(Win) Changed the error message you see when running the CheckUp application and
the RAM can’t be determined to be more accurate.
(Win) Updated the File > 3D Warehouse menu to show Share Component instead of Get
Models.
(Mac) Fixed an issue where autosave files were not deleted after reopening SketchUp
after a crash and taking actions.
(Mac) Fixed an issue in Image Export where the Resolution set by the user would not
persist on Mac.
(Mac) Fixed an issue where the user was not prompted to save an autosaved file after
a crash.
(Mac) Fixed an issue with the default file name supplied when downloading Unicode
models outside of SketchUp.
(Mac) Fixed an issue where files saved to folder names containing special characters
would cause autosave to fail.
(Mac) Fixed an issue in which materials were temporarily displayed in 3d Printing library
when a materials list was removed.
(Mac) Fixed an issue in which user could overwrite their entire Templates folder.
(Mac) Fixed an issue in which the Soften/Smooth Edges dialog initially displayed angle
of 360 degrees instead of 36 degrees.
(Mac) Fixed an issue where templates saved with names containing unicode characters
displayed an incorrect template name.
(Mac) Fixed an issue where exported animation used the incorrect size.
(Mac) Fixed an issue where the icon for the Section Fill button was missing in SketchUp
Viewer.
(Mac) We changed ‘Line Weight’ to ‘Line Scale’ in the Print and Export to 2D Graphic…
dialogs.
(Mac) We now allow assign entities color ‘Bylayer’ on 2D Section Slice.
(Mac) Fixed an issue in which the Aspect Ratio for Animation export wasn’t saving.
(Mac) Changed SketchUp to not reopen crashed models on re-launch.
(Mac) Fixed an issue where the paint bucket cursor changed back to OS cursor after
painting a face.
(Mac) Fixed issue in which 3D Warehouse window would show up blank when trying to
access while offline. Now a message appears indicating you are offline.

Bug Fixes/Small Improvements in LayOut and Style Builder
In addition to the above, we’ve been heads down fixing bugs and adding some smaller features:
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Stability
•
•

Fixed a crash that could occur when rendering or re-rendering a SketchUp viewport in
LayOut using Vector or Hybrid mode.
We had an issue where LayOut could lose the association to file references (SketchUp
models and images). We found this to be related to the users temp folder being removed
or over written possibly by an anti-virus utility or disk clean up process. This seemed to
be most obvious when a copy paste was used to import files. To remedy this we have
moved the active working file outside of your system temp folder.

Your working LayOut files will now exist in the following location:
Windows: c:\Users\<username>\AppData\local\SketchUp\SketchUp
2019\LayOut\working
macOS: /Users/<username>/Library/Application Support/SketchUp
2019/LayOut/working
•
•
•
•
•
•
•

We fixed a crash when opening a document with the units set to Points.
We fixed an issue where Path entities could get corrupt.
(Win) We fixed a crash when exporting to .PDF if the file type extension was removed.
(Mac) We fixed a crash if you would enter an empty value in the ‘Line Width’ field of the
SketchUp Model inspector.
(Mac) We fixed a crash when purging file references.
(Mac) We fixed an issue where a crash would occur when accessing ‘Other’ on the Text
Styles pulldown when rulers are active. We are preventing the accessory view from
coming up and now Text edits can only be done from the Fonts panel.
(Mac) We fixed a crash in the Label editor flyout.

SketchUp Model View
•
•
•
•
•
•

We fixed an issue where the SketchUp actual font height would display at the LayOut
Paper Space height.
We fixed the Hotspot on SketchUp models to better correspond with the cursor location.
Fixed an issue where internal lines would disappear when Vector rendering with the
‘Wireframe’ style.
(Win) Vector and Hybrid render has been improved to fix a number of issues where
either the background color or the section fill color would ‘flood’ beyond the SketchUp
Model view.
(Win) We fixed an issue where Raster rendered viewports would not display line weights
correctly especially on high resolution monitors.
(Mac) We fixed an issue when exporting to .PDF where lightened images would be
produced with Mac OS 10.13.4 and higher.

Table Tool
•
•

You can now copy and paste a pattern fill within a Table.
Copy and pasting Table data is now text and not an image.

DWG Import
•

We fixed an issue where Dimensions could get misaligned on import.
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We fixed an issue where an import would fail if the Viewport layer was not visible in
AutoCAD (off or frozen).
We improved our importer to better support non-rectangular viewports.
We fixed a bug where an import would fail with certain non-uniform scaled blocks.
We have improved our precision with small objects so that the import would not fail or
produce strange artifacts.
We fixed how underlined text is imported.
We now respect the visibility state of a Dynamic View Block.
Fixed an issue where LayOut text with fill was not being converted to AutoCAD filled
text.

DWG Export
•
•
•
•
•
•

Fixed an issue where text fill was not being exported on Text, Labels and Dimensions.
Fixed an issue where text was being exported too large.
We had a bug where text size was lost on user modified dimensions.
Fixed an issue where the text style and height within a Table would lost on export.
We had an issue where exported arcs could be drawn inside out.
(Mac) Fixed a crash when exporting with an attached .PDF.

Vector and Hybrid rendering in LayOut
•
•
•
•
•
•

Fixed an issue where extra lines were seen when a section cut is coincident with a face
when using Vector/Hybrid rendering in LayOut.
Fixed an issue where extra lines were seen when extruded circles are cut along their
center when using Vector/Hybrid rendering in LayOut.
Fixed an issue where hidden divided edges on top of faces drew as if they were visible
when using Vector/Hybrid rendering in LayOut.
Fixed an issue where images incorrectly showed a border around them when using
Vector/Hybrid rendering in LayOut.
Fixed an issue where lines were missing when Vector rendering some plan view models
in LayOut.
Fixed an issue where extension lines were not drawn when using Vector/Hybrid
rendering in LayOut.

Scaled Drawing
•

We fixed an issue where the paper space dimension was being used with certain arc
types.

Miscellaneous
•
•
•
•
•
•
•

We now allow users to convert the leader type on multiple selected dimensions from
the rt. click context menu.
We fixed a bug where labels would not align text correctly.
An issue has been fixed with dimensions where the manual set scale would always
default to Auto Scale.
We added a new ‘Hidden’ style dash pattern to be consistent with SketchUp’s dash
patterns.
We fixed an issue where click dragging would pick up the transform gizmo.
An issue with the Path tool has been fixed where inferences would be lost if esc or undo
was performed during input.
We fixed an issue where manipulating a copied Rectangle would give disproportionate
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results.
We fixed an issue where Rounded rectangles would not scale proportionally.
We fixed an issue where ‘Sample’ would go away during with the Style tool when the
cursor was moved.
The text tool has been fixed to allow highlighted text to be underlined individually.
Fixed an issue where the Align vertical icon was not aligned vertically.
Fixed an issue where Run of Dimensions would display the wrong value with entities
that are off axis.
(Win) We fixed an issue with the Text tool so that the Anchor point and Alignment
correspond with start location and mouse sweep direction.
(Win) Fixed an issue in presentation mode when changing pages would cause the display
to zoom in when your resolution was set to anything but 100%.
(Win) A crash has been fixed when switching between inspectors.
(Mac) We fixed an issue where the Format option will not be visible on the exporter
dialog when dialog is maximized on macOS High Sierra.
(Mac) We fixed an issue with Dimensions where editing the text color settings from the
font panel would not take effect.

SketchUp and LayOut API Release Notes
Upgrade to Ruby 2.5.1
We have upgraded from Ruby 2.2.4 to Ruby 2.5.1. These upgrades tend to introduce subtle
changes to the Ruby language that sometimes are difficult for us to find in our internal testing.
Our testing has not found any major compatibility issues between Ruby 2.2.4 and the new
2.5.1 and we expect the upgrade for most developers should be relatively straightforward.
Dashes
Stipples and dots and dotted stipples, oh my! SketchUp has added a Dashes feature that allows
for unique line styles to be applied and controlled at the Layer level. We have exposed this new
feature in the Ruby and C APIs. See the Improvements and Fixes sections of each API for a list
of classes and methods we’ve added. See the documentation for each API for complete
documentation on how to use these features.
Materials Bug Fixes and Improvements
The Extensibility team has done some code refactoring around how materials are named,
created, and duplicated in both the UI and in the core SketchUp code. The main change that
will be visible to developers is that we fixed a bug that was introduced in SketchUp 2018 where
if Ruby tried to name a material to its current name ie: material.name = material.name it
would fail, which was unexpected and unnecessary. There was also a bug where fetching a
material by using its string name could fail due to a syncing error in the internally cached list
of materials. We improved it so that scenario no longer fails. We also did some other code
cleanup around disallowing duplicate material names via the UI which should not affect the
Ruby API.
InstancePath Support for Dimensions and Text
In SketchUp 2019 we have added InstancePath support to our existing DimensionLinear and
Text classes. Now when creating a Linear Dimension, or an attached Text object, you can attach
it to a nested entity by providing a valid InstancePath object, or an array version of an instance
path. This will allow you to create a dimension in model space, but attach it to a valid nested
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entity. The linear dimension or text will then be attached to that entity, exactly how it is when
linear dimensions and text are created via the UI.
Ruby API Breaking Changes
•

•
•

SketchUp changed how it presents units. Now it adds a space between the number and
the unit indicator. If your extension uses a method of your own creation to interpret
strings formatted by SketchUp you might find it doesn't work anymore if you don't
account for the extra space. For example:
o Before 2019: "2.5mm"
o Now in 2019: "2.5 mm"
Ruby Version Upgrade - Ruby 2.5 removed the method: Dir::Tmpname.make_tmpname
If you were using that method, you will need to find an alternative
Entity.delete_attribute no longer returns “true” when attempting to delete a nonexisting dictionary key

Ruby API Additions and Improvements
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Update Ruby on Windows to use the right location for cacert.pem
Ensure Ruby uses a recent OpenSSL version
Fixed a regression on the Mac where renaming a material via the API will create
duplicate materials
Upgraded ruby version from 2.2.4 to 2.5.1 for both mac and windows
Added Sketchup::Tools#active_tool that returns the active Ruby tool
Added import_materials option to Sketchup::Model#import for dwg importer
Added instance path support for Sketchup::Entities#add_text
Added instance path support for Sketchup::Entities#add_dimension_linear
Added Sketchup::LineStyles class
Added Sketchup::LineStyle class
Added Sketchup::Layer#line_style=
Added Sketchup::Model#line_styles
Improved String.to_l which parses a String into a Length is now able to parse strings
that have a space between the number and unit. It can parse both "2.5mm" and "2.5
mm"
Improved Sketchup::InstancePath.new now accepts a path that includes a
Sketchup::Image object

Ruby API Bug Fixes
•
•
•
•
•
•
•
•
•
•
•
•

Fixed a crash upon exit on Mac when a FrameChangeObserver is active
Fixed an issue where Sketchup::Model could become unusable after calling
.singleton_class.
Fixed Ruby-created dimensions don't highlight when non-associated
Fixed Ruby-created dimensions don’t hide correctly when “Hide Foreshortened” is
enabled
Fixed SketchUp crash when constructing Geom::PolygonMesh with negative values
Fixed Ruby DWG Importer units were not working correctly
Fixed Geom::PolygonMesh will not accept negative numbers as parameter
Fixed Extensions are loaded in a non-deterministic order on High Sierra
Fixed SketchUp crashes when attempting to load component made in newer version
Fixed typo concerning merge_coplanar_faces in the Importer Options documentation
Fixed regression in SU 2018 when renaming a material with the same name
This used to throw an error when it should have been a no-op
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Fixed regression in SU 2018 were model.materials["MaterialName"] might fail
Fixed a crash when loading a component made in a newer version of Sketchup
Fixed an issue where the Ruby Console would fail with some ascii characters
Fixed UI::HtmlDialog such that non-resizable dialog doesn't use width and height from
preferences.
View.write_image should throw an error if there are more than 5 params passed in.

Miscellaneous
•
•

Fixed: Advanced Camera Tools - Subsequent Frustums are additive and can get quite
large.
(Mac) Fixed Extension Warehouse Icons appearing on web dialogs on Mac Mojave.

SketchUp C API Additions and Improvements
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Added SUDimensionGetFont()
Added SUDimensionSetFont()
Added SUDimensionLinearGetAlignment()
Added SUDimensionLinearGetTextPosition()
Added SUFontFromEntity()
Added SUFontToEntity()
Added SULayerGetLineStyle()
Added SULayerSetLineStyle()
Added SULengthFormatterGetForceInchDisplay()
Added SULengthFormatterSetForceInchDisplay()
Added SULineStyleGetName()
Added SULineStylesGetLineStyleByName()
Added SULineStylesGetLineStyleNames()
Added SULineStylesGetNumLineStyles()
Added SUModelGetImageDefinitions()
Added SUModelGetLineStyles()
Added SUModelGetNumImageDefinitions()
Added SUTransformationIsMirrored()
Added Return value SU_ERROR_SERIALIZATION for method SUStylesAddStyle()
Fixed SUDimensionLinear bug with setting a hidden property
Fixed SUDimensionRadiaul bug with setting a hidden property
Fixed SUTypedValueGetArray bug where the `out` param wasn't being set.
Fixed SUTypedValueGetArray memory leak.

DWG Importers and Exporters
•

Upgraded to TEIGHA 4.3.2

Layout Ruby API for SketchUp
•
•
•
•

Document.save will now throw an error if the file is already open in LayOut
Added Layout::Path#winding to get the current winding direction of the path. Returns
one of the new constants Layout::Path::PATH_WINDING_NONE,
Layout::Path::PATH_WINDING_CLOCKWISE, or
Layout::Path::PATH_WINDING_COUNTER_CLOCKWISE.
Added Layout::SketchUpModel#dash_scale to get the current scale value of stipples in
a SketchUp Model Ref. A value of 0.0 indicates the dash scale is automatically
determined based on the line weight.
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Added Layout::SketchUpModel#dash_scale= to set the scale value of stipples for the
SketchUp Model Ref. A value at or below 0.0 will cause the scale to automatically be
determined by the line weight.
Fix documentation of Layout::Path#append_point. When appending a bezier path
segment, the params should have been (control_1, control_2, point) and not (point,
control_1, control_2).

LayOut C API Additions and Improvements
•
•
•
•

LODocumentSaveToFile will now return an SU_ERROR_SERIALIZATION when trying to
save a .layout file that is currently open in LayOut.
Added LOPathGetWindingType
Added LOSketchUpModelGetDashScale
Added LOSketchUpModelSetDashScale

Chromium (CEF)
Chromium Version:
2019: Chrome/64.0.3282.119
2018: Chrome/56.0.2924.76
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Color Blindness Features
For people who experience color blindness, SketchUp makes seeing color-based modeling cues
easier than ever before. Here are the features that make 3D modeling more accessible:
•
•

New preferences settings: On the new Accessibility pane in the Preferences dialog
box, you can customize the colors of the drawing axes and inference colors.
A new preset style: When you apply the new Color Blind style to a model, color-based
modeling cues stand out better for people who have some degree of color blindness.

The following images show the new Accessibility pane and an example of how customized axes
colors appear with the Color Blind style applied. For help setting up SketchUp and your model
styles, see Changing colors of selected items and other on-screen aids and select the Help
Center documentation for SketchUp 2017.
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