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About me: My name is Patricia Gamburgo. I became an Architect in December of 1980.
I remember that, after my graduation, I felt that I didn’t have all the tools and answers to be a design
professional. So, I returned to University, for Post-Graduation Engineering courses. After this and during
the following years, I worked with different companies, doing design and project management, as well as
cost estimation and construction management (on site).
Being the manager of a big project, supervising different professionals and coordinating all the documents
turned out to be my biggest professional challenge.
Looking for tools and solutions, I went to College to learn “Advanced CAD applications”, where I was
introduced to the concept of Building Information Modeling (BIM) and to the programs allowing the
integration of all the documents of a project: I had found the answers I was looking for!
In 2001, due to a project deadline, I bought my first Punch! Software (R) program: it was Professional
Version 4. I completed my project in time, and the images were a success!
After this project, I spent many hours looking for answers, learning the program, understanding how the
program thinks and realizing the potential for homeowners and professionals. Since then, it has become
a fundamental tool in all of my professional activities. I was so excited with the software that in 2002, I
started my website http://www.punchhelpers.com where I provide architectural and drafting services as
well as training using all the Punch! Software (R) programs and versions.
In the past few years, I received dozens of emails from customers, forum users and trainees asking for
eBooks. They requested some type of eBook that could be easily searched and showing how the program
thinks in an architectural and design environment.
So, I decided to write a series of e-books, combining my experience with Punch! Software (R) and my
professional knowledge as Architect.
Since the beginning, I have worked closely with Punch Software (R). Currently, I am the Punch Software
Community Forum Moderator as well as a Beta Tester. And of course, the eBooks' writer!
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Disclaimer: The information provided in this e -book is designed just to provide helpful information on
the subjects discussed. This e-book is not meant to be used, nor should it be used as professional advice.
The author and publisher are not offering it as legal, engineering, architectural or other professional
services advice. You should seek the services of a competent professional before beginning any
construction or remodeling work.
This eBook contains all the necessary elements to learn and master the Punch! Software (R) programs V20
for Windows. The information can be used and accessed in different ways.
- Following the entire eBook provides a complete training to learn the Punch! Software (R) V20 for
Windows programs, not only by following tutorials and guides, but understanding how the program thinks
(Understanding the Walls, Understanding the Elevations, etc.)
- The tutorials show the “How To” for specific uses: How to start a project? How to insert a picture and
landscape it? How to create a walk-out basement? How to slope a lot? Just to name a few.
- The Visual Guides are graphic solutions that allow the visualization of the tools’ concepts.
- All the Power Tools included with the programs are individually explained with images, training guides,
and tutorials.
- Questions and answers by topic and general issues, that reflect the most asked and answered posts at
the Punch! Software (R) Community Forum.
- Topics and tools are linked on the screen using more than 2200 hyperlinks, so, while you are consulting
an item, you can easily access the additional information and have a full comprehension of all the items
related.
- You can search the information by content (using the Table of contents), by topic (Using the Glossary) or
by keyword (Using the Search feature).
- The Screen guides allow you to click the desired tool or feature in the image and be directed to the
respective topic.
- The constructive elements provide the necessary technical information. For example: the roof chapter
includes a glossary explaining the names of the different parts of a roof as well as the name and
development of 21 different types of roofs. Or, if you wish to develop a staircase, for example, you will
find not only how to create it using Punch! Software (R), but also, how stairs are calculated in real life as
well as the names of the different parts.
- This new edition contains more than 86,000 words, 550 pages with more than 1000 color images
(showing the new user’s interface, tables, examples, rendering results and screenshots as well as the
updates), covering exclusively the new Punch Software Version 20 for Windows.
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- Also, in this edition, I added a new feature (at the end of the eBook): a Glossary, allowing the visualization
and search of features by type, subject, etc. Then, by clicking on the page number, you will be directed to
the specific topic.
I hope that you find it useful, and that you will enjoy reading this e-book as much as I enjoyed writing it!

Patricia Gamburgo
First Edition: April 20, 2018.
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Punch! Software (R) is a 3D Home Design program. Therefore, each element in this software needs at least
three specifications => length, height, and thickness. These values will define the elements' properties.
In addition, 3D means that we are working in the space, therefore we need to define the elevation of each
element => this is the distance between the element and the 0” level => the 0” level in the Punch! Software
(R) world is usually the grass.
Things may look nice in the floor plan, but if all the parameters aren't perfectly determined, the 3D model
will not make sense.
Looking at this image; we don’t see any problem in the plan.

But, this is what may happen if the settings of all the elements are not defined accurately.

WHAT IS IMPORTANT IN A HOME DESIGN PROGRAM?
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Remember: the program always needs your accurate definitions!!
If possible, work with 2D / 3D simultaneously (live view / split screen) so you can visualize in 3D what you
are designing in 2D.

WHAT IS IMPORTANT IN A HOME DESIGN PROGRAM?
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Remember that the elements and objects can be located in different elevations, independently
of the house levels where they are placed.

Tip: Get familiarized with the program’s behavior before you start with your project.
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Essentially, CAD means Computer-Aided Design. The tools of a basic 2D CAD program are lines, shapes,
etc. So, it is safe to compare a pencil + paper set used in the past, with the 2D CAD systems currently used
by AEC professionals for mechanical drawings, packaging graphics, aerospace industry, etc. Usually, the
main advantage of a 2D CAD program is the precision: you can use a precision up to 1/256” or
0.00000001”. The Punch! Software (R) programs are also drawing programs but, as they are Home Design
programs, there are three main differences:
1 - They are intended only for home and building design, so their drawing tools are construction elements
like walls, doors, etc.
2 – The building elements and their properties are linked.
3 – They work in 2D + 3D
Let us see this example. In the image below, I drew a rectangle using a basic 2D CAD program and other
rectangle using Punch! Software (R). This is what we see in 2D.

Now, let us see what happens in 3D.

DIFFERENCE BETWEEN 3D AND 2D PROGRAMS
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In the 3D view of a 2D CAD program, the rectangle is still just a shape. However, in 3D view of Punch!
Software (R), the four lines become a set of walls with their properties, and the most important thing, the
program knows that these elements are walls.

In 3D Home Design, the program understands what you are drawing.
Therefore, if you draw a line in CAD, you can set the line’s thickness, pattern, color, length, etc. However,
this line will be always a line in 2D. In Punch! Software (R), if you set the correct parameters, the wall that
you draw as a line in 2D, will be a part of your building with the same properties of a wall in the real world.
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Nowadays, drawing a floor plan is not enough to build a house. Control and management tools are
necessary. Some programs, like Punch! Software (R), allow you to manage and synchronize different
aspects of your design.
Definition of BIM: BIM is the acronym of Building Information Modeling. The goal of this concept is the
generation and linking of all the graphic documents related with the design and construction of a building.
How does it work? As we stated, in Punch! Software (R), each building element knows its identity,
properties, location, and composition. This means that the program understands what you are drawing.
Therefore, if you determine the length of a wall, for example, this information will be reflected in the
Framing mode, on the Estimator Bill of Materials and will be exported to DWG, just to name some tools
(depending on your program). Moreover, each time you make a change, this info is updated to all the
related tools. For this reason, all the parameters and information must be consistent
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Punch! Software (R) is organized in levels (floors). The number of levels depends on the program:
Architectural Series: 20 levels, Professional: 12 levels, Premium: 6 levels, Home and Landscape, Interiors
and Landscape, Deck and Patio: 4 levels.
Each level has different subjects called tabs. The number of tabs depends on your program. For example:
Architectural Series contains 10 tabs but Interiors contains 5 tabs
Let’s examine an example with 3 levels and 9 tabs => you can imagine the structure as a multi layered
cake, as shown in the picture below.

As we stated, for all the Punch! Software (R) elements, you should determine the 4 specifications: length,
height, thickness and elevation. But now, as you are navigating through the "cake's layers" (levels and
tabs), it is necessary to add an address for each element. This address means:
1 - The level (first floor, second floor, etc.) where the element is located
2 - The tab (Floor tab, Electrical tab, etc.) where the element was generated or is currently situated.

QUESTIONS ABOUT LAYERS AND TABS
Question 1: What does Linked Tabs mean?

UNDERSTANDING LAYERS, TABS AND FLOORS
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Answer 1: Some subjects (Tabs) have elements attached to the walls called Components, like the Electrical
Tab, the Plumbing Tab or the HVAC Tab. This means that, for example, you need a wall to install an
electrical outlet. For this reason, in order to apply these elements of the Electrical Tab, the Plumbing tab
or the HVAC tab you need to show the Floor Tab (see Question # 4).
Question 2: Can I move a POB (Punch! Software (R) Object) from one tab to another tab?
Answer 2: Yes, as general rule you can move the objects among the tabs. For example, if you set a chair
in the Floor Tab you can move it to the Deck tab => Select the chair => Edit => Move to plan => Deck (in
this case) or => right click on the object => Move to plan => Deck (in this case).
Question 3: Can I move the walls with attachments from the Floor tab to other tabs?
Answer 3: Yes, you can, however, the items attached (Plugs, toilets, etc.) will always belong to their
original tabs (plugs belong to Electrical tab, toilets belong to Plumbing tab, doors belong to Floor tab, etc.).
Question 4: Can I show or hide the different tabs?
Answer 4: by clicking on the Workspace, the information tab shows the different Plan and Editing
workspace settings => the plans’ visibility controls are at the bottom. In the image below, as we are in the
Floor tab, this tab is selected (outlined in green) => you can show the elements of additional tabs by
selecting their names in the menu => in the image below, there are 2 additional tabs selected => Plumbing
(blue arrow) and Roof (red arrow).

Note: you can hide the Floor tab only in the Foundation tab, the Roofing tab, the Deck tab, the Landscape
tab and the Detail tab

UNDERSTANDING LAYERS, TABS AND FLOORS
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Note: the Linked tabs share the hide / show properties
Question 5: Is it possible to customize the tabs and elements’ colors?
Answer 5: Yes, it is possible, using the tools included in the Draw Styles Tab.

Tip: The use of different colors for the tabs is strongly recommended for a better visualization.
Question 6: I created a manual floor in the Floor tab; can I move it to the Deck tab or the Detail tab? Can
I change the 2D lines or patterns? If so, what changes will I see?
Answer 6: Yes, you can do this by selecting the manual floor => Edit => Move to plan. Or you can change
the 2D graphic elements using the tools included in the Draw Styles Tab. Actually, in this case the changes
are a good idea because, if your floor is in a different tab or with a different color / pattern, it will appear
in your Floor tab with a different color / pattern, therefore you will be able to select it easily. These
changes doesn’t produce modifications in Live View or in the Estimator Power Tool or in Framing mode.
It is just a 2D graphic modification.
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As we stated, the elements’ elevation is a key component of the Punch! Software (R) 3D model. However,
not all the elevations have the same reference point. Let’s define some concepts:

1 - By default, the Punch! Software (R) world is flat and covered with grass => this is the 0.00”
elevation of the project.
2 – If you draw a room in the first floor with a floor with thickness= 10” => all the furniture for this room
should be set at elevation = 10” => this is the elevation of the room’s floor defined by the walking surface
elevation.
The settings of the examples below (like the roof or the floor position) are incidental.
CASE 1: ALL THE LEVELS ABOVE GROUND.
Let’s examine this cross section: the house in the image below has 3 floors.

UNDERSTANDING THE ELEVATIONS
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The distance between the floor and the ceiling is the same for the 3 floors (96”) and the floor thickness is
10”.
The house is placed over a flat lot => this means that the grass covering the level 0.00” of the Punch!
Software (R) world is the level 0.00” of the project.
First Floor: In this case, the exterior walls are covering the floor (not always necessary) and they also cover
the ceiling thickness, so the wall height in this case is 96” + 10” + 10” = 116”. The exterior wall elevation is
0.00”, but note that the interior walls are on the floor so the elevation of the interior walls is 10”.
The back door is placed in an exterior wall. For this reason, the elevation must be 10” in order to become
leveled with the floor.
The elevation of the red armchair is also 10”, because it is placed over the floor => this means that the
red armchair is 10” above the grass level.
The ceiling elevation is 10”+ 96” = 106”.
As for the exterior objects=> the picnic table is on the grass so the elevation is 0.00”.
Second floor: the exterior walls are covering the ceiling thickness, so the wall height is 96”+ 10”= 106”. As
these walls are placed over the exterior walls of the first floor, the elevation is 116”. And as these walls
are leveled with the floor, the floor elevation is also 116”.
As we stated, the elevation of the elements unattached to the walls is related with the level 0.00” of the
project, therefore the elevation of the table shown on the second floor is 116” => this means that the
table is 116” above the grass.
In the second floor, there are two elements attached to the walls: a window and a door. As they are
attached, their elevation is related to the base of the walls where they are attached, so in this case, the
window elevation is 24” and the door elevation is 0” => this means that the windows is 24”above the
base of the wall and the door is at the same level of the base of the wall.
Third floor: in this case, the exterior walls end at the level of the exterior soffit and the ceiling, so the
walls’ height is 96”. Therefore, the base of the walls and the floor elevation is 222” and the ceiling elevation
is 222”+96”= 318”.
The elevation of the elements placed on the floor (a dog in this case) is 222” => this means that the dog
is 222” above the grass level.
As the roof is located on the soffit, the roof elevation is also 318”.

Questions for this issue
Question 1: why do you recommend the placement of the walls on the walking surface elevation?
Answer 1: because, if the lower part of the wall is embedded in the floor, the baseboard will be hidden
(embedded in the floor).

UNDERSTANDING THE ELEVATIONS
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Question 2: why do you recommend that the interior walls end below the ceiling?
Answer 2: because otherwise, the crown molding would be embedded in the ceiling
CASE 2: TOTAL OR PARTIAL LEVELS BELOW GROUND.
Let’s examine this cross section:
The house in the image has 3 floors.
The distance between the floor and the ceiling is the same for the 3 floors (96”), the floor thickness is 10”.
The house is partially below grade => this means bottom face of the floor is (in this case) 50” below the
level 0.00” of the Punch! Software (R) world.

First Floor: In this case, the exterior walls are located on the floor (not always necessary) and they cover
the ceiling thickness, so the walls’ height, is 96” + 10” = 106”.
The exterior and interior walls’ elevation is -40.00”, because they are on top of the floor.
UNDERSTANDING THE ELEVATIONS
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The back door is attached to the wall. For this reason, the elevation is 0” related with the base of the wall.
The elevation of the red armchair is -40”, because it is placed over the floor => this means that the red
armchair is -40” below the 0.00” grass level.
The ceiling elevation will be: -50” (lower elevation of the house) + 10” (floor thickness) + 96” (room height)
= 66”.
The picnic table is on the grass so the elevation is 0.00”.
Second floor: the exterior walls are covering the ceiling thickness, so their height is 96”+ 10”= 106”. As
these walls are placed over the exterior walls of the first floor, the elevation is 66”. And as these walls are
leveled with the floor, the floor elevation is also 66”.
As we stated, the elevation of the elements unattached to the walls is related with the level of the project,
therefore the elevation of the table shown on the second floor is 66” => this means that the table is 66”
above the 0.00” grass.
In the second floor, there are two elements attached to the walls: a window and a door. As they are
attached, their elevation is related to the base of the walls where they are attached, so in this case, the
window elevation is 24” and the door elevation is 0” => this means that the windows is 24”above the
base of the wall and the door is at the same level of the base of the wall.
Third floor: in this case, the exterior walls end at the intersection point with the roof, so the walls’ height
is 96” + 12”= 108”. Therefore, the base of the walls and the floor elevation is 172” and the ceiling elevation
is 172” + 96”= 268”.
The elevation of the elements placed on the floor (a dog in this case) is 172” => this means that the dog
is 172” above the grass level.
As the roof is located on the top of the walls, the roof elevation is 280”.

Go To: find more Information about the roof position / elevation and floors and ceilings
position / elevation

Remember these concepts:
=> The floor elevation is the distance (positive or negative) between the lower side of the floor and the
level 0.00” of the project.
=> The ceiling elevation is the distance (positive or negative) between the lower surface of the ceiling and
the level 0.00” of the project.
=> The reference of the elevation of all the elements unattached to the walls is the level 0” of the project.
=> The reference of the elevation of the elements attached to the walls (Doors, Windows, Plugs, Tubs,
etc.) is the base of the wall where they are attached.
UNDERSTANDING THE ELEVATIONS
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THE ELEVATIONS OF A PROJECT
Most of the Punch! Software (R) V20 programs allow more than 3 floors. For this reason, the management
of the elevations is a priority.
Basically there are 3 screens that manage the general elevations of the building.

Note: In the V20 version, the levels (called Floors) are locations in the space. Therefore, it is
possible to create different levels with small differences in the elevations. This is very effective to create
Split Level Houses

1 – New Project Setup

This screen is presented when we open the program. The goal is the setting of the default levels: number
of levels, height, slabs, etc. The basement option is very important because it allows the definition of the
basement position regarding the ground surface.

2 – Edit Current Floor
UNDERSTANDING THE ELEVATIONS
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By clicking on the Floor number (outlined in blue), a drop down menu will open. The “Edit Current Floor”
menu is one of the options. Notice that at the right of the selected floor button the Elevation bar shows
the Working Elevation.
The “Edit Current Floor” menu allows the modification of the heights and elevations, as well as renaming
the floor.

An important feature: don’t forget to select the Automatic Elevation Adjustment options
(outlined in red in the image above), so the remaining levels will be adjusted following the modifications.
In addition, it is possible to keep the Floor setting but change the Floor position: with this feature, you can
set your 4th floor (for example) above the first floor selecting => Floor base Elevation => Floor is above =>
First floor => specify the elevation.

3 – New Floor

UNDERSTANDING THE ELEVATIONS
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By clicking on the Floor number button (outlined in blue), a drop down menu will open. The “Add / Insert
Floor” menu is one of the options. Notice that at the right of the selected floor button the Elevation bar
shows the Working Elevation.
The “Add / Insert Floor” menu allows the insertion of additional levels, above any floor and with its own
settings and name.

A useful and important feature: don’t forget to select the Automatic Elevation Adjustment options
(outlined in red in the image above), so the remaining levels will be adjusted following the modifications.
Another useful feature allows you to create a new floor including a copy of the walls around the perimeter
of the current floor.

QUESTIONS ABOUT ELEVATIONS
Question 1: I will insert a Floor Cutout. How do I calculate the elevation of the Cutout?
Answer 1: The Floor Cutout has the same thickness and elevation used for the Floor where the Cutout is
applied.
UNDERSTANDING THE ELEVATIONS
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Question 2: How do I set the elevation of the POB’s (Punch! Software (R) Object)?
Answer 2A: Select the object => Right click => Set Object Elevation.
Answer 2B: Select the object => Edit => Set Object Elevation.
Answer 2C: Select the object => type the elevation in the Elevation bar => click Enter.
Question 3: I am setting the elevations of my floors and ceilings, is the elevation referred to the bottom
side or the upper side?
Answer 3: the elevation of floors, ceilings, decks, etc. is referred always to the location of the lower face
of these elements.
Question 4: How do the elevations work using the Auto floor?
Answer 4: The Auto floor feature means: a Floor attached to an Exterior wall. The bottom of this floor is
aligned with the base of the exterior wall. As this floor works like a part of the wall => all the elements
attached to the wall (doors, windows, baseboards, etc.) consider its elevation related with the top of the
floor (and not with the base of the wall as described before).
Question 5: I set my walls and floors with the right dimensions; however, they are not placed at the right
elevation. How do I solve this issue?
Answer 5: Before you start with your design => check the elevations of the project => in this way Punch!
Software (R) knows the exact levels of your building.
Question 6: the Height of the Walls of my first floor is 120”. I selected the walls in the perimeter and
copied them to the second floor; however, the program copied them at elevation 96”instead of 120”.
Why?
Answer 6: Before you start with your design => check the elevations of the project => in this way Punch!
Software (R) knows the exact levels of your building.
Question 7: Working with the new versions I noticed that there is a “Working Elevation” and an “Object
Elevation”, what does it mean?
Answer 7: If you click inside the building or room, the Elevation bar will show the Working Elevation: the
elevation of the building level. If you click on a POB, for example, the Elevation bar will show the elevation
of the object (Object Elevation) in the Punch! Software (R) world. For example: in a room (1st floor) the
Working Elevation will be 0”, but if we have a counter, the object elevation will be 36”
Question 8: I have a table (height= 38”) placed at the elevation 20” (top of the floor). I want to put a flower
pot on the top of the table. What elevation should I use? Also, in the same room, the height of the ceiling
is 10 feet (120”). I want to set a chandelier (a Punch! Software (R) object) with height= 40”. What elevation
should I use for the chandelier?
Answer 8: The elevation of the flower pot will be => the elevation of the table + the height of the table =>
this means => 20” (elevation of the table) + 38” (height of the table) = 58” (elevation of the flower pot –
top of the table).

UNDERSTANDING THE ELEVATIONS
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In order to place a Punch! Software (R) Object, the elevation of the object means the elevation where the
base of the object will be.
Notice that the ceiling elevation is 140”= 120” (height of the room) + 20” (elevation of the floor).
Therefore, the chandelier elevation will be 100”=> this is the elevation of the ceiling (140”) less the height
of the chandelier (40”).

Question 8: I created a table using the 3D Workshop Power Tool and I saved it in my library. I placed the
table in my dining room, where the walking floor elevation is 50”. I set the elevation of my table = 50”,
however, the table seems to float over the floor (approximately 18”above the floor). How can I fix this
issue?
Answer 8: After you create an object using the 3D Workshop Power Tool and before you save the object,
you must check that the object is resting on the Floor Grid of the 3D Workshop Power Tool. If the object
is elevated 18”for example from the Floor Grid, this distance will become part of the object, so the object
will be elevated 18” in the 3D model.

UNDERSTANDING THE ELEVATIONS
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How to create a helpful spatial map and input the values into Punch! Software (R)?
1. Print Pat’s Elevation Organizer.
2. Determine the elevation of the topography for this building location => this is Elevation A => write this
value in the respective location.
3. Determine the elevation of the top of the interior floor of the first level => this is Elevation B => write
this value in the respective location.
4. Determine the elevation of the top of the interior floor of the second level => this is Elevation C => write
this value in the respective location.
5. Determine the elevation of the top of the interior floor of the third level => this is Elevation D => write
this value in the respective location.
6. Determine the elevation of the top of the ceiling of the third level => this is Elevation E => write this
value in the respective location.
7. Determine the elevation of the base roof elevation => this is Elevation F => write this value in the
respective location.
8. The difference between the Elevation C and the Elevation B will determine the Distance D1 => this
distance is the height of the exterior walls of the first floor (Green wall in the PEO).
9. The difference between the Elevation D and the Elevation C will determine the Distance D2 => this
distance is the height of the exterior walls of the second floor (Magenta wall in the PEO).
10. The difference between the Elevation E and the Elevation D will determine the Distance D3 => this
distance is the height of the exterior walls of the third floor (Cyan wall in the PEO).
11. Alternatively, depending of the characteristics of the design of the roof and soffit, the Elevation E may
be the same of the Elevation F or not => verify the Height of the Walls for each case.
12. Open Punch! Software (R) => Floor button => Edit Current Floor => Insert the Distance D1 for the first
floor => Insert the distance D2 for the second floor => insert the distance D3 for the third floor => in this
way Punch! Software (R) will set the correct elevation for all the wall, objects, roofs, etc.

Add to Pat’s Elevation Organizer the values of the roof pitch, ceiling elevation, floor thickness, etc.
in order to visualize all the spatial information of your project.
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For projects with more than 3 levels, you can draw and print your own Elevation Manager,
adding the desired number of floors, the different locations and elevations, etc.
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There are several options to create a project. The choice will depend of your necessities and the available
format of the initial information.
OPTION 1 => I imagined my design and I drew a sketch on a napkin.

For this option you should start using the Quick Start Mode => add the rooms following the imagined
layout => adjust the dimensions.

Important: The Quick Start mode is like a “Draft” stage, so when you click the “Continue”
button you’ll move forward to the “Project” stage.
Therefore, once you moved to the “Project” stage, it is not possible to go back to the “Draft” stage.
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Complete the layout => Click Continue => your floor plan is ready => add doors, windows, etc.

HOW TO START A NEW PROJECT?

- 33 -

OPTION 2 => I have the plan of my house in DWG / DXF format.

To Import the plan, use File => Import => DXF / DWG File.
For better results, before you import your plan is important that you prepare and clean the file. To
perform this job, there are many free CAD programs in the web.
1 – Each floor should have its own file (one file for the first floor, one file for the second, etc.).
2 – Delete all the unnecessary elements (elevations, hatch, etc.)
3 – “Purge” or “Clean” the file => almost all the CAD programs have a cleaning tool.
4 – Save your file as DWG or DXF, using an appropriate version => you can use any version up to version
2018.
Note: you can import your plan bypassing the Quick Start screen => Continue => File => Import => DXF /
DWG File.

It is important that you import the plan in the same scale and unit system used to develop the
original CAD plan.
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Go To: find more information and tutorials about Import DXF / DWG files

After you import the plan => use one of the dimensions tools to confirm if the plan was imported in the
correct scale => in the image below the dimension outlined in red is the imported dimension and the
dimension outlined in cyan was generated using the dimension tool.
After you imported the file, select each element of the plan => Convert To => you can convert the lines
into Intelligent Features like Walls, (outlined in green in the image below) Decks, etc. Note that some
elements like doors, windows, furniture must be inserted separately, because they are Components.
In order to make the conversion to walls (outlined with a red rectangle in the image below), stairs, etc.,
try to select a line in the center of the element (pointed with a red arrow in the image below).

Important: as you convert the lines and shapes, set / verify the elevation of the different
elements.
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OPTION 3 => I have an image of the plan of my house in JPG / BMP / PNG format.

In this case, you should use the Trace Feature => Main Menu => Go to => Design => Floor Plan Trace
Properties =>the Trace menu will open => Set Image => Look for the image file in your computer
(acceptable formats are bmp, jpg, png, tiff or ptx) => in this first stage, don’t worry about the dimensions
of the image.
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As the image appears in the screen => use one of the dimensions tools and measure one of the dimensions
in the image => in the image above, the dimension in the image is 12’ and the dimension measured in the
program is 10’ => therefore 12’/10’= 1.20 => this means 120%
Again go to => Main Menu => Go to => Design => Floor Plan Trace Properties => the Trace menu will open
=> Percentage => 120% (Horizontal and vertical) => OK => In the plan, both dimensions (image and
program) must be the same. Sometimes, this process requires several adjustments and / or changes in
just one of the direction (horizontal or vertical) in order to fit the correct scale.
Take your time, calculate the scale, take dimensions => remember that the scale’s accuracy is a very
important step.

Note: The Floor Plan Trace Properties menu can be accessed using Design => Floor Plan Trace
Properties or Design => Options => Floor Plan Trace Properties, as shown in the image below.

How to Import a PDF file?
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In order to import a PDF file, you will need to convert it to image. If you have a PDF read / write
program, you can do this by opening the PDF file => Save as => Image => use the jpg, png, tiff formats.
If you don’t have a PDF read / write program => visualize the plan => use the Print Screen key in your
keyboard => Paste the image in your favorite image program => Save as => use the jpg, png, tiff formats.
After you create the image, use the trace feature as described above.
Notice that there are programs that convert PDF to DWG files. In this case, you can convert your PDF file
to DWG and then, use File => Import => DXF / DWG File.
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In Punch! Software (R) (as well as in your house) the walls are one of the most important elements of the
building. Therefore, the accurate definition of walls is critical to the development of the model.

Definition: Walls are structures connecting the foundations with the roofs and they are also
vertical surfaces enclosing a space (a dormer, for example).
Drawing walls with Punch! Software (R): the programs have an icon to draw walls (in the Tools’ Menu –
Floor Tab). Automatically, the walls created in the perimeter of the building will be Exterior walls and the
walls created in the interior of the building will be Interior walls.
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Question for this issue: Why is important a clear definition of the Exterior and Interior walls?
Answers:
1 – Constructive reasons => in real life, exterior walls are different from interior walls. Usually, exterior
walls have a different structure / framing as well as foundations and insulation.
2 – Punch! Software (R) reasons => in Punch! Software (R) the exterior walls’ perimeter defines the limit
between indoor and outdoor space. This distinction between interior and exterior is important to
determine the building limits and the topography settings.

EXTERIOR / INTERIOR WALLS – GENERAL SETTINGS
As we stated, the Exterior Walls are the building’s boundaries. So the first step for your project is the
definition of the walls on the perimeter => after you trace these walls, you must analyze the walls’
properties and settings.

If you are starting a project without the Quick Start Wizard, develop the Exterior walls first (in
order to define the interior space). After you complete the Exterior walls (perimeter of the house),
proceed with the development of the interior walls.

Important Setting for Exterior Walls design => confirm that the Exterior Walls are forming a
closed polygon.
The Exterior Walls form a closed polygon when they are continuous (no gaps) and also, all the wall
segments in the perimeter must be fused (see Joining the Walls).
Note that the program needs this closed polygon for 2 reasons.
a) The interior space outlined by the exterior walls will be considered “the building” so it will automatically
get roofs, floors, etc.
b) The topography elements, slopes, berms, etc. will stop at the exterior walls (so the grass will not invade
the interior of the house).

For the Exterior / Interior Walls design => verify the walls’ elevation in relation to the levels
of the project (see Understanding the Elevations).
Case 1 => Check the image below => all the Exterior Walls are fused, forming a closed polygon, as
recommended.
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The rendered image (right pane) shows a cross section by the area outlined in green (left pane) => note
that the roofs are covering the entire house and the topography remains outside of the house.
In addition, note that, as the Exterior / Interior Spaces are well defined, the program created the ceiling
and floor for the room, as shown in the cross section.

Case 2 => Check the image below => The Exterior Walls are not forming a closed polygon.

The live view image (right pane) shows a cross section of the area outlined in red (left pane) => note that
the roofs are not covering the area where the walls are not continuous and the topography is inside the
house.
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In addition, note that, as the Exterior / Interior Spaces are not well defined, the program didn’t create the
ceiling and floor for the room, as shown in the cross section.

To organize the elevations: print and fill Patricia’s Elevation Organizer.
You can determine the elevation of a wall using one of the following procedures:
a) Select the wall => Edit => Set object elevation.
b) Select the wall => Elevation bar (upper part of the screen) => Object Elevation.
EXTERIOR / INTERIOR WALLS – PROPERTIES – CONTINUITY
Wall Break: In Punch! Software (R), when you draw a straight Wall Unit (Wall A-C in the picture below),
the properties, materials, colors, trims, geometry, thickness, framing properties, and the shape are the
same for the entire length of the wall, from point A to point C.

If you need to change one or more of these elements, you need to divide the wall in two or more wall
segments, using the Wall Break tool (Floor tab).

By inserting a wall break, instead of a Wall Unit, you have 2 or more Wall Segments, so you
can change the properties, materials, colors, trims, the geometry, the framing properties, and the shape
of each segment. You can’t change the thickness of the wall segments by adding a wall break. You must
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set the changes manually. In the image below, you can see the differences between both segments of the
Exterior Wall A B C featuring a wall break (B).

The wall segment at the left has base trim, crown trim, flat shape and green color. The segment on the
right has a stone wainscot, pitched shape and blue color

Wall Break conflict: This conflict may happen if the Components attached to the walls (doors,
windows, cabinets, bathtubs, etc.) don’t fit within the length of a wall segment. Therefore: you can’t insert
a wall break within a door. Or you can’t insert a cabinet or a window if you don’t have enough space
between two wall breaks.

Go To: find more Information about Wall Break conflict.

Joining the Walls: When you draw 2 or more walls and you join them using the mouse, note that they will
"fuse", and instead of two or three different walls you will have a set of walls, with the same properties
(thickness and shape included) As we stated above, you can set the different properties manually, except
the thickness.

For Interior Walls: if you join two interior wall segments using the arrows (keyboard) the walls will
be together, but they will not fuse so you will be able to set different thickness for the wall segments. See
the image below.
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EXTERIOR / INTERIOR WALLS – PROPERTIES - GEOMETRY
For the Exterior / Interior Walls design you should determine the 3 physical parameters of the Geometry
of the wall => Length / Height / Thickness => see What is Important in a Home Design Program
Length: When you draw a wall in Punch! Software (R), the wall length is shown (Automatic Dimensioning).
You can customize the length by selecting one of the extremes and dragging it using the mouse or you can
select one of the extremes and move it using the arrow keys in your keyboard. In both cases, you can
visualize the length modifications checking the automatic dimensioning value.
The Punch! Software (R) programs have a Wall drop-down menu for the Custom Wall Length option
(outlined in blue in the image below).

In addition, some Punch! Software (R) V20 programs feature an arrow with the # sign => it is the Custom
Segment Length tool => this means that you can customize the length of any element (a wall in this case)
by selecting it using the # arrow => in this case, select the wall=> the Custom Segment Length menu will
pop up=> write the desired wall length => select the reference point (center, red / left or green / right) =>
change.
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Note that some Punch! Software (R) V20 programs feature both the Custom Wall Length tool
and the Custom Segment Length tool, See image below.

Thickness: the thickness of a wall is the distance between the two faces of a wall. In Punch! Software (R),
the thickness of a wall is always related with the finished wall.
Height: The height of a wall is the distance between two levels; however, in different situations and for
different type of walls, the height varies.
The height of a wall is determined by the position and by the shape of the wall. The walls’ shapes are
described at Exterior / Interior Walls - Shapes.
For flat walls and as a general rule we can consider that the height of an interior wall will be defined by
the distance between the floor and the ceiling. For the exterior walls, the joists and floors must be
considered, as is detailed in the image below.
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In this image, the height of all the floors / joists is 10” and the interior height is 96” for all the levels.
First floor => the height of the interior wall is 96” => this is the distance between the top of the floor of
the first level and the bottom of the ceiling. The height of the exterior wall is 116” because it covers the
floor and the upper joists (96”+ 10”+10”).
Second floor => the height of the exterior wall is 106” because it covers the upper joists (96”+10”).
Third floor => the height of the exterior wall is 96” because it doesn’t cover any element.
Any of the 3 options can be considered for any level, so you can, for example, draw the exterior wall over
the floor (first level) and in this case, the height of the exterior wall will be = 106” (96”+10”) instead of
116”.

EXTERIOR / INTERIOR WALLS – SHAPES
Default Shapes – Definitions.
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Due to the Walls’ Definition the walls must adapt their shape to fit and close the spaces. For this reason,
the shape of the wall must be composed exactly using the Wall Styles.
By clicking the Wall Style icon, you will find 14 styles (pictured below).

Each icon has a dark gray rectangle (flat area of the wall) + a light gray polygon (shaped area of the wall).
These shapes cover almost all the options, however, for certain situations (irregular roofs, for example) a
different shape is required. In these cases, you must develop a wall composed by two or more wall
segments and default shapes, creating a Custom Shaped Wall.
To create a Default Shaped wall, you must specify several parameters (heights and pitches) in order to
design the wall accurately.

The first and most important parameter is defined by the blue vertical segment (outlined in red in the
image above). This blue vertical segment is present in all the wall styles and it will lead the remaining
parameters.
In order to become familiar with the wall shapes, start by specifying the height of the blue segment using
the same height of the adjacent wall.
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The A and B parameters (if present) are pitches => for this reason you must fill the first part and they will
read “A = 9.5/8:12 pitch”.
The C and D parameters (if present) are secondary heights intended to complete the shape.

After you add or change any of the walls’ parameters or any other property in the Properties
tab you must press the Enter key in your keyboard so the new value will take effect.
Default Shapes – How to.
Let’s see how to develop and use each Wall Style. Notice that some of the styles are mirrored so they are
explained just once. All the styles begin with a blue vertical segment = 96” as default height.

Important: The roofs mentioned in this section are referred to the roofs developed in the Roof
Styles section.

Style 1 – Flat Wall.
Just set the height and draw the wall.

Style 2 - Gable / Saltbox Wall.
The Gable Wall shape is used to fit the Gable Roofs.
There are 3 different options for this style and they depend on the values entered for the pitches and
walls’ heights.
Option 1 => Regular Gable / Same heights on both sides of the wall - same pitches
Blue vertical segment (left) => 96” Additional wall height C => 96”.
Pitch A => 10:12 Pitch B => 10:12.
Notice that, in this case, the peak of the wall is exactly in the center of the wall.
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Option 2 => Irregular Gable – Saltbox roof. Different heights on the sides of the wall – same pitches =>
the peak is not in the center of the wall.
Blue vertical segment (left) => 96” Additional wall height C => 106”.
Pitch A => 10:12 Pitch B => 10:12 => Notice that in this case, the roof peak isn’t in the center of the wall

Option 3 => Irregular Gable - Saltbox roof Same heights on both sides of the wall – different pitches =>
the peak is not in the center of the wall
Blue vertical segment (left) => 96” Additional wall height C => 96”.
Pitch A => 10:12 Pitch B => 6:12 => Notice that in this case, the roof peak isn’t in the center of the wall.
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Styles 3 and 4 - Shed Wall.
The Shed or Pitched Wall is used to fit the Shed and Pitched Roofs. Both are the same style of wall, but
mirrored.

Blue vertical segment (left) => 96”.
Pitch A => 6:12.

Blue vertical segment (right) => 96”.
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Pitch A => 6:12.

Style 5 – Clipped Gable / Half Hipped Wall.
The Clipped Gable / Half Hipped wall is used to fit the Half Hipped Roofs (also for Simple Gambrel or
Dutch / Barn Roofs).
The image below shows a regular wall. However, the 5 parameters of this wall can be modified in order
to develop an irregular wall. For this image:
Blue vertical segment (left) => 96” Additional wall height C => 96”.
Total height D (to flat side) => 145”.
Pitch A => 8:12 Pitch B => 8:12.

Styles 6 and 7 – Half Hip Overhang / Double Pitched
Wall (1 outward + 1 inward pitch)
The Half Hip Overhang / Double Pitched Wall is used to fit some cases of the Double Gable Roof.
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This wall is commonly used as transition between two roofs that can be at different heights and / or with
different pitches. Both options are the same style of wall, but mirrored.
The image below shows the style 6 using the same heights on both ends of the wall and the same pitches.
Blue vertical segment (left) => 96” Additional wall height C => 96”.
Total height D (to flat side) => 134”.
Pitch A => 8:12 Pitch B => 8:12.

The style 7 mirrors the style 6. In the image below, the parameters are different so it is an irregular wall.

These are the parameters for the image above:
Blue vertical segment (left) => 104” Additional wall height C => 96”.
Total height D (to flat side) => 134”.
Pitch A => 6:12 Pitch B => 8:12.
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Style 8 – Double Overhang / Double Pitched Wall (2 outward pitches)
This wall is commonly used as a transition between two roofs that can be at different heights and / or with
different pitches.
The image below shows a transition wall, between two gable units with different heights and different
pitches. These are the parameters for this image:
Blue vertical segment (left) => 96” Additional wall height C => 91”.
Total height D (to flat side) => 117”.
Pitch A => 8:12 Pitch B => 4:12.

Styles 9 and 10 – Half Hip / Chamfered walls (one inward pitch)
These walls are commonly used when one of the ends of a wall is pitched.
Both options are the same style of wall, but mirrored.
The image below shows a wall pitched on the left side, transitioning to a straight wall. These are the
parameters for this image:
Blue vertical segment (left) => 96” Additional wall height C => 114”.
Pitch A => 6:12.
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Styles 11 and 12 – Overhang / Chamfered walls (one outward
pitch)
These walls are used when one of the ends of a wall is pitched; but they are very useful for other purposes.
Both options are the same style of wall, but mirrored.
The image below shows a style 12 wall with an outward chamfer on the left side, transitioning to a gable
unit. These are the parameters for this image:
Blue vertical segment (left) => 96” Additional wall height C => 119”.
Pitch A => 8:12.

A symmetric wall at the left of the gable would be a style 11 wall.

Styles 13 and 14 – Dormer wall
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These walls are used on the sides of a dormer, allowing the setting of both pitches (top and bottom). Both
options are the same style of wall, but mirrored.
The image below shows the walls of a gable dormer, identical as the ones generated with the Dormer Tool
(Roof Tab). These are the parameters for this image:
Vertical segment (left) => 72” => in this Style, the wall height is automatic => the calculation is based on
the triangle created with the length and the two pitches.
Pitch A => 0:12 (Top end of the wall is flat)
Pitch B => 10:12 (Bottom end of the wall follows the pitch of the main roof)

Additional uses for the Overhang / Chamfered walls (one outward pitch).
The height of the Blue vertical segment can be any dimension, starting at 1”, so using a short wall length,
there are several additional uses for this style of wall. See two examples below.

Wall enclosing the upper part of a staircase.
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Side wall of some types of custom dormers (wall outlined in blue): dormer walls that start with a flat
bottom instead of a point.

Custom Shaped Walls.
Some projects have particular configurations and not all the shapes and alternatives are included in the
14 styles described above. For these situations, you need to create a Custom Shaped Wall.
The Custom Shaped Walls are composed by two or more walls with different shapes, and they can be
contiguous or stacked.
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The images below show different situations and their development techniques.
1 – Wall under Gambrel roof .
In this case, you need to create and stack two walls with different shapes: a half hipped wall (green) and
a Gable wall (orange).

2 - Custom Gable Wall.
In this case, you need to create and stack two walls with different shapes: a flat wall (aqua) and a Gable
wall (orange).
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3 – Double Gable Wall.
In this case, you need to create and stack two walls with different shapes: a double pitched wall (yellow)
and a Gable wall (aqua).

4 – Irregular Walls.
Sometimes, when you have very irregular roofs, you will need to create contiguous irregular wall
segments. There are two ways to create these walls called segments.
4 – 1- The irregular wall segments go from the floor up to the roof.
You can use this technique if you have a massive wall, without doors, windows, etc. In this case, you can
divide the wall in segments and use the wall shapes to create each segment. In the image below, the wall
was created with a pitched wall (light blue) +a pitched wall (orange) + a Gable wall (brown).

4 – 2- The irregular wall segments are stacked on a flat wall.
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If the irregular wall has doors or any other wall attached component (like cabinets, for example), keep in
mind that several walls segments will create a Wall Break conflict therefore, you can’t insert a window
between two walls (for example). In this case, create a flat wall (green in the image below) for the lower
part of the wall, in order to insert the openings, etc. The irregular shapes were created with a pitched wall
(light blue) +a pitched wall (orange) + a Gable wall (brown) and they are stacked on the flat wall.

EXTERIOR / INTERIOR WALLS – NONLINEAR WALLS.
All the shapes described above look as a straight line in the floor plan. However, there are design situations
that call for a wall or a set of walls conforming different shapes in the floor plan, like circles, bows or bays.
We will call these walls as Nonlinear.

Definition: all the walls that don’t conform to a straight line in 2D (floor plan) are called
nonlinear. In Punch! Software (R), all the nonlinear walls are composed by segments of straight walls.
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As these walls are composed by segments (limited by wall breaks), it’s important to start the design by
defining the segments’ length, in order to avoid a Wall Break conflict with doors, windows, etc.

Curved / Arch (Bow) Walls.
By default, Punch! Software (R)’s wall segments are always straight lines; therefore the curved walls are a
set of adjacent straight segments that follow a curved shape in the floor plan.
Basically there are two methods to outline a curved / arch (bow) wall.
Method 1 - Using the Curved Wall Tool: select the Curved wall tool.

Right pane => define the Curved Segment Length => Workspace => Set the center of the imaginary circle
=> define the diameter and angle for the shape.

Question: What does the angle mean?
Answer: As we stated, we are creating a set of adjacent straight segments that follow a curved shape,
therefore, the angle in the screen is the angle created between the beginning and the end of the wall
segments. In the image below, the ends of the walls and the center of the circle are creating an angle of
120.34°. As you click at the end, the wall segments will appear.

Don’t forget that your walls’ segment must contain the attached elements, so if your windows’ width is
36” for example, the length of your segments must be enough to insert that window. In the image above,
the length of each segment is 37”.
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Go To: find more Information about the settings for the Curved Segment Length.

Method 2 – Using the Curves in the Detail tab:
As with any element in the Detail tab, you can draw a curve => select the curved line or shape => right
pane => Convert To => Wall.
This feature is particularly useful for curved walls because you can adjust the curve tension and path
before the wall generation.

The downside of this feature is the length of the segments: The more tension the curve’s path
has, the shorter the wall segments are.
For this reason, I recommend the use of this option just for wall units without attached elements like
windows, doors, cabinets, etc.
In the image below, you can see that, in the floor plan (2D), if the curve tension is high (a more closed
curve) the wall segments are shorter. For example, check the wall segment with length = 12” => this means
that you can insert only a very narrow door or window.

In the image below, you can see that, from the visual / rendering point of view, you will get better results
with small wall segments.
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2 – Angled / Bay / Chamfered Walls.

This tool should be applied to a straight wall in order to generate a Bay Wall.
In the image below, the wall segment “A” is straight. By applying the Bay Wall tool, the wall will feature a
set of walls forming a Bay Wall (Wall “B”). Before the use of the tool, you must set the two main
dimensions in the right bar => these dimensions are not the length of the walls => they are the Width and
Depth of the entire unit.
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Some Punch! Software (R) programs, as Punch! Software (R) Home and Landscape, don’t feature the Bay
Wall tool.
However, the Bay Wall can be created manually, following the sequence in the image below.

Draw a Straight Wall => use the Wall Break tool => Create the central segment => this dimension will
remain unchanged (76” in this case) => Create two breaks at the left and right of the central segment =>
the length of the 2 side segments must be identical => 40” in this case => Select the central segment =>
Go to Edit => Move => -40”=> same distance of the segment length.

Go To: find more Information about the settings for the Edit => Move feature.

Question: I need the side segments with length = 57”. How do I know the left and right distances
in order to place the breaks?
Answer: The angle of the side wall of a Bay unit is, in this case, 45°. This means that this wall is the
hypotenuse of a right-angled triangle => the sides (in X and Y) are identical. The solution, using the
Pythagorean Theorem:
SWDX => Side Wall Distance following X Axis
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SWDY => Side Wall Distance following Y Axis
LASW => Length of the Angled Side Wall
LASW²= SWDX² + SWDY²
In this case SWDX is equal to SWDY. So, using the desired length of 57”

=> 40”= SWDX => you need to set the wall break at 40” to get an angled wall with
length = 57”.

You can use the same procedure to create chamfered walls in a house.

Exterior / Interior Walls –Room Addition Tool
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The Punch! Software (R) programs Version 20 include the “Room Addition” Tool (Floor Tab).

By clicking on the icon (outlined in blue in the image), the Properties tab will show the sizing options and
the Settings button=> by clicking this button, the Room Addition Options menu will open.
Room Shape: there are 2 options (outlined in green) => Rectangle and Chamfered Corner. The chamfered
corners follow a 45 degrees angle; however, this can be edited after the insertion. Both shapes have a
menu with 3 tabs: Walls / Windows and Doors / Roofing (outlined in red in the image)
Walls: The settings of the Room Sizing (Width, Depth and Corner Width) are the lengths of the addition’s
walls. By default, the program will use the adjacent wall height, however the height can be modified for
the entire room (before the insertion) or for individual walls (after the insertion).
Windows and Doors: the menu contains several options for windows and doors, including the no window
(full wall) and no door options. The models are standard, however, (after the room insertion) they can be
edited (different elevations or sizes) or changed for custom doors and windows, or even deleted.
Roofing: this tab contains several roof options. The default setting is “No Roof” (showing just the ceiling).
Soffit and pitch can be specified. Depending of the room situation, check the “Clip roof at wall” option:
otherwise, the roof will continue over the original wall. If you use the Auto Roof option in the main
building or if you have special settings for the Auto Roof feature, you can select the use of this option for
the roof of the Room Addition.

Return to Table of Contents
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The floors, flat ceilings and decks are defined by horizontal planes.

General Definitions: The Floors are the walking surfaces of a house or room. In addition, the
structural element dividing two levels of a building is called a Structural Floor. The Ceiling is the upper
limit of a room. There are many definitions for decks, but for this book purposes, Decks are exterior floors,
configured as platforms or balconies.
In order to correctly define these horizontal elements the most important parameters are the Elevation
and Thickness.
FLOORS AND CEILINGS: BASIC CONCEPTS AND GLOSSARY.
(The drawing below is not a constructive detail – It is for reference only).

As general concept and specifically in Punch! Software (R), a Floor may have different meanings.
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Story of a building: in a building, the space contained between the walking surface and the ceiling of a
certain level or between two horizontal supporting structures is called a Floor (first floor, second floor,
etc.).
Finishing Surface: the material covering the walking surface is called Floor or Flooring (ceramic tiles, wood
planks, etc.).
Structure: the horizontal plane defining the supporting structure for a building story is called Floor or
Structural Floor. This component can be constructed as a concrete slab, or with a framing system (joist,
beams, etc.) or with trusses, for example.
Ceiling: the upper lining of a room, covering the lower face of the roof or the floor structure above.
Flat Ceiling: a ceiling horizontally located in the lower part of the structure.
Elevation of the Structure: follows the general concepts of Elevation and it is always referred to the lower
face of the prism.
Elevation of the walking surface: if the walking surface is a separated element from the structure, the
elevation of the walking surface is the level of the upper face of the structure => this means that, for a
structure on the ground (Level = 0.00”) and a thickness = 12”, the elevation of the walking surface will be=
12”.
Elevation of the flat ceiling: if the ceiling is a separated element from the structure, the elevation is the
level of the lower face of the structure less the thickness of the ceiling => this means that, for a structure
with elevation 96” and ceiling with thickness= 1”, the elevation of the flat ceiling will be= 95”.
Elevation of the Floor Cutout: follows the general concepts of Elevation and it is always referred to the
lower face of the cutout.
Thickness of the elements: is the distance between the bottom and the top faces of a floor or structure
or ceiling.

Notice that in Punch! Software (R), in Shaded Mode (instead of the Framing mode) the Floor
Structure will always appear as a hollow prism (a horizontal upper surface + a horizontal lower surface +
vertical surfaces in the perimeter).
THE FLOOR TAB AND THE FLOOR TOOLS.
The Floor tab is the second label in all the Punch! Software (R) programs. This layer is the space for the
placement of the elements of a traditional floor plan (walls, floors, stairs, doors and windows as well as
cabinets, accessories and the column tool.
The Floor Tools
There are two tools: the Floor Tool and the Floor Cutout Tool.
The Floor Tool: as a general concept the Floor Tool is used to create all types of floors, however, it can be
used to create a variety of elements.
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In order to create a floor => select the tool => outline the desired contour or perimeter => set the desired
Thickness => Press Enter.

As the elements created with this tool are prisms that follow a traced contour, depending on the initial
shape, the Floor Tool can be used to create floors, ceilings, columns, steps, counters, etc.

If the desired configuration is irregular or curved, as the column or the steps in the image above,
the best method is creating the contour using the shapes in the Detail Tab => Convert To => Floor.
The Floor Cutout Tool: this tool is intended to create holes in the elements created with the Floor Tool,
and works in the same way: holes can be created by outlining an area or by creating a shape using the
elements in the Detail tab => Convert To => Floor Cutout.
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Important: the Floor and the Floor Cutout must share the same Thickness and Elevation.
The Elevation of these elements is always referred to the base (lower face of the prism).
The floors and floors’ cutouts can be developed following the different Drawing Methods.

HOW TO ADD MANUAL FLOORS AND CEILINGS
After the floor plan is developed, you can add the horizontal elements. How to do this will depend of your
necessities and the Punch! Software (R) program.
By default, a set of walls conforming a closed perimeter automatically creates a floor and a ceiling surface
for each room (thickness= ¼”) => by clicking inside a room => Properties tab => you can choose to Show
or Hide the automatic floor and / or ceiling as well as the Thickness of the floor.

UNDERSTANDING FLOORS, CEILINGS AND DECKS

- 70 -

Notice that the elevation of these automatic floors and ceilings cannot be changed => the floor
elevation is aligned with the elevation of the base of the wall => the ceiling elevation is aligned with the
top of the shortest wall.
Adding a manual floor for the entire level => use the Floor Tool => outline the entire level => set the
Thickness and Elevation.
Adding a walking surface or a flat ceiling for a room, custom area or different elevation => use the Floor
Tool=> outline the desired area => set the Thickness and Elevation.
Adding different types of ceilings: you can use the versatility of the Floor Tool to create tray ceilings, faux
beams, etc. => outline the shape => set the Thickness and Elevation => texture as necessary.

Cathedral ceilings can be created with a faux freehand roof under the real roof.

Some Punch! Software (R) programs have the Ceiling Designer Power Tool that allows the
design of different types of ceilings; however, the ceilings created with this power tool don’t allow the
setting of the framing elements for them.
ADDITIONAL COMPONENTS: STAIRS.
The Stair Tool is in the Floor Tab.
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The stairs are the elements used to move up or down from one story of a building to another. It is
important to perform an accurate calculation of the stairs in order to avoid surprises.
Definitions.
Total Rise: vertical distance between the walking surfaces of the two floors.
Total Run: horizontal length of the full path of the stair.
Step Rise: vertical elevation of each step (height of the step).
Step Run: horizontal dimension between 2 rises of each step (depth of the step).
Head Height Requirements: minimum overhead clearance for all the steps.

Question for this issue: how do I calculate and layout stairs?
Answer: first, you should check the requirements of your Building Code to determine the guidelines for
rise, run and restrictions regarding head height.
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In order to design your stair in Punch! Software (R), follow these steps by checking the example in the
image above.
1 – Establish the Total Rise => in the example = 98”.
2 – Establish a Step Rise => check the code for maximum and minimums for the different uses, like
commercial, home, etc. => in the example = 7”.
3 – Divide the Total Rise by the Step Rise => 98”/ 7” = 14. This means that your stair will have 14 steps. If
the result is not an entire number of steps (for example 96”/ 7”= 13.71, use the following entire number,
in this case, 14.
4 – Multiply the number of steps (14 in this case) by the Step Run (10” in this case) => 14 steps x 10”=
140”=> this number is the Total Run of the stair.
5 – You can manually adjust the length of the stair according with the Total Run calculated or use the
Arrow with the # sign => click on the stair’s middle line => write the desired length (140”in this case).
6 – Verify if the overhead clearance of all the steps is above the minimum required.
Shapes and Layout.
The stairs in Punch! Software (R) are created starting by the middle line, that can be straight, “L” or “C”
shaped (for winding stairs), curved, almost circular (for spiral stairs), etc.
You can draw the line with the 2 stairs tools or use the shapes in the Detail tab => Convert To => Stairs.

You can customize the stairs adding rails, skirt walls, a large base, etc.

There are a few important properties:
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- All the stairs in Punch! Software (R) go from the lower level to the upper level (Example: first floor to
second floor). Therefore, the stairs’ elevation is always the elevation of the lower level (first floor in the
example). If you wish to place the stairs in a different elevation => select the stairs => Elevation bar =>
write the desired elevation => press Enter to confirm the new elevation.
- If you select the right and / or left handrail, the handrail will appear in the full length of the stair.
- All the steps have the same width.
- All the settings are valid for the entire length of the stairs. If you need different settings, you can stack
two stairs with different properties.

ADDITIONAL COMPONENTS: RAILS

For certain elements like Decks and stairs, the rails are automatic features that can be selected on / off
through the options in the Properties tab. However, usually, internal balconies or mezzanines created
with the Floor Tool need a rail. These rails can be developed with the Rail Tool in the Floor tab.
Components and properties.

All the rails in Punch! Software (R) follow the same model, with 3 components.
Posts: (optional) the approximate dimension is 4”x4”. They are automatically placed at the beginning and
at the end of the rail, as well as each time the mouse is clicked or a point is added.
Spindles (balusters): vertical elements in the rail, supporting the handrail. The spacing can be customized.
Handrail: horizontal elements running along the rail.
Each post or point added can be elevated separately. Each component group (Posts, Spindles and
Handrails) can be individually textured or colored.
The rails can be developed following the different Drawing Methods
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Note that you can choose in the drawing whether or not there will be rails in 2D by checking
the “Draw Handrails” option in the Properties bar (outlined in blue in the image below).

THE DECK TAB AND THE DECK TOOLS
This layer is the space for the placement of decks, exterior balconies, etc.

Question: what are the differences between decks and floors in Punch! Software (R)?
Answer: the first and big difference is that the Floors have a base surface, a top surface, plus the vertical
sides in the perimeter. The Decks have just a top surface plus the vertical sides in the perimeter (Skirting).
In addition, in the floor plan the decks have a diagonal hatch and the label “Deck” => the hatch and the
label cannot be removed.
Another important difference is that, if desired, the Rails are an automatic feature for the Decks.
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The Deck Tools
Deck Tool: By selecting this tool and outlining an area, a deck with rail will be developed.

Deck without Railing Tool: By selecting this tool and outlining an area, a deck without rail will be
developed.

Deck Cutout Tool: this tool is intended to create holes in the elements created with the Deck Tools, and
works in the same way: holes can be created by outlining an area
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In order to work flawlessly the Deck and the Deck Cutout must share the same Thickness and
Elevation. The Elevation of these elements is always referred to the base (lower level of the Skirting).

Decks (with or without rails) as well as rails’ cutouts can be developed following the different
Drawing Methods or by creating a shape using the elements in the Detail tab => Convert To => Deck, Rail
or Deck Cutout.
Deck Wall Trace Tool: this tool creates a deck following the contour of a building (regular or irregular) =>
click on a wall (the best option is starting in the center of the deck) => drag in the desired direction =>
extend to one side => a symmetrical side will follow => the exterior side of the deck will be straight.

Custom Deck Wall Trace Tool: this tool creates a deck following a building contour (regular or irregular)
=> click on a starting wall => drag towards the desired direction up to the end wall => add the remaining
(exterior) points of the deck => the difference with the Deck Wall Trace Tool is that you can customize the
exterior sides of the deck.

In the image below, using the tool and extending to the sides following the red arrows, the deck is
generated (pointed with a blue arrow in the image below)
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Parts and accessories
Steps: click on a side of the deck => Properties tab => Steps => Insert. This feature allows the addition of
steps in the deck and creates the opening in the rail. Selecting the steps => width, height and handrails
can be selected.
Skirting: the vertical sides of the deck outlining the perimeter are called skirting and usually cover the
structure. For this reason, sometimes the thickness of the Structural Floor is different from the height of
the deck and therefore the skirting.

The Elevation of a deck is the elevation of the lower point of the Skirting => this means that if
the height of your deck structure (and skirting) is 18” and the walking surface of the deck is at level 120”,
for example => the deck elevation is 120”- 18”= 102”.
Handrail: this element can be added automatically in the deck perimeter by checking the “Include” option
in the Properties tab. If you need to create openings in your handrail => insert additional points => select
the sector between points => unselect the Handrail option for this segment in the Properties tab.
For additional railings, note that the Rail Tool in the Deck tab is identical to the Rail Tool (Floor tab) and
can be used indistinctly.

Note that you can choose in the 2D drawing whether or not there will be rails by checking the
“Draw Handrails” option in the Properties bar (outlined in blue in the image below).
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Go To: find how to create a Custom Handrail
Stairs: You can add a stair to connect two different levels of your deck project, however, differently of the
Deck Steps the addition of this element doesn’t create an opening in the rail. In order to create the
opening, follow the directions in the Handrail section.
The stair tool in the deck tab is identical to the Stair Tool in the Floor tab, and can be used indistinctly.
Columns: for decks or porches, there are several resources available, depending of the necessities of the
project. In addition, you can use the Column tool in the Floor Tab.

How to Create a Custom Rail
You can create Custom Rails using the Fence Tool (if your program includes this tool it will be located in
the Landscape Tab)
Step 1: in the plan, draw the deck => select the sides that include rails (pointed with red arrows in the
image below).
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Step 2: in the Properties bar, unselect the options “Include Handrails” and “Include Post” (pointed with
green arrows in the image below).
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Step 3: Using the Fence Tool located in the Landscape tab (outlined in blue in the image below), draw the
fence following the perimeter of the previous rail (pointed with blue arrows in the image below). Set the
fence properties: Elevation (pointed with a brown arrow), Span (outlined in magenta in the image below),
Post (outlined in black in the image below), and type of fence (it should be Custom, pointed in yellow in
the image below).

Step 4: Visualizing in 3D, you will see a standard fence, with wood panels (pointed with a green arrow in
the image below).
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Step 5: Apply the desired texture on the panels. In this case, I used a wrought iron texture, to match the
furniture. You can Import a Custom Texture or use the ones in the Fences’ category. Or, you can create a
new design using the Fence Designer Power Tool (if your program includes this tool).

Return to Table of Contents
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Definition: The roofs are structures supported by walls, columns, and are intended to provide
upper covering of a house, pergola, porch, etc.
ROOFS: BASIC GLOSSARY AND DEFINITIONS.
(The drawings below are not constructive details – They are for reference only).

Roof panel: side of a roof delimitated by the Ridges, Rakes, Fascia, etc.
Ridge: the upper end of a roof, usually defined by the intersection of two inclined roof sections. In a Punch!
Software (R) plan, the ridge appears as a line.
Rafter: it is part of the roof structure. This pitched element runs between the Ridge and the Fascia. In
Punch! Software (R), the Rafters are visible only in Framing mode.
Fascia (also called Eaves Board or Eaves Fascia): vertical element covering the ends of the Rafters. In
Punch! Software (R) the fascia height is always 6".
Fascia Lower Edge is the lower end of a roof.
Truss: roof structure composed by several elements (beams, diagonals, etc.). In Punch! Software (R), the
Trusses are visible only in Framing mode.
Soffit: horizontal surface under the Overhang.
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Overhang: exterior projection of the roof. It runs between the exterior surface of the exterior wall and
the Fascia Lower Edge Also called Eave.
Roof Pitch: one of the methods for defining the slope of a roof. The roof pitch is expressed as X:12, where
X means the vertical rise (in inches) for a horizontal run of 12 inches (1 feet).
Rake: Sloped board outlining a gable roof.

Roof Angle: one of the methods for defining the slope of a roof. The roof angle is measured between the
inclined members of the roof and a horizontal plane.
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Elevation Base: the roof base elevation is the vertical distance between the 0.00” level of the project and
the Fascia Lower Edge.
Elevation Peak: the roof peak elevation is the vertical distance between the 0.00” level of the project and
the ridge.
Height of the Walls: Often, different structural or architectural designs mean different walls’ height.
Example 1 (upper image) If the roof structure rests on the walls (including beams) and there is no Soffit,
then the wall will have a full height. Example 2 (lower image) If the roof structure rests on the walls
(including beams) and there is a Soffit then the wall height will be the elevation of the Fascia Lower Edge.
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Go To: find more Information about the walls’ specifications, perimeters and elevations => See
Understanding the Elevations and Exterior / Interior Walls – General Settings.

THE ROOF TOOLS
In the Roof tab, there are 3 types of tools. The choice of the tool is determined by the necessities and
characteristics of each project.
1 - Ready-Made Shapes Roof Tools: These 6 shapes (Gable, Hip, Hip/Gable, Gable Connector, Hip
Connector, and Cross Connector) are ready to use.

Important Note: The Ready-Made roof shapes are not related with the Auto Roof feature.
After the Ready-Made roofs are inserted in the plan, the shapes, parts and angles cannot be modified
however, the customizable elements can be modified during the insertion or after the development.
The dimensions, the Roof pitch and the Roof Elevation can be customized; however, the pitch and
elevation will be the same for all the pieces of the shape. Note that additional points cannot be inserted.
This means that all the parts of Ready-Made roof shapes will work and change together, as a block.
The Ready-Made roof shapes can be inserted in any point of the model and at any stage of the
development => Select the desired shape => click on the insertion point => drag in order to set the desired
roof’s dimensions.
The insertion point is usually outside the walls, using the desired Overhang distance as a guide.
Example => inserting a ready-made Hip roof with an overhang of 3 feet.
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Define the Insertion Point according with the overhang dimension (X= 3ft / Y= 3ft) => Define the End point
according with the overhang dimension (X= 3ft / Y= 3ft) => select the roof model (Hip roof in this case) =>
Click on the insertion point => stretch the shape towards the End Point => click on the end point.
Set the Roof pitch and Roof Elevation.

Keep in mind that the elevation of the Ready-Made Roofs is always the Elevation Base.
2 - Free Hand Roof Tool: this tool is indicated for the development of irregular or custom shaped pieces
of roof as well as the development of Custom Style roofs.
The roof members created with the Free Hand Roof Tool can be developed featuring any number of
vertices and with any shape. All the points can be edited or moved. New points can be added or existent
points can be deleted at any moment during the development.

Go To: find more information regarding the Add Points and Delete Points features.
The Elevation of a piece created with the Free Hand Roof Tool can be set as Elevation Base or as Elevation
Peak.
Free Hand Roof Tool: when and how use it.
Case 1 => roof members with irregular shapes.
When => usually, irregular floor plans have irregular shaped roofs. In this case, the pieces must be
developed separately following the custom shapes.
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How => select the tool => outline the shape => set the Roof pitch and Roof Elevation => Examine if the
elevation of each point matches the elevation of the contiguous point.

Case 2 => regular roofs featuring members with different roof pitches.
When => Two contiguous roofs’ parts with different pitches come together with an angle different of 45°.
Therefore, the pieces must be developed with the Free Hand Roof Tool in order to edit and move the
points.
How => create the roof parts => set the desired pitches => set the same Elevation Base for all the members
(in the image below: 96”) => determine the Elevation Peak for the member with the higher pitch (in the
example below: 236”) => in the member with the lower pitch, select the contact point between this
member and the member with the higher pitch (marked with a red arrow in the image below) =>
determine the elevation of this point (in the image below: 208”) => this point is the Elevation Peak of this
member => as all the members should have the same Elevation Peak using the arrows in the keyboard,
move this point away from the base until you see the same elevation (236” in the image below, marked
with a red star) => adjust the 2 remaining points of the higher pitched members so the 3 vertexes will
converge in the same point and with the same elevation (236”), as shown in the green rectangle.

UNDERSTANDING THE ROOFS

- 88 -

Case 3: Custom shaped roofs
When => this is the most common use of the Free Hand Roof Tool. Some plans or structures need special
roofs (like pergolas or gazebos, for example). Some architectural styles need custom shaped roofs.
How => Each piece must be developed individually, keeping in mind the necessary continuity of the
Elevation Base and the Elevation Peak of the contiguous pieces.
In certain cases, the pieces are identical but the pieces are rotated. For example, a roof with 10 sides (see
picture below) will be divided in 10 triangles => the angle of each triangle is => 360° / 10= 36° and as the
pieces are identical, each member / triangle is rotated 36° in respect to the contiguous triangle.
When the pieces are different, the points can be moved or edited in order to modify and harmonize the
angles and pitches.
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Questions for this issue: How do I rotate a roof member? How do I rotate the pitch?
Answers: Rotating a roof member => Select the entire roof member => Main menu => Edit => Rotate =>
write the desired angle.
Manually rotating the pitch 1=> select the pitch arrow and manually rotate the angle => the arrow will
become a line during the rotation.

Manually rotating the pitch 2=> select the pitch arrow => Main menu => Edit (outlined in green in the
image below) => Rotate => or select the Rotate tool in the Expanded Edit toolbar (outlined in magenta in
the image below)=> write the desired angle => OK.
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Slope to Edge: by default, manually developed freehand roofs consider their south side as the edge,
therefore, the pitch arrow points down (south). To change the pitch direction, select a new edge => right
click on the new edge => Set Slope to Edge (outlined in red) => the pitch will slope towards the new edge.

3 - Free Hand Roof (Wall Assist) Tool.
The roof members developed with the Free Hand Roof (Wall Assist) Tool work and have the same
properties as the pieces of a Free Hand Roof. There are 2 options for this tool:
-Roof member with 4 points.
-Roof member with 3 points.
For both options => set the desired Soffit depth => click on the wall => drag the roof member towards the
interior of the building => the tool will show the depth of the roof member => set the desired depth.
Determine the Elevation Base, pitches, etc.

Note that in this case, by default, the program will use the wall’s height as the Elevation Base
of the Free Hand Roof (Wall Assist) member.
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AUTOMATIC ROOFS
This is an automatic feature in the hub of the program. It creates Gable Roofs and Hip roofs.

Definition: these roofs are automatically generated by the program for a set of walls if they
are conformed as an enclosed polygon. Flat walls generate Hip roofs. Gable walls generate gable roofs

Go To: find more Information about Important Setting for Exterior Walls design.

How to Create an Automatic Roof.
By default, the Automatic roof comes unchecked.
1 - Create the floor plans of all the levels.
2 - Confirm that, for all the levels where you will have a roof, the walls form enclosed polygons.
3 – Click on the exterior side of the exterior walls in order to activate the Properties tab (right pane).
4 – Select Options => set the pitch, overhang, etc. => click OK.
5 – In the Properties tab=> Build Roof.
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All the pieces created with the Auto Roof feature work and have the same properties as the
pieces of a Free Hand Roof.
Therefore, you can delete or edit each piece separately, add or delete points, etc.

TYPES OF ROOFS BY PITCH
From the point of view of the slope, we have two types of roofs: Flat Roofs and Pitched Roofs.
Flat Roofs

Definition: A Flat Roof is a horizontal structure, therefore it has a pitch of 0° (or 0:12). This
structure is (commonly) a concrete slab.

How to Create a Flat Roof
Method 1 => Using the Roof tab: Go to the Roof tab => Select the Free hand roof Tool => outline the roof
perimeter => Select the roof => Properties tab (right pane) => set the pitch as 0:12 => Press Enter in your
keyboard.
Method 2 => using the Floor Tool: Go to the Floor Tab => select the Floor Tool => outline the roof
perimeter.
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Note that only the second method allows the definition of the thickness as well as the material
as concrete. All the roofs created with the Roof tools have a fixed thickness= 6”.
Pitched Roofs

Definition: A Pitched Roof is a construction created with one or more sloped pieces. The
structure can be wood, metal, concrete, etc.
Depending on the type of pitch, design, etc., the roofs have different names called roof styles.

THE ROOFS’ STYLES
The images below show a screenshot of the split screen (2D + 3D) of the most common roof styles and
how to develop these styles in Punch! Software (R).

Important: note that, although some roof styles and parts can be created using Ready-Made
roof shapes as the gable roof, for example, they can’t be edited by points. Therefore, in order to create
or edit a roof or add / delete points (as shown in the image below), the best option is the use if the Free
Hand Roof tool.

Note that there is a relation between the roof style and the wall styles / shapes, so take the time
to analyze the characteristics and properties of the building.
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Gable Roof

Hip Roof
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Saltbox Roof

Gambrel Roof
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Double Gable Roof

Crossed Gable Roof
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Crossed Hip Roof

Lean-To Roof
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Dutch Roof

Mansard Roof
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Shed Roof

Skillion Roof

UNDERSTANDING THE ROOFS

- 100 -

Pyramid Roof

Rotunda Roof
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Bay Window Roof

Bonnet Roof
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Half Hipped Roof (also called Jerkinhead / Clipped gable / Shreadhead)

Butterfly Roof
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Monitor Roof

Sawtooth Roof
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Helm Roof

ROOF ACCESSORIES AND COMPLEMENTS.

The Skylights, Roof Cutouts and Dormers must be placed entirely in one roof panel. This
means that these elements can’t be placed across the Ridges, Rakes, Fascia, etc.
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Roof Cutouts
Roof cutouts are openings created in a roof, in order to create the space to place chimneys, Custom
dormers, etc.
How to place a roof cutout
1 - Roof tab => Roof Cutout Tool => outline the shape of the roof opening (rectangle, circle, etc.) => the
program will set the elevation automatically.
2 – Select the Cutout points => you can modify the shape, add / delete points, etc.

Skylights
Skylights are windows installed in a roof.
How to place a skylight
1 - Roof tab => Skylight Tool => place the skylight on the roof => the program will set the elevation
automatically.
2 – Select the Skylight => this step will activate the Properties tab => set the skylight dimensions => press
Enter after each modification.
3 – Selecting the Skylight Style button (outlined in blue in the image below) => the drop down menu will
open => you can choose different types of windows or a Custom Window.

4 – The skylight trim has 2 parts: interior and exterior => In order to change the color / material of the
exterior side of the trim: apply the finishing from the exterior side of the roof => In order to change the
color / material of the interior side of the trim: apply the finishing from the interior side of the roof.
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Dormers
A dormer is a walled structure projected out onto a sloped roof. There are several types of dormers that
can be developed using different combinations of wall shapes + Roof Styles, however the most efficient
method is the use of the Dormer Tool (Roof tab). This tool places the desired dormer style as well as the
dormer walls, roof style and roof cutout.
How to place a dormer
– Using the tool => Roof tab => Dormer Tool (outlined in blue in the image below) => this step will activate
the Properties tab => define the dormer settings => the program will set the elevation automatically.
– Settings 1: Dimensions => the width and height of the front wall can be defined in the sizing fields.
Notice that the depth of the dormer will be automatically defined according with the pitches’ settings.
– Settings 2: Pitches => the pitch of the base roof can be redefined or used as detected. The slope of the
dormer’s roof (Gable, Hip or Shed) can be defined by pitch or by angle.
– Settings 3: Windows => windows are optional. If the dormer includes a window (by checking this
option), the window model can be defined after the dormer is placed by select the window => model and
settings will appear in the Properties tab
– Settings 4: Styles => by clicking on the Style button (outlined in orange), the drop down menu will open
(outlined in magenta) showing the 4 available dormers’ styles => Hip (hip roof + flat wall, pointed in green)
Gable (gable roof + Gable wall, pointed in red) Shed (Shed roof + flat wall, pointed in gray) Eyebrow
(triangular gable roof + triangular Gable wall, pointed in brown)
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– Settings 5: Side walls => the side walls (also called cheek walls) are Dormer Style walls. Their lengths
and pitches are automatically defined.
In the image below, we can see the four styles in Live View, featuring the same color codes => Hip (hip
roof + flat wall, with the green roof) Gable (gable roof + Gable wall with the red roof) Shed (Shed roof +
flat wall, with the gray roof) Eyebrow (triangular gable roof + triangular Gable wall with the brown roof)

Curved Dormer: this dormer can be developed using a Custom Shaped Wall and a curved Roof-object
created with the 3D Workshop Power Tool.

Return to Table of Contents
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In this section we are going to learn how to develop the topography and create the landscape.
TOPOGRAPHY
The topography can be developed with the different tools and resources, but frequently, several tools are
used together to obtain the desired effect.

Topography Elevations: in Punch! Software(R) the elevation of the topography elements is not
cumulative => it is always referred to the Working Elevation, and it must be defined.
The topography components can be developed following the different Drawing Methods or by creating a
shape using the elements in the Detail tab => Convert To => Topography Line or Excavation.
Topography Tools

In the Landscape tab, by clicking the Topography Tools icon, (outlined in blue) the drop down menu shows
3 tools: Topography Line, Slope Lot Section, and Excavate Topography
Topography Line: this tool can be used with different approaches and results.

Note: A complicated topography takes a long time to render and consumes computer
resources. To reduce the elaboration time => create the topography or make the changes in 2D and before
you go to Live View => go to Design => Update Topography Grid.
Note: the images below are in Clear View, in order to show the rendering patches
Case 1: creating a topography map: sometimes, it is possible to obtain the topography map of the lot,
showing the curves. This map can be imported as image and you can trace the curves or you can import
the CAD plan to the Detail tab => Convert To => Topography Line. Note that in this case, you need to
specify the elevation of each curve.
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Case 2: creating a berm or plateau: using the Topography Line tool draw the desired shape => set the
elevation. Alternatively, you can draw a shape using the tools in the Detail tab => Convert To =>
Topography Line.

Note that in this case, if we draw just the shape and add the elevation, the terrain will remain flat because
we must define the topography working elevation. For this reason, I added a shape with elevation= 0”,
that defines the working elevation.
Case 3: creating a building pad: a building pad is a flat surface, intended to define a level. For example,
the definition of the access of a house or a patio. Even if you have other topography entities, the building
pad will remain flat and in the desired elevation, as we can see in the image.
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The Slope tool
This tool creates a precise slope between two elevations. In the image below, the slope runs between the
level 0”and the level -53”. For a better finishing effect, you can add building pads following the slope
elevations (optional).

This tool can be used in two different ways:
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Option 1 – Using the slope tool => set the Start Elevation (pointed with a red arrow in the image below)
=> set the Descent Angle (outlined in magenta in the image below) => the End Elevation will be
calculated automatically (pointed with a blue arrow in the image below).

Option 2 – Using the slope tool => set the Start Elevation (pointed with a brown arrow in the image
below) => set the End Elevation (pointed with a green arrow in the image below) => the Descent Angle
will be calculated automatically (outlined in cyan in the image below).

This topography tool is useful to develop walk out basements.

The Excavate Topography tool
The excavation area can be traced as any other topography entity. This tool creates a transparent solid
area following the traced perimeter. The default depth is 36”; however, it can be adjusted
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This topography tool is useful to develop the openings for egress windows.
The Quality Issue
As any elaborated 3D entity, the topography consumes a high amount of computer resources. For this
reason, it is important to balance the quality with the resources.
In the Main Menu => Design => Lot properties, there are two parameters that will determine the 3D
rendering quality of the topography
Patch resolution: the topography is defined by squares (patches). They are visible in the Clear View
images. The minimum patch is 12”and the maximum is 120”. A topography created with more patches
will be more accurate; however, it will consume more time and resources.
Quality of the Topography Generation: it varies between 0.5 and 10. A higher quality will create softer
and more realistic contours; however, it will consume more resources, increasing the rendering time.

For these reasons, I recommend that you start with low quality and high patches. Increase the
quality checking the results and the resources of your computer.
LANDSCAPE
The landscape can be developed with several tools. Different programs have different tools. The blue
arrows show the drop down menus.
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The landscape tools
The landscape components can be developed following the different Drawing Methods or by creating a
shape / line using the elements in the Detail tab => Convert To => Property Line, Ground Fill, Patio, etc.
The tools as described from left to right.
Property line: This tool has two modes:
1 - Clicking once in first icon in the menu => this is a drawing tool that allows the trace of the lot perimeter
on the workspace. Alternatively, you can draw a line or a shape using the tools in the Detail tab => Convert
To=> Property Line
2 - Clicking twice on the icon => the Survey Coordinates menu opens: in the table, you can input the
references of your survey => the program will create the Property line. This option is available only in the
following titles: Architectural Series, Professional, as well as Deck and Patio.
Fill Tool: this is a drawing tool that allows the drawing of any shape for fill purposes using the different
Drawing Methods. Alternatively, you can draw a shape using the tools in the Detail tab => Convert To =>
Ground Fill Region. The regions created with this tool have thickness = 0” and can be set to “Float above
topography”. They can be described as “table clothes” because they are thin surfaces that follow the
surfaces below them (topography).
By default, the surface is textured with mulch, however any texture can be applied.

For better results, add several points (handles) in the perimeter so each point can “Float above
topography”
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Patio Tool: this is a drawing tool that allows the development of floors with any shape for patio or other
uses using the different Drawing Methods. It works as the Floor Tool (Floor tab). Alternatively, you can
draw a shape using the tools in the Detail tab => Convert To => Patio.
By default, the surface and sides are textured with paver bricks and the thickness is 2”; however, the
texture and thickness can be customized. The floors developed with this tool act like rigid slabs, therefore
these elements don’t “Float above topography”.
Exterior Cabinet Tool: there are 12 cabinet types in the menu

Cabinet 1 => Base Cabinet
Cabinet 2 => Corner Cabinet
Cabinet 4 => 45° Corner Cabinet
Cabinet 4 => Three Drawers’ Cabinet
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Cabinet 5=> 2 Burner Gas Grill Cabinet
Cabinet 6 => 4 Burner Gas Grill Cabinet
Cabinet 7 => Side Burner Cabinet
Cabinet 8 => Buffet Cabinet.
Cabinet 9 => Refrigerator Cabinet.
Cabinet 10 => Sink Cabinet.
Cabinet 11 => Ice Chest Cabinet.
Cabinet 12 => Trash Bin Cabinet.
All the options are Base Cabinets. By default, all the doors and drawers are textured with a metallic
finishing; however, all the materials can be customized.
The parts, style, hardware and sinks can be customized as detailed in the interior Cabinet Tool. However,
these cabinets include an additional part: the Bar Top that can be placed on 3 sides of the cabinet and
customized to overhang as desired

Placement: the exterior cabinets can be placed in any location and they don’t need to be
attached to a wall.
Pathway / Driveway Tool: this is a drawing tool that allows the development of straight or curved path
for walking or driving using the different Drawing Methods. By clicking on the tool, you can draw the axis
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of the path: the pathway or driveway will follow this axis. Alternatively, you can draw a shape using the
tools in the Detail tab => Convert To => Pathway / Driveway. The default width is 36”, but it can be
customized as necessary.
The regions created with this tool have thickness = 0” and can be set to “Float above topography”. They
can be described as “table clothes” because they are thin surfaces that follow the surfaces below them
(topography). For better results, add several points (handles) in the center line so each point can “Float
above topography.
Edging Tool: this tool creates ornamental borders for driveways, pathways, flower beds, etc. as well as
the actual pathways, using the different Drawing Methods. In the floor plan, the tool creates a line that
will be filled with the edge elements. Alternatively, you can draw a line or a shape using the drawing tools
in the Detail tab => Convert To => Edging.
The tool allows the customization of the components’ shapes and properties: dimensions, height, the
spacing between the elements as well as the variable height of the elements. These properties allow the
use of this tool for other uses, such as the creation of walkways with stepping stones, for example.

For better results on a sloped terrain, add several points (handles) in the center line so each point can
“Float Above Topography”.

Tip: if the distance between the elements is 0” => the adjacent edging pieces will blend.
Fence Tool: By clicking on the Fence icon, the drop down menu opens with 2 options: Fence and Gate.
The fence option has two groups: the Standard wood fences (with the Privacy, Picket, Ranch and Rail
default models) and the Custom models. The Custom Fence is a tool in itself and can be combined with
the use of the Fence Designer Power Tool.
For any model, click on the icon and trace the fence line. Alternatively, you can draw a line or a shape
using the tools in the Detail tab => Convert To => Fence => select the model.
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The default models (Privacy, Picket, Ranch and Rail) are textured with wood; however, as these fences
are composed by 3D elements, you can change the materials as necessary. This means that, instead of
the wood texture, you can finish the fence with any material or paint color, for example.

The custom fences are composed by three elements: the span, the posts and the gates.
- Span: it is the distance between 2 posts. The length and height of the span can be customized to fit the
necessities. The span is a 2D surface with a texture partially transparent. By default, the texture is Iron
Ornamental. As the span is a 2D image, it is not possible to change the color of the span elements (for
example: you can’t change the color of the iron pickets). Instead, you can apply another texture (Materials
Library => Custom Fences => check the types and options => apply the texture on the span).
Alternatively, you can use or import any other Custom Texture.

Go To: find more Information about Importing Custom Textures
- Posts: In the Custom Fences, the program will add posts:
1) Each time you click the mouse. So, if you draw a line, you will have 2 points, one in the start point and
one at the end point.
2) Between spans. This means that, if you set the span as 70”, for example, there will be a post each 70”.
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The posts are 3D objects; therefore, they can be textured or painted as desired. By default they are square
prisms with width= 24”and height= 72”. The width and height of the posts can be customized to fit the
necessities; however, the shape of the posts can’t be changed.
- Gates: the gates work as the spans but they can be textured independently. By default the width is=
36”and the height is= 72”; however, the width and height of the gates can be customized to fit the
necessities
The Fence Elevation.
By default, the fences “Float above topography”. This feature allows that the fences follow the lot slopes
and contours. The points that will follow the topography will be the posts. Notice that the spans will be
always horizontal elements. For this reason, in order to follow a sloped topography, a fence needs as many
posts as possible, as you can see in the image => the shadows show the differences

Retaining Wall Tool: this tool works as the Wall Tool (Floor Tab) and doesn’t include any special property
=> shapes and dimensions can be customized. Notice that an isolated retaining wall doesn’t stop the
topography.

Irrigation tools: there are 6 tools:
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- Sprinkler Head: a circular 2D symbol showing the head location and sprinkling area
- Irrigation Water Line: a 2D line showing the path of the water line
- Irrigation Zone: a 2D symbol marking the irrigated area
- Irrigation Control Panel: a 3D Component, wall attached
- Irrigation Backflow Valve: a 2D and 3D Component
- Rain Sensor: a 2D and 3D Component

THE PLANTS
The Plant Library is located in the Libraries tab (right pane of the screen). The library has subcategories
for trees, hedges, shrubs, etc.
The plants can be placed by dragging and dropping onto the floor plan or they can be also dropped in Live
View => by default, the plants will be placed “Floating Above Topography”.
The plants in Punch! Software (R) are developed from pictures; therefore it is not possible to change the
texture or color of the plants in the libraries. For example: the programs offer the plant “Gallica Rose”
with red flowers. If you wish a “Gallica Rose” with deep pink flowers, you can’t paint the flowers within
the program: in this case, you need to create a new plant by importing a new image

Go To: find more Information about importing new plants.

Depending on the characteristics, the plants can be customized by libraries or by project.
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Customizing the Plant’s Settings in the Libraries
In order to change the library settings of a plant, you need to copy the plant to the User Library. Once the
plant is in the User Library (you can do this by right clicking on the thumbnails in the library or by right
clicking on a plant) => Edit Details => all the settings of the plants can be edited. In addition, the plants can
be added to the Favorites library.

Go To: find more Information about User Library and the Favorites library.
The names of the plants, as well as the zones, the soil, the sun light, the propagation, the water, the
temperature and the region settings don’t affect the visual and behavior of the plants in the program.
They are used for search and information purposes.
The Maximum Grow Height indicates the full height of the plant after the full growth cycle (different for
each plant). For example:

The Annual Growth Rate (outlined in red in the image below) controls the size of the plant in 2D and 3D.
You can change these parameters in order to fit your custom condition or specifications.
You can control the growth of the plants in you project using the Plant Growth Meter
The Grow Projection (desired age of the plants) is available in the Main Menu => Design => Options =>
General => Plant Growth Projection.
Plants - Top Down View: the Normal View of the plant is the front view of the plant => it is the image that
you will see in 3D Walk-Through and Fly-Around views. The Aerial View of the plant (outlined in green in
the image below) is the image that you will see in 3D Aerial Top-Down view. For this option the program
includes a standard top view for each plant type. If desired, in the menu, you can change the image of the
Aerial View by clicking on the Choose button.
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Customizing the Plant’s Settings in a Project

The changes in the plants described below are effective only in the current project => this
means that they are not saved in the Plant Library.
Changes in the geometry: by default, when we insert a plant, the geometry is defined according with the
parameters defined in the Annual Growth Rate, as specified in the Plant Library, however these
parameters can be changed for individual elements of a project. By selecting a plant, you can define the
information by filling in the fields at the top of the Properties tab (outlined in red in the image below). In
this way you can define individual characteristics for the different specimens of the same plant shown in
your project.
Plants in 2D: by default, in 2D, all the plants have the same symbol (a circle with several lines originating
from the center, pointed in blue in the image below). However, after the insertion of a plant in the floor
plan, it is possible to change the 2D aspect by selecting a new symbol in the Plant Symbol Library (pointed
in green in the image below). The library includes different subcategories with symbols for hedges,
annuals, trees, etc. The different symbols don’t modify the plants.

Go To: find more information on How to Customize Your 2D Plan.
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Plants’ information: by pointing to the plant with the Leader Dimension Tool, the text in the floor plan
will show the plant’s common name and botanical name (pointed in magenta in the image below).

Go To: find more Information about Creating New Symbols for the Plant Library.
Plant Inventory Bar: by clicking on Design => Show Plant Bar => the plant bar will open at the bottom of
the 2D screen showing all the plants used in the file. The plants can be selected, applied, etc.
In addition, you can drag and drop a new plant into the slot of any plant in this bar => the new plant will
replace all the instances of the previous plant.

Additional Tools
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At the bottom of the Plant Libraries, there are two useful tools:
- The Search field (pointed in blue in the image below): this field allows the search of a plant by name by
writing the name of the plant (common, botanical) => the matching plants will appear in the Library tab.
- The Options button (gear wheel, pointed in red in the image below) => by clicking on this button,
additional options will appear. The Hardiness zones contains the maps of 5 world regions, matching the
zones listed for the plants. The PlantFinder allows a more detailed search, as explained in the next topic.

The PlantFinder
The PlantFinder allows a search based on the characteristics of the plants: Hardiness zones, sunlight
requirements, soil requirements, water requirements and propagation. The matching plants will appear
in the Library tab.
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Tips:
Name of the plant: Click on a plant in the library => in the bottom left corner of the screen (the Status
bar), you will see the name of the plant.
Finding a plant: By selecting and right clicking any plant in the floor plan => select Locate Plant (outlined
in red in the image below) => the plant will be selected in the library.

Return to Table of Contents
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In this section we are going to learn how to develop the structure of the project.

Visualizing the Structure in Live View: the 3D structural elements can be visualized in live view
only in Framing mode (but not in Shaded Mode)

Remember: always check the structural specifications with a licensed Engineer or a licensed
building professional.

FOUNDATIONS
There are 4 tools in the Foundation tab:

Stiffener Beam: this element is a foundation reinforcement beam, usually constructed in steel. By clicking
on the icon, you can draw the beam line. Alternatively, you can draw a line using the tools in the Detail
tab => Convert To => Stiffener Beam. The Properties tab menu allows the customization of the width and
depth. The beam appears (with dimensions) in the floor plan, but it is not visible in live view (any style).
Foundation Pier: this element is a point type foundation, usually constructed in concrete, masonry or
treated wood. By clicking on the icon, you will draw a circle marking the pier. Alternatively, you can draw
a circle using the tools in the Detail tab => Convert To => Foundation Pier. The Properties tab menu allows
the customization of the diameter and depth. The beam appears (with dimensions) in the floor plan and,
if the Foundation Pier is above the topography level, it is also visible in live view (Framing mode).
Post Tension Strand: this element is a foundation device to prevent cracks, usually constructed in steel.
By clicking on the icon, you can draw the device line. Alternatively, you can draw a line using the tools in
the Detail tab => Convert To => Post Tension Strand. This element appears as an arrow in the floor plan
and it is not visible in live view (any style).
Foundation Slope: this element means a floor inclination intended to provide the correct slope to a drain.
By clicking on the icon, you can draw the slope line. Alternatively, you can draw a line using the tools in
the Detail tab => Convert To => Foundation Slope. This element appears as an arrow in the floor plan and
it is not visible in live view (any style).
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Auto Foundation: by default, the walls in the perimeter of the lower floor create an auto foundation set
composed by a slab and the perimeter walls’ foundation.
By clicking on the exterior side of the perimeter walls, a yellow band will be created around the walls
(pointed by the green arrow in the image) => the Properties tab menu allows the modification /
customization of the elements.

Slab Height: height of the foundation slab defined in the New Project screen.
Foundation Width: (outlined in red in the image above) => this is the foundation usually called Footing: it
follows the wall length and is always wider than the wall (in order to transmit the load to the ground). The
width is related with the width of the wall, number of floors, type of materials, type of soil, building codes,
etc. The necessary width will be determined by a licensed Engineer.
Slab Framing: by clicking on the Slab Framing button (outlined in blue in the image above) the Auto
Foundation menu will open (pointed in blue in the image). The menu allows the selection of the framing
material. If the material is wood, the joist, rim and spaces can be selected.

STRUCTURAL SETTINGS VISUAL GUIDE
Not all the structural elements are defined in the same way. Some are defined by right click and some are
defined in the Properties tab (right pane of the screen). This Visual Guide shows the images of the
different building elements in the Framing Tab and how their structural settings are defined.

Note that the Auto Roof is not included in the Visual Guide because there are separate
specifications for the Auto roof Framing.
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The details of each structure are explained in the sections Framing Tab and Defining other structural
elements.

FRAMING TAB
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There are 3 tools in the Framing tab:

Beams: (in dark blue in the Visual Guide) => by clicking on the icon, you can draw the beam line => select
the beam => The Properties tab menu (right pane) allows the customization of the width and depth of the
beam as well as the building materials. The beam appears (with dimensions) in the floor plan (Framing
tab) and it is also visible in live view (Framing mode). The elevation can be specified using the Elevation
bar or by right clicking the beam, following the concepts of Elevation of the structural elements.
Framing Joist: (in green in the Visual Guide) =>by clicking on the icon, you can draw the joist area in the
workspace => select the joist area => The Properties tab menu (right pane) allows the customization of
the joists’ size, angle and spacing as well as the building materials (wood or steel). The rim in the perimeter
can be included by checking this option.
The joists appear in the floor plan (Framing tab) and they are also visible in live view (Framing mode). The
elevation can be specified using the Elevation bar or by right clicking the joist area, following the concepts
of Elevation of the structural elements.
Framing Support Columns: (in brown in the Visual Guide) => by clicking on the icon, you can place the
column in the workspace => select the column => The Properties tab menu (right pane) allows the
customization of the columns’ height, diameter / width as well as the building materials (wood or steel).
The default height is the default ceiling height for the level. The steel columns have a round section and
the wood columns have a square section. These columns appear in the floor plan with the diameter
dimension (Framing tab) and they are also visible in live view (Framing mode). The elevation can be
specified using the Elevation bar or by right clicking the column, following the concepts of Elevation of
the structural elements.
DEFINING OTHER STRUCTURAL ELEMENTS
Structure of the Walls: (in red in the Visual Guide) => right click on the wall => Framing Properties =>
define the building material => specify the type of wall (load) and insulation. The walls’ structural elements
don’t appear in the floor plan (in any tab) but they are visible in live view (Framing mode). The elevation
follows the concepts of the general elevations.
Structure of the Manual Floors: (in magenta in the Visual Guide) => (only for manual floors developed
with the Floor Tool) => right click on the floor => Framing Properties => select the building material (wood,
steel or concrete) => if the material is wood, customize the joists’ angle and spacing as well as the rim
option. The joists appear in the floor plan (Framing tab) and they are also visible in live view (Framing
mode). The elevation follows the concepts of the general elevations.
Structure of the Decks: (in orange in the Visual Guide) => right click on the deck => Framing Properties =>
customize the framing of the decking board (width and angle) Frame and Rim joists’ size, angle and spacing
as well as the building material. In addition the Post piers can be specified in this menu. The joists appear

THE STRUCTURE

- 129 -

in the floor plan (Framing tab) and they are also visible in live view (Framing mode). The elevation follows
the concepts of the general elevations
Structure of the Stairs: (not in the guide) => right click on the Stairs => Framing Properties => select the
building material (wood or steel)
Structure of the Manual Roofs: (in gray in the Visual Guide) => (only for roofs developed with the Roof
tools in the Roof tab) => right click on the roof => Framing Properties => define the building material =>
specify the type structure (Rafters or Trusses). The roofs’ structural elements don’t appear in the floor
plan (in any tab) but they are visible in live view (Framing mode). The elevation follows the concepts of
the roofs elevations.
Structure of the Roof – Auto roof: For this tool, the framing settings are defined with the Options Menu.
By clicking on the exterior side of the perimeter walls, a yellow band will be created around the walls
(pointed in green in the image) => the Properties tab opens => click on the Options button => the
Automatic Roof Options menu will open, including the Framing Options (outlined in red in the image) =>
define the building material. The roofs’ structural elements don’t appear in the floor plan (in any tab) but
they are visible in live view (Framing mode). The elevation follows the concepts of the roofs elevations.

Question for this issue: Can I texture the framing elements with other colors or materials?
Answer: Colors and materials cannot be applied in live view Framing mode.

Elevation of the structural elements: as we know, the elevation of the building elements is a
very important specification. This includes, of course, the structural elements.
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Let’s see an example: how to set the correct elevation of a beam? In the image, we can see the slab with
height= 4” and the wall with height= 96”. The height of the beam is 12”. Therefore:
- The top of the wall is= 100” (96”+ 4”)
- The height of the beam is 12” (outlined in green)
- The elevation of the beam is measured from the base of the beam
- The elevation of the beam will be => the level of the top of the wall – the height of the beam => 100”12”= 88” => as indicated in the Elevation bar (outlined in black).

Return to Table of Contents

THE STRUCTURE

- 131 -

Objects, Accessories, Symbols & Components ......................... - 133 Settings, Tools and Drawing Resources ....................................... - 174 The Libraries ..................................................................................... - 205 Customizing Your 2D Plan.............................................................. - 218 -

Return to Table of Contents

THE STRUCTURE

- 132 -

After you complete the building items of your project (like walls, roofs, etc.) it is time to add doors,
windows, furniture, etc.

Definitions: in addition to the building structures, Punch! Software (R) has two other types of
3D entities: 3D Objects and Special Objects. The main difference between them resides in the elements’
inherent properties
3D OBJECTS
3D Objects are elements created with the 3D Custom Workshop Power Tool or selected from the Punch
3D library or 3D files imported from external sources (3DS, SKP). By default, 3D objects don’t have any
special property or behavior and can be modified, resized, textured, elevated, rotated or renamed as
necessary. In other words, if you create and texture a concrete column as a POB, for example, you can
open this object using the 3D Workshop Power Tool and then, rotate and retexture the same object and
save it as a wood beam.
POB (Punch! Software (R) Objects): a *.POB file is a Punch! Software (R) proprietary format for the objects
developed with the 3D Workshop Power Tool. This Power Tool allows the development of almost any
type of 3D objects using 2D shapes / 3D solids. The main advantage of the objects created from scratch
with this tool is the fact that they have fewer polygons than the similar (imported) skp or 3DS files. The
3D Custom Workshop Power Tool is present in all the PC Punch! Software (R) programs.
POBs are saved as objects as part of the 3D Object Library, and in this case, they don’t have any special
property. In addition, POBs can be saved also as Components, adopting the properties of the category
where they were saved (Toilets, Edging, etc.). The POBs can be exported to 2D / 3D using formats DXF /
DWG.
Imported Objects: The Punch! Software (R) programs import 2 different formats of objects: 3DS files and
SKP (Sketchup) files.
The programs import these files from the HUB of the program (File => Import). By selecting an object, its
current dimensions appear in the Properties tab, therefore, the dimensions can be adjusted (by units or
percentage sizing). Proportions and angle can be adjusted as well (outlined in blue in the image below)

Reminder =>after changing any of the parameters or any other property in the Properties tab
you must press the Enter key in your keyboard so the new value will take effect.
Materials and colors can be applied to the objects. If the Smart Wand is activated, all options of this tool
are available (pointed with a green arrow in the image below).
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Note that, after you import a 3DS object, it is possible to open it using the 3D Workshop Power Tool
(use right click => 3D Workshop Power Tool). After this, it is possible to modify the object and save it to
the User Library.

The Polygons’ Issue
Although the importing capabilities in the Punch! Software (R) programs are very important, the size (in
kb) and definition of some imported objects may compromise the operation of the program.
As a general concept, in order to smoothen the surfaces in a 3D program, the segments of each object
must be smaller. Each segment is called a polygon, and usually, nice and smooth 3D objects have very high
count of polygons. As each polygon is rendered individually, the more polygons an object has, the more
calculations the processor and video adapter need to do, therefore it is necessary to have more dedicated
memory and of course, it takes more time to render.
For this reason, if the video chip is integrated with the motherboard, the memory is shared so the render
capabilities are reduced => therefore, if possible, always try to use the POB.

Go To: find more Information about the polygons’ issue
You can visualize the issue in the image below, with all the polygons selected. The chair on the left is an
imported 3DS file and the chair on the right is a POB
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The chair on the left has 19,909 polygons and the size in the 3D library is 626 kb. The chair on the right
has 3,486 polygons and the size in the 3D library is 62 kb.

SPECIAL OBJECTS
Some 3D entities are called Special Objects or Components because they have embedded one or more
special properties or behaviors. For example, if you insert an 110W receptacle (Electrical tab), you can’t
open or edit it with the 3D Workshop Power Tool, you can’t move it to another tab; you can’t detach it
from a wall, just to name a few properties. There are different types of Special Objects like Accessories,
Tool Generated Elements, 3D Symbols, etc. Independent of the names or how they are created, we’ll
analyze them ordered by tab. If they are inserted using a wall, they are called Wall Attached Components.
DOOR TOOL
Location: Floor tab
Objective: The door tool is intended to create openings in the walls, communicating two rooms or a room
and the exterior. The opening can be created with or without trim and / or folders.
Elevation and height: the doors’ elevation is always referred to the base of the wall where they are
inserted, independently of the elevation of the wall. By default, the doors’ elevation is at 0”; however this
level can be changed, if necessary. The vertical distance between the bottom and the head of the door
(the top of the entire piece) is the height of a door => in order to align the top of the doors and windows,
follow the lintel note.
Insertion and Settings: By clicking on the Door icon (Floor Tab) the Properties tab (right pane) shows the
drop down menu with the Default doors, the Custom icon and the Style icon.
OBJECTS, ACCESSORIES, SYMBOLS & COMPONENTS

- 135 -

The first 3 options are empty casements => they will create a trimmed opening in the wall, without any
folder. Or the trim can be set as 0” in order to create an uncased opening. The additional options (Hinged,
Light, Pocket, Bi-fold, Sliding and Garage) cannot be edited and they have special operation properties.
Custom Doors: by default there are six categories of Custom Doors => Exterior, Garage Doors, Interior,
Light, Panel, and Sliding. New categories and subcategories can be created in the User Library. New doors
can be created or current Custom doors can be customized using the Door Designer Power Tool as well
as the customization options in the Properties tab.

How To Customize a Door
After you choose the door model, click on the wall to insert the door. In order to customize it select the
door and proceed to the Properties tab.

The modifications created in the Properties tab are effective only for the selected door in a
particular project. The modifications regarding the dimensions, model, finishing, etc. can be done in any
order.
Properties: you can customize the properties (outlined in green in the image below) like the thickness of
the trim, door dimensions (width and height), as well as the door elevation. The door elevation is the
distance between the base of the door and the base of the wall.
Swing: you can set the swing options (outlined in magenta in the image below) like the mount position
(flush or center) as well as the swing angle and side of the hinges.
Single / double panels: each custom door can be defined as single or double door by checking Double
door box (pointed with a green arrow in the image below).
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Model: you can also change the door model by selecting the inserted door and click on the new model of
the library (right pane, outlined in blue in the image below).
Flip: the Custom doors panels, hinge side and swing side can be flipped using the buttons pointed with
magenta arrows in the image below.
Operation: The opening operations of the Pocket, Bi-fold, Sliding and Garage doors are specific to these
types of default doors => this means that it is not possible to create a Custom Door with side or overhead
opening => all the Custom doors will open as hinged doors.

Hardware: this option allows the placement of the Door Knobs, Handles and Bars as well as Hinges, Chains
and Latches on both sides of the door (categories and subcategories pointed with blue arrows in the image
below). The Vertical Offset and the Horizontal Offset position can be customized (outlined in green in the
image below).

Note that the hardware will be applied accordingly with the selected hinge side option (pointed
with a magenta arrow in the image below).
Also note that you can apply only one hardware component for each side of the door.
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Style: this option allows you to apply six different styles of panels for the default hinged non curved doors

Reminder =>after changing any of the numeric parameters or any other property in the
Properties tab you must press the Enter key in your keyboard so the new value will take effect.

Questions about doors
Question 1: what elements can be customized in a door without any power tool?
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Answer 1: different colors / materials on both sides of the trim, color /material of the folder, thickness of
the trim, dimensions (width and height), elevation, single / double door, swing angle and the addition of
hardware. To change the name and specs, copy the door to the User Library.
Question 2: how can I create a double bifold door with W= 48”?
Answer 2:
- In the desired wall, insert an empty casement (no folder) => set the width= 48” (in blue in the image
below).
- Insert 4 doors with 12" each inside the casement (in white in the image attached) => set the swing angle
at 45 degrees and the trim at 1" => set them together
- Go to Materials => Miscellaneous => Black Invisible (1st icon) => apply on the trim (both sides).

Question 3: How to create an opening in the wall without any trace of the trim?
Answer 3:
- Place an empty casement (pointed with a magenta arrow in the image below).
- Go to Materials => Miscellaneous (outlined in green in the image below) => Select Black Invisible (the
1st icon, pointed with a blue arrow in the image below)
- Apply on both sides of the trim (pointed with a red arrow in the image below).
- As you will see, the trim will become transparent, creating an untrimmed opening.
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You can use the method above to create wall openings, niches, etc.
Question 4: how can I flip a bi-fold door (fold to the right or left)?
Answer 4: It is related with the wall direction => if you draw the wall from the left to the right, the door
folds to the left. But if you draw the wall from the right to the left, the door folds to the right.

Question 5: Is it possible to add Custom Door trims?
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Answer 5: yes, it is possible. Create the door => go to the Trim tab => Wall trim => choose a trim model
=> drag and drop on the door trim.
Question 6: is it possible to move a door along a wall using the arrows in the keyboard?
Answer 6: yes, it is possible to use the drag along the wall method. However, the movement will stop if
there are wall breaks.

Aligning the top of the openings - the lintel: In a building, unless we have different structural
solutions, usually there is a beam around the perimeter of a room or at least above the openings: this
beam is a lintel. The goal of this beam is the support of the load above the openings, windows and doors.
For this reason, if we have a continuous top line for the openings, the head of the windows (with simple
height models) should be horizontally aligned with the head of the doors (with simple height models,
without transoms) , as per the image below => therefore, if this is the case => the elevation of the door
(from the base of the wall, in blue)+ the height of the door (in white) + the door trim (in red) => should be
equal to => the elevation of the window (from the base of the wall, in blue) + the height of the window (in
white) + trim (in green) => in this case = 84”

WINDOW TOOL
Location: Floor tab
Objective: The window tool is intended to create openings in the walls (usually exterior walls). The
openings can be created with or without trim and / or sashes.
Elevation and height: the windows’ elevation is always referred to the base of the wall where they are
inserted, independently of the elevation of the wall. By default in the Punch! Software (R) programs, the
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windows’ elevation is 24”; however this level can be changed as necessary. The vertical distance between
the bottom and the head of the window (the top of the entire piece) is the height of a window => in order
to align the top of the doors and windows, follow the lintel note
Insertion and Settings: By clicking on the Windows’ icon (Floor Tab), the Properties tab shows the drop
down menu with the Default windows and the Custom Windows. Once you select the window model,
you can customize the window as well as add or modify the embedded shutters .

The modifications created in the Properties tab are effective only for the selected window in a
particular project.
Default Windows: The first 2 options are casements with grills, which can be customized or removed. The
Curved, Angled and Round shapes are fixed windows => they will create a trimmed opening in the wall,
without sashes. Or the trim can be set as 0” in order to create an uncased opening.

How to Customize a Window
After you choose the window model, click on the wall to insert the window. In order to customize it, select
the window and proceed to the Properties tab. You can also change the window model by selecting the
inserted window and click on the new model in the Library tab (right pane).

The modifications created in the Properties tab are effective only for the selected window in a
particular project. The modifications regarding the dimensions, model, finishing, etc. can be done in any
order.
Properties: you can customize the properties (outlined in green in the image below) like the thickness of
the trim, window dimensions (width and height), as well as the window elevation. The window elevation
is the distance between the base of the window and the base of the wall.
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Custom Windows: by default there are six categories of Custom Windows => Casement, Curved, Double
Hung, Fixed, Vent and Windows set. New windows can be created or current Custom windows can be
customized using the Window Designer Power Tool as well as the customization options in the Properties
tab such as width, Height, Elevation, Trim thickness as well as pitch (for sloped windows)(outlined in green
in the image below).
Operation: The windows can be designed to show a certain type of operation (double hung, for example),
however, all the elements in a Punch! Software (R) window remain parallel to the wall. This means for
example that you can’t show (in 2D or 3D) an opened awning window.

Reminder =>after changing any of the parameters or any other property in the Properties tab
you must press the Enter key in your keyboard so the new value will take effect.
Shutters (Embedded): by opening the Windows’ drop down menu and selecting the Shutters option
(pointed with a black arrow in the image below) it is possible to add embedded shutters to any window.
The shutters are organized in 3 libraries, according with the opening styles: Folding and Rollup, Sliding,
and Swing. Most of the properties can be customized.
- Layout (outlined in blue in the image below): the shutters can be placed to the left and right of the
window (used when the model is composed by 2 different pieces) or centered (used when the model is
composed by 1 piece).
- Sizing (pointed with a brown arrow in the image below): by default, the automatic sizing is selected. With
this option, the shutters’ sizes follow the windows’ sizes. To customize the dimensions, you can select the
manual sizing option and set the new dimensions, depth and offsets as necessary.
- Draw Shutters (pointed with yellow arrows in the image below): by checking the Draw Shutters option,
the 2D symbols of these components will appear in the floor plan. Notice that, if the shutter is composed
of 2 parts, the Draw Shutters option must be checked for both parts.
OBJECTS, ACCESSORIES, SYMBOLS & COMPONENTS

- 143 -

- Flip Wall Mount Side (outlined in magenta in the image below): by default, the shutters are placed on
the exterior face of the wall, however, by clicking on Flip Wall Mount Side button, the shutter will be
placed on the opposite face (interior face in this case).
- Left Tab (pointed with red arrows in the image below) / Right Tab (pointed with green arrows in the
image below): for opened shutters featuring the left / right layout, each side must be set separately by
selecting the Left / Right tab and the correspondent half shutter in the library (hover over the pieces to
see the names and positions).
- Flip (pointed with an aqua arrow in the image below): flips the selected piece.
- Remove (pointed with a gray arrow in the image below): removes the selected shutter / piece. For
opened shutters featuring the left / right layout, each side must be deleted separately by selecting the
element in the Left / Right tab.

The embedded shutters are a part of the window. Some shutters can be independent of the
windows such as the shutters as accessories as well as the objects created with the 3D Workshop
Power Tool.

Questions about windows / shutters
Question 1: What elements can be customized in a window shutter without any power tool?
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Answer 1: different colors / materials on both sides of the trim, color /material of the folder / shutter,
thickness of the trim / shutter, dimensions (width and height) and elevation. To change the name and
specs, copy the window to the User Library.
Question 2: How to create an opening in the wall without any trace of the trim?
Answer 2: - Place an empty casement picture window (pointed with a magenta arrow in the image below).
- Go to Materials => Miscellaneous (outlined in green in the image below) => Select Black Invisible (the
1st icon, pointed with a blue arrow in the image below)
- Apply on both sides of the trim (pointed with a red arrow in the image below).
- As you will see, the trim will become transparent, creating an untrimmed opening.

You can use the method above to create wall openings, niches, etc.
Question 3: Is it possible to add Custom Window trims?
Answer 3: yes, it is possible. Create the door => go to the Trim tab => Wall trim => choose a trim model
=> drag and drop on the window trim.
Question 4: is it possible to move a window along a wall using the arrows in the keyboard?
Answer 4: yes, it is possible to use the drag along the wall method. However, the movement will stop if
there are wall breaks.
Question 5: is it possible to create window frame with glass blocks or stained glass inside the frame?
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Answer 5: yes, it is possible. There are 2 options:
- Standard option: go to Custom Windows => Fixed => the 3rd window is a fixed window with an opaque
panel => Visualize in LiveView (pointed with a green arrow in the image below) => Go to Materials =>
Stained Glass (outlined in red in the image below) => Drag and drop the desired material on the panel
(pointed with blue arrows in the image below). Of course, you can use other materials according with your
necessities.

Custom Option => If your program has the Window Designer Power Tool, you can create a standard
casement (any shape) with an opaque panel => texture the panel as necessary. If you don’t have the Power
Tool, insert an empty casement or a fixed window (any shape) => create a 2D surface using the 3D
Workshop Power Tool => insert the surface inside the window => texture the panel as necessary.
Question 6: is it possible to change the colors and materials of the embedded shutters?
Answer 6: yes, it is possible. Just drag and drop the new color or material on the shutter. Notice that, for
opened shutters featuring the left / right layout, each side must be textured separately.

ACCESSORIES TOOL
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Location: Floor tab
Objective: The Accessories tool is primarily intended to add accessories for doors and windows, like
curtains, blinds, etc.
Elevation and height: the accessories’ elevation (top and bottom) is always referred to the base of the
wall where they are inserted (outlined in red in the image below), independently of the elevation of the
wall. The accessories have special elevation settings: they are defined by the relation among the top
elevation, the bottom elevation and the height of the accessory.
The relation is always => Top Elevation = Bottom Elevation + Height. By default, the top elevation is 84”;
however this level can be changed, if necessary. This is convenient for cornices, for example, that must be
placed above the windows.

Insertion and Settings: By clicking on the Accessories’ icon (Floor Tab) the Properties tab shows the first
category of accessories => clicking in the category name opens the menu of the different categories =>
choose an accessory => click and drag onto the wall to insert the accessory. It is not necessary to have a
door or window present to insert the accessory, however, all the accessories must always be applied on
walls.
After the insertion => select the accessory in the plan => Properties tab => you can adjust the settings. If
you wish to align your accessories with the top of the windows and doors, and they are aligned with a
lintel with elevation of 84” (for example), you can use the same top elevation for the accessories.
The vertical distance between the bottom and the top of the accessory (the top of the entire piece) is the
height of the accessory.
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All the settings can be modified, however the relation between the elements is maintained
Examples of possible changes in the settings (as per image above):
- If we keep the top elevation = 84” and we set the accessory height = 70”, the program will change
automatically the bottom elevation = 14”
- If we keep the accessory height = 65” and we set the bottom elevation = 10”, the program will change
automatically the top elevation = 75”
- If we keep the accessory height = 65” and we set the top elevation = 90”, the program will change
automatically the bottom elevation = 25”
The Width of the accessory works independently of the other dimensions and must be defined manually
according with the type of window / door and the type of accessory: for example, a Cornice with Crown
Molding must be wider than the window, but a blind must fit the window.
The distance between the accessory and the wall can be controlled using the Wall Offset command =>
usually, as in real life, a blind must be placed at a distance from the wall but a cornice must be placed
directly on the wall.
The final setting of the bar is the transparency of the accessory => 0% is opaque and 100% is transparent.
Note that, using a transparency= 100%, the accessory disappears.
The modifications regarding the dimensions, elevations, offset, etc. can be done in any order.
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Notice that the accessories can be applied on any or both sides of a wall.
Shutters as Accessories: the accessories library includes 5 shutters’ categories => Half, Louvered, Patio
Door, Plantation and Raised Panel Shutters. These components work like any other accessory and can be
added by dragging and dropping the accessory on the wall (floor plan).
They can be resized manually using the fields in the Properties tab (outlined in red in the image below)
or you can use the AutoSize option (outlined in green in the image below) to fit the accessory using the
window / door size.
As with any accessory, you can set the translucency values using the controls outlined in magenta in the
image below.

Questions about accessories
Question 1: I like one of the blinds in the library, but the default colors don’t match the colors I need. Can
I change the colors / textures of the accessories?
Answer 1: as the accessories are pictures, you can’t change the default colors. There are three options:
- Create a Custom Accessory.
- Edit the Accessory with the Material Editor.
- Export the picture of the accessory to a graphic program => apply a color layer => import the new picture
as accessory
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How to Create a Custom Accessory?
In Punch Software (R), an accessory doesn’t mean only a curtain or draperies. You can use this tool to
create your custom wall accessory as well as a custom window or door molding. Let’s see how to create a
Custom Window Brick Header.
Step 1: first, you will need a picture of the desired trim, header, precast or keystone. Using any image
program or PhotoView Editor Power Tool (if your program includes this tool) proceed to mask the picture
=> this means that you must cover all the undesired areas using color black (RGB 0,0,0). The black color
will be rendered as “transparent” in the main program. The picture will look as the image below:

Step 2: Open your program. This picture should be imported as a custom material. So. Go to => File =>
Import => Material to library. Of course, the material will be imported to your User Library.
As you can see in the image below (outlined in blue), I have a subcategory called “moldings”, where I place
all my moldings and trims.
Two important settings: in the size fields, outlined in red in the image below, select “stretch” (you will set
the dimensions in the next step). Also, select “Transparent Black”(outlined in green in the image below),
so the masking (Step1) will be transparent. Although the thumbnail is square it doesn’t affect the quality.
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Step 3: in the main program, go to the Floor tab and select the Accessories Tool (outlined in red in the
image below) => go to your User Library (outlined in green in the image below) => select the trim (outlined
in yellow in the image below) => place the Accessory in the floor plan, clicking on the desired window
(pointed with a blue arrow in the image below).

Step 4: In the floor plan => Select the Accessory (pointed in red in the image below) => if you work using
Split screen (2D / 3D) you will be able to see the trim and the window (pointed with a blue arrow in the
image below) => set the dimensions and elevation in the Information tab (outlined in green in the image
below). Also, don’t forget to include a small offset (pointed with a magenta arrow in the image below).
This will create “depth” in the accessory.
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Note that when you render the image, the offset in the accessory creates shadows (pointed with blue
arrows in the image below).

This is the finished image. The same procedure can be used for any other Custom Accessory.
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CABINET TOOL
Location: Floor tab.
Objective: The cabinet tool is intended to create cupboards, shelves, islands, etc.
Elevation and height: the cabinets’ elevation is always referred to the base of the wall where they are
inserted, independently of the elevation of the wall. By default, the base cabinets’ elevation is 0”; however
this level can be changed, if necessary. This is also valid for all the types of full cabinets. The elevation of
the top cabinets appears as 0” in the Elevation bar, however the distance between the floor and the base
of the top cabinet is 54”. The vertical distance between the bottom and the top of the cabinet is the height
of the cabinet. In order to align the top of the cabinets with the doors and windows, follow the lintel note
Insertion and Settings: By clicking in the Cabinets’ icon (Floor Tab) the Properties tab shows the menu
with the Cabinets’ types, parts, Styles, sinks and hardware options.

The cabinets can be placed by inserting them on the floor plan or they can be also dropped in Live View
=> the program will define the elevation automatically.

You can also use the Drag Along Wall Method to place your cabinets in the correct position.
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How to Insert Cabinets: When you place a cabinet using the Cabinet Tool (Floor Tab, outlined
in green in the image below), you have two options to place the cabinets:
- If you place the cabinet by clicking on the floor of the room, Punch will set an island cabinet (pointed in
red in the image below).
- If you place the cabinet by clicking on the wall of the room (on the axis / center of the wall, not on the
surface of the wall), the program will set a wall cabinet using the selected Type (pointed with blue
arrows in the image below)

When you apply the cabinet, it is placed following the movements of your cursor. If you moved your
cursor to the opposite surface of the wall, just select it and drag it to the desired surface of the wall
(pointed with a blue arrow in the image below).
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Types of cabinets: the first button in the Properties tab allows the selection of the type of cabinet.
Cabinet 1 => top cabinet. Default elevation: 24.
Cabinet 2 => microwave top cabinet. Default elevation: 24.
Cabinet 3 => full cabinet. Default elevation: 0.
Cabinet 4 => double oven cabinet. Default elevation: 0.
Cabinet 5 => single oven cabinet. Default elevation: 0”.
Cabinet 6 => stacked refrigerator cabinet. Default elevation: 0”.
Cabinet 7 => side by side refrigerator cabinet. Default elevation: 0”.
Cabinet 8 => base cabinet. Default elevation: 0”.
Cabinet 9 => corner cabinet. Default elevation: 0”.
Cabinet 10 => angled corner base cabinet. Default elevation: 0”.
Cabinet 11 => angled corner top cabinet. Default elevation: 54”.
Cabinet 12 => oven range combo cabinet. Default elevation: 0”.
Cabinet 13=> base oven cabinet. Default elevation: 0”.
Cabinet 14 => base range cabinet. Default elevation: 0”.
Cabinet 15 => dishwasher cabinet. Default elevation: 0”.
Cabinet 16 => book shelf cabinet. Default elevation: 0”.

Note: the type of cabinet can be selected before or after the placement: this means that you can
select the type of cabinet first and place it after or, you can place the cabinet and (while the cabinet is
selected) you can select the type of cabinet.
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The Islands: the island is a special type of cabinet that is created when a cabinet is not placed on a wall.
Selecting the island and clicking on the first button allows the selection of 3 different types of islands:
Island Cabinet => Default elevation 0”.
Island Range Cabinet => Default elevation 0”.
Bartop Island cabinet => Default elevation 0”.

Customizing Cabinets
The parts of the cabinets: the second button in the Properties tab allows the definition of the cabinet’s
parts. The parts of the cabinet are related with the type of cabinet. For example: selecting the cabinet # 3
(outlined in blue in the image), the second button offers the following parts: top cabinet, top door, base
cabinet, base door, drawers, counter top and backsplash. By selecting each part, you can define the
dimensions and properties of the elements. These are the options:
Select Top Cabinet => Define the top cabinet dimensions => Define the elevation of the cabinet above the
counter => Define the addition of the selected number of shelves on the left and / or right sides.
Select Top Door => Define the number and dimensions of the top doors => Define a side offset (if
necessary) => Define the Facing Style => Define the hardware. Note: by default, the top cabinet has 2
doors. If you change the number of doors to 3, for example, the program will calculate the width of each
door automatically. But if, after this change, you decide to change to 1 door, you must enter the new
width manually.
Select Base Cabinet => Define the base cabinet dimensions => Define the Style Appearance: this option
will set the position of the chosen Style in the cabinet (for doors and drawers)
Select Base Door => Define the number and dimensions of the base doors => Define the Facing Style =>
Define the hardware and its placement =>Define if the doors are stacked or side by side => Define if the
base cabinet has doors or insets => Define a side offset (if necessary) => Define if the base cabinet has a
desk opening. Note: by default, the base cabinet has 2 doors. If you change the number of doors to 3, for
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example, the program will calculate the width of each door automatically. But if, after this change, you
decide to change to 1 door, you must enter the new width manually.
Select Drawers => Define the number and dimensions of the drawers => Define the Facing Style => Define
the hardware and its placement =>Define if the drawers are stacked or side by side => Define if the base
cabinet has drawers or insets => Define a side offset (if necessary). Note: by default, the base cabinet has
2 drawers. If you change the number of drawers to 3, for example, the program will calculate the width
of each drawer automatically. But if, after this change, you decide to change to 1 drawer, you must enter
the new width manually.
Select Countertop => Define the thickness => Define the overhangs.
Select Backsplash = Define dimensions => define the visible sides.
The styles of the cabinets: by clicking on the Facing Style button, the Style menu opens. There are 7
different styles, including a “No style” option. These options will be applied on the doors and drawers
panels that will be located in the position defined by the Style appearance. Note: in order to set the same
style for all the cabinets, the same style option must be selected for the top doors, base doors and
drawers.

The sinks: the sinks libraries are part of the Plumbing tools as well as the Furnishing library:
- Kitchen => Kitchen sink
- Bath => Lavatory sink.
Although the sinks are POBs, they have a special property: when they are placed on a cabinet counter,
they automatically create the hole for the sink. For this reason, the sinks are considered Components.
The program sets automatically the elevation of the sinks placed on the cabinets’ counters, however, in
some special situations it is recommended to set the elevation manually.
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If the sinks are applied from the plumbing tab, they will be attached to the walls. If the sinks are
applied from the Library tab, they can be placed as objects in 2D or 3D.
The hardware of the cabinets: the Hardware Library button (outlined in green in the image below) selects
the desired type of hardware: Pulls or Knobs. The Hardware style button (outlined in red in the image
below) opens the different models (pointed with a red arrow in the image below) of the selected type
(Pulls or Knobs). The position can be defined using the 4 arrows at the bottom (outlined in blue in the
image below).
Note: in order to set the same hardware for all the cabinets, the same type and model options must be
selected for the top doors, base doors and drawers. However, the positions of the hardware may be
different for each part (sides for the doors, center for drawers, etc.)

Questions about cabinets
Question 1: No matter what type of cabinet I select, my program always places an island?
Answer 1: If you select a cabinet and place the cabinet by clicking on the floor of a room, this cabinet will
be an island. If you place the cabinet by clicking on a wall, you can select one of the cabinet types.

Go To: find more information about How to Insert a Cabinet
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Question 2: I decided to change the type of cabinet. Should I delete the cabinet and place a new cabinet?
Answer 2: It is not necessary to delete the cabinet. Just select the cabinet and choose a new cabinet type
in the menu. The cabinet will change automatically.
Question 3: How do I delete a cabinet or any other component?
Answer 3: Select the Component => use the Delete key in your keyboard.
Question 4: How do I create a desk type cabinet? Can I set a door and a drawer on each end?
Answer 4: Create a cabinet => in this case, I started with a cabinet with 3 doors and 3 drawers as the one
pointed with a blue arrow in the image below. Select the cabinet (pointed with a red arrow in the image
below)=> go to the Base Cabinet section (outlined in magenta in the image below) => Check the option
“Has an opening”=> Select the desired Width => the cabinet will have an opening (pointed with green
arrow in the image below) => Set the Door and drawers according with your preferences.

In order to create an office desk, you can remove the backsplash.

Question 5: How do create a pantry cabinet?
Answer 5: Create a cabinet using the Book Shelf (last of the menu, pointed with a magenta arrow in the
image below) => Select the cabinet (pointed with a blue arrow in the image below) => Go to the Base Door
section (outlined in green in the image below) => uncheck the stack doors option (outlined in red in the
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image below) => uncheck the inset option (outlined in cyan in the image below) => Set the number of
doors as desired (usually 2 doors, outlined in black in the image below)

COLUMN TOOL
Location: Floor tab
Objective: The column tool is intended to create internal or external columns.
Elevation and height: the columns’ elevation is always referred to the level of the floor where they are
applied. The columns height is defined by the default height of the room, however the height can be
changed if necessary => the total height or the parts, considering that the sum of the Base + the Shaft +
the Cap will be always = the full height.
Insertion and Settings: The columns can be placed by inserting them on the floor plan => the program
will define the elevation automatically. The models and settings can be selected after the insertion. This
tool develops only square and round columns; therefore for the width you can only select one side or
the diameter.
Parts and dimensions: the columns have are 3 parts: Cap (top element), Shaft (central element) and Base
(lower element). After the column insertion, the first step is the setting or confirmation of the column’s
full height (that includes a drop down menu).
In the image below, the full height of the column is= 95”. As the sum of the Base + the Shaft + the Cap will
be always = the full height, if we change the height of the cap (5” in the image) and / or the base (6”in the
image), the program will calculate automatically the height of the shaft (84” in the image).
Each part (Cap, Shaft and Base) includes a menu with different models that can be combined.
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Questions about columns
Question 1: Can I apply color and materials on these columns?
Answer 1: yes, you can apply different colors or materials on each part (Cap, Shaft and Base) => the color
or material will be applied to the entire part, therefore you can’t paint just one of the sides
Question 2: Can I remove the cap and base?
Answer 2: you can’t remove the elements completely; however, you can set their heights to the minimum
(1/16”)
Question 3: Can you tell me the difference between the columns created with the Column tool and the
columns in the Furnishing library?
Answer 3: The columns created with the Column tool are Components and the columns in the 3D library
are POBs

ELECTRICAL TOOLS
Location: Electrical tab
Objective: The electrical tools are intended to furnish the necessary elements for an electrical plan.
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Elevation: the elevation of the electrical components depends of the type of insertion, and can be changed
as necessary
1-Wall attached components (such as phone outlets, for example): the elevation is always referred to the
base of the wall where they are inserted, independently of the elevation of the wall.
2-Floor components (such as floor receptacles, for example): by default, the elevation is the floor level.
3-Ceiling components (such as ceiling fans, for example): by default, the elevation is the ceiling level.
4-Detached components (such as a network router, for example): by default, the elevation is the floor
level.

Electrical Components and walls: the Electrical Component labeled as “wall” types (wall
receptacles, phone outlets, etc.) should be placed by clicking on a wall. These components will remain
always:
- Attached to the wall: this means that, for example, you can’t insert a wall receptacle on a cabinet
- Located in the Electrical tab: this means that, for example, you can’t move a switch to the Plumbing tab.
The remaining components (Floor, Ceiling and Detached Components) can be placed in any location of
the house and can be moved to another tab
The electrical categories (fixtures): there are several categories in the electrical tab, depending the
program. The elements are grouped by function. Note that not all the components are present in all the
programs. The subcategories can be accessed using the drop down menus.

Note: the Switch connector and the Conduit are just lines: they don’t appear in 3D and they are
not considered in the Estimator Power Tool.
Electrical Receptacle: this category includes 3 types of receptacles (see menu in the image).
Electrical Switches: (outlined in green in the image)
Ceiling Fans: (outlined in yellow in the image)
Phone and cable: phone and cable outlets (see menu in the image).
Smoke detector: ceiling unit (outlined in red in the image)
Thermostat: wall unit (outlined in black in the image)
Home Theater: this category includes components for TV, video and sound (see menu in the image).
Home Security: this category includes components for safety and protection (see menu in the image)
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Home Automation: this category includes different components such as automation touch panel, backup
generator, etc. (see menu in the image)

The electrical categories (lighting): there are 2 lighting categories in the electrical tab=> general light and
flood light (outlined in blue in the image above)
General lighting: this tool includes 11 subcategories (see image below)
1 - Recessed - Can light => for ceilings (includes fixture)
2 - Standard light => for ceilings (includes fixture)
3 - Recessed Up light => for floors (includes fixture)
4 - Heat Vent Light => for ceilings (includes fixture)
5 - Vent Light => for ceilings (includes fixture)
6 - Landscape Path Light => for floors (includes fixture)
7 - Landscape Light Up => for floors (includes fixture)
8 - Landscape Light Down=> for walls or columns (includes fixture)
9 - Point Light Up and Down => can be placed where necessary (no fixture)
10 - Point Up Light => can be placed where necessary (no fixture)
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11 - Point Down Light => can be placed where necessary (no fixture)

How to set electrical lighting?
The General Lighting components include a control panel (different for each component), allowing the
settings of the different elements.
Type of light: beam is a light directed to a point. Ambient is a general light in the room

Dimmer: controls the intensity of the light
Falloff: controls the quantity of light
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Glow: controls the shine of the light

Flood light: the separated light tool is the Flood light. This light is most used for exterior spaces, and
projects two light beams.
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Note that this is the only light component that is wall attached

The Photo Render Light Effects
The Photo Render light commands are at the bottom of the Properties tab.
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By default, the light’s color is white, as shown in the upper image. By clicking on the Color bar (outlined in
red in the image above) you can select the desired color for each light. In the image above, you see the
blue color selected and the blue light pointed by the blue arrow.
The projection of the shadows is optional, by selecting The Cast Shadow option (shadows are pointed by
the green arrow in the image above)

PLUMBING TOOLS
Location: Plumbing tab
Objective: The plumbing tools are intended to furnish the necessary elements for a plumbing plan.
Elevation: the elevation of the plumbing components depends of the type of insertion, and can be
changed as necessary.
1-Wall attached components (as the toilets, for example): the elevation is always referred to the base of
the wall where they are inserted, independently of the elevation of the wall.
2-Floor components (as the floor drain, for example): by default, the elevation is the level of the floor
3-Detached components (for example, the water heater): by default, the elevation is the level of the floor

Plumbing Components and walls: the Plumbing Component labeled as “wall” types (toilets,
showers, etc.) should be placed by clicking on a wall. These components will remain always:
- Attached to the wall: this means that, for example, you can’t attach a hose bib to a cabinet
- Located in the Plumbing tab: this means that, for example, you can’t move a toilet to the Deck tab.
The remaining components (Floor and Detached Components) can be placed in any location of the house
and can be moved to another tab

Placement of components: although the wall attached components are intended to follow the
rules above, some projects require special settings (for example a bath tub detached from the walls). In
these cases, the components can be dragged directly from the preview bar and placed in the workspace
or in the Live View window. In the image below, we can see the same bathtub placed as a component
attached to a wall (red arrow) or as an object (blue arrows)
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The plumbing tools: there are several categories in the plumbing tab, depending of the program. Note
that not all the components are present in all the programs.
Bibs: these are wall components that must be inserted by clicking on a wall. The program will set the
elevation automatically.
For the bibs, the 2 subcategories can be accessed using the drop down menu.

Drain: This is a floor component that can be placed by clicking on the desired location in the plan.
Toilets: this is a wall component that must be inserted by clicking on a wall or placed manually as an
object. There are several models of toilets and bidets that can be selected before or after the insertion.
These components can be resized or flipped using the Properties tab (right of the screen). The toilets and
bidets follow the Placement of Components rules. The toilets libraries are part of the Plumbing tools as
well as the Furnishing library.

If toilets are applied from the plumbing tab, they will be attached to the walls. If the toilets are
applied from the Library tab, they can be placed in 2D or 3D.
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Sinks: this is a wall component that must be inserted by clicking on a wall. There are several models of
sinks that can be selected before or after the insertion. These components can be resized or flipped using
the Properties tab (right of the screen).

Important: How to place a sink? in order to place a sink (kitchen or bathroom) there are 4
different situations that may happen. See image below.
1 Using the Sink tool (Plumbing tab) to place a sink on a cabinet generated with the Cabinet tool. In this
unique case (green arrow), the sink will be a component with 2 properties: it will create the hole in the
counter, and it will be attached to the wall. The program will set the elevation automatically. In order to
move the sink to the front of the cabinet to center it, you can modify the offset distance.
2 Dragging and dropping a sink from the Furnishing library (outlined in red) on a cabinet – object (POB).
In this case, the sink will be also a POB and it will not create the hole in the counter (for under counter
sinks); however, it can be used for vessel sinks. The elevation must be set manually.
3 (Recommended) Dragging and dropping a sink from the Furnishing library (outlined in red) on a cabinet
generated with the Cabinet tool. In this case, the sink will be a component; therefore it will create the
hole in the counter. The program will set the elevation automatically.
4 Dragging and dropping a sink from the Furnishing library (outlined in red) and placed in the desired
location in the plan. In this case, the sink will be a simple POB without any special property. The elevation
must be set manually.
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Showers and Tubs: these are wall component that must be inserted by clicking on a wall or placed
manually as objects. There are several models of showers and tubs that can be selected before or after
the insertion. These components can be resized or flipped using the Properties tab (right of the screen).
The showers and tubs follow the Placement of Components rules. The showers and tubs libraries are part
of the Plumbing tools as well as the Furnishing library.

If the showers and tubs are applied from the plumbing tab, they will be attached to the walls.
If the showers and tubs are applied from the Library tab, they can be placed as POB in 2D or 3D.
Water Heater: This is a detached component that can be placed by clicking on the desired location in the
plan. By default, the elevation is the level of the floor but it can be customized.

HVAC TOOLS
Location: HVAC tab
Objective: The HVAC tools are intended to furnish the necessary elements for a heating, ventilation, and
air conditioning plan.
Elevation: the elevation of the HVAC components depends of the type of insertion, and can be changed
as necessary.
1-Wall attached components (such as baseboard heaters, for example): the elevation is always referred
to the base of the wall where they are inserted, independently of the elevation of the wall.
2-Floor components (such as floor registers, for example): by default, the elevation is the level of the floor.
3-Ceiling components (such as ceiling registers, for example): by default, the elevation is the ceiling level.
4-Detached components (such as the Heat Pump, for example): by default, the elevation is the floor level.

HVAC Components and walls: the HVAC Component labeled as “wall” types (wall registers,
baseboard heaters, etc.) should be placed by clicking on a wall. These components will remain always:
- Attached to the wall: this means that, for example, you can’t attach a wall return to a cabinet.
- Located in the HVAC tab: this means that, for example, you can’t move a wall return to the Deck tab.
The remaining components (Floor, Ceiling and Detached Components) can be placed in any location of
the house and can be moved to another tab.

Some HVAC components follow the placement of components rules. These components are
part of the HVAC Tools as well as the Furnishing library.
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If they are applied from the HVAC tab, they will be attached to the walls. If they are applied from the
Library tab, they can be placed as POBs in 2D or 3D.
The HVAC categories: there are several categories in the HVAC tab, depending the program. Note that
not all the components are present in all the programs.
For the registers and the AC /pump, the subcategories can be accessed using the drop down menu.

Air Ducts: the elements created with this tool will appear in the floor plan and the Bill of Materials
(Estimator Power Tool); however the Air Ducts are not visible in Live View. As they are 2D elements, the
elevation is not important.
Registers: this category includes 3 types of registers (see menu in the image).
Furnace, Air Conditioner and Heat Pump: These are detached components that can be placed by clicking
on the desired location in the plan. By default, the elevation is the floor level but it can be customized
Heater / Radiator: this is a wall component that must be inserted by clicking on a wall. By default, the
elevation is the level of the floor but it can be customized.

2D SYMBOLS
The 2D symbols are located in the Library tab => 2D Symbol library. The library includes several categories.
In order to insert the symbols, just drag and drop the desired element on the floor plan.
The 2D symbols are intended to provide additional information in the floor plan, like construction details,
position of the cross section, etc. They are drawings without any specific property and don’t appear in 3D.
In order to import or create new symbols or modify the current symbols, you can use the Section Detailer
Power Tool or the Symbol Editor Power Tool (if these tools are included in your program).
Otherwise, you can create basic lines and shapes using the elements in the Detail Tab or you can import
DXF or DWG files using File => Import => DXF / DWG File.

Go To: find more Information about Importing DXF / DWG files
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If you wish to change the symbol in the workspace (without power tools), after you insert the 2D symbol
=> right click => Ungroup / Explode Symbol => using this feature, you will be able to select and edit the
lines, points and texts separately.
Also, note that the 2D symbol can be customized using the Draw Style tools.
- If you insert a symbol in the workspace, you will be able to change the color of all the lines (pointed with
a brown arrow in the image below) as well as the color of the text (pointed with a cyan arrow in the image
below).
- If you insert a symbol in the workspace and you use Ungroup / Explode Symbol, you will be able to
change the color and type of each line individually (pointed with a red arrow in the image below) as well
as the color of the text (pointed with a blue arrow in the image below).

Question about Symbols and Objects
Question 1: Can I import a DWG 2D symbol of an appliance and Convert To a 3D object (POB)?
Answer 1: The imported 2D DXF / DWG files can be used only as 2D symbol or to import a floor plan and
develop a Punch file.
Question 2: How can I search a Symbol in the libraries?
Answer2: Use the Search field at the bottom of the Library tab menu.
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The Punch! Software (R) programs include several helpful settings tools and drawing resources.
SETTINGS
The settings are defined using the Preferences Menu, the Options Menu and the Screen Buttons.
Preferences Menu
The programs have a Preferences Menu (Main Menu => Edit => Preferences) that include several settings
that allow the customization of the program use.
Undo
Location: Main Menu => Edit => Undo Preferences. Also Main Menu => Edit => Preferences => Undo
Preferences.
Definition: specification of the number of instances for the Undo feature (up to 50 levels) or deactivate.
Default settings: 25 levels, up to 50 levels.
Importance: the program uses this setting for restore and recovery.
Results of incorrect settings: the Undo feature increases the rendering time. However, deactivating the
Undo feature also deactivates the Auto recovery feature (in the event of a power failure, for example).
User Interface
Location: Main Menu => Edit => Preferences => User Interface.
Definition: customization of several interface’s options.
Importance: according to your necessities and preferences.
Preferences => User Interface => Startup
- Show Welcome Screen: this menu allows the initial management of the program, directing the user to
the main program, sample plans, etc.
- Start in Quick Start: option to start a project using Quick Start or going directly to the Main Program
- Automatically Check for Updates: you can choose to automatically check for updates as the program
begins. I strongly recommend to keep this option checked in order to avoid maintenance issues.
Preferences => User Interface => Toolbar Options (outlined in magenta in the image).
- Auto display Properties tab on Selection: if an element or component is selected, the Properties tab is
activated, showing the properties of the selected element or component. It is located at the right of the
screen (green arrow in the image).
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- Show Plant Inventory Bar: you can show or hide the Plant Inventory Bar (blue arrow in the image).
- Show Modify Toolbar: you can show or hide the Modify Toolbar (black arrow in the image).
- Show Decorator Palette: you can show or hide the Decorator Palette (red arrow in the image).
- Show Quick Palette: you can show or hide the Quick Palette that is located at the right of the screen.
Preferences => User Interface => Tool Tip Options (outlined in yellow in the image)
- Show / Hide the description of the different items in the design.
- Show / Hide Advanced Tool Tips: the advanced tips appear when the tools are selected in the different
tabs. You can hide these pop ups or delay them up to 3 seconds

Preferences => User Interface => Color Scheme
This feature (outlined in blue in the image below) has 3 options for the customization of the colors of the
program’s User Interface.
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Design colors
Location: Main Menu => Edit => Preferences => Design Colors or => Main Menu => 2D => Screen colors.
Definition: Customization of several of the program’s interface colors => by clicking inside of the color
boxes you can choose the desired color for each feature.
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Note that these colors are just for the listed program general features => tabs and individual
elements are managed with the Draw Style Tools.
Default settings: Default colors
Importance: according to your necessities and preferences.
Results of incorrect settings: the different colors for the different elements allows a better visualization
and understanding of the plans.
Auto Snap Options / Settings
Location: Main Menu => Edit => Preferences => Snap Settings or => Main Menu => 2D =>AutoSnap
options
Definition: a drawing help tool that marks specific points and aligns the segments.
Default settings: all the options are ON
Importance: allows more precision in the drawing.

Note that, for snapping purposes, the Laser Alignment detects the wall surface.
Preferences => System
This panel features a slider that allows the user to select one of three video card acceleration options.
This can be used to solve several display issues as stated in this question.
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The Full Acceleration position delivers a fast rendering process that sometimes create rendering errors
(textures going to the sky, black screens, etc.). The Low Acceleration position delivers a slow rendering
process, however, it solves several display issues. The middle position balances performance and speed.

In addition, you can use the Enable 2D Anti-aliasing option to avoid distortions in the 2D screen.
Options Menu
To open this menu, go to => Main Menu => Design => Options
Design Options => Design
General
Plant Growth Projection
Location: Main Menu => Design => Plant Growth Projection. Also in Main Menu => Design => Options =>
General => Plant Growth Projection.
Definition: defines the time span for the plant development.
Default settings: 18 years.
Importance: according to your necessities and preferences.
Results of incorrect settings: inconsistencies among the plants.
Auto-Generate Quick Start Roof
Location: Main Menu => Design => Options => General.
Definition: you can activate or deactivate the Auto Roof feature, as well as specify the roof settings for
the Quick Start stage.
Note that this option activates the roof only in the Quick Start feature.
Importance: according to your necessities and preferences.
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Plan Scale
Location: Main Menu => Design =>Plan Scale. Also in Main Menu => Design => Options => Design => Plan
Scale.
Definition: defines the current drawing scale.
Default settings: 1/4”= 1’
Importance: according to your necessities and preferences.
Options (English Units):

Options (Metric Units):

Results of incorrect settings: inconsistencies if other files are imported using different scales
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Unit of Measure
Location: Main Menu => Design => Unit of Measure. Also Main Menu => Design => Options => Design =>
Unit of Measure.
Definition: defines the measurement units and precision, for the current file as well as new plans.
Default settings: By default, the program determines the Unit of Measure based on the user's computer
location and settings, using the following forms:
English Units – Ft-in – Precision 1/16”
Metric Units – X.XXXX m
These default units can be changed in the Unit of Measure menu
Importance: according with your necessities and preferences.
Options: English Units

Options: Metric Units

Results of incorrect settings: the units must be easily readable, allowing a fast visualization and printing.
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Lot Properties
Lot Size
Location: Main Menu => Design => Lot properties => Lot Size. Also Main Menu => Design => Options =>
Design => Lot properties => Lot Size.
Definition: this setting defines the size of the workspace.

Notice for this setting: the lot size defined in this option is not necessarily related with the size
or shape of your property or the size of the printing paper. See Lot and Workspace
Default settings: 200 x 200 Ft
Importance: the program uses this setting for workspace management.
Results of incorrect settings: if the workspace is small and your property is large, the trace image or
imported file won’t fit in the workspace. However, keep in mind that a large workspace takes more
rendering time.
Topography Generation
Location: Main Menu => Design => Lot properties. Also Main Menu => Design => Options => Design =>
Lot properties.
Definition: these settings define the size of the patch resolution and the rendering quality
Default settings: patch= 36”x36”- Quality= 4
Importance: the program uses this setting for topography accuracy and definition.
Results of incorrect settings: unbalanced specifications / equipment situations create quality issues.
Note that small patches and better quality require more rendering time.

Lot Properties – The Lot and the Workspace
This is an important concept: “The Lot” specified in the Main Menu => Design => Lot properties is referred
to the Workspace, the big square that constitutes the program “world”. The workspace doesn’t mean your
property that you can define using the Property Line (Landscape tab), therefore you can insert your
property in the workspace, as shown in the image below.
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Floor Plan Trace Properties
Location: Main Menu => Design => Floor Plan Trace Properties. Also in Main Menu => Design => Options
=> Floor Plan Trace Properties.
Definition: defines the settings to use the Trace Tool feature.
Default settings: 100%
Importance: according to your necessities and preferences.
Results of incorrect settings: inconsistencies between the dimensions of the imported file and the
dimensions of the Punch file.

Go To: find more information about Importing and Tracing Floor Plans.
Design Options => 2D Options
General
Show Topography Lines
Location: Main Menu => 2D => Show topography lines. Also in Main Menu => Design => Options => 2D
Options => Show topography lines
Definition: a drawing guide to visualize the topography lines if the Landscape tab is visible.
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Default settings: the lines are visible
Importance: allows more precision in the drawing.
Results of incorrect settings: additional work to create exterior spaces
Show Virtual Ruler
Location: Main Menu => 2D => Show Virtual Ruler. Also in Main Menu => Design => Options => 2D Options
=> Show Virtual Ruler.
Definition: a drawing help tool that allows taking measurements in the screen.
Default settings: 144”= 12’, but can be adjusted

Importance: according to your necessities and preferences.
Grid Properties – Grid Visible – Snap to Grid
Location: Main Menu => 2D => Grid Properties – Grid Visible – Snap to Grid. Also in Main Menu => Design
=> Options => 2D Options => Grid Settings
Definition: an interface option presents a gridded background with lines or points that can be used as a
drawing guide. The type of guide is defined in the Grid Style section. The space between the lines or points
is defined in the Grid Spacing section. The Snap Grid defines the interval in the movements using the
arrows of the keyboard. Example: in the picture below, the Snap grid is set as 1”=> we see a table selected
in the living room=> if we move the table using the arrows in the keyboard, each click will move the object
1”in the desired direction

Default settings: the grid is visible
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Importance: a good drawing help.
Results of incorrect settings: additional work to trace the walls, floors, etc.
Dimensioning and Fonts
Automatic Dimensions – Automatic Fonts – Arrowhead Styles
Location: Main Menu => Design => Options => 2D Options =>Dimensioning and Fonts => Also Main Menu
=> 2D =>Dimensioning and Fonts.

Definition: defines the default font type and size for different features as well as arrowheads.
Default settings: Arial – Italic – 10

Note that dimensions’ colors are defined in the Design Colors section.
Importance: according to your necessities and preferences.
Options (Fonts): there are 4 different fonts settings: for Automatic Dimensioning, Room Labeling, Text
Object and Leader Dimension. In addition, you can choose to show / hide the unit indicator (feet, meters,
etc.).
Options (Arrowheads): there are 7 different arrowheads settings.
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Results of incorrect settings: the elements must be easily readable, allowing a fast visualization and
printing.
Dimensions Properties
Location: Main Menu => Design => Options => 2D Options =>Dimensioning and Fonts => Also Main Menu
=> 2D =>Dimensioning and Fonts.
Definition: customization of the dimensions’ settings and visibility.

Default settings: all the options are ON
Importance: customization of the drawing settings.
Results of incorrect settings: a clear definition of the dimensions allows a fast visualization and
understanding of the plans.
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3D Preferences

Go To: find the settings and information about the 3D Preferences

On Screen Buttons
Working Elevation
Location: Located in the Elevation bar. Also in Menu => Design =>Set Working Elevation.
Definition: defines the current drawing elevation, independently of the floor level.
Default settings: elevation of the floor level
Importance: the program uses this setting for elevation management.
Results of incorrect settings: problems with the elevation levels generate an inaccurate 3D model, as
explained
Default Heights
Location: use the Floor Button => define the heights in the New Project screen
Definition: the Default Height measures the distance between the floor level in one floor and the floor
level in the upper floor, or in other words, the distance between two floors.
Default settings: 108” for each level.
Importance: the program uses this setting for elevation management.
Results of incorrect settings: Example: you draw the walls of the first floor with height= 120”, expecting
to set the elevations of the walls of the second floor at 120”=> if the Default Height for the first floor is=
96” ,the program will set the elevation second floor at 96”.
Work on Floor
Location: Use the Working Floor Button. Also: Main Menu => Design => Work on Floor.

Definition: defines the current drawing level (Active Floor) as well as the visible floors.
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Default settings: First floor
Importance: according to your necessities and preferences.
Results of incorrect settings: confusing location of the elements
Elevation Bar
Location: Top of the working space.
Options: 2 options => Working Elevation and Object Elevation
Use: Select the area / object => write the desired Elevation => click Enter

Elevation Settings / Object Elevation
Location: Main Menu => Edit => Set Object elevation => the elevation menu will open. Also, the elevation
menu can be opened by right clicking an object. The bar is activated by selecting an object in the plan.
Options: 2 options
Option 1 => Object Elevation by Elevation bar. The Object Elevation bar (outlined in green) is activated
when an element is selected in the plan. The drop down menu shows additional preset elevations.

Option 2 => Object Elevation by Set Elevation Menu. The Set Elevation menu (outlined in blue) is activated
by right clicking on an element in the plan or in the Main Menu => Edit => Set Object elevation. Also, you
can open the menu by selecting the last option of the drop down menu of the Elevation bar. In this menu,
you can define a new elevation, use one of the preset elevations or float the element above topography.
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Use: Select the option in the menu or select an object in the plan => the elevation menu will open => write
the desired Elevation => click OK, or select one of the preset options.

Workspace Tools
Expanded Edit toolbar
Location: this toolbar is located at the left of the screen and includes different types of tools, depending
of the program.
The tools on the top (outlined in red) are Editing Tools. The tools below (outlined in blue) are Text and
Dimensions Tools.
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Editing Tools

Arrow
Location: first icon of the Expanded Edit Toolbar.
Use: Select the tool => use this tool to select and move any element (entire element or a point) in the
floor plan. Selecting while you press the Shift key in your keyboard adds all the selected elements. Also, it
can be used to apply the Drag Along the Wall Method.

What is the Drag Along the Wall Method?: when you place a wall attached component like
interior cabinets or a wall attached electrical component, or a window, for example, you have the option
of moving these elements along the wall using the mouse (independently of the final location of the
element). This is useful to define the components before you stack them.

Resize Segment
Location: second icon of the Expanded Edit Toolbar.
Use: Select the tool => select any segment of the constructive elements in the floor plan (wall, floor, deck,
etc.) => write the new length => OK

Rotate
Location: third icon of the Expanded Edit Toolbar. Also, this tool is part of the Edit Menu (Main Menu).
Use: there are 4 options
- Option 1: Select the entire element => double click on the tool => write the desired angle => OK.
- Option 2: Select the entire element => click on the tool => Press Shift and use the arrow keys to the right
/ left direction.
- Option 3: Select the entire element => Main Menu => Edit => Rotate=> write the desired angle => OK.
- Option 4: Select the entire element => click on the tool => select one of the object’s handles (yellow
points) => manually rotate the object

Tip: (-) angles rotate clockwise (+) angles rotate counterclockwise

Add Point
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Location: fourth icon of the Expanded Edit Toolbar.
Use: Select the tool => click on the segment where you wish to add the point (floor, deck, etc.). The points
can be added also in curves.

Delete Point
Location: fifth icon of the Expanded Edit Toolbar.
Use: Select the tool => click on the segment where you wish to delete the point (floor, deck, etc.). The
points can be deleted also in curves.

Fillet Corner
Location: sixth icon of the Expanded Edit Toolbar.
Options: 2 options => Curve Inwards – Curve Outwards
Use: Curve Outwards => Select the tool => select a corner point of a deck, floor, etc. (blue arrow) => drag
the point to the interior of the area (red arrow). To set the Curve Inwards, follow the same steps while
you press the “Shift” key.

Chamfer Corner
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Location: seventh icon of the Expanded Edit Toolbar.
Use: Select the tool => select a corner point of a deck, floor, etc. (blue arrow) => drag the point to the
interior of the area (red arrow).

Visual Array
Location: eighth icon of the Expanded Edit Toolbar.
Use: this tool can be used to set a line of elements (plants, for example) with the same distance between
the elements. For example => Select a plant => Select the tool => click on the workspace (blue arrow) =>
In the Properties tab , write the distance between the plants or the distances on centers (outlined in red)
=> Press Enter => => trace the line => the plants will appear in red => click on the workspace and release
the mouse (green arrow) => the plants will appear with the tab color

Text and Dimensions Tools
Text Tools
Location: nine icon in the Expanded Edit Toolbar
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Options: You can choose the different fonts, size, characteristics, alignment and angle.
Use: Select the tool => Click on the desired place of the Workspace => write the text => the text box will
be place in the selected location.

Manual Dimensions Tools
Location: the icons for these tools start below the Text Tools in the Expanded Edit Toolbar
Options: 6 options, depending of the program (see picture below):

Note: These dimensions are tools intended to provide measurements in addition of the
automatic features. The settings are as defined in the Automatic Dimensions section.
- Dimension Wall Spacing: (green arrow) measures the distance between 2 walls => settings can be
internal or to centers.
- Zero Offset Dimension: (yellow arrow) measures the distance between 2 points of an element: the
distance between the element measured and the dimension line (called offset) is always = zero.
- Offset Dimension: (black arrow) measures the distance between 2 points of an element: the distance
between the element measured and the dimension line (called offset) can be customized as necessary.
- Length dimension: (red arrow) measures the distance between 2 points at any point of the workspace:
the distance between the element measured and the dimension line (called offset) can be customized as
necessary. In addition, this tool measures dimensions in any angle.
- Diameter dimension: (blue arrow) measures the diameter of a circle (not ovals) by dragging the cursor
on the perimeter.
- Leader Dimension (brown arrow): this tool generates an arrow that can be used to define a dimension
a reference or just to add a text.
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ProjecTape
Location: last icon of the Expanded Edit Toolbar.
Use: Select the tool => set a point => you can visualize the distances to the next elements. In order to
delete the ProjecTape (on screen) use => Edit => Clear.

Properties Tab
Location: Right of the screen.
Options: 2 options => by workspace settings or by element selected
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Use: Workspace settings: when there are no elements selected, the Workspace settings options appear
in the Properties tab (outlined in red) => Snaps, grid, display dims and callouts can be set in this screen.
In addition, the visible tabs in the active tab can be selected. In this case, we can see the visible tabs in the
Floor tab (outlined in blue).

Use: Element selected: when any element is selected in the screen (a constructive element like a wall, a
POB or a Component, for example) the Properties tab is activated, showing all the customizable options.
For example, if we select a wall (green arrow), we can customize the geometry, thickness, etc.
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Note: in the Properties tab, some settings are fields to fill with your custom information
(outlined in blue in the image) => in order to change the value => each time you write new information =>
press Enter so the information takes effect => otherwise, the value will return to the default value.

Workspace Navigation Tools

Zoom
Location: first icon of the Zoom and Pan bar (left top corner).
Use: there are 3 options:
- Option 1: Select the tool => click on the screen with the left button of the mouse=> drag the mouse up
for Zoom In => drag the mouse down for Zoom out
- Option 2: Scroll the mouse wheel => up for Zoom In => down for Zoom out
- Option 3: Main Menu => 2D => Set Zoom

Pan
Location: second icon of the Zoom and Pan bar (left top corner).
Use: there are 2 options
- Option 1: Select the tool => click and hold on the screen with the left button of the mouse => move in
the desired direction to pan the screen
- Option 2: click and drag the middle button of your mouse

…Modify Toolbar
The Modify Toolbar is composed by 5 different groups composed by several icons, according with their
functions. These tools are also included in the Edit Menu / 2D Menu.
Align Tools

Includes 7 tools => Align to the left, Align to the vertical center, Align to the right, Align to the center,
Align to the top, Align to the horizontal center, and Align to the bottom.
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The toolbar icons show the objects’ position for each option (in blue), with respect to the red lines.
Distribute Tools

Includes 8 tools => Distribute Horizontal Left, Distribute Horizontal Center, Distribute Horizontal Right,
Horizontal Spacing Distribution, Distribute Vertical Top, Distribute Vertical Center, Distribute Vertical
Bottom, Vertical Spacing Distribution.

Note that, when you click on the Horizontal Spacing Distribution as well as the Vertical
Spacing Distribution icons, a small screen will open => this is the Gap Distribute panel (as shown in the
image below), where you should input the desired Gap distance between the distributed elements.

The toolbar icons show the objects’ position for each option (in blue), with respect to the red lines.
Match Size Tools

Includes 3 tools: Make Same Width As Last Item Selected, Make Same Depth As Last Item Selected, and
Make Same Size As Last Item Selected.
The toolbar icons show the objects resizing for each option, following the red arrows.
Duplicate, Flip and Mirror Tools

Includes 5 tools: Duplicate, Flip Horizontal, Flip Vertical, Mirror Horizontal, and Mirror Vertical.

Note that, when you click on the Duplicate icon, a small screen will open => this is the
Duplicate Offset panel (as shown in the image below), where you should input the desired offset
distances (vertical and horizontal, outlined in green in the image below) as well as the number of
repetitions (outlined in red in the image below)
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The Flip Tools and Mirror Tools are described in the Edit Section.
Screen Fit Tools

Includes 3 tools: Reset 2D View (resets all the previous screen settings), Fit To Window (all the items in
the workspace fit in the screen), and Fit to Selected (all the selected items fit in the screen).

Edit Menu Tools
To access the tools, go to Main Menu => Edit.
Duplicate
Settings and information according with this section.
Nudge Tool
Location: Main Menu => Edit => Nudge
Use: Select the elements => Select the tool => the element will move in the desired direction the distance
specified in the Snap to Grid settings.
Move Tool
Location: Main Menu => Edit => Move
Use: Select the elements => Select the tool => select the distance and direction => the element will move
following the distance and direction.
Rotate Tool
Settings and information according to this section.
Flip Tool
Location: Main Menu => Edit =>Flip.
Use: Select the elements => use the tool to flip the elements horizontally or vertically.
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Mirror Tool
Location: Main Menu => Edit =>Mirror.
Use: Select the elements => use the tool to mirror the elements horizontally or vertically.

Match Size
Settings and information according with this section.
Align to Grid
Location: Main Menu => Edit =>Align to Grid.
Use: using this tool, the objects can be aligned to the closer gridline, in the desired direction.
Align Objects
Settings and information according with this section.
Distribute Objects
Settings and information according with this section.
Draw Order
Settings and information according with this section.
Float Object Above Topography
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By selecting this tool and applying to an object, it will change the elevation settings for the element. The
objects won’t follow the floor elevation => they will follow the topography surfaces.
Adjust Entire Floor Elevation
This tool changes the elevation of the entire floor of a project.

Note that, when you select this option, a small screen will open => this is the Adjust Floor
Elevation panel (as shown in the image below), where you should input the desired new elevation
(outlined in red in the image below).

All the elements in the floor featuring specific elevations will be adjusted.
Copy to Floor Tool
Location: Main Menu => Edit => Copy to Floor
Use: Select the elements => select the tool => select the floor => use the tool to copy the desired elements
to the desired floor. Example: you can select the walls in the perimeter of the first floor of the house and
copy these walls on the second floor

Note: before you copy or move the elements vertically, review the required vertical settings
for these tools
Move to Floor Tool
Location: Main Menu => Edit => Move to Floor
Use: Select the elements => select the tool => select the floor => use the tool to move the desired
elements to the desired floor. Example: you can select the walls in the perimeter of the first floor of the
house and move these walls on the second floor.
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Move to Plan Tool
Location: Main Menu => Edit => Move to Plan
Use: Select the elements => select the tool => select the tab (Deck, Detail, etc.) => use the tool to move
the desired elements to the desired tab. Example: you can select the exterior furniture that you placed in
the Floor Tab and move it to the Landscape tab.

Note: remember the tab limitations regarding the walls with attachments and linked tabs
Move Entire Plan Tool
Location: Main Menu => Edit => Move entire plan
Use: Select the tool => specify the distance / direction=> use the tool to move the entire project to a
specified point in the workspace.
Rotate Entire Plan Tool
Location: Main Menu => Edit => Rotate entire plan
Use: Select the tool => specify the angle => use the tool to rotate the entire project using a specified
angle.
Flip Entire Plan Tool
Location: Main Menu => Edit => Flip entire plan
Use: Select the tool => specify direction=> use the tool to flip the entire project using a specified direction.

Design Menu Tools
Set Working Elevation
Location: Main Menu => Design => Set Working Elevation.
Definition: As defined in the Working Elevation section.
Plan Scale
Location: Main Menu => Design => Plan Scale. Also in Main Menu => Design => Options.
Definition: As defined in the Plan Scale section.
Unit of Measurement
Location: Main Menu => Design => Unit of Measurement. Also in Main Menu => Design => Options.
Definition: As defined in the Unit of Measurement section.
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Update Topography Grid
Location: Main Menu => Design => Update Topography Grid.
Definition: a complicated topography takes a long time to render and consumes computer resources. To
reduce the elaboration time => create the topography or make the changes in 2D and use this tool before
you go to Live View
Work on Plan
Location: Main Menu => Design =>Work on Plan
Definition: defines the current drawing tab.
Default settings: Floor tab
Importance: according to your necessities and preferences.
Results of incorrect settings: confusing location of the elements
Work on Floor
Location: Main Menu => Design => Work on Floor.
Definition: As defined in the Working Floor section.
Active Floor Area
Location: Main Menu => Design => Active Floor Area
Definition: informs the floor area of the active drawing level (the area appears in the status bar, outlined
in red in the image).

Default settings: First floor
Importance: according to your necessities and preferences.
Results of incorrect settings: inaccurate information.
Plant Grow Projection
Location: Main Menu => Design => Plant Grow Projection. Also in Main Menu => Design => Options.

SETTINGS, TOOLS AND DRAWING RESOURCES

- 201 -

Definition: As defined in the Plant Grow Projection section.
Show Plant Inventory Bar
Location: Main Menu => Design => Show plant bar. Also in the Preferences menu => User interface
Definition: an interface option, showing a lower bar with all the plants used in the project.
Default settings: the bar is hidden
Importance: allows the view and fast selection of the plants.
Results of incorrect settings: additional work to select and set the plants.
Show Floor Plan Trace Image
Location: Main Menu => Design => Show Floor Plan Trace Image.
Definition: Use this option to show / hide the Floor Plan Trace Image
Floor Plan Trace Properties
Location: Main Menu => Design => Floor Plan Trace Properties.
Definition: As defined in the Floor Plan Trace Properties section

2D Menu Tools
…Reset 2D View
Location: Main Menu => 2D => Reset 2D View.
Definition: resets the view to default
Set Zoom
Location: Main Menu => 2D => Set Zoom.
Definition: an interface option, defines the size of the elements in the screen.
Default settings: 75%
Importance: according to your necessities and preferences.
Results of incorrect settings: balance an accurate view with a full view
Fit to Window
Location: Main Menu => 2D => Fit to Windows.
Definition: an interface option => all the elements on the workspace fit in the screen.
Default settings: 75%
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Importance: according to your necessities and preferences.
Results of incorrect settings: balance an accurate view with a full view
Fit to Selected
Location: Main Menu => 2D => Fit to Selected.
Definition: an interface option => create a shape outlining the desired elements on the workspace=>
select the outline => the outline will fit the screen.
Default settings: 75%
Importance: according to your necessities and preferences.
Results of incorrect settings: balance an accurate view with a full view
Visible Floors
Location: Main Menu => 2D => Visible Floors. Also, by clicking the drop down option in the Working Floor
Button
Definition: an interface option, defines the visible levels on the workspace.
Default settings: View all floors

Importance: according to your necessities and preferences.
Results of incorrect settings: confusing view of the plans.
Grid Controls
Location: Main Menu => 2D => Grid Properties / Grid Visible / Snap to Grid.
Definition: As defined in the Grid Properties / Grid Visible / Snap to Grid sections
AutoSnap Options
Location: Main Menu => 2D => Autosnap Options.
Definition: As defined in the Autosnap section
Selection Filter
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Location: Main Menu => 2D => Selection Filter
Definition: an interface option => allows the preferential selection of one or more layers.
Default settings: none selected
Importance: according to your necessities and preferences.
Dimension Settings
Location: Main Menu => 2D => Dimensioning & Fonts / Automatic Dimensioning / Windows/Doors
Callouts / Cursor Dimensions.
Definition: settings and options as defined in the Dimensioning and Fonts section
Show Topography Lines
Location: Main Menu => 2D => Show Topography Lines
Definition: As defined in the Show Topography Lines section
Show Virtual Ruler
Location: Main Menu => 2D => Show Virtual Ruler
Definition: As defined in the Show Virtual Ruler section.

Recommendation: I strongly recommend adjusting the settings and becoming familiar with the
tools before you start a new project.

Return to Table of Contents
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The Punch! Software (R) programs have different libraries for objects, materials, trims, etc. Let’s explore
the access and organization of the libraries.
Libraries - Definitions
- Library tab: this tab contains the different libraries and it is located at the right of the Properties tab
(green outline in the image below).
- Library: collection of related components or elements used to complete or enhance a project. The
libraries are grouped by type of component. There are 9 libraries (not all the libraries are present in all the
programs): 2D Symbols, 3D effects, Furnishing, Materials, Paint Colors, Plants, Templates, Trim, Wall
Accessories and Plant Symbols. The libraries menu can be accessed by clicking the libraries button (blue
arrow and outline in the images below).

- Category: (green arrow in the image below) => main title of a certain library that defines the contents of
the entire group of elements.
- Subcategory: (magenta arrow in the image below) => secondary title of a certain library that defines the
contents of a partial group of elements.
- Preview Bar: (aqua arrow in the image below) => set of thumbnails showing the contents of a library.
- Search field: (gray arrow in the image below) => by writing a name or characteristic in this field, the
program performs a search in the current library and shows the results in the Preview Bar.
- Type of Library Bar: (pointed by the black arrow in the image below) => shows the four types of libraries,
defined by the type of access:
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- Stock Library => (orange arrow in the image below) => it is the library shipped with the
program. The elements in this library cannot be renamed, resized or edited, however, they can be copied
to the User Library.
- User Library => (red arrow in the image below) => this library is composed by the elements
copied from the Stock Library or created with 3D Custom Workshop Power Tool as well as the imported
elements. The elements in this library can be renamed, resized and edited.
- Download Library => (pink arrow in the image below) => this library is composed by packages
provided by Punch Software (R).
- Favorites Library => (brown arrow in the image below) => by clicking on the star close to each
element of the library, the element is copied to this library that will group the user’s favorite elements.

Options button (gear wheel): this button is present at the bottom - left of a few of the libraries’ menu =>
the button is active when the menu presents options.
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Libraries Access and Organization
Access
The libraries menu can be accessed by clicking the libraries button (blue arrow and outline in the image).
The image above shows the access to the Furnishing library of the Stock Library.
By clicking on the small triangle on the right of the first item (Accessories), the Categories Menu opens
and the Categories can be selected (pointed in green in the image above). By clicking on the “+” sign on
the left of the Categories name, the Subcategories open and they can be selected (pointed in magenta
in the image below). Note that the Subcategories may include several sublevels. The contents of the
specific library is shown as thumbnails in the Preview Bar (pointed in red in the image above).

Important Note: the Categories and Subcategories can be created / added also using
Windows Explorer. You can also add, delete, or copy elements within Windows Explorer.
Organization
The different libraries are organized in the Library tab (outlined in brown in the image below). By
default, the libraries show the Stock Library. By right clicking any element we have two options:
- Add to Favorites: this option copies the element to the Favorites library.
- Copy to User Library: (outlined in blue in the image below) this option copies the element (the “Aoede
- Hand towel bar” in the example) to the User Library => in this case, the Copy to Library menu will open
(outlined in magenta in the image below) => the library locator shows the current Categories and
Subcategories in the User Library. If you wish to start a new location, you can use the New button
(outlined in red in the image) => the New Category menu will open (outlined in green in the image) =>
write the name of the new category.
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The Libraries Contents - Default and Custom Elements
2D Symbols: in addition to the default Punch! Software (R) symbols, new elements can be added to the
User Library by importing or creating using the Symbol Editor Power Tool or the Section Detailer Power
Tool, if they are available in your program.
This is the default library of 2D Symbols.
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Go To: find more Information about 2D Symbols
3D Effects: this library is included only in the Architectural Series programs. The different effects
(Displacement and Reflectivity) are part of the program and new effects cannot be included or imported.

Go To: find more Information about 3D effects
Furnishing: in addition to the default Punch! Software (R) objects in the Furnishing library (outlined in
blue in the image below), new elements can be added to the User Library by importing them or by
creating them using the 3D Custom Workshop Power Tool.
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Go To: find more Information about the Furnishing libraries in the following sections:
Libraries Access and Libraries Organization.
Materials: in addition to the default Punch! Software (R) materials, new elements can be added to the
library to be used as materials, backgrounds, etc. by using File => Import => Material to library.
This is the default library of the Materials.

Go To: find more Information about Importing Custom Textures and applying textures

3D Backgrounds: in addition to the default backgrounds, new elements can be added to the User Library
by importing them using File => Import => 3D background.
The Backgrounds library is the first category in the Material library (see image above).

Go To: find more Information about Importing Custom Textures and applying textures

Paint Colors: the libraries include:
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- Custom colors: there are 6 groups (Winter, Spring, Summer, Autumn, Contemporary and Gray Tones).
By double clicking any color in these groups, the color menu opens allowing the edition of the selected
color by changing the Red, Green and Blue (RGB) composition (outlined in red in the image below). Usually,
paint brands have a catalogue with the RGB composition, so the paint colors can be easily reproduced.
The Hue, Saturation and Luminosity can be also customized.

Note that, although this customization happens in the Stock Library , it isn’t permanent: it is
only part of the current project.

- Color Ramp: features a spectrum of 25 shades for the different colors’ families. The colors of this
library cannot be changed or customized.
- Paint library: includes companion colors, interior, exterior and Paint Colors Pack.

By double clicking these colors, the Paint Chooser menu opens, allowing a better view of the color and
the group. The colors of this library cannot be changed or customized, however, they can be added to
the Favorites library.
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Tip: it is not possible to import a color to the Paint Color Libraries, however, if you need to use a
specific color and you have a picture, you can import the color as a texture, in the Materials Library

Go To: find more Information about Importing Custom Textures and applying textures

Plants: in addition to the default Punch! Software (R) Plants, new elements can be added to the User
Library by importing them using File => Import => Plant to library.
Additional filter options can be found by selecting the Options button (black arrow in the image below)

Go To: find more Information about Plants (properties, selection, etc.), importing new
plants, and Customizing Plants Geometry.
In the image below we can see the default library of Plants:
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Templates: in addition to the default Punch! Software (R) Templates, new elements can be added to the
User Library by selecting elements in the project and saving them as Templates by clicking in the Options
button (black arrow in the image below).
This is the default library of the Templates.
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Note that the templates’ preview can be created as 2D or 3D thumbnails.

Go To: find more Information about Creating Templates
Trims and moldings: in addition to the default Punch! Software (R) trims, new elements can be added to
the User Library by creating them using the Trim Designer Power Tool.
This is the default library of Base Trims.

The Trim libraries include the wainscot library and the Library paneling, as shown in the image below.
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Wall Accessories: the elements in the default Punch! Software (R) accessories library can be copied to the
User Library to be resized, edited, etc.
This is the default library of Wall Accessories:

Quick Palette Library: a separated Library that provides the initial color / materials settings of a project.

The library includes several palettes with different settings. These palettes can be customized using the
Edit Quick Palette option => drag and drop the new material / color in the desired slot
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Plant Symbols: this library is accessible after the insertion of a plant.
The library includes 9 subcategories (Annuals, Cacti, Ground Cover, Hedges, Hedges, Ornamental Grass,
Perennials, Shrubs, Trees and Tropicals). The symbols can be copied and customized in the User Library.
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Go To: find more Information about Plants in 2D and Creating new 2D Plant Symbols.

Return to Table of Contents
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The Punch! Software (R) programs have different tools to help you to customize your 2D plan.
THE DRAWING METHODS
The drawing methods allow various shapes and drawing techniques as well as different start and end
points to develop the desired component or element. Not all the elements offer the same methods that
are available in the Draw method drop down menu

THE DETAIL TAB
The Detail tab includes 2D shapes and lines to help with the floor plan presentation.

Notice: note that some of the shapes can be developed by simply drawing them or by using
the Drawing Methods, although the options are limited.
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The different options for each element are shown in the Properties tab: the shapes and lines can be edited
(as objects or points, outlined in blue in the image), the curves can be adjusted or straightened (outlined
in magenta in the image), and the areas can be obtained by clicking the “Cal. Area” button (outlined in
cyan in the image). In addition, the shapes and lines can be developed with or without dimensions.
Shapes and lines (outlined in black): these are 2D Entities that can be edited as object or by points. These
2D entities can be converted using the Convert To Tool (outlined in green in the image).

Editing Options: each 2D element in the program, can be edited as object (pointed in yellow
in the image) or by points (pointed in red in the image). When you edit as object, the 2D shape moves as
a whole entity. When you edit by points, each point or line can be selected separately, edited, moved,
etc.

The Convert To Tool (outlined in green in the image above)
After we import a CAD file or after we draw any line or polygon in the Detail tab, we can convert these
CAD entities into Punch! Software® intelligent entities.
It is important to note that not every line, shape or CAD element can be converted to intelligent entities.
Lines can be Converted To
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Polygons can be Converted To

Go To: find more information and tutorials about Import DXF / DWG files

Drawing Styles
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Draw Styles Tab
The Draw Styles tab is located between the Properties tab and the Libraries tab, at the right of the screen
(outlined in green in the Visual Guide below).

Draw Styles Tools and Styles
Line (outlined in blue in the Visual Guide above)
The tools in this menu control the different attributes of the lines and outlines: Styles (continuous, dotted,
etc, pointed with a blue arrow in the image below), Weight (pointed with a green arrow in the image
below), Line Join types (pointed with a red arrow in the image below, Color (as per Paint Colors library),
as well as Translucency (0 to 100).
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Fill (Outlined in magenta in the Visual Guide above)
By checking the Filled field in the Fill tool (outlined in red in the image below), the selected element is
filled with the selected color (pointed with a blue arrow in the image below). The colors are as per the
Paint Colors library. Translucency can be selected (0 to 100).

Pattern (Outlined in black in the Visual Guide above)
By clicking inside the Pattern square (outlined in red in the image below) the Pattern menu will open
(outlined in magenta) showing the different pattern options.
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You can select a pattern (pointed with a brown arrow in the image below) => the selected patern will
appear inside the selected shape (pointed with a cyan arrow in the image below). The pattern will
appear in the color selected in the color field (outlined in green in the image below).
The colors are as per Paint Colors library. Translucency can be selected (0 to 100) as well as the scale of
the pattern.

Note that, if desired, Fills and Patterns can be used simultaneously (pointed with a black
arrow in the image below).

Text (Outlined in cyan in the Visual Guide above)
The Draw Style Text tool customizes all the instances where the text is present: texts automatically
generated by the program or manually created using the Text Tool.
For example, for the automatically generated labels (rooms), you can select the room => select the text
tool (Draw Style bar) => change the text settings. In the image below, the default black color was changed
to red (pointed with blue arrow in the image below). The text colors are as per Paint Colors library.
Translucency can be selected (0 to 100).
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Note that, as the texts are inserted in “boxes” you can include Patterns (pointed with a magenta
arrow in the image below) as well as Fills (pointed with a blue arrow in the image below)

Draw Order (Outlined in yellow in the Visual Guide above)
Using these tools you can select the drawing order of overlapping elements.
There are 4 available options:
- First icon => Bring Forward: moves the selected element in front of closer element (pointed with a
green arrow in the image below).
- Second icon => Send Backwards: moves the selected element behind closer element (pointed with a
magenta arrow in the image below).
- Third icon => Bring to Front: moves the selected element in front of all the elements (pointed with a
blue arrow in the image below).
- Fourth icon => Sent to Back: moves the selected element to behind all the elements (pointed with a
brown arrow in the image below).
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Format Painter (Outlined in brown in the Visual Guide above)
This tool allows you to copy of the style of an element to other elements. For example, customize the
lines, fills and pattern of a 2D object (pointed with a green arrow in the image below) => click on the
Format tool (outlined in blue in the image below) => select the desired elements (pointed with red arrows
in the image below) => the selected elements will adopt the style of the first object.

Draw Style Profiles (Outlined in red in the Visual Guide above)
By default, the Draw Style tools include a set of Draw Style Profiles. By clicking on the Draw Styles Profiles
button (outlined in red in the visual guide above), the menu opens (pointed with a red arrow in the visual
guide above).
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The default profiles are ordered by tab, and they are defined by component. For example, the dormer
cutout (pointed with a green arrow in the Visual Guide) is located in the Roofing Plan and set with a
dashed line, no fill and no pattern. This means that each time that you place a dormer cutout, the
program will create it following this profile. However, you can modify these profiles as well as create
new profiles.
By selecting the profile, you can change the colors, add a pattern, etc. Then you can either save it with
same name (customizing the style) or you can save it with another name and create a second profile for
the same component. This is very useful to identify different stages of a construction, using for example,
one style for existing areas and another style for new areas. Note that exterior walls cannot be
customized individually.

Plant Symbols
Creating 2D Plant Symbols
The drawing tools in the Detail tab (outlined in yellow in the image below), plus the elements in the
Draw Style allow the development of Plant Symbols.
Draw the desired profile or symbol using 2D lines and shapes (pointed with a red in the image below) =>
select the element (this is important) => Open the Plant Library => click on the Options button (outlined
in blue in the image below)=> the Options menu will open => select the “Create Plant Symbol” option
(outlined in green in the image below) => Save the symbol in the desired category of the Plant Symbol
Library.
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In addition, once the customized symbol is ready, you can create a Custom Draw Style Profile and use it
in other projects. To save your custom symbol => select the custom symbol => Open the Draw Style Profile
Menu (pointed with a magenta arrow in the image below) => Click on the “Save As” button (pointed with
a blue arrow in the image below) => you will be asked to set a name (for example, tree 1) => the new
profile will appear in the “Saved Style Profiles” list (outlined in black in the image below).
Note that the new profile (pointed with a red arrow in the image below) will appear in the tab where the
elements was created => in this case, the Landscape tab.

An additional Option => if you prefer, instead of drawing the symbol, you can Import a DWG / DXF
file with the symbol and follow same the procedure described above.

Go To: find more information and tutorials about Import DXF / DWG files
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Now, it is time to learn about the 3D resources. Although the 3D tools are important for visualization
purposes during all the stages of the project, don’t forget to check your plan’s specifications before you
proceed to the 3D stage.
In order to create a 3D image, there are some important considerations
– What I am going to show?
– Which is the best tool to create the image?
As a general concept, I prefer to use the Walk – Through tool for detailed and close up images and the Fly
Around tool for elevated and more general images.
Another important element is the lighting: the images must be well illuminated: check the light sources
and orientation

Recommendation: I strongly recommend inspecting the project using split screen (half 2D and
half 3D) in order to detect inconsistencies in the elevations or specifications

THE 3D TOOLS: NAVIGATION
Note: not all the programs have the same tools / features.
Walk – Through

Also known as “Little man”, this tool is present in all the programs. All the functions can be
controlled using the mouse
The camera (Walk -Through Elevation) is located at the eye level of a person, and the elevation can be set
using => 3D => 3D Navigation (or double click the Little Man icon in the Live View screen). Also see
Changing Elevation
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Different elevations should be used to visualize different levels of the building. In the image below, in
order to visualize the second floor, the Walk -Through Elevation should be 166”and, in order to visualize
the third floor, the Walk -Through Elevation should be 273”.

Walking: the little man walks forward by moving the mouse up while pressing the left button. It walks
backward by moving the mouse down while pressing the left button.
Rotating: the little man rotates by moving the mouse to the left or to the right while pressing the left
button.
Pan: the little man pans by using the right button of the mouse and dragging to the left / right.
Changing Elevation: to change the elevation while in Live View => move the mouse up while pressing right
button up to increase the elevation or move the mouse down while pressing right button up to decrease
the elevation.
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Looking up and down: by default the camera looks straight, however, it can be oriented up or down using
the wheel of the mouse, as shown in the image below

Tip: In order to start and become familiar with this tool, you can work with the split screen (half 2D
and half 3D) and move / rotate the little man manually
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Flying Around

Also known as “Chopper”, this tool is present in all the programs. All the functions can be controlled
using the mouse
The camera (Fly Around Altitude) is located at on a helicopter flying around the Center of Reference, and
the elevation can be set using => 3D => 3D Navigation (or double click the chopper icon in the Live View
screen). Also see Changing Flying Elevation

Note that different elevations should be used to visualize different levels of the building.

Rotating: the chopper rotates clockwise by moving the mouse to the left while pressing the left button. It
rotates counterclockwise by moving the mouse to the right while pressing the left button.
Moving Up and Down: the chopper moves vertically between the 0”level and the defined Fly Around
Altitude. To go up => move the mouse up while pressing the left button. To go down: move the mouse
down while pressing the left button.
Pan: the chopper pans by using any of the 4 arrows in the keyboard while pressing the left button.
Angle: the maximum angle of the Fly Around Camera is (approximately) = 35 degrees
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Changing Flying Elevation: to change the altitude while in Live View => move the mouse up while pressing
right button up to increase the altitude or move the mouse down while pressing right button up to
decrease the altitude.

Tip: In order to start and become familiar with this tool, you can work with the split screen (half 2D
and half 3D) and move the center of reference manually

Aerial View

Also known as “Satellite View” or “Bird View”, this tool is present in all the programs. It looks down
vertically to a point (called Center of Reference)
Rotating: the satellite rotates clockwise by moving the mouse to the left while pressing the right button.
It rotates counterclockwise by moving the mouse to the right while pressing the right button.
Pan: the satellite pans using the left button of the mouse
Changing Aerial View Altitude: to change the altitude while in Live View => move the mouse up while
pressing right button up to increase the altitude or move the mouse down while pressing right button up
to decrease the altitude
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Room View

This tool is a variant of the aerial view. In the floor plan, select the desired room=> in the plan, the
room will be highlighted in yellow. The 3D view will show the aerial view of the room. The commands are
the same of the aerial view.
Rotating: the satellite rotates clockwise by moving the mouse to the left while pressing the right button.
It rotates counterclockwise by moving the mouse to the right while pressing the right button.
Pan: the satellite pans using the left button of the mouse
Changing Aerial View Altitude: to change the altitude while in Live View => move the mouse up while
pressing right button up to increase the altitude or move the mouse down while pressing right button up
to decrease the altitude

By pressing in the Room View icon, the program will change the Center of Reference and Aerial View
Altitude to show the aerial view of the selected room
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THE TOOLS: DECORATING
Applying Colors and Materials
The Colors and Materials show the finishing surfaces of walls, floors, furniture, etc. In order to apply the
colors / materials, just drag and drop these elements from the libraries on the desired surface.

Tips to apply the Materials and Colors:
- Try to set the position of the little man close to the surface you wish to apply texture or color.
- Very important: If the room elevation is under the 0.00” level => the little man elevation must be also
under the 0.00” level
- Doors and windows’ trims=>apply the color / texture on the surfaces parallel with the wall where the
door / window is installed.
- If the terrain is interfering, in the Design menu => Options => 3D preferences=> Visible 3D elements =>
uncheck the lot and topography options.
Options and Tools

Decorator Palette
Outlined in green in the image: the Default Palette is activated by selecting => Main Menu=> 3D =>
Decorating Options => Decorator Palette Visible. You can Save and rename as many palettes as you wish,
and open them in other projects, as necessary
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As you develop your project, drag and drop the materials and colors in the palette. By default, there are
several groups in the palette that you can rename in order to organize the materials using different
categories like walls, floors, etc.
The main advantage of this tool is the fact that you don’t need to get close or see the object to change the
material: just drag and drop a replacement material or color in the correct slot.
You can add other elements like Accessories or Custom Fences
Find Applied (Dropper)
Outlined in blue in the image: this tool is used to find any material or color applied in the file, while we
are visualizing in live view mode. In the image above, say we want to find the material used to texture the
picture frame => select the dropper (outlined in blue in the image) => click on the desired object (the
frame in this case, pointed with the blue arrow) => the material will be selected in the Material tab and in
the Decorator Palette (if it is opened) => both selections outlined in blue.
Quick Palette (Default Design Materials)
Outlined in red in the image: Activated by default, this tool comes with a Default Quick Palette that
includes materials and colors for floors, trims, walls, etc. These materials and colors will be applied as the
initial finishing in any new project. You can change the default quick palette using any other Quick palette
(in the Quick Palette Library )or just creating a new palette replacing one or all the default materials or
colors => to do this => Main Menu => 3D => Decorating Options => Quick palette => the Quick palette will
open as shown in the image => just drag and drop the new material or color on the desired slot.

Smart Wand
To enable or disable the use => Main Menu => 3D => Decorating Options => Enable Smart Wand.
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When you attempt to apply a material or texture (and this tool is activated), you are offered additional
placement options. For example: select a texture in the Decorator Palette => apply the texture on a wall
(drag and drop, see blue arrow) => placement options will pop in the screen => in the selected place, in
similar places in the room or in similar places in the structure

The tool also works when you apply moldings or 3D effects
Applying Moldings
The moldings are: Base Trim, Crown Trim, Wainscot, and Library Paneling. They are included in the Trim
tab (outlined in green), and can be applied by dragging and dropping on the walls. The moldings can be
also applied in the doors and windows casings

APPLYING LIGHTING SETTINGS (For 3D Rendering)
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Natural light: by clicking in the sun icon (outlined in blue in the image above), the light menu opens. The
menu also opens using => Main Menu => 3D => 3D rendering => Lighting => Lighting.
Depending of the type of image desired, the sun can be activated or deactivated. Keep in mind that the
sun will generate reflections (pointed by the blue arrow) and shadows. These effects will look odd in a
night scene, for example.
Also, avoid the direct sunlight effect on floors with Reflections.
The sun settings include: Direction, Angle and Brightness. These settings must be correctly balanced in
order to avoid overexposed or very dark images.
The sun direction can be placed using any angle around the building: notice that direct or front sun will
create small shadows. The angle reflects the day time, where an angle with 90 degrees means noon time.
The brightness conditions filter the sun light (with clouds, for example).
Shadows: the quality of the shadows range from 1 to 6 or Optimal Quality => note that a better shadow
quality will take more rendering time
Ambient Light: including intensity and brightness. This setting controls the general lighting conditions of
the ambient, independently of the sun settings.

APPLYING LIGHTING SETTINGS (For Photorealistic Rendering)
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Natural light: this setting works as described for non-Photorealistic rendering => by clicking in the sun icon
(outlined in blue in the image below), the light menu opens. The menu also opens using => Main Menu =>
3D => 3D rendering => Lighting => Lighting.
Depending of the type of image desired, the sun can be activated or deactivated. Keep in mind that the
sun will generate reflections (pointed by the blue arrow) and shadows. These effects will look odd in a
night scene, for example.
Also, avoid the direct sunlight effect on floors with Reflections. Notice that, in Photorealistic rendering,
the sun reflections are more intense.
The sun settings include: Direction, Angle and Brightness. These setting must be correctly balanced in
order to avoid overexposed or very dark images.
The sun direction can be place using any angle around the building: notice that direct or front sun will
create small shadows. The angle reflects the day time, where an angle with 90 degrees means noon time.
The brightness conditions filter the sun light (with clouds, for example).
Sunlight color: (outlined in green in the image below) by clicking on the color window, the color menu
opens allowing the selection of any color for the sunlight. With this option, it is possible, for example, to
set a more dark light for the afternoon or a more light hue for the morning.
Shadows: there are no controls for this setting in Photorealistic rendering => the quality is always the best
Photo Scene Lighting: the Photo Realistic rendering tends to soften the surfaces, colors and lights. For this
reason, it is always recommended the use of extra light. There are two options: Eye (more direct) or
Ambient (more diffused). Both options (Eye and Ambient) can be used together.
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Recommendation: there isn’t an exact and error-proof guide for lighting conditions: it depends
on the scene, the type of building, the desired effects, etc. For these reasons, it’s important to balance the
settings, making small changes and previewing the scene.

APPLYING ADDITIONAL SETTINGS
There are several settings that provide additional help for a good rendering (not all the programs include
all the settings).

Global Sun Position: (outlined in red) you can set your specific lighting conditions by setting the location
of your property as well as the desired date and time.
True North Angle: (outlined in green) determines the exact position of the North in the working space =>
the sunlight and shadows will be more accurate.
Adjusting Lighting for Day / Night Time: (outlined in blue) sets the condition for Day scenes or a night
scene
All Light Fixtures ON / OFF: (outlined in magenta) allows the controls of all the light fixtures

APPLYING SPECIAL EFFECTS
Some programs have special features as reflections and 3D effects
Reflections: the Professional series program allows reflections on some surfaces like Floors, Decks, Stairs,
Countertops and Patios. To add the reflections => select the element (a Floor in the image below) =>
Properties tab => set the desired Reflectivity level
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3D Effects: the Architectural Series program include a 3D effects library with 2 types of effects: Reflectivity
and Displacement. These effects provide reflections, shine, light, metal finishing, materials appearance,
etc. The effects can be applied on any surface, including walls, floors, POBs, Components, etc.

Start by using low effects because some reflections and finishing may cause odd effects or
create a lighting conflict.
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The Reflectivity Effects
The Reflections effects are excellent to create a shiny finishing on large surfaces (for example, floors). Use
Mirror effects for real reflections on small surfaces. The Metal or Plastic finishing are perfect to simulate
surfaces like chromed elements or PVC furniture. In the image below, we can see several effects

The Continuous Light effect is very useful to simulate lighted rooms in a night scene.

Note: the light provided by the lighting elements in the Electrical tab may create rooms that
are too bright when combined with the 3D effects.

Recommendation: there is no error-proof guide for 3D effects + lights: depends on the scene,
the type of building, the desired effects, etc. For these reasons, it is important to balance the settings,
making small changes and previewing the scene.

The Displacement Effects
These effects produce different appearances on the surfaces. In the image below we can see the 3
displacement effects applied in addition to the Mirror Reflectivity Effect.
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THE HELPING TOOLS
Selecting Elements in Live View
Any element in the active floor plan can be selected in the live view screen. This means that if you wish
to select a deck in the second floor, the Deck tab and the second floor must be active.
The elements are selected using the 3D selector tool in the live view screen (outlined in blue in the image
below).

Note: If you wish to select plants, use the 3D selector tool in the live view screen and in addition,
hold the Control key in your keyboard.
In the image below: say we wish to select the wall in the front corner.
1 - Set a split screen: half screen Floor plan / half screen live view.
2 - The wall is in the first floor, so we confirm that this is the active floor (outlined in red).
3 - As we will select a wall, we confirm that the Floor tab is active.
4 - Click on the 3D selector tool (Outlined in blue in the image).
5 - Click on the desired wall (pointed with the blue arrow in the image).
6 - The wall will be selected in the Floor plan, therefore, the Properties tab will be active: the wall
properties can be edited
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The 3D Cutaway Tool
This tool is the last item of the Expanded Edit Toolbar (outlined in blue in the image below). The tool cuts
vertical or horizontal slices of the 3D model, creating a horizontal or vertical plane at the desired level.
While you are visualizing the cutaway in 3D, you can select elements, place objects as well as apply colors
and materials.
There are 3 types of cutaway planes (outlined in brown in the image below):
-Vertical: this direction will cut a vertical plane (perpendicular to the floor), along the full height of the
building removing everything to the other side of the plane.
-From Top: this direction will cut a horizontal plane (parallel to the floor) removing everything from the
top of the building down to the plane. The plane will be located at the elevation defined in the “Elevation”
field (outlined in black in the image below).
From Bottom: this direction will cut a horizontal plane (parallel to the floor) removing everything from
the base of the building up to the plane. The plane will be located at the elevation defined in the
“Elevation” field (outlined in black in the image below).
Use the tool to draw lines on the floor plan to define the cutaway lines (pointed with a blue arrow in the
image below). These lines define the cutaway planes. You can trace multiple lines using different angles,
however there is only one active cutaway at a time, marked with the text “active”.
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In the image below, the active cutaway line text is outlined in red. The remaining cutaway line text is
outlined in yellow. You can select and activate / deactivate the different cutaway line using the “Activate
/ Deactivate 3D Cutaway” button (outlined in magenta in the image below).
The symbols in both ends of the cutaway line point the direction of the cut and visualization. In the image
below, the direction looks towards the interior of the room. You can flip this direction using the “Flip
Cutaway Direction” (pointed with a green arrow in the image below).

For example, say we wish to cut a horizontal plane in this building.
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In this case, we select the “From Top” cutaway mode and we set the desired elevation to visualize the
desired section (pointed with the blue arrow in the image below).

If we wish to cut out the right side of the building, we select the “Vertical” cutaway mode and we set the
cutaway line to visualize the desired section (pointed with the blue arrow in the image below).
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Note: the blue transparent planes were added for visualization purposes, but they are not part
of this tool.

Return to Table of Contents
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THE RENDERING MODES
Working in Live View: Program Options
The different onscreen elements use computer resources and increase the rendering time. For this
reason, the best option is a rational use of resources. During the elaboration process, take advantage the
Render Options: hide temporarily the unnecessary elements and temporarily reduce the quality.

Recommendation: rendering steps for a rational use of resources, during the elaboration time:
1 - Develop the constructive aspects of house first, (walls, roof, floors, doors, windows, etc.).
2 - Develop the topography with a low quality definition.
3 - After the house and topography development, you can start the decoration stage. To use fewer
resources, use the Render Options: hide the unnecessary elements and reduce the quality. These options
can be changed later.
4 - Working in Clear View mode increases the speed.
5 - If you are working in the interior of the house, deactivate the topography.
6 - If you are working in the exterior of the house, deactivate the interior furniture and interior lights.
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WORKING IN LIVE VIEW: RENDERING OPTIONS AND STYLES
Elevation Editor Mode
The Architectural Series, Professional and Premium programs have an Elevation Editor Tool: this feature
is specified to develop Elevations and Cross sections.
An elevation is a flat view of one of the exterior sides of a building. indicated
A cross section is a 2D view of the interior of the building after one of the exterior sides was sliced using
the 3D Cutaway Tool.
The Elevation Editor Tool includes several features:
- Doors, Windows and Accessories can be applied and edited (outlined in green in the image below). These
elements can be dragged and dropped on the walls => selecting them => the Properties tab bar will be
active, so the doors, windows and properties can be edited, and included the elevation. This is very
convenient to add elements to stacked walls.
- The image can be panned in the screen using the Pan tool (outlined in red).
- As this is a Live View Image, we can use the 3D selector tool (outlined in black in the image below) as
well as the Find Applied tool (outlined in brown in the image below).
- The Rich Text Tool can be used to add any text or specifications (outlined in yellow in the image below).
- There are four different types of dimensions: Zero Offset, Offset Dimension, Length Dimension, and
Leader Dimension (outlined in cyan in the image below).
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- The texts and dimensions can be customized using the tools in the Draw Style bar (outlined in blue in the
image below)
- There are four preset elevation sides (Front, Back, Left, and Right) plus the Pan Rotation - Custom Angle
(outlined in gray in the image below).

Pan Rotation - Custom Angle : using the pan rotate tool (outlined in gray in the image below), the building
will rotate around its center, so, it is possible to visualize two elevations at the same time, or, an elevation
(pointed in orange in the image below) plus a cross section (pointed in magenta in the image below).

Note that all the annotations, dimensions or texts belong to each specific elevation. So, for
example, if you added dimensions in the front elevation, when you start the operation of the pan-rotation
tool, these dimensions will disappear, but will appear again if you visualize the front elevations again.
Of course, you can add new dimensions or annotations in the elevations or cross sections obtained using
the pan rotation tool.
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The Elevations can be visualized I the different styles. For example: Shaded (above) and Clear View (below)

Rendering Styles: Shaded
This is the most common style. The image below shows Shaded in 3D Rendering Mode

The image below shows the same Shaded view but in Photo Realistic Mode
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Rendering Styles: Clear View
In this style, there are no textures, just the outlined surfaces. The transparency can be specified.
The main advantage is the speed in the 3D movements, therefore it is recommended for the developing
process as well as 2D Elevations

Rendering Styles: Textured Wireframe
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Indicated for fast conceptual sketches

Rendering Styles: Color Wireframe
Indicated for fast color sketches. Notice that the colors match the Colors Preferences and Drawing Styles.

Rendering Styles: Framing
Visualize the structural elements
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Rendering Styles: Real View

Real View is a tool that allows the construction of 3D scaled models.
The Real View rendering style allows the 3D visualization of the building, showing the location of the
different templates that will constitute the scaled model

The numbers in the yellow circles are the templates’ numbers. Using the Render Options we can hide
the different elements for a better visualization. In the image below, the roof is hidden in order to
visualize the interior.
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Go To: find more Information about Using and Printing RealModel
Rendering Modes: Preview
The preview button (outlined in green in the image below) allows a fast on-screen rendering, using all
the specified settings (rendering options, Reflections, etc.)
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Rendering Modes: 3D Rendering
This rendering mode is present in all the Punch! Software (R) programs. It can be created with 4 different
Final Quality options: Low, High, Ultra-High and Excellent. The best quality options consume more
computer resources.

Rendering Mode: Photo Realistic Rendering
This rendering mode is present only the Architectural Series programs. It provides a superb quality for the
images. Compare the image below with the normal 3D Rendered Mode image.
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Provides also amazing results for night time images

Photo Rendering Effects and Styles
Programs that include Photorealistic Rendering have additional filters and styles.

Note: In order to visualize the effects and styles, you must preview the image in final quality or
Export the image.
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Photo rendering styles: these styles can be accessed using the icons in the Live View screen

Or using the Main Menu => 3D => Photo-Realistic rendering => Render Style

There are six different filters => Shaded (default), Contour, Hatch, Mosaic, Oil Painting (see image below)
and Stipple
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Photo Rendering Effects
The Photo rendering mode includes different effects that can be accessed using the Design Options panel
=> 3D Preferences => Photo Rendering Effects
There are 2 types of rendering effects: Outdoors Foreground Effects (outlined in blue in the image below)
and Camera Effects (outlined in red in the image below)

Outdoor Foreground Effects: there are three Outdoor Foreground Effects: Fog, Ground Fog, and Snow
(See image below).
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For the consistency effect, it is recommended to change the background, plants, etc.
Camera effects: by setting the angle of view, blur factor and focus distance (resembling the adjustments
of a camera) it is possible to render an image focusing on a single object and blurring the background, as
shown in the image below.

Questions about rendering
Question 1: Is it possible to change the background?
Answer 1: Yes, it is possible. Drag and drop a new background image on to the “sky”. There are several
background images in the program Materials Library. Note that these images are prepared to be used
also when there is a slope down in the topography, therefore, when it is used on a flat lot, the image looks
“sunk” => there are two options to solve this issue:
1 - Edit the image with any graphic program, adding a lower segment that will be underground (see the
Sky textures in the Materials Library)
2 - Set a background image (as shown in this image) using the Photo View Power Tool following this
tutorial
Question 2: I placed a small wall to insert some electrical components. Can I render it transparent?
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Answer 2: In the Materials Library => Miscellaneous => the first icon is the Black Invisible Texture => apply
over the desired elements => they will become invisible in Live View.
Question 3: Can I save the different 3D locations of my project?
Answer 3: Yes. When you are in the desired location / position => go to 3D => Saved 3D Views = > save
the view with name. You can update the views as well as organize them.
Question 4: What does it mean “rendering time”? Why is this important?
Answer 4: the rendering time is the period used by the computer to process a rendered image. It varies
between few seconds to several hours, and it is directly related with the computer capabilities and the
complexity of the file. For this reason is strongly recommended the rational use of resources during the
elaboration time

CREATING ANIMATIONS
In order to create an animation successfully, the first step is, of course, a 3D model ready. Also, it is
recommended to verify the computer’s resources and perform a cleaning – maintenance routine .

Recommendation: while you are exporting or previewing the animation, close any other
software and avoid any other activity in your computer, including e-mail.
The Animator icon (outlined in green in the image) is at the left- bottom of the screen, the last icon in the
Expanded Edit Toolbar.
The animation final product will be a movie (AVI format) created by the addition of successive rendered
Walk-Through images.
First, you need to create an animation path: click on the icon (outlined in green in the image below) and
then on the floor plan => trace the desired path. You can create the viewpoints by clicking with the mouse
or you can Add Points later.
The Segment: the line between two viewpoints is called segment (pointed in blue in the image). Using the
Properties tab it is possible to select the segment information visible on the screen as well as the duration
of each segment (outlined in blue in the image below).
The length (in seconds) of each segment is extremely important because, if the length (in inches) of a
segment is, for example, 150” and we set the length (in time) as 2 seconds, the quality of the animation
will be low. But if, for the same distance, we set the length (in time) as 10 seconds, the quality of the
animation will be high. You can use a thumb rule: measure the length of the segment and set the time
that you would need to walk this distance at a leisurely speed.
Fading: we can choose to add a color fade effect at the beginning and at the end of the animation.

RENDERING MODES AND ANIMATIONS

- 263 -

The Viewpoints: each viewpoint is the location, direction and elevation on the “Little Man”. For a better
understanding of this concept, work with a split screen (half floor plan / half Live View) => Select one of
the Viewpoints of the animation => Update 3D From Animation Segment => in the Live View screen, you
will see what the Little man is seeing in that exact point of the animation. This means that we can rotate,
change the elevation or look up or down the “Little Man” view as we explained previously. These changes
will be reflected in the animation, and will happen gradually during the segment => this means that, if one
viewpoint we have an elevation of 216” and the Little Man is looking straight, but these parameters
change in the following viewpoint, the changes (rotation, elevation, etc.) will happen gradually along the
segment.
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You can preview the animation in order to confirm the final product, elevations, views, etc. Then you can
export the animation, choosing the quality, screen size, shadows, etc.

The export process to an AVI file is long, and the amount of time will be determined by the parameters
above as well as the computer capabilities.

Return to Table of Contents

RENDERING MODES AND ANIMATIONS

- 265 -

The How to Tutorials ........................................................................ - 267 Screen Visual Guides ..................................................................... - 278 General Questions, Answers and Tutorials .................................. - 283 -

Return to Table of Contents

RENDERING MODES AND ANIMATIONS

- 266 -

THE HOW TO – TUTORIALS
How to insert a picture of the house and add landscape to it?
1 – Take a picture of the house. Choose carefully the angle of the picture: you will use the same point of
view in the landscape images.
2 – Using any image program, cover all the undesired areas with black color (RGB 0,0,0). Trim the picture
so the lower part of the house is on the lower part of the picture

3 – Using the Photo View Power Tool, import the picture. Use real life dimensions: if the width of the
house is 60’ and the total height is 30’, use these dimensions for the imported picture.
4 – The picture will appear in the floor plan as a line. Keep in mind that it works like a board, therefore,
you can’t modify the picture after you imported it.
5 – Set the screen in split mode (half floor plan / half Live View)
6 – Place the little man in the same position and elevation that you used for the picture (in the image
below, see the camera, outlined in red)
7 – Carefully, add the desired elements (deck, plants, furniture, pool, etc.) => always check the elevations
and angles
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8 – Verify sun and light settings as well as shadows
9 – Render the image

How to create different levels in the same floor? How to create a split level house? How to set the
different levels in the topography?
Even if your program / version allows only 3 floors, split levels or different levels in the same floor are not
a problem if you set the elevations correctly. Use the Pat’s Elevation Manager to write the elevations’
levels (adding a text reminder if you wish). For example, say that the first floor of your house has 3 levels:
The garage at level 0” (in brown in the image), the main entrance at +24” (in red in the image) and the
living room at 48” (in green in the image).
Create each level using a different Working Elevation, all them in the first floor.
As for the topography, create three different building pads, using the different elevations (0”, 24”and 48”)
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How to create a walk out basement?
1 – Define the level of the upper access of the building => in this example, it is the level 0”
2 – Define the level of the walk out basement => in the example, it is the level -96”
3 – Define the length of the slope => in this example it is = 227”
4 – Use the slope tool in the extension of the slope and set the angle to fit the upper and lower levels =>
in this case is 21 degrees.
5 – Set building pads with elevations 0” and -96”in the upper and lower levels respectively.

Alternatively, depending of the necessities and characteristics of your project, you can consider 0”as the
lower level of the building
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1 – Define the level of the upper access of the building => in this example, it is the level 96”
2 – Define the level of the walk out basement => in the example, it is the level 0”
3 – Define the length of the slope => in this example it is = 227”
4 – Use the slope tool in the extension of the slope and set the angle to fit the upper and lower levels =>
in this case is 21 degrees.
5 – Set building pads with elevations 96” and 0”in the upper and lower levels respectively.

How to create an egress window well?
1 – Use the Excavation Tool to create the necessary excavation area, with the requested depth.
2 – You can build the well using the 3D Workshop PT, or using walls and a floor=> set the elevations
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How to create a template?
The templates are a useful resource to create design layouts that can be used repeatedly in different
projects. To create a template, simply select the elements in the floor plan => and saving them as
Templates by clicking in the Options button (blue outline and arrow in the image below).

Go To: find more Information about Templates Library

How to create arches with columns?
1 – Create the arches using empty casements (Door Tool)
2 – Texture the trim with the same material used on the wall
3 - Set the trim thickness as 0” (unless you wish the trim effect)
4 – Add columns, as explained in this answer
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5 – Adjust the dimensions in order to create the desired effect (arches must start at the top of the columns)
6 – Render the image

How to create a roof over a deck? How to add columns and rails?
Is not uncommon to develop the house including the roof and decide to add a covered deck after.
In this case, as the perimeter of the deck doesn’t include walls, the Auto Roof feature won’t generate a
roof for the deck. In this tutorial we will learn how to develop this.
1 – Check / adjust or delete the connecting roof piece => Check the settings of the adjacent roof pieces
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Note that, in order to remove a roof piece or to Add Points to fit a new roof piece, the roof
must be a created as Auto Roof or as Freehand Roof.
2 – Using the Roof tools (Roof tab), create a roof with the desired shape to cover the deck. In the image
below, we can see the old roof (pointed with the red arrow in the image below) and the hip connector
(green roof) covering the deck => Roof pitch and elevation are adjusted.
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3 - There are several resources to add the rail / columns:
- The height of the posts (rails) can be adjusted => as shown in the picture below, the posts can be used
as columns.
- Alternatively, the columns can be created with the Column tool (Floor tab)

You will find columns as 3D objects in the 3D library => Exterior Category => Accessories
subcategory
- You can place a Custom fence adjusting the height of the columns, as shown at the left of the image (red
arrow).

Go To: find more Information about Custom Fences

Go To: find more Information about Roofs

How to create a Crawl Space?
By definition, a Crawl Space is a non-habitable level below an elevated house and it features a low
clearance (usually, the height is less than 4 ft.). In the image below, the height of the space is 60”, with
34” below the 0” level
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There are different approaches to create this space:
Option 1: Create a basement with ceiling height= 60” (magenta arrow in the image below) and base
elevation = -34” (blue arrow in the image below). The elevation of the Living Space (above) will be 30”

Option 2: If you prefer to develop the Crawl Space and the Living Space in the same level, you can
reproduce the same situation (above) using stacked walls.
If the floor of the Crawl Space is dirt, you can hide the auto floor.
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How to copy and align an entire level from a different file?
Question: I created two versions of my project (Version1 and Version2). Now, I’d like to blend the two
versions: I’d like to keep the first floor of Version1, and add the second floor of Version2. How do I copy
and align the floors?
Answer: follow these steps:

Floors must be copied and pasted in the same level. This means that if you select and copy
the second floor of a file, you must paste it in the second floor of the other file
Step 1: For both levels / files, confirm that all the elements are visible:
For Windows Versions=> If you are working in the Floor tab (for example) and you also have elements in
the Plumbing, Electrical and Detail Tabs => click on the Workspace => go to the Properties tab => check
the names of the plans you wish to show.

Step 2: Go to the Detail Tab => use the square / rectangle tool => create a square / rectangle following
the perimeter of the Workspace. Repeat this process in all the floors / files that you are going to copy.
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Step 4: In both files => activate Snap to Grid
Step 4: Go to the file that you are going to copy => Edit => Select All
Step 5: Go to the file / level where you are going to paste => Edit => Paste
Step 6: With all the elements selected => move all the elements using the arrow keys until the corner of
the outline (marked in red in the image) is aligned with the upper left corner of the workspace.
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In the following pages, you will find several screenshots showing the most common screens and situations
that you will find while you are using Punch Software (R) Version 20.
The different tools and features are outlined with a red rectangle => by clicking inside the red rectangle
you will be directed to the exact page of the eBook where you will find information, answers and tricks
about the selected feature.
Note: in order to show the full screens, the texts and the details in the images are very small. For this
reason, for a better visualization of the images of this chapter, use a large Zoom value (about 300%). The
images have a good resolution so the information will be clearly visible.
Quick Start Screen

Go To: find more Screen Guides:
Workspace Screen
Floor Tab Screen
Plants Screen
LiveView Screen
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Workspace Screen

Go To: find more Screen Guides:
Quick Start Screen
Floor Tab Screen
Plants Screen
LiveView Screen
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Floor Tab Screen

Go To: find more Screen Guides:
Quick Start Screen
Workspace Screen
Plants Screen
LiveView Screen
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Plants Screen

Go To: find more Screen Guides:
Quick Start Screen
Workspace Screen
Floor Tab Screen
LiveView Screen
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Live View Screen

Go To: find more Screen Guides:
Quick Start Screen
Workspace Screen
Floor Tab Screen
Plants Screen
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MY PROGRAM IS NOT WORKING PROPERLY
Question 1A: Help! I am trying to visualize my project in Live View but I can see only black screen.
Question 1B: Help! I am trying to visualize my project in Live View but it only works while I click the mouse.
If I release the mouse, I see a black screen
Question 1C: Help! I am trying to apply a brick texture on the walls, but the texture ends on the grass.
Question 1D: Help! I am trying to apply a brick texture on the walls, but the texture ends on the sky.
Answer 1: For all the situations above, we are talking about a video card + settings issue.
Most of the video cards and video chips are designed for gaming, therefore, for the average card, speed
comes first and precision after. In other words, if during a computer game you are "chasing a monster"
certainly, you are not interested in the exact shadows of the castle's walls, or the texture's scale or the
exact dimensions of the rooms => your only interest is speed. However, if you are designing, you need
accuracy, even if the rendering takes more time. This is the reason why, with several video cards, to get
good rendering results and accuracy you need to reduce the speed (accelerations).
Onboard video cards and video chips are very popular, especially for laptops. But unfortunately, they are
not good for rendering purposes. There is a good reason for this: onboard video cards and video chips
share the resources with the main processor, therefore (as explained above) the same processor is used
for calculations and rendering. With complex surfaces, this process is almost impossible. In other words,
if you have just walls, roofs, etc., the system will work, but if you have furniture, columns, molding, etc.,
(lots of polygons) the system will crash and you will see a black screen or textures’ errors.
There are several tricks and work-around to solve this problem.
First Stage => Punch Preferences System Settings
1 – Reduce the hardware accelerations using the Preferences => System slider.
Second Stage => Maintenance (always a good idea).
1 – Check the updates for your Punch(R) Software.
2 - Check the website of your video card manufacturer and update the driver of your video card, chipset,
etc.
Third Stage => Balancing speed and performance.
1 - Go to the video setup on your PC (may be different for different versions of Windows and video cards);
for most, click on an empty part of the windows Desktop, click on Settings => Advanced => Troubleshoot).
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For Windows 7 => Right Click on your desktop => Personalize => Display => Change Display settings =>
Advanced. In both cases => back the accelerations slider to the left, one level each time and see if the
problem disappears. If the accelerations controls are not available, this means that you don't have
dedicated memory for video card. In this case, go to the control panel of your video chip / adapter =>
performance => move the control and lower the performance.
2 - Right click on the wallpaper (look for a place without icons) => Properties => Settings => Advanced =>
Open GL => Compatibility Settings => Force 16 bits => Apply => OK
3 - Set your video color depth at 24 or 32 bits ("true color").
4 - Some brands of video card users reported additional problems => in this case change the color settings
from 32 bit to 16 bit.
Question 2: When I open certain Power Tools (specially the 3D Workshop Power Tool) the program
crashes. How do I fix this issue?
Answer 2: Some malware programs hidden in your computer may affect the power tools behavior. Run 2
or 3 anti-malware programs (usually they find different things).
There are many free malware cleaners in the web. Keep in mind that Trojans, worms, etc. are not
computer viruses, so if you have just an anti-virus program, you need also an anti-malware program.
Question 3: When I try to import or edit an object with the 3D Workshop Power Tool, the object is not
visible. I see a gray screen, but if I click on the object, I can see a box around the object contour.
Answer 3: The “empty box issue” using the 3D Workshop Power Tool is a symptom of an issue with the
video card driver => Check the website of your video card manufacturer and update the driver of your
video card, chipset, etc.
Question 4: I opened my Punch! Software (R) file in my laptop and some of the materials are replaced
with yellow and black squares with an exclamation mark, like in the image below. The materials look fine
in my main computer.
Answer 4: the exclamation marks mean missing textures. If you created Custom Textures or Custom
Fences in your main computer, you need to copy or create the same textures (same names and categories)
in order to keep the same textures’ references in both computers.

Question 5: When I try to import or edit an object with the 3D Workshop Power Tool, the power tool
crashes. The objects are not imported or saved.

GENERAL QUESTIONS, ANSWERS AND TUTORIALS

- 284 -

Answer 5: This issue happens when the object has a large number of polygons. Before you import the
object => try to simplify the object (more basic).
Question 6: I opened my Punch! Software (R) but I can’t see the entire screen. The Properties tab seems
distorted / cut.
Answer 6: - Close your programs. Go to your desktop => Right click => Properties => Settings => Advanced
=> Search the configuration for the Display =>The tab is different in different Windows / Video card
configurations => Set the DPI settings in Normal Size (96 dpi)
Question 7 I uninstalled my old Punch! Software (R) program but my new program is not working properly.
What can I do?
Answer 7: You must perform a clean installation. To do this, first remove the old program using the Add /
remove programs (Windows) => check the Windows Explorer for other program folders => delete these
folders. If possible, clean the registry. Then proceed to install the new program. Notice that it is possible
to have several Punch! Software (R) versions in the same computer

THE PROGRAM INTERFACE
Question 1A: I added a Custom roof with a custom pitch but I can’t change the pitch.
Question 1B: I want to add some Custom doors and windows but I can’t change the dimensions.
Question 1C: I want to customize the properties of my floor, ceilings and decks but after I write the values
in the fields in the Properties tab, they return to their defaults.
Answer 1: The Properties tab is located in the right pane of the screen and is activated when you select a
Punch! Software (R) element, allowing for the element’s customization. After you change a roof pitch, or
a window / door dimension or any other property in the Properties tab bar, you must press the Enter key
in your keyboard so the new value will take effect.
Question 2: I outlined my plan using “Quick Start”, but in the menu, the “Save”, “Save As” and “Print”
options in the menu are grayed out.
Answer 2: The “Quick Start” tool is just a fast start => click the Continue button in order to proceed to the
main program => all the options and features are available in the main program.
Question 3: Can I show or hide the different elements (like roofs or landscape) in live view?
Answer 3: Yes, you can. In live view => Click on the Navigation and render options icon => the menu will
open => 3D Preferences => Visible 3D Elements => by default almost all the icons are checked => check
only the icons you wish to show.
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Question 4: I added a table in my plan. I can see it in my floor plan; however I can’t see it in Live View.
Answer 4: There are two elements to check:
1 – Select the object in the plan and verify the elevation => the object should be at the same elevation of
the top of the floor.
2 – in live view => click on the “Navigation and Render options” icon or => on the 3D Menu => Render
Options => Verify if the 3D Objects are checked (in the options Show or Hide in live view).
Question 5: I am trying to walk through the 3 levels of my project; however the little man walks only
through the first floor. How do I change this?
Answer 5: Set the different elevations of the little man. Double click on the little man icon to set the exact
elevation of the walk through. I suggest setting the elevation at 40” above the floor level => if you wish to
visualize your second floor and the floor is at 120” => set the little man elevation at 160”. The elevation of
all the 3D visualization tools (little man, chopper) can be changed by double clicking on the icons.
Question 6: I added a table in my plan and I want to delete it. I can’t see or select it in my floor plan;
however I can see it in Live View.
Answer 6A: Checking the floor plan => go to the first floor => start by checking the first tab (Foundations)
in the first floor => check all the remaining tabs of the second and third floors => remember that the object
can be located in any floor or tab.
Answer 6B: work with 2D / 3D simultaneously (live view / half screen) => In the floor plan screen =>
confirm that all the tabs are visible => In the live view screen => use the 3D Selection Tool (the arrow
icon) => point to the object => the object will be selected in the floor plan => the floor plan must be active
in the floor where the object is located.
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THE HOW TO - QUESTIONS
Question 1: How do I stack two walls?
Answer 1: If you have a wall with height= 50”, for example and a second wall with height= 40”, select the
second wall => Edit => set object elevation => 50” => set both walls together in the floor plan.

Tip: If your program has Elevation Editor, you can use these tools to visualize and stack the walls.
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Question 2A I can’t move my window / door along the wall. It just moves few inches and then stops.
Question 2B: I created a cabinet for the left side of my kitchen wall, but now, I decided to move it to the
right side. However, I can only move it few inches and then it seems frozen.
Answer 2: A wall break effectively divides a wall in two parts, so we can say that actually, we have two
different walls. Each wall can be textured or painted or you can change the properties of each part.
In the image below, the wall break is pointed in red. We can consider that we have the blue wall on the
left and the green wall on the right. For this reason, you can’t move the double door to the left (to the
blue wall) and you can’t move the cabinet to the right (green wall).

Question 3: is it possible to move an object to an exact point?
Answer 3: Select the object => Main Menu => Edit –Move => Write the exact distance in both directions
=> remember the following codes => example for a movement of 40”:
X axis => 40” => will move the object 40”to the right.
X axis => - 40” => will move the object 40”to the left.
Y axis => 40” => will move the object 40”up.
Y axis => - 40” => will move the object 40”down.
Question 4: I am drawing a curved wall. I set the Curved Segment Length as 60”, however the segments’
length is different. Why is this happening?
Answer 4: Because the program divides the curve in an exact number of segments so the dimension
created is the closest possible for the number of segments.
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Question 5: How to add columns?
Answer 5A: Structural columns => these columns can be added using the column tool in the Framing Tab.
The structural columns are listed in the Estimator’s Bill of Materials and they are visible in live view only
in Framing mode (not in Textured Mode).
Answer 5B: Columns as 3D objects => these columns are available in the 3D Objects Library (Exterior =>
Accessories) or can be developed with the 3D Workshop Power Tool. The 3D elements are listed as objects
in the Estimator’s Bill of Materials and they are visible in live view only in Textured Mode (but not in
Framing mode).
Answer 5C: Columns created using the Floor Tool => these columns are visible in Textured Mode as well
as Framing mode. However, they will appear as floors (and not as columns) in the Estimator’s Bill of
Materials.
Answer 5D: Decoration Columns => use the Column tool
Question 6A: What is a room label?
Question 6B: How can I get the dimensions and area of my rooms?
Answer 6: by clicking in the interior of a room => the room becomes yellow => the Properties tab shows
the name, dimensions, and area fields. You can choose to show / hide this information as well as change
the name of the room => press Enter after the changes
Question 7: How to use 2 materials in one wall?
Answer 7: there are 3 methods:
- In the Trim tab => Wainscot => select the desired height => apply on the wall => texture as necessary
- If your program has the Trim Designer Power Tool, you can create a trim to fit the desired height or even
with an effect, as in this image
- If you need also two framing materials => you can stack two walls
Question 8: I am using the snap tools. Is there a way to stop the angle constraint while I am drawing?
Answer 8: Yes. Just press Shift (keyboard) while you draw
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Question 9 A: Rocks and stones as POBs are too heavy (in kb). Is there any other option?
Question 9 B: How to add people and animals?
Answer 9: There are 2 options
- In the Programs’ Files folder => Go to Embellishments => Boulder => you will find 18 bmp files already
masked => you can import them in your file using the Photo View Power Tool and this Tutorial => the
stones will appear as small boards in your design. You can also use the pictures of other stones.
- In your program, use File=> Import => Plant to library => Import the same stones described above, or
pictures of people or animals. In the floor plan, they will appear as plants, but in Live View they will look
as objects. The main advantage of this method is the fact that the plants, stones, persons, etc., will always
look at the camera. The stones and the people in this image were imported using the procedure described
above

Question 10: Is it possible to add a Crown Molding on a top cabinet?
Answer 10: Yes, it is. Just drag and drop a Crown Molding over the cabinet, as shown in the picture below.
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Go To: find more Information about Importing Images, Importing Plants and Importing 3D
Objects.
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The DXF / DWG files are drawing files originated in a CAD (Computer Aided Design) program. There are
different types of CAD files, however, in order to import a CAD file and start a project, Punch! Software
(R) only imports 2D DXF / DWG floor plans. As the CAD programs are complex and work with lots of
variables, it is not uncommon that, when users try to import a CAD file, they get a few issues.
There isn’t a unique solution covering all the issues. In addition, note that some actions are just
recommendations for better results. For these reasons, we will define concepts and review several issues.

Purpose of importing a DXF / DWG file
One of the purposes of importing DXF / DWG file to Punch is converting lines and shapes into intelligent
features => for example, a 2D line in the CAD file can be converted to a 3D wall in Punch.
Another important purpose is the exact location and dimensions of the components => for example,
location, size and opening side of doors. In addition, a precise CAD file creates an accurate Punch file.

Preparing the file to import - Recommendations
Images with black background were developed with a third party CAD program.
1 - Remove Extra Drawings: as Punch imports and uses only DXF / DWG floor plans, additional drawings
as elevations (pointed with a green arrow in the image below), cross sections, or constructive details that
are useless in this stage, can be removed in advance.
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2 - Remove Extra Plans: each floor plan should be imported as a separate file (first floor, second floor,
etc.), therefore, if you have more than one floor plan in the drawing, remove the extra plan (pointed with
a red arrow in the image below), leaving just the floor plan that you are importing to this floor.

3 - Remove Litter: Usually, when professionals are creating a DXF / DWG file with a CAD program, they
use auxiliary symbols or templates. Sometimes, part of these elements remain after the file is saved.
To visualize and remove these components => open the DXF / DWG file with a CAD program => use =>
View => Zoom => Extents (or Zoom => Fit).
In this way, the elements that are not part of the plan (litter) will be clearly visible (outlined in red in the
image below)
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In order to avoid mistakes, it is recommended that you select explode the litter before you
delete it.

Go To: find more Information about Exploding CAD elements.
4 - Remove Extra Elements: Many elements contained in a CAD plan are useful in 2D but if we import
them to Punch they don’t provide advantages to create the Punch file. The image below shows the plan,
ready to be imported to Punch. However, we can clean the elements that don’t provide clear advantages
(Unless you need them). For example, a bed or a chair: these elements can’t be converted to intelligent
entities and they don’t provide the settings’ information. Keep in mind that larger files consume more
computer resources.
So, check the plan carefully and if possible, delete the unnecessary elements: furniture, people, CAD
patterns (hatches), etc.
These elements are clearly visible in the image below:
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Deleting these elements is a custom option, however, I recommend to start with a plan containing just
the necessary elements to create a Punch file.

Go To: find more Information about Elements that can be Converted To intelligent entities
and Balancing your computer resources.
As shown in the image below, I kept the following elements: walls, doors, windows and dimensions.

HOW TO IMPORT A CLEAN DXF / DWG FILE

- 296 -

This is the result when I imported the file to Punch.

In this case, the lines can be selected and converted to walls (pointed with red arrow) using the Convert
To tool (outlined in green); imported dimension can be checked using the Punch Dimension Tools
(outlined in blue). Windows / Doors can be used as references.
5 – Final Clean: if you removed elements or parts of the CAD drawing, before you leave the program, clean
the file using Drawing Utilities => Purge (some programs name it “Clean”). You can choose the different
options, including unused layers, blocks, etc.
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The Importing Process

Notice that DXF / DW files are imported into Punch, therefore they will not open using the File
=> Open commands in the Main menu.
Let’s suppose that we have this CAD file:

To import it, use=> File => Import => DXF / DWG File => browse your computer and select the file =>the
DXF / DWG Import menu will open as per the image below)
There are three settings to manage:
- Scale (Units): by clicking on the arrow, a drop down menu will open (pointed with a red arrow in the
image below) => you can choose the desired unit (Inches, Feet, Yards, Millimeters, Centimeters,
Decimeters, or Meters). If you don’t know the settings of the original CAD file, choose the last option in
the drop down menu (Use Design’s Units) pointed with a magenta arrow in the image below).
- Explode blocks when possible: by checking this option (pointed with a blue arrow in the image below)
the program will explode the CAD Blocks before importing the file.
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Note that, if desired, you can skip this option because certain symbols can be exploded in
Punch after importing them.
- Use imported geometry’s colors: by checking this option (pointed with a green arrow in the image
below) the program will import the colors used in the original CAD file. If you don’t check this option, all
the imported lines, texts and entities will appear in a black color. Any line, text or entity can be customized
using the Draw Style Tools.

Note that, as most of the CAD programs use a black background, many elements are
developed using white color. The components that were developed in white in the original CAD file will
be imported to Punch in black color.
After the options are selected => Click the OK button (outlined in black in the image below) => the file will
appear in the workspace.

The imported file should look like the image below.
As you can see, the lines show the same colors of the original CAD file and the Punch dimensions match
the CAD dimensions (outlined in blue in the image below).
In addition, as the explode blocks option was selected, the doors (that were blocks in the original CAD file)
were imported as lines. You can see a part of the door symbol (a line) selected individually (pointed with
a magenta arrow in the image below)

Note that the exploded elements (the doors and windows in this case) can’t be grouped with
their previous properties.
However, any line, text or entity can be customized using the Draw Style Tools.
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If your CAD floor plan includes several elements in the same drawing, like electricity, topography,
etc. delete these elements in the plan that you intend to import. In this way, you will work faster in Punch.
You can create additional CAD plans with the remaining elements (electricity, plumbing, etc.) and import
them later.

Issues importing the DXF / DWG files.
The issues: below, you will find some of the most common issues found during the importing process.
- I am trying to import a CAD file, the process seems complete, but all I get is a white screen.
- When I try to import a CAD file, the program crashes
- When I try to import a CAD file, the program hangs and there is a “Not responding” notification.
- I am trying to import a CAD file, I am able to complete the process, but the plan has lots of points, circles,
lines and other artifacts.
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- I am trying to import a CAD file, I am able to complete the process, but the plan is located out of the
workspace.
- I am trying to import a CAD file, I am able to complete the process, but the plan is bigger than the
workspace.
- When I try to import a CAD file, I get an error message.
Finding solutions: these are the most common answers for the issues above.
- Check if the CAD Layers in the original file are visible and editable.
- Verify if you are using the correct scale / units.
- Check if the original file contains External References.
- Remove the litter.
- Delete unnecessary elements.
- If necessary, explode CAD blocks and patterns.
- Check the file size and balance with your computer resources.
- Clean / Purge the file.

DXF / DWG Files Definitions – To be applied (if necessary) in a CAD program
These CAD definitions are important in order to understand some of the issues. The images with black
background were developed with a third party CAD program.

Note that the symbols, colors and icons can be different for different CAD programs.
- CAD file version => the Punch programs Version 20 (for Windows) will import different CAD versions (up
to DXF / DWG V2018). Basically, this means that you can import any CAD version.

Go To: find more Information about How to find the version number of a CAD file?
- CAD External References => sometimes, draft professionals creating CAD plans connect different
drawings or previously designed blocks, so they don’t need to repeat the elements in each plan. In this
case, if a plan or block are the reference of another plan, they are called an External References (or Xref).
The External Reference is a drawing with a specific address. If you open the CAD file but the specific
address is not available, you will receive an error message.
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In this case, you must detach the External Reference.
In the image below, you can see the panel containing the Blocks (outlined in red) and External References
(outlined in green). You can select and delete the blocks “WP2” and “WP3” (pointed with red arrows) as
well as the External Reference “New Bedroom 2” (pointed with a green arrow).
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- CAD Block => in CAD a block is a set of lines or shapes that define an object. Same concept of 2D Symbols
as in Punch. The lines and elements will remain together unless you explode the block. In the image below,
the bed pointed with a green arrow, is a block.
- CAD Hatch (or Pattern) => it is an array of lines or shapes that create a design. Same concept of Pattern
as in Punch. The lines and shapes will remain together unless you explode the hatch. In the image below,
the floor representation as well as the walls’ fill (both pointed with red arrows), are patterns. Usually, in
CAD, doors, windows, plants, fixtures, etc. are blocks.

Exploding CAD Blocks and Patterns => most CAD programs include a tool called “Explode” (pointed with
a red arrow in the image below).
By using this tool, applied to a hatch or a block, you will get the lines and shapes that compose the
blocks or patterns.
For example, in the image below, the blue arrow is pointing a floor pattern. As you can see, when we
select this pattern, all the floor is selected (lines in color magenta). Now, if we use the Explode tool
(pointed with a red arrow in the image below) and we apply it to the floor pattern on the right (pointed
with a green arrow), we can see that each line is selected separately (line selected is in magenta).

Note that, if you need to delete the block or pattern but you explode these elements first,
you will need to delete each line separately.
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Units / Scale: Each CAD file includes a scale and a unit of measurements. The scale is the relation
between the drawing and the dimension in real life. The units are referred to type of dimension system
adopted (English or Metric). Usually, this information is visible in the Properties section of a CAD file.
CAD Layers: usually, DXF / DWG files are organized in layers that work like layers in a cake with different
flavors. Therefore, each layer has its own properties: name, color, line type, etc. There are 2 important
properties that can affect the importing process in Punch:

Note that not all the CAD programs have the same layers features: Visibility, Freezing, Locking
and Hiding are not the same features and they can be available or not.

1 – Layers Visibility (usually identified with an eye or a light bulb, outlined in green in the image below):
this property allows the layer visibility or invisibility. An invisible or hidden layer may compromise the
information view as well as the blocks features.
2 – Frozen or Locked Layers: a frozen layer (usually identified with a snowflake) is protected and it is not
visible. A locked layer (usually identified with a locker, pointed with red arrows in the image below) is
visible, however, the entities can’t be selected or modified.
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Verifying and balancing your computer’s settings and resources
Not all the computers have the same features, but the motherboard and memory are two very
important factors. The capability of these elements of dealing with some files can be decisive when you
are trying to import a CAD file. For example, say you import a file with lots of plants and you explode
these CAD blocks => each plant will become a group of points that are useless and the size of the file will
be enormous (in MB). In this case, probably, you will experience problems to import the file.
In addition, even if you import the file, you will need additional computer resources to create the Punch
model and render it.
For these reasons, I recommend to check your computer capabilities and delete the unnecessary
elements from your file.

How to find the version number of a CAD file? (Without a CAD program)
- Go to Window Explorer => Select the CAD file => Right click => Open With => Notepad.
- In Notepad, you will see a lot of computer language, but at the beginning, you will see a number
(outlined in red in the image).
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The number in the edited file is AC1015. So now, check this guide.

The code AC 1015 (as shown in the Notepad image) belongs to DWG / DXF Version 2000, identifying in
this way, the Version number of the file.

Return to Table of Contents
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The Punch! Software (R) programs include a Furnishing library with 3D objects as well as the 3D Workshop
Power Tool, intended to develop custom 3D objects.
Some manufacturers have their products developed as 3D objects using popular file formats like 3DS or
SKP. There are also websites offering 3D objects for free. These objects can be imported in the Punch!
Software (R) programs
Polygons: all the programs intended to create 3D objects use polygons to develop the solids => they work
with the premise that smaller polygons create more accurate and smooth objects. But this condition
means that the best objects have lots of polygons, creating the polygons Issue. If we think about the
number of faces that must be rendered in a polygon, it is easy to understand why in order to render lots
of furniture, a computer needs a lot of hardware’s resources (processor, RAM, video card, etc.).
The following sequence (images with a blue background) was developed with a third party program). It
will show how to prepare a 3D object for better results and how the polygon reduction works. This sink
developed as a 3DS file has 2270 polygons.

We can see the size of the 2270 polygons in wireframe.
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This is what happens when we reduce the number of polygons to 1000 (for example).
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The polygon reduction means that two or more polygons are grouped, creating larger polygons, therefore,
less faces to render, however the surfaces are less smooth.

As it is clearly visible, by reducing the polygons, there is not a significant difference in the rendered
object, however, as the rendering time is a direct result of the number of polygons, consider that the
size (in polygons) of the reduced sink is 44% of the full size.
Checking both models side to side in the 3D Workshop Power Tool.
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The optimum format to save the 3DS files is 3DS binary (more basic, therefore less complicated). The sizes
of the POBs (Punch! Software (R) objects) in the 3D library are => right side= 447 kb / left size 171 kb.

Return to Table of Contents
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Punch! Software (R) allows importing pictures in different formats and with different purposes. The
picture preparation is necessary in order to obtain accurate results.
PREPARING THE PICTURES – DEFINITIONS AND PROCEDURES
Quality: the pictures’ quality is measured in pixels per inch. If you have more pixels in one inch, the picture
will have a better quality; therefore the rendering will be more realistic. For rendering purposes, I
recommend 300 pixels/ inch or more.
Orientation: try to take the picture straight to the object, not from the sides.
Masking: masking a picture is process that intends to “cut” an object from the background or delete
(mask) certain elements of the image. For example: say that we want to prepare the following picture so
we can see just the yellow flower

This procedure can be performed with a number of programs. Some Punch! Software (R) programs include
a Power Tool called Photo View Editor that can be used to mask a picture. If you don’t have this tool,
there are several free image programs that can be used.
If the background of the object has just one color, several programs have a Color Change tool. For the
image above, you must select the flower => cut it from the picture => paste on a new layer.
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For masking purposes, the picture should have always a black background. The reason for
this is because Punch! Software (R) renders this exact color as transparent.
Transparency: the background must always be black RGB 0,0,0.

This is the aspect of the masked picture.
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Trim (crop): although the image seems ready to be imported, the trimming step is important. When you
import a picture, you must define the dimensions and elevation => as these are the parameters of the
entire board, you must remove all the superfluous black space by cropping a square or rectangle around
the borders of the object, following the necessary proportions.

Important: the lower part of the image must be always placed on the lower side of the new
picture.

Size (proportions): the width and height of the picture (in pixels) should follow the proportions of the
object in real life. For example, the dimensions of the statue in the following picture are Width= 60”
Height= 93”. This means that the proportions of the new picture must be H / W = 1.55.

This information is important in order to keep the shape and proportion.
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The dimensions of the cropped and masked picture are W= 968 pixels H= 1500 pixels => H/W= 1.55.
Specific proportions: for plants purposes, the images must form a square => this means that the
proportions H/W must be always 1.00. For example, if we want to use the plant on the left of this image

If the plant is wider than it is tall, in order to create the square, you should add more surface on the top
of the image. If the plant is taller than it is wide, add surface on the sides of the image => always place the
plant on the lower side of the new image.
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Above=> the picture trimmed + masked, with an added area (top) creating a square= 512 x 512 pixels.
Seam Conditions: the pictures imported as materials need certain border conditions in order to avoid
unwanted effects when they are applied as textures. The best option is a picture taken from the center of
the surface, looking straight, without shadows.

The surface to be imported (called Texture Tile) should be cropped from the picture trying to follow the
joints between pieces or the material limits.
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Notice that in the first picture, the bricks are not parallel with the border of the picture => in
this case; before you crop the tile, you should straighten the picture using any image program.

Definitions by type of insertion
Static Boards: these are the pictures imported as simple boards => their position remain stationary in the
Live View motion.
Rotating Boards: these are the pictures imported as plants => they rotate around their axis in the Live
View motion.

IMPORTING PICTURES – OPTIMIZING AND USING PHOTOVIEW
PhotoView is a Power Tool that imports pictures that will appear as Static Boards in Live View.
A common use of this feature is the possibility of importing a picture of a house and set a landscape in
front of it. However, notice that if you use this option (as opposite of creating a 3D model with the
program) the picture will be just a board, not a 3D house, therefore you can’t change materials or colors
in the picture, or add windows or doors, etc.
In order to import a picture to be used with this tool => prepare the image following the concepts of
Quality, Orientation, Masking, Trim and Size.
For example, let’s import this statue => place it inside a pool and add some landscape. In the Power Tool
Menu => Photo View => Choose the picture (already processed) => set the dimensions (as we stated the
dimensions are Width= 60” Height= 93”).
This is the rendered image:

Now, let’s check the program settings.
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2D: In the floor plan, the picture will appear just as a line, because the image is just a board in front of a
wall as seen in the following image.
Elevation: the elevation in this case is -24 because the object is on the floor of the pool (depth= 20”).
Dimensions: the picture’s width and height are the dimensions of the object => in this case, the statue’s
dimension are Width= 60” Height= 93”.
Orientation: keep in mind that we are looking at Static Boards, so in order to obtain the PhotoView effect,
the little man (Walk-Through tool) must be in front of the board, looking straight.
Otherwise, the image will be distorted as we can see in this screenshot.

The same techniques should be used to set the picture of a house, or a person, or even a pet!

Go To: find more Information about PhotoView Power Tool

IMPORTING PICTURES – OPTIMIZING AND CREATING NEW PLANTS
Using the commands => File => Import => Plant to library allow the addition of new plants to the Plants
Custom Library, starting with a picture.
In order to prepare the picture of a plant to import => prepare the image following the concepts of Quality,
Orientation, Masking, Trim and Specific Proportions.
Following the steps regarding names, plant size, soil etc., the plant will be created.
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However, although the same picture could be used for PhotoView or to create a plant, the main difference
is the fact that the plants are Rotating Boards => this means that the plants are always facing the camera.

An additional use: I use the Rotating Boards concept to create additional elements (people, pets,
statues) that are always facing the camera => this procedure is useful for 3D Walk-Through and
Animations.
Let’s place the statue (prepared as a Rotating Board) in the same scene and look from a side view.
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The statue now acts like a plant, facing always the camera, as opposite of the situation in this picture.

IMPORTING PICTURES – OPTIMIZING AND CREATING TEXTURES
Using the commands => File => Import => Material to Library, allow the addition of new textures to the
Materials Custom Library, starting with a picture. This initial picture (Texture Tile) will be repeated
covering the entire specified surface (wall, floor, etc.).
In order to import a picture to be used as texture => prepare the image following the concepts of Quality,
Orientation, Trim and Seam Conditions.
With this Texture Tile ready (image below), let’s import it.

In the Main Menu => Go to File => Material to Library => the Material Importer menu will open (image
below). This menu provides several settings and tools.
Material Preview: (outlined and pointed with yellow arrow in the image below) Shows an image of the
materials according with the selected settings. The 5 different icons allow the selection of the number of
texture tiles in order to check the seamless conditions. In the image below, I used the 4 tiles options
(fourth icon). The four tiles are pointed with blue arrows in the image below.
Seamless Options: (outlined in green in the image below) These options select the direction(s) of the
Blend Options. These options are: None, Horizontal, Vertical or Both.
Blend Options: (outlined in red in the image below) As we stated in the Seam Conditions, the perfect
picture allows a seamless texture, however, we don’t always have a perfect picture => when this happens,
use the Blend options in the Material Importer menu => using this feature, the program will soften the
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borders with different intensities, creating a more continuous material surface. You can use the default
blends (Very Low, Low, Medium or High) or select the Custom Blends.
Dimensions: (outlined in magenta in the image below) By default, the program will set the dimension of
the Texture Tile as 72”x 72”, however, one or both dimensions can be changed => the dimensions of the
Texture Tile must be the same of the dimensions of the area in real life. In this image, there are 4 bricks
+ the mortar, therefore in real life the dimensions of the area are 36” x 36” => these are the dimensions
to set the texture. If you are importing a texture with just one element (a picture, for example) => set the
dimensions as “Stretch” in both directions.
Transparency: (Outlined in brown in the image below) As we stated, the color black renders as
transparent. However, sometimes a material has real areas painted with black => in this case; black is just
a color, but not a transparency. In order to avoid the transparency effect (that will create holes in the
surface) => uncheck the option Transparent Black.
When you are satisfied with the results, you can proceed to save the new material in the desired Category
/ Subcategory. In this case, I selected “Brick”, pointed with a black arrow in the image below.
Proceed to import the new material clicking on the “Import” button (pointed with a cyan arrow in the
image below)

This is the texture applied on a wall and rendered.

SETTING, OPTIMIZING AND IMPORTING PICTURES

- 321 -

Sometimes, the imported textures need color or shadow corrections, or changes in the colors. To modify
the material or accessory, you can use the Material Editor Tool.
Material Editor: By right clicking any of the textures or accessories in the libraries, the Material Editor
feature opens, allowing the customization of the textures.

Note that the different corrections and controls of the Material Editor are not cumulative.
This means that, if you change the color of a material, you must save the new material and then open
this new material in order to apply shadows. The edited material can be saved in the desired category of
the User Library.
The Tile Preview (pointed with a blue arrow in the image below) shows the original material (tiled).
By sliding the controls, the editor screen will show the results (the green arrow in the image below).
The color / shading and gamma controls can be used separately or together by selecting the Link option
(outlined with yellow in the image below).
To keep the transparent areas of your material, select the Preserve Transparent Black option (outlined
with brown in the image below).
The new material can be flipped horizontally or vertically using the Flip options (outlined in magenta in
the image below). The Orientation can be rotated clockwise or counterclockwise as pointed with a red
arrow in the image below.
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Color / shading and Gamma controls: these controls provide color and shading adjustments as well as
Gamma correction.
The different options of can be accessed using the drop down menu, as shown in the image below.

IMPORTING PICTURES – OPTIMIZING FOR 3D BACKGROUNDS
Using the commands => File => Import => 3D Background, allows the addition of new Custom options to
the Background Library, starting with a picture.
In Punch! Software (R), the default background is a blue sky with some clouds. Although it is a good start
point, you can use your own pictures, with the image of a cityscape, your neighborhood or a park. This is
the image of a Conservation Area (picture by MLK).

SETTING, OPTIMIZING AND IMPORTING PICTURES

- 323 -

In order to import a picture to be used with this tool => prepare the image following the concepts of
Quality, Orientation and Size => Keep in mind that the picture will be stretched on the background so the
definition quality must be flawless.
Check the orientation of the picture => the camera view and the picture view must be the same.
As the 3D background import menu opens, there are options regarding the size and orientation => you
can keep the aspect ratio or you can stretch the picture. Also you can tilt the orientation.
The settings can be changed later using => 3D => 3D Rendering => rendering options.
This is the house and pool with the new background.
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EXPORTING AND PRINTING – IMPORTANT DEFINITIONS
Exporting a file: is the capability of generating a file that can be opened with another program in order to
work, print or make changes on the documents.
Printing a file: is the capability of generating a document that can be printed on a paper or developed as
an electronic file.
EXPORTING A PUNCH! SOFTWARE (R) FILE
How to Export to DXF / DWG => the exported files are 2D floor plans only that can be opened with any
CAD program.
The image below is showing a Punch floor plan, ready to be exported to DWG / DXF.

In order to successfully export the file, there are two settings that we need to analyze before starting the
exporting process:
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1 – Punch exports only the floor plan of the active floor. This means that, if your file is opened in the
first floor, for example, Punch will export only the floor plan of the first floor, independently of the floor
visibility (View All Floors or View Working Floor Only, outlined in red in the image below).

So, if you have your floor plan in the first floor and the roof plan in the second floor (for example) and
you wish to export the floor plan plus the roof plan => go to the Second Floor => select the roof plan =>
Edit => Move to Floor => First Floor => Return to the First floor => both plans (Floor plan and Roof plan)
will be in the First Floor (pointed with green arrows in the image below) => you can now export the floor
plan and the roof plan from the First Floor.
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2 – Plans Visibility and CAD Layers. When we visualize a floor plan in Punch, we have the option to show
/ hide the different tabs. This is an important setting for exporting the file because only the visible tabs
will be exported.
On the left side of the image below (white background), we can see a screenshot of a Punch program =>
the properties tab (right of the screen) shows the Floor Visible Plans panel (outlined in blue color) =>
there are two hidden tabs: Foundation (outlined in red) and Framing (outlined in green).
On the right side of the image (black background), we can see a screenshot of a third party CAD
program => opening the layers panel (outlined in magenta) we can see that the Foundation layer
(outlined in yellow) and the Framing layer (outlined in cyan) are both hidden => these hidden CAD layers
are consistent with the tabs that were hidden in the Punch file.

Therefore, it is important to analyze and select the tabs visibility in Punch according with the
desired CAD layers visibility.
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After reviewing the two items above, and if your file is ready to export => use => File => Export => DXF /
DWG => the options menu will open, showing the following options as per the image below:
Format: (pointed with a red arrow in the image) => DXF or DWG, according with your necessities and
capabilities of the CAD program that will open the new file.
Version: (pointed with a green arrow in the image) => R12 to 2018, according with your necessities and
capabilities of the CAD program that will open the new file.
Color: (pointed with a blue arrow in the image) => by checking this option, the exported file will be
created with the original colors. Otherwise, the exported lines will be monochromatic.
Fills / Patterns: (pointed with a magenta arrow in the image) => by checking this option, the exported
file will be include the fills and patterns created using the Draw Style Tools.

This is the screenshot of the exported file with colors, fills, patterns, and layers. Patterns not available in
your CAD program, will not be imported.
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Exporting to VRML => this feature exports the 3D model to Virtual Reality Model Language Version 1 =>
this means that it export the 3D model but it just includes colors, not textures. In the image below, we can
see a VRML model exported from a Punch! Software (R) file.

This is the original file that was exported to VRML.

EXPORTING 3D IMAGES

Exporting a 3D rendering creates an image of a live view visualization.
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The 3D rendered images can be exported in different formats as jpg, bmp, png, and tiff. The maximum
size of the image is related with the properties of your display. To export 3D image => visualize the image
=> File => Export => 3D Image.
Rendering settings: analyze carefully all the conditions and specify the exact parameters balancing the
elements in the scene to be rendered with the resources of your computer => unless you change the
rendering settings, Punch! Software (R) will render all the elements in the file, independently if you are
seeing them or not. This means that, for example, if you have a very complicated topography, but you are
rendering your bedroom, you can deactivate the topography while you render the interior of the house.
Or, if you are rendering your garden, you can deactivate the lights’ effects inside the house. In order to
set the visibility of the elements => go to 3D => 3D Rendering => Rendering settings => choose the desired
options or click on the Navigation and Rendering options in the Live View screen.

It is always a good idea to preview the results before exporting the final rendering.

Go To: find more Information about Rendering and 3D images
EXPORTING ELEVATIONS
Some Punch! Software (R) programs include the Elevation Editor feature, that allows views in Elevation
View mode => this tool creates a straight view of the sides of the building plus the possibility of a Custom
Angle (Pan Rotate) => notice that the Elevations are also considered 3D images, therefore all the settings
described in the Exporting 3D Images section are valid for the Elevations. To export an elevation =>
visualize the elevation => File => Export => 3D Image.

It is always a good idea to preview the results before exporting the final rendering.
The image can be exported following the same settings in any of the Rendering styles.
The text tool (outlined in black in the image below) as well as the dimension tools (outlined in blue in the
image below) are available in the toolbar.
Windows, doors and accessories (outlined in red in the image below) can be inserted directly in the
elevation => by selecting one of the elements, its dimensions and elevation can be modified.
In addition, the Draw Style Tab (outlined in cyan in the image below) is available in elevation mode. The
use of the tools of this tab allows the customization of the lines and colors of the dimensions and texts
placed in elevation mode.

Notice that, the dimensions that you place on one of the elevations will disappear if you panrotate the elevation. It will be visible again by returning to the original elevation.
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EXPORTING 2D IMAGES
Punch! Software (R) exports the floor plans as 2D images with the following formats: jpeg, bmp, png, and
tiff. They follow the same parameters of the printed plans regarding Tabs, Levels and Unwanted Artifacts.

Important: for better results, before you export the 2D image, set the screen parameters =>
Main Menu => 2D => Fit to Windows. In the exporting menu => select “Print current view only”. In this
way, just the plan will be exported, showing a better definition. Keep in mind the concepts of Fonts and
Dimensions.
The Exporting 2D images process starts with a menu (see image below) with additional settings regarding
the settings.
Format (outlined in red in the image below): there are 4 available formats => jpeg, bmp, png, and tiff.
Image Settings (outlined in blue in the image below): these settings allow the customization of the
proportions, crop of the lot and image size.
It is recommended to keep the proportionality of the plan in order to avoid distortions.
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View options (outlined in green in the image below): using these options, you can print the building,
ignoring the lot settings.
Layer Visibility (outlined in magenta in the image below): using these options, you can choose the layers
to be exported.

PRINTING
PRINTING FLOOR PLANS – DEFINITIONS
When you click File => Print => the Print Preview opens, allowing the setting of several options.
Let’s review a few definitions:
Print to Scale: this means that the elements will be printed using a definite scale, so the printed page can
be measured. This type of printed plans has a fixed size (because it follows a scale), so the paper size must
follow the plan dimension.
Fit to Page: in this case, the plan will keep the proportions and the printed plan will fit one of the sides of
the selected paper.
Print to Paper: the process of printing with a standard printer or a plotter (commercial print).
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Electronic Printing: the process of printing to a virtual printer.
Levels: the plans look clearer if you print one level at a time.
Tabs: you can print one tab or several tabs together => Example (see image below) => If you are printing
from the Floor tab and you also have elements in the Roof, and Plumbing Tabs => In the Properties tab =>
Visible plans => check the names of the plans you wish to show.

Go To: find more Information about Show / hide tabs
Fonts and dimensions: in Punch! Software (R) the dimensions styles and fonts can be customized. For this
reason, it is a good idea to check in advance how these texts will appear in the desired printed option. For
example, a certain text may appear good using the Print to Scale option, but illegible using the Fit to Page
option.
Colors: depending of the type of printer, sometimes the colors don’t follow exactly the RGB definitions.
Laser printers are mostly monochromatic. Check the colors’ definitions in advance to avoid confusing
printings.
Page Settings: different printers allow the customization of the Paper size / type (outlined in green in the
image below), Orientation (outlined in red in the image below) and Margins (outlined in blue in the image
below). Note that, depending of the printer settings, the margins can be in millimeters, inches, etc.
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Starting the Printing Process
Preview: File => Print => opens the Printing menu showing the preview image (pointed with a back arrow
in the image below) and other setting options.
Printer Setup (outlined in blue in the image below): choose the desired printer and its settings.
Page setup (outlined in red in the image below): defines the page settings.
Print Scale (outlined in green in the image below): depending of the available paper size and your goals,
you can print to scale or print to fit page. Standard printers usually allow one or two sizes of paper, so, if
you have a large plan, the best option is print to fit page. Otherwise, you will get the printing work divided
among several pages.
View Options (outlined in magenta in the image below): using these options, you can print the current
view or you can print the building, ignoring the lot settings.
Layer Visibility (outlined in cyan in the image below): as we defined in the printing tabs concept, you must
define which tabs / elements will be visible. This means that, if we are printing from the Floor tab, for
example, we can choose printing just the current layer (Floor, pointed with a brown arrow in the image
below) or printing all the visible layers (pointed with yellow arrow in the image below).

Before printing, always check the image preview, in order to visualize any printing conflict.
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A common conflict and how to solve it: the Unwanted artifacts: check all the levels and all the tabs =>
confirm if there aren’t any unnecessary objects or lines or points or other artifacts because in order to
print, Punch! Software (R) collects all the information => sometimes a forgotten object in a distant corner
creates a huge area to be printed and most of the sheets will be empty. For example, in the image below,
there is a small artifact on the right up corner (outlined in green) => this element extends the printing area
to the green lines.
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PRINTING 3D VIEWS
This option works in same way that the Exporting 3D Images feature does. The only difference is the fact
that in this case; the images are printed instead of saved.
PRINTING TO FILE (ELECTRONIC PRINTING)
Several graphic programs create files that can be used for exchange and printing. These programs install
a virtual printer on your computer, so they can be used as a Standard printer, but the result is an electronic
file.
This option can be used for printing Floor Plans or printing 3D Views and Elevations. The most common
format is PDF, which can be used for references and exchange. Also the printing companies prefer this
format for plotting purposes => there are several free programs using this format, but not all of them
allow the creation of large prints.
For Windows versions: Open your Punch! Software (R) program and your floor plan => proceed to print as
indicated for a normal printing => the Print menu will open => select your virtual printer (outlined in red
in the image below).

Usually, the PDF writers have different paper sizes (A3, A1, etc.) so, you can choose the right
paper size to fit your drawing. You can also print to PDF the live view images, however, not all the PDF
writers print the elevations
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Questions about exporting and printing
Question 1: How do I add a frame and a title block?
Answer 1: the frame can be created with the rectangle tool (Detail Tab). The ready to use title blocks (in
3 languages) are in the Templates Library.
Question 2: I am trying to print a floor plan showing the Electrical and Plumbing features, however the
program prints just the floor plan. What am I doing wrong?
Answer 2: If you are working / printing in the Floor tab => you have the option of Show / hide tabs. Just
check the names of all the tabs you wish to show / print --> For example, if you are in the Floor tab => click
on the name and select the Plumbing and Electrical tabs, so you'll see the Floor tab elements as well as
the elements in the selected tab.
Question 3: Can you tell me the difference between DXF and DWG?
Answer 3: Both are CAD files, however, the DXF format is a primitive form, defined by written entities:
actually, if you wish, you can open these written entities with a word processor. For this reason, the files
are versatile, but they are fragmented. Therefore, they are heavy in bytes. The DWG files are more
efficient vector entities, less versatile, but they are light and easy to manipulate.
Question 4: When I use the commands File => Save As, the only option is the PRO format. I’d like to save
my file as PDF. Is this possible?
Answer 4: The format of the Punch! Software (R) is PRO, and you can save the files only using this format.
However, you can print to file your documents as PDF files.
Question 5: In addition to PDF, is there another format to print to file?
Answer 5: The DWF format is an interesting option because it allows the marking and review of the plans.
Aldo, you can use the Microsoft XPS Document Writer.

Return to Table of Contents
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As stated, Real View is a tool that allows the construction of 3D scaled models. By rendering in Real View
mode, we visualize the building and the templates that will constitute the model.
The RealModel menu has several options that allow the visualization / printing of the different templates.

Menu: By using the commands => 3D => RealModel => Show RealModel => the RealModel screen with a
black background opens showing the 3D model with the templates’ numbers and the different menu
options become available. Note that the 3 visualization modes are available: Walk through, Fly around
and aerial view.
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Note that, unless you open the Show RealModel option, you can’t access to the different items
of the menu.
Model Scale: depending the intended use and units, there are 3 different type of scale. Architectural is
used for models scaled in English units. Hobby is used for models consistent with the scales commonly
used for hobbies (i.e. Model Trains). Ratio Architectural is used for models scaled in Metric units.

Printing the templates: there are 3 options to print the templates: print all the wall templates, print all
the roof templates or print the templates individually (specifying the number indicated in the yellow
labels)
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Notice that the templates are just the shapes of the different parts
Printing the textures and colors: print complete folders of the materials of the different elements
(specifying the number indicated in the yellow labels)

How to build the model?
A good option is the creation of the templates (parts) with a solid foam. The textures can be printed on a
self-adhesive paper (sheets for big labels work fine)

Return to Table of Contents
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The Ceiling Designer Power Tool is intended to develop custom ceilings, with special characteristics and
3D features.
In the main program, we have different tools to develop flat ceilings, including the auto ceiling, created
by default. If we develop a room with a flat ceiling, it will look like the image below:

In order to add a custom ceiling, the first step is disabling the auto ceiling. How to: => in the main program
=> click in the interior of the room => Properties tab => uncheck the option “Show Ceiling”.

After this, the room will look like this (The texture under the roof was added for effect):
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At this point, we are ready to develop the custom ceiling going to the Main menu => Design => Launch a
Power Tool => Ceiling Designer. The power tool opens, showing the floor plan as it appears in the in the
main program (current tab).

CREATING CEILINGS
Auto Ceiling
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By clicking on a wall, the Auto Ceiling button appears. By clicking on the button, the Auto Ceiling menu
opens so we can adjust the settings.

The default elevation is determined by the top level of the wall. In this case, the wall height is 96 and the
slab height is 4”, therefore, in this case the ceiling elevation is 100”. This value can be changed as
necessary.
The extension is the ceiling dimensions / position related with the walls’ axis. In the image above, the
walls’ thickness is 4”, therefore, if the perimeter of the ceiling matches the walls’ axis, the extension will
be 0”. If the perimeter of the ceiling matches the internal face of the walls, the extension will be -2” (image
above). ”. If the perimeter of the ceiling matches the external face of the walls, the extension will be +2”.
The extension can be changed as necessary
The Auto Ceiling has the same properties and features of the flat ceiling types.
Flat Ceilings
In this category, the main surface of the ceilings is horizontal.

In the image we can see the first four icons in the drawing bar. These tools generate horizontal ceilings
and accessories that can be combined with other types of ceiling.
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Flat Ceiling Drawing Tools
Square / rectangle tool: creates a square or rectangle, with adjustable dimensions. The drawing method
can be selected in the Properties bar (right pane). The corners can be filleted / chamfered. The curve can
be adjusted. Points can be added or deleted.
Circle: creates a circle, with adjustable dimensions. The drawing method can be selected in the Properties
bar (right pane).
Perimeter / irregular shape: this tool can be used to outline the room perimeter or create an irregular
shape. The corners can be filleted / chamfered. The curve can be adjusted. Points can be added or
deleted.
Multigon: creates a regular polygon. The number of sides is defines in the Properties bar (right pane). The
corners can be filleted / chamfered. The curve can be adjusted. Points can be added or deleted.
Flat Ceiling Properties

Note that flat ceilings can be developed also with the Floor Tool (Main program)
By selecting a ceiling, the Properties bar is activated.
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Edit Level: the flat ceiling can be edited as object or by points. As object means that the shape is
constrained, so the size can be changed but not the shape. By points means that each handle (point) can
be moved separately, modifying size and shape.
Auto Dim (on – off): shows / hides the dims in the floor plan.
Adjust curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all the
segments or just for one segment, depending of the necessities or the type of Edit Level.
Tray Height: the height of the tray is the distance between the base of the ceiling and the staring of the
horizontal plane.

Definition of tray: additional edge running in the perimeter of a ceiling, it can be vertical or
slanted.
Elevation: distance between the 0.00” level of a room / building and the lower plane of a ceiling.
Auto Elevate: adopts the default elevation.
Cutout: makes transparent the horizontal plane of the ceiling or a selected part.
Slanted: if unselected, the tray will be a vertical segment, with the defined height. If selected, the tray will
be a sloped segment, following the inset definition.
Inset: horizontal distance between the lower and the upper points of a sloped tray.
Flat Ceiling Drawing Tools
Drawing Method: by clicking on the square / rectangle icon or on the circle icons, the drawing method
options can be selected in the Properties bar.

The options for the square / rectangle tool are: rectangle starting from the top left side, rectangle starting
from center, square starting from the top left side, square starting from center.
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The options for the circle tool are: oval starting from the top left side, oval starting from center, circle
starting from the top left side, circle starting from center.
Snap Tools: the snap toolbar is on the left side of the Properties bar.

This bar provides an array of tools that allow more precision in the drawing. For example, the third tool
snaps to the center of a segment. In order to use these tools, the shapes must be edited by points.
Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.

Select the desired tool and apply on any straight line on the perimeter of the shape. In order to use these
tools, the shapes must be edited by points.
Chamfer / Fillet corners: these tools chamfer or fillet corners.
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Select the desired tool and apply on any standard corner on the perimeter and drag to the interior of the
shape. In order to use these tools, the shapes must be edited by points.

EXAMPLES - FLAT CEILING TYPES
Tray ceiling with slanted tray

Tray ceiling with vertical tray
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This is how the room looks with a slanted tray. See the difference with the room with a flat ceiling.

Tray ceiling with horizontal cutout
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Non-Flat Ceilings
In this category, the main surface of the ceilings are three dimensional.

In the image we can see the last five icons in the drawing bar. These tools generate non - flat ceilings and
accessories that can be used alone or combined with other types of ceiling.
Non-Flat Ceilings - Properties
The properties of these drawing tools are different from the properties of the flat ceilings.
=> Edit: the shapes and parts cannot be edited.
=> Points: it is not possible to add or delete points.
=> Curves: it is not possible to adjust the curve .
=> Fillet / chamfer: it is not possible to fillet / chamfer the shapes.
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=> Dimensions: the dimensions and pitches of the shapes are shown in the Properties bar and can be
modified.
=> Use of the shapes: these shapes can be used as full ceilings (covering all the room) or as partial units,
covering a cutout section.
=> Ends: the gable ceiling and the barrel ceiling can be developed with or without the vertical closing
pieces.
=> Direction changes: The ridge direction (gable ceiling and hip ceilings) and barrel ceiling direction can
be changed orthogonally as well as the pitch direction in the ceiling beams. There is a specific button for
each type in the Properties bar.

Non-Flat Ceilings - Drawing Tools and Examples
Gable Ceiling: this tool creates a sloped ceiling, pitched in two directions.
In the image below, we can see a gable ceiling developed over a flat ceiling cutout section. The pitches
can be selected in the Properties bar and they will appear in the plan (outlined in magenta). The direction
of the ridge (pointed in red) can be changed orthogonally. The ends of the gable are present (pointed in
green). The elevation point of the ceiling is pointed in blue.

Hip Ceiling: this tool creates a sloped ceiling, pitched in four directions.
In the image below, we can see a hip ceiling developed over a flat ceiling cutout section. The pitches can
be selected in the Properties bar and they will appear in the plan (outlined in magenta). The direction of
the ridge (pointed in green) can be changed orthogonally. The elevation point of the ceiling is pointed in
blue.
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Barrel Ceiling: this tool creates a ceiling shaped as a circular arc.

In the image above, we can see a barrel ceiling developed over a flat ceiling cutout section. The height of
the barrel will define the curvature. The direction of the barrel (pointed in blue) can be changed
orthogonally. The ends of the barrel are present (pointed in green). The elevation point of the ceiling is
pointed in red.
Dome ceiling: this tool creates hemispherical shaped ceilings
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In the image above, we can see a dome ceiling developed over a flat ceiling cutout section. The height of
the dome will define the curvature (pointed in green). The elevation point of the ceiling is pointed in blue.
Ceiling beams: this tool creates flat or pitched beams

In the image above, we can see flat beams developed below a flat ceiling. The dimensions of the beams
can be adjusted in the Properties bar (pointed in green). The elevation point of the beams is their base
(pointed in blue).

In the image above, we can see flat and pitched beams developed below a gabled ceiling. The dimensions
of the beams can be adjusted in the properties bar. The elevation point of the beams is their base (pointed
in red). The pitch is selected in the Properties bar (pointed in blue). The direction of the pitch can be
modified from the Properties bar (pointed in green).

ADDITIONAL TOOLS AND COMMANDS
Left Top Tools
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These tools are screen helpers. Described from top to bottom.

Arrow – Move / Resize / Select Tool: This tool is used to:
=> Move: point the entire object / shape in order to select it => move it manually to a different location.
=> Resize: point a corner of the object / shape in order to select it => drag the point to the new position
in order to edit the object.
=> Select: used to select elements => pointing the entire object / shape => or pointing a corner of the
object / shape (fillet / chamfer) => or in edit by Points mode, pointing one or several segments.
Resize segment (arrow with the # sign): Select the tool => select a ceiling => use edit by points mode =>
select a segment => write the new length => OK.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Zoom: by clicking the Zoom tool (magnifier icon) and keeping the left button down, you can increase or
decrease the distance to the object. By dragging it to the right, you will decrease the distance, therefore
you can get a closer look at the object (Zoom In). By dragging it to the left, you will increase the distance,
therefore you can get a distant look at the object (Zoom Out).
Pan: by clicking the Pan tool (hand icon) and keeping the left button down, you will be able to drag the
screen and move around in the workspace following the desired direction as you move the ”hand”.
Main Menu
File Menu: closes the Power Tool, returning to the main program. Confirm the changes.
Edit Menu
Undo: reverses the last X actions (X is the number of instances, according with the Undo Preferences).
Redo: reverses the undo command.
Undo Preferences: defines the number of Undo instances. The default number is 25, and the maximum
number is 50. There is an option to disable the Undo command, making the Power Tool operation faster.
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Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Select All: selects all the elements in the workspace.
Nudge: if the snaps are deactivated, use this command for movements

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
The snap movements are commanded only with arrow keys. The Nudge movements are commanded with
the arrow keys as well as using the following commands in the Main menu=> Edit => Nudge => Up / Down
/ Left / Right. The settings of the distance between the grids and the nudge distance are defined in the
Grid Properties Menu.
Move: allows the movement of the elements an exact distance
Rotate: activates the Rotate tool.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.
Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
Align to Grid: using this tool, the objects can be aligned to the closer gridline, in the desired direction.
Set Object Elevation: opens the elevation menu, to manually set the desired elevation.
Design Menu
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Auto – Elevate Settings: activates the Auto Elevate Settings Menu, allowing to determine the elevations’
parameters

Set Working Elevation: setting of the desired working elevation
2D Menu
Refresh: refreshes 2D screen.
Reset Plan View: resets the view to default.
Set Plan View Zoom: controls the zoom level numerically.
Fit to Window: zooms the drawing to fit in the screen.
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below.

The space between the lines or points is defined in the Grid Spacing section. The Snap Grid defines the
interval in the movements using the arrows of the keyboard.
Grid Visible: toggles on / off the grid visibility.
Snap to Grid: toggles on / off the snap to grid feature.
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Automatic Dimensioning: customization of the dimensions’ visibility.
Window / Door Callout: customization of the Windows and doors dimensions’ visibility.
Show Virtual Ruler: visibility of the virtual ruler which is a drawing help tool that allows taking
measurements on screen.
Drawing color: customizes the drawing colors for the tool.
Reset Drawing Color: sets the color back to the default color (RGB 0-121-242).
3D Menu
Reset 3D View: resets live view to the default parameters.
Clear View: sets the rendering mode to clear view, showing the object faces as semitransparent and the
edges of the object / shape as lines.
3D Viewing Method: sets the desired live view method: walk –through or fly around, and defines the
elevation for these options.
3D Lighting: light parameters for live view.
Rendering Options: opens the rendering options menu.

As in the main program, you can show / hide elements in live view as well as set the quality. These tool
settings are just for the tool use.

Go To: find more Information about Rendering Tools
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Window Menu
Layout options for the 2D / 3D screens.
Elevation Slider
Located of the left side of the screen.

By selecting any element (ceiling, beam, etc.) and right clicking on the Elevation slider => the elevation
menu opens, as shown in the image above.
Set elevation: opens the elevation menu, to manually set the desired elevation. If desired, the elevation
can be changed also by moving the slider up (to increase the elevation) or down (to decrease the
elevation).
Auto Elevate Ceiling: adopts the default elevation.
Auto Elevate Settings: opens the Auto Elevate Settings menu.

TEMPLATES
The templates bar is located on the right side of the screen, is the second tab below the Properties bar.
By clicking on the tab name, the menu opens allowing the selection of the templates of the different types
of ceiling.
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Applying a template
By selecting a category, the library for that category opens, showing the available templates for the
selected category.
For example, the Coffered category has two templates: in order to apply the template => select the desired
model in the library => drag and drop on the floor plan => if necessary, adjust position, dimensions,
elevation, etc.

Creating a template
This feature allows to save a ceiling design as a template that can be retrieved and used in other projects.
In order to create a new template => select all the elements => template tab => create a template =>
choose the category and name.
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Questions about this tool
Question 1: Is it possible to add a texture to a ceiling created with the Ceiling Designer Power Tool?
Answer 1: Yes, it is possible to add colors and textures. After the new ceiling is created, return to the main
program in order to add colors or textures.
Question 2: I created a barrel ceiling, and I’d like to use it as a roof. Is it possible to change the thickness
of the ceilings created with the Ceiling Designer Power Tool?
Answer 2: It is not possible to change the thickness of the ceilings created with the Ceiling Designer Power
Tool.
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The 3D Workshop Power Tool is a real 3D factory where you can create or modify almost any type of
Punch object. In order to take advantage of all the features, it is necessary to understand how it works as
well as all the tools and tricks.

Remember: the 3D Workshop works differently and has different features from the main
program. For this reason, try to become familiar with the commands and the Power Tool’s concepts.
As we open the 3DW Power Tool, we see the Main Screen.

The interface is composed by the grids (Workspace) , the toolbars, the Properties bar and the Main menu
THE GRIDS (WORKSPACE)
Grid Selection: the Grids can be selected using the Grid Selection bar
using the options in the Main Menu => Design.

as well as

In the Main Screen image we can see the 3 grids marked with circles.
The Front Grid, marked with a red circle, is the first icon in the Grid Selection bar
The Floor Grid, marked with a green circle, is the second icon in the Grid Selection bar

3D CUSTOM WORKSHOP POWER TOOL

- 362 -

The Side Grid, marked with a blue circle, is the third icon in the Grid Selection bar
When we select a grid, the icon becomes green and the scale of the grid (blue squares) becomes smaller.
In order to insert a shape, line or solid, you must select a grid as starting point. In the Main Screen image
we can see that the Floor Grid is selected.
Grid View: independently of the selected grid, the workspace can be visualized in different view using the
View bar.

It is outlined in brown in the Main Screen image, showing the 3D View (first tab).
In addition to the 3D and 2D views, it includes the 2D Profile Tool that defines the 2D symbol of the object
as it will appear in the Floor Plan (Main program)
Regarding the 2D views, there are 6 different options: Top, Bottom, Front, Back, Left and Right, as shown
in the images below
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The Grids’ Directions: the elements placed in the workspace can be moved up / down; left / right; front /
back. These are the general directions of the 3D Workshop Power Tool.
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Note that, independently of the selected grid or the selected view, the element can be moved
following the directions in the image, using the Move command.
The Grids’ Properties: the workspace contains 3 grids, that can be made visible or not, by selecting the
option. The grids’ properties can be defined in the Grid Spacing Menu or with the individual options that
can be accessed using the Design option of the Main Menu (outlined in red). Also, by clicking in the last
icon of the Top - Left Toolbar.

The default dimensions of the grids (outlined in green) are Width= 360”, Height 180”and Depth 360”.
These dimensions can be changed to other values, and the objects constrained to these boundaries as
shown in the image. The default distance between the gridlines (the lines that create the grid, outlined in
brown) is 12”. The default Snap to Grid distance (outlined in blue) is 12”. The default nudge distance
(outlined in yellow) is 1”, however the new versions allow 3 default distances that can be selected as
necessary.

THE TOOLBARS
TABS BAR
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This bar is located at the right of the workspace
The Properties Bar
This tab is activated when an element is selected and several functions are activated.

Move to Layer: by selecting an object, the name of layer where the object is located appears (outlined in
black in the image) => by clicking on the Move to Layer button, the object can be moved to another layer
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Type of Polygon / Shape selector: the polygon / shape can be Open (in green) or Closed (in blue)

Texture Mapping and Shading: these parameters determine the aspect of the texture applied. The
settings must be adjusted according with the texture applied
Type of Cap Selector: the polygon / shape can be Capped (in blue) or Uncapped (in red)

Adjust curve: this setting adjusts the tension of the curve. In the image, we have a polygon with 12 faces
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The Curve tension can be adjusted for all the segments or just for one segment, depending of the
necessities or the type of Selection.
By selecting the all the polygon’s faces and adjusting the Curve tension appropriately, a 2D polygon can
be converted to a circle. By selecting the all the polygon’s faces and adjusting the Curve tension
appropriately, the 3D polygon can be converted to a cylinder.

Resize Object button (Opens the Resize Menu) (outlined in red in the Properties bar image): this feature
allows the setting of the exact dimensions (Width, Height, and Depth) or percentage of the object or part
of it as well as the reference point of the dimension.
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Move Command (outlined in blue in the Properties bar image): allows the movement of the object an
exact distance in the desired grid and direction

Important Notes: in order to set the exact movement: write the desired distance in the correct
grid, adding the + or – sign as shown in the grid direction image =>don’t forget to press Enter after each
input, so the change takes effect.
Translucency button (Opens the Translucency Menu) (outlined in green in the Properties bar image): this
feature allows the setting of the desired level of translucency in the object. An object with translucency=
100% is transparent, therefore it is not visible.
Cabinet Cutout: create a 2D shape => select the Cabinet Cutout option, at the bottom of the Properties
bar => Save to the User Library => this shape, applied on a cabinet counter (created with the Cabinet tool)
will create a cutout => don’t forget to use the same elevation of the counter.

Layer Tab

Layer (definition): in the 3DCW, the layers work like overlying elements that can be shown or
hidden as desired.
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Active Layers: this command shows the names of the layers with contents.
Show / Hide layers: these buttons allow the possibility of showing / hiding all the layers (with their object).
New: by clicking on this button, a new layer can be created and named. The layers’ list is shown below
with the visible layers marked with an asterisk.
Show / Hide: these buttons allow the possibility of showing / hiding the layers selected in the list, with
their objects.
Rename: the layer name can be modified by selecting a layer in the list and using the rename button.
Remove: a layer can be deleted by selecting a layer in the list and using the remove button.
Furnishing Tab
This tab contains all the elements included in the Furnishing / 3D Objects Libraries.
Materials Tab
This tab contains the Materials’ libraries: the materials can be applied following the application options,
which may vary for the different programs.
Paint Colors Tab
This tab contains the Paint Colors’ libraries: Custom Colors, Color Ramp and Paint Library. The colors can
be applied following the application options, which may vary for the different programs.
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Applying materials / colors / 3D Effects - different options: depending of the program and
version, there are different options to apply materials or paint colors.
As we click on the application button, a drop down menu opens:

=> Apply to single pane: the texture / color is applied to a single face of the object.
=> Apply Wrap Segment: the texture / color is applied to a single segment of the object.
=> Apply Wrap: the texture / color is applied to all the segments
=> Apply To Entire Group: the texture / color is applied to all the elements of a Group.
=> Apply Matching: the texture / color is applied to all the elements with matching texture / color.
Example: all the elements painted with color blue can be textured with brick in just one step.
=> AutoClick Placement: by selecting this option, the desired material / color remains selected until it is
deselected by right clicking. This option is useful to texture / paint a number of faces of an object. For
example, if you have an object with 20 faces but you want to use a texture / color on 5 faces => select
AutoClick Placement => select the texture / color => apply on the desired faces => click the right button of
the mouse to deselect the option.
Palette Tab
This tab contains the Decorator Palette, as created in the hub of the Main program
3D Effects Tab (For the Architectural Series Program)
This tab contains the 3D Effects library. The effects can be applied following the application options,
which may vary for the different programs.
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Go To: find more Information about the Decorator Palette and 3D effects

THE LOWER LEFT CORNER TOOLS
The toolbar located in the lower left corner includes four tools that are related with the view and
generation of the elements.

From left to right:
Starting point of a drawing (the tool toggles between the options): in order to draw a shape (rectangle,
circle, etc.) we can start from a corner or from the center. Each option is useful in different situations. For
example, the drawing from center option is a good solution when we need to draw concentric objects.

Selection Mode (the tool toggles between the options): if we are working in Wireframe mode, there are
two selection modes: by the object’s boundaries or by points.
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The option by boundaries selects the entire object, so any modification will affect the entire shape or
object. The option by points selects the object’s handles in the entire element or one point or one side.
By right clicking any element selected (totally or partially) by points, we have further options (in addition
of the standard Cut – Copy – Clear)
Center on Object: sets the Zoom and the Rotation Origin Point on the selected segment. In this image,
the point is outlined by the green star.
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As we can see, it is located out of the object. Therefore, as the chopper will fly – around the point, it will
fly out of the object. In order to fix this issue => select the object => right click => Center on Object => the
Rotation Origin Point will be centered on the object (outlined in green)
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Defining the Rotation Origin Point: The Rotation Origin Point is the Center of Reference of
the Fly–Around Tool (Chopper). This means that the Chopper flies around of this point. To set the
Elevation of this point, you can use: Main Menu => View => Set Rotation Elevation.

Go To: find more Information about the Fly–Around Tool
Select All: selects all the object.
Select Object Points: selects all the points of the object.
Add Point: adds a point in the place where the mouse is placed. (2D shapes)
Delete point: this option is activated if just one point is selected and deletes this specific point (2D shapes)
Select Segment: selects a segment.
Move to layer: Moves the entire object to the selected layer
Rendering style (the tool toggles between the options): in order to visualize or edit an object or shape,
there are two options: the Materials and Colors style presents the object / shape as a solid. All the faces
accept textures (materials) or colors, as well as shading and 3D effects and reflections (for the programs
that include these features).
The Wireframe style shows the object / shape as a transparent element composed by lines (edges of the
object / shape) and points (vertexes of the object / shape). This style is required in order to edit the curves,
forms, add points, delete points, modify the position of one or more points and change the shape and /
or dimensions of a group of points.
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Viewing Options (the icon opens a menu, as shown in the Lower Left Corner tools image): some of the
options in the menu are the same presented in the View Bar: they are Top, Bottom, Front, Back, Left and
Right Views. There are additional options:
3D Style: there are two options: Perspective and Orthographic. The 3D perspective view is the usual 3D
view of the object plus some grid space. The 3D Orthographic view is more focused in the object
Reset Scroll / Reset View: These options are convenient to return to the default view after the
modifications, different views, movements, etc.
Move to Layer: Moves the entire object to the selected layer
Rotation Origin Visible: selecting / unselecting this option, makes the Rotation Origin Point visible or not.
Edit 2D Profile: this option activates a tool that allows the modification of the 2D Profile.

Defining the 2D profile: the 2D profile is the 2D symbol of the top view of the object in
Wireframe mode showing the representation of the element in the Floor Plan (Main Program)
As default, the program will generate a 2D profile using a top view of the object, in Wireframe mode,
including all the lines and elements. If the object was developed with many lines, curves and polygons,
the symbol doesn’t represent the object. In the image we can see a table (rendered in 3D at the left) and
the unedited 2D Profile at the right.
As we can see, the symbol on the right barely represents the table on the left.

By selecting the Edit 2D profile option, we can select any line or element (outlined in red) in order to use
the tools in the Properties bar (outlined in blue) or to modify the position or the lines using different snap
options (outlined in green) as well as delete or change the segments.
Additional options for this tool can be found in the Main Menu => View => 2D Profile.
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The Top – Left Toolbar
This toolbar contains 10 tools, all of them are very important.

Tip: in addition of the Move / Resize / Select, the first tool (Arrow) can be used as “escape” tool
=> by selecting any element => select the arrow and click on a grid => the object will be unselected.
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Arrow – Move / Resize / Select Tool: This tool is used to:
=> Move: point the entire object / shape in order to select it => move it manually to a different location in
the workspace.
=> Resize: point a corner of the object / shape in order to select it => drag the point to the new position
in order to resize the object.
=> Select: used to select elements => pointing the entire object / shape => or pointing a corner of the
object / shape => or in Selection by Points mode, pointing one or several segments.
=> Select to Apply: point a Material or Color => drag to apply on the object / shape.
=> Select to Open / Toggle: point any tab or icon to open or toggle between options.
Select In Polygon: this tool allows the selection of a group of points by creating a polygon (lasso) around
the desired points. The polygon is created with dashed lines, as shown in the image. Note: this tool works
only with Wireframe plus Selection by Points modes.

Rotate: this tool is used to rotate an entire polygon, a shape or a group of points. Select the desired
elements => double click the rotate icon (or use Main Menu => Edit => Rotate) => write the desired angle
and sign => the (-) sign rotates clockwise and the (+) sign or no sign rotates counterclockwise.
Also, by clicking the rotate icon once, the cursor appears as a rotate symbol => select a point (handle) and
rotate the object manually.

Note: the elements always rotate parallel to the selected grid
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Skew: this tool is used to obliquely distort an object / shape. The distortion can be horizontal or vertical.
Select the desired element => double click the skew icon => write the distance in the desired direction =>
the signs follow the general directions of the 3D Workshop Power Tool.
Also, by clicking the Skew icon once, the cursor appears as a skew symbol => select a point (handle) and
skew the object manually.

Note: the elements always skew parallel to the selected grid. In the image below, the Floor
Grid is selected.

Extrude: this tool is used to project a 2D shape and create a 3D solid. Draw a shape => double click the
Extrude icon (or use Main Menu => Edit => Extrude) => write the desired distance and number of
segments. This means that if you wish to extrude 36”, you can extrude 1 segment with 36”or 3 segments
with 12”. The segmented option is useful if you need to edit or resize the intermediate points (red arrows
in the image below). Note: in order to select the intermediate points, use the Wireframe plus Selection
by Points modes.
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Also, by clicking the Extrude icon once, the cursor appears as an extrude symbol => select a point (handle)
and extrude the object manually.

Note: the elements are always extruded perpendicular to the selected grid as detailed in the
images below.
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Pan: by clicking the Pan tool (hand icon) and keeping the left button down, you will be able to drag the
screen and move around in the workspace following the desired direction as you move the ”hand”.
Zoom: by clicking the Zoom tool (magnifier icon) and keeping the left button down, you can increase or
decrease the distance to the object. By dragging it to the right, you will decrease the distance, therefore
you can get a closer look at the object (Zoom In). By dragging it to the left, you will increase the distance,
therefore you can get a distant look at the object (Zoom Out).

Dynamic Zoom: you can Zoom In / Out during your work using the mouse wheel (up: zooms in
/ down: zooms out, depending of your mouse configuration)
Fly-Around (Chopper Tool): this tool is used for 3D visualization. It considers a viewer located on a
helicopter flying around the Rotation Origin Point. As stated, to set the Elevation of this point, you can
use: Main Menu => View => Set Rotation Elevation.
Toggle Snap to Grid (the tool toggles between the options): this tool activates / deactivates the Snap to
Grid feature

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
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12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
The snap movements are commanded only withe arrow keys. The Nudge movements are commanded
with the arrow keys as well as using the following commands in the Main menu=> Edit => Nudge => Up /
Down / Left / Right. The settings of the distance between the grids and the nudge distance are defined in
the Grid Properties Menu
Grid Properties: shows the Grid Properties Menu.
The Top Right Toolbar
This toolbar contains 11 tools. These features are useful to create or edit complex or multipart objects.

Group / Ungroup: the group tool assembles the selected parts, creating a new object.
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In the image above, on the left, we have the blue object and the red object: the objects are separated
entities that can be moved, resized, rotated or modified separately. So, the blue object and the red object
are ungrouped. Note that the each object shows its own contour.
If we select the blue object and the red object and we click on the group tool, the program creates a new
object, as the yellow object that we can see at the right. The change in the color is not automatic, it was
created for learning purposes. The parts aren’t separated entities and can’t be moved, resized, rotated or
modified separately. So, the yellow object is a group. Note that there is just one contour for the entire
object. If we select the yellow object and we click on the ungroup tool, the program creates separated
objects, as the blue object and the red object that we can see at the left.
You can also use the group / ungroup commands located in Main Menu => Edit.
Lock / Unlock: the lock tool freezes the objects properties and makes the object immovable regarding its
position in the workspace. By selecting one or more objects / shapes and clicking on the lock tool, the
elements will become “frozen”. By selecting the locked objects and clicking the on the unlock tool, the
objects return to their normal properties. You can also use the lock / unlock commands located in Main
Menu => Edit.
Hide Detection / Detect All: by selecting an object or a part of it (using the Wireframe plus Selection by
Points modes) and clicking on the hide detection tool the elements can’t be selected. The remaining
elements and points can’t be selected and modified, as shown in the image.

By pointing the object (even if you don’t see the detection) and clicking the Detect All tool, the objects
and points can be selected normally. This tool is useful to modify a part of the object, keeping the
remaining part without changes. You can also use the detection commands located in Main Menu => Edit.

3D CUSTOM WORKSHOP POWER TOOL

- 386 -

Mirror Horizontal / Mirror Vertical: By selecting a shape or object and clicking on one of the mirror tools,
the object will be duplicated in the selected direction. You can also use the mirror commands located in
Main Menu => Edit.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
In the image below, the blue shape is the original element. The green shape is the blue shape mirrored
horizontally. The red shape is the blue shape mirrored vertically.
The change in the color is not automatic, it was created for learning purposes.

Flip Horizontal / Flip Vertical: By selecting a shape or object and clicking on one of the flip tools, the object
will be reversed in the selected direction. You can also use the flip commands located in Main Menu =>
Edit.
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Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.
In the image below, the outlined shape was the original element. The green shape is the original shape
flipped horizontally. The red shape is the original shape flipped vertically.
The change in the color is not automatic, it was created for learning purposes.

Duplicate Properties: this command should be understood as “Copy with Properties”. By selecting an
object /shape and clicking the duplicate properties tool, we can copy the object a predetermined number
of times and separate the copies a predetermined distance. You can also use the duplicate command
located in Main Menu => Edit.
As we click the duplicate properties tool, the duplicate properties menu opens making possible the setting
of the distance between the new shapes (in both directions) as well as the number of copies.
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The distance between the copies is the distance (vertical or horizontal) between the first corners on the
left of the objects / shapes.
In the image below, the blue square (selected) is the original shape. In the duplicate properties menu, we
set a distance of 50” (horizontal, marked with a red arrow in the image) and 0” (vertical). The repetition
set is 4. This means that the 4 green squares of the object will be created with a horizontal distance of
50”between the left corners, but without any vertical dislocation.
The change in the color is not automatic, it was created for learning purposes.

THE MAIN MENU
The Main Menu has 6 submenus that include several commands
File menu
New: starts a new instance with an empty workspace.
Open: opens a new POB (Punch! Software (R) Object)
Close: closes the current instance on the tool.
Save: saves the object with the current modifications in the current computer location.
Save As: saves the object with the current modifications in a different computer location.
Save to Object Library: saves the object with the current modifications to the User Library.
Save to Component Library: saves the object with the current modifications in a Component library.
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Export 3D: saves the 3D image of the object as jpg, bmp, etc.
Export: saves the object using the formats of previous versions of the 3D Custom Workshop program. The
files can be exported to 2D / 3D using the DXF and DWG formats.
Exporting to 2D 3D DXF: this command will export a 2D CAD wireframe image of the object that can be
opened and edited with any 2D CAD program.

Exporting to 3D DXF: this command will export a 3D CAD wireframe object that can be opened and edited
with any 3D CAD program.
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Note that the object will be exported as it appears in the 3D Workshop Power Tool screen.
Printer Set Up / Print: setting and commands for printing the elements
Exit: exits the power tool, returning to the main program.

Questions for the File menu:
Question 1: What is the different between a 3D object and a component?
Answer 1: a 3D object is a solid without properties. A component is solid that adopts the properties of the
category where it is saved. For example: if you develop a toilet and save it to the object library, it will be
become just an object, like a chair or a table. But if you save it to the Component library as a toilet, it will
have the same properties of the toilets in the Plumbing Tab (Main program).
Question 2: Can I save my POB (Punch! Software (R) Object) using other 3D formats?
Answer 2: there are additional options to export the objects to CAD.
Question 3: Is it possible to import 3D objects in other formats and edit them using the 3DCW Power Tool?
Answer 3: Yes, it is possible to import 3DS files to the main program and then, open the files using the
3DCW Power Tool.

Go To: find more Information about Importing Objects

EDIT MENU
Undo: reverses the last X actions (X is the number of instances, according with the Undo Preferences).
Redo: reverses the undo command.
Undo Preferences: defines the number of Undo instances. The default number is 100, and the maximum
number is 150. There is an option to disable the Undo command, making the Power Tool operation faster.
Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Group / Ungroup: as described for this tool in the toolbar.
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Lock / Unlock: as described for this tool in the toolbar.
Flip: as described for this tool in the toolbar.
Mirror: as described for this tool in the toolbar.
Hide Detection / Detect All: as described for this tool in the toolbar.
Select All: selects all the elements in the Workspace.
Duplicate: as described for this tool in the toolbar.
Nudge: as defined for this tool.
Revolve: the revolve tool creates solids by rotating a shape around an axis.

The difference between Rotating and Revolving: by selecting a shape or an object and using
the Rotate tool, the object or shape will rotate itself parallel to the selected plane. By selecting a shape
and using the Revolve tool, the shape spins around a virtual axis, but the spin is perpendicular to the
selected plane.

In order to create a solid using the revolve tool, some parameters must be defined.
=> The shape: the revolve tool works only with shapes (not with objects) so the first step is the definition
of the shape that is going to spin. Any shape in the 2D Drawing Tools can be used. The image below shows
different options using a semicircle.
=> The grid: the shape and the axis must be inserted in the grid that define the revolving plane.
=> The radius: the radius is the distance between the shape and the spinning axis.
=> The angle: measures (in degrees or radians) the angle between the initial and the ending positions of
the spin.
=> The angle sign: negative angles create concave objects and positive angles create convex objects.
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Align Objects: using this tool, two objects can be aligned following the following parameters: Top,
Horizontal Center, Bottom, Left, Vertical Center, Right, Back, Depth Center and Front.
In this image, we can see 4 objects.
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These are the same objects aligned to the Front.

Extrude: as described for this tool in the toolbar.
Rotate: as described for this tool in the toolbar.
Align to Grid: using this tool, the objects can be aligned to the closer gridline, in the desired direction.

DESIGN MENU
Draw on Floor Grid (X - Z Axis): selects Floor Grid as working grid, following the general grid directions.
Draw on Front Grid (X - Y Axis): selects Front grid as working grid, following the general grid directions.
Draw on Side Grid (Z - Y Axis): selects Side grid as working grid, following the general grid directions.
Grid Properties: activates the Grid Properties Menu.
Grid Visible: toggles on / off the grid visibility.
Snap to Grid: toggles on / off the Snap to Grid feature.
Active Layer: shows the name of the active layer.
Visible Layers: allows show / hide all the layers.
Align, as shown in the Layers tab.
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Image Trace Properties: this option allows to import and trace any image (jpg, bmp, etc.) and trace the
shape in order to create an object. The images don’t need any special preparation, however, for a better
manipulation, I’d recommend to trim the object.

Note: in order to visualize and trace, you must set the rendering style as Wireframe and the
2D grid view.
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In the image above, we set an image for the Floor Grid, so this image will be visible only on Wireframe
rendering mode and Top grid view.
Note that the size of the image must resemble the real size of the object, however, you can use a larger
size for a better definition and resize the object after completion.

OPTIONS MENU
This menu includes 12 commands.
Object Size: opens the resize menu.
Object Translucency: sets the translucency levels.
Planar / Surface Mapping: setting of the texture mapping and shading.
Object / Point Selection: defines the selection mode.
Draw from Center / Draw from Center: defines the starting point of a drawing.
Curve Smoothing: setting of the curve smoothing levels for a shape.
Precision: by default, this tool works with the same units and precision determined in the hub (main
program), however, this option opens a menu that allows the selection of a new precision setting within
the measurement units (English or Metric).

Rotation Origin Visible: selecting / unselecting this option, makes the Rotation Origin Point visible or not.
Custom Options: this command opens a menu that includes several options to customize the use and
appearance of the 3DCW.
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=> Smoothness and sensitivity: these controls define the quality and definition settings. Note that more
quality consumes more computer resources
=> Point handles: defines the size of the points in the screen.
=> Multigon Tool -# of sides: defines the number of sides when you draw a polygon.
=> Auto Reset Tools: if selected, allows an automatic reset view.
=> Start in Wireframe: if selected, the 3DCW starts in Wireframe mode.
=> Auto Update 2D Profile Size: automatic update of the size of the 2D Profile.
=> Colors: definition of the colors for the different elements.
View menu
This menu includes 17 submenus
Reset view: resets the view to default.
Reset Scroll Position: resets the 2 scroll bars (horizontal and vertical) to the center position.
Auto Display Properties: if this option is on, each time that an object is selected the Properties Tab opens
automatically.
2D Design Tools: opens the 2D Design Toolbar.
3D Design Tools: opens the 3D Design Toolbar.
3D CUSTOM WORKSHOP POWER TOOL

- 397 -

Toolbars: shows / hides the grid view Toolbar.
Render 3D Final Quality: renders the objects in the workspace with the selected quality.
3D Final Quality: selection of the desired quality for final rendering: Low (fast), High (moderate), Ultra
High (slow) or Excellent (very slow).
3D Rendering Style: selection of the desired type of rendering. This command offers 3 style options:
=> Shaded Style: showing all the colors and textures (this style is also called Materials and Colors)
=> Wireframe: as previously described, this style shows the object / shape as a transparent element
composed by lines (edges of the object / shape) and points (vertexes of the object / shape).
=> Clear View: shows the object faces as semitransparent and the edges of the object / shape as lines. The
colors can be customized in the Custom Options menu.
The two first styles can be selected also using the Rendering style button (Bottom left tools).

3D Camera Angle: selects the different camera orthogonal positions for 3D.
3D lighting: defines the light intensity for the scene.
View in Perspective / View in Orthographic: definition between 3D perspective, using the fly around tool
and 3D orthographic (the 3 angles are fixed)
Set Zoom: controls the zoom level numerically.
Set Rotation Elevation: defines the elevation of the Rotation Origin Point for the Fly – Around Tool
2D View: using this command can be selected one of the six 2D views as detailed in the grid view Toolbar.
2D Profile: opens the 2D Profile Tool in order to edit the 2D Profile as detailed in the grid view Toolbar.
In this location, there are 3 additional commands:
=> Edit 2D profile: this option activates a tool that allows the modification of the 2D Profile.
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=> Auto generate 2D profile: automatically creates the 2D Profile.
=> Show 3D objects: this option shows / hides the 3D internal components of the object in the 2D symbol,
on order to create a clear shape, as shown in the image.

DRAWING TOOLS AND ACCESSORIES
2D Drawing Tools
The 2D drawing tools are a group of shapes and lines that can be selected, combined and used as they are
or they can be extruded.

The icon on the left (outlined in green in the image) toggles to the 3D Drawing Tools menu.
3D Drawing Tools
The 3D drawing tools are a group of solids and surfaces that can be used as they are or combined to create
an object.

The icon on the left (outlined in red in the image) toggles to the 2D Drawing Tools menu.
Elevation Slider
The Elevation Slider tool allows the identification and setting of the elevation of an object
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Elevation in the 3DCW: is the vertical distance between the Floor Grid and the base of the
object

On the left – bottom side of the screen, we’ll find a command that shows / hides the Elevation Slider
(pointed by the green arrow in the image above). By right clicking on the Slider control, the commands
menu opens (pointed by the blue arrow in the image above).
Set Elevation: by clicking this option, the indicator opens showing the current elevation of the object. For
example, if the object is directly on the Floor Grid, then the elevation will be 0.00”. If desired, the elevation
can be changed by writing a new value or moving the slider up (to increase the elevation) or down (to
decrease the elevation).
The increments for the slider can be defined by Inch or by Foot by selecting the desired option in the
menu.
Eye – Dropper Tool
The Eye – Dropper tool allows the identification of any material or color applied on an object.
This tool is located on the bottom – right side of the screen (outlined in green in the image below).
Select the tool => the cursor will become an eye dropper => apply on the face of the object showing any
color or material => the Color Tab or Material tab will open and outline the material or color (outlined in
green in the image below).
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Note: If the color or material is included in the Decorator Palette (Main program), by opening
the Palette Tab in this power tool, the color or material will be selected.

Custom Options icon (on screen)

This icon (outlined in red in the image) activates the Custom Options Menu.

TUTORIALS
These tutorials don’t cover the development of all the elements that can be created with the 3DCW (it
would be an impossible task!), however these are basic objects with different levels of difficulty. These
tutorials are frequently asked by the software’s users and allow the application and understanding of the
principles of this Power Tool.
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How to create a basic table?
Step 1: using the 3D drawing tools, create a square prism (this will become a leg of the table) => using the
resize menu => set the dimensions.

Step 2: using the duplicate tool => duplicate the leg, setting the horizontal distance between legs.

Step 3: using the duplicate tool => duplicate the 2 legs, setting the vertical distance between legs.
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Step 4: Select the legs => set them as a Group => apply texture as a group.

Step 5: using the 3D drawing tools, create a square prism (this will become the top of the table) => using
the resize menu => set the dimensions.

Step 6: using the eye- dropper tool => identify the texture used for the legs => apply on the table top
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Step 7: using the Elevation Slider => set the elevation of the table top => or use the Move menu

Step 8: using the Alignment tool => center the legs and the table top

Step 9: the table is ready
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How to create tapered column? How to create a custom column?
Step 1: using the 2D Drawing Tools create a polygon => set the curve tension
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Step 2: use the extrude tool to create a solid => resize the column => work in Wireframe mode => set the
Selection by Points.

Step 3: select the point of the top of the column => resize the width and length as desired
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Step 4: the tapered column is ready.
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Step 5: creating a star shape =>select alternate points in the base of the column=> hide the detection =>
select the remaining points => resize the width and length as desired
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Step 6: repeat the process with the base of the column

Step 7: using the View Bar => confirm in 2D view - top view if the shape and dimensions are accurate.
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Step 8: the tapered – star shaped columns is ready

How to create a curved banquette?
Step 1: using the grid selection, choose a vertical grid => use the 2D Drawing Tools => outline the shape
of the banquette
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Step 2: Working in Wireframe => Selection by Points => adjust the curve of the desired segments

Step 3: position the shape and use grid selection=> the shape and the axis must be inserted in the grid
that define the revolving plane
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Step 4: define the revolving parameters (angle and radius)
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Step 5: Click OK => the solid is ready

Step 6: => adjust the curve of the desired segments

3D CUSTOM WORKSHOP POWER TOOL

- 413 -

Step 7: apply texture as desired.

Step 8: the curved banquette is ready

Questions for the 3DCW
Question 1: I need to change the dimensions of a POB (a mirror), but if I resize the dimensions in the
Properties tab, it looks deformed. Can you tell me how to proceed?
Answer 1: in this case, if you use the resize button, unless you add the same percentage for the width and
height, the object will look deformed. There is an alternative procedure for this.
For example, say you wish to resize this mirror
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The height is 35”, if we use the resize feature to reduce just the height to 20”, the frame will look deformed
(pointed by the red arrows below)

Instead, use Wireframe mode => select by points => lasso all the points on the upper part of the mirror
(outlined in green in the image) => Move => -15” (this is the difference between the original 35” and the
desired 20”)
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The mirror has the correct dimensions and it isn’t distorted.

Question 2: How to resize a POB proportionally in the 3 dimensions?
Answer 2: Open the resize button => select percent instead of object size => use the same percentage in
the 3 dimensions.
Question 3: I am trying to import a POB created by a friend, but it looks as small as a little dot. Why?
Answer 3: Sometimes it happens when the object was exported with a certain unit system and precision
and is imported with a different unit system and precision.
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Question 4: I am trying to import a POB created by a friend, but the workspace becomes white and nothing
happens. How to solve this issue?
Answer 4: Check your computer for virus, Trojans, etc.
Question 5: I am trying to import a 3DS file, but the power tool crashes. Any solution?
Answer 6: if the imported object has many polygons, it may crash the tool. Try to reduce the number of
polygons before attempt to import the object.

Go To: find more Information about polygons and Importing Objects

Return to Table of Contents
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The PhotoView Power Tool imports various types of images or pictures to be used in 3D (live view).

Important: The images or pictures imported with the PhotoView Power Tool are visible only in
3D. In the floor plan, they appear as a line.
PROPERTIES
This tool imports files in the following formats: bmp, jpg, png, tiff and ptx.
Is very important to note that you are importing a static picture with the following properties:
=> It works like a fixed board. This means that it is not a 3D object.
=> As it is a static element, you can rotate the board, but you can’t rotate the image.
=> It is not an editable 3D element: for example, if you are importing a picture of a house, you can’t add
or delete doors or windows, you can’t change the color of the siding, etc. Any modification to the picture
must be developed before you import it.
=> As the picture is fixed, you will get better results if the camera position in live view is the same position
of the camera in the picture.
These concepts will become clear in the practical applications.
BEFORE YOU IMPORT THE PICURE
Depending of the use of the picture, is important that you process the image in order to get the desired
results.
Quality
Try to use a clear picture with good quality (dpi) so it will blend with the rendering
Masking
In the Punch! Software (R) programs, the color black (RGB 0 0 0) renders transparent. Therefore, in a
picture, if you wish to hide a part of it, you must cover this sector with color black. This process is called
Masking.
The masking process can be executed with the PhotoView Editor Power Tool (for programs that include
this feature) or with a graphic program (some of them are free).
For example, this is a picture that shows a sculpture in a pond. Say you wish to import just the sculpture.
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If you import the picture without masking, this is how it will look in live view

Certainly, it doesn’t look realistic. So, proceed to mask the picture by covering all the undesired areas with
color black (RGB 0 0 0). The picture with look like this
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Trim
After masking the picture, it is necessary to trim the picture. First, you must define the elevation line of
the picture (red line in the image below): this is the point where the picture will touch the ground.

All the space below the elevation line must be trimmed so the sculpture will be placed on the ground
(otherwise, it would be floating). Also, trim the sides and top, in order the set the exact dimensions of the
sculpture. Total trim outlined in green. The trimmed picture will look like this

PHOTOVIEW POWER TOOL

- 420 -

After rendering, it will look like this
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USING THE TOOL (IMPORTING THE PICTURES)
As we open the tool, we select the file and we need to set the dimensions.

The dimensions of the picture are the dimensions of the object in real life (if it is a car, a house, a person
or a sculpture, for example) or the necessary extension for a background image. Then the image will be
placed in the plan.
Setting a background image
Say we want to use this image as background. It doesn’t need trim or masking.

The image will be placed in the plan following the X-X axis and we can rotate it as necessary.
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On the plan it will appear as a line (in yellow in the image above). I recommend the placement of the
images facing the camera (eyes of the “Little man” in Live View).
Adjust the settings as necessary in the Properties tab.
This is the rendered image including the background and the sculpture

Adding additional pictures
Additional pictures can be included in the file. As recommended, place the images facing the camera or
following the picture’s angle (in red in the image below).
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In the image below, we can see the background, the sculpture, a person, a car, and a small building. This
straw bale construction is a green shed that includes a green roof (covered with grass), so I inserted the
picture and placed grass from the Plant Library.
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Go To: find more Information about optimizing pictures and inserting and landscaping
pictures

Return to Table of Contents
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The PhotoView Editor Power Tool allows the edition of the pictures intended to be imported in the
program using the PhotoView Power Tool or as imported as new textures
The Menus
The menus and tools are basic.

Arrow icon: used for selection.
Magnifier icon: used for zoom.
Hand icon: used for pan on the screen.
Drawing tools (black bar): used to outline the working areas.

The right top toolbar shows the different working modes: color blending mode, fill mode, replicate mode
and material mode.
Editing Mode: by right clicking the working area, we can select the editing level: Point Editing Level and
Object Editing level. The Point Editing level allows a better accuracy of the shape.
The Tools
By selecting and right clicking on the working areas, we can access to the different tools.
Filling with color / color masking object: these options allow, for example, masking a picture by filling the
selected area with color black. Open the picture
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Outline and select the desired areas => the red dots will show the “handles”(the places where you clicked
around the image) => right click => Convert to => color masking object (or fill object) => the areas are
masked.

This mask can be saved as overlay mask in the File menu.
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Filling with Material: uses the same procedure. Used for creative results inserting a new material instead
of a color. For example: grass.

Material + Distortion: when we choose to fill a selection with a material green and yellow points appear
on the image perimeter (pointed by the arrows in the image below). These points allow to distort the
perspective of the selection and the material.
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Replication Object: used to create a copy of the object, and if desired, flip the copy (horizontal or vertical.

The final image can be saved as bmp in the File menu.

Go To: find more Information about optimizing pictures

Return to Table of Contents
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The Trim Designer Power Tool allows the development of different types of trims as well as wainscots and
panels.
INITIAL SCREEN
As we open the tool, the Trim Design Selection initial screen opens. This menu shows the five initial shapes.
Choose one of the options and set the initial dimensions (that can be changed later in the process)

After the selections, by clicking OK, we proceed to the main screen of the Power Tool
TOOLS AND MENUS

Black bar tools
Arrow icon: used for selection.
Magnifier icon: used for zoom.
Hand icon: used for pan on the screen.
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Square icon: resets the view.
Chamfer / Fillet corners: these tools chamfers or fillet corners.
Select the desired tool and apply on any standard corner on the perimeter and drag to the interior of the
shape.
Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.

MAIN MENU - ADDITIONAL TOOLS
Edit => Nudge: as defined below

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
The snap movements are commanded only withe arrow keys. The Nudge movements are commanded
with the arrow keys as well as using the following commands in the Main menu=> Edit => Nudge => Up /
Down / Left / Right. The settings of the distance between the grids and the nudge distance are defined in
the Grid Properties Menu.
Edit => Align to grid: using this tool, the objects can be aligned to the closer gridline, in the desired
direction
Edit => Flip vertically: by selecting a shape clicking on one of this flip option, the object will be reversed
vertically, allowing the shape to be used as base trim or crown molding.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.

OPTIONS MENU
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below.
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The space between the lines or points is defined in the Grid Spacing section. The Snap to Grid value defines
the interval in the movements using the arrows of the keyboard.
Grid Visible: toggles on / off the grid visibility.
Snap to Grid: toggles on / off the Snap to Grid feature.
Automatic Dimensioning: customization of the dimensions’ visibility.
Designing the trim
After we define the block and dimensions in the initial screen, the main screen opens, showing the
selected block and on the right, the first properties bar. This is the bar that we see if the trim is not
selected.

We can: resize the trim, set the grid options, save the trim to library and choose the design mode (base
trim or crown trim)

The difference between base trim and crown trim: the base trim outlines a floor and the crown
trim outlines a ceiling.
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In this case, I chose the first block, a rectangle. This shape is a good option for the development of trims
and wainscots. Using the black bar tools we can customize the shape. By selecting one or more points off
the shape, the properties bar of the shape appears.

Adjust the curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all
the segments or just for one segment, depending of the necessities, as shown in the image below (outlined
in red)
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As we develop the trim, we can check it in 3D on the right up corner. After, we save it to the Trim Library,
we can see the also the thumbnail in the selected library.

The same trim can be applied on interior walls, exterior walls or on doors / windows trims. Wainscots can
be developed in the same way. If desired, a curved border can be included.
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The second block of the initial menu can be used without modifications for base or crown trim

The trims can be saved to the Trim Library, or exported to the 3D Workshop Power Tool.

Return to Table of Contents
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The Door Designer Power Tool allows the development of custom doors and casements.
THE TABS
The interface of this tool is has 3 tabs: casings, panels and grills which are the components used to create
the different doors’ models.
Casing
The casing is the frame of a door and it is the element that creates the opening in the wall. The casing tab
has 8 drawing tools with different shapes that can be used alone or combined.

As we draw a shape or select this part in the workspace, the properties bar is activated.
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The properties bar shows the selected type (casing in this case), and allow the selection of different
options.
The 3D screen shows the updated image (outlined in red).
Panels
The panels build the dynamic parts of a door (folders, for example). The casing tab has 8 drawing tools
with different shapes that can be used alone or combined.

As we draw a shape or select this part in the workspace, the properties bar is activated.

The properties bar shows the selected type (panel in this case), and allow the selection of different
options.
The 3D screen shows the updated image (outlined in green).
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Grills
The grills build the bars used for security or decorative purposes. The casing tab has 8 drawing tools with
different shapes that can be used alone or combined.

As we draw a shape or select this part in the workspace, the properties bar is activated.

The properties bar shows the selected type (grill in this case), and allow the selection of different options.
The 3D screen shows the updated image (outlined in blue).
Properties Bar Options
Edit Level: the door components can be edited as object or by points. As object means that the shape is
constrained, so the size can be changed but not the shape. By points means that each handle (point) can
be moved separately, modifying size and shape.
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Auto Dim (on – off): shows / hides the dims in the workspace.
Adjust curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all the
segments or just for one segment, depending of the necessities or the type of Edit Level.
Bring to Front / Send to Back buttons: selects the relative position of one element referred to the
remaining elements. For example, in the panel image, the panels are in front of the casing.
Thickness: define the thickness of the panels and grills.
Open / Closed: the shape can be a closed polygon or an open polygon and in this case, it is possible to join
the shapes.

TOOLS AND MENUS
There are different tools and menus that help to design the Custom doors.
Workspace
As we open the tool, we find the workspace and the workspace menu on the right. This menu is activated
when the components are not selected.

Workspace Boundary / scale objects: dimensions of the workspace on the screen, with the scale objects
option (the door is scaled to the current workspace). The dimensions can be resized as necessary to fit the
door design. The maximum size is 30’x 30’.
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Grid options: the grid as well as the grid central lines can be visible or not. The snap to grid can be on /
off.
Nudge Rate: setting of the distance of the nudge option

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
Join Sensitivity: this setting measures the response / detection of two components using the join feature.
Precision: the setting of the units can be in Inches or Ft-Inches.
Tracking constant to Angle / to Roof Pitch: the upper component follows the desired angle option.
Library Import Options: these settings are activated when one of the doors in the library is selected to
edit (drag and drop) into the workspace.
Save Door to Library Button: activates the menu with all the options to save the current door to the Door
Library.
Left Top Tools

Arrow icon: used for selection.
Resize segment (arrow with the # sign): Select the tool => select a segment => write the new dimension
=> OK.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
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the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Magnifier icon: used for zoom.
Hand icon: used for pan on the screen.
Square icon: resets the view.
Bottom Arrows: select the following / previous object.
Black Bar Tools

Chamfer / Fillet corners: these tools chamfers or fillet corners.
Select the desired tool and apply on any standard corner on the perimeter and drag to the interior of the
shape.
Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.
For all these tools, the Edit Level must be by points.
Right Top Tools
Snap Tools

This bar provides an array of tools that allow more precision in the drawing. For example, the third tool
snaps to the center of a segment.
Join / Unjoin Selected: this tool groups or ungroups the selected components.
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Mirror / Flip tools

Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.
Drawing Method
To draw any component, the drawing method can be selected: from corners or from center.
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Main Menu
File Menu: closes the Power Tool, returning to the main program. Saves the door to library.
Edit Menu
Undo: reverses the last X actions (X is the number of instances, according with the Undo Preferences).
Redo: reverses the undo command.
Undo Preferences: defines the number of Undo instances. The default number is 25, and the maximum
number is 50. There is an option to disable the Undo command, making the Power Tool operation faster.
Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Select All: selects all the elements in the workspace.
Nudge: if the snaps are deactivated, use this command for movements.
Move: allows the movement of the elements an exact distance
Rotate: activates the Rotate tool.
Align to Grid: using this tool, the objects can be aligned to the closer gridline, in the desired direction.
Join / Unjoin: activates / deactivates the join tools.
Mirror / Flip: activates / deactivates the mirror / flip tools.
Send to Back Bring to front: sets the position of the component
2D Menu
Reset View: resets the view to default.
Set Plan View Zoom: controls the zoom level numerically.
Refresh: refreshes 2D screen.
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Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below.

The space between the lines or points is defined in the Grid Spacing section. The Snap Grid defines the
interval in the movements using the arrows of the keyboard.
Grid Visible: toggles on / off the grid visibility.
Grid Lines Visible: toggles on / off the visibility of the central grid lines.
Snap to Grid: toggles on / off the snap to grid feature.
Auto Reset Tools: resets all the tools.
3D Menu
Reset 3D View: resets live view to the default parameters.
Clear View: sets the rendering mode to clear view, showing the object faces as semitransparent and the
edges of the object / shape as lines.
Auto Final render: automatically renders in final quality.
Render Final Quality: manually sets for final render quality.
3D Final Quality: selection of the desired quality for final rendering: Low (fast), High (moderate), Ultra
High (slow) or Excellent (very slow).
Helicopter Speed: 5 different visualization speeds.

Questions for this tool
Question 1: Where are the materials and colors?
Answer 1: The materials and colors are applied in the main program.
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Question 2: Is it possible to design a custom garage door and open it as an overhead door?
Answer 2: All the custom doors open as hinged doors.
Question 3: how do I insert glass in my doors?
Answer 3: the empty spaces are rendered transparent, as glass. As we can see in this finished door.

They are transparent in the rendered images.
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Question 4: Is it possible to design a door with a separated transom?
Answer 4: Yes, the space between the door and the transom will be part of the wall, as shown in the
images below.
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Question 5: Can I define a different thickness for the casing?
Answer 5: The thickness of the casing is defined in the main program => select the window => define the
trim.

Go To: find more Information about doors

Return to Table of Contents
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The Window Designer Power Tool allows the development of custom windows and wall openings.
THE TABS
The interface of this tool is has 3 tabs: casings, sills and grills which are the components used to create
the different windows’ models.
Casing
The casing is the frame of a window and it is the element that creates the opening in the wall. The casing
tab has 8 drawing tools with different shapes that can be used alone or combined.

As we draw a shape or select this part in the workspace, the properties bar is activated.
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The properties bar shows the selected type (casing in this case), and allow the selection of different
options, including the Grill Wizard.
The 3D screen shows the updated image on the top.
Sills
The sills build the dynamic parts of a windows (a sash, for example). The sill tab has 8 drawing tools with
different shapes that can be used alone or combined.

As we draw a shape or select this part in the workspace, the properties bar is activated.

The properties bar shows the selected type (sill in this case), and allow the selection of different options.
The 3D screen shows the updated image (outlined in green).
Grills
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The grills build the bars used for security or decorative purposes. The casing tab has 8 drawing tools with
different shapes that can be used alone or combined.

As we draw a shape or select this part in the workspace, the properties bar is activated.

The properties bar shows the selected type (grill in this case), and allow the selection of different options.
The 3D screen shows the updated image (outlined in blue).
Properties Bar Options
Edit Level: the windows components can be edited as object or by points. As object means that the shape
is constrained, so the size can be changed but not the shape. By points means that each handle (point)
can be moved separately, modifying size and shape.
Auto Dim (on – off): shows / hides the dims in the workspace.
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Adjust curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all the
segments or just for one segment, depending of the necessities or the type of Edit Level.
Bring to Front / Send to Back buttons: selects the relative position of one element referred to the
remaining elements. For example, in the sill image, the grills are in front of the sills.
Thickness: define the thickness of the sills and grills
Open / Closed: the shape can be a closed polygon or an open polygon and in this case, it is possible to join
the shapes.
Grill Wizard: it is activated with the Build Grills button (outlined in green in the casing image), and inserts
the desired number of horizontal and vertical grills. The distances are calculated automatically.

TOOLS AND MENUS
There are different tools and menus that help to design the Custom windows.
Workspace
As we open the tool, we find the workspace and the workspace menu on the right. This menu is activated
if the components are not selected.

Workspace Boundary / scale objects: dimensions of the workspace on the screen, with the objects scale
option (the window is scaled to the current workspace). The dimensions can be resized as necessary to fit
the window design. The maximum size is 30’x 30’.
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Grid options: the grid as well as the grid central lines can be visible or not. The snap to grid can be on /
off.
Nudge Rate: setting of the distance of the nudge option

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
Join Sensitivity: this setting measures the response / detection of two components using the join feature.
Precision: the setting of the units can be in Inches or Ft-Inches.
Tracking constant to Angle / to Roof Pitch: the upper component follows the desired angle option.
Library Import Options: these settings are activated when one of the windows in the library is selected to
edit (drag and drop) into the workspace.
Save Window to Library Button: activated the menu with all the options to save the current window to
the Window Library.
Left Top Tools

Arrow icon: used for selection.
Resize segment (arrow with the # sign): Select the tool => select a segment => write the new dimension
=> OK.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
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the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Magnifier icon: used for zoom.
Hand icon: used for pan on the screen.
Square icon: resets the view.
Bottom Arrows: select the following / previous object.
Black bar tools

Chamfer / Fillet corners: these tools chamfers or fillet corners.
Select the desired tool and apply on any standard corner on the perimeter and drag to the interior of the
shape.
Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.

For all these tools, the Edit Level must be by points.
Right Top Tools
Snap Tools

This bar provides an array of tools that allow more precision in the drawing. For example, the third tool
snaps to the center of a segment.
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Join / Unjoin Selected: this tool groups or ungroups the selected Components.

Mirror / Flip tools

Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.
Drawing Method
To draw any Components, the drawing method can be selected: from corners or from center.
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Main Menu
File Menu: closes the Power Tool, returning to the main program. Saves the window to library.
Edit Menu
Undo: reverses the last X actions (X is the number of instances, according with the Undo Preferences).
Redo: reverses the undo command.
Undo Preferences: defines the number of Undo instances. The default number is 25, and the maximum
number is 50. There is an option to disable the Undo command, making the Power Tool operation faster.
Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Select All: selects all the elements in the workspace.
Nudge: if the snaps are deactivated, use this command for movements.
Move: allows the movement of the elements an exact distance
Rotate: activates the Rotate tool
Align to Grid: using this tool, the objects can be aligned to the closer gridline, in the desired direction.
Join / Unjoin: activates / deactivates the join tools .
Mirror / Flip: activates / deactivates the mirror / flip tools.
Send to Back Bring to front: sets the position of the component
2D Menu
Reset View: resets the view to default.
Set Plan View Zoom: controls the zoom level numerically.
WINDOW DESIGNER POWER TOOL

- 455 -

Refresh: refreshes 2D screen.
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below.

The space between the lines or points is defined in the Grid Spacing section. The Snap Grid defines the
interval in the movements using the arrows of the keyboard.
Grid Visible: toggles on / off the grid visibility.
Grid Lines Visible: toggles on / off the visibility of the central grid lines.
Snap to Grid: toggles on / off the snap to grid feature.
Auto Reset Tools: resets all the tools.
3D Menu
Reset 3D View: resets live view to the default parameters.
Clear View: sets the rendering mode to clear view, showing the object faces as semitransparent and the
edges of the object / shape as lines.
Auto Final render: automatically renders in final quality.
Render Final Quality: manually sets for final render quality.
3D Final Quality: selection of the desired quality for final rendering: Low (fast), High (moderate), Ultra
High (slow) or Excellent (very slow).
Helicopter Speed: 5 different visualization speeds.

Questions for this tool
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Question 1: Where are the materials and colors?
Answer 1: The materials and colors are applied in the main program.
Question 2: how do I insert glass in my windows?
Answer 2: the empty spaces are rendered transparent, as glass. As we can see in this finished window.

They are transparent in the rendered images.

Question 3: Is it possible to design a window with a separated transom?
Answer 3: Yes, the space between the window and the transom will be part of the wall, as shown in the
images below.
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Question 4: Can I define a different thickness for the casing?
Answer 4: The thickness of the casing is defined in the main program => select the window => define the
trim.
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Go To: find more Information about Windows

Return to Table of Contents
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INSERTING A FENCE IN THE MAIN PROGRAM
The Fence Designer Power Tool is an application that allows the development of custom designs to be
applied on Custom Fences in the main program.
In the Main program, when we need to add a fence, we use the Fence tool, located in the Landscape tab
(outlined in green). The fence appears in the plan as a line (straight or curved)

The Custom Fence option is composed by 3 elements: span, post (or column) and the gate.
The span (outlined in red) is the pane located between two columns or posts (outlined in black). The gate
is the opening of the fence
The dimensions of these elements can be customized using the Properties tab in the main program. By
visualizing the fence in live view, we can customize the appearance of the different elements (materials
and colors).
The materials used to apply and create the span are in the Custom Fences category (Materials Library). In
the image below, we can see a vinyl material applied on the span (drag and drop).
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Question about this issue
Question 1: Why are the Custom Fences in the Materials’ Library?
Answer1: They are textures with transparent parts applied on a surface. This is a close view of the fence
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Go To: find more Information about Custom Fences

CREATING A FENCE
Therefore, with the Fence Designer Power Tool we will be creating special textures to be applied on the
span.
As we open the tool, the selection menu opens.

In this menu we can choose the desired style, the piece (section or gate) as well as the dimensions.

Dimensions: it is recommended to define the dimensions of the Fence Section with the same
dimensions that will be used as the span dimensions in the main program.
Each style (Chain –Linked, Ornamental Iron, Picket, Privacy and Rail) include a brief explanation.
Alternatively, by selecting any style, the elements can be modified or deleted in order to create a custom
model
CHAIN LINKED

FENCE DESIGNER POWER TOOL

- 462 -

In the center of the screen we find the workspace with the dimensions defined in the selection menu. On
the right pane, we find the properties bar.
The chain linked fences are composed by a structure (Frame Work) and a mesh (Chain Link Fabric). By
default, the Frame Work is composed by one beam at the top, however, a second beam can be added at
the bottom. The 2 elements of the Chain Link Fabric can be customized: the dimensions of the mesh (red
arrow) and the thickness of the wire (black arrow)
ORNAMENTAL IRON

FENCE DESIGNER POWER TOOL

- 463 -

In the center of the screen we find the workspace with the dimensions defined in the selection menu. On
the right pane, we find the properties bar.
The Ornamental Iron option is composed by 3 elements: iron pickets, iron railings and the
embellishments.

Each element can be customized. The Iron Pickets, for example, have 3 models, that can be turned on /
off and the dimensions can be customized.

There are four levels of iron railings (horizontal bars). In the image below, the rail # 1 is unselected so it is
not visible (red arrow), rail #2 is selected so the height and elevation became editable (outlined in green).
Rails # 3 and # 4 remain unchanged (blue arrows). The four rails can be selected and edited.
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The embellishments are the decorative details (diamonds and rings) that can be placed in 3 different
levels. In the image below, the accessory # 1 is deactivated (red arrow), the accessory # 2 is “Ring” and
accessory # 3 is “Diamond”. When selected, each accessory can be customized (height and elevation)

PICKET
In the center of the screen we find the workspace with the dimensions defined in the selection menu. On
the right pane, we find the properties bar. At the bottom is the Style bar.
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The picket fences are composed by the pickets and the picket railings.
The pickets are the vertical boards. Width and spacing can be customized as well as the height (to a
maximum of 60”). There are 3 styles of picket caps; straight, pointed and curved. The upper edge of the
span allows 3 styles: Leveled (flat horizontal), scalloped and arched.
The picket railings are the horizontal boards, perpendicular to the pickets. There are 3 units available with
customizable height and elevation.

PRIVACY
In the center of the screen we find the workspace with the dimensions defined in the selection menu. On
the right pane, we find the properties bar.
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The privacy fences are composed by the boards and the privacy railings.
The privacy railings are the horizontal boards, perpendicular to the boards. There are 3 units available
with customizable height and elevation.
The boards are the vertical elements. Width and spacing can be customized as well as the height (to a
maximum of 60”). The gap between the boards can be turned on / off.
There are 3 styles of picket caps; straight, pointed and curved.

RAIL
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In the center of the screen we find the workspace with the dimensions defined in the selection menu. On
the right pane, we find the properties bar.

The rail fences are composed by horizontal boards. There are 3 rails available (first, second and tertiary)
with customizable heights and elevations.
CREATING A CUSTOM FENCE
In order to develop a custom fence, we must start with an empty workspace.
Tools
Shapes: there are 8 shapes available to develop the fence elements. These shapes can be used alone or
combined.

Left up corner menu
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Arrow icon: used for selection.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Magnifier icon: used for zoom.
Hand icon: used for pan on the screen.
How to develop the fence

Using the shapes, we can develop the fence or gate elements. By right clicking on the element, it can be
customized, with the following features
Clear: deletes the selected elements.
Move: allows the movement of the elements an exact distance.
Rotate: activates the Rotate tool.
Send to Back Bring to front: sets the location of the element by selecting the relative position of one
element referred to the remaining elements.
Edit Level: the shapes can be edited as object or by points. As object means that the shape is constrained,
so the size can be changed but not the shape. By points means that each handle (point) can be moved
separately, modifying size and shape.
Smooth / Unsmooth (Adjust curve): this setting adjusts the tension of the curve.
Color / Textures
By selecting one of icons on the upper right corner, we can open the colors and materials palettes that
are applied by selecting the element and clicking on the selected color / material in the palette
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All the elements can be resized and customized in order to get the desired design.

Saving / Exporting
The finished fence can be exported to the Materials Library (File => Export to Materials Library) or, using
File => Save As => the design is saved as a FDD file (fence designer document). This document can be
opened and edited afterwards using File => Open.
The new design must be exported to the materials’ library in order to be applied to the fence. The fence
can be saved in any category , of the User Library.
Applying the fence
As described, drag and drop the new design on the span
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MAIN MENU
Edit Menu
Undo: reverses the last X actions (X is the number of instances).
Redo: reverses the undo command.
Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Adjust design dimensions: adjust the dimensions of the workspace.
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Select All: selects all the elements in the workspace.
Options Menu
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below.

The space between the lines or points is defined in the Grid Spacing section. The Snap Grid defines the
interval in the movements using the arrows of the keyboard.
Grid Visible: toggles on / off the grid visibility.
Snap to Grid: toggles on / off the snap to grid feature

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
Show tracking dimensions: show the dimensions of the elements as we draw.
View Menu
Reset Design View: resets the view to the original size.
Refresh: refreshes the view.
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The Pool Designer Power Tool allows the development of any type of indoor or outdoor pools and
accessories, including above ground pools.
Basically there are two methods for developing a pool: using the Pool Wizard (outlined in red) or using
the five Manual Shapes in the black bar.

THE POOL WIZARD
By default, when we open the power tool, the Pool Wizard starts showing three tabs with different
options: Basic Shapes, Advanced Shapes and Above Ground.
Basic Shapes
These are the most common shapes. By selecting a shape, the properties bar on the right becomes active,
showing the default setting for the selected shape. For example, these are the default starting properties
selecting the rectangle (first shape).
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Starting Properties (for all the Wizard’s shapes)
Coping Properties (outlined in red): defines width and thickness of the border around the pool.
Water Properties (outlined in green): defines if the pool is filled and the water level.
Liner Properties: (on / off): toggles on/ off the user defines depth areas
Default Depths (outlined in blue): if the Liner Properties are unselected, the program uses the default
depths for this shape.
Sizing (outlined in brown) defines the pool dimensions.
Advanced Shapes
These are more advanced shapes. The properties bar shows the same starting properties.

Above Ground
These are the above ground shapes. The properties bar shows the same starting properties.
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MANUAL SHAPES
Some pools have a unique design and it is necessary to develop the shape from scratch. In these cases,
the pool can be created using the manual shapes (Shapes tab).
In addition, if the shape is available in the floor plan (main program) it can be traced using the manual
shapes. In the example below, the shape is visible in the floor plan.
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As it is an irregular polygon, proceed to trace the shape using the polygon tool.

The referred dims will match the dims of the walls of the pool. The properties bar shows similar starting
properties of available shapes of the Pool Wizard.

ADJUSTMENTS AND SETTINGS
After we insert a shape using the Pool Wizard, the liner builder appears in red (outlined in yellow in the
image below). This symbol means that the structure is not ready.
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By clicking on the liner builder, the “excavator” will perform the necessary tasks that will be completed
when the symbol turns green.
Customizing the settings
After the liner is ready, we can change the defaults or customize the different parameters.
Water: defines if the pool is filled and the water level (red arrow).
Coping: (On / Off) defines width and thickness of the border around the pool (green arrow).

Parallel Depth: profundity parallel to the shape’s perimeter. As we click on Parallel Depth button, the
menu opens and the settings can be customized (black arrow in the image below)

POOL DESIGNER POWER TOOL

- 478 -

Area Depth: profundity of the general selected area (blue arrow – below)

Area Depth: profundity of the specific selected area (red arrow – below)

Edit Level: the pool shapes can be edited as object or by points. As object means that the shape is
constrained, so the size can be changed but not the shape. By points means that each handle (point) can
be moved separately, modifying size and shape.
Adjust curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all the
segments or just for one segment, depending of the necessities or the type of Edit Level.
Auto Dim (on – off): shows / hides the dims in the workspace.
Elevation: the elevation of the different elements of the pool can be elevated with different parameters.
Depending of the element, the elevation can be set by right clicking the element or using the Elevation
Slider. The right clicking option opens the elevation menu, showing the available option for the selected
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element. In the image below we can see the available options for a ladder: on the pool coping (red arrows)
that are actually the custom elevation = 2” (black circles), the different depths (blue and green arrows) or
on the water surface (brown arrow)

THE COMMANDS AND TOOLS
There are several toolbars and commands to adjust the drawing settings.
The left top toolbar

Arrow – Move / Resize / Select Tool: This tool is used to:
=> Move: point the entire object / shape in order to select it => move it manually to a different location.
=> Resize: point a corner of the object / shape in order to select it => drag the point to the new position
in order to edit the object.
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=> Select: used to select elements => pointing the entire object / shape => or pointing a corner of the
object / shape (fillet / chamfer) => or in edit by points mode, pointing one or several segments.
Resize segment (arrow with the # sign): Select the tool => select the element => or use edit by points
mode => select a segment => write the new length => OK.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Zoom: by clicking the Zoom tool (magnifier icon) and keeping the left button down, you can increase or
decrease the distance to the object. By dragging it to the right, you will decrease the distance, therefore
you can get a closer look at the object (Zoom In). By dragging it to the left, you will increase the distance,
therefore you can get a distant look at the object (Zoom Out).
Pan: : by clicking the Pan tool (hand icon) and keeping the left button down, you will be able to drag the
screen and move around in the workspace following the desired direction as you move the ”hand”.
Zero Offset Dimension: measures the distance between 2 points of an element: the distance between the
element measured and the dimension line (called offset) is always = zero.
Snap Tools: the snap toolbar is on the right side of the workspace.

This bar provide an array of tools that allow more precision in the drawing. For example, the third tool
snaps to the center of a segment. In order to use these tools, the shapes must be edited by points.
Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.

Select the desired tool and apply on any straight line on the perimeter of the shape. In order to use these
tools, the shapes must be edited by points.
Chamfer / Fillet corners: these tools chamfers or fillet corners.
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Select the desired tool and apply on any standard corner on the perimeter and drag to the interior of the
shape. In order to use these tools, the shapes must be edited by points.
Elevation Slider
Located on the left side of the screen.

By selecting any element and right clicking on the Elevation slider => the elevation menu opens, as shown
in the image above.
Set elevation: opens the elevation menu, for manually set the desired elevation. If desired, the elevation
can be changed also by moving the slider up (to increase the elevation) or down (to decrease the
elevation).

THE MAIN MENU
File Menu: closes the Power Tool, returning to the main program. Confirm the changes.
Edit Menu
Undo: reverses the last X actions (X is the number of instances, according with the Undo Preferences).
Redo: reverses the undo command.
Undo Preferences: defines the number of Undo instances. The default number is 25, and the maximum
number is 50. There is an option to disable the Undo command, making the Power Tool operation faster.
Cut: cuts the selected elements.
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Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Select All: selects all the elements in the workspace.
Nudge: if the snaps are deactivated, use this command for movements

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
The snap movements are commanded only withe arrow keys. The Nudge movements are commanded
with the arrow keys as well as using the following commands in the Main menu=> Edit => Nudge => Up /
Down / Left / Right. The settings of the distance between the grids and the nudge distance are defined in
the Grid Properties Menu.
Move: allows the movement of the elements an exact distance
Rotate: activates the Rotate tool.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.
Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
Set Object Elevation: opens the elevation menu, for manually set the desired elevation
Design Menu
Set Working Elevation: setting of the desired working elevation.
Work on Plan: selection of the desired working tab.
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Calculate Pool Volume: automatically calculates the volume based on the current settings.
Pool Options: open the options menu, related with rendering, movements and appearance.

Live View Menu
Reset 3D View: resets live view to the default parameters.
3D Viewing Method: sets the desired live view method: walk –through or fly around, and defines the
elevation for these options.
3D Lighting: light parameters for live view.
View Menu
Refresh: refreshes 2D screen.
Reset Plan View: resets the view to default.
Set Plan View Zoom: controls the zoom level numerically.
Fit to Windows: zooms the drawing to fit in the screen.
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below.
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The space between the lines or points is defined in the Grid Spacing section. The Snap Grid defines the
interval in the movements using the arrows of the keyboard.
Grid Visible: toggles on / off the grid visibility.
Snap to Grid: toggles on / off the snap to grid feature.
Automatic Dimensioning: customization of the dimensions’ visibility.
Show Topography lines: (on / off) customization of the topography lines’ visibility.
Show Virtual Ruler: visibility of the virtual ruler which is a drawing help tool that allows taking
measurements in the screen.
Screen colors: customizes the drawing colors for the tool.

THE WORKING TABS
The working tabs are intended to provide additional features to the shapes.
Shape tab
As defined, allows the definition of customized shapes.
Depth tab
Allows the design of customized shapes and features for depth areas.
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Ladders tab
Allows the addition of premade ladders and hand support rails

Rail and Step tab
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Adds different types of steps, using different positions and styles. The number and count of steps can be
customized and well as the elevation.

Equipment tab
Provides different types of equipment (cleaner, thermometer, etc.) and tools for pool care (vacuum,
broom, etc.). Just drag and drop to place the elements in the desired location.

Accessory tab

POOL DESIGNER POWER TOOL

- 487 -

Provides different accessories for recreational purposes (slider, diving boards, net, etc.).
The slider and the diving board have different options:

Just drag and drop to place the elements in the desired location. Set the desired orientation and elevation.

TEMPLATES
The templates bar is located on the right side of the screen, is the second tab below the Properties bar.
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By clicking on the tab name, the menu opens allowing the selection of the templates of the different types
of pools.
Creating a template
This feature allows you to save a pool design as a template that can be retrieved and used in other projects.
In order to create a new template => select all the elements => Template tab => create a template =>
choose the name.

Questions for this tool
Question 1: I developed a pool using the Pool Designer Power Tool, but the Live View option of the tool
doesn’t show the house. Is this correct?
Answer 1: The Power Tool shows just the pool. As we close the tool, the finished pool design plus the
house can be visualized in the main program
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Question 2: Can I change the color of the liner?
Answer 2: Yes, you can. The color of the liner can be changed using the color window in the properties
bar (outlined in red). By double clicking the window, the color menu opens => select the color => OK. The
color will be applied automatically to the liner (there is no need to drag and drop)

Question 3: Can I change the materials of the liner and steps?
Answer 3: Yes, you can. The materials can be changed in the main program. If the pool liner is below the
elevation 0”, in order to apply the materials, set the little man’s elevation below the elevation 0”.
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Go To: find more Information about applying colors and materials

Return to Table of Contents
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With the Fireplace Wizard Power Tool you can create 5 basic types of fireplaces. These models are
presented in the first selection menu of the tool

These models are based on prismatic pieces that can’t be edited within this Power Tool

Editing the pieces and shapes: the finished fireplaces can be exported to the 3D Workshop
Power Tool, where all the pieces and shapes can be edited.
Each model has 2 stages (face and chimney). The face stage has one, two or three faces’ definition,
depending of the model. The chimney is optional in all the models.
MASONRY FIREPLACE (SINGLE ROOM)
Stage 1: defining the face dimensions
The first definition screen defines the dimensions of the elements of the front face (one definition for
each type): Chimney box, Firebox, Mantel (optional) and Hearth (optional).
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Stage 2: defining the chimney dimensions
Default for all the models: this stage is optional. It defines the dimensions of the chimney box and chimney
pot (optional).
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Stage 3: adjustments
Default for all the models: After the definition screens, the dimensions of all the elements can be edited
in the different tabs of the properties bar, at the right of the workspace.

MASONRY FIREPLACE (DUAL ROOM – SINGLE FIREBOX)
Stage 1: defining the face dimensions
The first definition screen defines the dimensions of the elements of the front face and back face (two
definitions for each type, except the firebox): Firebox, Mantel (optional) and Hearth (optional). Notice that
the face menu has a drop down menu to select the dimensions of the two different faces.
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Stage 2: defining the chimney dimensions
Follows the Chimneys’ Default for all the models.
Stage 3: adjustments
Follows the Adjustments’ Default for all the models.

Notice that, after the initial development of the fireplace, you can select the working face, in
the Main menu => Design => Face.

MASONRY FIREPLACE (DUAL ROOM – DUAL FIREBOX)
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Stage 1: defining the face dimensions
The first definition screen defines the dimensions of the elements of the front face and back face (two
definitions for each type): Chimney box, Firebox, Mantel (optional) and Hearth (optional). Notice that the
front face menu has a drop down menu to select the dimensions of the two different faces.

Stage 2: defining the chimney dimensions
Follows the Chimneys’ Default for all the models.
Stage 3: adjustments
Follows the Adjustments’ Default for all the models.

Notice that, after the initial development of the fireplace, you can select the working face, in
the Main menu => Design => Face.
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MASONRY CORNER FIREPLACE
Stage 1: defining the face dimensions
The first definition screen defines the dimensions of the elements of the front face (one definition for
each type): Chimney box, Firebox, Mantel (optional) and Hearth (optional).

Stage 2: defining the chimney dimensions
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Follows the Chimneys’ Default for all the models.
Stage 3: adjustments
Follows the Adjustments’ Default for all the models.

PENINSULA FIREPLACE (3 SIDES)
Stage 1: defining the face dimensions
The first definition screen defines the dimensions of the elements of the front face and the 2 side faces
(three definitions for each type): Chimney box, Firebox, Mantel (optional) and Hearth (optional). Notice
that the front face menu has a drop down menu to select the dimensions of the two different faces.

Stage 2: defining the chimney dimensions
Follows the Chimneys’ Default for all the models.
Stage 3: adjustments
Follows the Adjustments’ Default for all the models.

Notice that, after the initial development of the fireplace, you can select the working face in
the Main menu => Design => Face.
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MATERIALS AND COLORS
Materials and colors can be changed at any stage of the development, using the materials and colors tabs,
at the right of the workspace. Notice that the change affects the entire component (Chimney box, Firebox,
Mantel and Hearth) => this means that, within the program, you can’t change just a side of the mantel for
example. However, you can export the fireplace to the 3D Workshop Power Tool, where all the pieces
and shapes can be edited.

TOOLS AND MENUS
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File Menu
Save As: saves the fireplace as a PFW file for future use.
Export: exports the fireplace as a POB file that can be opened and edited with the 3D Workshop Power
Tool.
Exit Power Tool: closed the tool, inserting the fireplace in the main program
Design Menu
Allows the selection of the working face as well as the desired components.

FINISHED MODELS
Masonry Fireplace (Single Room)

Masonry Fireplace (Dual Room – Single Firebox)
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Masonry Corner Fireplace

Peninsula Fireplace (3 Sides)

FIREPLACE WIZARD POWER TOOL

- 501 -

Question for this tool
Question 1: I resized (increasing) all the face elements, and now I can’t decrease the length. What to do?
Answer 1: Decrease the length of the mantel and hearth first, then resize the face dimensions

Return to Table of Contents
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The Mantel Designer Power Tool is intended to create mantels and other elements to embellish the faces
of a fireplace.
DRAWING THE MANTEL
The starting point of the mantel development is the drawing of the elements using the shapes included in
the black bar.

There are 5 shapes to develop the mantel face (Rectangular, Circle / Oval, Polygon, Multigon and Curved)
plus the Dentil tool (outlined in red).
The Dentil tool creates moldings or dented surfaces using prismatic projections that can be customized.
The shapes must be created in the grid.

Important: note that in this tool, the working space is the front grid, the equivalent of a wall or
fireplace.
In the image below, we can see a polygonal shape in split 2D / 3D

CUSTOMIZING THE MANTEL
Mantel Face
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After we complete the drawing of this element and selecting the shape, the properties bar is activated on
the right side of the workspace, allowing the customization of the mantel face.

Projection: is the distance between the grid (wall, fireplace, etc.) and the mantel face.
Edit Level: the mantel shapes can be edited as object or by points. As object means that the shape is
constrained, so the size can be changed but not the shape. By points means that each handle (point) can
be moved separately, modifying size and shape.
Adjust curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all the
segments or just for one segment, depending of the necessities or the type of Edit Level.
Auto Dim (on – off): shows / hides the dims in the workspace.
Dentil Mantel Face
After we complete the drawing of this element and selecting the shape, the properties bar is activated on
the right side of the workspace, allowing the customization of the mantel face.
Projection: is the distance between the grid (wall, fireplace, etc.) and the dentil mantel face.

Note about the projection: notice that if you are adding a dentil molding on a mantel face, the
projection of both elements will start on the wall, so, for the dentil, you must consider the projection of
the mantel face plus the dentil.
Auto Dim (on – off): shows / hides the dims in the workspace.
Teeth height (outlined in red): vertical distance between the bottom and the top of the teeth.
Teeth width (outlined in green): horizontal distance between the left and right faces of a tooth.
Teeth spacing (outlined in blue): horizontal distance between the teeth.
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TOOLS
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Left up toolbars

Arrow – Move / Resize / Select Tool: This tool is used to:
=> Move: point the entire object / shape in order to select it => move it manually to a different location.
=> Resize: point a corner of the object / shape in order to select it => drag the point to the new position
in order to edit the object.
=> Select: used to select elements => pointing the entire object / shape => or pointing a corner of the
object / shape (fillet / chamfer) => or in edit by points mode, pointing one or several segments.
Resize segment (arrow with the # sign): Select the tool => select the element => or use edit by points
mode => select a segment => write the new length => OK.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Zoom: by clicking the Zoom tool (magnifier icon) and keeping the left button down, you can increase or
decrease the distance to the object. By dragging it to the right, you will decrease the distance, therefore
you can get a closer look at the object (Zoom In). By dragging it to the left, you will increase the distance,
therefore you can get a distant look at the object (Zoom Out).
Pan: by clicking the Pan tool (hand icon) and keeping the left button down, you will be able to drag the
screen and move around in the workspace following the desired direction as you move the ”hand”.

Toggle Snap to Grid (the tool toggles between the options): this tool activates / deactivates the Snap to
Grid feature.
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Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
The snap movements are commanded only withe arrow keys. The Nudge movements are commanded
with the arrow keys as well as using the following commands in the Main menu=> Edit => Nudge => Up /
Down / Left / Right. The settings of the distance between the grids and the nudge distance are defined in
the Grid Properties Menu.
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below.

The space between the lines or points is defined in the Grid Spacing section. The Snap Grid defines the
interval in the movements using the arrows of the keyboard.
Workspace size: defines the size of the grid / workspace.
Right up toolbars
Snap Tools: the snap toolbar is on the right side of the workspace.
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This bar provide an array of tools that allow more precision in the drawing. For example, the third tool
snaps to the center of a segment. In order to use these tools, the shapes must be edited by points.
Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.

Select the desired tool and apply on any straight line on the perimeter of the shape. In order to use these
tools, the shapes must be edited by points.
Chamfer / Fillet corners: these tools chamfers or fillet corners.

Select the desired tool and apply on any standard corner on the perimeter and drag to the interior of the
shape. In order to use these tools, the shapes must be edited by points.
Editing the pieces and shapes: although this power tool includes editing tools, the finished mantels can
be exported to the 3D Workshop Power Tool, where all the pieces and shapes can be customized.
Main Menu
File Menu
Export: exports the mantel as a POB file that can be opened and edited with the 3D Workshop Power
Tool.
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Exit Power Tool: closed the tool, inserting the mantel in the main program
Edit Menu
Undo: reverses the last X actions (X is the number of instances, according with the Undo Preferences).
Redo: reverses the undo command.
Undo Preferences: defines the number of Undo instances. The default number is 25, and the maximum
number is 50. There is an option to disable the Undo command, making faster the Power Tool operation.
Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste with no Offset: pastes in place the elements previously copied or cut.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Select All: selects all the elements in the workspace.
Nudge: if the snaps are deactivated, use this command for movements
Move: allows the movement of the elements an exact distance
Rotate: activates the Rotate tool.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.
Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
Align to Grid: using this tool, the objects can be aligned to the closer gridline, in the desired direction.
Design Menu
Workspace size: defines the size of the grid / workspace.
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Image Trace Properties: this option allows import and trace any image (jpg, bmp, etc.) and trace the shape
in order to create an object.
The images don’t need any special preparation, however, for a better manipulation, I’d recommend to
trim the object.

Note that the size of the image must resemble the real size of the object, however, you can use
a larger size for a better definition and resize the object after completion.
Trace Image Visible: this option toggles on / off the visibility of the trace image.
3D Menu
Reset 3D View: resets live view to the default parameters
Render Final Quality: manually sets for final render quality.
3D Lighting: light parameters for live view.
2D Menu
Refresh: refreshes 2D screen.
Reset Plan View: resets the view to default.
Set Plan View Zoom: controls the zoom level numerically.
Fit to Window: sets the size of the workspace to fit the screen size.
Grid Properties: activates the Grid Properties Menu.
Grid Visible: toggles on / off the grid visibility.
Snap to Grid: toggles on / off the Snap to Grid feature.
Show Virtual Ruler: visibility of the virtual ruler which is a drawing help tool that allows taking
measurements in the screen
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TEMPLATES
The templates bar is located on the right side of the screen, is the second tab below the Properties bar.
By clicking on the tab name, the menu opens the template library, allowing the selection of the templates
of the different types of mantels.

Creating a template
This feature allows to save a mantel design as a template that can be retrieved and used in other projects.
In order to create a new template => select all the elements => Template tab => create a template =>
choose the name.

Return to Table of Contents
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The Section Detailer Power Tool is a drawing application that allows the elaboration of any 2D element,
detail, etc. These drawings can be linked to the floor plan, exported or printed.

Important: Note that this tool provides 2D drawings that can be used or printed for
information purposes. The drawings, texts dimensions and contents are not added to the structure of the
building, they can’t be converted to 3D elements and they are not part of the bill of materials (Estimator
Power Tool)

LINK SYMBOLS
As we open the power tool, the link symbol menu opens.

The style of the symbol, size, line and name can be selected. This symbol can be placed in the desired
location in the floor plan (outlined in green).
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If clicked, the tool opens showing the menu and detail

DRAWING ELEMENTS
These elements are in the drawing toolbar. Shapes, colors, hatches and lines’ types can be selected.
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The first eight icons are the shapes, that can be filled (or not) with a color (pointed with blue arrows). The
different colors can selected by clicking on the color windows. They can also be filled with different
patterns (hatches, pointed by the red arrow).
The colors also can be selected for the lines or outlines (pointed with the magenta arrow). Thickness and
type of lines have several options (pointed by the black arrow).

TOOLBARS
The toolbars allow the customization of the drawings.
Left Side Toolbars - 1

Arrow – Move / Resize / Select Tool: This tool is used to:
=> Move: point the entire object / shape in order to select it => move it manually to a different location.
=> Resize: point a corner of the object / shape in order to select it => drag the point to the new position
in order to edit the object.
=> Select: used to select elements => pointing the entire object / shape => or pointing a corner of the
object / shape (fillet / chamfer) => or in edit by points mode, pointing one or several segments.
Resize segment (arrow with the # sign): Select the tool => select a ceiling => use edit by points mode =>
select a segment => write the new length => OK.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Skew: this tool is used to obliquely distort a shape. The distortion can be horizontal or vertical. Select the
desired element => double click the skew icon => write the distance in the desired direction.
Trim: this option “cuts” a segment. Use edit by points mode => select the segment => apply the trim tool
(scissors) +. The segment will be divided and the two parts can be separated.
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Left Side Toolbars – 2 – Fillet and Chamfer Tools

These tools chamfers or fillet corners. Select the desired tool and apply on any standard corner on the
perimeter and drag to the interior of the shape. In order to use these tools, the shapes must be edited by
points.
Left Side Toolbars - 3

Resize selected: activates the resize menu. This feature allows the setting of the exact dimensions (X-Axis
or Y- Axis) or the percentage of the object as well as the reference point of the dimension.
Adjust curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all the
segments or just for one segment, depending of the necessities or the type of Edit Level.
Zoom: by clicking the Zoom tool (magnifier icon) and keeping the left button down, you can increase or
decrease the distance to the object. By dragging it to the right, you will decrease the distance, therefore
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you can get a closer look at the object (Zoom In). By dragging it to the left, you will increase the distance,
therefore you can get a distant look at the object (Zoom Out).
Pan: : by clicking the Pan tool (hand icon) and keeping the left button down, you will be able to drag the
screen and move around in the workspace following the desired direction as you move the ”hand”.
Left Side Toolbars - 4

This toolbar offers multiple options to add text (straight or angled) and dimensions (offset, angled,
diameter, radius, angle and leader dimension)
Left Side Toolbars – 5 – Grid Settings

Toggle Snap to Grid (the tool toggles between the options): this tool activates / deactivates the Snap to
Grid feature

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
The snap movements are commanded only withe arrow keys. The Nudge movements are commanded
with the arrow keys as well as using the following commands in the Main menu=> Edit => Nudge => Up /
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Down / Left / Right. The settings of the distance between the grids and the nudge distance are defined in
the Grid Properties Menu.
Toggle Visible Grid: toggles on / off the grid visibility.
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a gridded
background with lines or points that can be used as a drawing guide. The type of guide is defined in the
Grid Style section, as shown in the image below. The space between the lines or points is defined in the
Grid Spacing section. The Snap Grid defines the interval in the movements using the arrows of the
keyboard.

Bottom Toolbar

Starting point of a drawing (the tool toggles between the options): in order to draw a shape (rectangle,
circle, etc.) we can start from a corner or from the center. Each option is useful in different situations. For
example, the drawing from center option is a good solution when we need to draw concentric objects.
Edit Level: the shapes can be edited as object or by points. As object means that the shape is constrained,
so the size can be changed but not the shape. By points means that each handle (point) can be moved
separately, modifying size and shape.
Draw Parallel (On / Off): toggles on or off the drawing of a parallel line in the shape’s perimeter.
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By right clicking on the shape with parallel perimeter, the parallel menu opens allowing the customization
of this feature, setting the parallel line position (inside, outside or center), the parallel width and the
option of group both lines

The commands at the bottom of the screen inform the position of the elements, scale and allow the
rotation of the elements (outlined in blue) and to set the zoom (outlined in green)
Add / Delete Points (Top Bar)

Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.
For these tools, the Selection Mode must be by points
Right Side Toolbars - 1
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Snap Tools: This bar provides an array of tools that allow more precision in the drawing. For example, the
8th tool snaps to the center of a segment.
Right Side Toolbars - 2

Group / Ungroup: the group tool assembles the selected parts, creating a new object.
Lock / Unlock: the lock tool freezes the objects properties and makes the object immovable regarding its
position in the Workspace. By selecting one or more objects / shapes and clicking on the lock tool, the
elements will become “frozen”. By selecting the locked objects and clicking the on the unlock tool, the
objects return to their normal properties.
Join / Unjoin Selected: this tool groups or ungroups the selected.
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Bring to Front / Send to Back: selects the relative position of one element referred to the remaining
elements
Right Side Toolbars - 3

Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape is
deleted.
Detail Bar (up right corner)

Settings of the detail properties and selection of the working detail.
THE MAIN MENU
File Menu
Save As: the details developed with this power tool can be saved as PDD files for future use or edition.
Import Symbol: the symbols developed with the Symbol Editor Power Tool (PSY files) can be imported to
be used or edited within the Section Detailer Power Tool.
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Import / Export DXF / DWG files: these types of files are the most used for CAD programs. There are many
websites that offer free CAD symbols and details. Using this function, these files can be imported into this
tool to be used in the program or exported to other CAD programs. The files must be in DXF / DWG format.
Up to version 2004, however, in my experience, version 2000 works better.
Printer Setup / Print: setting according with your printer or PDF Editor.
Edit Menu
Undo: reverses the last X actions (X is the number of instances).
Redo: reverses the undo command.
Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Select All: selects all the elements in the workspace.
Hide Detection / Detect All: by selecting an object or a part of it and clicking on the hide detection tool
the elements can’t be selected. The remaining elements and points can’t be selected and modified.
Duplicate: creates a copy of the selected elements, using the parameters of the Duplicate Offsets.
Duplicate Offsets: opens the Duplicate Offsets menu in order to set the offset distance and number of
copies.

Nudge: if the snaps are deactivated, use this command for movements
Move: allows the movement of the elements an exact distance
Rotate: activates the Rotate tool
Project Menu
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Drawing scale: if the drawing is a real constructive detail or a piece of equipment or furniture, then the
drawing must follow the same scale of the plan in the main program. A very common scale (default in the
main program) is 0.25”= 1’ => this means that a line with 0.25” is equivalent to one ft. in real life.
Paper Size: settings of the paper size (note: for printing within this power tool).
Active Layer: this command shows the names of the layers with contents.
Visible Layers: allows show / hide all the layers.
Layer Info: shows the Layers Properties Menu, allowing show / hide or create / remove layers.

Layer (definition): in the Section Detailer, the layers work like overlying elements that can be
shown or hidden as desired.
Grid: management of the Grid Settings.
Align to Grid: using this tool, the objects can be aligned to the closer gridline, in the desired direction.
Background color: general color of the workspace.
Grid color: color of the gridlines.
Axis Color: color of the X and Y axis (if selected).
Draw Axis (On / Off): visibility of the X and Y axis (left and bottom of the workspace).
Draw Page Breaks: shows the pages layout according with the selected paper size.
Move Origin: moves a numeric distance the origin of the workspace.
Detail Link Properties / Switch Details: activates the elements is the Detail Bar.

SECTION DETAILER POWER TOOL

- 522 -

Arrange Menu
Bring to Front / Send to Back: selects the relative position of one element referred to the remaining
elements
Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.
Group / Ungroup: the group tool assembles the selected parts, creating a new object.
Lock / Unlock: the lock tool freezes the objects properties and makes the object immovable regarding its
position in the Workspace. By selecting one or more objects / shapes and clicking on the lock tool, the
elements will become “frozen”. By selecting the locked objects and clicking the on the unlock tool, the
objects return to their normal properties.
Join / Unjoin Selected: this tool groups or ungroups the selected.
Options Menu
Pen: setting of the options for lines: Color. Type and Thickness, as shown in the Drawing Elements.
Fill: setting of the options for filling the shapes: colors and gradients.
Dimensions: setting of the dimensions properties and tolerances.
Parallel: opens the Parallel Menu.
Draw Parallel: (On / Off): toggles on or off the drawing of a parallel line in the shape’s perimeter.
Draw from Center: draws the shape from center.
Open Selected / Close Selected: by selecting a segment and using the “open selected” option the selected
segment can be detached and the polygon can opened. By selecting the “close selected” option the points
are reattached and they conform a close polygon.
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Curve Smoothing: adjust curvature .
Scale Selection: opens the scale / resize menu. This feature allows the setting of the exact dimensions (XAxis or Y- Axis) or the percentage of the object as well as the reference point of the dimension.

Precision: this option opens a menu that allows the selection of a new precision setting within the
measurement units (English or Metric).
Point Selection / Object Selection: setting of the Edit Level.
Preferences: choice of the working settings.
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RIGHT CLICKING
By right clicking on a shape or segment, the selected element can be edited.
Note that only using this feature it is possible to move the elements among the layers using the Move to
Layer Command => the name of the layers will appear => select the desired layer.

Return to Table of Contents
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The Symbol Editor Power Tool is a drawing application that allows the elaboration of any 2D element,
detail, etc. The drawings can be saved in the Symbol Libraries, applied into the floor plan, exported or
printed.

Important: Note that this tool provides 2D drawings that can be used or printed for information
purposes. The drawing, texts dimensions and contents are not added to the structure of the building, they
can’t be converted to 3D elements and they are not part of the bill of materials (Estimator Power Tool)

Question for this issue.
Q: are the Symbol Editor Power Tool and the Section Detailer Power Tool the same tool?
A: although they share several features and both develop 2D elements, they are not the same tool. The
Section Detailer Power Tool has additional color and finishing features as well as layers. In addition, the
details created with the Section Detailer Power Tool can be linked with the floor plan (main program).
DRAWING ELEMENTS
The drawing elements can be found in the drawing toolbar. Shapes, fill, hatches and lines’ types can be
selected.

The first eight icons are the shapes, that can be filled (or not) with a color (pointed with the magenta
arrow). They can also be filled with different patterns (hatches, pointed by the black arrow).
Thickness and type of lines have several options (pointed by the red arrow).
TOOLBARS
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The toolbars allow the customization of the drawings.
Left Side Toolbars - 1

Arrow – Move / Resize / Select Tool: This tool is used to:
=> Move: point the entire object / shape in order to select it => move it manually to a different location.
=> Resize: point a corner of the object / shape in order to select it => drag the point to the new position
in order to edit the object.
=> Select: used to select elements => pointing the entire object / shape => or pointing a corner of the
object / shape (fillet / chamfer) => or in edit by points mode, pointing one or several segments.
Resize segment (arrow with the # sign): Select the tool => select a ceiling => use edit by points mode =>
select a segment => write the new length => OK.
Rotate: this tool is used to rotate a shape. Select the desired element => double click the rotate icon (or
use Main Menu => Edit => Rotate) => write the desired angle and sign => the (-) sign rotates clockwise and
the (+) sign or no sign rotates counterclockwise. Also, by clicking the rotate icon once, the cursor appears
as a rotate symbol => select a point (handle) and rotate the object manually.
Skew: this tool is used to obliquely distort a shape. The distortion can be horizontal or vertical. Select the
desired element => double click the skew icon => write the distance in the desired direction.
Trim: this option “cuts” a segment. Use edit by points mode => select the segment => apply the trim tool
(scissors) +. The segment will be divided and the two parts can be separated.
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Left Side Toolbars – 2 – Fillet and Chamfer Tools

These tools chamfers or fillet corners. Select the desired tool and apply on any standard corner on the
perimeter and drag to the interior of the shape. In order to use these tools, the shapes must be edited by
points.
Left Side Toolbars - 3

Resize selected: activates the resize menu. This feature allows the setting of the exact dimensions (X-Axis
or Y- Axis) or the percentage of the object as well as the reference point of the dimension.
Adjust curve: this setting adjusts the tension of the curve. The curve tension can be adjusted for all the
segments or just for one segment, depending of the necessities or the type of Edit Level.
Zoom: by clicking the Zoom tool (magnifier icon) and keeping the left button down, you can increase or
decrease the distance to the object. By dragging it to the right, you will decrease the distance, therefore
you can get a closer look at the object (Zoom In). By dragging it to the left, you will increase the distance,
therefore you can get a distant look at the object (Zoom Out).
Pan: : by clicking the Pan tool (hand icon) and keeping the left button down, you will be able to drag the
screen and move around in the workspace following the desired direction as you move the ”hand”.
Left Side Toolbars - 4

This toolbar offers multiple options to add text (straight or angled) as well as the Leader Dimension Tool.
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Left Side Toolbars – 5 – Grid Settings

Toggle Snap to Grid (the tool toggles between the options): this tool activates / deactivates the Snap to
Grid feature

Defining Snap to Grid and Nudge: in the Punch! Software (R) programs, a snap to grid means
the fast jump between two grids using the arrow keys in the keyboard. Therefore, if the grids’ distance is
12” and the snap to grid feature is activated, each click on the arrow keys will move a point 12”. If the
snap to grid feature is not activated, each movement is a nudge.
The snap movements are commanded only withe arrow keys. The Nudge movements are commanded
with the arrow keys as well as using the following commands in the Main menu=> Edit => Nudge => Up /
Down / Left / Right. The settings of the distance between the grids and the nudge distance are defined in
the Grid Properties Menu.
Toggle Visible Grid: toggles on / off the grid visibility.
Grid Properties: activates the Grid Properties menu. The grid is an interface option. It presents a
background with lines or points that can be used as a drawing guide. The type of grid is defined in the Grid
Style section, as shown in the image below. The space between the lines or points is defined in the Grid
Spacing section. The Snap Grid defines the interval in the movements using the arrows of the keyboard.

Bottom Toolbar
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Starting point of a drawing (the tool toggles between the options): in order to draw a shape (rectangle,
circle, etc.) we can start from a corner or from the center. Each option is useful in different situations. For
example, the drawing from center option is a good solution when we need to draw concentric objects.
Edit Level: the shapes can be edited as object or by points. As object means that the shape is constrained,
so the size can be changed but not the shape. By points means that each handle (point) can be moved
separately, modifying size and shape.
Draw Parallel (On / Off): toggles on or off the drawing of a parallel line in the shape’s perimeter.

The parallel menu (Options Menu) allows the customization of this feature, setting the parallel line
position (inside, outside or center), the parallel width and the option of group both lines

The commands at the bottom of the screen inform the position of the elements, scale and allow the
rotation of the elements (outlined in blue) and to set the zoom (outlined in green)
Add / Delete Points (Top Bar)

SYMBOL EDITOR POWER TOOL

- 530 -

Add / Delete Points: extra points can be added or superfluous points can be deleted by using these tools.
For these tools, the Edit Level must be by points
Right Side Toolbars - 1

Snap Tools: This bar provides an array of tools that allow more precision in the drawing. For example, the
8th tool snaps to the center of a segment.
Right Side Toolbars - 2

Group / Ungroup: the group tool assembles the selected parts, creating a new object.
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Lock / Unlock: the lock tool freezes the objects properties and makes the object immovable regarding its
position in the Workspace. By selecting one or more objects / shapes and clicking on the lock tool, the
elements will become “frozen”. By selecting the locked objects and clicking the on the unlock tool, the
objects return to their normal properties.
Join / Unjoin Selected: this tool groups or ungroups the selected.
Bring to Front / Send to Back: selects the relative position of one element referred to the remaining
elements
Right Side Toolbars - 3

Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.

Mirroring an object: mirroring an object or shape means duplicating the object symmetrically
(horizontally or vertically) as a mirror reflection. Note that in this option, the original object or shape
remains.
Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.

Flipping an object: flipping an object or shape means turning the object symmetrically
(horizontally or vertically) as a mirror reflection. In this option, the original object or shape is deleted.
Symbol Bar (up right corner)

Saves the Symbol to the Symbol Libraries.
THE MAIN MENU
File Menu
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Open Symbol: the symbols developed with the Symbol Editor Power Tool (PSY files) can be opened to be
used or edited.
Save As: the details developed with this power tool can be saved as PSY files for future use or edition.
Import / Export DXF / DWG files: these types of files are the most used for CAD programs. There are many
websites that offer free CAD symbols and details. Using this function, these files can be imported into this
tool to be used in the program or exported to other CAD programs. The files must be in DXF / DWG format.
Up to version 2018..
Printer Setup / Print: setting according with your printer or PDF Editor.

Go To: find more Information about Importing DXF / DWG files
Edit Menu
Undo: reverses the last X actions (X is the number of instances).
Redo: reverses the undo command.
Cut: cuts the selected elements.
Copy: copies the selected elements.
Paste: pastes the elements previously copied or cut.
Clear: deletes the selected elements.
Select All: selects all the elements in the workspace.
Hide Detection / Detect All: by selecting an object or a part of it and clicking on the hide detection tool
the elements can’t be selected. The remaining elements and points can’t be selected and modified.
Duplicate: creates a copy of the selected elements, using the parameters of the Duplicate Offsets.
Duplicate Offsets: opens the Duplicate Offsets menu to set the offset distance and number of copies.

Nudge: if the snaps are deactivated, use this command for movements
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Move: allows the movement of the elements an exact distance
Rotate: activates the Rotate tool
Project Menu
Drawing scale: if the drawing is a real constructive detail or a piece of equipment or furniture, then the
drawing must follow the same scale of the plan in the main program. A very common scale (default in the
main program) is 0.25”= 1’ => this means that a line with 0.25” is equivalent to one ft. in real life.
Paper Size: settings of the paper size (note: for printing within this power tool.
Grid: management of the Grid Settings.
Align to Grid: using this tool, the objects can be aligned to the closer gridline, in the desired direction.
Background color: general color of the workspace.
Drawing color: opens the palette in order to define the color for the lines and fills.

Grid color: color of the gridlines.
Axis Color: color of the X and Y axis (if selected).
Draw Axis (On / Off): visibility of the X and Y axis (left and bottom of the workspace).
Draw Page Breaks: shows the pages layout according with the selected paper size.
Move Origin: moves a numeric distance the origin of the workspace.
Arrange Menu
Bring to Front / Send to Back: selects the relative position of one element referred to the remaining
elements
Mirror: by selecting a shape and clicking on one of the mirror options, the object will be duplicated in the
selected direction.
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Flip: by selecting a shape and clicking on one of the flip options, the object will be reversed in the selected
direction.
Group / Ungroup: the group tool assembles the selected parts, creating a new object.
Lock / Unlock: the lock tool freezes the objects properties and makes the object immovable regarding its
position in the Workspace. By selecting one or more objects / shapes and clicking on the lock tool, the
elements will become “frozen”. By selecting the locked objects and clicking the on the unlock tool, the
objects return to their normal properties.
Join / Unjoin Selected: this tool groups or ungroups the selected.
Options Menu
Pen: setting of the options for lines: Color. Type and Thickness, as shown in the Drawing Elements.
Parallel: opens the Parallel Menu.
Draw Parallel: (On / Off): toggles on or off the drawing of a parallel line in the shape’s perimeter.
Draw from Center: draws the shape from center.
Open Selected / Close Selected: by selecting a segment and using the “open selected” option the selected
segment can be detached and the polygon can opened. By selecting the “close selected” option the points
are reattached and they conform a close polygon.

Curve Smoothing: adjust curvature.
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Scale Selection: opens the scale / resize menu. This feature allows the setting of the exact dimensions (XAxis or Y- Axis) or the percentage of the object as well as the reference point of the dimension.

Precision: this option opens a menu that allows the selection of a new precision setting within the
measurement units (English or Metric).
Point Selection / Object Selection: setting of the Edit Level.
Preferences: choice of the working settings.

RIGHT CLICKING
By right clicking on a shape or segment, the selected element can be edited.
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The Estimator Power Tool generates a Bill of Materials (BOM) based on the building developed in the
main program.

Question for this issue
Q: What is the meaning of BOM?
A: BOM mean Bill of Materials. In a building, a BOM is the list of the not processed materials that is
necessary for the construction. If the BOM includes the prices, it becomes a budget

Important: the BOM is created by compiling the lengths, areas and volumes of the different
materials set in the main program and the power tool’s preferences. Therefore, in order to create an
effective BOM, follow these steps:
Main program: define the structure of the walls, roofs, floors, etc. Set the correct sections and thickness
for joists, rafters, studs, blocks, slabs, etc. Keep in mind that the BOM will be reflecting these choices and
settings
Main program: the Estimator Power Tool compiles your settings, but it doesn’t convert objects. For
example: in your floor plan, you added a custom column created with the 3D Workshop Power Tool. In
the plan and live view, it looks like a column, but in the Estimator it won’t be included as a structure, but
as an object. Therefore, although you can add the price of the custom column in the Estimator, it is a good
policy to add a column in the Framing Tab (Main Program)

Go To: find more Information about structural settings

SETUP OPTIONS / PREFERENCES
The initial settings’ menu determines the quantification of the different items of the BOM by defining the
lengths, exclusions and inclusions. The roof can be quantified by pre-determined squares (On) or by area
(Off)
PC versions
In the PC versions of the program, the Setup options menu starts as we open the program. In addition,
this menu can be opened also using Options => Setup Options in the Main Menu of the tool.
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THE TABS
The Estimator’s tabs are the tabs ‘names of the Main Program. So the BOM can be visualized by the full
project, by tab or by room.

The tabs are on the screen or the desired tab can be set using View => Estimates (Main menu – PC version)
or using BOM => Work on Schedule
ADDING PRICES
The prices must be added manually. The price list is located in View => Plan cost list.
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These prices can be edited, the Estimate can be updated and the list saved as Master.
ADDITIONAL FEATURES
The finished BOM or budget can be exported using different formats as well as printed.
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Usually, the users of the program ask me for tips and advice. Most of my answers are here, but if you feel
that you need to ask more questions, the Punch Software Community Forum is a great place to ask these
questions and share information about the programs.
Punch! Software (R), as any program, has a learning curve. The best way to learn the program, is practice
+ practice + practice. Check for solutions and answers in this e-book and try to create elements not related
with your project, so you will become familiar with the commands and how to develop the different
elements.
Feel free to browse my website www.punchhelpers.com, check all the galleries, services, advice, etc.
Also, my Facebook page includes news, tips and links for free resources.
If you need help with your design, styles, dimensions, etc. check my new eBook “Designing your Dream
Home Using Punch Software (R)”. This eBook is the answer to the countless questions that home owners
find themselves asking during the design of their projects. This new eBook is the perfect companion to my
Training eBooks.
I am planning new e-books and resources. Of course, if you have ideas or you think that “something is
missing” in the e-books, I’d like to hear from you: just email me!
If you enjoyed this book, a review to that effect would be greatly appreciated.
Patricia Gamburgo
punchhelpers@punchhelpers.com
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